SOLIDWORKS 설치 및 관리

이 안내서는 개별 설치와 여러 시트 설치 모두에 대한 SOLIDWORKS 제품 설치, 사용권 발급, 업그레이드에 대한 내용을 설명합니다.

개별 설치 | 여러 시트 배포
설치 하나 또는 몇 개의 컴퓨터에 설치. | 설치 많은 수의 클라이언트 컴퓨터에 배포되는 관리자 이미지 작성.
사용권 발급 사용권 활성 또는 네트워크 사용권 발급. | 사용권 발급 사용권 활성 또는 네트워크 사용권 발급.
업그레이드 개별 설치를 새 릴리즈로 업그레이드. | 업그레이드 다른 컴퓨터에서의 설치에 사용된 관리 이미지를 업데이트하여 여러 컴퓨터를 새 릴리즈로 이동.
관리 설치의 수정, 복구, 제거, 새 릴리즈로 업그레이드. | 관리 관리 이미지 및 클라이언트 업그레이드, 네트워크 사용권 발급 관리, Workgroup PDM 볼트 관리.

SOLIDWORKS 설치 관리자를 사용하여 SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, Workgroup PDM, SOLIDWORKS PDM 및 SOLIDWORKS SolidNetWork License Manager를 포함한 SOLIDWORKS 제품 구성 요소에 대한 설정을 구성할 수 있습니다.

SOLIDWORKS Workgroup PDM 지원은 SOLIDWORKS 2017 이후로 종료됩니다. 이미 SOLIDWORKS Workgroup PDM을 사용 중인 고객은 계속 설치를 할 수 있지만 파일 볼트를 SOLIDWORKS PDM 서버로 마이그레이션하는 계획을 수립하기 시작해야 합니다.

SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.

목차

  • 개별 설치 또는 관리 이미지

    컴퓨터에 개별적으로 SOLIDWORKS 제품을 설치해야 합니까? 혹은 관리 이미지를 작성해 하나의 명령으로 모든 클라이언트에 설치를 배포해야 합니까?

  • SOLIDWORKS 설치 시작

    로컬 컴퓨터에서 DVD를 로딩하거나 공유 설치 디렉터리를 액세스하거나 SOLIDWORKS에서 다운로드하여 SOLIDWORKS 설치를 시작할 수 있습니다.

  • SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁

    Windows 8(및 이상 버전)의 사용자 인터페이스는 Windows 이전 버전과는 많이 다릅니다. 탐색 방법이 다를 뿐 아니라 주요 명령에 액세스하는 방법도 몇 가지 추가되었습니다.


개별 설치 또는 관리 이미지

컴퓨터에 개별적으로 SOLIDWORKS 제품을 설치해야 합니까? 혹은 관리 이미지를 작성해 하나의 명령으로 모든 클라이언트에 설치를 배포해야 합니까?

한 컴퓨터에만 설치할 경우이거나 여러 대의 컴퓨터를 관리하는 경우, 선택은 명백합니다. 그렇지 않은 경우, 다음 비교를 참고하십시오.

개별 설치 | 관리 이미지
사용자가 SOLIDWORKS 관리를 직접할 수 있습니다. | 시스템 관리자가 옵션 편집기를 사용하고 다음과 같은 설치 옵션을 정해서 여러 설치를 사용자 정의할 수 있습니다 : 새 설치 만들기, 기존 설치 업데이트하기, 관리 사용자로 설치 실행하기, 설치 전후에 외부 명령 실행하기, 다른 제품 그루핑 등.
컴퓨터는 설치 작업을 하는 사람이 물리적으로 직접 액세스 할 수 있어야 합니다. | 클라이언트 컴퓨터를 같은 네트워크에서 액세스 할 수 있다면 멀리 위치해 있을 수 있습니다.
개별 설정으로 다른 버전, 서비스 팩이나 제품을 다른 컴퓨터에 설치할 수 있습니다. | 옵션 편집자를 사용하면 관리 이미지가 여러 설치의 버전, 서비스 팩, 제품, 설정간의 일관성을 유지할 수 있습니다.
컴퓨터에서 네트워크나 전자메일에 액세스가 가능해야 합니다. 네트워크 또는 전자메일 연결은 SOLIDWORKS를 활성화하고 파일을 다운로드하는 데 필요합니다. 네트워크 액세스는 네트워크 사용권 서버에서 사용권을 수집할 때도 필요합니다. | 로컬 네트워크 연결이 응용 프로그램 배포에 필요합니다; 미디어 드라이브가 클라이언트 컴퓨터에 필요하지 않습니다. 클라이언트가 자동으로 업데이트 될 수 있습니다. 같은 관리자 이미지에서 배포된 모든 클라이언트에 같은 서비스 팩이 적용됩니다. 여러 버전을 관리 유지하기 위해 여러 개의 관리 이미지를 작성할 수 있습니다. 사용권 활성을 자동화 할 수 있습니다. 관리자 이미지는 서버에서 추가 디스크 공간을 필요로 하고, 클라이언트는 개별 설치와 같은 공간이 필요합니다.
상위 주제
SOLIDWORKS 설치 및 관리
관련 개념
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁
관련 태스크
SOLIDWORKS 설치 시작


SOLIDWORKS 설치 시작

로컬 컴퓨터에서 DVD를 로딩하거나 공유 설치 디렉터리를 액세스하거나 SOLIDWORKS에서 다운로드하여 SOLIDWORKS 설치를 시작할 수 있습니다.

SOLIDWORKS 설치를 시작하려면 다음 중 하나를 선택해서 실행합니다.

  • 디스크를 사용해서 로컬 컴퓨터에 설치하려면, 컴퓨터의 디스크 드라이브에 해당 디스크를 삽입합니다.
  • 다운로드 디렉터리에서 설치하려면 디렉터리를 찾아 setup.exe를 더블클릭 합니다.
  • SOLIDWORKS에서 다운로드하여 설치하는 방법:
    1. SOLIDWORKS 웹 사이트를 찾아갑니다.
    2. 가입 서비스 고객으로 사용자의 전자우편과 암호를 사용하거나 사용자의 제품 번호로 로그인합니다.
    3. Self Service 아래의 Download Software and Updates를 클릭합니다.
    4. Download Software(Windows, Mac, Linux)에서 다운로드할 SolidWorks 버전과 서비스 팩을 선택합니다.
상위 주제
SOLIDWORKS 설치 및 관리
관련 개념
개별 설치 또는 관리 이미지
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁


SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁

Windows 8(및 이상 버전)의 사용자 인터페이스는 Windows 이전 버전과는 많이 다릅니다. 탐색 방법이 다를 뿐 아니라 주요 명령에 액세스하는 방법도 몇 가지 추가되었습니다.

다음 도움말에서는 Windows 8에서 가장 기본적인 세 가지 기능에 액세스하는 방법을 설명합니다. Windows 8을 사용하여 SOLIDWORKS를 설치할 때 이 도움말을 참조하십시오.
이러한 단계는 사용자 Windows 시스템이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 특히 Windows 8보다 최신 버전에 대한 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.
상위 주제
SOLIDWORKS 설치 및 관리
관련 개념
개별 설치 또는 관리 이미지
개별 컴퓨터에 설치
관련 태스크
SOLIDWORKS 설치 시작

SOLIDWORKS를 시작하는 중

Windows 8 참 바에서 SOLIDWORKS를 시작하고 바탕 화면에 고정할 수 있습니다.

참 바에서 SOLIDWORKS에 액세스하는 방법:

  1. 시작 화면에서 화면의 오른쪽 하단 코너를 클릭합니다.

    참 바가 화면의 오른쪽에 표시됩니다.

    Windows 로고+C를 눌러 참 바에 액세스할 수도 있습니다.

  2. 검색 아이콘을 누르거나 클릭합니다.
  3. 검색 상자에 SOLIDWORKS를 입력하고 아래로 밀거나 SOLIDWORKS 타일을 누릅니다.
SOLIDWORKS 타일을 오른쪽 클릭한 후 화면 하단에 표시되는 도구 모음에서 시작 화면에 고정 클릭하여 SOLIDWORKS를 바탕 화면에 고정할 수 있습니다.

제어판에 액세스하기

제어판에 액세스하는 방법:

  1. 시작 화면에서 화면의 오른쪽부터 밀거나 마우스를 화면의 오른쪽 상단 코너로 끌어서 놓습니다.

    참 바가 화면의 오른쪽에 표시됩니다.

  2. 검색 아이콘을 누르거나 클릭합니다.
  3. 검색 상자에 제어판을 입력합니다.
  4. 프로그램 화면의 왼쪽에 나타나는 제어판 타일을 클릭합니다.

명령 프롬프트에 액세스하기

명령 프롬프트에 액세스하는 방법:

  1. 시작 화면에서 오른쪽 클릭하여 화면 하단에 도구 모음을 표시합니다.
  2. 도구 모음의 오른쪽에 있는 모든 프로그램을 클릭합니다.
  3. 프로그램 화면 오른쪽의 Windows 시스템에서 명령 프롬프트를 누르거나 클릭합니다.

유용한 바로가기

다음 목록에는 유용한 키보드 바로가기가 나와 있습니다.

Alt+Tab | 데스크탑에서 실행 중인 여러 응용 프로그램 사이를 전환합니다.
Windows 로고 키+Q | 프로그램 목록 및 검색 창을 엽니다.
Windows 로고 키+R | 실행 대화 상자를 엽니다.
Windows 로고 키+I | 설정 창을 엽니다.
키보드 바로가기에 대한 자세한 내용은 Microsoft Windows 문서를 참고하십시오.


개별 설치

목차

  • 개별 컴퓨터에 설치

    몇 가지 설치 방법을 사용하여 개별 컴퓨터에 SOLIDWORKS를 설치할 수 있습니다.

  • 개별 설치 관리

    대개, 개별 설치 관리는 설치 수정, 복구, 제거, 업그레이드로 이루어집니다.


개별 컴퓨터에 설치

몇 가지 설치 방법을 사용하여 개별 컴퓨터에 SOLIDWORKS를 설치할 수 있습니다.

SOLIDWORKS 설치 관리자는 구입한 제품에 대한 설치에 맞게 설치를 수행합니다. 설치를 시작하기 전:

  • SOLIDWORKS 제품 번호를 준비해 놓습니다.
  • 인터넷 연결을 확인합니다. 연결은 권한을 확인하는 데 필요합니다.

SOLIDWORKS 설치 관리자는 Microsoft Windows Installer, Office Web Components, Microsoft Visual Studio Tools for Applications, Visual Basic, .NET Framework 등의 다양한 Microsoft 구성 요소를 필요로 합니다. 올바른 버전의 모든 필요한 Windows 구성 요소가 설치되어 있지 않을 경우 SOLIDWORKS 설치 관리자는 SOLIDWORKS 제품을 설치하기 전에 해당 구성 요소를 자동으로 설치합니다. Windows용 Bonjour 서비스도 필수 구성 요소입니다.

Windows 8을 실행 중인 경우 시작 또는 제어판에 액세스하는 등의 작업은 SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁을(를) 참조하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 특히 Windows 8 이상 버전을 사용하고 있는 시스템에 대한 자세한 설명과 옵션을 보려면 Microsoft Windows 문서를 참고하십시오.
설치 방법 | 절차 요약
SOLIDWORKS 설치 매체 사용하기 | DVD 디스크를 컴퓨터 디스크 드라이브에 삽입합니다.
서버에서 다운로드 디렉터리 사용 다운로드 디렉터리에서 setup.exe을 더블 클릭합니다.

다운로드 디렉터리는 SOLIDWORKS 제품을 설치하는 컴퓨터에서 액세스할 수 있어야 하고 설치를 시작하기 전에 모든 SOLIDWORKS 설치 파일이 포함되어 있어야 합니다. 사용자 컴퓨터가 인터넷에 연결되어 있고 다운로드 디렉터리에 대한 쓰기 권한이 있을 경우 SOLIDWORKS 설치 관리자가 누락된 파일을 찾는 과정을 도와줍니다.

업데이트 확인을(를) 사용하여 기존 SOLIDWORKS 설치 업데이트하기 다음 중 하나를 수행합니다.
  • SOLIDWORKS에서 도움말 > 업데이트 확인을(를) 클릭합니다.
  • Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인를 클릭합니다.
인터넷이 연결되어 있어야 합니다.

Workgroup PDM 클라이언트는 볼트 업데이트를 자동으로 감지합니다. 클라이언트를 업데이트 하기 위해 서비스 팩을 다운로드할 필요는 없습니다. 자세한 내용은 Workgroup PDM 온라인 도움말에서 클라이언트 업데이트를 참고합니다.

SOLIDWORKS 사용자 웹 사이트에서 다운로드하기
  1. SOLIDWORKS 웹 사이트를 찾아갑니다.
  2. 가입 서비스 고객으로서 사용자의 이메일과 암호를 사용하거나 사용자의 제품 번호로 로그인합니다.
  3. Self Service에서 Download Software and Updates을 클릭합니다.
  4. Download Software에서 설치하려는 SOLIDWORKS 버전을 클릭합니다.
인터넷이 연결되어 있어야 합니다.

Customer Portal 사이트에 로그인 권한이 있는 서브스크립션 서비스 고객이어야 합니다.

설치가 완료되면, SOLIDWORKS 응용 프로그램을 시작하고 사용권을 활성화을(를) 활성화합니다.

컴퓨터에 설치된 제품 목록을 보려면 SOLIDWORKS 주 메뉴에서 도움말 > My Products를 클릭합니다. My Products는 현재 사용 가능한 모든 SOLIDWORKS 제품을 표시합니다. 체크 표시는 활성화 및 네트워크 사용권을 기반으로 사용자 또는 사용자의 조직에서 현재 보유한 제품을 나타냅니다.
상위 주제
개별 설치
관련 개념
개별 설치 관리
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁


개별 설치 관리

대개, 개별 설치 관리는 설치 수정, 복구, 제거, 업그레이드로 이루어집니다.

목차

  • 설치 수정

    모든 설치 파일을 사용하여 이전 설치를 완료했다면 설치를 수정하여 설치되지 않은 제품을 설치하거나 제품을 제거할 수 있습니다. 이 옵션은 서비스 팩으로 이전 버전을 업그레이드한 경우 사용할 수 없습니다.

  • 설치 복구

    설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

  • 개별 설치를 이전 서비스 팩으로 롤백

  • 설치 제거

    개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

  • 새 릴리즈로 업그레이드

    개별 설치를 SOLIDWORKS 새 릴리즈로 업그레이드하는 방법은 몇 가지가 있습니다.

  • 제품 공존 규칙

    새 제품의 설치와 기존 제품의 업그레이드 시 공존 규칙은 다음과 같습니다.

상위 주제
개별 설치
관련 개념
개별 컴퓨터에 설치


설치 수정

모든 설치 파일을 사용하여 이전 설치를 완료했다면 설치를 수정하여 설치되지 않은 제품을 설치하거나 제품을 제거할 수 있습니다. 이 옵션은 서비스 팩으로 이전 버전을 업그레이드한 경우 사용할 수 없습니다.

SOLIDWORKS를 이미 설치한 후 나중에 애드인 제품을 추가로 구입한 경우, 설치를 수정해서 새 애드인을 포함할 수 있습니다. 개별 컴퓨터 각각에 애드인을 설치해야 합니다.

SOLIDWORKS 패키지 원본을 수정해서 SOLIDWORKS Professional이나 SOLIDWORKS Premium를 포함하는 경우, Workgroup PDM은 설치되지 않습니다.
  1. 작업 중인 SOLIDWORKS 세션이 없는지 확인합니다.
  2. Windows 7 이상에서는 시작 > 제어판 >프로그램 추가/제거을(를) 클릭합니다.
  3. 수정할 SOLIDWORKS 설치를 선택한 후 변경을(를) 클릭합니다.
  4. SOLIDWORKS 설치 관리자 시작 페이지 화면에서 (현재 컴퓨터의) 개별설치 수정을(를) 클릭합니다.
  5. 제품 번호 화면에서 적합한 제품 번호가 지정되었는지 확인합니다.
  6. 제품 선택 화면에서 설치하거나 제거할 제품을 선택합니다.

    설치를 수정하는 경우,

    • 새 제품 번호를 지정하더라도 기본적으로 설치되거나 제거된 제품이 없습니다. 반드시 각 제품이나 구성 요소 설치 작업을 변경시켜야 합니다.
    • 특정 구성 요소에 대해 적용되는 작업을 보려면 확인란이 아닌, 구성 요소 이름을 클릭합니다. 계획된 설치 작업이 제품 목록 아래 정보 필드에 나타납니다.
    • 제품 구성 요소 옆에 있는 확인란을 클릭하여 해당 구성 요소에 대한 설치 작업을 변경할 수 있습니다. (예를 들어, 구성 요소를 설치하거나 제거할 경우 해당 확인란을 선택하면 구성 요소가 설치되거나 제거되도록 지정되고 확인란을 선택 취소하면 구성 요소가 설치되거나 제거되지 않도록 지정됩니다.)
    • 최초 스팩에서 구성 요소 설치 작업을 변경하면 목록에서 해당 구성 요소 옆에 별표(*)가 나타납니다.
    • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
    • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.

  7. 요약 화면에서 지금 수정을(를) 클릭합니다.
  8. 설치 완료 화면에서 마침을(를) 클릭합니다.
상위 주제
개별 설치 관리
관련 개념
새 릴리즈로 업그레이드
제품 공존 규칙
관련 태스크
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거


설치 복구

설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

하지만, 설치를 복구하려면 원해 설치되었던 컴퓨터 위치에 이전 설치의 모든 소스 파일과 적용되었던 서비스 팩이 있어야 합니다.

개별 설치를 복구할 수 있습니다. 관리 이미지를 수정할 수 없습니다; 반드시 관리 이미지를 설치해제 한 다음 재설치합니다.
  1. Windows 7 이상에서 시작 > 제어판 > 프로그램 > 프로그램 및 기능을 클릭합니다.
  2. 복구하려는 SOLIDWORKS 버전을 선택하고 변경을(를) 클릭합니다.
  3. SOLIDWORKS 설치 관리자 시작 화면에서 를 클릭합니다.을(를) 클릭합니다.
  4. 복구할 제품 화면에서 복구할 제품을 선택합니다.
  5. 화면에서 나머지 제품은 선택 취소합니다.
  6. 복구를 클릭합니다.
상위 주제
개별 설치 관리
상위 주제
설치 오류/취소된 설치
관련 개념
새 릴리즈로 업그레이드
제품 공존 규칙
관련 태스크
설치 수정
개별 설치를 이전 서비스 팩으로 롤백
설치 제거
실패하거나 취소된 설치 복구
SOLIDWORKS 리셀러에 문의


개별 설치를 이전 서비스 팩으로 롤백

개별 설치를 현재 주요 버전 제품군의 이전 서비스 팩으로 롤백하려면 컴퓨터에 현재 설치된 서비스 팩을 제거한 후 이전 버전을 다시 설치합니다.
상위 주제
개별 설치 관리
관련 개념
새 릴리즈로 업그레이드
제품 공존 규칙
관련 태스크
설치 수정
설치 복구
설치 제거


설치 제거

개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

  1. 작업 중인 SOLIDWORKS 세션이 없는지 확인합니다.
  2. SOLIDWORKS 사용권을 다른 컴퓨터로 이전하려면, 이 컴퓨터에 있는 SOLIDWORKS 설치를 제거하기 이전에 사용권을 이전하시기 바랍니다.

    자세한 내용은 사용권 이전을 참조하십시오.

  3. Windows 7 이상에서는 제어판 > 프로그램 및 기능을 실행합니다.
  4. 제거할 제품 구성 요소를 선택합니다.

    경우에 따라 특정 주요 릴리즈 버전에 대해 여러 개의 SOLIDWORKS 서비스 팩이 있습니다. SOLIDWORKS 주요 릴리즈를 제거하려면 해당 주요 릴리즈에 대한 모든 서비스 팩 요소를 제거합니다.

  5. 제거 화면에서 다음을 수행합니다.
    1. 제거할 제품을 선택합니다. 기본적으로 모든 구성 요소가 선택됩니다.
    2. 제거하지 않으려는 제품은 선택 취소합니다.
    3. 사용자 정의 제거를 수행할지 또는 전체 제거를 수행할지 선택합니다. 기본적으로 SOLIDWORKS 설치 관리자는 표준 제거를 수행하고 프로그램 파일 및 폴더를 제거합니다.

      1. 고급 옵션에서 변경을 클릭합니다.

        고급 옵션 화면이 나타나고 프로그램 파일 및 폴더 옵션이 선택됩니다.

      2. 사용자 정의 제거를 수행하려면 하나 이상의 옵션을 선택하고, 전체 제거를 수행하려면 모든 옵션을 선택합니다.
      3. 요약으로 돌아가기를 클릭합니다.
      4. 요약 화면에서 고급 옵션을 확장하여 제거 방법 및 항목을 표시합니다.

    4. 항목 제거를 클릭합니다.
상위 주제
개별 설치 관리
상위 주제
여러 시트 설치 관리
관련 개념
새 릴리즈로 업그레이드
제품 공존 규칙
관리 이미지를 새 버전으로 업그레이드
서비스 팩 제품 업데이트 관리
관련 태스크
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
사용권 이전


새 릴리즈로 업그레이드

개별 설치를 SOLIDWORKS 새 릴리즈로 업그레이드하는 방법은 몇 가지가 있습니다.

다음 경우 새 릴리즈로 업그레이드할 수 있습니다.
  • 새 설치 매체 수령
  • SOLIDWORKS 시작 시 업그레이드 알림 메시지를 받은 경우
  • 직접 업데이트 확인
  • SOLIDWORKS 설치 관리자의 새 인스턴스를 시작하는 경우

새 주요 릴리즈를 설치하면 이전에 설치된 주요 릴리즈를 업그레이드하거나 새 릴리즈를 한 곳에 같이 설치할 수 있습니다. 이전에 설치된 주요 릴리즈에 대한 서비스 팩 릴리즈를 설치하는 경우 해당 릴리즈가 자동으로 업데이트됩니다.

상위 주제
개별 설치 관리
관련 개념
제품 공존 규칙
관련 태스크
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거

직접 업데이트 확인

현재 설치된 SOLIDWORKS 릴리즈의 업데이트를 다음 방법 중 하나를 사용하여 확인할 수 있습니다.

  • SOLIDWORKS에서 도움말 > 업데이트 확인을 클릭합니다.
  • Microsoft Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.

Workgroup PDM 클라이언트 업그레이드

볼트를 업데이트한 후 처음으로 로그인할 때 클라이언트에게 업데이트를 알리는 메시지가 나타납니다. 클라이언트 업데이트에 서비스 팩은 필요하지 않습니다.

볼트와 비교한 클라이언트 상태 | 작업
볼트와 동일한 버전 | 없음
같은 주요 릴리즈, 볼트보다 최신 버전 | 없음
최신의 주요 릴리즈, 볼트보다 최신 버전 | 로그인이 차단됨
같은 주요 릴리즈, 볼트보다 이전 버전 | 선택적인 업그레이드
이전 주요 릴리즈, 볼트보다 이전 버전 | 업데이트 필요

자세한 내용은 Workgroup PDM 도움말에서 클라이언트 업데이트를 참고합니다.

업그레이드 주의사항

다른 주요 버전으로 여러 번 설치된 제품에는 항상 주요 업그레이드 또는 한번의 작업으로 주요 버전으로 업그레이드를 하는 기능이 지원되지 않습니다.

이 경우, SOLIDWORKS 설치 관리자가 새 버전을 먼저 설치한 다음 오래된 버전을 제거해서 업그레이드합니다. 이때 다른 제품과는 달리, 주요 SOLIDWORKS 제품은 주요 업그레이드를 지원합니다.

결과는 다음과 같습니다.
  • 주요 버전 간 SOLIDWORKS 제품을 업그레이드하는 경우:
    • 사용자의 기존 설치 위치가 변경되지 않습니다.
    • 업그레이드 중 오류가 있거나 취소할 경우 업그레이드를 되돌릴 수 있습니다.
  • 다른 제품이 주요 버전 간 업그레이드 될 경우:
    • 각 제품이 새 위치에 새 제품으로 먼저 설치된 다음, 원래 설치가 제거됩니다.
    • 일단 시작되면, 업그레이드 중 오류가 있거나 취소할 경우 업그레이드를 되돌릴 수 없습니다.


제품 공존 규칙

새 제품의 설치와 기존 제품의 업그레이드 시 공존 규칙은 다음과 같습니다.

규칙 | 예
아래 언급한 제품을 제외하고 핵심 SOLIDWORKS 제품의 주요 릴리즈 버전 다수가 허용됩니다. | SOLIDWORKS 2015 SP3.0과 SOLIDWORKS 2016 SP0.0은 같은 컴퓨터에서 함께 사용할 수 있습니다.
같은 주요 릴리즈 버전의 서비스 팩 다수가 허용되지 않습니다. | SOLIDWORKS 2016 SP0.0과 2016 SP1.0은 같은 컴퓨터에서 함께 사용할 수 없습니다. SOLIDWORKS 2016 SP0.0이 이미 설치되어 있는 컴퓨터에 SOLIDWORKS 2016 SP1.0을 설치하는 경우 SOLIDWORKS 설치 관리자가 SP0.0을 SP1.0으로 바꿉니다.
컴퓨터에 한 버전만이 허용되는 제품:
  • Workgroup PDM Server
  • SolidNetWork License Manager
 이전 SOLIDWORKS의 주요 릴리즈가 컴퓨터에 남아 있더라도 SOLIDWORKS 2016 SP0.0이 설치되면 Workgroup PDM 서버가 2016 SP0.0으로 업그레이드됩니다.
컴퓨터에 한 버전만이 허용되는 제품:
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

SOLIDWORKS 2016 SP0.0 또는 SP1.0을 설치할 경우 SOLIDWORKS 2016 PDM Server 및 PDM Client도 업그레이드해야 합니다.

SOLIDWORKS 2016 PDM Server를 설치할 경우 PDM Server 설치 프로세스를 사용하여 SOLIDWORKS PDM Client를 설치해야 합니다. 클라이언트 설치 프로세스를 사용해 SOLIDWORKS PDM Client를 따로 설치하지 마십시오.

SOLIDWORKS PDM Client는 동일한 컴퓨터에서 SOLIDWORKS PDM Server와 같은 릴리즈 버전 및 서비스 팩이어야 합니다.

자세한 내용은 SLDIM을 사용한 PDM Server 설치 항목을 참조하십시오.

SOLIDWORKS의 주요 릴리즈 버전으로 포함된 제품의 한 버전만 설치할 수 있습니다. 그러나 SOLIDWORKS의 다른 주요 릴리즈 버전에서 포함된 제품의 버전을 함께 사용할 수 있습니다. | SOLIDWORKS 2016 SP0.0을 2016 SP1.0으로 업그레이드할 경우, SOLIDWORKS Explorer 2016 SP0.0이 2016 SP1.0으로 자동 업그레이드됩니다. 그러나 SOLIDWORKS Explorer 2015 SP4.0은 SOLIDWORKS Explorer 2016 SP0.0 또는 SOLIDWORKS Explorer 2016 SP1.0과 함께 사용할 수 있습니다.
동일한 컴퓨터에서 SOLIDWORKS의 주요 버전을 여러 개 실행하려면 관리 권한이 필요합니다.
상위 주제
개별 설치 관리
관련 개념
새 릴리즈로 업그레이드
관련 태스크
설치 수정
설치 복구
개별 설치를 이전 서비스 팩으로 롤백
설치 제거


여러 시트 설치

목차

  • 여러 클라이언트에 배포

    관리자 이미지를 작성한 다음, 설치를 클라이언트에 배포해서 여러 클라이언트에 SOLIDWORKS 제품을 설치할 수 있습니다.

  • 관리 이미지 사용

    관리 이미지를 사용하여 단일 네트워크 위치에서 SOLIDWORKS 제품의 설정 가능한 설치를 지원합니다.

  • 관리 이미지를 전자우편을 통해 클라이언트에 배포

    공유 관리 이미지 디렉터리를 작성한 후에는 전자우편으로 클라이언트에 통지할 수 있습니다.

  • 명령줄 배포

    명령 프롬프트 또는 배치 파일(자동 설치)을 사용하여 관리 이미지를 자동으로 배포할 수 있습니다.

  • 여러 시트 설치 관리

    여러 시트 설치 시의 관리 작업으로는 관리 이미지를 새 버전으로 업그레이드, 서비스 팩 업데이트 적용, 설치 제거 등이 있습니다.


여러 클라이언트에 배포

관리자 이미지를 작성한 다음, 설치를 클라이언트에 배포해서 여러 클라이언트에 SOLIDWORKS 제품을 설치할 수 있습니다.

여러 클라이언트에 배포하는 절차:
  1. 관리자 이미지를 작성합니다.
    • SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기
  2. 관리 이미지를 클라이언트에 배포합니다.
    • 관리 이미지를 전자우편을 통해 클라이언트에 배포
    • 명령줄을 사용하여 관리 이미지로부터 설치
  3. 사용권 절차를 구현합니다.
    • 개별 사용권 관리
    • SolidNetWork License Manager를 사용하여 사용권 관리
Windows 8을 실행하는 경우 시작 또는 제어판 액세스 등의 작업에 대해서는 SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁을 참조하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.
상위 주제
여러 시트 설치
관련 개념
관리 이미지 사용
관리 이미지를 전자우편을 통해 클라이언트에 배포
명령줄 배포
여러 시트 설치 관리
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁


관리 이미지 사용

관리 이미지를 사용하여 단일 네트워크 위치에서 SOLIDWORKS 제품의 설정 가능한 설치를 지원합니다.

클라이언트 컴퓨터를 포함한 네트워크 상의 컴퓨터로부터 관리 이미지를 설치할 수 있습니다.
  • 관리 이미지가 공유 폴더에 있어야 합니다.
  • 모든 제품을 포함시키면 관리 이미지 디스크 필수 공간이 7GB 이상이 될 수 있습니다.
  • 관리 이미지를 업그레이드할 때 공유이름을 업데이트하는 경우 응용 프로그램 시작시 클라이언트 업그레이드가 자동으로 이루어집니다. 자세한 사항은 관리 이미지에서 클라이언트를 업그레이드하기를 봅니다.
  • 클라이언트가 컴퓨터에 관리자 권한이 있어야 합니다. 클라이언트의 권한이 부족한 경우 다른 방법을 사용하여 이미지를 설치할 수 있습니다.

관리 이미지를 작성하고 나면 관리 이미지 옵션 편집기가 해당 이미지에서 사용자 및 그룹 설치에 대한 설치 옵션 설정을 관리할 수 있습니다. 자세한 내용은 관리 이미지 옵션 편집기를 참조하십시오.

목차

  • SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기

    여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터에 설치된 프로그램을 배포할 수 있습니다.

상위 주제
여러 시트 설치
관련 개념
여러 클라이언트에 배포
관리 이미지를 전자우편을 통해 클라이언트에 배포
명령줄 배포
여러 시트 설치 관리
관리 이미지에서 클라이언트 업그레이드
관리 이미지 옵션 편집기


SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기

여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터에 설치된 프로그램을 배포할 수 있습니다.

  1. SOLIDWORKS 설치 관리자를 시작합니다. SOLIDWORKS 설치 시작을 참조하십시오.
  2. 시작 화면에서 관리 이미지를 선택합니다.

    관리 이미지 작성 옵션이 나타납니다.

    옵션 | 설명
    기본 설정을 사용하여 새 이미지를 작성합니다. | 기본 구성 설정을 사용하여 관리 이미지를 작성합니다(즉, 사이트의 기존 관리 이미지에 대해 현재 지정된 설정을 기반으로 하는 것이 아님).
    기존 이미지의 설정과 파일을 사용하여 새 이미지를 작성합니다. | 사이트의 기존 관리 이미지에 지정된 구성 설정을 사용하여 이미지를 작성합니다. 찾아보기를 클릭하여 기존 관리 이미지의 설치 디렉터리를 지정합니다.
  3. 화면의 지시 사항에 따르십시오.

목차

  • 관리 이미지 옵션 편집기

    관리 이미지 옵션 편집기로 개별 컴퓨터와 컴퓨터 그룹의 관리 이미지 내 설치 변수 설정을 사용자 정의할 수 있습니다.

상위 주제
관리 이미지 사용
관련 태스크
SOLIDWORKS 설치 시작


관리 이미지 옵션 편집기

관리 이미지 옵션 편집기로 개별 컴퓨터와 컴퓨터 그룹의 관리 이미지 내 설치 변수 설정을 사용자 정의할 수 있습니다.

관리 이미지를 만들고 나면 SOLIDWORKS 설치 관리자가 옵션 편집기 시작 여부를 묻습니다. 관리 이미지 폴더에 있는 sldAdminOptionEditor.exe을(를) 더블 클릭하여 옵션 편집기를 시작할 수 있습니다.

컴퓨터 그룹이나 개별 컴퓨터에 다른 설치 구성을 지정하려면 옵션 편집기에서 컴퓨터 이름, IP 주소 또는 IP 주소 범위를 추가한 다음 이러한 컴퓨터의 설치 옵션을 지정합니다.

파일 또는 폴더 경로 메시지가 표시되는 모든 대화 상자에 선택된 폴더를 환경 변수에 지정할 수 있는 옵션이 포함됩니다. 예를 들어 C:\Program Files\SOLIDWORKS Corp를 선택할 경우 파일 경로는 %ProgramFiles%\SOLIDWORKS Corp에 매핑됩니다. 가장 일반적인 변수는 %ProgramFiles% 및 %SystemDrive%입니다.

모든 경로가 환경 변수로 변환될 수 있는 것은 아닙니다. 예를 들어 Z:\SOLIDWORKS Data는 적절한 환경 변수로 매핑될 수 없습니다.

목차

  • 그룹과 컴퓨터 추가 및 삭제

    관리 이미지 옵션 편집기로 컴퓨터 그룹과 개별 컴퓨터에 다른 설치 구성을 지정할 수 있습니다.

  • 옵션 설정 보기 및 편집하기

    SOLIDWORKS 관리 이미지 옵션 편집기를 사용하여 이미지에 대해 지정된 그룹과 컴퓨터의 옵션 설정을 보고 변경할 수 있습니다.

  • 옵션 편집기에서 설치 배포하기

    수동 또는 푸시 방식을 사용하여 옵션 편집기에서 직접 설치를 배포할 수 있습니다.

  • 옵션 편집기 종료

    확인 또는 닫기를 클릭하여 옵션 편집기를 종료할 수 있습니다.

  • 옵션 편집기에 대한 바탕 화면 바로 가기 만들기

    응용 프로그램 내의 특정 관리 이미지에 대한 옵션 편집기의 Windows 바탕 화면 바로 가기를 만들 수 있습니다.

상위 주제
SOLIDWORKS 설치 관리자로부터 관리 이미지 만들기


그룹과 컴퓨터 추가 및 삭제

관리 이미지 옵션 편집기로 컴퓨터 그룹과 개별 컴퓨터에 다른 설치 구성을 지정할 수 있습니다.

예를 들어, 이미지에서 사용 가능한 구성 요소의 특정 서브세트를 사용하고 다른 그룹에서는 제품 구성요소의 다른 서브세트를 사용하도록 여러 컴퓨터를 구성하려는 경우입니다. 하나의 관리 이미지를 사용하는 경우라도 옵션 편집기 그룹 설정을 사용하여 다른 제품 서브세트를 다른 컴퓨터 그룹에 설치할 수 있습니다.

그룹 추가 방법
  1. 전체 설정을 오른쪽 클릭한 후 그룹 추가를 클릭합니다.
  2. 그룹 이름을 입력합니다.

컴퓨터 추가하기:
  1. 기존 그룹이나 전체 설정을 오른쪽 클릭한 후 컴퓨터 추가를 클릭합니다.
    기존 그룹을 오른쪽 클릭하는 경우 컴퓨터가 그 그룹에 추가됩니다. 그렇지 않으면 최상위 레벨에 추가됩니다.
  2. 다음 중 하나를 클릭합니다.
    • 내 컴퓨터 이름을 선택하여 컴퓨터 이름을 하나 이상 입력합니다. 여러 대의 컴퓨터를 줄 바꿈, 빈칸, 탭, 쉼표, 마침표, 콜론, 세미콜론으로 구분할 수 있습니다. 외부 파일로부터 컴퓨터 이름 목록을 복사하고 붙여 넣을 수 있습니다. 컴퓨터 이름에 도메인 한정자가 포함되어서는 안됩니다. 예를 들어 pluto.solidworks.com은 타당치 않습니다.
    • IP 주소로를 선택하여 컴퓨터의 IP 주소를 입력합니다.
    • IP 주소 범위로를 선택하여 범위의 시작 IP 주소와 종료 IP 주소를 입력합니다.
    • 여러 대의 컴퓨터 추가를 클릭해서 네트워크로부터 컴퓨터를 선택합니다.

기존 컴퓨터를 그룹으로 이동하기:

컴퓨터를 그룹으로 끕니다.

그룹에서 컴퓨터 이동하기:

컴퓨터를 일반 설정이나 다른 그룹으로 끕니다.

그룹이나 컴퓨터 삭제하기:

그룹이나 컴퓨터를 오른쪽 클릭한 후 그룹 삭제나 컴퓨터 삭제를 클릭합니다.

그룹을 삭제할 경우 그 그룹안의 모든 컴퓨터가 삭제됩니다.

모든 그룹과 컴퓨터 삭제하기:

전체 설정을 오른쪽 클릭한 후 그룹 삭제를 클릭합니다.

상위 주제
관리 이미지 옵션 편집기
관련 개념
옵션 편집기에서 설치 배포하기
관련 태스크
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관련 참조
옵션 설정 보기 및 편집하기


옵션 설정 보기 및 편집하기

SOLIDWORKS 관리 이미지 옵션 편집기를 사용하여 이미지에 대해 지정된 그룹과 컴퓨터의 옵션 설정을 보고 변경할 수 있습니다.

  • 옵션 편집기를 처음 시작하면 옵션 설정이 읽기 전용 모드로 표시됩니다. 편집 아이콘이 음영 모드로 표시되어 있지 않습니다.

    전체 설정, 그룹 또는 컴퓨터를 클릭하면 해당 항목에 대한 옵션 설정의 요약이 표시됩니다.

    범위 | 표시되는 옵션 설정
    전체 설정 | 관리 이미지에 대해 지정된 모든 옵션 설정
    그룹 | 전체 설정과 관련해 그룹 설정에서의 변경 사항
    컴퓨터 | 그룹과 관련해 컴퓨터 설정에서의 변경 사항
  • 옵션 설정을 변경하려면 편집 아이콘을 클릭합니다. 아이콘이 음영 모드로 표시되고 더 상세한 설정 목록이 나타납니다.

    전체 설정, 그룹 또는 컴퓨터를 클릭하면 해당 항목에 대한 옵션 설정을 변경할 수 있습니다. 이어받은 전체 설정 또는 그룹 설정과 다른 옵션 설정을 변경하면 해당 옵션 설정이 하이라이트됩니다.

    편집 아이콘을 다시 클릭하면 표시가 읽기 전용 모드로 다시 바뀝니다.

    설정을 변경하면 옵션 편집기를 마칠 때 변경 사항을 저장할 것인지, 무시할 것인지를 묻는 메시지가 나타납니다.

목차

  • 그룹과 컴퓨터의 옵션 설정 지정

    모든 컴퓨터(전체 설정), 컴퓨터 그룹, 개별 컴퓨터의 옵션 설정을 지정할 수 있습니다.

  • 관리 이미지 옵션 설정

    옵션 편집기를 사용하여 개별 클라이언트나 그룹에 제품 번호, 소프트웨어 구성 요소가 설치되는 클라이언트의 설치 옵션, Toolbox 위치와 같은 옵션 설정을 지정할 수 있습니다.

  • 전체 및 그룹 옵션 설정 이어받기

    전체 설정 또는 그룹의 옵션 설정은 그 아래 항목들이 이어받습니다.

  • 각 컴퓨터의 설정 사용자 정의

    컴퓨터 이름을 오른쪽 클릭하면 특정 컴퓨터에 적용한 설정을 수정할 수 있습니다.

상위 주제
관리 이미지 옵션 편집기
관련 개념
그룹과 컴퓨터 추가 및 삭제
옵션 편집기에서 설치 배포하기
관련 태스크
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기


그룹과 컴퓨터의 옵션 설정 지정

모든 컴퓨터(전체 설정), 컴퓨터 그룹, 개별 컴퓨터의 옵션 설정을 지정할 수 있습니다.

  1. 옵션 편집기에서 수정할 개체를 클릭합니다(전체 설정, 그룹 또는 컴퓨터).
  2. 오른쪽에서 편집 아이콘을 클릭합니다.

    아이콘이 음영 모드로 표시되고 더 상세한 설정 목록이 나타납니다.

  3. 왼쪽에서 선택한 항목에 대해 오른쪽에 있는 옵션 설정을 클릭하여 옵션 설정을 변경합니다.

    전체 설정 또는 그룹 설정을 무시하는 옵션 설정의 변경 사항이 하이라이트됩니다.

  4. 확인 또는 닫기를 클릭하여 변경 사항을 저장합니다.
    옵션 | 설명
    확인 | 변경 사항이 저장되고 옵션 편집기가 종료됩니다.
    닫기 | 옵션 편집기에 변경 사항을 저장한 후 종료할 것인지를 묻는 메시지가 나타납니다.
상위 주제
옵션 설정 보기 및 편집하기
관련 개념
전체 및 그룹 옵션 설정 이어받기
각 컴퓨터의 설정 사용자 정의
관련 참조
관리 이미지 옵션 설정


관리 이미지 옵션 설정

옵션 편집기를 사용하여 개별 클라이언트나 그룹에 제품 번호, 소프트웨어 구성 요소가 설치되는 클라이언트의 설치 옵션, Toolbox 위치와 같은 옵션 설정을 지정할 수 있습니다.

제품 번호

클라이언트 컴퓨터에 설치할 제품의 제품 번호를 입력합니다.
SOLIDWORKS 제품을 구입하는 여러 방법이 있으므로 일부 제품 번호로 두 개나 그 이상의 제품을 포괄할 수 있습니다. 예를 들어, SOLIDWORKS 제품 번호로 개별 SOLIDWORKS Simulation 제품 번호를 입력하지 않고 SOLIDWORKS Simulation을 설치할 수 있습니다. 또한, 일부 제품은 제품 번호를 필요로 하지 않습니다. 제품 번호에 관한 질문은 리셀러(VAR)에게 문의하십시오.
SolidNetWork 사용권을 사용하여 사용권을 관리하는 경우:
  • 첫 번째 제품 번호 필드에 SolidNetWork 제품 번호를 입력합니다.
  • SNL Server port@server 필드에서 SolidNetWork License Manager 서버 이름과 포트 이름을 nnnnn@서버이름 형식으로 입력합니다. 여러 항목 입력 시 세미콜론으로 분리합니다.

SolidNetWork 사용권에 관한 자세한 내용은 SolidNetWork 사용권 설치 및 구성을 참조하십시오.

클라이언트 설치 옵션

주요 버전의 클라이언트 설치 실행을 어떻게 진행하겠습니까? 클라이언트 설치 시 기존에 설치되어 있는 주요 버전을 어떻게 처리할 지 지정할 수 있습니다.
  • 기존의 주요 버전 업그레이드 하기(기존 버전이 있는 경우)

    기존의 주요 버전을 새 버전으로 대치해 설치하려는 경우 이 옵션을 지정합니다.

  • 새로운 주요 버전 만들기

    기존의 주요 버전을 유지하고 새 주요 버전을 설치하려는 경우 이 옵션을 지정합니다. 새 버전을 설치할 위치를 지정하려면 찾아보기를 클릭합니다.
새 주요 버전을 설치하기 전에 최근에 설치된 버전을 제거하시겠습니까? 기존에 있던 이전 주요 버전 설치를 제거할지 여부를 지정할 수 있습니다.
  • 아니오, 설치를 제거하지 않습니다.

    이전 주요 버전 설치를 유지하려는 경우 이 옵션을 지정합니다.

  • 예, 사용자 정의 설치 제거를 수행합니다.

    다음 항목을 제거하려면 이 옵션을 선택합니다. 프로그램 파일 및 폴더, 레지스트리 항목, 데이터 파일 및 폴더.

SOLIDWORKS 설정을 어떻게 적용하겠습니까? 클라이언트 설치 시 클라이언트 컴퓨터에서 구성된 SOLIDWORKS 설정이나 설정 복사 마법사에서 내보낸 SOLIDWORKS 설정을 기반으로 SOLIDWORKS 설정을 구성하도록 지정할 수 있습니다. 설정 복사 마법사는 시스템 설정을 사용자, 컴퓨터, 프로필에 저장, 복원, 적용합니다.
SOLIDWORKS 소프트웨어에 있는 도구 > 설정 저장/복원에서 도구을(를) 시작하거나 시작 > 모든 프로그램 > SOLIDWORKS 버전 > SOLIDWORKS 도구 > 설정 복사 마법사 [image] 을(를) 클릭할 수 있습니다.
도구 > 설정 저장/복원을 선택하면 현재 사용자 설정을 저장하거나 복원하면서 SOLIDWORKS 소프트웨어를 계속 작동 및 실행할 수 있는 특수 모드에서 설정 복사 마법사가 실행됩니다.
  • 현재 설정을 사용하거나(설정이 있는 경우) 또는 SOLIDWORKS 기본 설정을 사용합니다.

    클라이언트 컴퓨터가 SOLIDWORKS 설정을 지정한 경우 이 설정을 유지합니다. (클라이언트에서 구체적으로 지정되지 않은 설정의 경우 클라이언트 설치 시 SOLIDWORKS 기본 설정을 사용합니다.)

  • 설정 복사 마법사에서 내보낸 설정 파일을 사용합니다.

    이 옵션 설정을 선택하면 기존의 설정 복사 마법사 내보내기 파일의 옵션 설정을 지정할 수 있습니다. (일반적으로 이 파일의 이름은 solidworkssettings.sldreg입니다.) 찾아보기를 클릭하여 기존 설정 파일을 찾거나, 새로 만들기를 클릭하여 설정 복사 마법사를 시작하고 새 설정 파일을 만들 수 있습니다.

    자세한 내용은 SOLIDWORKS 도움말을 참조하십시오.
클라이언트 설치 활성을 어떤 방식으로 하겠습니까? 설치를 실행한 후 제품 활성화를 자동으로 완료할 지, 사용자가 직접 수행하도록 요구할지 여부를 지정할 수 있습니다.
자동 제품 활성을 지정한 경우, 클라이언트가 처음으로 설치 작업 후 SOLIDWORKS를 실행할 때 공유 네트워크 위치에서 관리 이미지를 사용할 수 있어야 합니다. 관리 이미지를 사용할 수 없는 경우, 해당 클라이언트는 자동 제품 활성을 완료할 수 없게 됩니다. 따라서 SOLIDWORKS 제품 활성을 수동으로 실행시키지 않을 경우 SOLIDWORKS를 실행할 수 없습니다.
  • 각 클라이언트의 설치가 완료될 때마다 자동으로 활성화합니다.

    이 옵션 설정을 선택하면 SOLIDWORKS 제품 활성을 사용하여 제품 활성이 자동으로 실행됩니다. (일반적으로 이 파일 이름은 AutoActivation.xml입니다.) 찾아보기을(를) 클릭하여 기존 활성 파일을 찾거나 새로 만들기을(를) 클릭하여 SOLIDWORKS 제품 활성을 시작한 후 새 활성 파일을 작성합니다.

  • 자동으로 활성화하지 않습니다.

    이 옵션 설정을 선택하면 제품 활성이 자동으로 실행되지 않습니다. 클라이언트 사용자가 설치 작업 이후에 직접 제품 활성화를 수행합니다.

관리자 옵션

모든 설치 중 진단 로그를 작성합니다. | 클라이언트 설치 시 설치 관련 문제를 해결하는 데 사용할 수 있는 진단 로그를 작성할 수 있습니다. 이 로그를 작성하면 클라이언트 설치가 느리게 실행될 수 있습니다.
다른 사용자 이름으로 설치를 실행합니다. | 클라이언트 설치는 사용자 계정 컨트롤(UAC)이 해제된 경우에만 다른 사용자로 실행될 수 있습니다. 이 옵션은 개별 사용자가 컴퓨터에 대해 SOLIDWORKS 제품 설치 시 필요한 로컬 관리자 권한을 갖고 있지 않을 경우 유용할 수 있습니다. 클라이언트에 관리 권한이 없는 경우 다른 배포 및 설치 방법을 사용할 수 있습니다. 옵션 편집기에서 설치 배포하기를 참조하십시오.
설치 전후 프로그램을 실행합니다. | 클라이언트 설치 전이나 후에 사용자 정의 프로그램을 실행하도록 지정할 수 있습니다.
클라이언트가 SOLIDWORKS 고객 피드백 프로그램에 참여하기를 원하십니까? | 클라이언트 컴퓨터가 SOLIDWORKS 고객 피드백 프로그램에 참여하도록 지정할 수 있습니다. 작업 수행 정보를 SOLIDWORKS에 보내면 제품 향상에 도움이 됩니다. 이 절차는 명확하며 기밀로 처리됩니다. 자세한 내용은 고객 피드백 프로그램 웹 사이트를 참고하십시오.

설치 옵션 전후 프로그램 실행에 대한 제약 요소

이러한 옵션을 사용하여 SolidWorks 배포 전후에 클라이언트 컴퓨터에서 다른 설치 프로그램이나 스크립트를 실행할 수 있습니다(예: Microsoft Office를 설치하는 스크립트).

Windows 8 클라이언트 컴퓨터에 자동으로 배포할 경우 이러한 옵션 사용에 제약이 따릅니다. 옵션을 사용하여 사용자 인터페이스를 표시하는 설치 프로그램이나 스크립트를 배포할 경우 오류가 발생합니다(예: 대화 상자를 표시하는 스크립트). SOLIDWORKS 자동 배포를 실행하면 대상 컴퓨터에 SOLIDWORKS를 설치할 수 없습니다. 이 제약 요소는 Windows 7 클라이언트 컴퓨터에서는 발생하지 않습니다.

설치 전 프로그램 실행 및 설치 후 프로그램 실행 옵션을 사용하려면 클라이언트 컴퓨터에 설치할 수 있는 프로그램만 선택해야 합니다.

설치할 소프트웨어

설치할 SOLIDWORKS 제품 구성 요소를 지정할 수 있습니다.
  • 제품 구성 요소 옆에 있는 확인란을 선택하면 클라이언트 설치 시 해당 구성 요소가 설치되도록 지정됩니다.
  • 확인란을 선택 취소하면 해당 구성 요소가 설치되지 않습니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.
언어은(는) SOLIDWORKS 제품 설치 시 지정된 언어만 지원됩니다. 이 때 SolidWorks가 아닌 타 제품의 경우 해당 언어 지정 설치에 영향을 받지 않습니다. 예를 들어 eDrawings®, SOLIDWORKS Workgroup PDM 및 SOLIDWORKS Explorer 설치 시 지원하는 모든 언어가 설치됩니다.

Toolbox 옵션

지원할 표준 및 클라이언트 설치의 기본 Toolbox 위치를 지정할 수 있습니다.

여러 사용자가 대개 네트워크 위치(예: UNC 경로, 공유 폴더 또는 공통 네트워크 드라이브 스팩)를 통해 공유 Toolbox에 액세스하는 것이 일반적입니다.

이 위치에 기존의 주요 버전 Toolbox가 있으면 클라이언트 설치 시 해당 Toolbox가 새 주요 버전으로 업그레이드됩니다. 그러면 파일이 더 이상 이전 SOLIDWORKS의 주요 버전과 호환되지 않습니다.
SOLIDWORKS 이전 버전용 Toolbox를 유지하려면(예: 일부 클라이언트가 이전 버전을 계속 사용할 수 있게 할 경우), 새 버전으로 업그레이드하는 클라이언트에 대해 다른 Toolbox 네트워크 위치를 지정해야 합니다.

SOLIDWORKS Toolbox 관리에 대한 자세한 내용은 SOLIDWORKS 도움말에서 SolidWorks 도움말 정보를 참조하십시오.

SOLIDWORKS PDM 클라이언트 옵션

SOLIDWORKS PDM 클라이언트 및 애드인 배포에 대한 다음 옵션을 선택할 수 있습니다.

  • PDM 제품 유형
  • PDM 클라이언트 유형
  • 피처

클라이언트 및 애드인에 대한 자세한 내용은 SOLIDWORKS PDM 섹션을 참조하십시오.

Electrical 옵션

SOLIDWORKS Electrical의 관리 부품에 다음과 같은 파라미터를 지정할 수 있습니다.
  • 데이터 경로
  • Collaborative Server 컴퓨터 이름 및 포트 번호
  • SQL Server 컴퓨터 이름 및 비밀번호

이 구성 요소에 대한 자세한 내용은 SOLIDWORKS Electrical 섹션을 참조하십시오.

상위 주제
옵션 설정 보기 및 편집하기
관련 개념
전체 및 그룹 옵션 설정 이어받기
각 컴퓨터의 설정 사용자 정의
SolidNetWork 사용권 설치 및 구성
옵션 편집기에서 설치 배포하기
SOLIDWORKS Electrical
관련 태스크
그룹과 컴퓨터의 옵션 설정 지정


전체 및 그룹 옵션 설정 이어받기

전체 설정 또는 그룹의 옵션 설정은 그 아래 항목들이 이어받습니다.

예:
  • 전체 설정에 지정된 설정을 모든 그룹과 컴퓨터가 이어받습니다.
  • 그룹에 정의된 설정을 그 그룹 안의 모든 컴퓨터가 이어받습니다.

컴퓨터나 그룹의 옵션 설정을 변경해서 기본이나 이어받은 설정을 덮어쓸 수 있습니다. 기본이나 이어받은 값에서 옵션 설정을 변경할 때 그 옵션이 강조표시됩니다.

이어받은 원본 값으로 설정을 되돌리려면 그룹이나 컴퓨터 이름을 오른쪽 클릭한 후 전체 설정으로 되돌리기(그룹이나 그룹 멤버가 아닌 컴퓨터) 또는 그룹 설정으로 되돌리기(그룹 멤버인 컴퓨터)를 클릭합니다.
상위 주제
옵션 설정 보기 및 편집하기
관련 개념
각 컴퓨터의 설정 사용자 정의
관련 태스크
그룹과 컴퓨터의 옵션 설정 지정
관련 참조
관리 이미지 옵션 설정


각 컴퓨터의 설정 사용자 정의

컴퓨터 이름을 오른쪽 클릭하면 특정 컴퓨터에 적용한 설정을 수정할 수 있습니다.

바로가기 메뉴에서 각 컴퓨터에 다음 작업을 수행할 수 있습니다.
  • 편집기에서 컴퓨터 삭제
  • 전체 설정으로 되돌리기
  • 노트 추가 또는 편집
  • 편집 옵션

편집 옵션을 사용하면 클라이언트 설치 옵션 및 관리 옵션과 같은 컴퓨터에 대한 모든 옵션을 수정할 수 있습니다.

상위 주제
옵션 설정 보기 및 편집하기
관련 개념
전체 및 그룹 옵션 설정 이어받기
관련 태스크
그룹과 컴퓨터의 옵션 설정 지정
관련 참조
관리 이미지 옵션 설정


옵션 편집기에서 설치 배포하기

수동 또는 푸시 방식을 사용하여 옵션 편집기에서 직접 설치를 배포할 수 있습니다.

  • 옵션 편집기의 직접 배포하기 페이지를 사용하여 사용자에게 설치 지침을 전자우편으로 전송합니다. 사용자에게 클라이언트 컴퓨터에 대한 권한이 있는 경우에 이 방법을 사용합니다.
  • 옵션 편집기의 직접 배포하기 페이지를 사용하여 대상 컴퓨터로 설치를 자동으로 푸시합니다. 사용자 정의 제거도 수행할 수 있습니다. 사용자가 자신의 시스템에 소프트웨어를 설치할 관리 권한이 없는 경우에 이 방식을 사용합니다.

어떤 방식을 사용하든, 관리 이미지 설치 디렉토리를 Windows 공유 디렉토리로 변경해 네트워크 위치를 통해 사용할 수 있도록 해야 합니다(예: C:\SolidWorks Admin\SolidWorks 2014 SP0machine\\shared_directory 또는 전체 이미지를 각 컴퓨터에서 C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0과 같은 로컬 디렉토리로 복사).

목차

  • 매핑된 드라이브를 사용하여 관리 이미지 배포하기

    UNC 경로(\\컴퓨터_이름\공유_이름)은 관리 이미지 설치 디렉토리로 네트워크 위치를 지정하기 위한 권장되는 방법입니다. 그러나, 설치하는 사용자들이 모두 관리 이미지 공유 디렉토리로 같은 드라이브 문자로 매핑된다는 조건 하에, 매핑된 드라이브를 관리 이미지의 StartSWInstall.hta 파일에 대한 위치로 사용할 수 있습니다(예: U:\StartSWInstall.hta).

  • StartSWInstall.exe를 사용하여 관리 이미지 배포하기

  • 직접 배포하기

    사용자가 시스템 설치에 필요한 권한을 갖고 있는 경우에 이 방식을 사용합니다.

  • 자동 배포 필수 구성 요소

    자동 배포를 사용할 경우, 설치 작업이 대상 시스템에 푸시되고 사용자에게 요구되는 작업 없이 각 시스템에서 Microsoft 작업 스케줄러에 의해 수행됩니다. 사용자가 자신의 시스템에 소프트웨어를 설치할 관리 권한이 없는 경우에 이 방식을 사용합니다.

  • 자동 배포하기

상위 주제
관리 이미지 옵션 편집기
관련 개념
그룹과 컴퓨터 추가 및 삭제
관련 태스크
옵션 편집기 종료
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관련 참조
옵션 설정 보기 및 편집하기


매핑된 드라이브를 사용하여 관리 이미지 배포하기

UNC 경로(\\컴퓨터_이름\공유_이름)은 관리 이미지 설치 디렉토리로 네트워크 위치를 지정하기 위한 권장되는 방법입니다. 그러나, 설치하는 사용자들이 모두 관리 이미지 공유 디렉토리로 같은 드라이브 문자로 매핑된다는 조건 하에, 매핑된 드라이브를 관리 이미지의 StartSWInstall.hta 파일에 대한 위치로 사용할 수 있습니다(예: U:\StartSWInstall.hta).

예를 들어, U: 드라이브를 관리 이미지 공유 디렉토리로 매핑한 경우 사용자들에게 file://U:\StartSWIOnstall.hta 링크를 클릭하라는 안내가 포함된 전자우편 통지가 발송됩니다. 전자우편을 받은 사용자들은 U: 드라이브가 관리 이미지에 대한 UNC 위치(\\machine_name\share_name)에 매핑된 경우, 성공적으로 관리 이미지를 설치할 수 있습니다.

상위 주제
옵션 편집기에서 설치 배포하기


StartSWInstall.exe를 사용하여 관리 이미지 배포하기

클라이언트에서 admin_image_install_dir\StartSWInstall.exe 명령을 실행하여 관리 이미지를 설치하거나 설치 제거할 수 있습니다. 이 방법은 관리 이미지 옵션 편집기에 정의된 옵션, 컴퓨터 및 그룹을 사용하여 SOLIDWORKS를 설치합니다.

StartSWInstall.exe 명령에 다음 스위치를 추가할 수 있습니다.
/install | 클라이언트 컴퓨터에 관리 이미지를 설치합니다.
/uninstall 다음 두 가지 옵션 스위치를 사용하여 클라이언트 컴퓨터에서 소프트웨어를 제거합니다.

/removedata

제거에만 사용할 수 있습니다. 제거 중에 SOLIDWORKS 데이터 파일 및 폴더를 제거합니다.

/removeregistry

제거에만 사용할 수 있습니다. 제거 중에 SOLIDWORKS 레지스트리 항목을 제거합니다.
/showui | SOLIDWORKS 설치 관리자의 진행 창을 표시합니다. 이 옵션을 사용하지 않으면 SOLIDWORKS 설치 관리자가 사용자에게 표시되지 않습니다.
/now | 설치 또는 제거를 즉시 시작합니다. 5분 경고 대화 상자가 나타나지 않습니다.

사용자 조작 없이 설치를 진행하고 싶으나 관리 이미지 옵션 편집기에서 자동 배포되는 것은 원치 않는 경우 StartSWInstall.hta보다 StartSWInstall.exe을(를) 사용하는 것이 좋습니다.

상위 주제
옵션 편집기에서 설치 배포하기


직접 배포하기

사용자가 시스템 설치에 필요한 권한을 갖고 있는 경우에 이 방식을 사용합니다.

전자우편을 사용하여 직접 설치를 배포하는 방법

  1. 옵션 편집기에서 배포를 클릭합니다.

    각 컴퓨터에 적절한 설치 및 상태가 나타납니다.

  2. 전자우편 보내기을(를) 클릭합니다.
  3. 관리 이미지 설치 디렉터리에 대한 네트워크 경로를 지정합니다.

    일반적으로 관리 이미지 설치 디렉터리의 경로는 처음에 Windows 파일 경로로 표시됩니다(예: C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0). 대화 상자에 이 경로는 네트워크 경로가 아닙니다이(가) 표시됩니다.

    1. 찾아보기를 클릭하여 해당 관리 이미지 설치 디렉터리에 대한 네트워크 위치를 지정합니다.
    2. 관리 이미지가 설치된 컴퓨터를 탐색하여 관리 이미지 설치 디렉터리로 지정된 Windows 공유 디렉터리를 선택합니다.

      관리 이미지 공유 디렉터리 내에서 찾지 않도록 합니다(예: 64bit 하위 디렉터리).

    3. 확인을(를) 클릭합니다.

      대화 상자에 이 경로는 네트워크 경로입니다라고 나타납니다.

    컴퓨터 사용자에게 관리 이미지의 StartSWInstall.hta 파일이 있는 네트워크 위치를 사용하여 관리 이미지로 설치하는 방법을 안내하는 전자우편이 작성됩니다.

  4. SOLIDWORKS 설치를 담당하는 사용자에게 이메일은 보냅니다.

사용자는 이메일에서 StartSWInstall.hta의 네트워크 위치 링크를 더블 클릭하여 관리 이미지로부터 SOLIDWORKS를 설치할 수 있습니다.

옵션 편집기에서 설치 상태이(가) 표시됩니다.
보류 | 사용자가 해당 컴퓨터에서 아직 설치를 실행하지 않았습니다.
성공 | 사용자가 해당 컴퓨터에서 설치를 성공적으로 완료했습니다.
실패함 | 사용자가 해당 컴퓨터에서 설치를 실행했지만 실패했습니다.

표시될 수 있는 기타 상태 메시지: 설치 완료, 설치 제거 완료, 설치 중, 설치 제거 중, 다시 부팅 필요, 설치 실패, 설치 제거 실패

상위 주제
옵션 편집기에서 설치 배포하기


자동 배포 필수 구성 요소

자동 배포를 사용할 경우, 설치 작업이 대상 시스템에 푸시되고 사용자에게 요구되는 작업 없이 각 시스템에서 Microsoft 작업 스케줄러에 의해 수행됩니다. 사용자가 자신의 시스템에 소프트웨어를 설치할 관리 권한이 없는 경우에 이 방식을 사용합니다.

강제 설치를 사용하는 경우 작업 스케줄러는 SOLIDWORKS 설치 관리자를 시작하여 관리자가 지정한 자격 증명으로 실행합니다. 작업 스케줄러는 컴퓨터의 LocalSystem 계정으로 실행됩니다. 이 계정은 컴퓨터 보안 계정으로 네트워크에 표시됩니다. 컴퓨터 보안 계정에는 관리 이미지가 있는 공유 폴더에 대한 읽기 권한이 있어야 합니다.

Active Directory에서 공유 폴더 그룹에 컴퓨터를 추가하는 경우 개체 유형을 선택하고 컴퓨터가 선택되었는지 확인합니다.

또한 관리 이미지를 제공하는 컴퓨터 및 대상 클라이언트 컴퓨터가 동일한 Microsoft Active Directory 도메인의 멤버여야 합니다.

상위 주제
옵션 편집기에서 설치 배포하기


자동 배포하기

사용자 시스템에 설치를 푸시하여 자동으로 배포하는 방법

  1. 옵션 편집기에서 자동 배포하기 탭을 클릭합니다.

    각 컴퓨터에 적절한 설치 및 상태가 나타납니다.

  2. 배포 열 아래 배포 열에서 대상 클라이언트 컴퓨터 및 그룹을 선택합니다.

    배포 프로세스를 시작하기 전에 배포 열 아래에서 하나 이상의 컴퓨터 또는 그룹을 선택해야 합니다.

  3. Install Time(설치 시간) 아래에서 Now(지금)를 클릭하여 즉시 배포하거나 Later(나중에)를 클릭하여 배포를 수행할 특정 날짜와 시간을 예약합니다.
  4. 클라이언트 옵션 아래, 다음 중에서 선택합니다.
    • SOLIDWORKS 2015 설치 또는 업그레이드
    • SOLIDWORKS 2015 제거
      설치 제거를 선택하는 경우, 프로그램 파일 및 폴더와 함께 레지스트리 항목과 데이터 파일 및 폴더도 삭제할지 여부를 지정할 수 있습니다.
  5. 배포가 완료되었을 때 대상 컴퓨터를 재부팅하려면 Reboot computer automatically(컴퓨터 자동 재부팅)을 클릭합니다.
  6. 대상 컴퓨터의 Client Credentials(클라이언트 자격 증명)을 입력합니다.
  7. 배포를 클릭해 배포 프로세스를 실행합니다.
옵션 편집기에 다음과 같은 설치 상태가 표시됩니다.
보류 | 이 컴퓨터에 아직 설치를 실행하지 않았습니다.
성공 | 이 컴퓨터에 설치가 완료되었습니다.
실패함 | 이 컴퓨터에 설치하는 데 실패했습니다.

표시될 수 있는 기타 상태 메시지: 설치 완료, 설치 제거 완료, 예약 중, 연결 중, 설치 중, 설치 제거 중, 다시 부팅 필요, 예약된 항목 설치, 예약된 항목 설치 제거, 설치 실패, 설치 제거 실패, 연결 실패 및 예약 실패

상위 주제
옵션 편집기에서 설치 배포하기


옵션 편집기 종료

확인 또는 닫기를 클릭하여 옵션 편집기를 종료할 수 있습니다.

  • 확인, 닫기 또는 Windows 응용 프로그램 닫기 버튼을 사용하여 변경 사항을 적용하고 옵션 편집기를 종료합니다.
    • 옵션 설정 변경 사항을 모두 적용하고 옵션 편집기를 종료하려면 확인을 클릭하고
    • 옵션 편집기를 그냥 종료하려면 닫기를 클릭합니다.

      적용할 변경 사항이 있으면 저장 여부를 묻는 메시지가 나타납니다.

    • Windows 응용 프로그램 닫기 버튼(X)을 클릭합니다. 적용할 변경 사항이 있으면 저장 여부를 묻는 메시지가 나타납니다.
상위 주제
관리 이미지 옵션 편집기
관련 개념
그룹과 컴퓨터 추가 및 삭제
옵션 편집기에서 설치 배포하기
관련 태스크
옵션 편집기에 대한 바탕 화면 바로 가기 만들기
관련 참조
옵션 설정 보기 및 편집하기


옵션 편집기에 대한 바탕 화면 바로 가기 만들기

응용 프로그램 내의 특정 관리 이미지에 대한 옵션 편집기의 Windows 바탕 화면 바로 가기를 만들 수 있습니다.

  1. 옵션 편집기를 시작합니다

    예를 들어, Windows 탐색기에서 관리 이미지 설치 디렉토리를 찾아 sldAdminOptionEditor.exe를 더블 클릭합니다.

  2. 이 옵션 편집기에 대한 바탕 화면 바로 가기 만들기를 클릭합니다.

    관리 이미지에 대한 해당 옵션 편집기의 바로 가기가 Windows 바탕 화면에 나타납니다.

상위 주제
관리 이미지 옵션 편집기
관련 개념
그룹과 컴퓨터 추가 및 삭제
옵션 편집기에서 설치 배포하기
관련 태스크
옵션 편집기 종료
관련 참조
옵션 설정 보기 및 편집하기


관리 이미지를 전자우편을 통해 클라이언트에 배포

공유 관리 이미지 디렉터리를 작성한 후에는 전자우편으로 클라이언트에 통지할 수 있습니다.

관리 이미지 디렉터리를 다른 컴퓨터에서 액세스할 수 있는 컴퓨터에서 공유되도록 구성합니다(예: UNC 경로 사용).

관리_이미지_설치_디렉터리\StartSWInstall.hta에 대한 링크가 포함된 전자우편을 모든 클라이언트에 보낼 수 있습니다. 클라이언트는 이 링크를 클릭한 후 SOLIDWORKS 제품 지금 설치를 클릭하여 관리 이미지에서 설치를 시작할 수 있습니다.

새 SOLIDWORKS 버전으로 관리 이미지를 업그레이드하는 경우 이전에 해당 이미지로 설치한 클라이언트가 자동으로 업그레이드하도록 관리 이미지 위치와 공유 속성을 구성할 수 있습니다. 자세한 사항은 관리 이미지에서 클라이언트를 업그레이드하기를 봅니다.
상위 주제
여러 시트 설치
관련 개념
여러 클라이언트에 배포
관리 이미지 사용
명령줄 배포
여러 시트 설치 관리
관리 이미지에서 클라이언트 업그레이드


명령줄 배포

명령 프롬프트 또는 배치 파일(자동 설치)을 사용하여 관리 이미지를 자동으로 배포할 수 있습니다.

SOLIDWORKS PDM 클라이언트 명령줄을 사용하여 관리 이미지를 배포하려면 SOLIDWORKS PDM 설치 가이드를 참조하십시오.

목차

  • 관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비

    관리 이미지를 작성한 후, 클라이언트에 통보하기 전에 명령줄이나 Microsoft Active Directory를 사용하여 작성한 관리 이미지로 설치할 수 없는 Microsoft Windows 구성 요소를 설치해야 합니다.

  • 명령줄을 사용하여 관리 이미지로부터 설치

    명령줄을 사용하여 관리 이미지로부터 설치를 배포할 수 있습니다.

  • 명령줄 속성

    여기에 설명된 명령줄 속성에는 피처 속성, 글로벌 속성, 제품 특정 속성 및 Windows 위치 규칙 등이 포함됩니다.

  • Microsoft Active Directory를 사용하여 관리 이미지 배포

    클라이언트에 SOLIDWORKS 주요 제품을 배포할 때 Microsoft Active Directory 배포가 지원됩니다.

  • Microsoft Active Directory를 사용하여 Windows 구성 요소 설치

    여기에 나온 절차에 따라 Microsoft Windows Active Directory를 사용하여 클라이언트 컴퓨터에 SOLIDWORKS를 설치할 기존 관리 이미지를 준비합니다.

상위 주제
여러 시트 설치
관련 개념
여러 클라이언트에 배포
관리 이미지 사용
관리 이미지를 전자우편을 통해 클라이언트에 배포
여러 시트 설치 관리


관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비

관리 이미지를 작성한 후, 클라이언트에 통보하기 전에 명령줄이나 Microsoft Active Directory를 사용하여 작성한 관리 이미지로 설치할 수 없는 Microsoft Windows 구성 요소를 설치해야 합니다.

이러한 Windows 구성 요소를 직접 설치하는 과정은 명령줄이나 Microsoft Active Directory를 사용하여 관리 이미지로 설치할 경우에만 필요합니다. SOLIDWORKS 설치 관리자를 사용하여 관리 이미지를 만들고 설치할 경우 이 Windows 구성 요소가 자동 설치됩니다.
다음은 Windows 구성 요소에서 SOLIDWORKS에 필요한 파일 요약입니다.
Office Web Components | DriveWorks에 필요한 COM 컨트롤이 포함되어 있습니다.
Visual C++ 2005, 2008, 2010 및 2012 Redistributable Package | Microsoft Visual C++의 런타임 구성 요소가 포함되어 있습니다. 2005, 2008, 2010 및 2012 버전을 모두 설치해야 합니다.
Visual Basic for Applications 7.1 | Visual Basic 매크로를 지원합니다.
Visual Studio Tools for Applications | Visual Studio 프로그램을 지원하는 도구 세트가 포함되어 있습니다. SOLIDWORKS 2013부터 Microsoft Visual Studio Tools for Applications(VSTA) 설치는 선택 사항입니다. VSTA 설치 여부는 Microsoft .NET Framework 3.5를 컴퓨터에 설치해야 하는지에 따라 달라집니다. Windows 7 이상의 경우 .NET Framework는 운영 체제에 하나의 기능으로 포함되어 있습니다. .NET Framework 3.5를 설치해야 하는 경우 Windows 미디어 및 인터넷에서 사용할 수 있습니다. Windows 미디어를 찾을 수 없거나, 인터넷에 연결할 수 없거나, Microsoft .NET Framework 3.5를 컴퓨터에 설치할 권한이 없는 경우 컴퓨터 관리자에게 도움을 요청하십시오.
Visual Studio Remote Debugger | 64-bit 운영 체제의 디버깅 환경을 제공합니다.
.NET Framework 4.5 | .NET Framework 4.5 응용 프로그램 실행에 필요한 공용 언어 런타임과 .NET Framework 구성 요소가 포함되어 있습니다.
Windows용 Bonjour 서비스 | LAN에서 서비스를 검색할 수 있는 기능을 제공합니다.
Visual C++ 재배포 가능 패키지 및 .NET Framework 4.5는 주요 SOLIDWORKS 제품만이 아닌 모든 SOLIDWORKS 제품에 필요합니다.

관리 이미지 디렉터리의 하위 폴더에 이들 구성 요소가 포함되어 있어야 합니다.

다음 표에서 지원되는 각 운영 체제에 필요한 특정 파일을 확인할 수 있습니다.
운영 체제: Windows Server 2008 R2 64비트 SOLIDWORKS 매체: Windows 7 64비트 버전
Windows Server 2008 R2 또는 Windows Server 2012 및 2012 R2 설치는 SOLIDWORKS PDM Server, Workgroup PDM Server 및 SOLIDWORKS SolidNetWork License Manager에서 지원됩니다.
Windows Installer: | (해당 사항 없음)
Office Web 구성 요소: | owc11.exe
Visual C++ 2005 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2008 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2010 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2012 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual Studio Tools for Applications: (선택 사항) | vsta_aide.msi
VSTA가 설치된 경우 .NET 3.5 Framework(dotnetfx35.exe)가 필요합니다. Windows 7의 경우 .NET Framework 3.5는 운영 체제에 하나의 기능으로 포함되어 있습니다.
Visual Studio 원격 디버거: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Windows용 Bonjour 서비스: | bonjour64.msi
운영 체제: Windows Server 2012 및 2012 R2 64비트 SOLIDWORKS 매체: Windows 7 64비트 버전
Windows Server 2008 R2 또는 Windows Server 2012 및 2012 R2 설치는 SOLIDWORKS PDM Server, Workgroup PDM Server 및 SOLIDWORKS SolidNetWork License Manager에서 지원됩니다.
Windows Installer: | (해당 사항 없음)
Office Web 구성 요소: | owc11.exe
Visual C++ 2005 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2008 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2010 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2012 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual Studio Tools for Applications: (선택 사항) | vsta_aide.msi
VSTA가 설치된 경우 .NET 3.5 Framework(dotnetfx35.exe)가 필요합니다. Windows 7의 경우 .NET Framework 3.5는 운영 체제에 하나의 기능으로 포함되어 있습니다.
Visual Studio 원격 디버거: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Windows용 Bonjour 서비스: | bonjour64.msi
운영 체제: Windows Server 2012 및 Windows Server 2012 R2 64비트 SOLIDWORKS 매체: Windows 8 및 8.1용 64비트 버전
Windows Server 2008 R2 또는 Windows Server 2012 및 2012 R2 설치는 SOLIDWORKS PDM Server, Workgroup PDM Server 및 SOLIDWORKS SolidNetWork License Manager에서 지원됩니다.
Windows Installer: | (해당 사항 없음)
Office Web 구성 요소: | owc11.exe
Visual C++ 2005 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2008 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2010 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 20102 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual Studio Tools for Applications: (선택 사항) | vsta_aide.msi
VSTA가 설치된 경우 .NET 3.5 Framework(dotnetfx35.exe)가 필요합니다. Windows 8의 경우 .NET Framework 3.5는 운영 체제에 하나의 기능으로 포함되어 있습니다.
Visual Studio 원격 디버거: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .NET 4.5는 이 요구 사항을 충족하는 운영 체제의 일부로 포함되어 있습니다.
Windows용 Bonjour 서비스: | bonjour64.msi
운영 체제: Windows 7 64비트 SOLIDWORKS 매체: Windows 7 64비트 버전
Windows Installer: | (해당 사항 없음)
Office Web 구성 요소: | owc11.exe
Visual C++ 2005 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2008 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2010 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2012 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual Studio Tools for Applications: (선택 사항) | vsta_aide.msi
VSTA가 설치된 경우 .NET 3.5 Framework(dotnetfx35.exe)가 필요합니다. Windows 7의 경우 .NET Framework 3.5는 운영 체제에 하나의 기능으로 포함되어 있습니다.
Visual Studio 원격 디버거: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Windows용 Bonjour 서비스: | bonjour64.msi
운영 체제: Windows Server 8 및 8.1 64비트 SOLIDWORKS 매체: Windows 8 64비트 버전
Windows Installer: | (해당 사항 없음)
Office Web 구성 요소: | owc11.exe
Visual C++ 2005 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2008 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2010 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual C++ 2012 재배포 가능 패키지: | vcredist_x86.exe vcredist_x64.exe 둘 다 설치되어야 합니다.
Visual Studio Tools for Applications: (선택 사항) | vsta_aide.msi
VSTA가 설치된 경우 .NET 3.5 Framework(dotnetfx35.exe)가 필요합니다. Windows 7의 경우 .NET Framework 3.5는 운영 체제에 하나의 기능으로 포함되어 있습니다.
Visual Studio 원격 디버거: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .NET 4.5는 이 요구 사항을 충족하는 운영 체제의 일부로 포함되어 있습니다.
Windows용 Bonjour 서비스: | bonjour64.msi

목차

  • 64-bit 운영 체제의 명령줄에서 Windows 구성 요소 설치

    다음 단계에 따라 64비트 버전 Windows에서 명령줄을 사용하여 관리 이미지 설치에 필요한 Windows 구성 요소를 설치합니다.

상위 주제
명령줄 배포
관련 개념
명령줄을 사용하여 관리 이미지로부터 설치
명령줄 속성
관련 태스크
Microsoft Active Directory를 사용하여 관리 이미지 배포
Microsoft Active Directory를 사용하여 Windows 구성 요소 설치


64-bit 운영 체제의 명령줄에서 Windows 구성 요소 설치

다음 단계에 따라 64비트 버전 Windows에서 명령줄을 사용하여 관리 이미지 설치에 필요한 Windows 구성 요소를 설치합니다.

한 번의 설치 작업으로 여러 구성 요소를 설치하려면 다음 절차의 명령으로 배치 파일을 작성해서 클라이언트 컴퓨터에 구성 요소를 설치합니다.

  1. 대상 컴퓨터에 적어도 620MB의 사용가능한 디스크 공간과 Temp 디렉터리가 있어야 합니다.
  2. 다음 명령을 실행하여 Office Web Components를 설치합니다.

    관리_이미지_디렉터리\OfficeWeb_11\owc11.exe/quiet

  3. Visual C++ 2010 RELEASE 재배포 가능 패키지를 설치합니다.

    RELEASE = 2005, 2008, 2010 및 2012용 패키지를 설치합니다.

    관리_이미지_디렉터리\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    관리_이미지_디렉터리\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    이 패키지의 32비트와 64비트 버전을 모두 설치해야 합니다.

    예를 들어, 다음을 사용하여 Visual C++ 2005 재배포 가능 패키지를 설치하는 방법:

    • 관리_이미지_디렉터리\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q
    • 관리_이미지_디렉터리\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  4. Microsoft .NET Framework 4.5를 설치합니다.

    관리_이미지_디렉터리\.Net_Framework_4.5\dotnetfx45_full_x86_x64.exe

  5. Visual Studio Tools for Applications를 설치합니다.

    관리_이미지_디렉터리\Microsoft_VSTA\vsta_aide.msi

    VSTA를 설치하려면 .NET Framework 3.5가 필요합니다.

    Windows 7 이상의 경우 .NET Framework 3는 운영 체제에 하나의 기능으로 포함되어 있습니다.

  6. Visual Studio Remote Debugger를 설치합니다.

    관리_이미지_디렉터리\VSRemoteDebugger\install.exe /Q

  7. Visual Basic 7.1을 설치합니다.

    관리_이미지_디렉터리\Microsoft_VBA\vba71.msi 및 관리_이미지_디렉터리\Microsoft_VBA\vba71_1033.msi은(는) 모든 언어에 필요합니다.

    이 패키지의 64비트 버전만 설치해야 합니다.

    추가적으로 원하는 언어가 있으면 다음 중에서 패키지를 선택하여 설치해야 합니다.

    vba71_1028.msi | 중국어
    vba71_1031.msi | 독일어
    vba71_1036.msi | 프랑스어
    vba71_1040.msi | 이태리어
    vba71_1041.msi | 일본어
    vba71_1042.msi | 한국어
    vba71_1046.msi | 포르투갈어(브라질)
    vba71_2052.msi | 중국어-간체
    vba71_3082.msi | 스페인어
    영어, 체코어, 폴란드어, 러시아어, 터키어는 언어 패키지를 추가로 설치할 필요가 없습니다.
    SOLIDWORKS 2013 서비스 팩 2.0부터 추가 구성 요소를 설치해야 합니다. Msiexec.exe /p vba71-kb27832-x64.msp

  8. Windows용 Bonjour 서비스를 설치합니다.

    관리_이미지_디렉터리\Bonjour\Bonjour64.msi

상위 주제
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비


명령줄을 사용하여 관리 이미지로부터 설치

명령줄을 사용하여 관리 이미지로부터 설치를 배포할 수 있습니다.

자동으로 설치하기:

  1. 명령 프롬프트 창을 엽니다(Windows에서 시작 > 실행 클릭).
  2. msiexec.exe 명령과 함께 /i 및 /qb 스위치를 입력하고 아래 표시된 대로 기본값이 아닌 옵션의 속성을 설정합니다.
개별 설치 구성 요소 명령줄 속성:
  • 명령줄 피처 속성
  • 명령줄 글로벌 속성
  • eDrawings 명령줄 속성
  • SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
  • SOLIDWORKS Flow Simulation 명령줄 속성

자동 설치의 템플릿으로 다음 예를 사용합니다.

SOLIDWORKS Client

  • SOLIDWORKS 주요 제품(영어)
  • Toolbox 애드인
  • 피드백 프로그램에 참여
  • 프랑스어

SOLIDWORKS:

msiexec /i "64비트_관리_이미지_경로\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\사용자_폴더" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

SOLIDWORKS 프랑스어 설치 구성 요소는 별도로 설치해야 합니다.

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

SOLIDWORKS 언어 구성 요소 설치 명령을 지정할 때 명령줄 인수를 지정하지 마십시오.

eDrawings 클라이언트

  • 작업 성능 로그
  • 모든 피처

msiexec /i "관리_이미지_경로\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\사용자_폴더" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Explorer와 Workgroup PDM 애드인

  • Workgroup PDM 애드인이 포함된 SOLIDWORKS Explorer

msiexec /i "관리_이미지_경로\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Program Files\사용자_폴더" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb

SOLIDWORKS Electrical

Microsoft SQL Server에서 SOLIDWORKS Electrical을 사용할 경우 기술적으로 복잡하기 때문에 SOLIDWORKS Electrical에 대한 명령줄 예제는 문서에서 제외되었습니다.

상위 주제
명령줄 배포
관련 개념
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄 속성
관련 태스크
Microsoft Active Directory를 사용하여 관리 이미지 배포
Microsoft Active Directory를 사용하여 Windows 구성 요소 설치


명령줄 속성

여기에 설명된 명령줄 속성에는 피처 속성, 글로벌 속성, 제품 특정 속성 및 Windows 위치 규칙 등이 포함됩니다.

목차

  • 명령줄 피처 속성

    SOLIDWORKS 설치는 명령줄 배포에 대한 다음 ADDLOCAL 속성을 지원합니다.

  • 명령줄 글로벌 속성

    각 속성은 개별 설치나 관리자 설치로 지정되었습니다(특별히 표시되어 있지 않는한). 글로벌 속성을 사용하여 제품 번호를 관리자 설치와 개별 설치에 모두 전달할 수 있습니다.

  • eDrawings 명령줄 속성

    다음 명령줄 속성은 eDrawings®에 특정한 속성입니다.

  • SOLIDWORKS Composer/Composer Player 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Composer와 SOLIDWORKS Composer Player에 특정한 속성입니다.

  • SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Explorer와 SOLIDWORKS Workgroup PDM에 특정한 속성입니다.

  • SOLIDWORKS Flow Simulation 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Flow Simulation에 특정한 속성입니다.

  • SOLIDWORKS Inspection 명령줄 속성

    다음 명령줄 속성은 SOLIDWORKS Inspection에 특정한 속성입니다.

  • 관리 이미지의 MSI 파일 위치

    명령줄에서 관리 이미지를 작성할 경우 제품 구성 요소 .msi 파일이 SOLIDWORKS 매체의 다음 위치에 저장되어 있습니다.

상위 주제
명령줄 배포
관련 개념
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄을 사용하여 관리 이미지로부터 설치
관련 태스크
Microsoft Active Directory를 사용하여 관리 이미지 배포
Microsoft Active Directory를 사용하여 Windows 구성 요소 설치


명령줄 피처 속성

SOLIDWORKS 설치는 명령줄 배포에 대한 다음 ADDLOCAL 속성을 지원합니다.

  • CircuitWorks
  • CoreSOLIDWORKSTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
명령줄 설치의 속성을 지정할 때:
  • SOLIDWORKS는 ADDSOURCE 옵션을 사용하는 제품 설치를 지원하지 않습니다.
  • 속성은 대/소문자를 구분하며, 공백과 대시(-)를 포함할 수 없으며 쉼표로 구분되어야 합니다.

    혼합된 사례의 SolidWorks는 응용 프로그램을 올바르게 설치하려면 ADDLOCAL 속성으로 지정해야 합니다.

상위 주제
명령줄 속성
관련 참조
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


명령줄 글로벌 속성

각 속성은 개별 설치나 관리자 설치로 지정되었습니다(특별히 표시되어 있지 않는한). 글로벌 속성을 사용하여 제품 번호를 관리자 설치와 개별 설치에 모두 전달할 수 있습니다.

Property | 설명
ENABLEPERFORMANCE SOLIDWORKS에 작업 수행 정보를 자동으로 보내는 옵션 선택 여부를 지정합니다.

1

작업 성능 데이터 전송

0

작업 성능 데이터를 전송하지 마십시오.
INSTALLDIR SOLIDWORKS의 설치 폴더

(개별 설치에만)
MBDSERIALNUMBER | SOLIDWORKS Simulation 제품의 제품 번호.
MOTIONSERIALNUMBER | SOLIDWORKS Motion 제품의 제품 번호.
OFFICEOPTION 설치할 제품 패키지를 지정합니다.
0 | SOLIDWORKS Client
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL 현재 설치된 기능을 모두 업데이트하려면 ALL을 지정합니다.
기존 주요 릴리즈 내에서 서비스 팩을 업데이트할 때만 이 속성을 지정합니다. 예를 들어, 기존 SOLIDWORKS 2015 SP01 설치를 SOLIDWORKS 2015 SP02로 업데이트할 경우 지정하면 됩니다.
REINSTALLMODE Microsoft Installer 재설치 옵션.

예를 들어, 같은 주요 릴리즈 내에서 한 서비스 팩 릴리즈를 다른 서비스 팩 릴리즈로 업그레이드할 때 REINSTALLMODE=vomus을 지정해야 합니다.

REINSTALLMODE 설정에 대한 자세한 내용은 www.microsoft.com에서 Windows Installer 문서를 참고하십시오.

기존 주요 릴리즈 내에서 서비스 팩을 업데이트할 때만 이 속성을 지정합니다. 예를 들어, 기존 SOLIDWORKS 2015 SP01 설치를 SOLIDWORKS 2015 SP02로 업데이트할 경우 지정하면 됩니다. SOLIDWORKS의 새 최신 주요 릴리즈를 처음으로 설치할 때는 이 속성을 지정하지 마십시오.
SERVERLIST SolidNetWork 서버 목록.
SolidNetWork 서버 목록은 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다.

xxxxx@서버_이름1;yyyyy@서버_이름2;&

여기서 x와 y는 한 자리 수 입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.

(개별 설치에만)
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation 제품의 제품 번호.
SOLIDWORKSSERIALNUMBER | 모든 애드인을 포함하는 SOLIDWORKS 제품의 제품 번호.
SWMIGRATE SOLIDWORKS 설치 선택 대화 상자에 표시된 목록에서 업그레이드할 SOLIDWORKS 버전을 지정합니다. 예:

SWMIGRATE="SOLIDWORKS 2015 x64 Edition SP01"

이전 주요 릴리즈가 현재 설치되어 있는 상태에서 새 주요 릴리즈를 설치할 때만 이 속성을 지정합니다. 같은 주요 릴리즈 내에서 한 서비스팩 릴리즈에서 다른 서비스 팩 릴리즈로 업그레이드할 때는 이 속성을 지정하지 마십시오.
TOOLBOXFOLDER SOLIDWORKS Toolbox 파일의 설치 폴더.

(개별 설치에만)

예: TOOLBOXFOLDER = "c:\SOLIDWORKS Data"
TRANSFORMS 다음 형식의 언어별 항목이 포함되어 있습니다.
TRANSFORMS 번호.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
SOLIDWORKS 기존 버전을 현재 버전으로 업그레이드할지를 지정합니다.
0 | 새 설치, 업데이트하지 않습니다.
1 | 업데이트

(개별 설치에만)

이전 주요 릴리즈가 현재 설치되어 있는 상태에서 새 주요 릴리즈를 설치할 때만 이 속성을 지정합니다. 같은 주요 릴리즈 내에서 한 서비스 팩 릴리즈에서 다른 서비스 팩 릴리즈로 업그레이드할 때는 이 속성을 지정하지 마십시오.
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


eDrawings 명령줄 속성

다음 명령줄 속성은 eDrawings®에 특정한 속성입니다.

속성 | 설명
ADDLOCAL 설치할 eDrawings 응용 프로그램 부분을 지정합니다.
All이 권장 옵션입니다.
명령줄 구문 | 피처
모두 | 모든 구성 요소를 설치합니다. eDrawings 응용 프로그램이 설치된 SOLIDWORKS와 AutoCAD Publisher 응용 프로그램 설치를 확인합니다.
CALS | eDrawings Viewer에서 CAL 파일 보기
Inventor | Autodesk Inventor 응용 프로그램에서 eDrawings 파일을 작성합니다.
eDrawingsViewer | eDrawings 파일과 기타 파일을 봅니다.
ProE | eDrawings Viewer를 사용하여 ProE 파일 보기
DXFDWGTranslator | eDrawings Viewer에서 DXF/DWG 파일을 봅니다.
Shortcuts | 바탕화면 바로가기를 설치합니다.
XML3D | eDrawings Viewer에서 3DXML 파일을 봅니다.
INSTALLDIR | eDrawings을(를) 설치할 폴더를 지정합니다.
LOGPERFORMANCE 전자우편을 통해 SOLIDWORKS Corporation에 성능 데이터를 자동으로 보내는 옵션의 선택 여부를 지정합니다.
1 | 작업 성능 데이터 전송
0 | 전송 안함
SNLSERVER SolidNetWork 사용권 서버의 포트@서버이름을(를) 입력합니다. 여러 개의 포트@서버이름을(를) 구분할 때는 세미콜론(;)을 사용합니다.

SNLSERVER 포트 서버 이름은 SOLIDWORKS SNL 서버 설정에만 필요합니다. 포트_목록@서버_스트링은(는) 세미콜론(;)으로 구분되는 문자열 목록이며, 각 문자열은 다음 형식의 서버 포트 번호입니다.

xxxxx@서버_이름1; yyyyy@서버_이름2;

여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Composer/Composer Player 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Composer와 SOLIDWORKS Composer Player에 특정한 속성입니다.

SOLIDWORKS Composer:

속성 | 설명
ACTIVSERIALNUMBER | SOLIDWORKS Composer의 제품 번호입니다.
ACTIVSERIALNUMBERPLAYERPRO | 선택 사항. SOLIDWORKS Composer Player Pro의 제품 번호입니다.
ADDLOCAL 전체 응용 프로그램을 설치할 경우 다음 항목을 지정하지 않아도 됩니다.
필수 사항:
  • 사용권 발급
  • Documents_2D
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
선택 사항:
  • Sync3Dvia
INSTALLDIR | SOLIDWORKS Composer 소프트웨어를 설치할 폴더를 지정합니다.

SOLIDWORKS Composer Player:

속성 | 설명
ACTIVSERIALNUMBERPLAYERPRO | 선택 사항. SOLIDWORKS Composer Player Pro의 제품 번호입니다.
INSTALLDIR | SOLIDWORKS Composer Player 소프트웨어를 설치할 폴더를 지정합니다.
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Explorer와 SOLIDWORKS Workgroup PDM에 특정한 속성입니다.

SOLIDWORKS Explorer/Workgroup PDM 클라이언트:
클라이언트 속성 | 설명
EXPLORERORPDM
0 | SOLIDWORKS Explorer만 해당
1 | Workgroup PDM 피처 설치 가능
ADDLOCAL
  • 스탠드얼론
  • 클라이언트
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

스탠드얼론이(가) Contributor이고 클라이언트이(가) SOLIDWORKS Explorer 자동 설치용 SOLIDWORKS 애드인입니다.

AutoCAD를 지정할 경우 사용자 컴퓨터에 AutoCAD가 설치되어 있어야 합니다. Workgroup PDM이 적절한 AutoCAD 버전을 찾습니다. 다음 중 하나 이상의 AutoCAD 버전을 지정할 수 있습니다.

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 및 DocMgr64은(는) 64비트 SOLIDWORKS Explorer 설치에만 유효합니다.

INSTALLDIR | Workgroup PDM을 설치할 폴더를 지정합니다.
ACTIVSERIALNUMBER | SOLIDWORKS 제품 번호를 지정합니다.
Workgroup PDM Server:
서버 속성 | 설명
ADDLOCAL
  • 볼트
  • WebPortal
  • API

WebPortal(Viewer)을 지정하는 경우, VAULTNAME도 지정해야 합니다.
INSTALLDIR | Workgroup PDM을 설치할 폴더를 지정합니다.
LICENSE_SERVER | 사용권 서버가 있는 컴퓨터의 이름을 지정합니다.
VAULTDATA | 볼트의 경로와 폴더를 지정합니다.
VAULTNAME | 볼트가 있는 컴퓨터의 이름을 지정합니다.
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Flow Simulation 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Flow Simulation에 특정한 속성입니다.

속성 | 설명
ACTIVSERIALNUMBER SOLIDWORKS Flow Simulation 스탠드얼론 제품 번호.

(관리 이미지로 개별 설치와 클라이언트 설치)
CWUPGRADEINSTALL SOLIDWORKS Flow Simulation 응용 프로그램의 기존 버전을 업그레이드합니다.
1 | 업데이트
2 | 새 설치; 새 디렉터리에 설치

(관리 이미지로 개별 설치와 클라이언트 설치)
INSTALLDIR 특정 SOLIDWORKS Flow Simulation 응용 프로그램 소프트웨어에 대한 설치를 지정합니다.

(개별 설치에만)
SERVERLIST | 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다: xxxxx@서버_이름1; yyyyy@서버_이름2;& 여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
SOLIDWORKSPATH SOLIDWORKS 소프트웨어가 설치된 폴더를 지정합니다.

(관리 이미지로 개별 설치와 클라이언트 설치)
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성
관리 이미지의 MSI 파일 위치


SOLIDWORKS Inspection 명령줄 속성

다음 명령줄 속성은 SOLIDWORKS Inspection에 특정한 속성입니다.

속성 | Description
ACTIVSERIALNUMBER | SOLIDWORKS Inspection의 제품 번호입니다. (관리 이미지로 개별 설치와 클라이언트 설치)
INSTALLDIR | SOLIDWORKS Inspection 응용 프로그램 소프트웨어 설치를 지정합니다. (개별 설치에만)
SERVERLIST | 세미콜론(;)으로 구분되는 스트링 목록이며, 각 스트링은 서버 포트 번호를 다음 형식으로 사용합니다: xxxxx@서버_이름1; yyyyy@서버_이름2;& 여기서 x와 y는 한 자리 수입니다. 목록에 있는 마지막 서버 뒤에는 세미콜론(;)을 붙이지 않습니다.
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
관리 이미지의 MSI 파일 위치


관리 이미지의 MSI 파일 위치

명령줄에서 관리 이미지를 작성할 경우 제품 구성 요소 .msi 파일이 SOLIDWORKS 매체의 다음 위치에 저장되어 있습니다.

SOLIDWORKS(주요 제품, 영어)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS 주요 제품(영어가 아닌 구성 요소)

중국어 번체 | swwi\lang\chinese\chinese.msi
중국어 간체 | swwi\lang\chinese-simplified\chinese-simplified.msi
체코어 | swwi\lang\czech\czech.msi
프랑스어 | swwi\lang\french\french.msi
독일어 | swwi\lang\german\german.msi
이태리어 | swwi\lang\italian\italian.msi
일본어 | swwi\lang\japanese\japanese.msi
한국어 | swwi\lang\korean\korean.msi
폴란드어 | swwi\lang\polish\polish.msi
포르투갈어(브라질) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
러시아어 | swwi\lang\russian\russian.msi
스페인어 | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS Activation Wizard

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Explorer

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional에서는 API를 제공하지만 이는 클라이언트에서만 사용할 수 있으며 .msi 파일에서 사용할 수 없습니다. 자세한 내용은 SOLIDWORKS PDM 클라이언트 install\API 디렉터리의 API 설명서를 참조하십시오.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Viewer

swviewer\SOLIDWORKS Viewer.msi

Workgroup PDM Server

pdmwserver\SOLIDWORKS Workgroup PDM Server.msi
상위 주제
명령줄 속성
관련 참조
명령줄 피처 속성
명령줄 글로벌 속성
eDrawings 명령줄 속성
SOLIDWORKS Composer/Composer Player 명령줄 속성
SOLIDWORKS Explorer/Workgroup PDM 명령줄 속성
SOLIDWORKS Flow Simulation 명령줄 속성
SOLIDWORKS Inspection 명령줄 속성


Microsoft Active Directory를 사용하여 관리 이미지 배포

클라이언트에 SOLIDWORKS 주요 제품을 배포할 때 Microsoft Active Directory 배포가 지원됩니다.

Microsoft Active Directory란 네트워크 환경에서 클라이언트와 서버 관리에 사용되는 디렉터리 서비스 입니다. 관리, 이동, 배포 과정을 단순화합니다.

  1. SOLIDWORKS 설치 관리자를 사용하여 관리 이미지를 작성합니다.
  2. 명령줄을 사용하여 관리 이미지를 작성한 경우 Microsoft Active Directory를 사용하여 관리 이미지로부터 설치하는 데 필요한 Windows 구성 요소를 설치합니다. 자세한 내용은 Microsoft Active Directory를 사용하여 Windows 구성 요소 설치을 참조하십시오.

    명령줄을 사용하여 이미지를 직접 작성한 경우에만 이 단계를 수행합니다. SOLIDWORKS 설치 관리자를 사용하여 이미지를 작성하고 설치한 경우, 모든 Windows 구성 요소가 자동으로 설치됩니다.

  3. SOLIDWORKS 소프트웨어를 사용자 정의할 변형 파일을 작성합니다.
    1. 명령 프롬프트 창을 엽니다.
    2. 관리 이미지가 있는 폴더에서 SWCreateMST.exe 파일을 명령 프롬프트 창에 끌어 놓습니다.

      명령 줄 형식:

      관리_이미지_디렉터리\SWCreateMST.exe 관리_이미지의_MSI_파일_경로속성_목록

      속성은 피처 속성 또는 글로벌 속성이 될 수 있습니다. 자세한 내용은 명령줄 피처 속성 및 명령줄 글로벌 속성을 참고하십시오.

      다음 예를 템플릿으로 사용합니다.

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      변형 파일인 SOLIDWORKS.mst가 관리 이미지가 포함된 폴더에 작성됩니다.

  4. Active Directory에서 SOLIDWORKS 소프트웨어를 배포하기 위해 Published Apps 그룹 정책을 편집합니다.
  5. 그룹 정책 대화 상자에서 컴퓨터 구성과 소프트웨어 설정을 확장합니다.
  6. 소프트웨어 설치를 오른쪽 클릭하고 새로 만들기 > 패키지를 선택합니다.
  7. 관리 이미지를 찾아 열기를 클릭합니다.
  8. 소프트웨어 배포 대화 상자에서 고급 게시 또는 할당을 선택한 후 확인을 클릭합니다.
  9. SOLIDWORKS 속성 대화 상자의 수정 탭에서:
    1. 추가을(를) 클릭합니다.
    2. .mst 파일을 찾습니다.
    3. 열기을(를) 클릭합니다.
  10. 확인을(를) 클릭합니다.
상위 주제
명령줄 배포
관련 개념
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄을 사용하여 관리 이미지로부터 설치
명령줄 속성
관련 태스크
Microsoft Active Directory를 사용하여 Windows 구성 요소 설치


Microsoft Active Directory를 사용하여 Windows 구성 요소 설치

여기에 나온 절차에 따라 Microsoft Windows Active Directory를 사용하여 클라이언트 컴퓨터에 SOLIDWORKS를 설치할 기존 관리 이미지를 준비합니다.

  1. 모든 Visual C++ 재배포 가능 패키지 설치 프로그램 파일을 추출하고 설치합니다.
    1. Visual C++ 2005

      1. administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T: {대상 디렉터리}
      2. administrative_image_directory\Microsoft_C++_2005_Redistributable_(64)\vcredist_x64.exe /C /T: {대상 디렉터리}
      3. Microsoft C++ 2005 재배포 가능 모듈의 설치 정책을 만듭니다.

    2. Visual C++ 2008

      1. administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {대상 디렉터리}
      2. administrative_image_directory\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {대상 디렉터리}
      3. Microsoft C++ 2008 재배포 가능 모듈의 설치 정책을 만듭니다.

    3. Visual C++ 2010

      1. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{대상 디렉터리}
      2. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{대상 디렉터리}
      3. Microsoft C++ 2010 재배포 가능 모듈의 설치 정책을 만듭니다.

    4. Visual C++ 2012

      1. 테스트 컴퓨터에 admistrative_image_directory\Microsoft_C++_2012_Redistributable\vcredist_x86.exe를 설치합니다.
      2. 이러한 폴더를 네트워크 위치로 복사(대상 디렉터리):
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
      3. 다음 파일의 설치 정책을 만듭니다
        파일 경로는 공백을 포함할 수 없습니다.

        대상 디렉터리\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        대상 디렉터리\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      4. 테스트 컴퓨터에 administrative_image_directory\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe를 설치합니다.
      5. 이러한 폴더를 네트워크 위치로 복사(대상 디렉터리):
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      6. 다음 파일의 설치 정책을 만듭니다
        파일 경로는 빈 칸을 포함할 수 없습니다.

        대상 디렉터리\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        대상 디렉터리\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        대상 디렉터리\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Microsoft .NET Framework 4.5를 설치합니다.

    WSUS(Windows Updates Services) 또는 이와 유사한 서비스를 사용하여 .NET Framework 4.5를 설치하는 것이 좋습니다.

  3. Office Web Components 파일의 압축을 풀고 설치합니다.
    1. 이 명령을 실행합니다:

      관리_이미지_디렉터리\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_디렉터리}

    2. 정책을 만들어 Office Web Components를 설치합니다.

      {Office_Web_components_디렉터리}\owc11.MSI

      이 설치에는 변형 파일이 필요없습니다.

  4. 다음 정책을 만들어 Visual Studio Remote Debugger(컴퓨터에 .Net Framework 3.5가 설치된 64비트 버전에만 해당)를 설치합니다.

    {Microsoft_remote_debugger_디렉터리}\rdbgexp.MSI

    이 설치에는 변형 파일이 필요없습니다.

  5. 다음 작업을 수행합니다.
    1. 응용 프로그램용 Visual Basic 7.1을 vba71-kb2783832-x64 서비스 팩으로 업데이트합니다.
    2. 관리 이미지를 작성한 후 다음 명령을 실행합니다.

      Msiexec /a {SOLIDWORKS Administrative image}/Microsoft_vba/vba71.msi /p {SOLIDWORKS Administrative image}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp

    3. 다음 정책을 만들어 Visual Basic 7.1을 설치합니다.

      {VBA 디렉터리}\vba71.MSI

      이 설치에는 변형 파일이 필요 없습니다.

  6. 다음 정책을 만들어 Visual basic 7.1 언어 팩을 설치합니다.

    {VBA 디렉터리}\vba71_nnnn.MSI

    여기서 nnnn은 필요한 언어를 정의합니다.
    • 1028 = 중국어
    • 1031 = 독일어
    • 1033 = 영어
    • 1036 = 프랑스어
    • 1040 = 이탈리아어
    • 1041 = 일본어
    • 1042 = 한국어
    • 1046 = 포르투갈어
    • 2052 = 중국어 - 중국
    • 3082 = 스페인어

  7. 다음 정책을 만들어 Bonjour 서비스를 설치합니다.

    {Bonjour 디렉터리}\Bonjour.MSI

    이 설치에는 변형 파일이 필요없습니다.

상위 주제
명령줄 배포
관련 개념
관리 이미지로부터 명령줄 설치를 하기 위해 클라이언트 준비
명령줄을 사용하여 관리 이미지로부터 설치
명령줄 속성
관련 태스크
Microsoft Active Directory를 사용하여 관리 이미지 배포


여러 시트 설치 관리

여러 시트 설치 시의 관리 작업으로는 관리 이미지를 새 버전으로 업그레이드, 서비스 팩 업데이트 적용, 설치 제거 등이 있습니다.

목차

  • 관리 이미지를 새 버전으로 업그레이드

    관리 이미지로부터 설치할 클라이언트를 업데이트 하려면, 먼저 관리 이미지를 업데이트한 후 클라이언트를 구성하여 이미지의 새 복사본을 참조합니다.

  • 서비스 팩 제품 업데이트 관리

    서비스 팩 제품 업데이트에 시스템 신뢰성, 프로그램 호환성, 보안 등의 업데이트가 포함될 수 있습니다.

  • 설치 제거

    개별 컴퓨터나 클라이언트/서버 환경에서 설치를 제거할 수 있습니다.

상위 주제
여러 시트 설치
관련 개념
여러 클라이언트에 배포
관리 이미지 사용
관리 이미지를 전자우편을 통해 클라이언트에 배포
명령줄 배포


관리 이미지를 새 버전으로 업그레이드

관리 이미지로부터 설치할 클라이언트를 업데이트 하려면, 먼저 관리 이미지를 업데이트한 후 클라이언트를 구성하여 이미지의 새 복사본을 참조합니다.

올바른 파일이 참조되도록 인터넷에서 SOLIDWORKS 설치 관리자를 실행합니다. SOLIDWORKS 설치 관리자에서 자동으로 업데이트를 수행하거나 SOLIDWORKS 다운로드 웹 사이트(http://www.solidworks.com/sw/support/downloads.htm)에서 직접 업데이트를 실행할 수도 있습니다.

(이미지의 새 복사본을 작성하는) 관리자 이미지가 업데이트되면, 관리이미지의 새 복사본를 참조하도록 해서 클라이언트를 업데이트할 수 있습니다.

클라이언트가 매핑된 드라이브나 공유 디렉터리를 사용해서 관리 이미지의 이전 버전을 참조하는 경우, 관리 이미지의 업데이트 사본 위치를 사용해서 매핑된 드라이브나 공유 디렉터리를 재정의할 수 있습니다.

목차

  • 관리 이미지의 업데이트된 설치 파일 다운로드

    SOLIDWORKS 설치 관리자는 관리 이미지를 업그레이드할 때 업데이트된 설치 파일이 필요하면 이를 감지합니다.

  • 관리 이미지 업그레이드

    관리 이미지를 업그레이드하기 위해 SOLIDWORKS 설치 관리자는 새 이미지 디렉터리를 작성합니다. 그러면 사용자는 새 관리 이미지 디렉터리를 사용하는 클라이언트를 지정하여 해당 제품 버전을 업그레이드합니다.

  • 관리 이미지에서 클라이언트 업그레이드

    SOLIDWORKS 설치 관리자는 관리 이미지로부터 설치한 클라이언트 컴퓨터를 자동으로 업데이트할 수 있습니다.

상위 주제
여러 시트 설치 관리
관련 개념
서비스 팩 제품 업데이트 관리
관련 태스크
설치 제거


관리 이미지의 업데이트된 설치 파일 다운로드

SOLIDWORKS 설치 관리자는 관리 이미지를 업그레이드할 때 업데이트된 설치 파일이 필요하면 이를 감지합니다.

  1. DVD를 삽입해서 SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 화면에서 관리 이미지를 선택합니다.
  3. 제품 번호 화면에서 SOLIDWORKS 제품 번호를 입력합니다.

    SOLIDWORKS 설치 관리자가 SOLIDWORKS 웹 사이트에서 사용 허가를 받은 제품과 사용 가능한 서비스팩을 확인합니다.

  4. 최신 버전이 있음 화면이 나타나는 경우 예, 새로운 버전 다운로드 및 설치:버전을 선택합니다.

    SOLIDWORKS 설치 관리자가 새 버전을 설치하기 위해 새 세션을 시작합니다.

  5. 다운로드 폴더에 문제가 있으면 다운로드 옵션이 나타나 이 경우, 새 설치 파일의 기본 디렉터리를 그대로 사용하거나 새 디렉터리 이름을 입력합니다.

    디렉터리가 없다는 메시지가 나타나면 예를 클릭해서 만듭니다.

  6. 다운로드 완료 화면에서 닫기를 클릭해서 현재 설치 프로그램을 닫고 새 버전을 위해 설치 프로그램을 시작합니다.
상위 주제
관리 이미지를 새 버전으로 업그레이드
관련 개념
관리 이미지에서 클라이언트 업그레이드
관련 태스크
관리 이미지 업그레이드


관리 이미지 업그레이드

관리 이미지를 업그레이드하기 위해 SOLIDWORKS 설치 관리자는 새 이미지 디렉터리를 작성합니다. 그러면 사용자는 새 관리 이미지 디렉터리를 사용하는 클라이언트를 지정하여 해당 제품 버전을 업그레이드합니다.

이 과정은 관리 이미지의 업데이트된 설치 파일을 다운로드한 것을 전제로 합니다. 자세한 내용은 관리 이미지의 업데이트된 설치 파일 다운로드를 참조하십시오.

  1. SOLIDWORKS 설치 관리자를 시작합니다. 자세한 내용은 SOLIDWORKS 설치 시작하기를 참조하십시오.
  2. 시작 화면에서 관리 이미지를 선택합니다.

    관리 이미지 작성 옵션이 나타납니다.

    옵션 | 설명
    기본 설정을 사용하여 새 이미지를 작성합니다. | 기본 구성 설정을 사용하여 관리 이미지를 작성합니다(즉, 사이트의 기존 관리 이미지에 대해 현재 지정된 설정을 기반으로 하는 것이 아닌).
    기존 이미지의 설정과 파일을 사용하여 새 이미지를 작성합니다. | 사이트의 기존 관리 이미지에 지정된 구성 설정을 사용하여 이미지를 작성합니다. 찾아보기를 클릭하여 기존 관리 이미지의 설치 디렉터리를 지정합니다.
  3. 제품 번호 화면에서 제품 번호를 확인합니다.
  4. 요약(이미지 작성 준비완료) 화면에서 관리 이미지 옵션이 올바른지 확인합니다.

    개별 관리 이미지와 설치 옵션에 대한 자세한 내용을 보려면 변경을 클릭하여 옵션 페이지로 이동한 후 도움말을 클릭합니다.

  5. 관리 이미지의 새 버전을 작성하려면 지금 작성을 클릭합니다.

이제 관리 이미지의 새 버전으로 클라이언트를 업그레이드할 준비가 됩니다. 자세한 사항은 관리 이미지에서 클라이언트를 업그레이드하기를 봅니다.

상위 주제
관리 이미지를 새 버전으로 업그레이드
관련 개념
관리 이미지에서 클라이언트 업그레이드
관련 태스크
관리 이미지의 업데이트된 설치 파일 다운로드
SOLIDWORKS 설치 시작


관리 이미지에서 클라이언트 업그레이드

SOLIDWORKS 설치 관리자는 관리 이미지로부터 설치한 클라이언트 컴퓨터를 자동으로 업데이트할 수 있습니다.

일반적으로 관리 이미지가 서버의 폴더에 구성됩니다. 클라이언트의 자동 업그레이드를 지원하려면 관리 이미지가 반드시 공유 폴더에 있어야 합니다.

관리 이미지를 업그레이드한 이후 원본 설치와 업그레이드된 설치가 다른 폴더에 위치합니다. 업그레이드된 설치를 사용하려면 먼저 원본 관리 이미지 폴더에서 공유 옵션을 제거한 다음, 업그레이드한 관리 이미지 폴더에 공유 옵션을 추가해야 합니다.

SOLIDWORKS가 원본 관리 이미지로부터 설치한 클라이언트 컴퓨터에서 시작되면 새 버전을 감지하고 클라이언트를 업그레이드합니다.

상위 주제
관리 이미지를 새 버전으로 업그레이드
관련 태스크
관리 이미지의 업데이트된 설치 파일 다운로드
관리 이미지 업그레이드

원본 관리 이미지 폴더에서 공유 옵션 제거

공유 폴더에서 액세스되는 관리 이미지를 업그레이드할 때 원본 폴더에서 공유 옵션을 제거해야 합니다.

  1. 원본 관리 이미지 파일이 있는 폴더를 찾습니다.
  2. 폴더를 오른쪽 클릭하고 등록 정보를 선택합니다.
  3. 공유 탭에서 이 폴더를 공유하지 않음을 선택한 후 확인을 클릭합니다.

이제 업그레이드된 관리이미지 폴더에 공유 옵션 추가에서 설명한 것처럼 업그레이드된 관리 이미지 폴더에 공유 옵션을 추가합니다.

업그레이드된 관리이미지 폴더에 공유 옵션 추가

업데이트된 관리 이미지 폴더를 작성하고 원본 관리 이미지 폴더를 비활성화하고 나면 공유 옵션을 새 폴더에 추가하여 관리 이미지를 다시 사용할 수 있도록 해야 합니다.

  1. 업그레이드된 관리 이미지 파일이 있는 폴더를 찾습니다.
  2. 폴더를 오른쪽 클릭하고 등록 정보를 선택합니다.
  3. 공유 탭에서 사용자 조직이나 그룹에 적합한 공유 속성을 지정하고 공유 이름을 원본 관리 이미지 폴더에 사용된 이름으로 변경합니다.
원본 관리 이미지 공유 위치에서 설치한 컴퓨터가 SOLIDWORKS를 시작할 때 자동으로 새 버전으로 업그레이드됩니다.


서비스 팩 제품 업데이트 관리

서비스 팩 제품 업데이트에 시스템 신뢰성, 프로그램 호환성, 보안 등의 업데이트가 포함될 수 있습니다.

사용자가 제품 업데이트를 얻는 두 가지 방법:
  • SOLIDWORKS 설치 관리자를 사용해 업데이트를 확인 및 다운로드하고 설치합니다.

    SOLIDWORKS 설치 관리자를 직접 시작하거나 정기적인 업데이트 확인을 예약할 수 있습니다.

  • SOLIDWORKS 지원 웹 사이트에서 직접 서비스팩을 다운로드합니다.

    서비스 팩이 기존 소프트웨어에 패치되면서 적용됩니다. 예를 들어, SOLIDWORKS 2015 SP1.0은 SOLIDWORKS 2015 SP0.0의 서비스 팩입니다. SOLIDWORKS 2015 설치 관리자에서는 이 서비스 팩을 설치할 수 있으나 SOLIDWORKS 2016의 SOLIDWORKS 설치 관리자에서는 설치할 수 없습니다.

    서비스 팩의 다운로드 및 설치에 관한 내용은 업데이트하려는 SOLIDWORKS 버전에 적합한 설치 문서를 참조하십시오

목차

  • 관리 이미지의 서비스 팩 롤백

    관리 이미지를 이전에 설치된 서비스 팩으로 롤백할 수 있습니다. SOLIDWORKS 소프트웨어를 디스크로 설치할 경우, 서비스 팩을 회복하려면 원본 디스크가 필요합니다. 이전 관리 이미지의 사본을 저장해야만 합니다.

  • Microsoft Active Directory로 배포한 클라이언트에 서비스 팩 적용하기

    Microsoft Active Directory를 사용해서 SOLIDWORKS 소프트웨어를 설치할 경우, 클라이언트에 서비스 팩을 적용할 수 있습니다.

상위 주제
여러 시트 설치 관리
관련 개념
관리 이미지를 새 버전으로 업그레이드
관련 태스크
설치 제거


관리 이미지의 서비스 팩 롤백

관리 이미지를 이전에 설치된 서비스 팩으로 롤백할 수 있습니다. SOLIDWORKS 소프트웨어를 디스크로 설치할 경우, 서비스 팩을 회복하려면 원본 디스크가 필요합니다. 이전 관리 이미지의 사본을 저장해야만 합니다.

이미 업그레이드된 관리 이미지는 이전 서비스 팩으로 롤백 할 수 없습니다. SOLIDWORKS 설치 관리자 이외의 방법으로 작성된 관리자 이미지를 이전 버전으로 롤백할 수 없습니다. 이러한 관리 이미지에서 설치된 클라이언트는 제거한 후 이전 버전에서 작성된 관리 이미지를 사용하여 다시 설치해야 합니다.
  1. 현재 관리 이미지가 있는 폴더를 삭제합니다. 폴더를 삭제하기 위해, 명령 프롬프트 창을 열고 다음을 입력합니다:

    rmdir /s/q 현재_관리_이미지_경로

  2. 관리 이미지의 백업 사본을 현재 관리 이미지를 삭제한 폴더 위치로 이동합니다. 폴더를 삭제하기 위해, 명령 프롬프트 창을 열고 다음을 입력합니다:

    move 관리_이미지_백업_경로현재_관리_이미지_경로

    관리 이미지를 롤백하면, 다음에 SOLIDWORKS 소프트웨어를 실행 할 때 클라이언트 컴퓨터가 자동으로 롤백됩니다.

상위 주제
서비스 팩 제품 업데이트 관리
관련 태스크
Microsoft Active Directory로 배포한 클라이언트에 서비스 팩 적용하기


Microsoft Active Directory로 배포한 클라이언트에 서비스 팩 적용하기

Microsoft Active Directory를 사용해서 SOLIDWORKS 소프트웨어를 설치할 경우, 클라이언트에 서비스 팩을 적용할 수 있습니다.

  1. 다음 명령줄을 사용해서 관리 이미지를 새 폴더에 복사합니다:

    xcopy 현재_관리_이미지_경로백업_관리_이미지_경로 /s/i/v

  2. SOLIDWORKS 설치 관리자를 사용하여 관리 이미지를 업그레이드합니다.
  3. 새 변형 파일을 작성해서 SOLIDWORKS 소프트웨어의 업그레이드 설치를 지정합니다.
    1. 명령 프롬프트 창을 엽니다.
    2. 관리 이미지가 있는 폴더에서 SWCreateMST.exe 파일을 명령 프롬프트 창에 끌어 놓습니다.

      명령 형식:

      관리_이미지_경로\SWCreateMST.exe 관리_이미지의_MSI_파일_경로속성_목록

      명령줄에 원본 변형 파일과 글로벌 속성인 UPGRADESWINSTALL과 SWMIGRATE를 작성하는데 사용되는 모든 파라미터가 포함되어야 합니다.

      예를 들어, 원래 명령이 다음과 같을 경우:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\사용자_폴더" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@사용자_서버

      업데이트 명령은 다음과 같아야 합니다.

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\사용자_폴더" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@사용자_서버 UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS 버전서비스_팩"

      변형 파일인 SOLIDWORKS.mst가 관리 이미지가 포함된 폴더에 작성됩니다.

  4. Active Directory에서 SOLIDWORKS 소프트웨어를 배포하기 위해 Published Apps 정책을 편집합니다.
  5. 그룹 정책 대화 상자에서 컴퓨터 구성과 소프트웨어 설정을(를) 확장합니다.
  6. 소프트웨어 설치을(를) 오른쪽 클릭하고 새로 만들기 > 패키지을(를) 선택합니다.
  7. 관리 이미지를 찾아 열기를 클릭합니다.
  8. 소프트웨어 배포 대화 상자에서 고급 게시 또는 할당을 선택한 후 확인을 클릭합니다.
  9. SOLIDWORKS 속성 대화 상자의 수정 탭에서:
    1. 추가을(를) 클릭합니다.
    2. .mst 파일을 찾습니다.
    3. 열기을(를) 클릭합니다.
  10. 확인을(를) 클릭합니다.
상위 주제
서비스 팩 제품 업데이트 관리
관련 태스크
관리 이미지의 서비스 팩 롤백


SOLIDWORKS Workgroup PDM

Workgroup PDM 응용 프로그램은 SOLIDWORKS 환경에서 또는 SOLIDWORKS Explorer 안의 스탠드얼론 응용 프로그램으로 실행되는 제품 데이터 관리 소프트웨어입니다. Workgroup PDM은 체크아웃, 체크인, 수정본 관리 및 기타 관리 작업과 같은 프로젝트 절차를 관리해 줍니다.

Workgroup PDM 시스템은 아래 도표와 같습니다:

  • 컴퓨터 당 볼트 한 개만 설치 할 수 있습니다.
  • Vault 디렉토리는 숨은 디렉토리나 읽기 전용이면 안됩니다.
  • 클라이언트/서버 응용 프로그램인 Workgroup PDM의 작업 수행은 네트워크 성능에 따라 달라집니다.
  • 사용자가 많은 문서를 관리해야 할 경우에는, 문서 수가 적은 프로젝트를 많이 작성하는 것이 문서 수가 많은 프로젝트를 적게 작성하는 것보다 작업 속도 향상에 도움이 됩니다.

지원 중단 알림

SOLIDWORKS Workgroup PDM 지원은 SOLIDWORKS 2017 이후로 종료됩니다. 이미 SOLIDWORKS Workgroup PDM을 사용 중인 고객은 계속 설치를 할 수 있지만 파일 볼트를 SOLIDWORKS PDM 서버로 마이그레이션하는 계획을 수립하기 시작해야 합니다.

설치

  • Clients, VaultAdmin, API, Viewer는 Vault와 동일한 컴퓨터에 또는 다른 컴퓨터에 설치 할 수 있습니다.
  • 클라이언트 API를 설치하기 위해 Workgroup PDM Server를 설치하지 않아도 됩니다. 클라이언트 API는 Workgroup PDM Client를 설치할 때 함께 설치됩니다.
  • 원격 위치의 볼트 폴더를 설정하려면, 서버 대상을 묻는 메시지가 표시되면 UNC(Universal Naming Convention) 경로를 입력합니다. (자세한 정보는 UNC 서식을 참고하십시오.)
  • 볼트 설치나 업데이트시 컴퓨터를 다시 시작합니다.
  • 다시 부팅한 다음 Workgroup PDM Server Service가 자동으로 시작되지 않으면 직접 시작합니다. Windows 탐색기의 폴더에서 \SOLIDWORKS Workgroup PDM\Vault 폴더에서 pdmwvault.exe을(를) 실행합니다.
  • Workgroup PDM 클라이언트를 설치할 때 반드시 각 컴퓨터에 solidworksexplorer.exe를 설치해야 합니다. 이 실행 파일은 공유 드라이브에 있습니다. Workgroup PDM Vault, Viewer, API Client, VaultAdmin이 각 클라이언트 컴퓨터에 설치되지 않았습니다.
Windows 8을 실행하는 경우 시작 또는 제어판 액세스 등의 작업에 대해서는 SOLIDWORKS에서 Microsoft Windows 사용 시 팁을 참조하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.

사용권

  • Workgroup PDM API의 사용권이 SOLIDWORKS 클라이언트와 Explorer 클라이언트의 사용권에 포함되어 있습니다. API 체크인은 클라이언트 사용권이 필요합니다.
  • Workgroup PDM Viewer 사용권이 볼트와 함께 설치되어야 Viewer가 활성화 됩니다.

권한

  • 볼트 관리자에게 설치와 볼트 폴더에 쓰기 권한이 있어야 합니다.
  • 볼트 관리자가 Windows 탐색기가 아닌 VaultAdmin에서 볼트 폴더를 관리해야 합니다.
  • 사용자에게 볼트 폴더를 위한 Windows 탐색기 안의 쓰기 권한이 없어야 합니다.

보안, 포트 및 동시 설정

  • Workgroup PDM을 Windows 서비스로 설치할 수 있어야 하며, 다른 응용 프로그램은 Windows 서비스를 블럭 또는 필터할 수 없습니다. 예를 들어, 설치 중 Microsoft AntiSpyware 같은 스파이웨어 차단 프로그램이 허용을 필요로 하는 메시지를 표시하면, 허용을 클릭해서 Workgroup PDM Server를 Windows Service로 설치합니다.
  • 활성 방화벽이 있는 컴퓨터에 Workgroup PDM을 설치하려면 방화벽 설정에서 예외적으로 Workgroup PDM 포트를 활성화해야 합니다.

    일반적인 포트 기본값:

    • 20000(VaultAdmin)
    • 30000(Data)
    • 40000(Request)
    • 80(Viewer)
    퐅, 설정 변경에 관한 자세한 내용은 SolidWorks Explorer 및 SOLIDWORKS Explorer 도움말에서 볼트 관리자용 문제 해결을(를) 참조하고 보안 센터의 경우 Microsoft Windows 도움말을 참조하십시오. Workgroup PDM Vault와 Viewer를 같이 설치하려면, 사용자 정의 대화 상자에서 설치 유형 옵션을 선택해야 합니다.
  • 서버와 해당 포트의 동시 설정이 같아야만 합니다. 예를 들어, 모두 100MB Full이거나 모두 Auto이어야 합니다.

SOLIDWORKS Toolbox 문서

SOLIDWORKS Toolbox 문서란 보통 수정본 통제가 필요없고 Workgroup PDM Vault에 체크인하지 않는 공통 하드웨어 부품을 말합니다. SOLIDWORKS Toolbox와 규격 라이브러리 설정에 관한 자세한 내용을 보려면, Workgroup PDM 온라인 도움말을 참조하십시오.

목차

  • Workgroup PDM Viewer

    Workgroup PDM 소프트웨어가 Microsoft Internet Information Services (IIS)를 사용하여 설치 중 자동으로 가상 디렉토리를 작성합니다.

  • Workgroup PDM Server 설치

    Workgroup PDM Server를 설치하면 관리되는 SOLIDWORKS 프로젝트를 저장하는 데이터베이스인 Workgroup PDM 볼트가 작성됩니다.

  • 클라이언트용 Workgroup PDM 구성

    Workgroup PDM 서버 볼트를 설치한 후 클라이언트용 볼트를 구성할 수 있습니다.

  • 경계 네트워크에 Workgroup PDM Server 및 Viewer 설치

    경계 네트워크(DMZ)에 SOLIDWORKS Workgroup PDM 웹 서버 및 Workgroup PDM Viewer 설치 시 방화벽과 관련이 있습니다.

  • Workgroup PDM Client 액세스

    Workgroup PDM 클라이언트는 Microsoft Windows 로그인 액세스 컨트롤을 사용하고 Workgroup PDM Viewer를 통해 웹에 액세스하고 Workgroup PDM Vault가 업데이트될 때마다 자동으로 업데이트됩니다.

  • Workgroup PDM VaultAdmin 관리

    Workgroup PDM을 설치한 후 볼트 관리자는 다음 작업을 수행해야 합니다.

관련 개념
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁


Workgroup PDM Viewer

Workgroup PDM 소프트웨어가 Microsoft Internet Information Services (IIS)를 사용하여 설치 중 자동으로 가상 디렉토리를 작성합니다.

Viewer를 설치하기 전에 Microsoft Internet Information Services (IIS)를 설치해야 합니다.
필요한 구성 요소:
  • Web Management Tools(웹 관리 도구)
    • IIS Management Console
  • World Wide Web 서비스: 응용 프로그램 개발 기능
    • .NET Extensibility
    • ASP.NET
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
IIS 설치 안내는 Microsoft 문서를 참고합니다.
Workgroup PDM Viewer 설치는 다음 제한 사항이 따릅니다,
  • Web Site Content Directory는 Web Portal 설치 폴더입니다.
  • Viewer 호스트 컴퓨터 이름에 언더스코어(_)를 사용할 수 없습니다.
  • Viewer는 항상 단일 볼트만 선택 할 수 있습니다.

사용자는 Internet Explorer의 주소란에 다음 URL을 입력하여 Workgroup PDM Viewer에 액세스 합니다.

http://ViewerComputerName/pdmweb/

상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
Workgroup PDM Client 액세스
Workgroup PDM VaultAdmin 관리
관련 태스크
Workgroup PDM Server 설치
클라이언트용 Workgroup PDM 구성


Workgroup PDM Server 설치

Workgroup PDM Server를 설치하면 관리되는 SOLIDWORKS 프로젝트를 저장하는 데이터베이스인 Workgroup PDM 볼트가 작성됩니다.

  1. SOLIDWORKS 설치 관리자를 시작합니다. SOLIDWORKS 설치 시작을 참조하십시오.
  2. 시작 화면에서 다음을 선택합니다.

    • 서버 제품
    • 이 컴퓨터에 SOLIDWORKS Workgroup PDM Server(볼트)를 설치합니다.

  3. 요약 화면에서 변경을 클릭하여 정품 확인 코드를 획득합니다. 다음 방법 중 하나를 사용하여 이 코드를 획득할 수 있습니다.
    • 인터넷 연결
      1. 제공되는 필드에 SOLIDWORKS 제품 번호 및 전자우편 주소를 입력합니다.
      2. 정품 확인(자동)을 선택하고 코드 가져오기를 클릭합니다.
    • 전자우편
      1. 컴퓨터가 인터넷에 연결할 수 없는 경우 전자 메일로 정품 확인(수동)을 클릭합니다. 설치 관리자는 정품 확인 요청 파일을 생성합니다.
      2. 저장을 클릭하여 시스템에 로컬로 파일을 저장합니다.
      3. 화면의 지시에 따르고 정품 확인 코드를 입력합니다.
  4. 요약으로 돌아가기를 클릭합니다.
  5. 요약 화면에서 지금 설치를 클릭합니다.
상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
Workgroup PDM Client 액세스
Workgroup PDM VaultAdmin 관리
관련 태스크
클라이언트용 Workgroup PDM 구성
SOLIDWORKS 설치 시작
관련 참조
Workgroup PDM Viewer


클라이언트용 Workgroup PDM 구성

Workgroup PDM 서버 볼트를 설치한 후 클라이언트용 볼트를 구성할 수 있습니다.

  1. 기본 사용자 이름과 암호로 VaultAdmin(SOLIDWORKS Explorer로 설치됨)에 로그인합니다
  2. VaultAdmin에서 사용자와 그룹 계정, 프로젝트 폴더, 권한 등을 지정합니다.

    자세한 내용은 Workgroup PDM 도움말을 참고합니다.

  3. Microsoft Windows 사용자 이름과 비밀번호와 일반적으로 다른 서버 컴퓨터 이름, 사용자 이름과 비밀번호를 클라이언트 사용자에게 전자메일로 보냅니다.
상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
Workgroup PDM Client 액세스
Workgroup PDM VaultAdmin 관리
관련 태스크
Workgroup PDM Server 설치
관련 참조
Workgroup PDM Viewer

다른 볼트 위치에 연결하기 위해 Workgroup PDM Viewer 설정

Windows 레지스트리를 사용하여 다른 볼트 위치에 연결하기 위해 Workgroup PDM Viewer를 설정할 수 있습니다.

  1. 볼트 컴퓨터 값을 변경하여 레지스트리 경로 업데이트:

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\Vault Computer

  2. Workgroup PDM Viewer를 재설치합니다. 볼트 컴퓨터 이름 대화 상자에서, 새 컴퓨터 이름을 입력합니다.

문서 다운로드용 Mime 형식 설정

Windows 레지스트리 설정을 사용하여 문서 다운로드를 위한 mime 형식을 설정할 수 있습니다.

기본값으로, Viewer는 일반 mime 형식인 “application/octet-stream”과 함께 Open Document 요청을 보냅니다. 그러면, Microsoft Internet Explorer는 제공된 파일 확장명으로 요청된 문서를 엽니다. Windows 레지스트리의 Mime Types 레지스트리 하위 키를 수정하여 추가 mime 형식을 매핑하거나 mime 형식 매핑을 끌 수 있습니다.

  • 추가 mime 형식을 매핑하려면 다음 레지스트리 하위 키 아래 추가 문자열 값을 작성합니다.

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Mime Types

    형식에서:

    "ext" = "mime type"

    예:

    "dxf" = "image/vnd.dxf"

    값을 추가하기 전에 레지스트리 서브키를 작성해야 합니다.

    mime 형식 매핑을 끄고 Use Custom MIME Types 레지스트리 값을 0(영)으로 변경합니다.

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    웹 서버를 다시 시작하지 않아도 이 설정이 활성화 됩니다.


경계 네트워크에 Workgroup PDM Server 및 Viewer 설치

경계 네트워크(DMZ)에 SOLIDWORKS Workgroup PDM 웹 서버 및 Workgroup PDM Viewer 설치 시 방화벽과 관련이 있습니다.

Workgroup PDM Viewer 클라이언트는 HTTP 또는 HTTPS 포트를 통해 Web server와 통신하므로, 이 포트는 Web server가 설치된 Internet Information Server (IIS) 시스템 상에서 반드시 열려 있어야 합니다.

  • HTTP 프로토콜의 경우, 기본 포트는 80 입니다.
  • HTTPS 프로토콜 (SSL)의 경우, 기본 포트는 443 입니다.

Web Viewer 클라이언트 자체에는 방화벽 예외가 필요하지 않습니다.

Web server 시스템은 다음과 같은 기본 포트를 통해 Vault 서버에 연결될 수 있음을 유의합니다.

  • 30000(Data)
  • 40000(Request)

목차

  • 경계 네트워크에서 Workgroup PDM Viewer를 위한 네트워크 구성

    네트워크 구성에서는 경계 서브넷 상에서 경계 네트워크 서버를 설정하고 내부/외부 네트워크로 통신하는 방법을 설명합니다.

  • Workgroup PDM Web Server 및 Viewer의 설치 및 구성

    경계 네트워크에서 Workgroup PDM 웹 서버를 설치할 때 구성 요소의 설치 위치가 매우 중요합니다.

상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
Workgroup PDM Client 액세스
Workgroup PDM VaultAdmin 관리
관련 태스크
Workgroup PDM Server 설치
클라이언트용 Workgroup PDM 구성
관련 참조
Workgroup PDM Viewer


경계 네트워크에서 Workgroup PDM Viewer를 위한 네트워크 구성

네트워크 구성에서는 경계 서브넷 상에서 경계 네트워크 서버를 설정하고 내부/외부 네트워크로 통신하는 방법을 설명합니다.

경계 네트워크 서버는 내부 방화벽을 통해 LAN과 통신합니다. 또한 외부 방화벽, 라우터, 및 부하 분산 장치를 통해 외부 네트워크와 통신합니다.

Internet Explorer 클라이언트는 포트 80 (SSL 사용 시 443)으로 Workgroup PDM Viewer/IIS 서버에 연결합니다. 그 후 Workgroup PDM Viewer가 포트 30000 또는 40000을 사용하여 Vault 서버에 연결합니다. Vault 서버는 요청한 정보를 다시 Workgroup PDM Viewer로 전송하고, 이 정보는 다시 Internet Explorer 클라이언트로 보내집니다.

경계 네트워크 웹 서버에는 두 개의 IP 주소가 있습니다.

  • LAN 상에 있는 내부 IP 주소
  • ISP에서 제공하는 공용 IP 주소

경계 네트워크에 있는 웹 서버는 부하 분산 장치 뒤에 위치하고 있습니다. 관리 작업을 위해 직접 웹 서버에 연결할 수 있지만, 경계 네트워크에 있는 서버로의 모든 웹 서비스 트래픽은 부하 분산 장치를 통해 처리되어야 합니다.

부하 분산 장치는 네트워트 레그 상에서 서버 하드웨어 IP 주소를 일반에게 공개된 가상 IP (VIP)로 변환합니다. 따라서 네트워크에 연결된 상태에서 VIP나 웹 서버 URL을 찾아보면, 해당 사이트를 볼 수 있습니다.

외부 방화벽은 분산 장치 VIP를 공개적으로 라우팅할 수 있는 주소로 변환합니다.

상위 주제
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
관련 태스크
Workgroup PDM Web Server 및 Viewer의 설치 및 구성


Workgroup PDM Web Server 및 Viewer의 설치 및 구성

경계 네트워크에서 Workgroup PDM 웹 서버를 설치할 때 구성 요소의 설치 위치가 매우 중요합니다.

  • 경계 서브넷에 IIS에서 사용 가능한 웹 서버를 설치합니다.
  • 경계 서브넷에 IIS에서 사용 가능한 Workgroup PDM Viewer를 설치합니다.
  • Workgroup PDM Vault를 주 도메인이나 로컬 인트라넷에 있는 내부 네트워크에 설치합니다.

경계 네트워크에 Workgroup PDM Viewer 설치 및 구성 시 필수 구성 요소:

  • Microsoft IIS 6.0 이상
  • 경계 서브넷 상에서 인터넷 서비스 제공자(ISP)에 의해 지정된 웹 서버로의 공용 IP 주소

Workgroup PDM 구성 요소 설치 및 구성하기:

  1. 경계 서브넷 서버 시스템에 Microsoft IIS를 설치합니다.
  2. SOLIDWORKS Workgroup PDM Server 설치 작업을 두 번 수행합니다.
    1. 먼저 볼트 서버에 Vault 구성 요소를 설치합니다.
    2. 설치 관리자를 두 번 실행하여 IIS 웹 서버에 Workgroup PDM Viewer와 Viewer 사용권 구성 요소를 설치합니다. 볼트 서버 컴퓨터 이름을 입력하여 웹 포털이 Vault 서버 서비스를 검색할 위치를 알 수 있도록 합니다.

    설치 작업을 수행할 때, PDMWeb 프로그램은 기본 IIS 웹 사이트에 자동으로 추가됩니다.

  3. 내부 네트워크의 방화벽 포트가 30000 및 40000으로 열려 있음을 확인합니다.
  4. 내부 서버가 경계 서버 시스템에서 고정 IP 주소를 가지고 있는 경우, C:\Windows\system32\drivers\etc\hosts 파일을 편집합니다. 시스템 이름을 IP 주소로 매핑하여 경계 서버가 내부 서버와 통신할 수 있도록 합니다.
    1. 메모장과 같은 텍스트 편집기에 호스트 파일을 엽니다.
    2. Vault 서버 IP 주소 및 이름에 새 행을 삽입합니다.
    3. 호스트 파일을 저장합니다.
상위 주제
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
관련 개념
경계 네트워크에서 Workgroup PDM Viewer를 위한 네트워크 구성


Workgroup PDM Client 액세스

Workgroup PDM 클라이언트는 Microsoft Windows 로그인 액세스 컨트롤을 사용하고 Workgroup PDM Viewer를 통해 웹에 액세스하고 Workgroup PDM Vault가 업데이트될 때마다 자동으로 업데이트됩니다.

Workgroup PDM 클라이언트로 로그인하기: | Workgroup PDM의 클라이언트 사용자 이름과 비밀번호가 Microsoft Windows 로그인과 다릅니다. 로그인에 관한 정보는 시스템 관리자에게 문의하십시오.
Workgroup PDM Viewer에 연결하기 | Viewer 연결 URL에 대한 정보는 시스템 관리자에게 문의하십시오.
Workgroup PDM 업데이트하기 | SOLIDWORKS PDM 클라이언트(SOLIDWORKS 애드인과 Contributor)는 볼트가 업데이트된 시간을 감지합니다. 클라이언트를 업데이트 하기 위해 서비스 팩을 다운로드할 필요는 없습니다.
상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
Workgroup PDM VaultAdmin 관리
관련 태스크
Workgroup PDM Server 설치
클라이언트용 Workgroup PDM 구성
관련 참조
Workgroup PDM Viewer


Workgroup PDM VaultAdmin 관리

Workgroup PDM을 설치한 후 볼트 관리자는 다음 작업을 수행해야 합니다.

  • VaultAdmin에 로그인
  • 볼트 관리자의 비밀번호 변경
  • 사용자 계정 작성
  • 계정 이름과 비밀번호를 사용자에게 통보

자세한 내용은 SOLIDWORKS 주 도움말에서 SOLIDWORKS Workgroup PDM을 참조하십시오.

상위 주제
SOLIDWORKS Workgroup PDM
관련 개념
경계 네트워크에 Workgroup PDM Server 및 Viewer 설치
Workgroup PDM Client 액세스
관련 태스크
Workgroup PDM Server 설치
클라이언트용 Workgroup PDM 구성
관련 참조
Workgroup PDM Viewer

Workgroup PDM VaultAdmin에 최초 로그인

Workgroup PDM VaultAdmin에 처음으로 로그인할 때 Workgroup PDM 관리자 이름과 비밀번호를 지정하고 Workgroup PDM Vault를 호스팅하는 컴퓨터 수를 지정합니다.

  1. Windows에서 시작 > 모든 프로그램 > SOLIDWORKS 버전 > Workgroup PDM VaultAdmin를 클릭합니다.
  2. 대화 상자에서 다음 정보를 입력합니다.

    이름 | pdmwadmin
    비밀번호 | pdmwadmin
    볼트 컴퓨터 | 볼트가 설치된 컴퓨터의 호스트 이름입니다. 볼트가 설치된 컴퓨터에서 VaultAdmin을 실행하면, localhost를 입력하십시오.

  3. 로그인을 클릭합니다.
보안 유지상, 관리자는 가능한 빨리 비밀 번호를 변경하는 것이 좋습니다. VaultAdmin에서 사용자와 그룹 탭을 선택하십시오.

Workgroup PDM Vault Server 업그레이드

SOLIDWORKS 업데이트 확인, SOLIDWORKS 설치 DVD 또는 로컬 폴더에 직접 다운로드한 Workgroup PDM 업그레이드 파일을 사용하여 Workgroup PDM Vault Server를 업그레이드할 수 있습니다.

Workgroup PDM Vault Server의 한 버전만을 설치할 수 있습니다.
  1. 모든 사용자가 볼트에서 로그아웃하도록 한 다음 Workgroup PDM 볼트를 잠굽니다.
  2. 볼트 데이터를 백업합니다.
  3. Microsoft Windows 제어판 프로그램 추가/제거를 사용하여 Workgroup PDM Server의 현 버전을 제거합니다.
  4. Workgroup PDM Server의 새 버전을 설치합니다.
    • SOLIDWORKS 업데이트 확인을 사용하는 방법:
      1. Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.
      2. 선택 가능한 최근 버전 대화 상자에서 새 버전 다운로드 및 설치를 선택하고 설치할 버전을 선택한 후 다음을 클릭합니다.

        SOLIDWORKS 설치 관리자의 새 버전이 다운로드 후 실행됩니다.

    • SOLIDWORKS 설치 DVD를 사용하려면 DVD를 드라이브에 삽입하고 SOLIDWORKS 설치 관리자 지침을 따릅니다.
    • 직접 다운로드한 Workgroup PDM 설치 파일(pdmwserver.exe)을 사용하려면 파일을 더블 클릭한 후 Workgroup PDM Server 업그레이드 지침을 따릅니다.
  5. SOLIDWORKS 작업 스케줄러를 사용해 볼트 안의 Workgroup PDM 파일을 업데이트합니다.
  6. 볼트 잠금을 해제한 후 사용자에게 다시 사용할 수 있음을 알립니다.

Workgroup PDM 클라이언트 업그레이드

볼트를 업데이트한 후 처음으로 로그인할 때 클라이언트에게 업데이트를 알리는 메시지가 나타납니다. 클라이언트 업데이트에 서비스 팩은 필요하지 않습니다.

볼트와 비교한 클라이언트 상태 | 작업
볼트와 동일한 버전 | 없음
같은 주요 릴리즈, 볼트보다 최신 버전 | 없음
최신의 주요 릴리즈, 볼트보다 최신 버전 | 로그인이 차단됨
같은 주요 릴리즈, 볼트보다 이전 버전 | 선택적인 업그레이드
이전 주요 릴리즈, 볼트보다 이전 버전 | 업데이트 필요

자세한 내용은 Workgroup PDM 도움말에서 클라이언트 업데이트를 참고합니다.


SOLIDWORKS PDM

SOLIDWORKS PDM은 기존에 SOLIDWORKS Enterprise PDM으로 알려졌던 클라이언트/서버 아키텍처를 기반으로 하는 문서 관리 제품입니다.

SOLIDWORKS PDM은 두 가지 유형으로 제공됩니다.
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM은 Microsoft SQL Server 데이터베이스를 사용하여 파일 볼트를 관리합니다.

이 표에는 각 제품 유형에 사용할 수 있는 데이터베이스 시스템, 서버 부품 및 클라이언트 옵션이 나열됩니다.
 | PDM Standard | PDM Professional
사용 영역 | 중소규모 사무실 네트워크, 최대 5명의 동시 사용자 | 대규모 사무실 네트워크, 다수의 동시 사용자
한계(L) | CPU 1개, 1GB 메모리, 데이터베이스 크기 10GB | 한계 없음
데이터베이스 관리 시스템 | Microsoft SQL Server Express 2014(SOLIDWORKS 설치 포함) | Microsoft SQL Server 2014(SOLIDWORKS 별도 포함) 또는 기존 설치된 Microsoft SQL Server 2014, 2012 또는 2008 R2 인스턴스
SolidNetWork License Manager가 필요합니까? | 예 | 예
보관 서버와 데이터베이스 서버가 포함됩니까? | 예 | 예
SOLIDWORKS PDM 웹 서버 및 Web2 서버가 포함됩니까? | No | 예
클라이언트 유형 | 고유 | 고유, 브라우저 기반
CAD 편집기용 클라이언트 애드인 | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration, Autodesk Inventor, AutoCAD
기여 피처용 클라이언트 애드인 | DraftSight | DraftSight, Microsoft Office Integration
뷰어용 클라이언트 애드인 |  | Microsoft Office 통합

목차

  • PDM 서버 부품 나열

  • 클라이언트 선택

    PDM 환경에 따라 필요한 클라이언트를 결정해야 합니다.

  • PDM Server 설치 전에 해야 할 작업

    PDM 서버 구성 요소를 설치하기 전에 다음 요구 사항에 주의하십시오.


PDM 서버 부품 나열

이 표에는 SOLIDWORKS PDM 서버의 서버 부품이 요약되어 있습니다.

서버 | 함수 | 설치
PDM Standard용 Microsoft SQL Server Express | SOLIDWORKS PDM 데이터 볼트에서 데이터를 관리합니다. | PDM Standard를 설치하거나 이전에 사용권을 구입하고 설치한 버전을 사용할 수 있습니다.
PDM Professional용 Microsoft SQL Server | SOLIDWORKS PDM 데이터 볼트에서 데이터를 관리합니다. | PDM Professional이 별도로 제공됩니다. 또한 이전에 사용권을 구입하고 설치한 버전을 사용할 수도 있습니다.
SolidNetWork License Manager | SOLIDWORKS PDM 사용권을 관리합니다. | 새 볼트를 구성하려면 먼저 설치해야 합니다. SLDIM을 사용하는 경우 SOLIDWORKS PDM 서버 구성 요소를 설치할 수 있습니다.
보관 서버 | 클라이언트와 파일 볼트 보관 간에 파일 전송을 관리하고 사용자와 자격 증명을 관리합니다. | - 필수 PDM Standard 또는 Professional을 설치합니다.
데이터베이스 서버 | 업데이트를 위해 PDM 데이터베이스를 폴링, 데이터 불러오기 및 내보내기 규칙을 관리, 메시지 시스템 관리, 복제 및 콜드 스토리지 일정을 예약합니다. | - 필수 PDM Standard 또는 Professional을 설치합니다.
웹 서버 및 웹2 서버 | 브라우저 기반 클라이언트에서 인터넷을 통해 파일 볼트에 대한 액세스를 제공합니다. | 선택 사항. PDM Professional만 설치합니다.

보관 서버는 설치된 컴퓨터의 시스템 계정에서 서비스로 실행됩니다. 한 보관 서버에서 같은 컴퓨터의 여러 파일 볼트를 호스팅할 수 있습니다.

스탠드얼론 설치에서 보관 서버, 데이터베이스 서버 및 라이센스 서버는 물론 SQL Express 또는 SQL Server 데이터베이스를 모두 같은 컴퓨터에 설치할 수 있습니다.

분산 환경에서는 서버 부품을 다른 컴퓨터에 둘 수 있습니다. 또한 여러 개의 보관 서버를 같은 파일 볼트 보관의 복제된 사본을 호스팅하도록 다른 컴퓨터에 설정할 수 있습니다. SOLIDWORKS Professional PDM 복제 안내서을(를) 참조하십시오.

상위 주제
SOLIDWORKS PDM
관련 개념
클라이언트 선택
PDM Server 설치 전에 해야 할 작업


클라이언트 선택

PDM 환경에 따라 필요한 클라이언트를 결정해야 합니다.

이 표에 SOLIDWORKS PDM Standard용 클라이언트가 요약되어 있습니다.
표준 클라이언트 유형 | 설명
CAD 편집기 | SOLIDWORKS, DWG/DXF 및 Microsoft Office 파일 작업을 지원합니다. Office 플러그인이 처리하는 모든 파일 형식은 SOLIDWORKS PDM Standard와 같은 방식으로 동작합니다.
참가자 | SOLIDWORKS, DWG/DXF 및 Microsoft Office 파일 작업을 지원합니다.
뷰어 | 파일 볼트에 대한 읽기 전용 액세스만 허용합니다. 사용자는 워크플로를 통해 파일을 전환할 수는 있지만 파일을 추가하거나 수정(체크아웃, 체크인, 업데이트)할 수는 없습니다.
이 표에 SOLIDWORKS PDM Professional용 클라이언트가 요약되어 있습니다.
Professional 클라이언트 유형 | 설명
CAD 편집기 및 Web | SOLIDWORKS와 같은 CAD 형식을 미리 보거나 관리할 수 있도록 모든 파일 유형을 지원합니다. CAD 애드인은 CAD 응용 프로그램 내에서 사용자가 SOLIDWORKS PDM Professional에 액세스할 수 있도록 허용합니다. 원격 사용자는 Web 및 Web2 클라이언트를 사용하여 인터넷을 통해 볼트를 검색하고 기본 기능을 수행할 수 있습니다.
Contributor & Web | CAD 파일을 포함한 모든 파일 유형 작업을 지원합니다. 그러나 CAD 애드인의 경우 이 클라이언트 유형에서 지원되지 않습니다. 원격 사용자는 Web 및 Web2 클라이언트를 사용하여 인터넷을 통해 볼트를 검색하고 기본 기능을 수행할 수 있습니다.
뷰어 | 파일 볼트에 대한 읽기 전용 액세스만 허용합니다. 사용자는 워크플로를 통해 파일을 전환할 수는 있지만 파일을 추가하거나 수정(체크아웃, 체크인, 업데이트)하거나 CAD 애드인을 사용할 수는 없습니다.
상위 주제
SOLIDWORKS PDM
관련 개념
PDM 서버 부품 나열
PDM Server 설치 전에 해야 할 작업


PDM Server 설치 전에 해야 할 작업

PDM 서버 구성 요소를 설치하기 전에 다음 요구 사항에 주의하십시오.

  • 서버와 클라이언트를 설치하려는 컴퓨터에서 모든 관리 권한을 얻습니다.
  • 데이터베이스 서버가 TCP 포트 3030으로 관리 서버에 액세스할 권한과 TCP 포트 1433으로 SQL Server에 액세스할 권한이 있는지 확인합니다.
  • 기존 SQL Server Express 또는 SQL Server 데이터베이스를 사용하려는 경우 SQL Server 데이터베이스 이름 및 데이터베이스에 대한 읽기/쓰기 액세스 권한이 있는 SQL Server 관리자 또는 데이터베이스 소유자의 계정 ID와 암호가 있어야 합니다. TEW 사용자는 사용할 수 없습니다.
  • PDM 클라이언트가 시스템에 이미 설치되어 있는 경우 이를 다시 삭제합니다. 동일한 시스템의 PDM 서버 및 PDM 클라이언트가 필요한 경우 SOLIDWORKS PDM 서버 설치 과정을 사용하여 둘 다 설치해야 합니다.

목차

  • SLDIM로 PDM 서버 설치

    PDM Standard PDM 서버 설치 시 동일한 컴퓨터에 보관 서버, 데이터베이스 서버 및 PDM CAD Editor 클라이언트를 설치할 수 있습니다. 별도로 클라이언트 설치를 실행할 필요가 없습니다.

  • SLDIM을 사용하여 PDM 클라이언트 설치

상위 주제
SOLIDWORKS PDM
관련 개념
PDM 서버 부품 나열
클라이언트 선택


SLDIM로 PDM 서버 설치

PDM Standard PDM 서버 설치 시 동일한 컴퓨터에 보관 서버, 데이터베이스 서버 및 PDM CAD Editor 클라이언트를 설치할 수 있습니다. 별도로 클라이언트 설치를 실행할 필요가 없습니다.

PDM Professional PDM 서버 설치 시 이러한 구성 요소와 Web 서버 및 Web2 Server를 포함할 수도 있습니다.

PDM Server 및 해당 구성 요소 설치 방법:

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 서버 제품을 선택하고 다음 사항을 확인합니다.
    • SOLIDWORKS PDM 서버 구성 요소를 설치합니다.
    • SolidNetWork License Manager를 설치합니다.

      SolidNetwork License Manager가 설치되면 옵션이 표시되지 않습니다.

  3. SolidNetwork License Manager 옵션 페이지가 표시되면 제품 번호를 입력하고 디렉터리 위치를 지정하고 다음을 클릭합니다.
  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지의 SOLIDWORKS PDM 서버에서 변경을 클릭합니다.
  6. SOLIDWORKS PDM Server 옵션 페이지에서
    1. 서버 제품을 선택하려면 SOLIDWORKS PDM Standard 또는 Professional을 클릭합니다.
    2. 설치 위치의 경우 찾아보기를 클릭하여 파일 경로를 지정하십시오.
    3. 피처 선택에서

      1. 보관 서버, 데이터베이스 서버 및 클라이언트를 클릭하여 동일한 컴퓨터에 해당 구성요소를 설치합니다. 분산 환경에서는 다른 컴퓨터에서 설치 관리자를 실행하여 보관 서버 및 데이터베이스 서버를 설치할 수 있습니다.
        PDM 클라이언트가 이미 컴퓨터에 설치된 경우 설치를 취소하고 클라이언트를 제거해야 합니다. 그 다음 SLDIM을 실행하여 클라이언트와 함께 PDM 서버를 설치할 수 있습니다.
      2. PDM Professional을 설치한 경우 Web 서버 및 Web2 Server를 클릭할 수도 있습니다.

    4. SQL Server에서는 PDM 서버(PDM Standard용 SQL Server Express)와 함께 제공되는 데이터베이스 및 관리 도구의 새 인스턴스를 설치하거나 데이터베이스 이름, 사용자 이름, 기존 인스턴스의 비밀번호를 지정할 수 있습니다.

      SQL Server 풀 에디션에는 별도로 PDM Professional이 함께 제공됩니다.

    5. 요약으로 돌아가기를 클릭합니다.
  7. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.

    SOLIDWORKS 설치 관리자에서 설치가 완료되면 보관 서버 설정 도구를 시작합니다. 마법사의 메시지에 따라 보관 서버를 구성합니다.

보관 서버, 데이터베이스 서버, Web 및 Web2 Server, SQL Server 데이터베이스를 설정, 구성, 문제 해결하는 방법에 대해 알아 보려면 SOLIDWORKS PDM 2016 설치 안내서에서 관련 주제를 참조하십시오.
상위 주제
PDM Server 설치 전에 해야 할 작업
관련 태스크
SLDIM을 사용하여 PDM 클라이언트 설치


SLDIM을 사용하여 PDM 클라이언트 설치

PDM 클라이언트 설치하는 방법:

  1. SOLIDWORKS 설치 관리자를 시작합니다.
  2. 시작 페이지에서 개별 설치를 선택합니다.
  3. 제품 번호 페이지에서 다음을 클릭합니다.

    SOLIDWORKS PDM은 제품 번호를 요구하지 않습니다.

  4. 시스템 경고의 지침을 따르고 다음을 클릭합니다.
  5. 요약 페이지의 제품 아래에서 변경을 클릭합니다.
  6. 제품 선택 페이지에서 다른 패키지나 제품을 선택합니다를 클릭합니다.
  7. 표시할 패키지를 선택합니다 대화 상자에서 SOLIDWORKS의 버전을 선택합니다. 선택을 마치면 확인을 클릭합니다.
  8. 제품 선택 페이지에서 SOLIDWORKS PDM 클라이언트를 선택합니다. 그런 다음 eDrawings를 선택하여 PDM 미리보기 기능을 활성화합니다. SOLIDWORKS PDM Professional을 사용하는 경우 항목 탐색기를 선택할 수도 있습니다.
  9. 요약 페이지에서 SOLIDWORKS PDM 옵션을 확장하고 변경을 클릭합니다.
  10. SOLIDWORKS PDM 클라이언트 옵션 페이지에서 다음 사항을 선택하고 요약으로 돌아가기를 클릭합니다.
    • PDM 제품 유형
    • PDM 클라이언트 유형
    • 애드인
  11. 요약 페이지에서 SOLIDWORKS 사용권 계약의 조건에 동의하고 지금 설치를 클릭합니다.
상위 주제
PDM Server 설치 전에 해야 할 작업
관련 태스크
SLDIM로 PDM 서버 설치


SOLIDWORKS Electrical

SOLIDWORKS Electrical은 지능적인 설계 도구, 포괄적인 파트 데이터베이스, 2D 개요도와 3D 모델의 실시간 통합을 통해 전기 시스템 설계를 단순화합니다.

SOLIDWORKS Electrical의 주요 부품은 다음과 같습니다.
  • SOLIDWORKS Electrical Schematic - 2D 동적 전기 배선 작성을 위한 도구입니다.
  • SOLIDWORKS Electrical 3D - 2D 개요도와 3D 모델을 통합하여 3D로 케이블과 와이어를 비롯한 전기 시스템을 제작할 수 있도록 해주는 도구입니다.
  • 데이터 - 사용자와 공유할 수 있는 파트, 기호, 라이브러리 및 카탈로그의 데이터베이스입니다.
  • Collaborative Server - 전기 배선 도면을 열고 업데이트할 수 있도록 관리해주는 유틸리티로,
  • Microsoft SQL Server 데이터베이스의 인스턴스입니다.

SOLIDWORKS Electrical에는 Microsoft SQL Server 데이터베이스가 필요합니다. 기존의 데이터베이스를 사용하거나 설치 시 새 인스턴스를 사용할 수 있습니다.

모든 SOLIDWORKS Electrical의 부품을 같은 컴퓨터에 설치할 수 있습니다. 이러한 설치를 일반적으로 스탠드얼론 설치라 합니다. 프로젝트 도면 및 보고서와 같은 모든 프로그램 데이터가 하나의 시스템에 저장됩니다. SOLIDWORKS Electrical을 설치하려면 시스템에 대한 모든 관리 권한이 있어야 합니다.

SOLIDWORKS Electrical 부품을 클라이언트/서버 응용 프로그램으로 설치할 수도 있습니다. 데이터를 네트워크 서버에 저장해야 하거나, 네트워크 서버에 모든 SOLIDWORKS Electrical 데이터베이스를 저장하는 기존의 SQL Server 데이터베이스가 있는 경우 이렇게 설치해야 합니다. 이 경우 서버와 클라이언트 시스템 모두에서 모든 관리 권한이 필요합니다. 또한 클라이언트 시스템은 서버에 네트워크 액세스가 가능해야 하고 프로젝트, 라이브러리 및 기호 작성을 위한 읽기/쓰기 권한이 있어야 합니다.

목차

  • SOLIDWORKS Electrical에서 데이터 관리하기

  • SOLIDWORKS Electrical의 설치 요구 사항


SOLIDWORKS Electrical에서 데이터 관리하기

대다수 프로그램에서는 모든 프로그램 데이터가 포함된 하나의 데이터베이스를 사용합니다. 그러나 SOLIDWORKS Electrical은 그렇지 않습니다. SOLIDWORKS Electrical의 각 프로젝트에는 고유한 ID 번호가 지정되고, 모든 프로젝트에는 이 고유한 ID 번호로 식별될 수 있는 관련 데이터베이스가 있습니다. 예를 들어, SOLIDWORKS Electrical Project Manager에서 ID 번호112로 프로젝트를 찾을 경우 연결된 데이터베이스의 이름은 “tew_project_data_112”입니다.

각 프로젝트마다 고유한 데이터베이스를 가지는 이유는 처리 시간이 상당히 줄어들기 때문입니다. 또한 심각한 데이터베이스 오류가 발생하더라도 프로젝트 하나만 영향을 받기 때문에 대다수 프로그램 정보의 무결성이 유지됩니다.

그러나 일부 기업에는 새 데이터베이스 작성을 제한하는 정책이 있습니다. SOLIDWORKS Electrical을 실행하려면 사용자가 새 데이터베이스를 작성하는 데 제한이 있어서는 안 됩니다. 사용자가 새 데이터베이스를 작성하지 못하도록 만드는 구성 설정이 없는지 시스템 또는 데이터베이스 관리자에게 확인하십시오.
상위 주제
SOLIDWORKS Electrical
관련 개념
SOLIDWORKS Electrical의 설치 요구 사항


SOLIDWORKS Electrical의 설치 요구 사항

현재 시스템 요구 사항은 http://solidworks.com/System_Requirements를 참고하십시오.

목차

  • 개별 및 서버 옵션

    SOLIDWORKS Electrical을 개별 모드나 서버 모드로 설치할 수 있습니다.

  • 데이터 위치 지정

  • Collaborative Server 설정

  • Microsoft SQL Server 설정

상위 주제
SOLIDWORKS Electrical
관련 개념
SOLIDWORKS Electrical에서 데이터 관리하기


개별 및 서버 옵션

SOLIDWORKS Electrical을 개별 모드나 서버 모드로 설치할 수 있습니다.

SOLIDWORKS Electrical은 기존 인스턴스든, 새 인스턴스든 상관없이 SQL Server의 인스턴스에 연결해야 합니다.

개별 모드에서는 다음과 같은 부품을 설치할 수 있습니다.
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • 데이터
  • SQL Server 데이터베이스의 새 인스턴스
서버 모드에서는 다음과 같은 부품을 설치할 수 있습니다.
  • SQL Server 데이터베이스의 새 인스턴스
  • Collaborative Server
  • 데이터

개별 모드와 서버 모드의 부품을 결합하여 클라이언트/서버 환경을 작성할 수 있습니다. 예를 들어, 클라이언트 시스템에는 SOLIDWORKS Electrical Schematic과 SOLIDWORKS Electrical 3D를 설치하고, 서버 시스템에는 모든 서버 부품을 설치할 수 있습니다.

상위 주제
SOLIDWORKS Electrical의 설치 요구 사항
관련 개념
데이터 위치 지정
Collaborative Server 설정
Microsoft SQL Server 설정


데이터 위치 지정

데이터 위치에 파트, 템플릿, 2D 및 3D 기호와 같은 프로그램 데이터를 저장할 디렉터리를 선택합니다. 이 위치는 전용 디렉터리여야 합니다. 루트 디렉터리이거나 SOLIDWORKS 데이터를 저장하는 데 사용한 디렉터리는 안 됩니다.

기본 디렉터리는 C:\ProgramData\SOLIDWORKS Electrical입니다. 사용 가능한 모든 프로그램 데이터가 저장되는 업데이트의 폴더가 같은 디렉터리에 추가됩니다.

SOLIDWORKS Electrical을 처음 시작하면 데이터 업데이트 마법사가 표시됩니다. 이 마법사에서 응용 프로그램과 SQL Server 데이터베이스에 추가할 데이터를 선택할 수 있습니다.
상위 주제
SOLIDWORKS Electrical의 설치 요구 사항
관련 개념
개별 및 서버 옵션
Collaborative Server 설정
Microsoft SQL Server 설정


Collaborative Server 설정

SOLIDWORKS Electrical을 실행하려면 Microsoft SQL Server 데이터베이스를 호스팅하는 시스템에 Collaborative Server를 설치해야 합니다.

Collaborative Server는 항상 실행 중이어야 하고, 방화벽과 바이러스 스캐너를 통해 클라이언트와 언제나 원활하게 양방향 통신을 수행할 수 있어야 합니다.

개별 모드나 서버 모드로 Collaborative Server를 설치하려면 다음 파라미터를 지정해야 합니다.
  • 컴퓨터 이름, 예: LOCALHOST
  • 컴퓨터의 IP 주소, 예: 127.0.0.1
  • 포트 번호, 예: 26666

원활한 양방향 통신을 제공하려면 Collaborative Server가 설치된 시스템에서 포트 번호 26666이 사용 가능한지 확인합니다. 포트 26666에 액세스할 수 없는 경우, 시스템 관리자에게 문의해 SOLIDWORKS Electrical에서 다른 포트에 액세스할 수 있도록 하십시오.

상위 주제
SOLIDWORKS Electrical의 설치 요구 사항
관련 개념
개별 및 서버 옵션
데이터 위치 지정
Microsoft SQL Server 설정


Microsoft SQL Server 설정

어떤 종류의 SOLIDWORKS Electrical 설치에서든 SQL Server 데이터베이스의 인스턴스를 사용할 수 있어야 합니다. SQL Server 데이터베이스가 이미 시스템에 설치되어 있는 경우 기존 데이터베이스를 사용하거나 SOLIDWORKS Electrical 설치 시 새 인스턴스를 설치할 수 있습니다.

SQL Server의 새 인스턴스를 설치하면 SOLIDWORKS 설치 시 Microsoft SQL Server Express의 무료 버전이 제공됩니다. 이 버전은 CPU 1개, 메모리 1GB 및 데이터 10GB로 제한됩니다. 이 메모리와 CPU 제한은 동시 사용자 5명을 지원하기에 충분합니다.

SQL Server Express Edition을 설치할 경우 서버 소프트웨어와 하드웨어가 http://solidworks.com/System_Requirements에 나와 있는 요구 사항을 충족하는지 확인합니다.

그러나 같은 서버에 동시 사용자가 6명 이상인 경우 SQL Server의 전체 버전을 구입해 설치해야 하고, 기존 SQL Server 인스턴스를 사용하는 SOLIDWORKS Electrical 설치 방법에 설명된 워크플로를 따라야 합니다.

SQL Server Express Edition에 대한 자세한 내용은 Microsoft SQL Server 문서를 참고하십시오.

상위 주제
SOLIDWORKS Electrical의 설치 요구 사항
관련 개념
개별 및 서버 옵션
데이터 위치 지정
Collaborative Server 설정

SQL Server의 새 인스턴스

SQL Server의 새 인스턴스를 설치할 경우 서버와 모든 클라이언트 시스템에 대한 모든 관리 권한이 필요합니다. 프로젝트, 라이브러리, 기호 및 기타 프로젝트 데이터를 작성 및 수정할 수 있도록 클라이언트에게 데이터베이스에 대한 읽기/쓰기 권한이 있는지도 확인해야 합니다.

SQL Server의 새 인스턴스를 설치할 경우 기본값 이외의 이름을 선택합니다.

SQL Server의 기존 인스턴스

새 SOLIDWORKS Electrical 데이터베이스를 설치하거나 기존 SQL Server 인스턴스에 설치된 SOLIDWORKS Electrical에 연결하려면 SQL Server 데이터베이스에 대한 모든 관리 권한이 있는 사용자 계정이 필요합니다.

SOLIDWORKS Electrical이 제대로 작동하려면 SQL Server를 혼합 모드 인증으로 사용해야 합니다. 혼합 모드 인증을 사용하면 Windows 또는 SQL Server 자격 증명 중 어느 것이든 사용할 수 있습니다.

기존 SQL Server 데이터베이스에 연결하기 위해 Windows 또는 SQL Server 인증을 사용할 수 있습니다. Windows 또는 SQL Server 로그인 시 모든 SQL Server 관리 권한을 가진 사용자 이름과 비밀번호를 입력합니다.

‘tew’ 사용자를 사용하여 SQL Server에 연결해 설치하는 것은 불가능합니다. SQL Server에 대한 적절한 자격 증명이 있는 로그인 정보를 얻으려면 SQL Server 관리자 또는 시스템 관리자에게 문의하십시오.

SQL Server 설치 후

SOLIDWORKS Electrical을 설치하면 SQL Server 인스턴스는 SOLIDWORKS Electrical에 다음과 같은 데이터베이스를 생성합니다.
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


사용권 관리

설치 후 개별 컴퓨터를 활성화하거나(사용권 활성) 서버에서 부동 네트워크 사용권을 설치 및 활성화하여(SolidNetWork 사용권 발급) SOLIDWORKS 사용권을 활성화할 수 있습니다.

대개, 개별 컴퓨터에 설치할 때 사용권 활성을 사용합니다; 그러나 소프트웨어를 개별적으로 설치한 다음, SolidNetWork License Manager로 사용권을 제어할 수 있습니다. 이와 반대로, 일반적으로 더 큰 사이트에서 부동 네크워크 사용권을 사용하더라도, 사용자가 관리자 이미지에서 배포한 다음 개별 컴퓨터에서 제품 번호를 활성화 할 수 있습니다.

Windows 8을 실행하는 경우 시작 또는 제어판 액세스 등의 작업에 대해서는 SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁을 참조하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.

목차

  • 개별 사용권 관리

    대개, 개별 사용권 관리는 SOLIDWORKS에서 직접 활성화 및 이전으로 이루어집니다.

  • SolidNetWork License Manager를 사용하여 사용권 관리

    SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.


개별 사용권 관리

대개, 개별 사용권 관리는 SOLIDWORKS에서 직접 활성화 및 이전으로 이루어집니다.

활성화란, SOLIDWORKS 스탠드얼론 사용권(SOLIDWORKS 사용권 외)의 제품 사용권 발급 및 등록 절차를 뜻합니다. 대개, 제품이 아직 활성화되지 않았으면 SOLIDWORKS에서 제품을 시작할 때 활성화를 시도합니다.

SOLIDWORKS에서 도움말 > 사용권 이전을 클릭하여 개별 사용권을 이전할 수도 있습니다.

상위 주제
사용권 관리
관련 개념
SolidNetWork License Manager를 사용하여 사용권 관리

사용권 활성

개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, 해당 컴퓨터에 대한 사용권을 활성화해야 합니다.

활성을 위해 인터넷이나 전자우편이 필요합니다. 활성화를 끝낸 후, 제품 사용시에는 인터넷이 필요하지 않습니다. 이 제품을 사용할 컴퓨터에서 전자우편을 사용할 수 없을 경우, 활성 파일을 저장해서 다른 컴퓨터로 보낼 수 있습니다.

절차:
  • SOLIDWORKS 모든 제품 라인의 소프트웨어 사용권을 활성화합니다.
  • 특정 컴퓨터에서 다른 컴퓨터로 사용권을 이전할 수 있습니다.
  • 설치 직후(권장) 또는 30일 안에 활성화 할 수 있습니다.
  • 동글이 필요없습니다. 그러나 활성화가 필요하지 않은 SOLIDWORKS의 이전 제품을 실행할 경우에는 동글이 여전히 필요합니다.

관리할 제품 번호가 여러 개 있는 시스템 관리자의 경우 관리 이미지 옵션 편집기를 사용할 수 있습니다. 자세한 내용은 관리 이미지 옵션 편집기를 참조하십시오.

사용권 활성하기:

  1. SOLIDWORKS를 시작합니다.
  2. 다음 중 한 가지 방법을 사용하여 SOLIDWORKS 제품 활성을 시작합니다.
    • 해당 컴퓨터의 사용권을 아직 활성화하지 않은 경우 SOLIDWORKS를 시작할 때 SOLIDWORKS 제품 활성 창이 자동으로 나타납니다.
    • SOLIDWORKS 제품 활성 창이 자동으로 나타나지 않으면 도움말 > 사용권 활성을(를) 클릭하여 활성화를 시작합니다.
  3. 제품 목록을 클릭하여 사용권을 활성화할 제품을 지정합니다.
  4. 인터넷을 통해 자동 활성을 지정하거나 전자우편을 통한 직접 활성을 지정합니다.
  5. 전자우편 정보를 입력합니다.
  6. 다음을(를) 클릭하여 계속합니다.
    • 인터넷: 활성화가 자동으로 이루어집니다.
    • 전자우편: 저장을 눌러 요청 파일을 작성한 후 activation@solidworks.com으로 파일을 첨부해 보냅니다. 응답 파일이 포함된 전자우편을 받으면 파일을 추출한 후 열기를 클릭하여 로드합니다.
      필요한 경우 활성 절차를 종료하고 다시 실행하여 응답 파일을 열 수 있습니다.
  7. 마침을(를) 클릭합니다.
관련 참조
관리 이미지 옵션 편집기

사용권 이전

사용권을 새 컴퓨터나 업그레이된 컴퓨터로 이전하려면 우선, Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버로 사용권을 이전한 후 다른 컴퓨터에서 다시 활성화합니다.

SOLIDWORKS에 사용권을 (하드 드라이브 실패 등의 이유로) Dassault Systemes SOLIDWORKS Corporation으로 이전할 수 없더라도 대부분의 경우 여전히 성공적으로 재활성화됩니다. 그렇지 않으면, 리셀러(VAR)에 문의합니다.

다시 서버로 사용권 이전하기:

  1. SOLIDWORKS에서 도움말 > 사용권 이전을 클릭하고 지침을 따릅니다.
  2. 재활성화를 하려면 새 컴퓨터나 업그레이드된 컴퓨터에서 첫 활성화 중 했던 것 같이 사용권을 활성화합니다. 자세한 내용은 사용권 활성을 참조하십시오.


SolidNetWork License Manager를 사용하여 사용권 관리

SolidNetWork License Manager는 사용권을 네트워크 상의 클라이언트에 배포하여 여러 개의 사용권 클라이언트를 지원합니다. 따라서 사용자는 사용권 부동화를 사용하여 사용권 수를 초과하여 사용할 수 있습니다.

다음 그림은 일반적인 SolidNetWork 사용권 설치 과정을 보여줍니다.

이 그림의 과정:
  • SolidNetWork License Manager 소프트웨어가 사용권 관리자 컴퓨터에만 설치되고 활성화되었습니다.
  • 사용권 클라이언트 컴퓨터에는 추가로 설치된 별도의 SolidNetWork 사용권 소프트웨어가 없습니다.

    설치 시 SolidNetWork 사용권 제품 번호를 지정하면 SOLIDWORKS 설치 관리자가 해당 컴퓨터를 SolidNetWork 사용권 클라이언트로 인식합니다. SOLIDWORKS 설치 관리자는 사용자에게 클라이언트를 사용권 관리자에 연결하기 위해 SolidNetWork License Manager 컴퓨터 이름과 포트 번호를 입력하라는 메시지를 표시합니다.

  • 사용권 관리자와 모든 사용권 클라이언트는 TCP/IP(Transmission Control Protocol/Internet Protocol) 연결이 설정되어 있어야 합니다.

목차

  • SolidNetWork 사용권 활성

    개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, SolidNetWork License Manager 컴퓨터에서 SolidNetWork 사용권을 활성화해야 합니다.

  • SolidNetWork 사용권 이전

    SolidNetWork 사용권을 새 컴퓨터나 업그레이된 컴퓨터로 이전하려면 우선, Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버로 사용권을 이전한 후 다른 컴퓨터에서 다시 활성화합니다.

  • SolidNetWork 사용권 설치 및 구성

    SolidNetWork 사용권 구성은 사용권 관리자 컴퓨터에 SolidNetWork License Manager를 설치한 후 SolidNetWork 사용권 제품 번호를 사용하여 클라이언트 컴퓨터에 SOLIDWORKS를 설치하는 과정으로 이루어집니다.

  • SolidNetWork 사용권 관리

    관련 작업으로는 사용권 관리자 시작, 업그레이드, 설치 제거와 사용권 차용 및 반환이 있습니다.

상위 주제
사용권 관리
관련 개념
개별 사용권 관리


SolidNetWork 사용권 활성

개별 컴퓨터에서 SOLIDWORKS 제품을 실행할 수 있으려면 먼저, SolidNetWork License Manager 컴퓨터에서 SolidNetWork 사용권을 활성화해야 합니다.

활성을 위해 인터넷이나 전자우편이 필요합니다. 활성화를 끝낸 후, 제품 사용시에는 인터넷이 필요하지 않습니다. 이 제품을 사용할 컴퓨터에서 전자우편을 사용할 수 없을 경우, 활성 파일을 저장해서 다른 컴퓨터로 보낼 수 있습니다.

절차:
  • 모든 SolidWorks 제품에 대한 SolidNetWork 사용권으로 SOLIDWORKS SolidNetWork License Manager를 활성화합니다.
  • SolidNetWork License Manager 컴퓨터에서 다른 컴퓨터로 SolidNetWork 사용권을 이전할 수 있도록 합니다.
  • 한 대의 SolidNetWork License Manager 컴퓨터에서 SolidNetWork 사용권을 설치하고 활성화할 수 있도록 합니다.
  • SolidNetWork 사용권을 사용할 수 있기 전에 수행해야 합니다.
  • 동글이 필요없습니다. SOLIDWORKS 현 버전에 대한 SolidNetWork 사용권을 활성화할 경우 이전 버전의 SOLIDWORKS에 대한 SolidNetWork 사용권이 활성화됩니다. (동글은 보유하지 않아도 됩니다.)

SolidNetWork 사용권 활성하기:

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. SolidNetWork 사용권을 아직 활성화하지 않은 경우 지금 활성화할 지 여부를 묻는 메시지가 나타납니다. 예를 클릭하여 활성화합니다.
  3. 제품 활성 방법 아래에서 인터넷으로 자동 요청(권장 사항)을 선택합니다.
  4. 연락처 정보 아래에서 전자우편 주소를 지정합니다.
성공적인 활성화/재활성화 대화 상자에 제품이 활성되었음이 표시됩니다.
상위 주제
SolidNetWork License Manager를 사용하여 사용권 관리
관련 개념
SolidNetWork 사용권 설치 및 구성
SolidNetWork 사용권 관리
관련 태스크
SolidNetWork 사용권 이전


SolidNetWork 사용권 이전

SolidNetWork 사용권을 새 컴퓨터나 업그레이된 컴퓨터로 이전하려면 우선, Dassault Systemes SOLIDWORKS Corporation의 사용권 키 서버로 사용권을 이전한 후 다른 컴퓨터에서 다시 활성화합니다.

SOLIDWORKS에 사용권을 (하드 드라이브 실패 등의 이유로) Dassault Systemes SOLIDWORKS Corporation으로 이전할 수 없더라도 대부분의 경우 여전히 성공적으로 재활성화됩니다. 그렇지 않으면, 리셀러(VAR)에 문의합니다.

다시 서버로 SolidNetWork 사용권 이전하기:

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.

  2. 사용권 정보에서 수정을 클릭합니다. SOLIDWORKS 제품 활성 마법사가 시작됩니다.
  3. 원하는 작업 아래에서 소프트웨어 사용권 이전을 클릭한 후 다음을 클릭합니다.
  4. 제품 이전 방법 아래에서 인터넷으로 자동 요청(권장 사항)을 선택합니다.
  5. 연락처 정보 아래에서 전자우편 주소를 지정합니다.
  6. 다음을 클릭합니다. 제품 사용권 이전이 완료됩니다.
상위 주제
SolidNetWork License Manager를 사용하여 사용권 관리
관련 개념
SolidNetWork 사용권 설치 및 구성
SolidNetWork 사용권 관리
관련 태스크
SolidNetWork 사용권 활성


SolidNetWork 사용권 설치 및 구성

SolidNetWork 사용권 구성은 사용권 관리자 컴퓨터에 SolidNetWork License Manager를 설치한 후 SolidNetWork 사용권 제품 번호를 사용하여 클라이언트 컴퓨터에 SOLIDWORKS를 설치하는 과정으로 이루어집니다.

목차

  • 사용권 관리자 설치 및 활성

    SolidNetWork License Manager는 여러 개의 사용권 클라이언트를 지원하며 네트워크상에 있는 다른 사용자에게 사용권을 분배합니다.

  • 사용권 클라이언트 설치

    SolidNetWork 사용권 클라이언트 컴퓨터에서 SOLIDWORKS를 설치할 때 제품 번호는 해당 컴퓨터를 SolidNetWork 사용권 클라이언트로 식별합니다.

  • 사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치

    SolidNetWork 사용권 클라이언트 컴퓨터를 설치하기 전에 최소 한대의 컴퓨터에 SolidNetWork License Manager를 설치하고 구성해야 합니다.

  • SOLIDWORKS 버전 액세스 관리

    사용자는 SolidNetWork 환경에서 특정 SOLIDWORKS 버전을 사용하지 못하도록 제한할 수 있습니다. 이 기능을 통해 다양한 개인, 프로젝트 및 비즈니스 부서에서 사용되는 SOLIDWORKS 버전을 관리할 수 있습니다.

  • 트라이어드 사용권 관리자 설치

    트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 사용권 파일을 관리하는 컴퓨터를 사용할 수 없는 경우, 다른 두 개의 컴퓨터 중 하나가 대신합니다.

  • 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용

    컴퓨터에 방화벽이 사용되는 경우 포트를 구성하여 SolidNetWork 사용권을 지원해야 합니다.

상위 주제
SolidNetWork License Manager를 사용하여 사용권 관리
관련 개념
SolidNetWork 사용권 관리
관련 태스크
SolidNetWork 사용권 활성
SolidNetWork 사용권 이전


사용권 관리자 설치 및 활성

SolidNetWork License Manager는 여러 개의 사용권 클라이언트를 지원하며 네트워크상에 있는 다른 사용자에게 사용권을 분배합니다.

사용권 활성화에 하드웨어 동글을 사용했던 SolidNetWork License Manager의 이전 버전에서 업그레이드하는 경우, 새 버전의 SolidNetWork License Manager를 설치하기 전에 하드웨어 동글을 제거하십시오.

  1. SOLIDWORKS Installation Manager(SOLIDWORKS 설치 시작에서 설명한 대로)를 시작합니다.
    1. 설치 유형에서 다음을 선택합니다.

      • 서버 제품
      • SolidNetWork License Manager(분배된 사용권)를 설치합니다.

    2. SolidNetWork License Manager 옵션 화면에서 SolidNetWork License 제품 번호와 SolidNetWork License Manager 설치 위치를 지정합니다.
    3. 요약 페이지에서 지금 설치을(를) 클릭하여 SOLIDWORKS 설치 관리자 과정을 완료합니다.
  2. SolidNetWork 사용권 활성화 하기:
    1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
    2. 활성화 여부 메시지가 나타나면 예를 클릭합니다.
    3. SolidNetWork 사용권 서버 정보 화면에서:

      • 회사에서 방화벽을 사용할 경우 서버에 방화벽 사용 중을(를) 선택합니다.

        자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참조하십시오.

      • 포트 번호(방화벽이 있는 경우 공급업체 데몬 포트 번호)에 기본값을 사용하거나 회사에서 사용하는 포트 번호를 지정합니다.
        포트 번호는 1024-60000 범위 사이의 TCP/IP 포트 번호로, 이 프로세스에만 사용됩니다. 대개 기본값(25734)이 적절하며 현재 사용권 관리자 컴퓨터 상의 어떤 FLEXnet 서버 프로세스와도 같지 않습니다.

    4. SOLIDWORKS 제품 활성화 화면에서:

      • 인터넷 또는 전자메일 방법을 선택합니다.
      • 전자우편 정보를 입력합니다.
      • 다음을 클릭하여 계속합니다.
        • 인터넷: 활성화가 자동으로 이루어집니다.
        • 전자우편: 저장을 눌러 요청 파일을 작성한 후 activation@solidworks.com으로 파일을 첨부해 보냅니다. 응답 파일이 포함된 전자우편을 받으면 파일을 추출한 후 열기를 클릭하여 로드합니다.
          필요한 경우 활성 절차를 종료하고 다시 실행하여 응답 파일을 열 수 있습니다.

  3. 마침을 클릭합니다.
상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치
트라이어드 사용권 관리자 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
사용권 클라이언트 설치
SOLIDWORKS 버전 액세스 관리
SOLIDWORKS 설치 시작


사용권 클라이언트 설치

SolidNetWork 사용권 클라이언트 컴퓨터에서 SOLIDWORKS를 설치할 때 제품 번호는 해당 컴퓨터를 SolidNetWork 사용권 클라이언트로 식별합니다.

  1. SOLIDWORKS 설치 관리자(SOLIDWORKS 설치 시작에서 설명한 대로)를 시작합니다.
  2. 현재 컴퓨터에 이 주요 릴리즈의 SOLIDWORKS를 처음으로 설치하는 경우라면 시작 화면에서 개별 설치 (현재 컴퓨터)을(를) 클릭합니다.

    기존 릴리즈에서 업그레이드하고 개별 사용권을 SolidNetWork 사용권으로 변경하는 경우 (현재 컴퓨터의) 기존 개별 설치 수정을(를) 클릭합니다. 자세한 내용은 개별 사용권에서 SolidNetWork 사용권으로 업그레이드를 참조하십시오.

  3. 제품 번호를 물으면 SolidNetWork License 제품 번호를 입력합니다.
  4. 서버 추가 대화 상자에서 SolidNetWork License Manager를 아래와 같은 형식으로 입력합니다:

    포트@컴퓨터이름

    포트 번호는 사용권 관리자 컴퓨터에서 사용한 번호와 동일해야 합니다. 기본값은 25734(License Manager 설치 및 활성 참조)입니다.

    SOLIDWORKS 설치 관리자가 해당 SolidNetWork License Manager가 액세스 가능한지 확인합니다. License Manager를 아직 설치하지 않은 경우 이 확인에 실패하지만 사용권 클라이언트 설치를 계속할 수 있습니다.

  5. 다음 SOLIDWORKS 설치 관리자 지침에 따라 SOLIDWORKS 설치를 완료합니다.
상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치
트라이어드 사용권 관리자 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
개별 사용권에서 SolidNetWork 사용권으로 업그레이드
관련 태스크
사용권 관리자 설치 및 활성
SOLIDWORKS 버전 액세스 관리
SOLIDWORKS 설치 시작


사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치

SolidNetWork 사용권 클라이언트 컴퓨터를 설치하기 전에 최소 한대의 컴퓨터에 SolidNetWork License Manager를 설치하고 구성해야 합니다.

SolidNetWork License 제품 번호를 사용해 설치할 때 SOLIDWORKS 설치 관리자는 SolidNetWork License Manager 컴퓨터 이름과 포트 번호를 입력하라는 메시지를 표시한 후 해당 정보를 확인합니다.

지정한 컴퓨터에 SolidNetWork License Manager를 아직 설치하지 않은 경우 이 확인 과정에 성공할 수 없습니다. 그러나, 이 경우 확인 과정의 실패가 사용자가 올바른 사용권 관리자 정보를 입력했는지 여부를 나타내지는 않습니다. 사용권 관리자가 설치된 상태에서 확인에 실패하면 잘못된 사용권 관리자 정보를 지정한 것입니다.

상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
트라이어드 사용권 관리자 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
사용권 관리자 설치 및 활성
사용권 클라이언트 설치
SOLIDWORKS 버전 액세스 관리


SOLIDWORKS 버전 액세스 관리

사용자는 SolidNetWork 환경에서 특정 SOLIDWORKS 버전을 사용하지 못하도록 제한할 수 있습니다. 이 기능을 통해 다양한 개인, 프로젝트 및 비즈니스 부서에서 사용되는 SOLIDWORKS 버전을 관리할 수 있습니다.

FLEXnet 옵션 파일을 사용하여 SOLIDWORKS 버전에 대한 액세스를 관리하는 방법

  1. SolidNetwork License Manager 설치 디렉터리에서 텍스트 파일을 작성합니다.

    SolidNetWork_License_Manager_설치_디렉터리\Licenses\sw_d.opt

  2. 사용권 파일에서 특정 SOLIDWORKS 버전에 대한 액세스를 관리하려면 SOLIDWORKS 옆에 다음 구문을 추가합니다.

    :SWVERSION=xx 여기서 xx는 관리하고자 하는 SOLIDWORKS 제품의 버전입니다.

  3. SOLIDWORKS의 여러 버전을 관리하려면 관리하고자 하는 각 버전에 대해 줄을 추가합니다.

    일부 FLEXnet 옵션은 지원되지 않습니다. 버전 필터에 지원되는 옵션은 다음과 같습니다.

    INCLUDE | 사용자 또는 그룹이 특정 버전을 시작하는 기능만 사용할 수 있습니다. 다른 모든 사용자는 해당 버전을 시작할 수 없습니다.
    INCLUDE_BORROW | 사용자 또는 그룹이 특정 버전을 차용하는 기능만 사용할 수 있습니다. 다른 모든 사용자는 해당 버전을 차용할 수 없습니다.
    EXCLUDE | 사용자 또는 그룹이 SOLIDWORKS의 특정 버전을 시작하는 것을 금지합니다. EXCLUDE는 INCLUDE에 우선합니다.
    EXCLUDE_BORROW | 사용자 또는 그룹이 SOLIDWORKS의 특정 버전을 차용하는 것을 금지합니다. EXCLUDE는 INCLUDE에 우선합니다.
    예제:
    1 | SWVERSION=24.0은 SOLIDWORKS 2016을 참조합니다.
    SWVERSION=23.0은 SOLIDWORKS 2015를 참조합니다.
    2 | INCLUDE solidworks:SWVERSION=24.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=24.0 USER jane
    옵션 파일의 이러한 줄은 jane에게만 SOLIDWORKS 2016 실행을 허용합니다. 다른 모든 사용자는 SOLIDWORKS 2016을 차용할 수 없지만 다른 버전의 SOLIDWORKS는 실행하고 차용할 수 있습니다. 또한 jane은 다른 버전의 SOLIWORKS도 실행하고 차용할 수 있습니다.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=24.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=23.0 GROUP chicago
    EXCLUDE solidworks USER don
    이러한 줄은 chicago라고 하는 사용자의 GROUP을 정의하고 SOLIDWORKS 2015 및 SOLIDWORKS 2016에 대한 액세스를 거부하지만 다른 버전의 SOLIDWORKS는 실행할 수 있습니다. 사용자 don은 모든 SOLIDWORKS 버전을 실행할 수 없습니다.
    4 | EXCLUDE swinspection_std:SWVERSION=24.0 HOST machine1
    이 줄은 machine1의 모든 사용자가 SOLIDWORKS Inspection 2016을 시작하는 것을 금지합니다. machine1은 다른 버전의 SOLIDWORKS Inspection 2015를 실행할 수 있습니다.

    FLEXnet에 대한 자세한 내용은 SolidNetwork License Manager 설치 디렉터리(\Docs\flexuser\licensingenduserguide.pdf)의 FLEXnet Publisher 사용권 관리 안내서를 참조하십시오.

상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치
트라이어드 사용권 관리자 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
사용권 관리자 설치 및 활성
사용권 클라이언트 설치


트라이어드 사용권 관리자 설치

트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 사용권 파일을 관리하는 컴퓨터를 사용할 수 없는 경우, 다른 두 개의 컴퓨터 중 하나가 대신합니다.

트라이어드 사용권 관리자를 사용하기 위한 조건:
  • 세 개의 하드웨어 동글이 필요합니다.
  • 자주 종료되도록 예약되지 않은 안정적인 컴퓨터에서만 트라이어드 관리자를 설치합니다.
  • 세 개의 사용권 관리자 컴퓨터를 같은 서브네트에 설치해야 하며, 속도가 느리거나 다이얼업 링크를 통해 트라이어드 사용권 관리자를 설정해서는 안됩니다.
  • 시스템 관리자는 사용권 관리자 컴퓨터가 다운될 때를 잘 포착하여 가능한 빨리 서버를 다시 시작해야 합니다.
    두 대의 사용권 관리자 컴퓨터만 실행할 경우 실패가 두 지점에서 일어나기 때문에 단일 사용권 관리자 컴퓨터를 운행하는 것보다 열악한 상황으로 됩니다.

목차

  • 첫 트라이어드 사용권 관리자 설치

    트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 이 과정은 트라이어드에서 첫 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 설명합니다.

  • 다음 컴퓨터에서 트라이어드 사용권 관리자 설치

    트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 이 과정은 트라이어드에서 두 번째와 세 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 설명합니다.

상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
사용권 관리자 설치 및 활성
사용권 클라이언트 설치
SOLIDWORKS 버전 액세스 관리


첫 트라이어드 사용권 관리자 설치

트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 이 과정은 트라이어드에서 첫 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 설명합니다.

  1. 첫 번째 트라이어드 사용권 관리자 컴퓨터에서 SOLIDWORKS 설치 관리자를 사용하여 SolidNetWork License Manager를 설치합니다.
    1. SOLIDWORKS Installation Manager(SOLIDWORKS 설치 시작에서 설명한 대로)를 시작합니다.
    2. 설치 유형에서 다음을 선택합니다.

      • 서버 제품
      • SolidNetWork License Manager(분배된 사용권)를 설치합니다.

    3. SolidNetWork License Manager 옵션 페이지에서 SolidNetWork License 제품 번호 및 SolidNetWork License Manager 설치 위치를 지정합니다.
    4. 요약 페이지에서 지금 설치을(를) 클릭하여 SOLIDWORKS 설치 관리자 과정을 완료합니다.
  2. SolidNetWork License Manager를 사용하여 첫 트라이어드 사용권 관리자 컴퓨터를 구성합니다.
    1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
    2. 아니오를 클릭합니다.

      SOLIDWORKS SolidNetwork License Manager의 서버 관리 탭이 나타납니다.

    3. 고급 옵션에서 옵션을 클릭합니다.

      고급 옵션 대화 상자가 나타납니다.

    4. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 클릭하고 확인을 클릭합니다.

      고급 옵션 대화 상자가 닫힙니다.

    5. 사용권 정보에서 수정을 클릭합니다.

      SolidNetWork 사용권 파일 마법사가 나타납니다.

    6. 서버 유형에서 트라이어드을 선택하고 다음을 클릭합니다.
    7. 서버 정보 창에서 첫 트라이어드 사용권 관리자 컴퓨터의 컴퓨터 이름, 동글 ID, 포트 번호가 맞는 지 확인하고 다음을 클릭합니다.

      서버가 동글 대신 NIC(네트워크 인터페이스 카드) 주소를 사용하는 경우 NIC 주소가 SOLIDWORKS에서 수신한 사용권 파일의 정보와 일치하고, 트라이어드 사용권 관리자 컴퓨터의 포트 번호가 올바른지 확인합니다. NIC 주소는 MAC(미디어 액세스 제어 주소) 주소라고도 합니다. 그리고 다음를 클릭합니다.

      NIC 주소를 찾으려면 명령 프롬프트 창을 열고 다음을 입력합니다.

      ipconfig /all

      컴퓨터가 방화벽을 사용하는 경우 이 화면에서 몇 개의 추가 항목도 설정해야 합니다. 자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참조하십시오.

    8. 트라이어드 파트너 서버 정보 화면에서 다른 두 트라이어드 사용권 관리자 컴퓨터의 컴퓨터 이름과 동글 ID 값을 입력합니다. 컴퓨터가 NIC 주소를 사용하는 경우 컴퓨터 이름 및 호스트 ID 값을 입력합니다.

      이렇게 하면 한 개의 사용권 관리자를 사용할 수 없을 경우 클라이언트 컴퓨터가 다른 두 서버에서 사용권을 가져올 수 있습니다.

    9. 사용권 화면에서 읽기를 클릭하여 SolidNetWork 사용권 파일을 찾아 엽니다.

      사용권이 SolidNetWork 사용권 파일 마법사에 표시됩니다.

    10. 마침를 클릭합니다.
    11. 확인을 클릭하여 SolidNetWork 사용권 파일 마법사를 종료한 다음 마침을 클릭하여 SolidNetWork License Manager을 종료합니다.
상위 주제
트라이어드 사용권 관리자 설치
관련 개념
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
다음 컴퓨터에서 트라이어드 사용권 관리자 설치
SOLIDWORKS 설치 시작


다음 컴퓨터에서 트라이어드 사용권 관리자 설치

트라이어드 사용권 관리자는 추가적인 안정성을 위해 3대의 컴퓨터를 사용합니다. 이 과정은 트라이어드에서 두 번째와 세 번째 컴퓨터에 SolidNetWork License Manager를 설치하는 방법을 설명합니다.

여기에서는 다른 컴퓨터에서 최소 하나의 트라이어드 사용권 관리자를 설치했다는 것을 전제로 합니다.

  1. 트라이어드 사용권 관리자 컴퓨터에서 SOLIDWORKS 설치 관리자를 사용하여 SolidNetWork License Manager를 설치합니다.
    1. SOLIDWORKS 설치 관리자를 시작합니다(SOLIDWORKS 설치 시작에 설명됨).
    2. 설치 유형에서 다음을 선택합니다.

      • 서버 제품
      • SolidNetWork License Manager(분배된 사용권)를 설치합니다.

    3. SolidNetWork License Manager 옵션 페이지에서 SolidNetWork License 제품 번호 및 SolidNetWork License Manager 설치 위치를 지정합니다.
    4. 요약 페이지에서 지금 설치을(를) 클릭하여 SOLIDWORKS 설치 관리자 과정을 완료합니다.
  2. SolidNetWork License Manager를 사용하여 트라이어드 사용권 관리자 컴퓨터를 구성합니다.
    1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.

      해당 컴퓨터에서 SolidNetWork License Manager를 처음으로 실행하는 것이므로 지금 활성화할 지 여부를 묻는 메시지가 나타납니다.

    2. 아니오를 클릭합니다.

      SOLIDWORKS SolidNetwork License Manager의 서버 관리 탭이 나타납니다.

    3. 고급 옵션에서 옵션을 클릭합니다.

      고급 옵션 대화 상자가 나타납니다.

    4. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 클릭하고 확인을 클릭합니다.

      고급 옵션 대화 상자가 닫힙니다.

    5. 사용권 정보에서 수정을 클릭합니다.

      SolidNetWork 사용권 파일 마법사가 나타납니다.

    6. 서버 유형에서 트라이어드 및 서버/사용권 정보 일치를 선택한 다음 다음을 클릭합니다.
    7. 서버 정보 창에서 해당 트라이드 사용권 관리자 컴퓨터의 컴퓨터 이름, 동글 ID, 포트 번호가 맞는 지 확인하고 다음을 클릭합니다.

      서버가 동글 대신 NIC(네트워크 인터페이스 카드) 주소를 사용하는 경우 NIC 주소가 SOLIDWORKS에서 수신한 사용권 파일의 정보와 일치하고, 트라이어드 사용권 관리자 컴퓨터의 포트 번호가 올바른지 확인합니다. NIC 주소는 MAC(미디어 액세스 제어 주소) 주소라고도 합니다. 그리고 다음를 클릭합니다.

      NIC 주소를 찾으려면 명령 프롬프트 창을 열고 다음을 입력합니다.

      ipconfig /all

      컴퓨터가 방화벽을 사용하는 경우 이 화면에서 몇 개의 추가 항목도 설정해야 합니다. 상세한 정보는 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용를 참고하십시오.

    8. 컴퓨터가 동글을 사용하는 경우 트라이어드 파트너 서버 정보 화면에서 다른 2개의 트라이어드 사용권 관리자 컴퓨터의 컴퓨터 이름 및 동글 ID 값을 입력합니다. 컴퓨터가 NIC 주소를 사용하는 경우 컴퓨터 이름 및 호스트 ID 값을 입력합니다.

      이렇게 하면 한 개의 사용권 관리자를 사용할 수 없을 경우 클라이언트 컴퓨터가 다른 두 서버에서 사용권을 가져올 수 있습니다.

    9. 사용권 화면에서 읽기를 클릭하여 SolidNetWork 사용권 파일을 찾아 엽니다.

      일반적으로, 사용권 파일은 사용자가 구성한 첫 번째 트라이어드 사용권 관리자 컴퓨터의 \licenses\sw_d.lic에 있습니다.

      사용권이 SolidNetWork 사용권 파일 마법사에 표시됩니다.

    10. 마침를 클릭합니다.

      SolidNetWork 사용권 파일 마법사 경고가 나타납니다.

    11. 확인을 클릭하여 SolidNetWork 사용권 파일 마법사를 종료한 다음 마침을 클릭하여 SolidNetWork License Manager을 종료합니다.

두 번째 트라이어드 사용권 관리자 컴퓨터를 구성하고 있는 경우 세 번째 트라이어드 관리자 컴퓨터에서 이 과정 반복합니다.

상위 주제
트라이어드 사용권 관리자 설치
관련 태스크
첫 트라이어드 사용권 관리자 설치


방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용

컴퓨터에 방화벽이 사용되는 경우 포트를 구성하여 SolidNetWork 사용권을 지원해야 합니다.

방화벽 소프트웨어에서 두 개의 SolidNetWork 사용권 포트(예: SNL-in-port와 SNL-out-port)를 추가하여 방화벽 제외 목록에 추가합니다. 이들 포트를 구성하는 데 대한 자세한 정보는 시스템 관리자에게 문의하십시오.

지원되는 Windows 운영 체제에서 Windows 방화벽을 사용할 경우 SolidNetWork 사용권 관리자 컴퓨터에서 포트를 수정하고 SolidNetWork 사용권 파일을 수정하여 사용권 클라이언트 컴퓨터에 사용권을 배포해야 합니다.

목차

  • Windows 방화벽에 사용권 관리자 컴퓨터 포트 수정

    Windows 방화벽을 사용하는 경우 SolidNetWork 사용권 관리자 컴퓨터에서 방화벽 포트 설정을 수정해야 합니다.

  • Windows 방화벽에 SolidNetWork License Manager 수정

    Windows 방화벽을 사용하는 경우 방화벽 포트를 사용하도록 SolidNetWork 사용권 파일을 수정하여 클라이언트 컴퓨터에 사용권 파일을 분배해야 합니다.

상위 주제
SolidNetWork 사용권 설치 및 구성
관련 개념
사용권 클라이언트를 설치하기 전에 SolidNetWork License Manager 설치
트라이어드 사용권 관리자 설치
관련 태스크
사용권 관리자 설치 및 활성
사용권 클라이언트 설치
SOLIDWORKS 버전 액세스 관리


Windows 방화벽에 사용권 관리자 컴퓨터 포트 수정

Windows 방화벽을 사용하는 경우 SolidNetWork 사용권 관리자 컴퓨터에서 방화벽 포트 설정을 수정해야 합니다.

  1. Windows에서 제어판을 연 후 보안 센터를 더블 클릭합니다.
  2. Windows 방화벽을 클릭합니다.
  3. 예외 탭에서, 포트 추가를 클릭합니다.
  4. 이름(예: SNL-in-port)과 포트 번호(예: 25734)를 입력한 후 확인을 클릭합니다.
  5. 두 번째 포트로, 다시 예외 탭에서 포트 추가를 클릭하고 다름 포트 이름과 번화(예: SNL-out-port와 25735)를 지정한 후 확인을 클릭합니다. 나중에 SolidNetWork 사용권 파일을 수정할 때 참조할 것이므로 포트 번호를 기록해둡니다.

    Workgroup PDM을 사용할 경우에는 Windows 방화벽에서 Workgroup PDM 포트 번호를 수정해야 합니다. 일반적으로, 이 포트는 20000(VaultAdmin), 30000(Data), 40000(Request), 80(Viewer)입니다.

  6. Windows 보안 센터와 제어판을 닫습니다.
상위 주제
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
Windows 방화벽에 SolidNetWork License Manager 수정


Windows 방화벽에 SolidNetWork License Manager 수정

Windows 방화벽을 사용하는 경우 방화벽 포트를 사용하도록 SolidNetWork 사용권 파일을 수정하여 클라이언트 컴퓨터에 사용권 파일을 분배해야 합니다.

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 서버 관리 탭의 사용권 서버에 있는 정지를 클릭합니다. (확인 메시지가 나타나면 예를 클릭하고 확인을 클릭하여 사용권 서버 정지를 완료합니다.)
  3. 사용권 정보에서 수정을 클릭합니다.
  4. 서버 유형에서 네트워크에 대한 서버 정렬을 선택한 다음(단일 또는 트라이어드) 다음을 클릭합니다.
  5. 서버 정보에서 다음을 수행합니다.
    1. 서버에 방화벽 사용 중
    2. 포트 번호와 공급업체 데몬 포트 번호에는 Windows 방화벽에 지정한 포트 번호가 포함되어야 합니다(자세한 내용은 Windows 방화벽에 사용권 관리자 컴퓨터 포트 수정 참조).
    3. 옵션 파일을 선택하고 파일을 찾기 위해서 찾아보기를 클릭합니다. 파라미터를 변경하려면 편집을 클릭합니다.

      사용권 관리자는 옵션 파일을 사용하여 FLEXnet 사용권을 관리 운영하는 데 필요한 여러 가지 파라미터를 제어할 수 있습니다.

      옵션 파일은 SolidNetwork License Manager 설치 디렉토리(SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt)에 저장해 두는 것이 좋습니다. 이 파일은 sw_d.lic 파일과 동일한 디렉토리에 있어야 합니다.

      옵션 파일에 대한 자세한 내용은 SolidNetwork License Manager 설치 디렉토리에 있는 FLEXnet Publisher 사용권 관리 안내서(License Administration Guide)를 참조하십시오(\Docs\flexuser\licensingenduserguide.pdf).

    4. 다음을 클릭하고 마침을 클릭합니다.
  6. 서버 관리 탭의 사용권 서버에 있는 시작를 클릭합니다.
  7. 확인을 클릭하여 SolidNetWork License Manager를 닫습니다.
상위 주제
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용
관련 태스크
Windows 방화벽에 사용권 관리자 컴퓨터 포트 수정


SolidNetWork 사용권 관리

관련 작업으로는 사용권 관리자 시작, 업그레이드, 설치 제거와 사용권 차용 및 반환이 있습니다.

사용권 관리자를 시작하거나 업그레이드하기 전에 차용한 사용권이 있으면 반환해야 합니다.

목차

  • SolidNetWork License Manager 시작

    Windows 시작 메뉴에서 SolidNetWork License Manager를 시작할 수 있습니다.

  • SolidNetWork License Manager 업그레이드

    SOLIDWORKS 주요 릴리즈의 경우 License Manager 업그레이드 과정은 이전 License Manager 제거, 새 License Manager 설치, SolidNetWork 사용권 재활성화 과정으로 이루어집니다.

  • SolidNetWork 사용권 파일 삭제

    새 SolidNetWork 사용권 파일로 업그레이드하기 전에 기존의 만료된 사용권을 삭제합니다.

  • SolidNetWork 사용권 차용 및 반환

    SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다. 사용 가능한 사용권 풀에서 사용권이 제거되므로 차용된 사용권을 다시 사용할 수 있게 하려면 반환해야 합니다.

  • 사용권 유휴 시간 추적

    SOLIDWORKS는 일정 시간 동안 사용되지 않은 사용권들을 남은 사용권 목록에 되돌려 보낼 수 있도록 SolidNetWork License Manager의 유휴 시간을 등록해주는 옵션이 있습니다.

  • 임시 사용권 설치

    "임시(ANY)" 사용권은 원본 SolidNetWork 사용권을 사용할 수 없을 때 임시로 사용할 수 있습니다.

  • 개별 사용권에서 SolidNetWork 사용권으로 업그레이드

    SOLIDWORKS 설치 관리자에서 SolidNetWork 사용권 제품 번호를 지정하여 개별 SOLIDWORKS 사용권에서 SolidNetWork 사용권으로 컴퓨터를 업그레이드할 수 있습니다.

  • 애드인 제품을 포함해 SolidNetWork 사용권 사용

    SolidNetWork License Manager를 사용해서 FeatureWorks, Workgroup PDM Server 등과 같은 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수 있습니다.

  • 사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용

    네트워크에서 컴퓨터 한 대를 구성하여 SolidNetWork 사용권을 배포하는 사용권 관리자와 사용자가 SOLIDWORKS 소프트웨어를 설치할 수 있는 관리 이미지 위치로의 역할을 동시에 할 수 있습니다.

  • FLEXnet Publisher 사용권 관리

    SolidNetWork 사용권 발급은 FLEXnet Publisher® 사용권 관리를 기반으로 합니다.

상위 주제
SolidNetWork License Manager를 사용하여 사용권 관리
관련 개념
SolidNetWork 사용권 설치 및 구성
관련 태스크
SolidNetWork 사용권 활성
SolidNetWork 사용권 이전


SolidNetWork License Manager 시작

Windows 시작 메뉴에서 SolidNetWork License Manager를 시작할 수 있습니다.

  • Windows에서 다음 명령을 실행합니다. 시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager.
상위 주제
SolidNetWork 사용권 관리


SolidNetWork License Manager 업그레이드

SOLIDWORKS 주요 릴리즈의 경우 License Manager 업그레이드 과정은 이전 License Manager 제거, 새 License Manager 설치, SolidNetWork 사용권 재활성화 과정으로 이루어집니다.

최근 버전의 사용권 관리자는 이전 버전에 남아 있는 클라이언트 컴퓨터에 사용권에 분배할 수도 있습니다.

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 사용권 사용 탭에서, 네트워크상에 있는 클라이언트 컴퓨터에서 SOLIDWORKS를 실행하고 있지 않은지 확인합니다.
  3. 이전 사용권 관리자 제거 자세한 내용은 SolidNetWork License Manager 설치 제거를 참조하십시오.
  4. 사용권 관리자 컴퓨터에서 새 사용권 관리자 설치 및 재활성 자세한 내용은 사용권 관리자 설치 및 활성를 참고하십시오.

SOLIDWORKS 응용 프로그램도 실행하는 컴퓨터에서 SOLIDWORKS License Manager를 업그레이드하려면 해당 컴퓨터에 새 SOLIDWORKS 응용 프로그램 서비스 팩을 설치하기 전에 SolidNetWork License Manager와 클라이언트를 업그레이드합니다.

관리 이미지를 호스팅하는 컴퓨터에서 사용권 관리자를 업그레이드할 경우 관리 이미지를 업그레이드하기 전에 사용권 관리자를 업그레이드합니다. 자세한 내용은 사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용을 참조하십시오.

목차

  • SolidNetWork License Manager 설치 제거

    SolidNetWork License Manager를 업그레이드할 경우 새 관리자를 설치하기 전에 이전 사용권 관리자를 제거해야 합니다.

상위 주제
SolidNetWork 사용권 관리


SolidNetWork License Manager 설치 제거

SolidNetWork License Manager를 업그레이드할 경우 새 관리자를 설치하기 전에 이전 사용권 관리자를 제거해야 합니다.

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 네트워크에서 SOLIDWORKS를 실행하는 컴퓨터가 없도록 합니다.

    사용권 수 탭에 SOLIDWORKS를 실행 중인 클라이언트가 표시됩니다.

  3. SolidNetWork 사용권을 다른 컴퓨터로 이전하려면, 해당 컴퓨터에 있는 SolidNetWork License Manager 설치를 제거하기 이전에 사용권을 이전하시기 바랍니다.

    SolidNetWork 사용권 이전에 관한 자세한 내용은 SolidNetWork 사용권 이전을 참조하십시오.

  4. 서버 관리 탭의 사용권 서버에 있는 정지를 클릭합니다.
  5. 확인을 클릭하여 사용권 관리자를 종료합니다.
  6. Windows에서 제어판 > 프로그램 추가/제거를 엽니다.
  7. SOLIDWORKS SolidNetWork License Manager를 선택하고 제거을(를) 클릭한 후 삭제를 확인합니다.
  8. Windows 탐색기에서 SOLIDWORKS SolidNetWork License Manager 폴더를 삭제합니다.

    (일반적으로, 이 폴더는 SOLIDWORKS 설치 디렉터리의 Program Files에 있습니다.)

이제 사용권 관리자 새 버전을 설치할 준비가 됩니다. 자세한 내용은 사용권 관리자 설치 및 활성을 참조하십시오.

SolidNetWork License Manager 컴퓨터에 하드웨어 동글이 있는 경우, 새 버전의 SolidNetWork License Manager를 설치하기 전에 해당 하드웨어 동글을 제거합니다.
상위 주제
SolidNetWork License Manager 업그레이드
관련 태스크
SolidNetWork 사용권 이전
사용권 관리자 설치 및 활성


SolidNetWork 사용권 파일 삭제

새 SolidNetWork 사용권 파일로 업그레이드하기 전에 기존의 만료된 사용권을 삭제합니다.

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 서버 관리 탭의 사용권 파일 아래에서, 수정을 클릭한 다음, 사용권 화면에 이를때까지 다음을 클릭합니다.
  3. 사용권 화면에서 기존 또는 만료된 SolidNetWork 사용권 파일을 선택하고 제거를 클릭합니다.
  4. 마침을 클릭한 다음 확인을 클릭합니다.
상위 주제
SolidNetWork 사용권 관리


SolidNetWork 사용권 차용 및 반환

SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다. 사용 가능한 사용권 풀에서 사용권이 제거되므로 차용된 사용권을 다시 사용할 수 있게 하려면 반환해야 합니다.

차용한 사용권은 차용된 현재 사용자 및 장비에서만 사용할 수 있으며 전송할 수 없습니다.

사용권은 지정 기간 동안(최고 30일까지 또는 시스템 관리자가 지정한 기간으로) 대여되고 해당 사용권은 사용권 풀에서 삭제됩니다.

시스템 관리자가 차용(빌려오기)를 사용자 정의해서 할 수 있는 작업:
  • 사용권 빌려주기를 허용할 사용자 또는 그룹 지정
  • 빌려줄 수 없는 사용권 수 설정

자세한 내용은 SolidNetWork_License_Manager_설치_디렉터리\Docs\flexuser\licensingenduserguide.pdf를 참고합니다.

목차

  • SolidNetWork 사용권 차용

    SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다.

  • 차용한 SolidNetWork 사용권 반환

    차용한 SolidNetWork 사용권은 사용 가능한 사용권 풀에서 제거되므로 해당 사용권을 반환하여 다시 사용할 수 있게 해야 합니다.

상위 주제
SolidNetWork 사용권 관리


SolidNetWork 사용권 차용

SolidNetWork 사용권을 빌려와 원격 위치에서 소프트웨어를 사용할 수 있습니다.

사용권을 차용하려면 SolidNetWork 사용권 서버에 연결되어 있어야 하지만 사용할 필요는 없습니다.

Windows 8 이상을 실행하는 경우 이러한 단계는 시스템 구성에 따라 다릅니다. 자세한 설명과 옵션은 Microsoft Windows 문서를 참고하십시오.
  1. 클라이이언트 컴퓨터에서 SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 사용권 차용 탭에서:
    1. 차용 기간에서 날짜를 선택합니다.
    2. 차용할 제품을 선택한 다음, 차용을 클릭하고 예를 클릭해서 확인합니다.
    3. 새로 고침을(를) 클릭합니다. 만료일 열에 사용권을 반납할 날짜가 표시됩니다.
  3. 확인을(를) 클릭합니다.
상위 주제
SolidNetWork 사용권 차용 및 반환
관련 태스크
차용한 SolidNetWork 사용권 반환


차용한 SolidNetWork 사용권 반환

차용한 SolidNetWork 사용권은 사용 가능한 사용권 풀에서 제거되므로 해당 사용권을 반환하여 다시 사용할 수 있게 해야 합니다.

  1. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  2. 사용권 차용 탭에서:
    1. 반환할 제품을 선택한 다음 반납을 클릭하고 예를 클릭해서 확인합니다.
    2. 새로 고침을 클릭합니다. 만료일 열이 비워져 사용권이 반납되었음을 표시합니다.
  3. 확인을 클릭합니다.
사용권 만기일 이후에 사용권을 반환할 필요는 없습니다. 사용권이 만기일 자정에 SolidNetWork 사용권 관리자의 풀에 반환되며 원격 시스템에서 프로그램을 더 이상 실행할 수 없습니다.
상위 주제
SolidNetWork 사용권 차용 및 반환
관련 태스크
SolidNetWork 사용권 차용


사용권 유휴 시간 추적

SOLIDWORKS는 일정 시간 동안 사용되지 않은 사용권들을 남은 사용권 목록에 되돌려 보낼 수 있도록 SolidNetWork License Manager의 유휴 시간을 등록해주는 옵션이 있습니다.

  1. SolidNetwork License Manager 설치 디렉터리에서 텍스트 파일을 작성합니다.

    SolidNetWork_License_Manager_설치_디렉터리\Licenses\sw_d.opt

  2. 파일에 다음 줄을 추가합니다.

    TIMEOUTALL 초

    여기에서 초는 900(15분) 또는 이 보다 큰 수로, 최대 허용 시간입니다.

상위 주제
SolidNetWork 사용권 관리


임시 사용권 설치

"임시(ANY)" 사용권은 원본 SolidNetWork 사용권을 사용할 수 없을 때 임시로 사용할 수 있습니다.

"임시" 사용권 파일을 설치하면 Dassault Systemes SOLIDWORKS Corporation의 SolidNetWork 사용권 수령 시 일반적인 사용권 실행에 동의하게 됩니다. 사용권 범위 내에서 규격 준수가 여전히 필요합니다.

"임시(ANY)" 사용권 설치하기:

  1. 기존 SolidNetWork 사용자이면 SolidNetWork License Manager를 설치 제거하고 설치 폴더를 삭제합니다. 자세한 내용은 SolidNetWork License Manager 설치 제거를 참고하십시오.
  2. SOLIDWORKS 설치 관리자를 시작합니다(SOLIDWORKS 설치 시작에 설명됨).
    1. 설치 유형에서 다음을 선택합니다.

      • 서버 제품
      • SolidNetWork License Manager(분배된 사용권)를 설치합니다.

    2. SolidNetWork License Manager 옵션 화면에서 SolidNetWork License 제품 번호와 SolidNetWork License Manager 설치 위치를 지정합니다.
    3. 요약 페이지에서 지금 설치을(를) 클릭하여 SOLIDWORKS 설치 관리자 과정을 완료합니다.
  3. SolidNetWork License Manager(시작 > 프로그램 > SOLIDWORKS 버전 > SolidNetWork License Manager > SolidNetWork License Manager)를 시작합니다.
  4. 활성화 여부 메시지가 나타나면 아니오를 클릭합니다.

    SOLIDWORKS SolidNetwork License Manager의 서버 관리 탭이 나타납니다.

  5. 고급 옵션 아래에서 옵션을 클릭합니다.

    고급 옵션 대화 상자가 나타납니다.

  6. SolidNetWork Server 사용권 모드 아래에서 사용권 파일 사용을 클릭하고 확인을 클릭합니다.

    고급 옵션 대화 상자가 닫힙니다.

  7. 사용권 정보 아래에서 수정을 클릭합니다.

    SolidNetWork 사용권 파일 마법사가 나타납니다.

  8. 서버 유형 아래에서 단일을 선택하고 다음을 클릭합니다.
  9. 다음 메시지가 나타날 경우:

    동글 ID를 읽을 수 없습니다.취소를 클릭하십시오.

    동글 ID "임시번호(ANY)"가 자동으로 표시됩니다.
    컴퓨터가 방화벽을 사용하는 경우 이 화면에서 몇 개의 추가 항목을 설정해야 합니다. 상세한 정보는 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용를 참고하십시오.

  10. 설치를 계속 합니다.
상위 주제
SolidNetWork 사용권 관리


개별 사용권에서 SolidNetWork 사용권으로 업그레이드

SOLIDWORKS 설치 관리자에서 SolidNetWork 사용권 제품 번호를 지정하여 개별 SOLIDWORKS 사용권에서 SolidNetWork 사용권으로 컴퓨터를 업그레이드할 수 있습니다.

컴퓨터에 SOLIDWORKS가 설치되어 있지 않을 경우 SOLIDWORKS 설치 관리자로 설치할 때 SolidNetWork 제품 번호를 입력하여 SolidNetWork 사용권을 지정할 수 있습니다.

컴퓨터에 SOLIDWORKS가 이미 설치되어 있고 개별 사용권에서 SolidNetWork 사용권으로 전환하려면 클라이언트 컴퓨터에 대한 설치를 수정하고 SOLIDWORKS 설치 관리자를 실행할 때 개별 사용권 제품 번호 대신 SolidNetWork 사용권 제품 번호를 지정할 수 있습니다. 자세한 내용은 설치 수정하기를 참조하십시오.
관리 이미지에서 SOLIDWORKS를 설치한 경우에는 수정 옵션을 사용할 수 없습니다. 관리 옵션 편집기를 사용하여 관리 이미지를 변경하고, 클라이언트를 제거한 후 설치를 재실행해야 합니다.
상위 주제
SolidNetWork 사용권 관리
관련 태스크
설치 수정


애드인 제품을 포함해 SolidNetWork 사용권 사용

SolidNetWork License Manager를 사용해서 FeatureWorks, Workgroup PDM Server 등과 같은 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수 있습니다.

  • SOLIDWORKS 소프트웨어 사용권과 SOLIDWORKS 애드인 사용권의 수가 같지 않아도 됩니다.
  • 애드인 제품의 사용권을 체크아웃하려면, 먼저 SOLIDWORKS의 사용권을 체크아웃해야 합니다.
  • 애드인 제품 사용권을 차용하려면, 애드인을 포함하는 SOLIDWORKS 소프트웨어 사용권과 SOLIDWORKS 제품 사용권을 모두 차용해야 합니다. 기본적으로 SOLIDWORKS Standard 사용권을 빌리지만 애드인을 사용하려면 SOLIDWORKS Professional 또는 SOLIDWORKS Premium 제품 사용권을 빌려야 합니다.
  • 애드인 제품 사용권 릴리즈하기:
    • SOLIDWORKS에서 Tools > 애드인을 클릭하고 해당 애드인을 선택 취소합니다.
    • SOLIDWORKS를 종료합니다.
상위 주제
SolidNetWork 사용권 관리


사용권 관리자와 관리 이미지 설치에 같은 컴퓨터 사용

네트워크에서 컴퓨터 한 대를 구성하여 SolidNetWork 사용권을 배포하는 사용권 관리자와 사용자가 SOLIDWORKS 소프트웨어를 설치할 수 있는 관리 이미지 위치로의 역할을 동시에 할 수 있습니다.

클라이언트 컴퓨터는 같은 컴퓨터에서 사용권 관리자로부터 사용권을 발급받은 후 SOLIDWORKS를 설치할 수 있습니다.

이 구성은 사용권 관리자와 관리 이미지가 같은 컴퓨터에 설치되어야 가능합니다. 먼저 사용권 관리자를 설치한 후 관리 이미지를 작성하고 배포합니다.
자세한 내용은 다음을 참고하십시오.
  • 사용권 관리자 설치 및 활성
  • 여러 클라이언트에 배포
상위 주제
SolidNetWork 사용권 관리


FLEXnet Publisher 사용권 관리

SolidNetWork 사용권 발급은 FLEXnet Publisher® 사용권 관리를 기반으로 합니다.

FLEXnet Publisher 사용권 관리에 대한 자세한 내용은 SolidNetwork License Manager 설치 디렉터리(\Docs\flexuser\licensingenduserguide.pdf)에서 FLEXnet Publisher 사용권 관리 안내서(License Administration Guide)를 참고합니다.

FLEXnet Publisher 사용권 관리에 대한 최신 정보는 Acresso® Software에 문의하십시오.

상위 주제
SolidNetWork 사용권 관리


문제 해결

다음 항목을 참고하여 설치 관련 문제를 해결합니다.

목차

  • 네트워크 저작권 사용

  • SOLIDWORKS 설치 관리자 로그 파일

    SOLIDWORKS 설치 관리자 로그 파일은 설치 문제를 해결하는 데 참조할 수 있습니다.

  • SOLIDWORKS 설치 관리자 다운로드 폴더

    SOLIDWORKS 설치 관리자는 사용자가 지정하는 폴더에 필요한 설치 파일을 다운로드할 수 있습니다. 다운로드 폴더에 관한 FAQ (자주 물어오는 질문)의 답이 이 항목에 제공됩니다.

  • SolidNetWork 사용권 문제 해결

    SolidNetWork License Manager 설치에 실패하면 다음 가능한 설명을 확인해 봅니다.

  • 업그레이드 문제 해결

    SOLIDWORKS 새 버전으로 업그레이드하는 동안 문제가 발생하면 다음과 같은 가능한 설명을 확인합니다.

  • 설치 또는 업그레이드 시 그래픽 카드 유효성 검사

    컴퓨터에 SOLIDWORKS 설치 또는 업그레이드를 하고 나면 SOLIDWORKS Rx를 실행하여 컴퓨터에서 지원 그래픽 카드 및 그래픽 카드 드라이버가 실행되고 있는지 확인해야 합니다.


네트워크 저작권 사용

서버에 제품 사용권이 없는 경우 이 대화 상자가 열립니다.

모든 제품 선택 항목을 표시하려면 제품 상자의 화살표를 클릭합니다. 선택 항목에는 SOLIDWORKS와 구매 가능한 모든 애드인이 포함됩니다.

총 사용권 수는 구입한 사용권의 총 수입니다.

무료 사용권은 현재 사용되고 있지 않은 사용권의 수입니다.

사용권 이용자 상자에는 현재 사용권을 이용 중인 각 사용자에 대한 정보가 나타납니다.

상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
관련 태스크
설치 또는 업그레이드 시 그래픽 카드 유효성 검사


SOLIDWORKS 설치 관리자 로그 파일

SOLIDWORKS 설치 관리자 로그 파일은 설치 문제를 해결하는 데 참조할 수 있습니다.

이 로그 파일은 다른 SOLIDWORKS 응용 프로그램 로그 파일과 함께 있습니다.
  • Windows 7 이상:

    C:\Users\사용자 이름\AppData\Roaming\SOLIDWORKS\Installation Logs\설치된_버전

로그 파일 디렉터리를 보려면 Windows 폴더 옵션을 숨김 파일 및 폴더 표시으로 설정해야 합니다.

응용 프로그램 데이터가 C: 이외의 드라이브에 있을 경우 그에 따라 디렉터리 경로를 조정합니다.

이 디렉터리에는 SOLIDWORKS 설치 관리자 과정의 일반 로그인 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 파일이 포함되어 있습니다.

Other Logs 하위 디렉터리에는 더 상세한 로그 정보가 포함되어 있습니다.

상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
관련 태스크
설치 또는 업그레이드 시 그래픽 카드 유효성 검사
관련 참조
네트워크 저작권 사용


SOLIDWORKS 설치 관리자 다운로드 폴더

SOLIDWORKS 설치 관리자는 사용자가 지정하는 폴더에 필요한 설치 파일을 다운로드할 수 있습니다. 다운로드 폴더에 관한 FAQ (자주 물어오는 질문)의 답이 이 항목에 제공됩니다.

Windows 8 이상 버전을 실행 중인 경우 시작 또는 제어판에 액세스하는 등의 작업은 SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁을(를) 참고하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 특히 Windows 8 이상 버전을 사용하고 있는 시스템에 대한 자세한 설명과 옵션을 보려면 Microsoft Windows 문서를 참고하십시오.
질문 답
이 폴더에 파일을 설치하는 방법은 무엇입니까?

setup.exe을(를) 실행합니다. 이전에 다운로드하지 않은 항목을 설치하기 위해 선택할 경우에도 일부 파일을 다운로드해야 할 수 있습니다.

msiexec을(를) 사용하여 설치하지 마십시오(아래 참고).
msiexec나 일부 다른 응용 프로그램을 사용해서 이 폴더에서 직접 MSI 파일을 설치할 수 있습니까?

아니오. 설치 관리자가 msiexec를 실행할 때 필요한 일부 파일을 다운로드 하지 않습니다.
설치하는 각 버전마다 같은 다운로드 폴더를 선택할 수 있습니까?

다운로드 폴더는 버전에 특정합니다. SOLIDWORKS 2010부터는 SOLIDWORKS 설치 관리자가 지정 폴더 안에 버전 특정 하위 폴더를 자동으로 작성합니다.

또한 Dassault Systemes SOLIDWORKS Corporation 웹 사이트에서 일부 제품을 직접 다운로드합니다. 설치 관리자로 그 제품을 설치할 수 있습니까?
SW2009부터 SOLIDWORKS 설치 관리자는 직접 다운로드한 파일을 사용할 수 있습니다. 그러나 파일을 다운로드하는 옵션을 선택한 상태에서 SOLIDWORKS 설치 관리자를 실행하는 것이 좋습니다. SOLIDWORKS 설치 관리자에 설치하려는 제품에 따라 필요한 파일이 링크와 함께 표시됩니다. (프록시 서버로 적용된 다운로드 한계 때문에) 내장된 다운로드 페이지가 열리지 않으면 이 옵션이 사용됩니다.
Microsoft Internet Explorer에서 다운로드 또는 설치 중 파일을 저장하거나 실행할 지를 물으면 항상 저장으로 지정합니다.
다운로드한 파일을 다른 사용자와 공유할 수 있습니까?

예. 그렇게 하려면 네트워크 공유에 다운로드합니다. 그러면 각 클라이언트가 공유에서 SOLIDWORKS 설치 관리자를 실행해 설치할 수 있습니다.

사용자가 첫 다운로드 중 선택하지 않은 일부 설치 항목을 선택하지 않는 한, 또는 설치할 이 다운로드를 사용하는 컴퓨터가 파일을 다운로드한 컴퓨터와 요구되는 조건이 다를 경우 다운로드가 더 이상 필요하지 않습니다.

다른 사용자 대신해서 다운로드하지만 설치하지 않을 경우 설치 시 다운로드만 옵션을 선택합니다. 이 옵션을 통해 사용자 시스템에 설치 가능한 제품과 관계 없이 제품을 선택할 수 있습니다. 그러나 이 옵션을 패치 다운로드나 관리 이미지 작성에 사용할 수 없습니다.
SOLIDWORKS 제품의 새 버전 출시는 어떻게 통보받습니까?
새 버전이 출시되어 통보받는 경우:
  • 업데이트 확인(시작 > 모든 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인)를 실행하는 경우
  • SOLIDWORKS 백그라운드 다운로더를 활성화한 경우
  • Windows 프로그램 추가/제거에 설치된 SOLIDWORKS 버전을 선택한 경우 변경을(를) 클릭합니다.
  • 다운로드 폴더에서 설치 관리자의 구 버전(sldIM.exe)을 실행하는 경우
이 경우, 새 버전을 선택해서 다운로드할 수 있습니다. SOLIDWORKS 설치 관리자가 설치 파일이 아닌 새 버전 자체를 다운로드하고 실행하게 됩니다. SOLIDWORKS 설치 관리자의 새 버전이 실행된 후, 설치 작업 세트를 선택할 수 있습니다. 그런 다음, SOLIDWORKS 설치 관리자는 필요한 설치 파일(전에 다운로드하지 않음)을 확인하고 해당 파일의 다운로드를 제공합니다.
SOLIDWORKS 설치 관리자로 설치할 제품의 다른 서비스 팩을 선택할 수 없는 이유는 무엇입니까?

각 SOLIDWORKS 설치 관리자 버전은 SOLIDWORKS 제품의 특정 버전만 설치하도록 지정되었습니다. 다른 서비스 팩을 설치하려면 해당 버전의 SOLIDWORKS 설치 관리자를 실행해야 합니다. 출시된 최신 버전을 검색하려면 이전 항목을 참고하십시오.
SOLIDWORKS 설치 관리자에서 파일을 다운로드할 수 없는 이유는 무엇입니까?

프록시 서버의 제한 때문에 파일 다운로드를 할 수 없을 경우, SOLIDWORKS 설치 관리자가 파일을 자동으로 다운로드할 수 없습니다.

직접 파일을 다운로드한 다음 SOLIDWORKS 설치 관리자로 설치할 수 있습니다. SOLIDWORKS 설치 관리자에서 옵션을 선택하여 개별 파일을 선택합니다(예: 수동 다운로드 페이지의 다운로드 옵션). 사용자 제품선택 및 시스템 요구사항을 근거로 하는 웹 페이지가 모든 필수 파일을 직접 다운로드하는 링크가 포함된 독립 창에 표시됩니다. 이 링크는 SOLIDWORKS Customer Portal에 제공된 링크와 동일하지만 파일 검색에 필요하지 않습니다.
일부 SOLIDWORKS 제품만 최신 서비스 팩으로 업데이트됩니다. 업데이트 확인에서 최신 버전이라고 표시되는 이유는 무엇입니까?

업데이트 확인으로만 SOLIDWORKS 설치 관리자의 최신 버전이 설치되었는지 또는 실행 중인지 여부를 알 수 있습니다.

설치된 최신 버전에 모든 제품을 업데이트하려면 프로그램 추가/제거에서 SOLIDWORKS의 최근 설치 버전을 선택하고 변경을(를) 클릭합니다.

DVD를 다운로드 폴더에 복사할 수 있습니까?

예, 해당 플랫폼용으로 릴리즈된 모든 DVD의 모든 콘텐트를 복사하지 않으면 설치에 실패할 수 있습니다. SOLIDWORKS 설치 관리자가 버전 인식을 위해 swdata*.id에서 파일을 찾습니다. 이 파일이 없으면, 사용자가 복사한 설치 파일을 인식하지 못하고 다운로드가 필요합니다.
상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 로그 파일
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁
관련 태스크
설치 또는 업그레이드 시 그래픽 카드 유효성 검사
관련 참조
네트워크 저작권 사용


SolidNetWork 사용권 문제 해결

SolidNetWork License Manager 설치에 실패하면 다음 가능한 설명을 확인해 봅니다.

상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
업그레이드 문제 해결
관련 태스크
설치 또는 업그레이드 시 그래픽 카드 유효성 검사
관련 참조
네트워크 저작권 사용

SolidNetWork 사용권 로그 파일 액세스

사용권 오류가 있을 때 답이 SNL_Manager_설치_디렉토리\lmgrd.log 파일에 나와 있습니다.

SOLIDWORKS의 사용권을 얻을 수 없습니다. 사용권 서버에 연결할 수 없습니다.

대개, 이 문제는 포트 설정이 원인입니다.

  • SolidNetWork 사용권 관리자와 사용권 클라이언트 사이의 포트 설정이 일치하지 않을 수 있습니다.
  • SolidNetWork 사용권 관리자의 여러 버전의 추가 포트 설정이 지정되어 있지 않을 수 있습니다.
  • 클라이언트 컴퓨터에서 서버 이름을 정확하게 확인하고 해당 서버로 경로를 지정했는지 확인합니다. 서버에서 클라이언트 컴퓨터 이름을 정확하게 확인하고 해당 클라이언트로 경로를 지정했는지도 확인합니다.
SolidNetWork License Manager 및 클라이언트 포트 설정에 관한 자세한 내용은 방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용을 참조하십시오.
관련 개념
방화벽이 있는 상태에서 SolidNetWork 네트워크 사용권 사용


업그레이드 문제 해결

SOLIDWORKS 새 버전으로 업그레이드하는 동안 문제가 발생하면 다음과 같은 가능한 설명을 확인합니다.

상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
관련 태스크
설치 또는 업그레이드 시 그래픽 카드 유효성 검사
관련 참조
네트워크 저작권 사용

이동한 원본에서 업그레이드

SOLIDWORKS 설치 시 SOLIDWORKS 설치 관리자가 설치 원본 (디스크 미디어, 네트워크의 디스크 이미지 등)의 위치를 기억합니다. 업데이트 시 원본이 같은 위치에 있을 것으로 예상합니다.

원본이 이동 또는 삭제되거나 원본 미디어가 변경된 경우, SOLIDWORKS 설치 관리자가 오류 메시지를 생성합니다. 그러나 다른 위치에 같은 파일과 폴더 구조를 포함된 경우 그 위치를 찾아서 업그레이드를 계속할 수 있습니다.


설치 또는 업그레이드 시 그래픽 카드 유효성 검사

컴퓨터에 SOLIDWORKS 설치 또는 업그레이드를 하고 나면 SOLIDWORKS Rx를 실행하여 컴퓨터에서 지원 그래픽 카드 및 그래픽 카드 드라이버가 실행되고 있는지 확인해야 합니다.

그래픽 카드 및 드라이버 확인 방법:

  1. 설치 관리자에서 설치를 완료하고 완료 페이지를 표시하면 시스템 점검에서 시스템 진단 실행을 클릭합니다.

    SOLIDWORKS Rx는 진단 프로그램을 시작하고 실행합니다.

  2. SOLIDWORKS Rx를 통해 지원되는 그래픽 카드 및 그래픽 드라이버인지 확인합니다. 그래픽 카드는 지원되지만 드라이버가 없는 경우 상태 메시지에서 지원되는 드라이버에 대한 링크를 제공할 수 있습니다.

SOLIDWORKS를 10회 시작할 때마다 시스템 점검 메시지가 나타나며 시스템 진단을 다시 실행하는 것이 좋습니다. 이러한 알림이 표시되지 않게 하려면 Windows 알림 영역에서 SOLIDWORKS Resource Monitor를 오른쪽 클릭하고 알림 끄기를 클릭합니다.

Windows 알림 영역에서 SOLIDWORKS Resource Monitor를 오른쪽 클릭하여 언제든지 그래픽 카드와 드라이버를 확인할 수 있습니다. 바로가기 메뉴를 사용하여 다음을 수행할 수도 있습니다.
  • SOLIDWORKS Resource Monitor의 도움말 표시
  • 시스템 진단 실행
  • 그래픽 드라이버 업데이트
상위 주제
문제 해결
관련 개념
SOLIDWORKS 설치 관리자 로그 파일
SOLIDWORKS 설치 관리자 다운로드 폴더
SolidNetWork 사용권 문제 해결
업그레이드 문제 해결
관련 참조
네트워크 저작권 사용


SOLIDWORKS 설치 관리자 응용 프로그램 도움말

SOLIDWORKS 설치 관리자는 SOLIDWORKS 제품을 설치하고 업데이트하는 스탠드얼론 응용 프로그램입니다.

다음 방법으로 SOLIDWORKS 설치 관리자를 실행할 수 있습니다.
  • SOLIDWORKS DVD 또는 공유 원본 폴더나 다운로드 폴더 사용(새 버전을 설치하는 경우)
  • 제어판 프로그램 추가/제거 페이지 사용(기존 버전을 수정하거나 제거할 경우)
  • 예약된 업데이트 확인이나 직접 업데이트 확인 이용(새 버전을 찾고 다운로드하고 설치할 경우)

SOLIDWORKS의 각 버전은 해당 SOLIDWORKS 버전에 특정한 SOLIDWORKS 설치 관리자가 있습니다.

SOLIDWORKS 2008 이전 버전의 경우 SOLIDWORKS 2007 설치 관리자를 사용하거나 SOLIDWORKS 지원 웹 사이트에서 직접 제품 버전을 다운로드합니다.
Windows 8을 실행 중인 경우 시작 또는 제어판에 액세스하는 등의 작업은 SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁을(를) 참고하십시오. 이러한 단계는 사용자 시스템에 Windows 8이 어떻게 구성되어 있는지에 따라 달라질 수 있습니다. 특히 Windows 8 이상 버전을 사용하고 있는 시스템에 대한 자세한 설명과 옵션을 보려면 Microsoft Windows 문서를 참고하십시오.

목차

  • SOLIDWORKS 백그라운드 다운로더

    SOLIDWORKS 백그라운드 다운로더는 백그라운드 작업을 통해 자동화된 파일 다운로드를 수행하여(예를 들어, 새 서비스 팩 릴리즈를 찾은 경우) 다운로드 작업 동안 다른 작업을 계속할 수 있도록 도와줍니다. 다운로드가 완료되면 다운로드의 설치, 연기, 및 삭제 여부를 묻는 메시지가 표시됩니다.

  • 업데이트 확인 결과

    업데이트 확인은 SOLIDWORKS의 차기 버전을 확인합니다.

  • 관리 이미지 위치

    관리 이미지의 설치 위치를 지정합니다.

  • 다운로드 옵션

    다운로드 파일 위치, 파일 다운로드 방식, 다운로드 파일 설치 여부와 같은 다운로드 작업 완료에 대한 세부 옵션을 지정합니다.

  • SOLIDWORKS 설치 관리자 파일 다운로드 옵션

    SOLIDWORKS 설치 관리자의 차후 버전을 다운로드하도록 선택했습니다. 이 화면을 사용해서 다운로드되는 위치과 방법을 지정합니다.

  • 제품 설치 파일 다운로드

    특정 제품에 빠진 파일을 다운로드하는 위치과 방법을 지정합니다.

  • 다운로드 진행

    SOLIDWORKS 설치 관리자가 이 절차 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

  • 다운로드 결과

    다운로드 결과가 성공적이었는지, 실패했는지, 취소되었는지 여부를 알려줍니다.

  • 설치 오류/취소된 설치

    설치 시 오류가 발생했거나 취소되었습니다.

  • 설치 완료

    SOLIDWORKS 설치 관리자가 그 과정을 완료했습니다.

  • 설치 위치

    SOLIDWORKS 설치 위치를 지정합니다.

  • 업그레이드 옵션

    한 개 이상의 SOLIDWORKS 이전 주요 버전이 해당 컴퓨터에 설치되어 있습니다. 기존 버전을 최신 버전으로 업그레이드할지, 새 버전에 대한 새 설치를 작성할지를 선택합니다.

  • 설치 진행

    이 화면에 설치 절차가 표시됩니다.

  • 설치 유형

    새 설치, 기존 설치 수정 또는 복구, 관리 이미지 작성, 관리 서버 제품 설치, 또는 설치하지 않고 파일 다운로드 등과 같은 실행할 설치 작업을 지정합니다.

  • 여러 컴퓨터에 설치하고 관리하기

    여러 대의 SOLIDWORKS 컴퓨터에 설치하고 관리하기 위해 SOLIDWORKS 설치 관리자에 다음 도구가 제공됩니다.

  • 수동 다운로드

    파일을 직접 다운로드할 것을 선택했습니다. (또는 마지막으로 SOLIDWORKS 설치 관리자를 실행할 때 수동 다운로드를 선택했습니다.)

  • 최신 버전이 있음

    설치 관리자가 새 SOLIDWORKS 제품을 감지했습니다. 선택으로 원본 설치 DVD나 다운로드에 포함된 버전을 설치하거나, 최신 버전을 다운로드하고 설치할 수 있습니다.

  • 새로운 버전이 없음

    다운로드할 새 버전이 없습니다. 지정된 버전을 계속 설치합니다.

  • 프로세스 감지

    SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 설치를 하지 못하게 하는 프로세스를 감지했습니다.

  • 제품 선택

    설치, 수정, 다운로드, 또는 제거할 제품 구성 요소를 지정합니다.

  • 다운로드할 제품

    SOLIDWORKS 제품을 선택해서 특정 위치에 다운로드합니다.

  • 복구할 제품

    이 설치 복구하기를 지정할 경우 이 화면에 현 버전의 SOLIDWORKS 설치 관리자로 복구할 수 있는 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다.

  • 제품 번호

    배포 상자에 기재된 제품 번호가 구입한 SOLIDWORKS 제품을 사용자의 컴퓨터와 연관시킵니다.

  • 서버 설치

    설치를 시도하는 서버 제품이 설치 결과와 함께 나열됩니다.

  • SolidNetWork License Manager

    SolidNetWork License Manager 서버 제품의 설치 옵션을 지정합니다.

  • 요약

    SOLIDWORKS 설치 관리자에 파일 작업에 필요한 모든 정보가 있습니다.

  • 시스템 검사 경고

    시스템 검사는 설치 과정에 영향을 줄 수 있는 보고된 문제를 검사합니다. 대부분의 경우 SOLIDWORKS 설치 관리자로 진행할 수 있습니다.

  • 구멍 가공 마법사/Toolbox 옵션

    SOLIDWORKS Toolbox가 설치되어 있으면 SOLIDWORKS에 구멍 유형과 하드웨어의 규격 라이브러리가 포함됩니다.

  • 제품 설치 제거

    제어판에서 프로그램을 제거 또는 설치 제거하려면 화면에 현재 버전의 SOLIDWORKS 설치 관리자로 제거 가능한 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다. 표준, 사용자 정의 또는 전체 제거를 수행할 수 있습니다.

  • Workgroup PDM 서버 옵션

    SOLIDWORKS Workgroup PDM Server 제품의 설치 옵션을 지정합니다.

관련 개념
SOLIDWORKS에서 Microsoft Windows 8 사용 시 팁


SOLIDWORKS 백그라운드 다운로더

SOLIDWORKS 백그라운드 다운로더는 백그라운드 작업을 통해 자동화된 파일 다운로드를 수행하여(예를 들어, 새 서비스 팩 릴리즈를 찾은 경우) 다운로드 작업 동안 다른 작업을 계속할 수 있도록 도와줍니다. 다운로드가 완료되면 다운로드의 설치, 연기, 및 삭제 여부를 묻는 메시지가 표시됩니다.

SOLIDWORKS 백그라운드 다운로더는 SOLIDWORKS를 설치하면 기본적으로 활성화됩니다.

SOLIDWORKS 설치 관리자가 실행 중일 동안(설치 작업 또는 다운로드 작업) SOLIDWORKS 백그라운드 다운로더가 일시 정지됩니다. 예를 들어, 다운로드가 실행 중이면 새 다운로드를 시작할 수 없게 일시 정지되고 다운로드 폴더 지정을 변경할 수 없습니다.

SOLIDWORKS 설치 중 요약 페이지에서 다운로드 옵션을 변경하여 SOLIDWORKS 백그라운드 다운로더를 비활성화할 수 있습니다. (백그라운드 다운로더를 사용하시겠습니까? 옵션을 선택 취소합니다.)

다운로더가 활성화되면 Windows 시스템 트레이에서 도구 모음에 아이콘이 나타납니다.

이 아이콘을 클릭하면 다음 작업이 활성화됩니다.
  • 배경 다운로더 도움말
  • 다운로드 일시 정지
  • 다운로드 계속
  • 다운로드 취소
  • 설치 옵션
  • 다운로드 위치 변경
  • 업데이트 확인
  • 업데이트 자동 확인
  • 업데이트 자동 다운로드
  • 백그라운드 다운로더 사용 해제

배경 다운로더 도움말

SOLIDWORKS 설치 안내서에서 백그라운드 다운로더에 대한 이 도움말 항목을 엽니다.

다운로드 일시 정지/계속

다운로드가 백그라운드에서 실행 중인 경우 다운로드 일시 정지를 클릭하면 해당 다운로드가 일시 정지되고 나중에 다운로드 계속을 클릭하여 다시 시작할 수 있습니다.

다운로드 취소

다운로드가 실행 중인 경우 해당 다운로드를 중단하고 백그라운드 다운로드가 이미 다운로드한 파일을 삭제합니다.
취소한 다운로드는 다시 시작할 수 없습니다.

설치 옵션

다운로드가 완료되면 다음 옵션 중에서 선택할 수 있습니다.
  • 지금 설치: 다운로드한 파일을 설치합니다.
  • 나중에 알림: 다운로드한 파일을 설치하지 않지만 나중에 알림 메시지가 나타나게 설정합니다.
  • 이 다운로드 삭제: 다운로드한 파일을 설치하지 않고 삭제합니다. (이 옵션은 다운로드한 파일을 설치하지 않기로 결정한 경우 유용합니다.)

다운로드 위치 변경

백그라운드 다운로더가 파일을 다운로드할 위치를 변경합니다.

이 옵션은 다운로드가 실행 중이거나 일시 정지된 상태에서는 사용할 수 없습니다.

업데이트 확인

SOLIDWORKS 설치 관리자의 업데이트 확인 기능을 실행합니다.

업데이트 자동 확인

주기적으로 업데이트 확인을 실행하여 업데이트 다운로드가 준비되면 알려줍니다.

업데이트 자동 다운로드

주기적으로 업데이트 확인을 실행하여 업데이트가 있으면 다운로드합니다.

SOLIDWORKS 백그라운드 다운로더 비활성/재활성

백그라운드 다운로더를 아이콘을 클릭하여 백그라운드 다운로더 사용 해제를 선택하여 비활성화할 수 있습니다.

백그라운드 다운로더를 다시 활성화하려면 시작 > 모든 프로그램 > SOLIDWORKS 설치 관리자 > SOLIDWORKS 백그라운드 다운로더를 클릭합니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


업데이트 확인 결과

업데이트 확인은 SOLIDWORKS의 차기 버전을 확인합니다.

다음과 같이 하여 직접 업데이트 확인을 실행할 수 있습니다.
  • Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.
  • SOLIDWORKS에서 도움말 > 업데이트 확인을 클릭합니다.
관리 이미지로 설치한 클라이언트에서는 업데이트 확인을 사용할 수 없습니다.

최신 버전이 있음

SOLIDWORKS 설치 관리자가 SOLIDWORKS 제품의 새 버전을 감지했습니다. 해당 버전의 SOLIDWORKS 설치 관리자를 선택하여 새 버전으로 업데이트할 수 있습니다.

이 새 버전은 설치에서 지정한 제품을 기반으로 설치 파일을 다운로드할 수 있습니다. SOLIDWORKS 설치 관리자로 설치하는 다른 사용자와 다운로드한 파일을 공유할 수 있습니다.

이 다운로드는 SOLIDWORKS 설치 관리자로만 할 수 있습니다.
다음 옵션을 사용할 수 있습니다:
  • 사용가능한 여러 버전이 있으면 목록에서 버전을 선택할 수 있습니다.
  • 이 버전에 관한 자세한 사항은 선택하면 이 업그레이드에 내용을 볼 수 있습니다를 클릭합니다.
다음을 클릭하면 선택한 버전의 SOLIDWORKS 설치 관리자를 받아 실행합니다.

사용가능한 새 다운로드 없음/새 버전 확인 불가능

최신 버전을 설치하고 있거나 확인할 SOLIDWORKS 사이트에 연결할 수 없기 때문에 SOLIDWORKS 설치 관리자가 SOLIDWORKS 제품의 새 버전을 찾을 수 없습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


관리 이미지 위치

관리 이미지의 설치 위치를 지정합니다.

관리 이미지를 작성할 경우에는 다음 옵션이 적용됩니다.
새로운 이미지 위치 | SOLIDWORKS 설치 관리자가 새로운 이미지를 작성할 디렉터리 위치입니다. | 이 위치에는 기존 이미지를 포함할 수 없습니다. 관리 이미지는 클라이언트 배포를 위해 공유할 수 있는 폴더에 있어야 합니다.
이미지 작성을 위해 필요한 예상 공간 | 관리 이미지 작성에 필요한 추가 공간입니다. | 설치할 디스크에 이미지 작성 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로부터 이미지 작성 | SOLIDWORKS 제품 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션를 참고하십시오.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


다운로드 옵션

다운로드 파일 위치, 파일 다운로드 방식, 다운로드 파일 설치 여부와 같은 다운로드 작업 완료에 대한 세부 옵션을 지정합니다.

SOLIDWORKS 설치 관리자가 전자 소프트웨어 유통(ESD)을 지원합니다. SOLIDWORKS DVD에서 설치하지 않을 경우, 설치 중인 SOLIDWORKS 제품의 원본을 지정할 것을 묻는 메시지가 받습니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.

원하는 작업이 무엇입니까?

다음 중 하나를 선택합니다.

다운로드 및 설치/다운로드 및 이미지 작성

다운로드가 완료되면 SOLIDWORKS 설치 관리자는 다운로드한 파일을 사용하여 설치를 실행합니다.

다운로드만. 한 번 다운로드를 하면 여러 대의 컴퓨터에서 다운로드한 파일을 공유할 수 있습니다.

SOLIDWORKS 설치 관리자는 다운로드가 완료된 후 설치를 실행하지 않습니다.

대개, 설치 파일 세트를 구성하여 여러 대의 컴퓨터에 공유하기 위해 파일을 다운로드할 경우 이 옵션을 지정합니다.

이 옵션을 지정하면 다운로드할 다음 두 파일 세트 중에서 선택하라는 메시지가 나타납니다.
  • 이 컴퓨터를 위한 파일: 해당 컴퓨터에 현재 있는 파일 세트 중 누락된 파일만 다운로드에 포함됩니다.
    이 세트에는 다음 요소만 포함되므로 상대적으로 크기가 작습니다.
    • 제품 선택 페이지에서 선택한 제품 파일만
    • 컴퓨터에 필요하지만 아직 설치되지 않은 구성 요소만

    그러나, 이 다운로드 파일 세트를 다른 컴퓨터에서 설치하기 위해 사용하면 일부 파일이 누락됩니다(다른 컴퓨터에 유효한 설치 파일 세트와 다를 수 있으므로). 이 다운로드 파일을 다른 컴퓨터에 설치하는 데 사용할 수 있지만 설치를 실행할 때 해당 컴퓨터에 유효한 설치 파일 세트를 완료하기 위해 파일을 추가로 다운로드해야 할 수 있습니다.

  • 모든 컴퓨터와 공유할 파일: 모든 컴퓨터에서 해당 버전을 설치하기 위해 사용할 수 있는 전체 설치 파일 세트가 다운로드에 포함됩니다.

    이 파일은 모든 컴퓨터에서 해당 버전의 모든 제품을 설치할 수 있는 전체 파일 세트가 포함되어 있으므로 다운로드 크기가 큽니다.

    다운로드할 제품 세트를 한정해 지정할 경우 이 옵션은 해당 지정을 무시하고 제품 버전에 포함된 모든 제품을 다운로드합니다.

    다운로드에는 개별 설치를 수행하는 데 필요한 파일만이 아닌, 관리 이미지를 작성하는 데 필요한 모든 파일이 포함됩니다.

설치만 합니다/관리 이미지만 작성합니다. 필요한 설치 파일이 이미 있습니다.

SOLIDWORKS 설치 관리자가 파일을 다운로드하지 않지만 선택한 디렉터리에 있는 파일을 사용합니다.

찾아보기를 클릭하여 다른 위치를 찾습니다. 예를 들어, 필요한 모든 파일이 포함된 위치인 설치 DVD나 다운로드 폴더를 찾아볼 수 있습니다.

폴더가 완전하지 않다는 오류 메시지를 받고 해당 위치에 모든 설치 파일이 존재하면, 설명가능한 경우수는 다음과 같습니다:
  • 이전에 다운로드하지 않은 설치 일부를 선택했거나 기본적으로 선택된 경우
  • 파일이 시스템 필수사항의 다른 세트와 함께 다른 컴퓨터에 다운로드된 경우
  • 클라이언트 설치를 이전에 실행했고, 대형 파일 세트가 필요한 관리 이미지를 현재 작성중인 경우.

모든 파일이 포함된 폴더를 찾아보거나(예: DVD) 다운로드 옵션 중 하나를 선택할 수 있습니다.

필요한 파일을 어디에 다운로드 하시겠습니까?

이는 다운로드할 폴더 위치입니다.

경우에 따라 이 옵션이 보이지만 비활성 상태일 수 있습니다. 예를 들어, 설치만 하기를 지정한 경우 SOLIDWORKS 설치 관리자는 별도의 다운로드 폴더를 사용하지 않고, 해당 옵션으로 지정된 디렉터리에서 다운로드된 파일을 설치합니다.

이 파일을 다운로드하는 경우나 사용자 위치에서 액세스할 경우 모두, 모든 파일이 반드시 같은 다운로드 폴더에 다운로드되어야 합니다.

예상 다운로드 크기

새 다운로드의 경우나 중단된 이전 세션에서 다운로드를 계속하는지 경우와 상관없이, 예상 다운로드 디스크 공간은 선택한 완전한 구성요소 부품을 기준으로 합니다.

예를 들어, 중단된 이전 다운로드를 계속하면 SOLIDWORKS 설치 관리자가 아직 다운로드되지 않은 파일만을 처리합니다. 다운로드 시간이 예상 시간보다 짧습니다.

파일이 이전 다운로드에서 다운로드가 완료된 경우 그 크기가 이 예상 크기에 포함되지 않습니다. 따라서, 예상 크기가 실제 다운로드 크기보다 클 수 있습니다.

다운로드 방법을 선택합니다.

다음 두 가지 옵션이 있습니다.
수동 다운로드 | 경우에 따라, 프록시 서버로 인해 SOLIDWORKS 설치 관리자가 자동 다운로드를 수행할 수 없습니다. | 이 옵션을 선택함으로써, 웹 페이지를 통해 직접 파일을 다운로드한 후 SOLIDWORKS 설치 관리자에서 설치 과정을 완료할 수 있습니다. 이 웹 페이지는 설치 완료에 필요한 파일만 다운로드하도록 SOLIDWORKS 설치 관리자에 의해 사용자 정의됩니다.
더 높은 네트워크 대역폭을 사용해서 신속한 다운로드 | 다운로더는 다운로드 중 사용된 네트워크 대역폭을 높임으로서 알고리듬을 사용하여 다운로드 속도를 높입니다. 경우에 따라 네트워크 성능에 지장을 가져올 수 있습니다. 다운로드 중 문제가 있을 경우, 이 옵션은 프록시 서버에서 지원되지 않습니다. 이 옵션을 선택해제하고 다운로드를 재시도 합니다. 자세한 사항은 사용자의 네��워크 관리자에게 문의합니다. 이 옵션은 자동 다운로드에만 해당합니다. 수동 다운로드에는 영향을 주지 않습니다.

SOLIDWORKS 백그라운드 다운로더 사용하기

SOLIDWORKS 백그라운드 다운로더를 사용하여 이 다운로드 작업을 완료하거나, SOLIDWORKS 서비스 팩이 릴리즈될 때마다 이를 다운로드할 수 있습니다.

Solidworks 백그라운드 다운로더는 새 서비스 팩의 업데이트를 탐지하고 이를 백그라운드에서 자동으로 다운로드합니다. 이 때 다운로드 작업 완료 시간과 설치 준비가 된 파일을 알려주는 메시지가 표시됩니다. 자세한 내용은 SOLIDWORKS 백그라운드 다운로더를 참고하십시오.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


SOLIDWORKS 설치 관리자 파일 다운로드 옵션

SOLIDWORKS 설치 관리자의 차후 버전을 다운로드하도록 선택했습니다. 이 화면을 사용해서 다운로드되는 위치과 방법을 지정합니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.

이 화면은 기본 다운로드 폴더에 문제가 있을 경우에만 나타납니다(예를 들어, 쓰기 권한이나 네트워크 권한이 없을 경우). 대개, 다운로드를 계속할 다른 다운로드 디렉터리를 지정할 수 있습니다.

다운로드 디렉터리

SOLIDWORKS 설치 관리자 파일의 대상을 찾아봅니다.

다운로드 크기와 필요한 공간이 표시됩니다. 필요한 공간은 특정 다운로드의 압축 풀기에 필요한 추가 공간을 포함하고 실제 다운로드 크기보다 큽니다.

신속 다운로드 사용

이 옵션을 선택하면, 다운로더가 알고리듬을 사용해서 다운로드 속도를 향상시킵니다.

신속 다운로드로 대역폭이 증가되고 네트워크 작업 수행에 지장이 올 수 있습니다. 신속 다운로드를 사용하기 전에 네트워크 관리자와 확인합니다.

신속 다운로드가 프록시 서버로 지원되지 않을 경우 이 옵션이 자동으로 비활성화 됩니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 설치 파일 다운로드

특정 제품에 빠진 파일을 다운로드하는 위치과 방법을 지정합니다.

SOLIDWORKS 설치 관리자가 다운로드 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

이 화면을 취소하고 닫으면 남은 설치 작업이 취소됩니다.

취소 결과와 중단된 설치를 완료하는 방법에 관한 자세한 내용은 설치 오류를 참고합니다.

다운로드 디렉터리

다운로드된 파일의 대상을 찾아봅니다.

다운로드 크기와 필요한 공간이 표시됩니다. 필요한 공간에는 특정 다운로드의 압축 풀기에 필요한 추가 공간이 포함되고 실제 다운로드 크기보다 큽니다.

다운로드 폴더에 관한 질문의 답은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참조하십시오.

다운로드 옵션

SOLIDWORKS 설치 관리자 다운로드 폴더

더 높은 네트워크 대역폭을 사용해서 신속한 다운로드

다운로더는 다운로드 중 사용된 네트워크 대역폭을 높임으로서 알고리듬을 사용하여 다운로드 속도를 높입니다.

경우에 따라 네트워크 성능에 지장을 가져올 수 있습니다. 다운로드 중 문제가 있을 경우, 이 옵션은 프록시 서버에서 지원되지 않습니다. 이 옵션을 선택해제하고 다운로드를 재시도 합니다. 자세한 사항은 사용자의 네��워크 관리자에게 문의합니다.
신속 다운로드로 대역폭이 증가되고 네트워크 작업 수행에 지장이 올 수 있습니다. 신속 다운로드를 사용하기 전에 네트워크 관리자와 확인합니다.

신속 다운로드가 프록시 서버로 지원되지 않을 경우 이 옵션이 자동으로 비활성화됩니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 개념
SOLIDWORKS 설치 관리자 다운로드 폴더
관련 참조
설치 오류/취소된 설치


다운로드 진행

SOLIDWORKS 설치 관리자가 이 절차 중 모든 파일을 동시에 다운로드하고 확인하고 압축을 풉니다.

시작한 후 다운로드를 취소하려면 취소를 클릭합니다.

다운로드를 취소하거나 다운로드에 실패할 경우 다운로드 취소됨 또는 다운로드 문제 화면에 완료되지 않은 다운로드가 표시되어 다운로드를 계속하거나 응용 프로그램을 닫을 수 있습니다.

다운로드 폴더와 관련된 질문에 대한 답변은 SOLIDWORKS 설치 관리자 다운로드 폴더를 참고하십시오.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


다운로드 결과

다운로드 결과가 성공적이었는지, 실패했는지, 취소되었는지 여부를 알려줍니다.

다운로드 문제/다운로드 취소됨

다운로드 문제이(가) 나타나면 SOLIDWORKS 설치 관리자에 다운로드를 완료할 수 없는 문제가 발생한 것입니다.

다운로드 취소됨이 나타나면 다운로드가 완료되기 전에 사용자가 취소한 것입니다.

다운로드 계속하기:

자동 다운로드 다시 시도/계속 진행 | 취소한 부분부터 자동 다운로드를 계속 진행하려면 이 옵션을 선택하고 다운로드 다시 시도 또는 다운로드 계속 진행을 클릭합니다.
웹 브라우저에 파일을 개별 다운로드 | 경우에 따라, 프록시 서버로 인해 SOLIDWORKS 설치 관리자가 자동 다운로드를 수행할 수 없습니다. | 이 옵션을 선택함으로써, 웹 페이지를 통해 직접 파일을 다운로드한 후 SOLIDWORKS 설치 관리자에서 설치 과정을 완료할 수 있습니다. 이 웹 페이지는 설치 완료에 필요한 파일만 다운로드하도록 SOLIDWORKS 설치 관리자에 의해 사용자 정의됩니다.

다운로드 완료

다운로드만 옵션을 지정한 경우 다운로드가 완료되면 다운로드 완료 화면이 나타납니다.

마침을 클릭하여 SOLIDWORKS 설치 관리자를 종료합니다.

다운로드한 제품들을 직접 설치하려 하지 마십시오. 항상 SOLIDWORKS 설치 관리자를 사용하여 다운로드한 파일을 설치합니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


설치 오류/취소된 설치

설치 시 오류가 발생했거나 취소되었습니다.

오류나 취소가 발생되는 경우:
  • 오류나 취소 이전에 설치된 제품이 컴퓨터에 잔류합니다.
  • 가능하다면 취소 시 설치되던 제품을 되돌리며 부분적인 설치가 없게 됩니다.
  • 나머지 제품이 설치되지 않거나 설치 제거됩니다. 아직 시도하지 않았습니다 아래 해당 목록이 표시됩니다.

    해당 제품의 설치를 계속하거나 설치를 제거하려면 표시된 링크를 클릭합니다.

SOLIDWORKS 설치 관리자는 .NET Framework와 같이, 컴퓨터에 설치되지 않은 필수 구성 요소를 먼저 설치합니다.

목차

  • 실패하거나 취소된 설치 복구

    설치 중 오류가 발생하거나 설치가 취소된 경우 설치를 다시 실행하여 해당 지점에서 설치를 복구할 수 있습니다.

  • 설치 복구

    설치된 SOLIDWORKS 제품에 문제가 있을 경우, SOLIDWORKS 설치 관리자를 사용해서 설치를 복구할 수 있습니다.

  • SOLIDWORKS 리셀러에 문의

    설치의 수정이나 복구에 실패할 경우, 이 화면에서 수집된 정보와 함께 지역 SOLIDWORKS 리셀러에게 문의합니다. SOLIDWORKS 설치 관리자 로그 파일을 zip 파일로 제공해야 할 수도 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


실패하거나 취소된 설치 복구

설치 중 오류가 발생하거나 설치가 취소된 경우 설치를 다시 실행하여 해당 지점에서 설치를 복구할 수 있습니다.

  1. 설치 오류 또는 설치 취소 화면에 표시된 대로 실패한 설치의 오류 메시지와 제품 코드를 기록합니다.

    원본 파일을 찾는 메시지가 나타나고 SOLIDWORKS 기존 설치를 수정하지 않을 경우 설치나 컴퓨터가 손상될 수 있습니다. SOLIDWORKS 리셀러에게 문의합니다.

  2. 컴퓨터를 다시 시작합니다.
  3. Windows에서 실행되는 SOLIDWORKS 제품이 없는지 확인하려면 Ctr+Alt+Del을(를) 눌러 작업 관리자를 엽니다.
  4. 프로세스 탭에서 이미지 이름 아래 다음과 같은 프로세스가 나타나면 프로세스 끝내기을(를) 클릭합니다.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. 응용 프로그램이 이미 설치된 상태에서 수정이나 제거를 하려면 설치 복구를 시도합니다. 자세한 사항은 설치 복구하기를 봅니다.
  6. Windows 7 이상에서는 시작 > 제어판 >프로그램 추가/제거을(를) 클릭합니다. 이전 Windows 버전에서는 시작 > 제어판 > 프로그램 추가/제거을(를) 클릭합니다.
  7. 실패한 SOLIDWORKS 버전을 선택합니다.

    설치하려는 SOLIDWORKS 버전을 입력하지 않으면 설치 절차를 반복합니다.

  8. 다음 중 하나를 실행합니다.
    • 재시도하려면 변경을 클릭하고 설치 중 설치에 실패하거나 건너뛴 모든 제품을 선택합니다.

    • 실패한 설치를 건너뛰려면, 변경을 클릭하고 설치중 건너뛴 모든 제품을 선택합니다. 설치에 실패한 제품을 선택 취소합니다.

    • 설치를 중단하려면 제거를 클릭하고 설치된 제품을 선택합니다.

    이렇게 하면 업그레이드하는 제품의 이전 버전이 복구되지 않습니다.

상위 주제
설치 오류/취소된 설치
관련 태스크
설치 복구
SOLIDWORKS 리셀러에 문의


SOLIDWORKS 리셀러에 문의

설치의 수정이나 복구에 실패할 경우, 이 화면에서 수집된 정보와 함께 지역 SOLIDWORKS 리셀러에게 문의합니다. SOLIDWORKS 설치 관리자 로그 파일을 zip 파일로 제공해야 할 수도 있습니다.

  1. 로그 파일을 찾습니다.
    • Windows 7 이상:

      C:\Users\사용자 이름\AppData\Roaming\SOLIDWORKS\Installation Logs\설치된_버전\

    폴더를 찾을 수 없을 경우 숨은 폴더일 수 있습니다. Windows 탐색기에서 도구 > 폴더 옵션을 클릭합니다. 보기 탭의 고급 설정 아래에 있는 숨김 파일 및 폴더에서 숨김 파일 및 폴더 표시를 선택합니다.

  2. 하위 폴더를 포함한 이 폴더의 전체 항목을 압축합니다.
상위 주제
설치 오류/취소된 설치
관련 태스크
실패하거나 취소된 설치 복구
설치 복구


설치 완료

SOLIDWORKS 설치 관리자가 그 과정을 완료했습니다.

다음 옵션 중 하나가 표시됩니다.

새 기능 설명서

개별 설치의 경우, 설치 절차를 완료하면 SOLIDWORKS와 애드인 제품의 새 기능을 설명하는 문서가 나타납니다.

관리 이미지 설치의 경우, 클라이언트 컴퓨터가 설치를 완료하면 같은 문서가 나타납니다.

조사

신속한 조사에 응해서 설치 절차에 관한 사용자의 의견을 주시면 감사하겠습니다.

SOLIDWORKS 고객 피드백 프로그램에 참여

작업 수행 정보를 SOLIDWORKS에 보내면 제품 향상에 도움이 됩니다. 이 절차는 명확하며 기밀로 처리됩니다. 다음 중 하나를 선택합니다.
  • 참여함
  • 참여 안 함
  • 나중에 알림
자세한 내용은 고객 피드백 프로그램 웹 사이트을(를) 참조하십시오.

관리 이미지 작성이 완료되었습니다

관리 이미지 작성이 완료되면 이미지 사용자 정의를 클릭하여 관리 이미지 옵션 편집기를 실행하여 이미지를 사용자 정의할 수 있습니다.

현재 이미지를 클라이언트에 설치하는 방법을 보여줍니다.를 클릭하여 옵션 편집기 사용에 대한 사용법을 표시합니다.

옵션 편집기를 사용하여 관리 이미지를 구성하는 데 대한 자세한 내용은 관리 이미지 옵션 편집기를 참조하십시오.

이미지 사용자 정의를 클릭하여 관리 이미지 옵션 편집기를 시작하여 해당 관리자에 대한 옵션 설정을 사용자 정의합니다.
관리 이미지 설치 디렉터리에 있는 sldAdminOptionEditor.exe를 더블 클릭하여 나중에 옵션 편집기를 시작할 수 있습니다.

목차

  • SOLIDWORKS 업데이트 확인

    SOLIDWORKS 설치 관리자를 사용하여 업데이트를 직접 확인하거나 자동으로 주기적 업데이트를 확인하도록 구성할 수 있습니다.

  • SOLIDWORKS 고객 피드백 프로그램

    SOLIDWORKS를 설치할 때, 제품 향상에 도움이 되도록 작업 수행 정보를 SOLIDWORKS Corporation으로 보내도록 지정할 수 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 참조
관리 이미지 옵션 편집기


SOLIDWORKS 업데이트 확인

SOLIDWORKS 설치 관리자를 사용하여 업데이트를 직접 확인하거나 자동으로 주기적 업데이트를 확인하도록 구성할 수 있습니다.

  1. 다음 중 한 방법으로 SOLIDWORKS 설치 관리자를 시작합니다.

    • SOLIDWORKS 응용 프로그램에서 도움말 > 업데이트 확인을 클릭합니다.

    • Windows에서 시작 > 프로그램 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 클릭합니다.

    SOLIDWORKS 설치 관리자가 현재 사용할 수 있는 업데이트가 있는지 여부를 알려줍니다.

  2. 업데이트가 있을 경우 다운로드해서 설치할 지 여부를 선택합니다.
  3. 자동 주기적 업데이트 확인을 사용하도록 구성한 경우 SOLIDWORKS 설치 관리자가 그 과정을 완료할 때 __일마다 업데이트 확인을 선택하고 확인 빈도를 지정합니다.
상위 주제
설치 완료
관련 개념
SOLIDWORKS 고객 피드백 프로그램


SOLIDWORKS 고객 피드백 프로그램

SOLIDWORKS를 설치할 때, 제품 향상에 도움이 되도록 작업 수행 정보를 SOLIDWORKS Corporation으로 보내도록 지정할 수 있습니다.

이 정보는 SOLIDWORKS가 제품 사용과 품질에 관련된 트렌드를 결정하는 데 사용됩니다. 최고 품질의 제품을 만들고자 하는 목표에 이 성능 로그가 유용한 도구로 사용됩니다.

이 절차에는 숨김이 없습니다. 로그 파일 안에 포함된 모든 정보가 기밀로 취급됩니다. 이 정보는 기타 목적으로 사용되지 않으므로 사용자가 연락을 받는 경우는 없습니다.

고객 피드백 프로그램에 관한 자세한 정보는 고객 피드백 프로그램 웹 사이트를 참고하십시오.

상위 주제
설치 완료
관련 태스크
SOLIDWORKS 업데이트 확인


설치 위치

SOLIDWORKS 설치 위치를 지정합니다.

관리 이미지 작성을 제외한 설치에서 다음 옵션이 적용됩니다.
선택한 제품 설치 위치 | SOLIDWORKS를 설치하는 디렉터리 위치입니다. 설치를 업그레이드하거나 수정할 경우 해당 설치의 기존 위치에 모든 파일이 설치되어 있어야 합니다. 이 경우 SOLIDWORKS의 기존 설치 위치를 변경할 수 없습니다.
설치에 필요한 예상 디스크 공간 | 설치나 수정하기 위해 선택한 제품에 필요한 추가 공간입니다. | 설치할 디스크에 설치 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로 부터 설치 | SOLIDWORKS 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션을 참조하십시오.
SOLIDWORKS 설치 위치를 변경하기 전에 시스템 관리자에 문의하십시오.

관리 이미지 위치

관리 이미지를 작성할 경우에는 다음 옵션이 적용됩니다.
새로운 이미지 위치 | SOLIDWORKS 설치 관리자가 새로운 이미지를 작성할 디렉터리 위치입니다. | 이 위치에는 기존 이미지를 포함할 수 없습니다.
이미지 작성을 위해 필요한 예상 공간 | 관리 이미지 작성에 필요한 추가 공간입니다. | 설치할 디스크에 이미지 작성 조건에 맞는 충분한 여유 공간이 있는지 확인합니다.
다음으로부터 이미지 작성 | SOLIDWORKS 제품 설치를 실행하는 디렉터리 위치입니다. 이 옵션은 설치만 합니다 옵션을 지정한 경우에만 나타납니다. 자세한 내용은 다운로드 옵션을 참조하십시오.
기존 이미지 위치 | 기존 관리 이미지를 업그레이드할 경우 SOLIDWORKS 설치 관리자는 기존 이미지의 설정을 기반으로 새로운 이미지를 작성합니다. 이 기존 이미지는 수정되지 않습니다. 시작 화면에서 지정한 원본 이미지의 위치가 표시됩니다.

특정 버전 디렉터리 경로 사용하지 않기

설치 디렉터리 위치에 버전 번호를 지정하고(예: C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2015\) 해당 설치를 SOLIDWORKS 2016로 업그레이드하면 SOLIDWORKS 2015로 표시된 디렉터리가 SOLIDWORKS 2016 설치 디렉터리로 지정됩니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 참조
다운로드 옵션


업그레이드 옵션

한 개 이상의 SOLIDWORKS 이전 주요 버전이 해당 컴퓨터에 설치되어 있습니다. 기존 버전을 최신 버전으로 업그레이드할지, 새 버전에 대한 새 설치를 작성할지를 선택합니다.

이 옵션은 해당 컴퓨터에 설치된 현 주요 버전의 이전 버전이 없을 경우에만 나타납니다. 현 주요 릴리즈의 이전 버전이 설치되어 있지 않을 경우 SOLIDWORKS 설치 관리자는 항상 해당 설치를 업데이트합니다.

(SOLIDWORKS 2010부터는 동일 주요 버전에 대한 여러 서비스 팩의 병렬 설치가 지원되지 않습니다.)

업그레이드 시:
  • 지정한 모든 제품이 업그레이드됩니다.
  • 설치된 모든 제품이 기본적으로 선택됩니다.
  • 제품을 선택 취소하면 해당 제품이 업그레이드되지 않습니다.
    제품 구성 요소를 선택 취소할 경우 SOLIDWORKS 설치 관리자가 해당 구성 요소를 제거하도록 지정하는 것이 아닙니다. 제품 구성 요소를 제거하려면 프로그램 추가/제거를 사용합니다. 자세한 내용은 설치 제거하기를 참조하십시오.

적절한 옵션을 선택하고 다음을 클릭하여 계속합니다.

SOLIDWORKS 버전의 새 설치를 작성합니다.

이 옵션을 선택하면 현 주요 버전에 대한 새 설치를 작성하는 것 외에도 이전 주요 버전 설치를 유지합니다.

이 옵션은 최신 버전을 설치한 후에도 SOLIDWORKS의 이전 버전을 액세스하려는 경우 유용합니다. 예를 들어, 이전 버전을 실행하는 다른 사용자와 파일을 공유하는 경우 최신 버전을 사용하여 저장한 파일과 버전이 호환되지 않는 문제를 피할 수 있습니다.

SOLIDWORKS 이전 주요 버전을(를) SOLIDWORKS 현재 설치된 주요 버전(으)로 업그레이드합니다.

이 옵션을 선택하면 이전 버전 설치가 새 버전 설치로 업그레이드됩니다.
설치가 완료되고 나면 SOLIDWORKS 이전 버전을 해당 컴퓨터에서 더 이상 사용할 수 없게 됩니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 태스크
설치 제거


설치 진행

이 화면에 설치 절차가 표시됩니다.

시작한 후 설치를 취소하려면 취소를 클릭합니다.

취소 결과와 중단된 설치를 완료하는 방법에 관한 자세한 내용은 설치 오류을(를) 참조하십시오.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


설치 유형

새 설치, 기존 설치 수정 또는 복구, 관리 이미지 작성, 관리 서버 제품 설치, 또는 설치하지 않고 파일 다운로드 등과 같은 실행할 설치 작업을 지정합니다.

개별 설치

이 컴퓨터에 SOLIDWORKS 제품을 설치합니다.

이 옵션은 설치할 버전이 해당 컴퓨터에 설치되어 있지 않을 경우에만 나타납니다.

기존 개별설치 수정

해당 컴퓨터에서 기존 SOLIDWORKS 설치를 수정합니다.

이 옵션은 설치할 버전이 해당 컴퓨터에 설치되어 있을 경우에만 나타납니다.
수정 작업:
  • SOLIDWORKS 제품 구성 요소 추가 또는 제거
  • 다른 SOLIDWORKS 패키지(예: SOLIDWORKS Professional, SOLIDWORKS Premium 등)로 변경
  • SOLIDWORKS 제품 번호 설정 변경
    이전 설치 중에 SOLIDWORKS 제품 번호를 이미 지정한 경우 SOLIDWORKS 설치 관리자가 다시 물어보지 않습니다. SOLIDWORKS 설치 관리자에서 사용할 제품 번호를 변경하려면 이 옵션을 선택해야 합니다.

개별설치 복구

해당 컴퓨터에서 기존 SOLIDWORKS 설치를 복구합니다.

이 옵션은 설치할 버전이 해당 컴퓨터에 설치되어 있을 경우에만 나타납니다.
복구로 모든 파일이 존재하며 제대로 등록되고 검색된 문제를 수정하는지 확인합니다. 작성된 데이터는 영향을 받지 않습니다.
  • 제품을 복구하려면 선택이 되었는지 확인합니다.
  • 복구로 불필요한 제품의 확인란을 선택 취소합니다.
개별 설치를 복구할 수 있습니다. 관리 이미지 설치는 복구할 수 없습니다. 관리 이미지를 사용하여 다시 설치해야 합니다.

관리 이미지

현재 컴퓨터에 관리 이미지를 작성하거나 업데이트 합니다.

관리 이미지를 사용하여 여러 대의 컴퓨터에 설치할 수 있습니다. 관리 이미지를 사용하여 여러 클라이언트에 SOLIDWORKS를 설치하는 데 대한 내용은 관리 이미지 사용을 참조하십시오.

관리 이미지를 작성하거나 업데이트할 경우:
  • 기존 이미지의 설치 설정을 사용하여 새 이미지나 업데이트된 이미지를 구성하거나 SOLIDWORKS 기본 설치 설정을 사용할 수 있습니다.
  • 기존 이미지를 업데이트할 경우:
    • 업데이트하는 경우라도 SOLIDWORKS 설치 관리자가 새 이미지 복사본을 작성합니다. 원본 이미지는 수정되지 않습니다.
    • 업데이트하는 기존 이미지의 파일을 사용하여 업데이트된 이미지를 작성할 수 있습니다. 이렇게 하면 다운로드 크기가 작아집니다.
    이전 이미지를 업데이트하는 데 사용할 서비스 팩 버전의 이미지를 지정하지 않을 경우 크기를 줄이는 이점을 취할 수 없습니다.

서버 제품

SOLIDWORKS 관리 서버 제품으로는 SOLIDWORKS Electrical, SOLIDWORKS Workgroup PDM Server(볼트), SOLIDWORKS PDM 및 SolidNetWork License Manager 등이 있습니다.

SOLIDWORKS Electrical 및 SOLIDWORKS PDM의 경우, 같은 컴퓨터나 다른 컴퓨터에 클라이언트 및 서버 도구를 설치할 수 있습니다.

이러한 서버 설치에 대한 자세한 내용은 도움말의 해당 항목을 참조하십시오.

다운로드만

제품을 설치하지 않고 선택한 SOLIDWORKS 제품의 설치 파일을 다운로드합니다.

이 옵션은 DVD에서 설치하는 경우 사용할 수 없습니다.

다운로드한 파일의 내용이 SOLIDWORKS 설치 DVD에 있는 파일과 동일합니다. 이 옵션을 선택하면 사용자 컴퓨터에 이미 설치된 파일과 상관없이 설치 파일의 정품 세트를 다운로드합니다.

이 방식을 사용해서 사용자가 설치 작업을 하는 서버를 설정할 수 있습니다. 관리 이미지 작성과는 다릅니다.

현재 컴퓨터에 잘못된 버전의 SOLIDWORKS 아키텍처를 설치한 경우

현재 컴퓨터 아키텍처(예: 32비트 컴퓨터에 64비트 SOLIDWORKS를 설치하려는 경우)에 잘못된 버전의 SOLIDWORKS 설치 미디어를 사용하여 설치를 시도하는 경우, 설치 창에 이 오류가 표시됩니다.

설치를 계속하려면:
  1. 현재 SOLIDWORKS 설치 관리자 세션을 취소합니다.
  2. 현재 컴퓨터 아키텍처와 시스템 요구 사항을 확인합니다.
  3. 이 컴퓨터 아키텍처에 해당하는 올바른 버전의 SOLIDWORKS 설치 미디어를 사용하여 다시 설치합니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 개념
관리 이미지 사용
SOLIDWORKS Workgroup PDM
SolidNetWork License Manager를 사용하여 사용권 관리
SOLIDWORKS Electrical


여러 컴퓨터에 설치하고 관리하기

여러 대의 SOLIDWORKS 컴퓨터에 설치하고 관리하기 위해 SOLIDWORKS 설치 관리자에 다음 도구가 제공됩니다.

SOLIDWORKS 관리 이미지

여러 대 컴퓨터에 SOLIDWORKS를 설치할 경우, 관리 이미지를 사용한 다음 다른 컴퓨터로 응용 프로그램을 배포할 수 있습니다.

Workgroup PDM Server

Workgroup PDM 응용 프로그램은 SOLIDWORKS 환경에서 또는 SOLIDWORKS Explorer 안의 스탠드얼론 응용 프로그램으로 실행되는 프로젝트 데이터 관리 소프트웨어입니다. Workgroup PDM Server를 설치하면 관리되는 SOLIDWORKS 프로젝트를 저장하는 데이터베이스인 Workgroup PDM 볼트가 작성됩니다.

SOLIDWORKS Workgroup PDM 지원은 SOLIDWORKS 2017 이후로 종료됩니다. 이미 SOLIDWORKS Workgroup PDM을 사용 중인 고객은 계속 설치를 할 수 있지만 파일 볼트를 SOLIDWORKS PDM 서버로 마이그레이션하는 계획을 수립하기 시작해야 합니다.

SOLIDWORKS PDM

SOLIDWORKS PDM은 SOLIDWORKS Enterprise PDM과 동일한 클라이언트/서버 아키텍처를 기반으로 하는 문서 관리 제품입니다. 다음 2가지 버전으로 제공됩니다. Standard 및 Professional. SOLIDWORKS PDM은 Microsoft SQL Server 데이터베이스를 사용하여 파일 볼트를 관리합니다.

SolidNetWork License Manager

SolidNetWork License Manager로 사용권을 부동화하면 사용자 수가 사용권 수를 초과되는 것이 허용됩니다. 클라이언트 사용권을 사용하고 있지 않으면 다른 SOLIDWORKS 사용자가 사용할 수 있습니다.

SolidNetWork License Manager를 사용해서 FeatureWorks 등과 같은 SOLIDWORKS 주요 애드인 제품의 사용권을 배포할 수도 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


수동 다운로드

파일을 직접 다운로드할 것을 선택했습니다. (또는 마지막으로 SOLIDWORKS 설치 관리자를 실행할 때 수동 다운로드를 선택했습니다.)

해당 링크를 클릭하여 다운로드를 완료하는 데 필요한 전체 파일 목록이 포함된 자동으로 생성된 웹 페이지를 엽니다.

요약 페이지에서 지정한 폴더에 다운로드해야 합니다. 모든 파일이 해당 폴더에 다운로드되기 전까지는 설치를 시작할 수 없습니다.

수동 다운로드를 완료하고 나면 다음을 클릭하여 계속합니다.

자동으로 다운로드하려는 경우 요약 페이지로 돌아가 다운로드 옵션을 변경하여 옵션을 변경할 수 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


최신 버전이 있음

설치 관리자가 새 SOLIDWORKS 제품을 감지했습니다. 선택으로 원본 설치 DVD나 다운로드에 포함된 버전을 설치하거나, 최신 버전을 다운로드하고 설치할 수 있습니다.

DVD에서 설치할 경우

최신 버전을 사용하시겠습니까? 아래에서 다음 중 하나를 선택합니다.
  • 아니오, 이 DVD에서 버전을(를) 계속 설치합니다. 그 후 더 작은 다운로드로 업데이트가 가능합니다.

    이 옵션을 선택해서 현재 설치 관리자로 설치를 계속합니다.

    설치완료 후, 설치 관리자를 사용해서 업데이트를 확인하고 설치할 수 있습니다. 업데이트를 확인하려면 시작 > SOLIDWORKS 설치 관리자 > 업데이트 확인을 실행합니다.

    이 방식의 장점은 다운로드 크기가 작다는 것입니다. 단점은 2 단계 절차이고 다운로드 파일이 특정 버전에 속한다는 점입니다 (다른 버전을 사용하는 다른 사용자와 공유가 불가능합니다).

  • 예, 이 DVD로 설치하고 난 후 다음에 다운로드 및 업데이트합니다: 버전.

    이 옵션을 선택하면 설치 관리자의 차후 버전을 다운로드하고 실행하고 해당 버전의 SOLIDWORKS 제품이 설치됩니다.

    DVD 버전을 업데이트하는 작은 서비스 팩 버전이 있을 경우 설치 관리자는 DVD에서 원보 버전을 먼저 설치한 후 서비스 팩 업데이트를 적용합니다. 이렇게 하면 다운로드 크기가 작아집니다.

    DVD에서 설치를 계속한 후 나중에 업데이트를 적용하는 옵션을 선택하여 같은 결과를 얻을 수 있습니다.

    이 옵션의 이점은 한 단계로 이루어진다는 점입니다.

DVD으로 정품 버전을 설치한 후 설치관리자를 사용해서 설치 업데이트를 확인하면 다운로드 크기가 줄게되어 일반적으로 이 방식이 선호됩니다.

다운로드에서 설치할 경우

다음 중 하나를 선택합니다.
  • 버전설치를 계속합니다.

    이 옵선을 선택하면 첫 다운로드에 포함된 버전을 계속 설치합니다.

  • 새 버전 다운로드 및 설치: 버전

    이 옵션을 선택하면 새 버전을 다운로드해서 설치합니다. 여러 새 버전이 있을 경우, 다운로드하고 설치할 버전을 선택할 수 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


새로운 버전이 없음

다운로드할 새 버전이 없습니다. 지정된 버전을 계속 설치합니다.

설치를 계속하려면 다음을 클릭합니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


프로세스 감지

SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 설치를 하지 못하게 하는 프로세스를 감지했습니다.

  • SolidWorks 설치를 계속하려면 다음 중 하나를 실행합니다.
    • 관련 프로세스(예: Microsoft Windows 작업 관리자 사용)를 닫은 후 재시도를 누릅니다.
    • 프로세스를 닫지 않고 계속하려면 무시를 클릭합니다.
  • 설치를 중단하려면 취소를 누릅니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 선택

설치, 수정, 다운로드, 또는 제거할 제품 구성 요소를 지정합니다.

제품 목록에서:
  • 제품 목록은 위에서 지정한 제품 목록에 나타나는 전체 제품 목록입니다.
  • 특정 구성 요소에 대해 적용되는 작업을 보려면 확인란이 아닌, 구성 요소 이름을 클릭합니다. 계획된 설치 작업이 제품 목록 아래 정보 필드에 나타납니다.
  • 제품 구성 요소 옆에 있는 확인란을 클릭하여 해당 구성 요소에 대한 설치 작업을 변경할 수 있습니다. (예를 들어, 구성 요소를 설치하거나 제거할 경우 해당 확인란을 선택하면 구성 요소가 설치되거나 제거되도록 지정되고 확인란을 선택 취소하면 구성 요소가 설치되거나 제거되지 않도록 지정됩니다.)
  • 설치 수정을 수행하는 경우 제품 선택을 변경하면 구성 요소 왼쪽에 별표(*)가 나타납니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.

서비스 팩을 적용하는 경우, FeatureWorks와 같이 SOLIDWORKS 아래 나타나는 SOLIDWORKS 기능을 선택할 수 없습니다. 이 업그레이드 유형을 실행할 때 구성요소를 추가하거나 제거할 수 없기 때문입니다.

SOLIDWORKS 설치 관리자로 실행한 작업은 제품 공존 규칙 세트로 제어됩니다. 자세한 내용은 제품 공존 규칙을 참조하십시오.

SOLIDWORKS 설치 관리자는 기본적으로 다음 제품 구성 요소를 선택합니다.
  • 업그레이드 또는 서비스 팩 업데이트를 수행하는 경우 SOLIDWORKS 설치 관리자가 현재 설치된 제품을 선택합니다.
  • 그렇지 않으면, SOLIDWORKS 설치 관리자 사용할 수 있는 모든 제품을 선택합니다.
설치 또는 다운로드 시간과 필요한 디스크 공간을 줄이려면 제품 구성 요소를 확장하고 필요치 않은 구성 요소에 해당하는 확인란을 선택 취소합니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우 다른 패키지나 제품을 선택합니다을(를) 클릭하여 설치하거나 수정할 SOLIDWORKS 패키지(SOLIDWORKS Professional 또는 SolidWorks Premium)를 변경할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 설치 미디어의 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다. 구입하거나 평가하기 위해 받은 제품을 선택할 수 있습니다.

SOLIDWORKS 검색

SOLIDWORKS 검색으로 SOLIDWORKS 문서, Workgroup PDM 볼트와 3D ContentCentral에서 강력한 전체 텍스트 검색 기능이 제공됩니다. 검색이 미리보기와 파일 위치와 이름을 표시합니다.

설치 후 SOLIDWORKS 검색이 신속한 검색을 위해 SolidWorks 문서를 색인합니다. SOLIDWORKS 파일만이 기본적으로 색인됩니다.

Windows 데스크톱 검색이 사용자의 컴퓨터에 설치되지 않은 경우, SOLIDWORKS 검색을 설치하면 자동으로 설치합니다.

언어 지원

SOLIDWORKS 제품과 언어 구성 요소를 확장하면 사용자가 설치할 수 있는 언어가 표시됩니다.

언어은(는) SOLIDWORKS 제품 설치 시 지정된 언어만 지원됩니다. 이 때 SolidWorks가 아닌 타 제품의 경우 해당 언어 지정 설치에 영향을 받지 않습니다. 예를 들어 eDrawings®, SOLIDWORKS Workgroup PDM, SOLIDWORKS Explorer 및 SOLIDWORKS PDM 설치 시 지원하는 모든 언어가 설치됩니다.

필요한 공간

SOLIDWORKS 설치 관리자가 페이지 하단에 총 설치 크기나 총 다운로드 크기를 보고합니다.

  • 다운로드만 옵션을 선택하면 다운로드 크기이 표시됩니다. 다운로드 크기가 모든 다운로드 파일에 필요한 총 디스크 공간을 의미합니다 (다운로드 완료 후 파일 압축을 풀 때 추가 필수 공간 제외). 이 값은 추정값입니다.
    설치에 필요한 모든 파일이 총 다운로드 크기에 포함됩니다. 일부 파일이 현재 다운로드 폴더로 이미 다운로드된 경우, 다시 다운로드되지 않습니다. 결과적으로, 실제 다운로드 크기가 표시된 총 다운로드 크기보다 작거나 파일 다운로드가 필요합니다.
  • 그렇지 않으면 설치 크기가 나타납니다. 설치크기란 이 설치를 완료할 때 일어나는 디스크 공간 사용의 변경사항을 의미합니다. 파일 압축으로 인해 이 값은 추정값입니다.

    기존 설치를 업그레이드하거나 제거하려면 이 설치 크기는 0입니다.

    설치에 필요할 경우 표시된 수에 다운로드에 필요한 공간이 포함되지 않습니다.

    다운로드가 필요하고 같은 드라이브로 다운로드 하는 경우, 실제 필요한 디스크 공간이 표시되는 설치 크기보다 눈에 띄게 클 수 있습니다.

    차후 수정에서 다운로드와 설치 시간을 줄이려면, 설치후 다운로드 파일을 삭제합니다. 일반적으로 결과 업데이트와 패치를 하려면 마지막 정품 설치 파일 세트에 권한이 있어야 합니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 개념
제품 공존 규칙


다운로드할 제품

SOLIDWORKS 제품을 선택해서 특정 위치에 다운로드합니다.

다운로드 가능한 제품은 사용자가 제공하는 제품 번호로 결정됩니다:

  • 개별 부품에 실행할 작업이 각 항목의 오른쪽 나타납니다.
  • 구성 요소에 설치 하위 구성 요소 선택 항목이 포함되어 있으면 해당 구성 요소 옆에 + 아이콘이 표시됩니다. 구성 요소에 포함된 하위 구성 요소를 보려면 + 아이콘을 클릭합니다.
  • 하위 구성 요소 선택 항목이 보이게 구성 요소가 확장되어 있으면 해당 구성 요소 옆에 - 아이콘이 표시됩니다. 하위 구성 요소 목록을 축소하려면 - 아이콘을 클릭합니다.
  • 각 구성 요소의 왼쪽에 있는 확인란을 클릭해서 SOLIDWORKS 설치 관리자의 취급 방식을 선택합니다.
지정하지 않는 한 SOLIDWORKS 설치 관리자는 받을 수 있는 모든 제품 구성 요소를 다운로드합니다. 다운로드 시간과 필요한 디스크 공간을 줄이려면 제품 구성 요소를 확장하고 필요하지 않은 구성 요소만 선택합니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우, 다운로드할 SOLIDWORKS 패키지를 선택할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다.

SOLIDWORKS 설치 관리자로 사용자가 받을 수 있는 제품을 확인할 수 없을 경우 다른 패키지나 제품을 선택합니다을(를) 클릭하여 설치하거나 수정할 SOLIDWORKS 패키지(SOLIDWORKS Professional 또는 SolidWorks Premium)를 변경할 수 있습니다. 사용자가 선택한 패키지와 호환 가능한 설치 미디어의 SOLIDWORKS 제품 모두가 SOLIDWORKS 설치 관리자에 나열됩니다. 구입하거나 평가하기 위해 받은 제품을 선택할 수 있습니다.

언어 지원

언어는 SOLIDWORKS 제품 설치 시 지정된 언어만 지원됩니다. 이 때 SolidWorks가 아닌 타 제품의 경우 해당 언어 지정 설치에 영향을 받지 않습니다. 예를 들어 eDrawings®, SOLIDWORKS Workgroup PDM 및 SOLIDWORKS Explorer 설치 시 지원하는 모든 언어가 설치됩니다.

필요한 공간

선택한 제품에 따라 다운로드 작업에 필요한 속도가 표시됩니다. 다운로드 크기가 모든 다운로드 파일에 필요한 총 디스크 공간을 의미합니다 (다운로드 완료 후 파일 압축을 풀 때 추가 필수 공간 제외). 이 값은 추정값입니다.

차후 업데이트와 패치에서 다운로드와 설치 시간을 줄이려면, 설치 후 다운로드 파일을 삭제합니다. 일반적으로 결과 업데이트와 패치를 하려면 마지막 정품 설치 파일 세트에 권한이 있어야 합니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


복구할 제품

이 설치 복구하기를 지정할 경우 이 화면에 현 버전의 SOLIDWORKS 설치 관리자로 복구할 수 있는 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다.

복구로 모든 파일이 존재하며 제대로 등록되고 검색된 문제를 수정하는지 확인합니다. 작성된 데이터는 영향을 받지 않습니다.
  • 제품을 복구하려면 선택이 되었는지 확인합니다.
  • 복구로 불필요한 제품의 확인란을 선택 취소합니다.

복구를 클릭하여 선택한 제품의 복구를 시작합니다.

개별 설치를 복구할 수 있습니다. 관리 이미지 설치는 복구할 수 없습니다. 관리 이미지를 다시 설치해야 합니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


제품 번호

배포 상자에 기재된 제품 번호가 구입한 SOLIDWORKS 제품을 사용자의 컴퓨터와 연관시킵니다.

SOLIDWORKS 제품이 이미 사용자의 컴퓨터에 설치되어 있으므로 제품 번호가 기본적으로 표시됩니다.
  • SOLIDWORKS 제품 번호가 표시되어 있지 않으면 입력합니다.
  • 해당 SOLIDWORKS 사용권에 포함되지 않은 제품의 제품 번호가 있을 경우 다른 제품번호가 있습니까? 아래에서 해당 제품 항목을 클릭한 후 제품 번호를 입력합니다.

인터넷에 연결되어 있으면 입력한 제품 번호가 설치할 제품 선택시 사용 가능한 제품을 자동적으로 표시하는데 사용됩니다.

SOLIDWORKS 제품을 구입하는 여러 방법이 있으므로 일부 제품 번호로 두 개 이상의 제품을 포괄할 수 있습니다. 예를 들어, SOLIDWORKS 제품 번호로 개별 SOLIDWORKS Simulation 제품 번호를 입력하지 않고 SOLIDWORKS Simulation을 설치할 수 있습니다. 또한, 일부 제품은 제품 번호를 필요로 하지 않습니다. 제품 번호에 관한 질문은 리셀러(VAR)에게 문의하십시오.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


서버 설치

설치를 시도하는 서버 제품이 설치 결과와 함께 나열됩니다.

서버 설치 상태

서버 제품 설치는 외부 설치 응용 프로그램에 의해 수행됩니다. 현재 해당 응용 프로그램에 있지 않을 경우 설치를 완료하려면 해당 응용 프로그램으로 전환해야 합니다.

서버 제품 설치를 중단하려면 취소를 클릭합니다.

서버 설치 완료

외부 설치 응용 프로그램이 성공적으로 완료되었습니다.

마침 또는 다음를 클릭합니다.
  • 다른 관리 제품(예: SOLIDWORKS 관리 이미지)를 설치할 경우 해당 설치가 계속됩니다.
  • 서버 제품 설치만 설치 과정에 포함된 경우 SOLIDWORKS 설치 관리자가 닫힙니다.

취소나 실패한 서버 설치

서버 제품 설치가 시작된 후 취소되거나 실패한 경우 설치되지 않은 서버가 나열됩니다.

닫기 또는 다음를 클릭합니다.
  • 다른 관리 제품 설치를 지정한 경우 SOLIDWORKS 설치 관리자가 계속 실행됩니다.
  • 서버 제품 설치만 설치 과정에 포함된 경우 SOLIDWORKS 설치 관리자가 닫힙니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


SolidNetWork License Manager

SolidNetWork License Manager 서버 제품의 설치 옵션을 지정합니다.

제품 번호

SolidNetWork License 제품 번호를 지정합니다. 쉼표로 구분하여 여러 개의 제품 번호를 지정할 수 있습니다.
SolidNetWork 제품 번호는 SOLIDWORKS 제품 번호와 다릅니다.

설치 위치

SolidNetWork License Manager의 설치 위치를 지정합니다.

기존 SolidNetWork License Manager를 업데이트할 경우 기존 설치 위치에 설치해야 합니다.

자세한 내용

SolidNetWork License Manager 설치, 구성 및 사용에 관한 자세한 내용은 SolidNetWork License Manager를 사용하여 사용권 관리를 참조하십시오.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 개념
SolidNetWork License Manager를 사용하여 사용권 관리


요약

SOLIDWORKS 설치 관리자에 파일 작업에 필요한 모든 정보가 있습니다.

계속하기: | 지금 지금 버튼을 클릭하여 설치 과정을 시작합니다(예: 지금 설치, 지금 작성, 지금 다운로드, 지금 수정).
설치 설정 변경하기: | 변경하려는 부분에서 변경 [image] 을 클릭합니다(예: 제품, 설치 위치, Toolbox 옵션).
취소하기: | 취소을(를) 클릭하여 설치 구성 요소를 변경하지 않고 SOLIDWORKS 설치 관리자를 종료합니다.
이전 페이지로 돌아가기: | 뒤로을(를) 클릭하여 SOLIDWORKS 설치 관리자의 이전 페이지로 돌아갑니다.
설치 옵션의 특정 세트에 대한 자세한 정보(예: 제품, 설치 위치, Toolbox 옵션 등):
  1. 정보를 보려는 부분 옆의 변경 [image] 을 클릭합니다.
  2. 세부 정보 페이지가 나타나면 도움말을(를) 클릭하여 설치 옵션 설정에 대한 정보를 얻습니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


시스템 검사 경고

시스템 검사는 설치 과정에 영향을 줄 수 있는 보고된 문제를 검사합니다. 대부분의 경우 SOLIDWORKS 설치 관리자로 진행할 수 있습니다.

이 단계에서 나타날 수 있는 경고가 해결 방법에 대한 권고와 함께 아래 나와 있습니다.

제품 번호 확인 문제

설치관리자가 사용자의 제품번호를 확인할 수 없으므로 새 버전 확인이 불가능합니다. 연결 후 타당한 제품번호를 입력했다면, 일시적인 서버 문제일 수 있습니다. 나중에 재시도 합니다.

제품 번호 확인: 설치 관리자가 제품 번호를 확인할 수 없어 귀하가 설치 가능한 제품을 판별할 수 없습니다. 설치하고자 하는 제품을 선택할 수 있으나 설치 파일을 다운로드 할 수 없습니다. 설치 파일을 다운로드 할 수 있는 원본 파일이나 DVD가 있어야 합니다.

해상도(R):
  • 인터넷 연결을 확인합니다. 제품 번호를 확인하려면 인터넷에 연결되어 있어야 합니다.
  • 입력한 제품 번호가 설치하려는 제품에 유효한 지 확인합니다.
  • 일부 설치에서는 버전이 릴리즈된 당시의 유효한 서브스크립션이 필요할 수 있습니다. 자세한 내용은 SOLIDWORKS 리셀러에게 문의하십시오.
  • 대부분의 경우 DVD 또는 이전에 다운로드한 파일 세트로 설치할 경우 설치를 계속할 수 있습니다.

최신 버전이 있음

최신 버전이 있음

새로운 버전이 있음

이 제품의 최신 버전을 다운로드 할 수 있습니다.

해상도(R): 업데이트 확인 작업을 수행할 때 SOLIDWORKS에서 다운로드하여 새로운 버전을 설치하라는 메시지가 나타납니다. 처음에 지정한 버전을 사용하여 이 작업을 계속하거나 새로운 버전을 다운로드하고 해당 버전을 대신 사용하여 계속할 수 있습니다.

최근 버전 사용 가능

이 버전은 최근 버전입니다. 다음을 클릭하여 계속합니다.

새로운 다운로드가 없음

해결 방법: 이 메시지는 설치 또는 설치 수정 중에 업데이트 확인을 할 때 나타날 수 있습니다. 현재 사용자가 최신 버전을 설치하고 있거나 설치했음을 나타냅니다.

인터넷 연결 문제

인터넷 연결: 설치 관리자가 사용자의 설치 가능한 제품 확인을 위한 SOLIDWORKS 서버에 연결할 수 없습니다. 설치하고자 하는 제품을 선택할 수 있으나 설치 파일을 다운로드 할 수 없습니다. DVD의 원본 파일이나 이전에 다운로드 받은 파일을 제공해야 합니다.

새 버전 확인 불가능

설치관리자를 서버에 연결할 수 없어서 새로운 버전 확인이 불가능합니다.

해결 방법:
  • 인터넷 연결을 확인합니다.
  • DVD 또는 이전에 다운로드한 파일 세트로 설치할 경우 설치를 계속할 수 있습니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


구멍 가공 마법사/Toolbox 옵션

SOLIDWORKS Toolbox가 설치되어 있으면 SOLIDWORKS에 구멍 유형과 하드웨어의 규격 라이브러리가 포함됩니다.

SOLIDWORKS Toolbox 설정, 확장, 사용에 대한 자세한 내용을 보려면 SOLIDWORKS에서 도움말 > Toolbox 도움말을 클릭합니다.
이 도움말을 보려면 도구 > Add-In을 사용하여 Toolbox 애드인을 시작해야 합니다.

SOLIDWORKS Toolbox를 사용하기 전에, 사용자의 회사와 그룹 정책에 따라 적절히 구성되었는지 확인합니다. 여러 경우, 그룹이 구성되고 중앙 Toolbox가 유지됩니다. SOLIDWORKS 관리자에게 SOLIDWORKS 설치 중 Toolbox를 지정하는 방법에 대해 문의하십시오.

설치 후 선택된 SOLIDWORKS Toolbox를 변경할 수 있습니다. SOLIDWORKS에서 도구 > 옵션을 클릭합니다. 시스템 옵션 탭에서 구멍 가공 마법사/Toolbox를 클릭합니다.

다음 부분에는 이 화면에서 볼 수 있는 모든 설정의 모든 옵션에 대한 설명이 나와 있습니다. 실제로 표시되는 Toolbox 옵션은 해당 컴퓨터의 기존 SOLIDWORKS 및 Toolbox 설정과 사용자가 지정한 SOLIDWORKS 설치 관리자 선택 항목에 따라 다릅니다.

새 버전 Toolbox 작성

해당 컴퓨터에 새 버전의 SOLIDWORKS Toolbox를 작성합니다.

새 버전을 작성하려면 제품 선택 화면에서 SOLIDWORKS > SOLIDWORKS Toolbox를 확장하고 Toolbox에서 지원할 규격을 선택합니다. 모든 규격이 기본적으로 선택됩니다.

해당 컴퓨터의 기존 Toolbox는 수정되지 않습니다.

기존 Toolbox 참조 또는 업그레이드

기존 Toolbox를 사용합니다. 찾아보기를 클릭하여 현 설치에 사용하려는 Toolbox의 위치를 지정합니다.

  • Toolbox가 이전 SOLIDWORKS 주요 버전으로 설정된 경우 최신 버전으로 업그레이드됩니다. 해당 Toolbox에 대한 모든 사용자 정의가 업그레이드된 Toolbox에서 유지됩니다.
    Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.
  • Toolbox가 현 SOLIDWORKS 버전으로 설정된 경우(예를 들어, 이미 업그레이된 공유 네트워크 Toolbox를 지정한 경우) 해당 Toolbox에 대한 업그레이드가 수행되지 않습니다.
  • SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정를 참고하십시오.

이 옵션은 관리 이미지 작성을 제외한 모든 설치 시나리오에서 나타납니다.

이전 버전 Toolbox 업그레이드

이전 주요 버전으로 설정된 Toolbox를 새 위치로 복사하고 해당 복사본을 최신 버전으로 업그레이드합니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전이 해당 컴퓨터에 설치되어 있지만 해당 설치를 최신 릴리즈로 업그레이드할 것을 선택하지 않은 경우 나타납니다.
이 옵션의 목적은 이전 버전의 Toolbox를 사용하는 사용자에게 영향을 주지 않고 컴퓨터에 설치된 SOLIDWORKS의 이전 주요 버전의 Toolbox를 업그레이드하기 위함입니다.

SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정를 참고하십시오.

현재 설치된 이전 버전 Toolbox 업그레이드

현 Toolbox를 최신 버전으로 업그레이드합니다.
Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전을 현 버전으로 업그레이드하고 해당 버전으로 설정된 Toolbox가 해당 컴퓨터에 있을 경우 나타납니다.

SOLIDWORKS PDM 환경의 Toolbox를 업그레이드하는 경우 추가적인 절차가 필요합니다. 자세한 내용은 SOLIDWORKS Toolbox 설정를 참고하십시오.

설치된 현재 버전 Toolbox 사용

SOLIDWORKS 설치 관리자가 해당 컴퓨터에서 SOLIDWORKS의 현 주요 릴리즈 버전으로 설정된 Toolbox를 감지했습니다.

이 옵션을 선택하면 SOLIDWORKS가 이 Toolbox를 사용합니다. 업그레이드가 수행되지 않습니다.

이 옵션은 SOLIDWORKS의 이전 주요 릴리즈 버전이 해당 컴퓨터에 설치되어 있지만 Toolbox가 현 버전으로 설정되어 있는 경우 나타납니다. 이는 공유 Toolbox가 아직 이전 버전의 SOLIDWORKS를 실행하는 컴퓨터에서 작성된 경우 발생합니다.

클라이언트 컴퓨터를 위한 Toolbox 위치를 지정합니다

클라이언트를 관리 이미지로 설치할 때 네트워크나 디렉터리 위치를 기본 Toolbox 위치로 지정합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

이 옵션은 새 관리 이미지를 작성할 때 나타납니다.

클라이언트 컴퓨터의 기존 이미지가 참조하고 있는 Toolbox를 업그레이드 또는 사용합니다

업데이트하는 기존 관리 이미지에 지정된 Toolbox 위치를 사용합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

클라이언트 컴퓨터를 위해 다른 Toolbox 위치를 선택합니다

업데이트하는 기존 관리 이미지에 지정된 위치와 다른 Toolbox 위치를 지정합니다.
위치에 클라이언트 설치 시 SOLIDWORKS의 이전 주요 릴리즈 버전으로 설정된 Toolbox가 포함되어 있으면 SOLIDWORKS 설치 관리자가 해당 Toolbox를 업그레이드합니다.

목차

  • SOLIDWORKS Toolbox 설정

    SOLIDWORKS Toolbox는 강력하고 복합적인 도구입니다. 여기에서는 SOLIDWORKS 설치 관리자를 사용하여 Toolbox를 설정하기 전에 고려할 몇 가지 사항을 요약합니다.

  • UNC 서식

    UNC(Uniform(또는 Universal) Naming Convention) 서식은 공유 파일 위치를 나타내기 위해 파일 이름 구문 형식을 지정합니다.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말
관련 개념
SOLIDWORKS Toolbox 설정


SOLIDWORKS Toolbox 설정

SOLIDWORKS Toolbox는 강력하고 복합적인 도구입니다. 여기에서는 SOLIDWORKS 설치 관리자를 사용하여 Toolbox를 설정하기 전에 고려할 몇 가지 사항을 요약합니다.

SOLIDWORKS Toolbox에 대한 자세한 도움말 보기

SOLIDWORKS Toolbox 설정, 확장, 사용에 대한 자세한 내용을 보려면 SOLIDWORKS에서 도움말 > Toolbox 도움말을(를) 클릭합니다.
이 도움말을 보려면 도구 > 애드인을 사용하여 Toolbox 애드인을 시작해야 합니다.

공유 Toolbox 사용

Toolbox를 설치할 때, Toolbox 데이터를 로컬 컴퓨터나 공유 위치에 저장할 수 있습니다. 네트워크 위치에 Toolbox 데이터를 저장할 것을 권장합니다. 공유 위치를 사용함으로써, 모든 SOLIDWORKS 사용자가 같은 체결부품 정보를 공유할 수 있습니다.

첫 설치일 경우 Toolbox를 설치하고자 하는 새 공유 위치를 찾아봅니다.

기존 Toolbox 업그레이드

Toolbox를 SOLIDWORKS 새 주요 릴리즈 버전으로 업그레이드하면 해당 Toolbox가 SOLIDWORKS의 이전 주요 릴리즈 버전을 실행하는 컴퓨터와 호환되지 않습니다.

다른 컴퓨터에 이전 버전이 설치되어 있고 해당 버전에 대해 설정된 Toolbox 설정이 계속 필요한 경우 해당 Toolbox를 복사하고 그 복사본을 업그레이드해야 합니다. 새 SOLIDWORKS 설치를 통해 Toolbox 복사본이 업그레이드되고 이전에 설치된 SOLIDWORKS는 기존 Toolbox를 계속 사용합니다.

Toolbox 액세스 구성

설치 후 Toolbox 부품을 액세스할 때 SOLIDWORKS가 Toolbox 구성 방식을 확인하고 액세스와 성능 향상을 위한 제안을 합니다.

공유 네트워크 Toolbox(권장)을 액세스하기 위해서는 공유 Toolbox가 설치된 서버에 대한 UNC 경로를 사용합니다. 자세한 내용은 UNC 형식을 참조하십시오.

관리자가 모든 그룹에 Toolbox 비밀번호를 작성하고 권한 및 환경설정을 지정합니다. 설정에 액세스를 제한하고 공유 환경설정을 지정함으로써 그룹의 팀원이 모두 일정한 Toolbox 데이터를 사용할 수 있습니다.

SOLIDWORKS PDM 환경에서 Toolbox 업그레이드하기

SOLIDWORKS 소프트웨어를 업그레이드할 때 파트가 추가되었으면 Toolbox도 업그레이드됩니다. Toolbox 루트 폴더가 SOLIDWORKS PDM 볼트에 있으면 SOLIDWORKS 업그레이드를 시작하기 전에 Toolbox 폴더를 준비해야 합니다.

업그레이드를 수행하는 첫 번째 시스템에서 최근 버전 내려 받기를 사용하여 Toolbox 파일을 로컬 캐시로 다운로드하고 Toolbox 데이터베이스 파일을 체크아웃해야 합니다. 업그레이드하는 다른 시스템에서는 Toolbox 파일만 다운로드하면 됩니다.

업그레이드하기 전에 다음 사항을 확인하십시오.
  • 볼트 데이터베이스와 보관 서버에 완전한 최근 백업이 있는지 확인합니다.
  • Toolbox 파트가 체크아웃되었거나 현재 체크아웃된 어셈블리에 의해 사용되고 있지는 않은지 확인합니다.

Toolbox를 업그레이드하는 방법

  1. Windows 탐색기에서 모든 권한(체크아웃, 체크인, 추가, 삭제)을 가진 사용자로 볼트에 로그인합니다.
  2. Toolbox 폴더를 오른쪽 클릭하고 최근 버전 내려 받기를 클릭하여 모든 Toolbox 파일과 Toolbox 데이터베이스를 로컬 캐시에 복사합니다.
    보관 서버가 원격에 있는 경우에는 이 작업에 몇 분이 소요됩니다.
  3. \Toolbox_folder_name\lang\your_lang에서 Toolbox 데이터베이스 파일(SWBrowser.mdb)을 체크아웃합니다.
  4. SOLIDWORKS 설치 관리자를 실행하여 업그레이드를 수행합니다.
  5. 요약 화면 Toolbox 옵션 설치 위치가 볼트 내의 위치인지 확인합니다.

    볼트 내 위치가 아닐 경우 변경을 클릭하고 Reference or upgrade an existing Toolbox(기존 Toolbox 참조 또는 업그레이드)를 선택하여 볼트 내 Toolbox 위치를 찾습니다.

  6. 업그레이드가 완료되면 Windows 탐색기에서 Toolbox 폴더를 체크인하여 신규 또는 업그레이드된 파일을 볼트로 추가해 다른 사용자가 Toolbox를 사용할 수 있도록 합니다.
  7. SOLIDWORKS 2012 이상 버전으로 업그레이드할 경우, 볼트의 Toolbox 폴더에 다음 파일이 있는지 확인합니다.
    • \Toolbox_폴더_이름\Updates
    • \Toolbox_폴더_이름\ToolboxStandards.xml
    • \Toolbox_폴더_이름\Browser\ToolboxFiles.index

      이 파일이 없으면 공인 리셀러에게 문의하십시오.

  8. Toolbox를 사용하여 SOLIDWORKS PDM 통합을 사용하는 나머지 컴퓨터를 업그레이드합니다.
    1. Windows 탐색기에서 Toolbox 폴더에 대한 읽기 권한이 있는 사용자로 볼트에 로그인합니다.
    2. Toolbox 폴더를 오른쪽 클릭하고 최근 버전 내려 받기를 클릭하여 모든 Toolbox 파일을 로컬 캐시에 복사합니다.
    3. SOLIDWORKS 설치 관리자를 실행하여 업그레이드를 수행합니다.

      Installer가 Toolbox가 이미 업그레이드되었음을 감지합니다.

SOLIDWORKS PDM에서 Toolbox 구성에 대한 자세한 내용은 SOLIDWORKS PDM 관리 도구 도움말에서 SolidWorks Enterprise PDM 관리 도구을(를) 참조하십시오.

상위 주제
구멍 가공 마법사/Toolbox 옵션
관련 참조
UNC 서식


UNC 서식

UNC(Uniform(또는 Universal) Naming Convention) 서식은 공유 파일 위치를 나타내기 위해 파일 이름 구문 형식을 지정합니다.

\\서버\볼륨\경로

예:

\\Disk_Server\SOLIDWORKS\AdminImage

상위 주제
구멍 가공 마법사/Toolbox 옵션
관련 개념
SOLIDWORKS Toolbox 설정


제품 설치 제거

제어판에서 프로그램을 제거 또는 설치 제거하려면 화면에 현재 버전의 SOLIDWORKS 설치 관리자로 제거 가능한 SOLIDWORKS 제품이 버전 번호와 함께 표시됩니다. 표준, 사용자 정의 또는 전체 제거를 수행할 수 있습니다.

표준 제거를 수행하면 SOLIDWORKS 제품의 프로그램 파일 및 폴더가 제거됩니다. 표준 제거 대상으로 지정한 릴리즈의 모든 SOLIDWORKS 제품이 기본적으로 표시됩니다.

사용자 정의 제거를 수행하면 프로그램 파일 및 폴더, 레지스트리 키 및 데이터 폴더(예: SOLIDWORKS Toolbox), 원본 다운로드 위치의 파일 및 폴더 중에서 하나 이상이 제거됩니다.

설치 제거를 완전히 수행하면 설치 디렉터리, 레지스트리 키 및 데이터 폴더가 제거됩니다.

제품을 제거하는 방법
  1. 제거 화면에서 제품이 선택되어 있는지 확인합니다.

    모든 제품을 제거하면 Solidworks 설치 관리자도 제거됩니다.

  2. 제거하지 않으려는 제품은 선택 취소합니다</Z1>.

    어떤 제품이라도 그대로 두면 SOLIDWORKS 설치 관리자는 제거되지 않습니다.

  3. 사용자 정의 제거를 수행할지 또는 전체 제거를 수행할지 선택합니다.
    1. 고급 옵션에서 변경을 클릭합니다.

      고급 옵션 화면이 나타납니다. 프로그램 파일 및 폴더 옵션이 선택되어 있습니다.

    2. 사용자 정의 제거를 수행하려면 하나 이상의 옵션을 선택하고, 전체 제거를 수행하려면 모든 옵션을 선택합니다.
    3. 요약으로 돌아가기를 클릭합니다.
    4. 요약 화면에서 고급 옵션을 확장하여 제거 방법 및 항목을 표시합니다.
  4. 항목 제거를 클릭합니다.
항목 제거를 클릭하면 SOLIDWORKS 설치 관리자가 즉시 제품을 제거하기 시작합니다.
상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


Workgroup PDM 서버 옵션

SOLIDWORKS Workgroup PDM Server 제품의 설치 옵션을 지정합니다.

설치 위치

Workgroup PDM 서버 제품의 설치 위치를 지정합니다.

설치할 제품

설치할 Workgroup PDM 서버 제품을 지정합니다.
Workgroup PDM Vault | Workgroup PDM 볼트 데이터의 위치를 지정합니다. Workgroup PDM Viewer 사용권이 볼트와 함께 설치되어야 Viewer가 활성화 됩니다.
Workgroup PDM Viewer | Workgroup PDM Viewer를 설치할 때 Viewer가 액세스할 Workgroup PDM 볼트 컴퓨터의 이름이나 IP 주소를 지정해야 합니다.

Workgroup PDM API

Workgroup PDM API의 사용권은 SOLIDWORKS 클라이언트와 Explorer 클라이언트의 사용권에 포함되어 있습니다. API 체크인은 클라이언트 사용권이 필요합니다.

자세한 내용

Workgroup PDM 설치에 대한 자세한 내용은 SOLIDWORKS Workgroup PDM을 참고합니다.

Workgroup PDM 사용에 관한 자세한 내용은 SOLIDWORKS 도움말의 SolidWorks 도움말을(를) 참조하십시오.

상위 주제
SOLIDWORKS 설치 관리자 응용 프로그램 도움말


법적 고지

ⓒ 1995-2015, Dassault Systemes SolidWorks Corporation, a Dassault Systemes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

본 문서에서 언급한 정보 및 소프트웨어는 통보 없이 변경될 수 있으며 이는 Dassault Systemes SolidWorks Corporation(DS SolidWorks)의 책임이 아닙니다.

DS SolidWorks사의 서면 허가 없이는 목적에 상관 없이 전자적 또는 수동적인 방식 등의 어떠한 형태나 방법으로도 본 문서의 내용을 재생하거나 전송할 수 없습니다.

본 문서에서 언급한 소프트웨어는 허가 하에 제공되며 허가 조건하에서만 사용 및 복사가 가능합니다. DS SolidWorks사의 소프트웨어 및 문서의 모든 보증 사항은 사용권 계약에 기재된 것이며 본 문서나 내용물에 기재되지 않거나 암시된 내용은 본 보증 사항을 포함한 사용권 계약의 변형 및 수정 내용으로 간주하십시오.

특허권 고지

SOLIDWORKS® 3D 기계 설계 CAD 소프트웨어는 미국 특허권 5,815,154, 6,219,049, 6,219,055, 6,611,725, 6,844,877, 6,898,560, 6,906,712, 7,079,990, 7,477,262, 7,558,705, 7,571,079, 7,590,497, 7,643,027, 7,672,822, 7,688,318, 7,694,238, 7,853,940, 8,305,376; 8,581,902; 8,817,028, 8,910,078 및 외국 특허권(예: EP 1,116,190 B1 및 JP 3,517,643)에 의해 보호됩니다.

eDrawings® 소프트웨어는 미국 특허권 7,184,044, U.S. 특허권 7,502,027, 및 캐나다 특허권 2,318,706 에 의해 보호됩니다.

U.S. 및 기타 국가 특허 출원중.

SOLIDWORKS 제품 및 서비스에 관한 상표 및 제품명

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings 및 eDrawings 로고는 DS SolidWorks의 등록 상표이며 FeatureManager는 DS SolidWorks의 합작 등록 상표입니다.

CircuitWorks, FloXpress, PhotoView 360 및 TolAnalyst는 DS SolidWorks의 상표입니다.

FeatureWorks는 Geometric Ltd.의 등록 상표입니다.

SOLIDWORKS 2016, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Workgroup PDM, SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, eDrawings, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical, SOLIDWORKS Composer 및 SOLIDWORKS MBD는 DS SolidWorks의 제품 이름입니다.

기타 브랜드 또는 제품 이름은 각 보유 회사의 상표 또는 등록 상표입니다.

상용 컴퓨터 소프트웨어 - 소유권

소프트웨어는 48 C.F.R. 2.101(1995년 10월)의 용어 정의에 의거한 “상용 품목”으로, “상용 컴퓨터 소프트웨어” 및 “상용 소프트웨어 문서”(48 C.F.R. 12.212(1995년 9월)의 용어 정의에 의거)로 구성되어 있으며 (a) 민간 기관이 수행하거나 민간 기관을 대신한 조달(48 C.F.R. 12.212에 규정된 정책 준수) 또는 (b) 국방부 부서가 수행하거나 국방부 부서를 대신한 조달(48 C.F.R. 227.7202-1(1995년 6월) 및 227.7202-4(1995년 6월)에 규정된 정책 준수)을 위해 미국 정부에 제공됩니다.

위에서 언급한 경우를 제외한 권한으로 미국 정부 기관으로부터 본 소프트웨어 요청을 받았을 경우, 요청의 내용을 DS SolidWorks에 통지하면 DS SolidWorks는 자체 판단 하에 5일 내에 그 요청을 수락하거나 거절합니다. 계약업체/제조업체: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

SOLIDWORKS Standard, Premium, Professional 및 Education 제품에 관한 저작권 고지

소프트웨어 일부 ⓒ 1986-2015 Siemens Product Lifecycle Management Software Inc. All rights reserved.

이 작업에는 Siemens Industry Software Limited에서 소유하는 다음 소프트웨어가 포함되어 있습니다.

D-Cubed™ 2D DCM ⓒ 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ 3D DCM ⓒ 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ PGM ⓒ 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ CDM ⓒ 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ AEM ⓒ 2015. Siemens Industry Software Limited. All Rights Reserved.

소프트웨어 일부 ⓒ 1998-2015 Geometric Ltd.

이 소프트웨어에는 NVIDIA 2006-2010의 PhysX™가 포함되어 있습니다.

소프트웨어 일부 ⓒ 2001-2015 Luxology, LLC. All rights reserved. 특허 출원 중.

소프트웨어 일부 ⓒ 2007-2015 DriveWorks Ltd.

ⓒ 1984-2010 Adobe Systems Inc.와 그 사용권 허가업체. All rights reserved. U.S. 특허권 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382에 의해 보호됩니다. 특허 출원 중.

Adobe, Adobe 로고, Acrobat, Adobe PDF 로고, Distiller 및 Reader는 미국 및 기타 국가에서 Adobe Systems Inc.의 등록 상표 또는 상표입니다.

DS SolidWorks 저작권 정보에 대한 자세한 내용은 도움말 > SOLIDWORKS 정보를 참조하십시오.

SOLIDWORKS Simulation 제품에 관한 저작권 고지

소프트웨어 일부 ⓒ 2008 Solversoft corporation.

PCGLSS ⓒ 1992-2014 Computational Applications and System Integration, Inc. All rights reserved.

SOLIDWORKS Standard 제품에 관한 저작권 고지

ⓒ 2011, Microsoft Corporation. All rights reserved.

SOLIDWORKS PDM Professional 제품에 관한 저작권 고지

Outside In® Viewer Technology, ⓒ 1992-2012 Oracle

ⓒ 2011, Microsoft Corporation. All rights reserved.

eDrawings 제품에 관한 저작권 고지

소프트웨어 일부 ⓒ 2000-2014 Tech Soft 3D.

소프트웨어 일부 ⓒ 1995-1998 Jean-Loup Gailly and Mark Adler.

소프트웨어 일부 ⓒ 1998-2001 3Dconnexion.

소프트웨어 일부 ⓒ 1998-2014 Open Design Alliance. All rights reserved.

소프트웨어 일부 ⓒ 1995-2012 Spatial Corporation.

Windows®용 eDrawings® 소프트웨어는 부분적으로 Independent JPEG Group의 작업을 기반으로 합니다.

iPad®용 eDrawings® 일부 저작권 ⓒ 1996-1999 Silicon Graphics Systems, Inc.

iPad®용 eDrawings® 일부 저작권 ⓒ 2003 – 2005 Apple Computer Inc.


관리 이미지 옵션 편집기

SOLIDWORKS 관리 이미지 옵션 편집기 기능이 향상되었습니다.

  • 관리자는 새로운 제거 옵션을 사용해서 클라이언트 컴퓨터에서 전체 제거 또는 사용자 지정 제거를 수행할 수 있습니다. 제거 옵션은 옵션 편집기의 클라이언트 설치 옵션 섹션에서 사용할 수 있습니다. 옵션을 보려면 예, 사용자 정의 설치 제거를 수행합니다.를 클릭하고 제거할 항목을 선택합니다.
  • 관리자는 목록에서 SOLIDWORKS Toolbox 표준을 미리 선택할 수도 있습니다.