Instalace a správa programu SOLIDWORKS

Tato nápověda obsahuje informace o instalaci, licencích a správě produktů SOLIDWORKS pro individuální instalace i pro vícenásobné instalace.

Individuální instalace | Zavádění násobných instalací
Instalace Instalace na jednom nebo na více počítačích. | Instalace Vytvoření administrativní kopie, která se zavádí na více klientských počítačů.
Licencování Aktivace licence nebo síťové licence. | Licencování Aktivace licence nebo síťové licence.
Upgrady Instalace nové verze na individuálních počítačích. | Upgrady Instalace nové verze na více počítačích aktualizací administrativní kopie používané k instalaci na těchto počítačích.
Správa Změny, opravy a odstraňování instalací, upgrady na nové verze. | Správa Upgrady administrativních kopií a klientů, správa síťových licencí, správa úschovny Workgroup PDM.

Manažer instalací SOLIDWORKS vám umožní konfigurovat nastavení pro produkty SOLIDWORKS, mezi které patří SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, Workgroup PDM, SOLIDWORKS PDM a Manažer licencí SOLIDWORKS SolidNetWork.

Podpora SOLIDWORKS Workgroup PDM bude po verzi SOLIDWORKS 2017 ukončena. Zákazníci, kteří již software SOLIDWORKS Workgroup PDM používají, ho mohou nadále instalovat, ale měli by začít plánovat migraci úschoven na SOLIDWORKS PDM Server.

Manažer licencí SolidNetWor podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

Obsah

  • Individuální instalace nebo administrativní kopie

    Měli byste nainstalovat produkty SOLIDWORKS na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?

  • Zahájení instalace SOLIDWORKS

    Můžete zahájit instalaci SOLIDWORKS načtením z DVD na místním počítači s přístupem ke sdílené instalační složce nebo stahováním ze SOLIDWORKS.

  • Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8

    Uživatelské rozhraní systému Windows 8 (a novějších systémů) se významně liší od předchozích verzí Windows. Jsou zde odlišné navigační techniky i nové způsoby přístupu ke klíčovým příkazům.


Individuální instalace nebo administrativní kopie

Měli byste nainstalovat produkty SOLIDWORKS na každý počítač zvlášť, nebo vytvořit administrativní kopii a rozšířit instalaci na klienty pomocí jednoho příkazu?

Volba je závislá na počtu počítačů, na kterých provádíte instalaci. U nerozhodných situací zvažte následující porovnání.

Individuální instalace | Administrativní kopie
Uživatelé mohou provádět vlastní správu SOLIDWORKS. | Správce systému může upravit vícečetné instalace za použití Editoru možností. Určuje přitom možnosti instalace jako je vytvoření nové instalace nebo aktualizace stávající instalace, spuštění instalace jako administrativní uživatel, spuštění externích povelů před nebo po instalaci, různé seskupení produktů atd.
Počítače musí být fyzicky přístupné uživateli, který provádí instalaci. | Klientské počítače nemusí být fyzicky dostupné, ale musí být dostupné ze stejné sítě.
Můžete nainstalovat různé verze, aktualizace Service Pack, nebo produkty na různých počítačích s rozdílnými nastaveními. | S použitím Editoru možností mohou administrativní kopie udržet konzistentní verze, aktualizace Service Pack, produkty a nastavení pro vícečetné instalace.
Dané počítače musí mít přístup k síti nebo k e-mailu. Pro aktivaci softwaru SOLIDWORKS a stažení souborů je nutné síťové připojení nebo přístup k e-mailu. Síťový přístup je nutný také při shromažďování licencí ze síťového licenčního serveru.

Ke spuštění programu je vyžadováno připojení k místní síti. Zdrojové médium není vyžadováno na klientských počítačích.

Klientské počítače mohou být aktualizovány automaticky. Klientské počítače, na nichž je program nainstalován ze stejné administrativní kopie, používají stejnou aktualizaci service pack. Pokud chcete udržovat různé verze, můžete vytvořit různé administrativní kopie.

Lze nastavit automatickou aktivaci licence.

Administrativní kopie vyžaduje dodatečné místo na disku na serveru. Klienti vyžadují stejné místo jako individuální instalace.

Nadřazené téma
Instalace a správa programu SOLIDWORKS
Související pojmy
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8
Související úlohy
Zahájení instalace SOLIDWORKS


Zahájení instalace SOLIDWORKS

Můžete zahájit instalaci SOLIDWORKS načtením z DVD na místním počítači s přístupem ke sdílené instalační složce nebo stahováním ze SOLIDWORKS.

Spustit instalaci SOLIDWORKS můžete jedním z následujících způsobů:

  • K instalaci na místní disk počítače vložte odpovídající disk do diskové jednotky.
  • Chcete-li provést instalaci ze složky pro stahování, přejděte do dané složky a poklepejte na soubor setup.exe.
  • Instalace stažením z webové stránky SOLIDWORKS:
    1. Přejděte na webovou stránku společnosti SOLIDWORKS.
    2. Přihlaste se jako Subscription Service Customer (Zákazník předplacené služby), zadejte svoji emailovou adresu a heslo, nebo sériové číslo SOLIDWORKS.
    3. Pod položkou Self Service klepněte na Download Software and Updates.
    4. V části Download Software (Stáhnout software) (Windows, Mac, Linux) vyberte verzi SOLIDWORKS a aktualizaci Service Pack, kterou chcete stáhnout.
Nadřazené téma
Instalace a správa programu SOLIDWORKS
Související pojmy
Individuální instalace nebo administrativní kopie
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8


Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8

Uživatelské rozhraní systému Windows 8 (a novějších systémů) se významně liší od předchozích verzí Windows. Jsou zde odlišné navigační techniky i nové způsoby přístupu ke klíčovým příkazům.

Následující témata popisují, jak v systému Windows 8 spustit tři nejzákladnější funkce. Pokud pro instalaci aplikace SOLIDWORKS použijete systém Windows 8, prostudujte si je.
Tyto kroky se mohou lišit podle vaší konfigurace systému Windows. Další pokyny a možnosti, týkající se především systémů novějších než Windows 8, najdete v dokumentaci k systému Microsoft Windows.
Nadřazené téma
Instalace a správa programu SOLIDWORKS
Související pojmy
Individuální instalace nebo administrativní kopie
Instalace na individuálních počítačích
Související úlohy
Zahájení instalace SOLIDWORKS

Spouštění SOLIDWORKS

Aplikaci SOLIDWORKS můžete spustit ze Šému (Charm Bar) Windows 8 a také si ji můžete připnout na plochu.

Otevření aplikace SOLIDWORKS ze Šému:

  1. Na obrazovce Start klikněte do pravého dolního rohu.

    Na pravé straně obrazovky se zobrazí Šém.

    Šém lze také otevřít stisknutím loga Windows a klávesy C.

  2. Klepněte na ikonu vyhledávání.
  3. Do pole vyhledávání napište SOLIDWORKS a přejeďte prstem dolů nebo klepněte na dlaždici SOLIDWORKS.
Aplikaci SOLIDWORKS můžete připnout na plochu klepnutím pravým tlačítkem na dlaždici SOLIDWORKS a klepnutím na možnost Připnout na Úvodní obrazovku na panelu nástrojů, který se zobrazí v dolní části obrazovky.

Přístup k ovládacímu panelu

Přístup k ovládacímu panelu:

  1. Na obrazovce Start přejeďte prstem z pravé strany obrazovky nebo myší přejeďte přes pravý horní roh obrazovky.

    Na pravé straně obrazovky se zobrazí Šém.

  2. Klepněte na ikonu vyhledávání.
  3. Do pole vyhledávání napište Ovládací panel.
  4. Klepněte na dlaždici Ovládací panel, která se zobrazí na levé straně obrazovky Aplikace.

Přístup k příkazovému řádku

Přístup k příkazovému řádku:

  1. Na obrazovce Start klepněte pravým tlačítkem. V dolní části obrazovky se zobrazí panel nástrojů.
  2. Na pravé straně panelu nástrojů klepněte na možnost Všechny aplikace.
  3. Na pravé straně obrazovky Aplikace pod nabídkou Systém Windows stiskněte nebo klepněte na položku Příkazový řádek.

Užitečné zkratky

Následující seznam uvádí užitečné klávesové zkratky:

Alt + Tab | Přepíná mezi jednotlivými aplikacemi na ploše.
Klávesa s logem Windows + Q | Otevře seznam Aplikace a okno Vyhledávání.
Klávesa s logem Windows + R | Otevře dialogové okno Spustit.
Klávesa s logem Windows + I | Otevře podokno Nastavení.
Další klávesové zkratky naleznete v dokumentaci k systému Microsoft Windows.


Individuální instalace

Obsah

  • Instalace na individuálních počítačích

    SOLIDWORKS můžete do individuálního počítače nainstalovat za použití několika instalačních metod.

  • Správa individuálních instalací

    Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.


Instalace na individuálních počítačích

SOLIDWORKS můžete do individuálního počítače nainstalovat za použití několika instalačních metod.

Manažer instalací SOLIDWORKS přizpůsobí instalaci produktům, které jste zakoupili. Před instalací:

  • Připravte si sériové číslo SOLIDWORKS.
  • Ujistěte se, že máte připojení k internetu. Pro kontrolu oprávnění je nutné připojení k síti.

Manažer instalací SOLIDWORKS vyžaduje různé systémové součásti od společnosti Microsoft, včetně nástroje Instalační služba systému Windows, webových součástí balíku Office, nástrojů Microsoft Visual Studio Tools for Applications, jazyka Visual Basic a rozhraní .NET Framework. Pokud nejsou nainstalovány správné verze nutných součástí Windows, Manažer instalací SOLIDWORKS je automaticky nainstaluje před instalací programů SOLIDWORKS. Služba Bonjour pro Windows je rovněž vyžadovanou součástí.

Používáte-li systém Windows 8, podívejte se na Tipy ohledně používání aplikace SolidWorks v systému Microsoft Windows 8, kde najdete pokyny pro přístup do nabídky Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti, týkající se především systému Windows 8 nebo novějších verzí, najdete v dokumentaci k systému Microsoft Windows.
Metoda instalace | Stručné souhrnné informace o postupu
S použitím instalačního média SOLIDWORKS | Vložte disk DVD do jednotky v počítači.
Použití adresáře pro stahování na serveru V adresáři pro stahování poklepejte na setup.exe.

Tento adresář pro stahování musí být přístupný z počítače, do kterého instalujete produkty SOLIDWORKS, a musí už před začátkem instalace obsahovat všechny instalační soubory SOLIDWORKS. Manažer instalací SOLIDWORKS vám může pomoci najít chybějící soubory, pokud máte přístup na internet a oprávnění k zápisu do adresáře pro stahování.

Aktualizace stávající instalace SOLIDWORKS za použití Zjistit aktualizace Proveďte jednu z následujících operací:
  • V programu SOLIDWORKS klepněte na Nápověda > Zjistit aktualizace.
  • V systému Windows, klepněte na Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace.
Ujistěte se, že máte funkční připojení k internetu.

Klienti Workgroup PDM zaznamenají, že došlo k aktualizaci úschovny. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack. Bližší informace viz Aktualizace klientů v online nápovědě PDM Workgroup.

Stažení ze zákaznických webových stránek SOLIDWORKS
  1. Přejděte na webové stránky společnosti SOLIDWORKS.
  2. Přihlaste se jako Subscription Service Customer (Zákazník předplacené služby), zadejte svoji e-mailovou adresu a heslo, nebo sériové číslo SOLIDWORKS.
  3. Pod položkou Self Service klepněte na Download Software and Updates.
  4. Pod Stáhnout software klepněte na verzi SOLIDWORKS, kterou chcete nainstalovat.
Ujistěte se, že máte funkční připojení k internetu.

Musíte být Zákazníkem předplacené služby s přístupem na stránku Zákaznický portál.

Po dokončení instalace, spusťte program SOLIDWORKS a aktivujte licenci.

Chcete-li si zobrazit produkty instalované na vašem počítači, klikněte na nabídku Nápověda > Moje produkty v hlavní nabídce softwaru SOLIDWORKS. V seznamu Moje produkty se zobrazí všechny momentálně dostupné produkty SOLIDWORKS. Zaškrtnutí označuje produkty, které vy nebo vaše organizace momentálně vlastní na základě aktivace a síťových licencí.
Nadřazené téma
Individuální instalace
Související pojmy
Správa individuálních instalací
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8


Správa individuálních instalací

Administrace individuálních instalací se obvykle skládá ze změny, opravy, odebrání nebo aktualizace instalací.

Obsah

  • Změna instalace

    Instalaci můžete upravit, chcete-li nainstalovat produkty, které nebyly nainstalovány, nebo odstranit produkty – ovšem za předpokladu, že předchozí instalace byla dokončena s úplnou sadou instalačních souborů. Tato možnost není k dispozici, pokud jste předchozí instalace upgradovali pomocí aktualizace Service Pack.

  • Oprava instalace

    Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

  • Vrácení samostatné instalace na předchozí servisní balíček

  • Odstranění instalace

    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

  • Upgrade na novou verzi

    Upgrade individuální instalace nové verze SOLIDWORKS lze provést několika způsoby.

  • Pravidla koexistence produktu

    Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.

Nadřazené téma
Individuální instalace
Související pojmy
Instalace na individuálních počítačích


Změna instalace

Instalaci můžete upravit, chcete-li nainstalovat produkty, které nebyly nainstalovány, nebo odstranit produkty – ovšem za předpokladu, že předchozí instalace byla dokončena s úplnou sadou instalačních souborů. Tato možnost není k dispozici, pokud jste předchozí instalace upgradovali pomocí aktualizace Service Pack.

Pokud jste nainstalovali SOLIDWORKS a později zakoupili doplňkový modul, instalaci můžete změnit a zahrnout tento nový doplňkový modul. Doplňkový modul musíte nainstalovat na každém počítači zvlášť.

Pokud upravujete původní sadu SOLIDWORKS na verzi SOLIDWORKS Professional nebo SOLIDWORKS Premium, Workgroup PDM není zahrnut.
  1. Přesvědčte se, že žádné relace SOLIDWORKS nejsou aktivní.
  2. V systému Windows 7 nebo novějším klikněte na Start > Ovládací panely > Programy a funkce.
  3. Vyberte instalaci SOLIDWORKS, kterou chcete změnit, a klepněte na Změnit.
  4. Na obrazovce Vítejte v instalaci SOLIDWORKS klepněte na Změnit individuální instalaci (na tomto počítači).
  5. Na obrazovce Sériové číslo ověřte, že jsou určena správná sériová čísla.
  6. Na obrazovce Výběr produktu vyberte produkty k instalaci nebo odstranění.

    Když upravujete instalaci:

    • Standardně nejsou instalovány nebo odstraněny žádné produkty, dokonce ani když určíte nové sériové číslo. Musíte změnit instalační operaci každého produktu nebo součásti.
    • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klepněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
    • Chcete-li změnit akci instalace pro danou součást, můžete klepnout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
    • Pokud změníte akci instalace součásti oproti původní specifikaci, zobrazí se vedle této součásti v seznamu hvězdička (*).
    • Jestliže součást obsahuje volitelné dílčí součásti k instalaci, zobrazí se vedle ni ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
    • Jestliže byla součást rozbalena tak, aby se zobrazily dostupné volitelné dílčí součásti, zobrazí se vedle ní ikona -. Chcete-li výpis dílčích součástí sbalit, klepněte na ikonu -.

  7. Na obrazovce Souhrn klepněte na Nyní upravit.
  8. Na obrazovce Instalace je dokončena klepněte na Dokončit.
Nadřazené téma
Správa individuálních instalací
Související pojmy
Upgrade na novou verzi
Pravidla koexistence produktu
Související úlohy
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace


Oprava instalace

Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

Chcete-li opravit instalaci, musí váš počítač obsahovat v místě původní instalace všechny zdrojové soubory z předchozí instalace a veškeré aktualizace Service Pack, které byly použity.

Je možné opravit individuální instalaci. Administrativní kopii nelze opravit. Musíte ji nejprve odinstalovat a pak nainstalovat novou administrativní kopii.
  1. V systému Windows 7 nebo novějším klikněte na nabídku Start > Ovládací panely > Programy > Programy a funkce.
  2. Vyberte verzi SOLIDWORKS, kterou chcete opravit a klepněte na Změnit.
  3. Na obrazovce Vítejte v Manažeru instalací SOLIDWORKS klepněte na Opravit individuální instalaci (na tomto počítači)
  4. Na obrazovce Produkty k opravě vyberte produkty, které chcete opravit.
  5. Zrušte výběr všech ostatních produktů.
  6. Klepněte na Opravit.
Nadřazené téma
Správa individuálních instalací
Nadřazené téma
Chyby během instalace / Instalace byla zrušena
Související pojmy
Upgrade na novou verzi
Pravidla koexistence produktu
Související úlohy
Změna instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace
Obnovení po nezdařené nebo zrušené instalaci
Kontaktování prodejce SOLIDWORKS


Vrácení samostatné instalace na předchozí servisní balíček

Chcete-li vrátit individuální instalaci na předchozí verzi servisního balíčku v aktuálním souhrnu hlavní verze, odinstalujte aktuální verzi servisního balíčku na počítači a pak znovu nainstalujte předchozí verzi.
Nadřazené téma
Správa individuálních instalací
Související pojmy
Upgrade na novou verzi
Pravidla koexistence produktu
Související úlohy
Změna instalace
Oprava instalace
Odstranění instalace


Odstranění instalace

Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

  1. Přesvědčte se, že žádné relace SOLIDWORKS nejsou aktivní.
  2. Chcete-li převést licenci SOLIDWORKS na jiný počítač, nejprve ji převeďte a pak teprve odstraňte instalaci SOLIDWORKS z původního počítače.

    Další informace viz Převádění licence.

  3. V systému Windows 7 nebo novějším spusťte Ovládací panely > Programy a funkce.
  4. Vyberte součásti produktu, které chcete odebrat.

    V některých případech možná najdete několik součástí aktualizace Service Pack SOLIDWORKS pro danou hlavní verzi. Pro odstranění hlavní verze softwaru SOLIDWORKS odstraňte všechny prvky aktualizace Service Pack pro tuto hlavní verzi.

  5. Na obrazovce Odinstalace proveďte následující:
    1. Vyberte produkty, které chcete odebrat. Všechny instalované produkty jsou standardně vybrány .
    2. Zrušte výběr produktů, které nechcete odstranit.
    3. Určete, zda se má provést vlastní nebo úplná odinstalace. Ve výchozím nastavení provede Manažer instalací SOLIDWORKS standardní odinstalaci a odstraní programové soubory a složky.

      1. Klepněte na možnost Změnit v části Upřesňující možnosti.

        Zobrazí se okno Upřesňující možnosti a je vybrána možnost Programové soubory a složky.

      2. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
      3. Klepněte na Zpět na souhrnné informace.
      4. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.

    4. Klepněte na Odstranit položky.
Nadřazené téma
Správa individuálních instalací
Nadřazené téma
Správa násobných instalací
Související pojmy
Upgrade na novou verzi
Pravidla koexistence produktu
Upgrade administrativních kopií na novou verzi
Správa aktualizace produktu servisního balíčku
Související úlohy
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Převedení licence


Upgrade na novou verzi

Upgrade individuální instalace nové verze SOLIDWORKS lze provést několika způsoby.

Můžete provést upgrade na novou verzi, když:
  • obdržíte nové instalační médium
  • při spuštění SOLIDWORKS obdržíte oznámení o upgradech
  • Zjistit aktualizace ručně
  • spustíte novou instanci Manažera instalací SOLIDWORKS

Když instalujete novou verzi programu, můžete upgradovat předchozí hlavní verzi nebo paralelně nainstalovat novou verzi. Pokud je instalována verze servisního balíčku pro předchozí finální hlavní verzi, tato verze se aktualizuje automaticky.

Nadřazené téma
Správa individuálních instalací
Související pojmy
Pravidla koexistence produktu
Související úlohy
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace

Zjistit aktualizace ručně

Aktualizace verzí právě nainstalované verze SOLIDWORKS můžete zjistit za použití jedné z těchto metod.

  • V SOLIDWORKS klepněte na položku Nápověda > Zjistit aktualizace.
  • V systému Microsoft Windows klepněte na Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace.

Provedení upgrade u klientů Workgroup PDM

Klienti budou vyzváni k aktualizaci, když se poprvé přihlásí do aktualizované úschovny. K aktualizaci klientů není potřebná aktualizace service pack.

Stav klienta ve vztahu k úschovně | Operace
Stejná verze jako verze úschovny | Žádná
Stejná hlavní verze, novější než úschovna | Žádná
Novější hlavní verze, novější než úschovna | Přihlášení je blokované
Stejná hlavní verze, starší než úschovna | Volitelná aktualizace
Starší hlavní verze, starší než úschovna | Povinná aktualizace

Další informace ohledně aktualizace klientů Workgroup PDM najdete na odkaze Aktualizace klientů v Nápovědě PDM Workgroup.

Rizika upgradu

Produkty vyžadující několik instalací v rámci hlavních verzí nepodporují vždy hlavní upgrady, nebo schopnost provádět upgrade mezi hlavními verzemi prostřednictvím jedné operace.

V tomto případě Manažer instalací SOLIDWORKS simuluje upgrade tak, že nejprve nainstaluje novou verzi a pak odstraní starou. V současné době podporuje významné upgrady produkt jádra SOLIDWORKS, ale ostatní produkty ne.

Následky:
  • Když se provádí upgrade produktu jádra SOLIDWORKS mezi významnými verzemi:
    • Stávající umístění instalace se nemění.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, můžete ho vrátit zpět.
  • Když jsou ostatní produkty upgradovány mezi hlavními verzemi:
    • Každý produkt je nejprve nainstalován jako nový produkt do nového umístění a poté je původní instalace odstraněna.
    • Pokud dojde k chybě, nebo pokud upgrade zrušíte během upgradu, nelze ho vrátit zpět.


Pravidla koexistence produktu

Pravidla koexistence produktů určuje, jak jsou instalovány nové produkty a aktualizovány stávající produkty.

Pravidlo | Příklady
Je povoleno více hlavních finálních verzí základního produktu SOLIDWORKS s výjimkou produktů uvedených níže. | Programy SOLIDWORKS 2015 SP3.0 a SOLIDWORKS 2016 SP0.0 mohou být nainstalovány na stejném počítači.
Více servisních balíčků z některých hlavních finálních verzí není povoleno. | Verze SOLIDWORKS 2016 SP0.0 a 2016 SP1.0 nemohou být nainstalovány na stejném počítači zároveň. Pokud nainstalujete verzi SOLIDWORKS 2016 SP1.0 do počítače, kde je již nainstalována verze SOLIDWORKS 2016 SP0.0, správce instalace aplikace SOLIDWORKS nahradí aktualizaci SP0.0 aktualizací SP1.0.
Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • Server Workgroup PDM
  • Manažer licencí SolidNetWork
 Pokud je nainstalován program SOLIDWORKS 2016 SP0.0, aplikace Workgroup PDM Server se upgraduje na verzi 2016 SP0.0, i když v počítači zůstane starší hlavní verze programu SOLIDWORKS.
Na jednom počítači je povolena pouze jedna verze následujících produktů:
  • Klient SOLIDWORKS PDM
  • SOLIDWORKS PDM Server

Pokud nainstalujete verzi SOLIDWORKS 2016 SP0.0 nebo SP1.0, měli byste provést upgrade na server PDM Server a klienta PDM verze SOLIDWORKS 2016.

Pokud nainstalujete SOLIDWORKS 2016 PDM Server, měli byste použít proces instalace serveru PDM pro instalaci klienta SOLIDWORKS PDM. Neinstalujte klienta SOLIDWORKS PDM samostatně pomocí procesu instalace klienta.

Klient SOLIDWORKS PDM musí mít stejnou finální verzi a servisní balíček jako server SOLIDWORKS PDM ve stejném počítači.

Další informace najdete v tématu Instalace serveru PDM s pomocí SLDIM.

S jakoukoli hlavní verzí může být nainstalována pouze jedna verze produktu SOLIDWORKS. Verze zahrnutých produktů z různých hlavních verzí produktu SOLIDWORKS však mohou být nainstalovány společně. | Pokud je program SOLIDWORKS 2016 SP0.0 upgradován na verzi 2016 SP1.0, Průzkumník SOLIDWORKS 2016 SP0.0 je rovněž automaticky upgradován na verzi 2016 SP1.0. Průzkumník SOLIDWORKS 2015 SP4.0 však může být na počítači nainstalován také s verzí Průzkumníka SOLIDWORKS 2016 SP0.0 nebo SOLIDWORKS 2016 SP1.0.
Ke spuštění více než jedné významné verze SOLIDWORKS na stejném počítači potřebujete oprávnění správce.
Nadřazené téma
Správa individuálních instalací
Související pojmy
Upgrade na novou verzi
Související úlohy
Změna instalace
Oprava instalace
Vrácení samostatné instalace na předchozí servisní balíček
Odstranění instalace


Násobné instalace

Obsah

  • Zavádění více klientů

    Produkt SOLIDWORKS můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.

  • Použití administrativní kopie

    Administrativní kopie umožňuje konfigurovatelné instalace produktů SOLIDWORKS z jediného místa v síti.

  • Oznámení o administrativní kopii klientům e-mailem

    Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.

  • Zavedení pomocí příkazového řádku

    Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).

  • Správa násobných instalací

    Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.


Zavádění více klientů

Produkt SOLIDWORKS můžete nainstalovat na více klientů vytvořením administrativní kopie, kterou poté můžete nainstalovat na jednotlivé klienty.

Zavedení na klientské počítače probíhá následovně:
  1. Vytvoření administrativní kopie.
    • Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS
  2. Rozmístění administrativních kopií klientům.
    • Oznámení o administrativní kopii klientům e-mailem
    • Instalace z administrativní kopie s použitím příkazového řádku
  3. Provedenísprávy licencí.
    • Správa jednotlivých součástí
    • Správa licencí za použití manažera licencí SolidNetWork
Pokud používáte Windows 8, viz Tipy pro používání SOLIDWORKS s Microsoft Windows 8 pro úlohy, jako je přístup k Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti najdete v dokumentaci k systému Microsoft Windows.
Nadřazené téma
Násobné instalace
Související pojmy
Použití administrativní kopie
Oznámení o administrativní kopii klientům e-mailem
Zavedení pomocí příkazového řádku
Správa násobných instalací
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8


Použití administrativní kopie

Administrativní kopie umožňuje konfigurovatelné instalace produktů SOLIDWORKS z jediného místa v síti.

Administrativní kopii můžete nainstalovat z kteréhokoli počítače v síti, včetně klientského počítače.
  • Administrativní kopie se musí nacházet ve sdílené složce.
  • Pokud zahrnete všechny produkty, může požadavek na místo na disku administrativní kopie dosáhnout 7GB a více.
  • Pokud aktualizujete název sdílení, když aktualizujete administrativní kopii, klient se automaticky aktualizuje při příštím spuštění aplikace. Detaily najdete na odkazu Upgrade klientů z administrativních kopií.
  • Klienti musí mít oprávnění správce systému na svých počítačích. Pokud mají klienti nedostatečná oprávnění, je k instalaci administrativních kopií k dispozici alternativní metoda.

Po vytvoření administrativní kopie může Editor možností administrativní kopie spravovat nastavení možností instalace pro uživatele a skupiny, kteří provádí instalaci z dané kopie. Podrobné informace naleznete v Editoru možností administrativní kopie.

Obsah

  • Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS

    Pokud instalujete SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

Nadřazené téma
Násobné instalace
Související pojmy
Zavádění více klientů
Oznámení o administrativní kopii klientům e-mailem
Zavedení pomocí příkazového řádku
Správa násobných instalací
Upgradování klientů z administrativní kopie
Editor možností administrativní kopie


Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS

Pokud instalujete SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

  1. Spusťte Manažer instalací SOLIDWORKS. Viz Zahájení instalace SOLIDWORKS.
  2. Na obrazovce Vítejte vyberte Administrativní kopie.

    Objeví se možnosti pro vytvoření administrativní kopie:

    Volba | Popis
    Vytvořit novou kopii pomocí výchozích nastavení. | Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie. | Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
  3. Postupujte podle návodu na obrazovce.

Obsah

  • Editor možností administrativní kopie

    Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.

Nadřazené téma
Použití administrativní kopie
Související úlohy
Zahájení instalace SOLIDWORKS


Editor možností administrativní kopie

Editor možností administrativní kopie vám umožní přizpůsobit nastavení parametrů instalace v administrativní kopii pro jednotlivé počítače a pro skupiny počítačů.

Když vytváříte administrativní kopii, Manažer instalace SOLIDWORKS vás vyzve ke spuštění Editoru možností. Editor možností můžete také spustit poklepáním na sldAdminOptionEditor.exe ve složce administrativní kopie.

Pokud chcete určit různé konfigurace instalace pro skupiny počítačů nebo individuální počítače, v Editoru možností vyberte počítač podle názvu počítače, IP adresy nebo rozsahu IP adres a pak určete možnosti instalace pro tyto počítače.

Všechna dialogová okna, která žádají cestu složky nebo souboru, obsahují možnost přiřazení vybrané složky k proměnné prostředí. Pokud například vyberete cestu C:\Program Files\SOLIDWORKS Corp, bude namapována na proměnnou %ProgramFiles%\SOLIDWORKS Corp. Nejčastější proměnné jsou %ProgramFiles% a %SystemDrive%.

Všechny cesty nelze převést na proměnné prostředí. Například cestu Z:\SOLIDWORKS Data nelze namapovat na vhodnou proměnnou prostředí.

Obsah

  • Probíhá přidávání a odstraňování skupin a počítačů

    Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.

  • Zobrazení a úpravy nastavení možnosti

    Editor možností administrativní kopie SOLIDWORKS umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.

  • Zavádění instalací z editoru možností

    Instalace můžete zavádět přímo z Editoru možností, a to manuálně nebo automatickým spuštění instalace.

  • Ukončení editoru možností

    Editor možností můžete ukončit klepnutím na OK nebo Zavřít.

  • Vytvoření zástupce pro Editor možností na ploše

    Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.

Nadřazené téma
Vytvoření administrativní kopie pomocí Manažera instalací SOLIDWORKS


Probíhá přidávání a odstraňování skupin a počítačů

Editor možností administrativní kopie vám umožní určit různé konfigurační instalace pro skupiny počítačů a jednotlivé počítače.

Například pokud chcete konfigurovat několik počítačů pro použití zvláštní podskupiny součástí produktu, které jsou dostupné v kopii, zatímco jiná skupina může použít jinou podskupinu součástí produktu. I když používáte administrativní kopii, nastavení skupina Editora možností vám umožní instalovat různé podskupiny produktů pro různé skupiny počítačů.

Chcete-li přidat skupinu:
  1. Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Přidat skupinu.
  2. Zadejte název souboru.

Přidat počítače:
  1. Klepněte pravým tlačítkem na stávající skupinu nebo Globální nastavení a pak klepněte na Přidat počítač.
    Pokud klepnete pravým tlačítkem na existující skupinu, budou k této skupině přidány počítače. Jinak jsou přidány na nejvyšší úroveň.
  2. Proveďte jednu z následujících operací:
    • Vyberte Podle názvu počítače a zadejte jeden nebo více názvů počítačů. Více počítačů může být odděleno zalomením řádky, mezerou, tabulátorem, čárkou, tečkou, dvojtečkou nebo středníkem. Můžete nakopírovat a vložit seznam názvů počítačů z externího souboru. Názvy počítačů nemohou zahrnovat určovatele domény. Například název pluto.solidworks.com je chybný.
    • Vyberte Podle IP adresy a zadejte IP adresu počítače.
    • Vyberte Podle rozsahu IP adres a zadejte počáteční a koncovou IP adresu rozsahu.
    • Klepněte na položku Přidat více počítačů pro výběr počítačů ze sítě.

Návod na přesunutí existujícího počítače do skupiny:

Přetáhněte počítač do skupiny.

Návod na přesunutí počítače ze skupiny:

Přetáhněte počítač na Globální nastavení nebo do jiné skupiny.

Chcete-li smazat skupinu nebo počítač:

Klepněte pravým tlačítkem na skupinu nebo počítač a klepněte na Odstranit skupinu nebo Odstranit počítač.

Pokud odstraníte skupinu, budou smazány všechny počítače uvnitř této skupiny.

Pro odstranění všech skupin a počítačů:

Klepněte pravým tlačítkem naGlobální nastavení a pak klepněte na Odstranit vše.

Nadřazené téma
Editor možností administrativní kopie
Související pojmy
Zavádění instalací z editoru možností
Související úlohy
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše
Související odkazy
Zobrazení a úpravy nastavení možnosti


Zobrazení a úpravy nastavení možnosti

Editor možností administrativní kopie SOLIDWORKS umožňuje prohlížet a měnit nastavení možností pro skupiny a počítače určené pro danou kopii.

  • Když poprvé spustíte editor možností, zobrazí se nastavení možností v režimu jen pro čtení. Ikona Upravit není stínovaná.

    Klepnutím na Globální nastavení se pro skupinu nebo počítač zobrazí shrnutí nastavení možností pro danou položku:

    Rozsah | Zobrazené nastavení možností
    Globální nastavení | Všechna nastavení možností zadaná pro administrativní kopii
    Skupina | Změny v nastavení skupin vzhledem ke globálním nastavením
    Počítač | Změny v nastavení počítače vzhledem ke skupině
  • Chcete-li provést změny v nastavení možností, klepněte na ikonu Upravit. Ikona se změní na stínovanou a zobrazí se podrobnější výpis nastavení možností.

    Po klepnutí na Globální nastavení budete moci pro skupinu nebo počítač změnit nastavení možností pro danou položku. Když provedete změnu nastavení možností, která se liší od zděděných globálních nastavení nebo nastavení skupiny, bude toto nastavení možností zvýrazněno.

    Když znovu klepnete na ikonu Upravit, zobrazení se vrátí zpět do režimu jen pro čtení.

    Když provedete změny, Editor možností vás vyzve, abyste je před skončením uložili nebo zrušili.

Obsah

  • Určení nastavení možností pro skupiny a počítače

    Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.

  • Možnost nastavení administrativní kopie

    Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.

  • Dědičnost globálních nastavení a nastavení možností skupin

    Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.

  • Úprava nastavení v jednotlivých počítačích

    Nastavení, které se použije v jednotlivých počítačích, je možné upravit klepnutím pravým tlačítkem na název příslušného počítače.

Nadřazené téma
Editor možností administrativní kopie
Související pojmy
Probíhá přidávání a odstraňování skupin a počítačů
Zavádění instalací z editoru možností
Související úlohy
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše


Určení nastavení možností pro skupiny a počítače

Můžete určit nastavení možnosti pro všechny počítače (Globální nastavení), skupiny počítačů a jednotlivé počítače.

  1. Klepněte na objekt, který chcete změnit (například Globální nastavení, skupinu, nebo počítač).
  2. Vpravo klepněte na ikonu Upravit.

    Ikona Upravit se změní na stínovanou a zobrazí se podrobnější výpis nastavení možností.

  3. Proveďte změny nastavení možností klepnutím na nastavení možností vpravo pro položku vybranou vlevo.

    Změny v nastavení možností, které potlačí Globální nastavení nebo nastavení skupin, jsou zvýrazněny.

  4. Klepnutím na OK nebo Zavřít uložte provedené změny.
    Volba | Popis
    OK | Editor možností uloží vaše změny a ukončí aplikaci.
    Zavřít | Editor možností zobrazí dotaz, zda chcete provedené změny uložit, a poté ukončí aplikaci.
Nadřazené téma
Zobrazení a úpravy nastavení možnosti
Související pojmy
Dědičnost globálních nastavení a nastavení možností skupin
Úprava nastavení v jednotlivých počítačích
Související odkazy
Možnost nastavení administrativní kopie


Možnost nastavení administrativní kopie

Editor možností vám umožňuje zadat možnosti pro individuální klienty nebo skupiny, včetně sériových čísel, možností klientské instalace, jaké součásti softwaru mají být instalovány a umístění toolbox.

Sériová čísla

Zadejte sériová čísla pro produkty, které budete instalovat na klientské počítače.
Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SOLIDWORKS. Například sériové číslo SOLIDWORKS vám umožní nainstalovat SOLIDWORKS Simulation bez zadání sériového čísla SOLIDWORKS Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoliv dotazy ohledně sériových čísel, kontaktujte místního prodejce.
Pokud spravujete licence pomocí správy licencí SolidNetWork:
  • Do prvního pole pro sériové číslo zadejte sériové číslo SolidNetWork.
  • Do pole Do pole zadejte název serveru Manažera licencí SolidNetWork a port ve formátu SNL Server port@server@ zadejte název serveru Manažera licencí SolidNetWork a port ve formátu . Více položek oddělte středníkem.

Podrobnosti o licencování SolidNetWork viz Instalace a konfigurace licencí SolidNetWork.

Možnosti klientské instalace

Jakým způsobem provést klientské instalace hlavních verzí? Můžete určit, jak budou klientské instalace nakládat se stávající instalací hlavní verze:
  • Upgradovat stávající hlavní verzi (pokud existuje).

    Určete tuto možnost, pokud chcete nahradit předchozí hlavní verzi instalací nové verze.

  • Vytvořit novou hlavní verzi.

    Tuto možnost zvolte, pokud chcete zachovat předchozí hlavní verzi a vytvořit novou instalaci pro novou hlavní verzi. Chcete-li zadat umístění pro instalaci nové verze, klepněte na Procházet.
Chcete nejprve odinstalovat předchozí verzi než nainstalujete novou hlavní verzi? Můžete určit, zda se má odinstalovat stávající instalace předchozí hlavní verze:
  • Ne, neodinstalovat.

    Tuto možnost vyberte, chcete-li zachovat předchozí instalaci hlavní verze.

  • Ano, provést vlastní odinstalování.

    Tuto možnost vyberte, pokud chcete odstranit následující položky: Programové soubory a složky, položky registru, datové soubory a složky.

Jakým způsobem se mají aplikovat nastavení programu SOLIDWORKS? Můžete určit, zda mají klientské instalace nakonfigurovat nastavení SOLIDWORKS podle nastavení SOLIDWORKS nakonfigurovaných na klientském počítači, nebo podle nastavení SOLIDWORKS vyexportovaných z Průvodce kopírováním nastavení. Průvodce kopírováním nastavení uloží, obnoví a rozmnoží nastavení systému mezi uživateli, počítači nebo profily.
Průvodce kopírováním nastavení můžete spustit z nabídky Nástroje > Uložit/obnovit nastavení v softwaru SOLIDWORKS nebo kliknutím na nabídku Start > Všechny programy > SOLIDWORKS verze > Nástroje SOLIDWORKS > Průvodce kopírováním nastavení [image].
Vyberete-li příkaz Nástroje > Uložit/obnovit nastavení, spustí se Průvodce kopírováním nastavení ve zvláštním režimu, který umožňuje softwaru SOLIDWORKS běžet dále i během ukládání nebo obnovování vašeho aktuálního uživatelského nastavení.
  • Použít aktuální nastavení (pokud existují) nebo použít výchozí nastavení SOLIDWORKS

    Pokud klientský počítač nadefinoval nastavení SOLIDWORKS, zachovejte tato nastavení. (Pro všechna nastavení, která nejsou specificky nadefinována na klientovi, použije klientská instalace výchozí nastavení SOLIDWORKS.)

  • Použít soubor nastavení exportovaný z Průvodce kopírováním nastavení.

    Výběr nastavení této možnosti vám umožňuje určit nastavení možnosti ze stávajícího souboru exportu Průzkumníka kopírováním nastavení. (Tento soubor je nejčastěji pojmenován solidworkssettings.sldreg.) Klepnutím na Procházet vyhledejte stávající soubor nastavení, případně klepněte na možnost Nový a spusťte Průvodce kopírováním nastavení, který vám pomůže vytvořit nový soubor nastavení.

    Více informací najdete v Nápovědě SOLIDWORKS.
Jak aktivovat klientské instalace? Můžete určit, zda chcete dokončit aktivaci produktu automaticky po spuštění instalace, nebo zda má aktivaci produktu provést po instalaci ručně uživatel.
Pokud zvolíte automatickou aktivaci produktu, musí být administrativní kopie dostupná ve sdíleném umístění na síti, když klienti po instalaci poprvé spustí SOLIDWORKS. Pokud nebude administrativní kopie dostupná klientům, kteří z ní provedli instalaci, nebudou moci dokončit automatickou aktivaci produktu. Tito klienti nebudou moci spustit SOLIDWORKS, pokud neprovedou ruční aktivaci produktu SOLIDWORKS.
  • Aktivovat automaticky po dokončení každé klientské instalace.

    Výběr tohoto nastavení možnosti určuje, že k aktivaci produktu dochází automaticky pomocí souboru aktivace produktu SOLIDWORKS. (Tento soubor se většinou jmenuje AutoActivation.xml.) Klepnutím na Procházet můžete vyhledat existující aktivační soubor, nebo můžete Nový pro aktivaci produktu SOLIDWORKS a vytvoření nového aktivačního souboru.

  • Neaktivovat automaticky.

    Výběr této možnosti znamená, že nedojde k žádné automatické aktivaci produktu. Uživatel klienta provede aktivaci produktu po instalaci.

Možnosti správy

Vytvořit diagnostický protokol během každé instalace. | Klientská instalace může vytvořit diagnostický protokol, který lze použít k řešení problémů s instalací. Vytvoření tohoto protokolu může zpomalit klientskou instalaci.
Spustit instalaci jako jiný uživatel. | Klientskou instalaci lze spustit jako jiný uživatel pouze v případě, že je vypnuta funkce Řízení uživatelských účtů. Tato volba může být užitečná, když jednotliví uživatelé nemají na svých počítačích místní oprávnění správce (která jsou nutná k instalaci produktů SOLIDWORKS). Pro případ, že klienti nemají oprávnění správce, je k dispozici alternativní metoda rozmístění a instalace. Viz Zavádění instalací z editoru možností.
Spustit program před nebo po instalaci. | Můžete určit, že se má před klientskou instalací nebo po ní spustit vlastní program.
Chcete se zúčastnit Programu zkušeností zákazníka SOLIDWORKS? | Můžete určit, že se klientské počítače mají účastnit Programu zkušeností zákazníků SOLIDWORKS. Informace o výkonu jsou zasílány společnosti SOLIDWORKS Corporation, aby pomáhaly zlepšovat produkt. Tento proces je transparentní a důvěrný. Podrobnosti najdete v webu Programu na zlepšení zkušeností zákazníků.

Omezení možností Spustit program před a po instalaci.

Tyto možnosti umožňují spustit v klientských počítačích další instalační programy nebo skripty před nebo po rozmístění SolidWorks, například skript, který nainstaluje Microsoft Office.

Pokud rozmísťujete automaticky do klientských počítačů se systémem Windows 8, existuje další omezení použití těchto možností. Dojde k selhání při použití této možnosti pro instalaci programu nebo skriptu, který zobrazuje uživatelské rozhraní, například skriptu, který zobrazí dialogová okna. Pokud je spuštěno automatické rozmísťování SOLIDWORKS, nepodaří se software SOLIDWORKS nainstalovat do cílových počítačů. Toto omezení není v klientských počítačích se systémem Windows 7.

Jestliže chcete použít možnosti Spustit program před instalací a Spustit program po instalaci, měli byste vybírat pouze programy, které lze instalovat v bezobslužném režimu.

Software k instalaci

Můžete určit, které součásti produktu SOLIDWORKS se mají nainstalovat.
  • Výběrem zaškrtávacího políčka vedle součásti produktu určíte, že se má daná součást nainstalovat během klientské instalace.
  • Je-li výběr zaškrtávacího políčka zrušen, součást nebude nainstalována.
  • Jestliže součást obsahuje volitelné dílčí součásti k instalaci, zobrazí se vedle ni ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • Jestliže byla součást rozbalena tak, aby se zobrazily dostupné volitelné dílčí součásti, zobrazí se vedle ní ikona -. Chcete-li výpis dílčích součástí sbalit, klepněte na ikonu -.
Specifikace Jazyky vymezuje jazyky, které se instalují pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například programy eDrawings®, SOLIDWORKS Workgroup PDM a Průzkumník SOLIDWORKS instalují všechny jazyky.

Možnosti Toolbox

Můžete určit, které normy mají být podporovány, a výchozí umístění Toolbox pro klientské instalace.

Je běžné, že má více uživatelů přístup ke sdílené knihovně Toolbox, typicky prostřednictvím síťového umístění (například cesty UNC, sdílené složky nebo určené obecné síťové jednotky).

Pokud umístění obsahuje starší hlavní verzi Toolbox, klientská instalace upgraduje daný Toolbox na novou hlavní verzi. Soubory již nebudou kompatibilní s předchozími významnými verzemi SOLIDWORKS.
Pokud chcete zachovat Toolbox pro starší verzi SOLIDWORKS (například pokud někteří klienti nadále používají starší verzi), musíte určit jiné síťové umístění pro klienty, kteří upgradují na novější verzi.

Podrobnosti o správě SOLIDWORKS Toolbox viz informace o Toolbox v Nápovědě SOLIDWORKS.

Možnosti klienta SOLIDWORKS PDM

Následující možnosti pro nasazení klientů a doplňkových modulů SOLIDWORKS PDM lze změnit:

  • Typ produktu PDM
  • Typ klienta PDM
  • Prvky

Další informace o těchto klientech a doplňkových modulech najdete v části SOLIDWORKS PDM.

Možnosti Electrical

Pro administrativní součásti softwaru SOLIDWORKS Electrical můžete zadávat následující parametry:
  • Cesta k datům
  • Název počítače a číslo portu serveru Collaborative Server
  • Název počítače a číslo portu serveru SQL

Další informace o těchto součástech najdete v části SOLIDWORKS Electrical.

Nadřazené téma
Zobrazení a úpravy nastavení možnosti
Související pojmy
Dědičnost globálních nastavení a nastavení možností skupin
Úprava nastavení v jednotlivých počítačích
Instalace a konfigurace licencí SolidNetWork
Zavádění instalací z editoru možností
SOLIDWORKS Electrical
Související úlohy
Určení nastavení možností pro skupiny a počítače


Dědičnost globálních nastavení a nastavení možností skupin

Nastavení možností pro Globální nastavení nebo skupiny dědí položky pod nimi.

Příklad:
  • Nastavení definovaná pro Globální nastavení dědí všechny skupiny a počítače.
  • Nastavení definovaná pro skupiny dědí všechny počítače uvnitř této skupiny.

Můžete změnit nastavení možností pro počítač nebo skupinu počítačů tak, aby se přepsala výchozí nebo zděděná nastavení. Když změníte nastavení možností z výchozí nebo zděděné hodnoty, volba je zvýrazněna.

Chcete-li vrátit nastavení na původní zděděné hodnoty, klepněte pravým tlačítkem myši na skupinu nebo počítač a klepněte na Obnovit globální nastavení (pro skupinu nebo počítač, který není členem skupiny) nebo Obnovit skupinová nastavení (pro počítač, který je členem skupiny).
Nadřazené téma
Zobrazení a úpravy nastavení možnosti
Související pojmy
Úprava nastavení v jednotlivých počítačích
Související úlohy
Určení nastavení možností pro skupiny a počítače
Související odkazy
Možnost nastavení administrativní kopie


Úprava nastavení v jednotlivých počítačích

Nastavení, které se použije v jednotlivých počítačích, je možné upravit klepnutím pravým tlačítkem na název příslušného počítače.

V místní nabídce můžete u jednotlivých počítačů provést tyto úlohy:
  • Smazat počítač z editoru
  • Obnovit globální nastavení
  • Přidat nebo upravit poznámky
  • Upravit možnosti

V nabídce Upravit možnosti můžete upravit jednotlivé možnosti počítače, například možnosti klientské instalace nebo možnosti správy.

Nadřazené téma
Zobrazení a úpravy nastavení možnosti
Související pojmy
Dědičnost globálních nastavení a nastavení možností skupin
Související úlohy
Určení nastavení možností pro skupiny a počítače
Související odkazy
Možnost nastavení administrativní kopie


Zavádění instalací z editoru možností

Instalace můžete zavádět přímo z Editoru možností, a to manuálně nebo automatickým spuštění instalace.

  • Ze stránky Zavést manuálně v Editoru možností můžete zaslat uživatelům e-mail s pokyny o tom, jak instalaci spustit. Tento způsob použijte v případě, že uživatelé mají ve svých klientských počítačích oprávnění správce.
  • Ze stránky Zavést automaticky v Editoru možností můžete instalaci na cílových počítačích spouštět automaticky. Lze provést i uživatelskou odinstalaci. Tuto metodu použijte, pokud uživatelé nemají oprávnění potřebná pro instalaci softwaru v jejich systému.

Chcete-li některou metodu použít, je nutné změnit instalační adresář administrativní kopie na sdílený adresář Windows, aby byla dostupná ze síťového umístění (například \\počítač\sdílená_složka, nebo můžete celou kopii zkopírovat do místního adresáře na každém počítači, například C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0).

Obsah

  • Použití namapovaného disku k zavedení administrativní kopie

    Doporučenou metodou pro určení síťového umístění pro instalační adresář administrativní kopie je cesta UNC (\\název_počítače\název_sdíleného_adresáře). Namapovaný disk však můžete použít jako umístění pro soubor StartSWInstall.hta v administrativní kopii (například U:\StartSWInstall.hta), za předpokladu, že mají všichni instalující uživatelé namapovánu jednotku se stejným písmenem na sdílený adresář administrativní kopie.

  • Zavedení administrativní kopie pomocí příkazu StartSWInstall.exe

  • Manuální zavádění softwaru

    Tuto metodu lze použít, pokud mají uživatelé oprávnění potřebná pro instalaci v jejich systému.

  • Předpoklady pro automatické zavedení

    Při automatickém zavádění jsou úlohy instalace spouštěny na cílových počítačích, kde je provádí aplikace Plánovač úloh Microsoft bez nutnosti jakéhokoli zásahu uživatele. Tuto metodu použijte, pokud uživatelé nemají oprávnění potřebná pro instalaci softwaru v jejich systému.

  • Automatické zavádění softwaru

Nadřazené téma
Editor možností administrativní kopie
Související pojmy
Probíhá přidávání a odstraňování skupin a počítačů
Související úlohy
Ukončení editoru možností
Vytvoření zástupce pro Editor možností na ploše
Související odkazy
Zobrazení a úpravy nastavení možnosti


Použití namapovaného disku k zavedení administrativní kopie

Doporučenou metodou pro určení síťového umístění pro instalační adresář administrativní kopie je cesta UNC (\\název_počítače\název_sdíleného_adresáře). Namapovaný disk však můžete použít jako umístění pro soubor StartSWInstall.hta v administrativní kopii (například U:\StartSWInstall.hta), za předpokladu, že mají všichni instalující uživatelé namapovánu jednotku se stejným písmenem na sdílený adresář administrativní kopie.

Pokud například namapujete jednotku U: na sdílený adresář administrativní kopie, e-mail s oznámením informuje uživatele o tom, že mají klepnout na odkaz na file://U:\StartSWIOnstall.hta. Uživatelé, kteří e-mail dostanou, mohou úspěšně provést instalaci, za předpokladu, že je disk U: namapován na umístění UNC pro administrativní kopii (\\název_počítače\název_sdíleného_adresáře).

Nadřazené téma
Zavádění instalací z editoru možností


Zavedení administrativní kopie pomocí příkazu StartSWInstall.exe

Na klientské počítače můžete nainstalovat nebo z nich odinstalovat administrativní kopii spuštěním příkazu admin_image_install_dir\StartSWInstall.exe. Při použití této metody dojde k instalaci SOLIDWORKS s možnostmi, počítači a skupinami definovanými v Editoru možností administrativní kopie.

K příkazu StartSWInstall.exe můžete připojit následující přepínače:
/install | Nainstaluje administrativní kopii na klientské počítače.
/uninstall Odebere instalaci softwaru z klientských počítačů. Zde jsou k dispozici dva volitelné přepínače:

/removedata

Přepínač je k dispozici pouze pro odebrání instalace. Během odebrání instalace odstraní datové soubory a složky SOLIDWORKS.

/removeregistry

Přepínač je k dispozici pouze pro odebrání instalace. Během odebrání instalace odstraní položky registru SOLIDWORKS.
/showui | Zobrazí okno Manažera instalací SOLIDWORKS s informacemi o průběhu. V ostatních případech je Manažer instalací SOLIDWORKS uživateli skrytý.
/now | Spustí instalaci nebo odebrání instalace okamžitě. V tomto případě se nezobrazí dialogové okno s upozorněním na 5minutový interval do spuštění.

Příkaz StartSWInstall.exe se doporučuje použít namísto příkazu StartSWInstall.hta v případech, kdy chcete, aby instalace probíhala bez zásahu uživatele, ale nechcete použít automatické zavedení pomocí Editoru možností administrativní kopie.

Nadřazené téma
Zavádění instalací z editoru možností


Manuální zavádění softwaru

Tuto metodu lze použít, pokud mají uživatelé oprávnění potřebná pro instalaci v jejich systému.

Chcete-li zavést instalaci manuálně přes e-mail, postupujte takto:

  1. V Editoru možností klepněte na Zavést.

    Objeví se dostupnost instalace a stav pro jednotlivé počítače.

  2. Klepněte na Odeslat e-mail.
  3. Zadejte síťovou cestu k instalačnímu adresáři administrativní kopie.

    Typicky se cesta k instalačnímu adresáři administrativní kopie zobrazuje nejprve jako cesta k souboru Windows (například C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0). V okně se zobrazí Tato cesta není síťová cesta.

    1. Klepněte na Procházet a určete síťové umístění pro tento instalační adresář pro administrativní kopii.
    2. Vyhledejte počítač, na němž je nainstalována administrativní kopie a vyberte sdílený adresář Windows, který jste specifikovali jako instalační adresář pro administrativní kopii.

      Nepřecházejte do sdíleného adresáře administrativní kopie (například do podadresářů 64bit).

    3. Klepněte na tlačítko OK.

      V dialogovém okně se zobrazí Tato cesta je síťová cesta.

    Vygeneruje se e-mail s pokyny pro majitele počítače ohledně instalace z administrativní kopie v síťovém umístění pro soubor administrativní kopie StartSWInstall.hta.

  4. Odešlete tento e-mail uživatelům odpovědným za instalaci SOLIDWORKS.

Uživatelé mohou nainstalovat SOLIDWORKS z administrativní kopie poklepáním na odkaz na síťové umístění pro soubor StartSWInstall.hta v e-mailu.

V Editoru možností se pod položkou Stav instalace zobrazí:
Čeká na vyřízení | Uživatel zatím nespustil na tomto počítači instalaci.
Úspěšný | Uživatel úspěšně dokončil instalaci na tomto počítači.
Neúspěšný | Uživatel spustil instalaci na tomto počítači, ale ta selhala.

Ostatní stavové zprávy, které se mohou zobrazit: Instalace úspěšně dokončena, Odinstalace úspěšně dokončena, Instalace, Odinstalování, Je vyžadován restart systému, Instalace se nezdařila a Odinstalace se nezdařila.

Nadřazené téma
Zavádění instalací z editoru možností


Předpoklady pro automatické zavedení

Při automatickém zavádění jsou úlohy instalace spouštěny na cílových počítačích, kde je provádí aplikace Plánovač úloh Microsoft bez nutnosti jakéhokoli zásahu uživatele. Tuto metodu použijte, pokud uživatelé nemají oprávnění potřebná pro instalaci softwaru v jejich systému.

Při push instalaci plánovač úloh spustí Manažera instalací SOLIDWORKS s vámi (správcem) určenými pověřeními. Plánovač úloh se spouští s použitím účtu LocalSystem. Tento účet je reprezentován v síti jako objekt zabezpečení počítače. Objekt zabezpečení počítače musí mít přístup ke čtení ke sdílené složce, ve které se nachází administrativní kopie.

Když ve službě Active Directory přidáte počítač do skupiny sdílené složky, vyberte Typy objektů a ujistěte se, že je vybrána položka Počítače.

Kromě toho musí být počítač hostující administrativní kopii i cílové klientské počítače členy stejné domény Active Directory.

Nadřazené téma
Zavádění instalací z editoru možností


Automatické zavádění softwaru

Chcete-li provést automatické zavedení spuštěním instalace v systémech uživatelů, postupujte takto:

  1. V Editoru možností klepněte na záložku Automaticky zavést.

    Objeví se dostupnost instalace a stav pro jednotlivé počítače.

  2. Ve sloupci Zavést vyberte cílové klientské počítače a ve sloupci Zavedení vyberte skupiny.

    Abyste mohli zahájit proces instalace, musíte ve sloupci Zavéstvybrat alespoň jeden počítač nebo skupinu.

  3. Položku Čas instalace nastavte na Nyní, pokud chcete instalaci provést ihned, nebo Později, pokud chcete instalaci naplánovat na určité datum a čas.
  4. V části Možnosti klienta vyberte jednu z následujících možností:
    • Instalace nebo upgrade softwaru SOLIDWORKS 2015
    • Odebrání instalace softwaru SOLIDWORKS 2015
      Vyberete-li odinstalaci, můžete nastavit, zda mají být spolu se soubory a složkami softwaru odstraněny i záznamy v registru a datové soubory.
  5. Chcete-li po dokončení instalace restartovat cílové počítače, vyberte možnost Automaticky restartovat počítač.
  6. Zadejte Klientské údaje pro cílové počítače.
  7. Klepnutím na Zavést zahájíte proces instalace.
V Editoru možností se zobrazí tento Stav instalace:
Čeká na vyřízení | Instalace zatím nebyla na tomto počítači spuštěna.
Úspěšný | Instalace na tomto počítači byla úspěšně dokončena.
Neúspěšný | Instalace na tomto počítači se nezdařila.

Ostatní stavové zprávy, které se mohou zobrazit: Instalace úspěšně dokončena, Odinstalace úspěšně dokončena, Plánování, Připojování, Instalace, Odinstalace, Je vyžadován restart systému, Instalace naplánována, Odinstalace naplánována, Instalace se nezdařila, Odinstalace se nezdařila, Připojení se nezdařilo a Plánování se nezdařilo.

Nadřazené téma
Zavádění instalací z editoru možností


Ukončení editoru možností

Editor možností můžete ukončit klepnutím na OK nebo Zavřít.

  • Klepněte na OK, Zavřít nebo zavřete okno pomocí tlačítka Zavřít ve Windows. Dojde k aplikaci změn a ukončení Editoru možností.
    • Klepnutím na OK aplikujete změny nastavení možností a ukončíte Editor možností.
    • Klepnutím na Zavřít ukončíte Editor možností.

      Pokud se mají použít nějaké změny, budete dotázáni, zda je chcete uložit.

    • Klepněte na tlačítko Zavřít v aplikaci (X). Pokud se mají použít nějaké změny, budete dotázáni, zda je chcete uložit.
Nadřazené téma
Editor možností administrativní kopie
Související pojmy
Probíhá přidávání a odstraňování skupin a počítačů
Zavádění instalací z editoru možností
Související úlohy
Vytvoření zástupce pro Editor možností na ploše
Související odkazy
Zobrazení a úpravy nastavení možnosti


Vytvoření zástupce pro Editor možností na ploše

Z aplikace můžete vytvořit zástupce Windows pro Editor možností na ploše pro konkrétní administrativní kopii.

  1. Spusťte Editor možností.

    V Průzkumníku Windows vyhledejte instalační adresář administrativní kopie a poklepejte na soubor sldAdminOptionEditor.exe.

  2. Klepněte na Vytvořit zástupce na ploše pro tento Editor možností.

    Na ploše Windows se objeví zástupce Editoru možností administrativní kopie.

Nadřazené téma
Editor možností administrativní kopie
Související pojmy
Probíhá přidávání a odstraňování skupin a počítačů
Zavádění instalací z editoru možností
Související úlohy
Ukončení editoru možností
Související odkazy
Zobrazení a úpravy nastavení možnosti


Oznámení o administrativní kopii klientům e-mailem

Po vytvoření sdíleného adresáře pro administrativní kopii můžete informovat klienty mailem.

Nakonfigurujte adresář administrativní kopie tak, aby byl sdílen na počítači, který je přístupná jiným počítačům (například pomocí cesty UNC).

Můžete zaslat všem klientům e-mail obsahující odkaz na instalační_adresář_administrativní_kopie\StartSWInstall.hta pro všechny klienty. Klienti poté mohou klepnutím na tento odkaz a výběrem Nyní instalovat SOLIDWORKS spustit instalaci z administrativní kopie.

Chcete-li upgradovat administrativní kopii na novou verzi SOLIDWORKS, můžete konfigurovat místo vaší administrativní kope a sdílené vlastnosti tak, že všichni klienti, kteří byli nainstalováni předtím za použití kopie, budou upgradováni automaticky. Detaily najdete na odkazu Upgrade klientů z administrativních kopií.
Nadřazené téma
Násobné instalace
Související pojmy
Zavádění více klientů
Použití administrativní kopie
Zavedení pomocí příkazového řádku
Správa násobných instalací
Upgradování klientů z administrativní kopie


Zavedení pomocí příkazového řádku

Administrativní kopii můžete automaticky zavést příkazového řádku nebo dávkového souboru (tichá instalace).

Chcete-li nasadit administrativní obraz pomocí příkazového řádku pro klienty SOLIDWORKS PDM, informace najdete v průvodci instalací SOLIDWORKS PDM.

Obsah

  • Příprava klientů na instalaci z příkazového řádku z administrativní kopie

    Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.

  • Instalace z administrativní kopie s použitím příkazového řádku

    Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.

  • Vlastnosti v příkazovém řádku

    Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.

  • Zavádění administrativní kopie pomocí Microsoft Active Directory

    Rozmístění pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SOLIDWORKS na klientské počítače.

  • Předpoklady instalace ve Windows pomocí Microsoft Active Directory

    Při přípravě stávající administrativní kopie, která nainstaluje SOLIDWORKS na klientské počítače pomocí Microsoft Active Directory, postupujte podle těchto pokynů.

Nadřazené téma
Násobné instalace
Související pojmy
Zavádění více klientů
Použití administrativní kopie
Oznámení o administrativní kopii klientům e-mailem
Správa násobných instalací


Příprava klientů na instalaci z příkazového řádku z administrativní kopie

Po vytvoření administrativní kopie a před tím, než budete informovat klienty, musíte nainstalovat komponenty Microsoft Windows, které nelze nainstalovat prostřednictvím administrativní kopie a které je nutno nainstalovat za použití příkazového řádku nebo Microsoft Active Directory.

Ruční instalace těchto součástí Windows je nutná pouze tehdy, pokud instalaci provádíte z administrativní kopie prostřednictvím příkazového řádku nebo služby Microsoft Active Directory. Pokud použijete Manažera instalací SOLIDWORKS pro vytvoření a instalaci administrativní kopie, tyto komponenty Windows se instalují automaticky.
Zde je souhrn souborů požadovaných softwarem SOLIDWORKS v součástech systému Windows:
Součásti Office Web | Obsahují ovladače COM potřebné pro DriveWorks.
Balíček k opětovné distribuci Visual C++ 2005, 2008, 2010 a 2012 | Obsahuje komponenty typu runtime pro Microsoft Visual C++. Musí být nainstalovány verze 2005, 2008, 2010 a 2012.
Visual Basic for Applications 7.1 | Zajišťuje podporu maker v jazyce Visual Basic.
Nástroje Visual Studio pro aplikace | Obsahuje sadu nástrojů podporující aplikace Visual Studio. Od verze SOLIDWORKS 2013 je instalace sady Microsoft Visual Studio Tools for Applications (VSTA) nepovinná. Předpokladem pro instalaci sady VSTA je, aby v počítači bylo nainstalováno rozhraní Microsoft .NET Framework 3.5. V systému Windows 7 a novějších je rozhraní .NET Framework již součástí operačního systému. Pokud potřebujete rozhraní .NET Framework 3.5 nainstalovat, najdete ho na médiích k systému Windows a na Internetu. Jestliže nemáte média k systému Windows k dispozici, nemáte připojení k internetu nebo oprávnění potřebná k instalaci rozhraní Microsoft .NET Framework 3.5 do počítače, požádejte o pomoc svého správce.
Vzdálený ladící program Visual Studio | Poskytuje ladící prostředí pro 64bitové operační systémy.
Rozhraní .NET Framework 4.5 | Obsahuje společný jazykový modul runtime a součásti .NET Framework, které jsou zapotřebí pro spouštění aplikací .NET Framework 4.5.
Služba Bonjour pro Windows | Umožňuje vyhledávání služeb v síti LAN.
Balíček k opětovné distribuci Visual C++ a rozhraní .NET Framework 4.5 jsou nutné pro všechny produkty SOLIDWORKS, nikoli pouze pro hlavní produkt SOLIDWORKS.

Tyto součásti musí být zahrnuty v podsložkách administrativní kopie.

Následující tabulka určuje konkrétní soubory požadované pro každý podporovaný operační systém.
Operační systém: Windows Server 2008 R2, 64bitová verze Média SOLIDWORKS: 64bitová verze pro systém Windows 7
Pro SOLIDWORKS PDM Server, Workgroup PDM Server a SOLIDWORKS SolidNetWork License Manager je podporována instalace v systému Windows Server 2008 R2 nebo Windows Server 2012 a 2012 R2.
Instalační služba Windows Installer: | (nepoužitelný)
Součásti Office Web: | owc11.exe
Balíček k opětovné distribuci Visual C++ 2005: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Nástroje Visual Studio pro aplikace: (volitelné) | vsta_aide.msi
Pokud je nainstalována sada VSTA, je vyžadováno rozhraní .NET 3.5 Framework (dotnetfx35.exe). V systému Windows 7 je rozhraní .NET Framework 3.5 již součástí operačního systému.
Vzdálený ladící program Visual Studio: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
Rozhraní .NET Framework 4.5: | .netfx45_full_x86_x64.exe
Služba Bonjour pro Windows: | bonjour64.msi
Operační systém: Windows Server 2012 a 2012 R2, 64bitová verze Média SOLIDWORKS: 64bitová verze pro systém Windows 7
Pro SOLIDWORKS PDM Server, Workgroup PDM Server a SOLIDWORKS SolidNetWork License Manager je podporována instalace v systému Windows Server 2008 R2 nebo Windows Server 2012 a 2012 R2.
Instalační služba Windows Installer: | (nepoužitelný)
Součásti Office Web: | owc11.exe
Balíček k opětovné distribuci Visual C++ 2005: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Nástroje Visual Studio pro aplikace: (volitelné) | vsta_aide.msi
Pokud je nainstalována sada VSTA, je vyžadováno rozhraní .NET 3.5 Framework (dotnetfx35.exe). V systému Windows 7 je rozhraní .NET Framework 3.5 již součástí operačního systému.
Vzdálený ladící program Visual Studio: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
Rozhraní .NET Framework 4.5: | .netfx45_full_x86_x64.exe
Služba Bonjour pro Windows: | bonjour64.msi
Operační systém: Windows Server 2012 a Windows Server 2012 R2, 64bitová verze Média SOLIDWORKS: 64bitová verze pro Windows 8 a 8.1
Pro SOLIDWORKS PDM Server, Workgroup PDM Server a SOLIDWORKS SolidNetWork License Manager je podporována instalace v systému Windows Server 2008 R2 nebo Windows Server 2012 a 2012 R2.
Instalační služba Windows Installer: | (nepoužitelný)
Součásti Office Web: | owc11.exe
Balíček k opětovné distribuci Visual C++ 2005: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Nástroje Visual Studio pro aplikace: (volitelné) | vsta_aide.msi
Pokud je nainstalována sada VSTA, je vyžadováno rozhraní .NET 3.5 Framework (dotnetfx35.exe). V systému Windows 8 je rozhraní .NET Framework 3.5 již součástí operačního systému.
Vzdálený ladící program Visual Studio: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
Rozhraní .NET Framework 4.5: | Rozhraní .NET 4.5 je součástí operačního systému, čímž je tento požadavek splněn.
Služba Bonjour pro Windows: | bonjour64.msi
Operační systém: Windows 7 64-bit Média SOLIDWORKS: 64bitová verze pro systém Windows 7
Instalační služba Windows Installer: | (nepoužitelný)
Součásti Office Web: | owc11.exe
Balíček k opětovné distribuci Visual C++ 2005: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Nástroje Visual Studio pro aplikace: (volitelné) | vsta_aide.msi
Pokud je nainstalována sada VSTA, je vyžadováno rozhraní .NET 3.5 Framework (dotnetfx35.exe). V systému Windows 7 je rozhraní .NET Framework 3.5 již součástí operačního systému.
Vzdálený ladící program Visual Studio: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
Rozhraní .NET Framework 4.5: | .netfx45_full_x86_x64.exe
Služba Bonjour pro Windows: | bonjour64.msi
Operační systém: Windows 8 a 8.1, 64bitová verze Média SOLIDWORKS: 64bitová verze pro systém Windows 8
Instalační služba Windows Installer: | (nepoužitelný)
Součásti Office Web: | owc11.exe
Balíček k opětovné distribuci Visual C++ 2005: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Balíček k opětovné distribuci Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Oba musí být nainstalovány.
Nástroje Visual Studio pro aplikace: (volitelné) | vsta_aide.msi
Pokud je nainstalována sada VSTA, je vyžadováno rozhraní .NET 3.5 Framework (dotnetfx35.exe). V systému Windows 7 je rozhraní .NET Framework 3.5 již součástí operačního systému.
Vzdálený ladící program Visual Studio: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
Rozhraní .NET Framework 4.5: | Rozhraní .NET 4.5 je součástí operačního systému, čímž je tento požadavek splněn.
Služba Bonjour pro Windows: | bonjour64.msi

Obsah

  • Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech

    Při instalaci předpokladů ve Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows postupujte podle těchto pokynů.

Nadřazené téma
Zavedení pomocí příkazového řádku
Související pojmy
Instalace z administrativní kopie s použitím příkazového řádku
Vlastnosti v příkazovém řádku
Související úlohy
Zavádění administrativní kopie pomocí Microsoft Active Directory
Předpoklady instalace ve Windows pomocí Microsoft Active Directory


Předpoklady instalace ve Windows z příkazového řádku na 64bitových operačních systémech

Při instalaci předpokladů ve Windows pro instalaci administrativní kopie za použití příkazového řádku na 64bitových verzích Windows postupujte podle těchto pokynů.

Pokud chcete jednou instalační operací nainstalovat několik součástí, vytvořte dávkový soubor s příkazy obsaženými v následujících pokynech. Poté tento soubor použijte k instalaci součástí na klientské počítače.

  1. Ujistěte se, že je na cílovém počítači alespoň 620 MB volného místa na disku a platná složka TEMP.
  2. Nainstalujte součásti Office Web spuštěním tohoto příkazu:

    adresář_administrativní_kopie\OfficeWeb_11\owc11.exe/quiet

  3. Nainstalujte balíček Visual C++ VERZE k opětovné distribuci.

    Nainstalujte balíček pro VERZE = 2005, 2008, 2010 a 2012.

    adresář_administrativní_kopie\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    adresář_administrativní_kopie\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    Musí být nainstalována 32bitová i 64bitová verze tohoto balíčku.

    Chcete-li například nainstalovat balíček k opětovné distribuci Visual C++ 2005, použijte:

    • adresář_administrativní_kopie\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q
    • adresář_administrativní_kopie\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  4. Nainstalujte rozhraní Microsoft .NET Framework 4.5:

    adresář_administrativní_kopie\.Net_Framework_4.5\dotnetfx45_full_x86_x64.exe

  5. Nainstalujte nástroje Visual Studio pro aplikace:

    adresář_administrativní_kopie\Microsoft_VSTA\vsta_aide.msi

    Pokud instalujete VSTA, je potřeba rozhraní .NET Framework 3.5.

    Pro systém Windows 7 a novější je rozhraní .NET Framework 3 součástí operačního systému.

  6. Nainstalujte vzdálený ladící program Visual Studio:

    adresář_administrativní_kopie\VSRemoteDebugger\install.exe /Q

  7. Nainstalujte Visual Basic 7.1:

    Položky adresář_administrativní_kopie\Microsoft_VBA\vba71.msi a adresář_administrativní_kopie\Microsoft_VBA\vba71_1033.msi jsou povinné pro všechny jazyky.

    Je přitom třeba nainstalovat pouze 64bitovou verzi tohoto balíčku.

    Dále nainstalujte následující balíček pro požadovaný jazyk:

    vba71_1028.msi | čínština
    vba71_1031.msi | němčina
    vba71_1036.msi | francouzština
    vba71_1040.msi | italština
    vba71_1041.msi | japonština
    vba71_1042.msi | korejština
    vba71_1046.msi | Portugalština – brazilská
    vba71_2052.msi | Čínština – zjednodušená
    vba71_3082.msi | španělština
    Angličtina, čeština, polština, ruština a turečtina další jazykové balíčky nevyžadují.
    Počínaje verzí SOLIDWORKS 2013 Service Pack 2.0 je třeba nainstalovat další předpokládanou součást: Msiexec.exe /p vba71-kb27832-x64.msp

  8. Nainstalujte službu Bonjour pro systém Windows:

    adresář_administrativní_kopie\Bonjour\Bonjour64.msi

Nadřazené téma
Příprava klientů na instalaci z příkazového řádku z administrativní kopie


Instalace z administrativní kopie s použitím příkazového řádku

Můžete rozmístit instalace z administrativní kopie za použití příkazového řádku.

Návod na tichou instalaci:

  1. Otevřete okno s příkazovým řádkem (klepněte ve Windows na Start > Spustit.
  2. V okně zadejte příkaz msiexec.exe s parametry /i a /qb a nastavte vlastnosti pro jakékoliv možnosti, které nejsou součástí výchozích hodnot zobrazených níže.
Vlastnosti individuální instalace příkazového řádku součásti zahrnuje:
  • Vlastnosti funkcí v příkazovém řádku
  • Globální vlastnosti v příkazovém řádku
  • Vlastnosti příkazového řádku eDrawings
  • SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
  • Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

Použijte následující příklady jako šablony pro bezobslužnou (tichou) instalaci.

SOLIDWORKS klient

  • SOLIDWORKS (hlavní část) (anglicky)
  • Doplňkový modul Toolbox
  • Účast v programu zpětné vazby zákazníků
  • Francouzština

SOLIDWORKS:

msiexec /i "cesta_k_64bitovemu_obrazu\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\vase_slozka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

Součást instalace SOLIDWORKS ve francouzštině musí být instalována zvlášť:

msiexec /i "cesta_k_64bitovemu_obrazu\SOLIDWORKS French\french.msi" /qb

Při zadávání povelů jazykové součásti instalace SOLIDWORKS nezadávejte argumenty v příkazovém řádku.

eDrawings klient

  • Protokol o výkonu
  • Všechny funkce

msiexec /i "cesta_k_obrazu\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\vase_slozka" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Explorer a doplňkový modul Workgroup PDM

  • SOLIDWORKS Explorer s doplňkovým modulem Workgroup PDM

msiexec /i "cesta_k_obrazu\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Program Files\vase_slozka" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb

SOLIDWORKS Electrical

Z důvodu technické komplikovanosti instalace softwaru SOLIDWORKS Electrical se serverem Microsoft SQL Server jsou příklady příkazů pro příkazový řádek pro software SOLIDWORKS Electrical z dokumentace vynechány.

Nadřazené téma
Zavedení pomocí příkazového řádku
Související pojmy
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Vlastnosti v příkazovém řádku
Související úlohy
Zavádění administrativní kopie pomocí Microsoft Active Directory
Předpoklady instalace ve Windows pomocí Microsoft Active Directory


Vlastnosti v příkazovém řádku

Vlastnosti v příkazovém řádku zde popisují vlastnosti funkcí, globální vlastnosti, produktově specifické vlastnosti a konvence umístění Windows.

Obsah

  • Vlastnosti funkcí v příkazovém řádku

    Instalace SOLIDWORKS podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.

  • Globální vlastnosti v příkazovém řádku

    Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.

  • Vlastnosti příkazového řádku eDrawings

    Tyto vlastnosti příkazového řádku jsou specifické pro aplikaci eDrawings®.

  • SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku

    Tyto vlastnosti v příkazovém řádku jsou specifické pro aplikace SOLIDWORKS Composer a SOLIDWORKS Composer Player.

  • SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku

    Tyto vlastnosti v příkazovém řádku jsou specifické pro SOLIDWORKS Explorer a SOLIDWORKS Workgroup PDM.

  • Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

    Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Flow Simulation.

  • SOLIDWORKS Inspection – vlastnosti v příkazovém řádku

    Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Inspection.

  • Umístění souboru MSI administrativní kopie

    Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SOLIDWORKS.

Nadřazené téma
Zavedení pomocí příkazového řádku
Související pojmy
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Instalace z administrativní kopie s použitím příkazového řádku
Související úlohy
Zavádění administrativní kopie pomocí Microsoft Active Directory
Předpoklady instalace ve Windows pomocí Microsoft Active Directory


Vlastnosti funkcí v příkazovém řádku

Instalace SOLIDWORKS podporuje tyto vlastnosti ADDLOCAL pro zavedení pomocí příkazového řádku.

  • CircuitWorks
  • CoreSOLIDWORKSTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulace
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
Při zadávání vlastností pro instalaci příkazového řádku:
  • SOLIDWORKS nepodporuje instalaci produktu pomocí možnosti ADDSOURCE..
  • Parametry rozlišují malá a velká písmena, nesmějí obsahovat mezery nebo pomlčky a musí být odděleny čárkami.

    Aby se aplikace nainstalovala správně, musí být ve vlastnostech ADDLOCAL zadáno SolidWorks s velkými i malými písmeny.

Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


Globální vlastnosti v příkazovém řádku

Každý parametr je definován pro administrativní nebo individuální instalace, není-li uvedeno jinak. Sériová čísla mohou být pomocí globálních parametrů předána administrativní i individuální instalaci.

Vlastnost | Popis
ENABLEPERFORMANCE Určuje, zda má aplikace automaticky odeslat emailem data o výkonu společnosti SOLIDWORKS Corporation.

1

Data o výkonu budou odeslána.

0

Data o výkonu nebudou odeslána.
INSTALLDIR Instalační složka pro SOLIDWORKS.

Pouze pro individuální instalace.
MBDSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Model Based Definition.
MOTIONSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Motion.
OFFICEOPTION Určete produktový balíček, který chcete nainstalovat:
0 | SOLIDWORKS klient
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
NOVÁ INSTALACE Vyberte Vyberte pro aktualizace všech funkcí, které byly nyní instalovány.
Tuto vlastnost zadejte pouze tehdy, když aktualizujete na nový Service Pack v rámci stávající verze (například při aktualizaci stávající instalace SOLIDWORKS 2015 SP01 na SOLIDWORKS 2015 SP02).
REINSTALLMODE Možnosti nové instalace aplikace Microsoft Installer.

Když například aktualizujete instalaci z jednoho vydání service pack na jiné uvnitř stejného hlavního vydání, měli byste specifikovat Když například aktualizujete instalaci z jednoho vydání service pack na jiné uvnitř stejného hlavního vydání, měli byste specifikovat .

Podrobnosti o nastavení REINSTALLMODE najdete v dokumentaci aplikace Windows Installer na stránce www.microsoft.com.

Tuto vlastnost zadejte pouze tehdy, když aktualizujete na nový Service Pack v rámci stávající verze (například při aktualizaci stávající instalace SOLIDWORKS 2015 SP01 na SOLIDWORKS 2015 SP02). Nezadávejte tuto vlastnost, pokud poprvé instalujete hlavní verzi SOLIDWORKS.
SERVERLIST Určuje seznam serverů SolidNetWork.
Seznam serverů SolidNetWork je seznam řetězců oddělených středníkem, z nichž každý je přiřazen číslu portu na serveru v následujícím formátu:

xxxxx@název_serveru1;yyyyy@název_serveru2;&

kde kde a x jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.

Pouze pro individuální instalace.
SIMULATIONSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS Simulation.
SOLIDWORKSSERIALNUMBER | Sériové číslo pro produkt SOLIDWORKS, které zahrnuje všechny doplňkové moduly.
SWMIGRATE Určuje verzi SOLIDWORKS pro upgrade, jak by byla zobrazena v seznamu v okně Výběr instalace SOLIDWORKS. Příklad:

SWMIGRATE="SOLIDWORKS 2015 x64 Edition SP01"

Zadejte tuto vlastnost pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze service pack na jinou v rámci té samé hlavní verze.
TOOLBOXFOLDER Instalační složka pro soubory SOLIDWORKS Toolboxu.

Pouze pro individuální instalace.

Například: TOOLBOXFOLDER = "c:\SOLIDWORKS Data"
TRANSFORMS Obsahuje položky specifické pro jazyk v podobě:
TRANSFORMS number.mst
  • Chinese (1028)
  • Chinese-Simplified (2052)
  • Czech (1029)
  • English (1033)
  • French (1036)
  • German (1031)
  • Italian (1040)
  • Japanese (1041)
  • Korean (1042)
  • Polish (1045)
  • Portuguese-Brazilian (1046)
  • Russian (1049)
  • Spanish (1034)
  • Turkish (1055)
UPGRADESWINSTALL
Určuje, zda je nutné provést upgrade stávající verzi SOLIDWORKS na aktuální verzi.
0 | Nová instalace, neprovádějte upgrade.
1 | Aktualizovat

Pouze pro individuální instalace.

Zadejte tuto vlastnost, pouze když instalujete novou hlavní verzi na nově instalovanou předchozí hlavní verzi. Nezadávejte tuto vlastnost, když aktualizujete z jedné verze aktualizace Service Pack na jinou v rámci té samé hlavní verze.
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


Vlastnosti příkazového řádku eDrawings

Tyto vlastnosti příkazového řádku jsou specifické pro aplikaci eDrawings®.

Vlastnost | Popis
ADDLOCAL Určuje, která část aplikace eDrawings se má nainstalovat.
Vše je doporučená možnost.
Syntaxe příkazového řádku | Prvek
Vše | Nainstaluje všechny funkce. Aplikace eDrawings hledá nainstalované aplikace SOLIDWORKS a AutoCAD Publisher a ověří instalaci.
CALS | Zobrazení souborů CAL v prohlížeči eDrawings
Inventor | Tvorba souborů eDrawings z aplikace Autodesk Inventor.
eDrawingsViewer | Zobrazení souborů eDrawings a ostatních souborů.
ProE | Zobrazení souborů ProE v prohlížeči eDrawings
DXFDWGTranslator | Zobrazení souborů DXF/DWG v prohlížeči eDrawings.
Shortcuts | Instalace zástupce na ploše.
XML3D | Zobrazení souborů 3DXML v prohlížeči eDrawings.
INSTALLDIR | Určuje instalační složku pro eDrawings.
LOGPERFORMANCE Určuje, zda má aplikace automaticky odeslat emailem data o výkonu společnosti SOLIDWORKS Corporation.
1 | Odeslání dat o výkonu
0 | Jinak
SNLSERVER Zadejte číslo_portu@název_serveru pro váš licenční server SolidNetWork. Jednotlivé kombinace hodnot číslo_portu@název_serveru oddělte středníky.

Název portu serveru pro SNLSERVER je požadován jen pro konfiguraci serveru SOLIDWORKS SNL. seznam_portů@serverové_řetězce je seznam řetězců oddělených středníkem a každý je přiřazen číslu portu na serveru v následujícím formátu:

xxxxx@název_serveru1; yyyyy@název_serveru2;

kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku

Tyto vlastnosti v příkazovém řádku jsou specifické pro aplikace SOLIDWORKS Composer a SOLIDWORKS Composer Player.

SOLIDWORKS Composer:

Vlastnost | Popis
ACTIVSERIALNUMBER | Sériové číslo softwaru SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Volitelné. Sériové číslo softwaru SOLIDWORKS Composer Player Pro.
ADDLOCAL Instalujete-li kompletní aplikaci, není nutné nastavovat následující položky.
Povinné:
  • Licencování
  • Documents_2D
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
Volitelné:
  • Sync3Dvia
INSTALLDIR | Určuje instalační složku softwaru SOLIDWORKS Composer.

SOLIDWORKS Composer Player:

Vlastnost | Popis
ACTIVSERIALNUMBERPLAYERPRO | Volitelné. Sériové číslo softwaru SOLIDWORKS Composer Player Pro.
INSTALLDIR | Určuje instalační složku softwaru SOLIDWORKS Composer Player.
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku

Tyto vlastnosti v příkazovém řádku jsou specifické pro SOLIDWORKS Explorer a SOLIDWORKS Workgroup PDM.

Pro klienta aplikace SOLIDWORKS Explorer/Workgroup PDM:
Parametr klienta | Popis
EXPLORERORPDM
0 | Pouze pro aplikaci SOLIDWORKS Explorer
1 | Je možné instalovat funkce Workgroup PDM
ADDLOCAL
  • Samostatná verze
  • Klient
  • Client64
  • Správa úschovny
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone je Contributor a Klient je doplňkový modul SOLIDWORKS pro bezobslužné instalace SOLIDWORKS Exploreru.

Pokud vyberete AutoCAD, AutoCAD musí být nainstalován na vašem počítači. PDM Workgroup najde vhodnou verzi AutoCAD. Můžete určit více než jednu verzi programu AutoCAD:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 a DocMgr64 pracují pouze se 64bitovými instalacemi SOLIDWORKS Exploreru.

INSTALLDIR | Určuje instalační složku pro Workgroup PDM.
ACTIVSERIALNUMBER | Určuje sériové číslo SOLIDWORKS.
Pro server Workgroup PDM.
Parametr serveru | Popis
ADDLOCAL
  • Úschovna
  • WebPortal
  • API

Pokud zadáte WebPortal (Viewer), musíte také určit VAULTNAME.
INSTALLDIR | Určuje instalační složku pro Workgroup PDM.
LICENSE_SERVER | Určuje název počítače, na kterém je licenční server.
VAULTDATA | Určuje cestu a složku úschovny.
VAULTNAME | Určuje název počítače, na kterém je úschovna.
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation

Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Flow Simulation.

Vlastnost | Popis
ACTIVSERIALNUMBER Sériové číslo samostatné licence aplikace SOLIDWORKS Flow Simulation.

(Individuální instalace a klientské instalace z administrativní kopie)

CWUPGRADEINSTALL Upgraduje existující verzi určité aplikace SOLIDWORKS Flow Simulation.
1 | Aktualizovat
2 | Nová instalace; nainstalovat v novém adresáři

(Individuální instalace a klientské instalace z administrativní kopie)

INSTALLDIR Určuje instalační složku pro instalaci určité aplikace SOLIDWORKS Flow Simulation.

(Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@název_serveru1; yyyyy@název_serveru2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
SOLIDWORKSPATH Určuje složku, ve které je nainstalován software SOLIDWORKS.

(Individuální instalace a klientské instalace z administrativní kopie)

Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku
Umístění souboru MSI administrativní kopie


SOLIDWORKS Inspection – vlastnosti v příkazovém řádku

Tyto vlastnosti příkazového řádku jsou specifické pro SOLIDWORKS Inspection.

Parametr | Komentář
ACTIVSERIALNUMBER | Sériové číslo softwaru SOLIDWORKS Inspection. (Individuální instalace a klientské instalace z administrativní kopie)
INSTALLDIR | Určuje instalaci softwaru SOLIDWORKS Inspection. (Pouze pro individuální instalace)
SERVERLIST | Seznam řetězců oddělených středníkem, z nichž každý se odkazuje na číslo portu na serveru v následujícím formátu: xxxxx@název_serveru1; yyyyy@název_serveru2;& kde x a y jsou jednomístná čísla. Za poslední server v seznamu nedávejte středník.
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
Umístění souboru MSI administrativní kopie


Umístění souboru MSI administrativní kopie

Pro vytvoření administrativních kopií z příkazového řádku se soubory součástí produktu .msi nacházejí v následujících umístěních na médiu SOLIDWORKS.

SOLIDWORKS (hlavní produkt, angličtina)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (neanglické jazykové součásti)

Tradiční čínština | swwi\lang\chinese\chinese.msi
Zjednodušená čínština | swwi\lang\chinese-simplified\chinese-simplified.msi
čeština | swwi\lang\czech\czech.msi
francouzština | swwi\lang\french\french.msi
němčina | swwi\lang\german\german.msi
italština | swwi\lang\italian\italian.msi
japonština | swwi\lang\japanese\japanese.msi
korejština | swwi\lang\korean\korean.msi
polština | swwi\lang\polish\polish.msi
portugalština (Brazílie) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
ruština | swwi\lang\russian\russian.msi
španělština | swwi\lang\spanish\spanish.msi
turečtina | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Projektory materiálů eDrawings

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

Manažer licencí SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

Průvodce aktivací SOLIDWORKS

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

Průzkumník SOLIDWORKS

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional poskytuje rozhraní API, které je ale k dispozici pouze pro klienta a není k dispozici v souboru .msi. Informace najdete v příručce k rozhraní API v adresáři SOLIDWORKS PDM Client install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Viewer

swviewer\SOLIDWORKS Viewer.msi

Server Workgroup PDM

pdmwserver\SOLIDWORKS Workgroup PDM Server.msi
Nadřazené téma
Vlastnosti v příkazovém řádku
Související odkazy
Vlastnosti funkcí v příkazovém řádku
Globální vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku eDrawings
SOLIDWORKS Composer/Composer Player – parametry v příkazovém řádku
SOLIDWORKS Explorer/Workgroup PDM – vlastnosti v příkazovém řádku
Vlastnosti příkazového řádku aplikace SOLIDWORKS Flow Simulation
SOLIDWORKS Inspection – vlastnosti v příkazovém řádku


Zavádění administrativní kopie pomocí Microsoft Active Directory

Rozmístění pomocí služby Microsoft Active Directory se používá pro instalaci hlavních produktů SOLIDWORKS na klientské počítače.

Služba Microsoft Active Directory je adresářová služba ke správě klientů a serverů na síti. Zjednodušuje správu, přenesení a zavádění.

  1. Vytvořte administrativní kopii pomocí Manažera instalací SOLIDWORKS.
  2. Po vytvoření administrativní kopie za použití příkazového řádku, nainstalujte předpoklady pro Windows instalaci z administrativní kopie za použití Microsoft Active Directory. Podrobnosti najdete v Předpoklady instalace ve Windows pomocí Microsoft Active Directory.

    Proveďte tento krok pouze tehdy, když jste kopii vytvořili ručně za použití příkazového řádku. Pokud jste kopii vytvořili a nainstalovali za použití Manažera instalace SOLIDWORKS, všechny předpoklady pro Windows budou nainstalovány automaticky.

  3. Vytvořte transformační soubor, který slouží k vlastní úpravě programu SOLIDWORKS:
    1. Otevřete okno Příkazový řádek.
    2. Ve složce, která obsahuje administrativní kopii, přetáhněte SWCreateMST.exe do okna Příkazového řádku.

      Příkaz by měl být ve formátu:

      adresář_administrativní_kopie\SWCreateMST.exe cesta_k_souboru_MSI_administrativní_kopieseznam_vlastností

      Vlastnosti mohou být buď vlastnosti funkcí nebo globální vlastnosti. Podrobnosti viz Vlastnosti funkcí v příkazovém řádku a Globální vlastnosti v příkazovém řádku.

      Použijte následující příklad jako šablonu:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\vaše_složka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST="25734@váš_server"

      Transformační soubor SOLIDWORKS.mst je vytvořen ve složce, která obsahuje administrativní kopii.

  4. V aktivním adresáři upravte zásady Publikovaných aplikací pro skupinu nebo skupiny, které zavádějí program SOLIDWORKS.
  5. V dialogovém okně Zásady skupiny rozbalte nabídku Konfigurace počítače a Nastavení softwaru.
  6. Klepněte pravým tlačítkem myši na Instalaci softwaru a vyberte Nový > Balíček.
  7. Vyhledejte administrativní kopii a klepněte na Otevřít.
  8. V dialogovém okně Zavedení aplikace vyberte Upřesnit vlastnosti publikování nebo přiřazení a klepněte na OK.
  9. V dialogovém okně Vlastnosti SOLIDWORKS na záložce Změny:
    1. Klepněte na Přidat.
    2. Vyhledejte soubor .mst.
    3. Klepněte na možnost Otevřít.
  10. Klepněte na tlačítko OK.
Nadřazené téma
Zavedení pomocí příkazového řádku
Související pojmy
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Instalace z administrativní kopie s použitím příkazového řádku
Vlastnosti v příkazovém řádku
Související úlohy
Předpoklady instalace ve Windows pomocí Microsoft Active Directory


Předpoklady instalace ve Windows pomocí Microsoft Active Directory

Při přípravě stávající administrativní kopie, která nainstaluje SOLIDWORKS na klientské počítače pomocí Microsoft Active Directory, postupujte podle těchto pokynů.

  1. Proveďte extrahování instalačních souborů balíčku k opětovné distribuci Visual C++ a nainstalujte je.
    1. Visual C++ 2005

      1. adresář_administrativní_kopie\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T: {cílový adresář}
      2. adresář_administrativní_kopie\Microsoft_C++_2005_Redistributable_(64)\vcredist_x64.exe /C /T: {cílový adresář}
      3. Vytvořte zásadu pro instalaci modulů Microsoft C++ 2005.

    2. Visual C++ 2008

      1. adresář_administrativní_kopie\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {cílový adresář}
      2. adresář_administrativní_kopie\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {cílový adresář}
      3. Vytvořte zásadu pro instalaci modulů Microsoft C++ 2008.

    3. Visual C++ 2010

      1. adresář_administrativní_kopie\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{cílový adresář}
      2. adresář_administrativní_kopie\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{cílový_adresář}
      3. Vytvořte zásadu pro instalaci modulů Microsoft C++ 2010.

    4. Visual C++ 2012

      1. Nainstalujte soubor adresář_administrativní_kopie\Microsoft_C++_2012_Redistributable\vcredist_x86.exe na zkušební počítač.
      2. Zkopírujte následující složky do síťového umístění (cílový adresář):
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
      3. Vytvořte zásady pro instalaci následujících souborů:
        Cesta k souboru nesmí obsahovat mezery.

        Cílový adresář\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Cílový adresář\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      4. Nainstalujte soubor adresář_administrativní_kopie\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe na zkušební počítač.
      5. Zkopírujte následující složky do síťového umístění (cílový adresář):
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      6. Vytvořte zásady pro instalaci následujících souborů:
        Cesta k souboru nesmí obsahovat mezery.

        Cílový adresář\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Cílový adresář\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Cílový adresář\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Nainstalujte rozhraní Microsoft .NET Framework 4.5.

    SOLIDWORKS doporučuje instalaci rozhraní .NET Framework 4.5 pomocí služby Windows Updates Services (WSUS) nebo podobné služby.

  3. Proveďte extrahování souborů součástí Office Web a instalujte je.
    1. Spusťte tento příkaz:

      adresář_administrativní_kopie\OfficeWeb_11\owc11.exe /extract:{adresář_webových_součástí_Office}

    2. Vytvořte zásadu pro instalaci součástí Office Web:

      {adresář_webových_součástí_Office}\owc11.MSI

      Pro tuto instalaci není zapotřebí žádný transformační soubor.

  4. Nainstalujte nástroj Visual Studio Remote Debugger (platí jen pro 64bitové verze, je-li na počítači nainstalováno rozhraní .Net Framework 3.5) tak, že vytvoříte následující zásady:

    {adresář_vzdáleného_ladicího_programu_Microsoft}\rdbgexp.MSI

    Pro tuto instalaci není zapotřebí žádný transformační soubor.

  5. Postupujte takto:
    1. Aktualizujte softwarovou součást Visual Basic for Applications 7.1 pomocí balíčku vba71-kb2783832-x64.
    2. Po vytvoření administrativní kopie spusťte následující příkaz:

      Msiexec /a {administrativní kopie SOLIDWORKS}/Microsoft_vba/vba71.msi /p {administrativní kopie SOLIDWORKS}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp

    3. Nainstalujte Visual Basic 7.1 vytvořením těchto zásad:

      {adresář VBA}\vba71.MSI

      Pro tuto instalaci není zapotřebí žádný transformační soubor.

  6. Nainstalujte jazykový balíček Visual Basic 7.1 vytvořením těchto zásad:

    {adresář VBA}\vba71_nnnn.MSI

    Kde nnnn určuje požadovaný jazyk:
    • 1028 = čínština
    • 1031 = němčina
    • 1033 = angličtina
    • 1036 = francouzština
    • 1040 = italština
    • 1041 = japonština
    • 1042 = korejština
    • 1046 = portugalština
    • 2052 = čínština – Čína
    • 3082 = španělština

  7. Nainstalujte službu Bonjour vytvořením těchto zásad:

    {adresář Bonjour}\Bonjour.MSI

    Pro tuto instalaci není zapotřebí žádný transformační soubor.

Nadřazené téma
Zavedení pomocí příkazového řádku
Související pojmy
Příprava klientů na instalaci z příkazového řádku z administrativní kopie
Instalace z administrativní kopie s použitím příkazového řádku
Vlastnosti v příkazovém řádku
Související úlohy
Zavádění administrativní kopie pomocí Microsoft Active Directory


Správa násobných instalací

Pro více instalací zahrnují administrativní úkoly provedení upgrade administrativních kopií na nové verze, aktualizaci nových verzí servisního balíčku a odstranění instalací.

Obsah

  • Upgrade administrativních kopií na novou verzi

    Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.

  • Správa aktualizace produktu servisního balíčku

    Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.

  • Odstranění instalace

    Instalaci můžete odstranit ze individuálního počítače, nebo z prostředí klient/server.

Nadřazené téma
Násobné instalace
Související pojmy
Zavádění více klientů
Použití administrativní kopie
Oznámení o administrativní kopii klientům e-mailem
Zavedení pomocí příkazového řádku


Upgrade administrativních kopií na novou verzi

Chcete-li aktualizovat klienty, kteří byli nainstalování z administrativní kopie, musíte nejprve aktualizovat samotnou administrativní kopii a pak konfigurovat klienty, aby měli odkaz na novou kopii.

Spusťte Manažera instalací SOLIDWORKS z internetu, aby byly použity správné soubory. Manažer instalací SOLIDWORKS se sám přesměruje, nebo můžete spustit aktualizaci přímo z webové stránky SOLIDWORKS Downloads (http://www.solidworks.com/sw/support/downloads.htm).

Poté, co aktualizujete administrativní kopii (čímž se vytvoří nová kopie), můžete aktualizovat klienty tak, že je odkážete na nově vytvořenou administrativní kopii.

Pokud mají klienti namapovanou jednotku, nebo sdílenou složku s původní administrativní kopií, můžete znovu namapovat jednotku, nebo sdílenou složku nově aktualizované administrativní kopie.

Obsah

  • Stažení aktualizovaných instalačních souborů pro administrativní kopie

    Manažer instalací SOLIDWORKS může rozpoznat, když při upgrade administrativní kopie potřebujete aktualizované instalační soubory.

  • Upgrade administrativní kopie

    Pro upgrade administrativní kopie vytvoří Manažer instalací SOLIDWORKS nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.

  • Upgradování klientů z administrativní kopie

    Manažer instalací SOLIDWORKS může automaticky aktualizovat klientské počítače instalované z administrativní kopie.

Nadřazené téma
Správa násobných instalací
Související pojmy
Správa aktualizace produktu servisního balíčku
Související úlohy
Odstranění instalace


Stažení aktualizovaných instalačních souborů pro administrativní kopie

Manažer instalací SOLIDWORKS může rozpoznat, když při upgrade administrativní kopie potřebujete aktualizované instalační soubory.

  1. Spusťte Manažera instalací SOLIDWORKS vložením disku DVD do jednotky.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.
  3. Na obrazovce Sériové číslo zadejte sériové číslo SOLIDWORKS.

    Manažer instalací SOLIDWORKS na webové stránce SOLIDWORKS zjistí vaše licencované produkty a dostupné aktualizace Service Pack.

  4. Pokud se zobrazí obrazovka Je k dispozici novější verze zvolte Ano, stáhnout a nainstalovat novější verzi:verze.

    Manažer instalace SOLIDWORKS spustí novou relaci a nainstaluje novější verzi.

  5. Pokud se vyskytne problém se složkou pro stahování , může se objevit okno Možnosti instalace – v takovém případě odsouhlaste výchozí složku pro nové instalační soubory nebo zadejte název nového adresáře.

    Pokud se zobrazí zpráva, že adresář neexistuje, vytvořte ho klepnutím na Ano.

  6. Na obrazovce Stahování dokončeno klepnutím na Zavřít ukončete aktuální instalační službu a spusťte instalační službu pro novou verzi.
Nadřazené téma
Upgrade administrativních kopií na novou verzi
Související pojmy
Upgradování klientů z administrativní kopie
Související úlohy
Upgrade administrativní kopie


Upgrade administrativní kopie

Pro upgrade administrativní kopie vytvoří Manažer instalací SOLIDWORKS nový adresář kopie. Klienty pak instruujete, aby pro upgrade této verze produktu použili nový adresář pro administrativní kopii.

Předpokladem tohoto postupu je, že máte stažené všechny aktualizované instalační soubory v administrativní kopii. Podrobné informace naleznete v Stažení aktualizovaných instalačních souborů pro administrativní kopie.

  1. Spusťte Manažer instalací SOLIDWORKS. Podrobnosti viz Zahájení instalace SolidWorks.
  2. Na obrazovce Vítejte vyberte položku Administrativní kopie.

    Objeví se možnosti pro vytvoření administrativní kopie:

    Volba | Popis
    Vytvořit novou kopii pomocí výchozích nastavení. | Vytvořit kopii pomocí výchozích nastavení konfigurace (tj. nikoli na základě nastavení určených pro stávající administrativní kopii na vašem serveru).
    Vytvořte novou kopii pomocí nastavení a souborů ze stávající kopie. | Vytvořit kopii pomocí nastavení konfigurace určených pro stávající administrativní kopii na vašem serveru. Klepněte na Procházet a určete instalační adresář pro stávající administrativní kopii.
  3. Na obrazovce Sériové číslo zadejte sériové číslo.
  4. Na obrazovce Souhrn (Připraveno k vytvoření kopie), zkontrolujte, že jsou možnosti administrativní kopie správné.

    Podrobnosti o individuální administrativní kopii a možnostech instalace získáte, když klepnete na ZMĚNA a dostanete se na stránku možností a pak klepnete na Nápověda.

  5. Pro vytvoření nové verze administrativní kopie klepněte na Vytvořit nyní.

Nyní můžete upgradovat klienty na tuto novou verzi administrativní kopie. Detaily najdete na odkazu Upgrade klientů z administrativních kopií.

Nadřazené téma
Upgrade administrativních kopií na novou verzi
Související pojmy
Upgradování klientů z administrativní kopie
Související úlohy
Stažení aktualizovaných instalačních souborů pro administrativní kopie
Zahájení instalace SOLIDWORKS


Upgradování klientů z administrativní kopie

Manažer instalací SOLIDWORKS může automaticky aktualizovat klientské počítače instalované z administrativní kopie.

Obvykle jsou administrativní kopie na serveru umístěné ve složkách. Administrativní kopie musí být ve sdílené složce, aby mohlo dojít k automatické aktualizaci klientů.

Po provedení upgradu administrativní kopie, bude původní instalace v jedné složce a upgradovaná instalace ve druhé složce. Chcete-li použít upgradovanou instalační službu, musíte nejprve odstranit možnost sdílení ze složky původní administrativní kopie a poté umožnit sdílení složky s upgradovanou administrativní kopií.

Po spuštění SOLIDWORKS na klientském počítači, který byl instalován z originální administrativní kopie, software zaznamená novou verzi a upgraduje klienta.

Nadřazené téma
Upgrade administrativních kopií na novou verzi
Související úlohy
Stažení aktualizovaných instalačních souborů pro administrativní kopie
Upgrade administrativní kopie

Odstranění možnosti sdílení ze složky s původní administrativní kopií

Když provádíte upgrade administrativní kopie, na kterou je přístup ze sdílené složky, musíte odstranit možnost sdílení z původní složky.

  1. Vyhledejte složku, ve které jsou umístěny soubory původní administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení vyberte Nesdílet tuto složku a klepněte na OK.

Nyní přidejte možnost sdílení pro složku s upgradovanou administrativní kopií podle popisu vPřidání možnosti sdílení ze složky s upgradovanou administrativní kopií.

Přidání možnosti sdílení ze složky s upgradovanou administrativní kopií

Poté, co jste vytvořili nebo aktualizovali složku administrativní kopie a deaktivovali sdílení původní složky administrativní kopie, musíte přidat možnost sdílení nové složce, aby se administrativní kopie znovu aktivovala.

  1. Vyhledejte složku, ve které jsou umístěny soubory upgradované administrativní kopie.
  2. Pravým tlačítkem klepněte na složku a vyberte Vlastnosti.
  3. Na záložce Sdílení určete vlastnosti sdílení vhodné pro vaši společnost nebo skupinu a změňte název sdílení na název používaný pro původní složku administrativní kopie.
Na počítačích s instalací z původního sdíleného umístění administrativní kopie se provede upgrade na novou verzi automaticky, když spustíte SOLIDWORKS.


Správa aktualizace produktu servisního balíčku

Aktualizace produktu servisního balíčku mohou obsahovat aktualizace spolehlivosti systému, kompatibility programu, zabezpečení, atd.

Aktualizace produktů můžete provést dvěma způsoby:
  • Pomocí Manažera instalací SOLIDWORKS zjistit, stáhnout a nainstalovat aktualizace.

    Manažera instalací SOLIDWORKS můžete spustit ručně nebo jej můžete nastavit tak, aby pravidelně zjišťoval aktualizace.

  • Ručním stažením aktualizací Service Pack z webové stránky podpory SOLIDWORKS.

    Aktualizace service pack je instalována jako oprava existující verze softwaru. Například SOLIDWORKS 2015 SP1.0 je aktualizace Service Pack pro SOLIDWORKS 2015 SP0.0. Tyto aktualizace Service Pack můžete nainstalovat pomocí Manažera instalací SOLIDWORKS 2015, ale nemůžete je nainstalovat pomocí Manažera instalací verze SOLIDWORKS 2016.

    Další informace o stahování a instalaci aktualizace Service Pack najdete v dokumentaci pro verzi programu SOLIDWORKS, kterou se snažíte aktualizovat.

Obsah

  • Návrat na předchozí aktualizaci Service Pack v administrativní kopii

    Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci service pack. Pokud jste program SOLIDWORKS nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.

  • Použití servisních balíčků pro klienty pomocí Microsoft Active Directory

    Pokud jste nainstalovali program SOLIDWORKS pomocí služby Microsoft Active Directory, můžete tuto službu také využít při instalaci aktualizací service pack.

Nadřazené téma
Správa násobných instalací
Související pojmy
Upgrade administrativních kopií na novou verzi
Související úlohy
Odstranění instalace


Návrat na předchozí aktualizaci Service Pack v administrativní kopii

Administrativní kopii můžete vrátit zpět na předchozí nainstalovanou aktualizaci service pack. Pokud jste program SOLIDWORKS nainstalovali pomocí disků, budete je pro aktualizaci Service Pack potřebovat. Podmínkou je také, že jste uložili kopii předchozí administrativní kopie.

Upgradované administrativní kopie nelze vrátit na předchozí aktualizaci Service Pack. Administrativní kopie vytvořené jiným způsobem, než pomocí Manažera instalací SOLIDWORKS, nelze vrátit zpět na předchozí verzi. Klienti instalovaní z této administrativní kopie musí být odinstalováni a pak znovu nainstalováni pomocí administrativní kopie vytvořené z dřívější verze.
  1. Odstraňte složku obsahující aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:

    rmdir /s/q cesta_k_aktuální_administrativní_kopii

  2. Přesuňte záložní kopii administrativní kopie na místo, ze kterého jste odstranili aktuální administrativní kopii. Postupujte tak, že otevřete okno s Příkazovým řádkem a zadejte:

    move cesta_k_záložní_administrativní_kopiicesta_k_aktuální_administrativní_kopii

    Po vrácení administrativní kopie zpět na předchozí verzi se klientské počítače aktualizují při příštím spuštění programu SOLIDWORKS.

Nadřazené téma
Správa aktualizace produktu servisního balíčku
Související úlohy
Použití servisních balíčků pro klienty pomocí Microsoft Active Directory


Použití servisních balíčků pro klienty pomocí Microsoft Active Directory

Pokud jste nainstalovali program SOLIDWORKS pomocí služby Microsoft Active Directory, můžete tuto službu také využít při instalaci aktualizací service pack.

  1. Zkopírujte administrativní kopii do nové složky prostřednictvím následujícího příkazového řádku:

    xcopy cesta_k_aktuální_administrativní_kopiicesta_k_záložní_administrativní_kopii /s/i/v

  2. Proveďte upgrade administrativní kopie pomocí Manažera instalací SOLIDWORKS.
  3. Vytvořte nový transformační soubor, který stanoví instalaci upgradu pro program SOLIDWORKS:
    1. Otevřete okno Příkazový řádek.
    2. Ve složce, která obsahuje administrativní kopii, přetáhněte SWCreateMST.exe do okna Příkazového řádku.

      Příkaz by měl být ve tvaru:

      cesta_k_administrativní_kopii\SWCreateMST.exe cesta_k_souboru_MSI_administrativní_kopieseznam_vlastností

      Na příkazovém řádku musí být uvedeny všechny parametry použité při vytváření původního transformačního souboru a také globální parametry Na příkazovém řádku musí být uvedeny všechny parametry použité při vytváření původního transformačního souboru a také globální parametry a UPGRADESWINSTALL.

      Například, pokud původní příkaz byl:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\vaše_složka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@váš_server

      příkaz aktualizace musí být:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\vaše_složka" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@váš_server UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS verzeaktualizace_service_pack"

      Transformační soubor SOLIDWORKS.mst je vytvořen ve složce, která obsahuje administrativní kopii.

  4. V aktivním adresáři upravte zásady Publikovaných aplikací pro skupinu nebo skupiny, které rozmísťují program SOLIDWORKS.
  5. V dialogovém okně Zásady skupiny rozbalte nabídku Konfigurace počítače a Nastavení softwaru.
  6. Klepněte pravým tlačítkem myši na Instalaci softwaru a vyberte Nový > Balíček.
  7. Vyhledejte administrativní kopii a klepněte na Otevřít.
  8. V dialogovém okně Zavedení aplikace vyberte Upřesnit vlastnosti publikování nebo přiřazení a klepněte na OK.
  9. V dialogovém okně Vlastnosti SOLIDWORKS na záložce Změny:
    1. Klepněte na Přidat.
    2. Vyhledejte soubor .mst.
    3. Klepněte na možnost Otevřít.
  10. Klepněte na tlačítko OK.
Nadřazené téma
Správa aktualizace produktu servisního balíčku
Související úlohy
Návrat na předchozí aktualizaci Service Pack v administrativní kopii


SOLIDWORKS Workgroup PDM

Aplikace Workgroup PDM je program pro správu dat produktů. Běží buď uvnitř prostředí programu SOLIDWORKS, nebo jako samostatná aplikace v rámci Průzkumníka SOLIDWORKS. Workgroup PDM řídí projekty pomocí procesů pro vyzvednutí, odevzdání, kontrolu revizí a další správní úkony.

Následuje ilustrace systému PDM Workgroup:

  • Počítač může obsahovat jen jednu úschovnu.
  • Adresář úschovny nemůže být skrytý adresář nebo adresář pouze pro čtení.
  • Výkon programu PDM Workgroup závisí na robustní síti, protože se jedná o aplikaci klient/server.
  • Pokud uživatelé spravují velký počet dokumentů, dosáhnete lepšího výkonu vytvořením více projektů nebo podprojektů obsahujících méně dokumentů, místo projektů s velkým množstvím dokumentů.

Oznámení o konci životnosti

Podpora SOLIDWORKS Workgroup PDM bude po verzi SOLIDWORKS 2017 ukončena. Zákazníci, kteří již software SOLIDWORKS Workgroup PDM používají, ho mohou nadále instalovat, ale měli by začít plánovat migraci úschoven na SOLIDWORKS PDM Server.

Instalace

  • Klienty, Správu úschovny, API a Prohlížeč je možné nainstalovat na stejném počítači jako je úschovna nebo na jiných počítačích.
  • Při instalaci PDM Workgroup serveru není nutné také instalovat klienta API. Klient API je nainstalován jako součást instalace PDM Workgroup klienta.
  • Jako umístění serveru zadejte úplný název UNC (Universal Naming Convention) serveru, pokud chcete nakonfigurovat složku úschovny na vzdáleném umístění. (Podrobnosti najdete v Formát UNC.)
  • Instalace nebo aktualizace úschovny vyžaduje restartování počítače.
  • Pokud se služba Workgroup PDM Server nespustí automaticky po restartování počítače, bude nutné tuto službu spustit ručně. V Průzkumníku Windows spusťte soubor V Průzkumníku Windows spusťte soubor ve složce pdmwvault.exe\SOLIDWORKS Workgroup PDM\Vault.
  • Při instalaci klienta Workgroup PDM musíte na každém počítači instalovat soubor solidworksexplorer.exe. Tento spustitelný soubor může být na sdílené jednotce. Workgroup PDM úschovna, Viewer, API klient a Správa úschovny VaultAdmin nejsou nainstalovány na každém klientském počítači.
Pokud používáte systém Windows 8, najdete v dokumentu Tipy ohledně používání aplikace SolidWorks v systému Microsoft Windows řešení úloh, jako je přístup k Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti najdete v dokumentaci k systému Microsoft Windows.

Licence

  • Licence na Workgroup PDM API je zahrnuta v licencích pro klienty SOLIDWORKS a klienty Průzkumníka. API pro odevzdávání vyžadují licence pro klienty.
  • Licence prohlížeče Workgroup PDM musí být nainstalována společně s úschovnou, aby bylo možné aktivovat Prohlížeč.

Oprávnění

  • Správce úschovny by měl mít oprávnění pro zápis k instalační složce a ke složce úschovny.
  • Správce úschovny by měl úschovnu spravovat ze správy úschovny VaultAdmin, ne z Průzkumníka Windows.
  • Uživatele by nikdy neměli mít oprávnění pro zápis v Průzkumníku Windows ke složce úschovny.

Zabezpečení, porty a nastavení duplexního přenosu

  • Workgroup PDM je nutné instalovat jako službu systému Windows, tak aby jiné aplikace nemohly blokovat nebo filtrovat tuto službu. Například pokud nástroje, které chrání před spywarem, jako např. Microsoft AntiSpyware, zobrazí během instalace výstrahu vyžadující souhlas, klepněte na Povolit, aby se Workgroup PDM Server mohl nainstalovat jako služba systému Windows.
  • Pokud instalujete Workgroup PDM v počítači s aktivní branou firewall, musíte zapnout porty Workgroup PDM jako výjimky v nastavení brány firewall.

    Nastavení portů je většinou:

    • 20000 (VaultAdmin)
    • 30000 (Data)
    • 40000 (Request)
    • 80 (Viewer)
    Informace o změně nastavení portů najdete v Řešení problémů pro správce úschovny v Nápovědě Workgroup PDM, v nápovědě pro Průzkumník SOLIDWORKS a také v nápovědě Microsoft Windows pro Zabezpečení systému Windows. Chcete-li nainstalovat úschovnu a prohlížeč Workgroup PDM současně, vyberte možnost Vlastní v dialogovém okně Typ instalace.
  • Zdvojené nastavení pro servery a jejich odpovídající porty by měly být stejné, například oba by mohly být Plné 100MB, nebo Automatické.

Dokumenty SOLIDWORKS Toolbox

Dokumenty SOLIDWORKS Toolbox jsou běžné hardwarové součásti, které ve většině případů nevyžadují kontrolu oprav a nejsou odevzdávány do úschovny PDM Workgroup. Další informace o tom, jak nakonfigurovat SOLIDWORKS Toolbox a ostatní standardní knihovny, jsou k dispozici v nápovědě online pro PDM Workgroup.

Obsah

  • Prohlížeč Workgroup PDM

    Program PDM Workgroup automaticky nastaví virtuální adresář během instalace pomocí služeb Microsoft Internet Information Services (IIS).

  • Instalace Workgroup PDM Server

    Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SOLIDWORKS.

  • Konfigurace PDM Workgroup pro klienty

    Po instalaci úschovny serveru Workgroup PDM můžete konfigurovat úschovnu pro klienty.

  • Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti

    Instalace Webového serveru SOLIDWORKS Workgroup PDM a Prohlížeče Workgroup PDM na hraniční síti (DMZ) má dopady na bránu firewall.

  • Přístup klientského počítače k Workgroup PDM

    Klienti Workgroup PDM používají kontrolu přístupu Microsoft Windows, mají přístup na webové stránky pomocí Workgroup PDM Viewer a automaticky se aktualizují kdykoliv se úschovna Workgroup PDM aktualizuje.

  • Workgroup PDM VaultAdmin správy úschovny

    Po ukončení instalace PDM Workgroup by správci úschovny měli provést následující:

Související pojmy
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8


Prohlížeč Workgroup PDM

Program PDM Workgroup automaticky nastaví virtuální adresář během instalace pomocí služeb Microsoft Internet Information Services (IIS).

Než nainstalujete PDMWorks Workgroup Viewer, je nutné nainstalovat internetovou informační službu Microsoft (IIS).
Mezi požadované součásti patří:
  • Nástroje pro správu webu
    • IIS Management Console
  • Webové služby: Funkce pro vývoj aplikací
    • .NET Extensibility
    • ASP.NET
    • CGI
    • Rozšíření ISAPI
    • Filtry ISAPI
Návod na instalaci IIS můžete nalézt v dokumentaci Microsoft.
Instalace Workgroup PDM Viewer musí probíhat podle těchto omezení:
  • Adresář obsahu webové stránky je instalační složka pro Viewer.
  • V názvu počítače hostitele Viewer nemůžete používat podtržítko.
  • Viewer může být současně napojený pouze na jednu úschovnu.

Uživatelé přistupují k prohlížeči PDM Workgroup zadáním následující adresy do pole Adresa v Internet Explorer:

http://ViewerNázevPočítače/pdmweb/

Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Přístup klientského počítače k Workgroup PDM
Workgroup PDM VaultAdmin správy úschovny
Související úlohy
Instalace Workgroup PDM Server
Konfigurace PDM Workgroup pro klienty


Instalace Workgroup PDM Server

Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SOLIDWORKS.

  1. Spusťte Manažer instalací SOLIDWORKS. Viz Zahájení instalace SolidWorks.
  2. Na obrazovce Uvítání vyberte následující:

    • Produkty Server
    • Do tohoto počítače nainstalujte software SOLIDWORKS Workgroup PDM Server (úschovnu).

  3. Na obrazovce Souhrnné informace, klepněte na tlačítko Změnit; získáte ověřovací kód. Kód můžete získat jedním z následujících způsobů:
    • Internetové připojení
      1. Zadejte do příslušných polí sériové číslo softwaru SOLIDWORKS a e-mailovou adresu.
      2. Vyberte možnost Ověřit automaticky a klepněte na Získat kód.
    • Email
      1. Nemá-li váš počítač přístup k síti Internet, klepněte na možnost Ověřit ručně přes e-mail. Manažer instalací vytvoří soubor s požadavkem na ověření.
      2. Klepnutím na tlačítko Uložit tento soubor uložte do systému.
      3. Postupujte podle pokynů na obrazovce a zadejte ověřovací kód.
  4. Klepněte na Zpět na souhrnné informace.
  5. Na obrazovce Souhrnné informace, klepněte na tlačítko Nainstalovat.
Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Přístup klientského počítače k Workgroup PDM
Workgroup PDM VaultAdmin správy úschovny
Související úlohy
Konfigurace PDM Workgroup pro klienty
Zahájení instalace SOLIDWORKS
Související odkazy
Prohlížeč Workgroup PDM


Konfigurace PDM Workgroup pro klienty

Po instalaci úschovny serveru Workgroup PDM můžete konfigurovat úschovnu pro klienty.

  1. Přihlaste se do správy úschovny VaultAdmin (nainstalováno společně s Průzkumníkem SOLIDWORKS) pomocí výchozího uživatelského jména a hesla.
  2. Ve správě úschovny VaultAdmin nastavte uživatelské a skupinové účty, složky projektu, oprávnění, atd.

    Bližší informace viz Workgroup PDM Workgroup PDM Help.

  3. Zašlete email klientským uživatelům obsahující název počítače serveru, jejich uživatelská jména a hesla, která jsou obvykle jiná než jejich uživatelská jména a hesla v systému Microsoft Windows.
Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Přístup klientského počítače k Workgroup PDM
Workgroup PDM VaultAdmin správy úschovny
Související úlohy
Instalace Workgroup PDM Server
Související odkazy
Prohlížeč Workgroup PDM

Konfigurace Workgroup PDM Viewer pro připojení na jiné umístění úschovny

Můžete konfigurovat Workgroup PDM Viewer, aby byl napojen na jiné umístění úschovny pomocí registru Windows.

  1. Aktualizujte cestu registru změnou hodnoty Vault Computer (Počítač úschovny):

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\Vault Computer

  2. Nainstalujte Workgroup PDM Viewer znovu. V dialogu Název počítače úschovny zadejte název nového počítače.

Konfigurace typů MIME pro stahování dokumentů

Můžete konfigurovat typy MIME pro stahování dokumentů pomocí nastavení registru Windows.

Ve výchozím nastavení Viewer zašle požadavky Otevřít dokument s obecným typem MIME "application/octet-stream." Microsoft Internet Explorer potom otevře požadovaný dokument s dodanou příponou souboru. Můžete mapovat další typy MIME nebo vypnout mapování typů MIME úpravou typů MIME v dílčím klíči registru Windows.

  • Pro mapování dalších typů MIME vytvořte dodatečné řetězcové hodnoty v dílčím klíči registru:

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Mime Types

    v podobě:

    "ext" = "typ mime"

    Příklad:

    "dxf" = "image/vnd.dxf"

    Nejprve musíte ručně vytvořit tento dílčí klíč registru a poté vložit hodnoty.

    Mapování typu MIME vypnete změnou hodnoty Use Custom MIME Types registru na 0 (nula).

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    Pro aktivaci tohoto nastavení není potřeba restartovat web server.


Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti

Instalace Webového serveru SOLIDWORKS Workgroup PDM a Prohlížeče Workgroup PDM na hraniční síti (DMZ) má dopady na bránu firewall.

Protože klienti Prohlížeče Workgroup PDM komunikují s Webovým serverem přes porty HTTP nebo HTTPS, musí být tyto porty otevřeny na systému Serveru služby IIS, na kterém je Webový server nainstalován.

  • Pro protokol HTTP je výchozím portem 80.
  • Pro protokol HTTPS (SSL) je výchozím portem 443.

Klienti Webového serveru nepotřebují výjimky brány firewall.

Musíte zajistit, aby se systém Webového serveru mohl spojit se serverem Úschovny přes tyto výchozí porty.

  • 30000 (Data)
  • 40000 (Request)

Obsah

  • Konfigurace sítě pro Prohlížeč Workgoup PDM na hraniční síti

    Konfigurace sítě představuje nastavení serveru hraniční sítě na dílčí hraniční síti a její komunikaci s interními a externími sítěmi.

  • Instalace a konfigurace Webového serveru a Prohlížeče Workgroup PDM

    Při nastavování Webového serveru Workgroup PDM na hraniční síti je důležité umístění instalace součástí.

Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Přístup klientského počítače k Workgroup PDM
Workgroup PDM VaultAdmin správy úschovny
Související úlohy
Instalace Workgroup PDM Server
Konfigurace PDM Workgroup pro klienty
Související odkazy
Prohlížeč Workgroup PDM


Konfigurace sítě pro Prohlížeč Workgoup PDM na hraniční síti

Konfigurace sítě představuje nastavení serveru hraniční sítě na dílčí hraniční síti a její komunikaci s interními a externími sítěmi.

Server hraniční sítě komunikuje s LAN prostřednictvím interní brány firewall. S externími sítěmi komunikuje prostřednictvím externí brány firewall, směrovače a clusteru rozložení zátěže.

Klient prohlížeče Internet Explorer se s Prohlížečem Workgroup PDM/IIS serverem spojuje přes port 80 (nebo 443, pokud používá SSL). Prohlížeč Workgroup PDM se poté spojuje se serverem úschovny prostřednictvím portů 30000 nebo 40000. Server úschovny odešle požadované informace zpět do Prohlížeče Workgroup PDM, který je následně předává zpět klientovi prohlížeče Internet Explorer.

Hraniční síť webového serveru má dvě IP adresy:

  • Interní IP adresu na LAN
  • Veřejnou IP adresu poskytovanou poskytovatelem ISP

Webový server na hraniční síti je umístěný za clusterem rozložení zátěže. I když je možné získat přístup k webovému serveru přímo pro administrativní úkoly, všechen provoz webových služeb na hraniční síti je zpracováván přes rozložení zátěže.

Rozložení zátěže přeloží IP adresu hardwaru serveru na virtuální IP (VIP) na části sítě, která je přístupná veřejnosti. Když přejdete na VIP nebo na URL webového serveru během připojení k síti, webová stránka se zobrazí.

Externí brána firewall přeloží VIP rozložení zátěže na veřejnou route-able adresu.

Nadřazené téma
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Související úlohy
Instalace a konfigurace Webového serveru a Prohlížeče Workgroup PDM


Instalace a konfigurace Webového serveru a Prohlížeče Workgroup PDM

Při nastavování Webového serveru Workgroup PDM na hraniční síti je důležité umístění instalace součástí.

  • Na dílčí hraniční síti nainstalujte Webový server se službou IIS.
  • Na dílčí hraniční síti nainstalujte Prohlížeč Workgroup PDM se službou IIS.
  • Na hlavní doméně nebo na interní síti na místním intranetu nainstalujte Úschovnu Workgroup PDM.

Předpoklady pro instalování a konfiguraci Prohlížeče Workgroup PDM na hraniční síti jsou:

  • Microsoft IIS 6.0 nebo novější
  • Veřejná adresa IP na Webový server na dílčí hraniční síti přiřazená vašim poskytovatelem ISP

Návod na instalaci a konfiguraci součástí Workgroup PDM:

  1. Na systému dílčího hraničního serveru nainstalujte službu Microsoft IIS.
  2. Proveďte dvě instalace serveru SOLIDWORKS Workgroup PDM:
    1. Nejprve na Serveru úschovny nainstalujte součást Úschovny.
    2. Spusťte instalační službu podruhé a nainstalujte Prohlížeč Workgroup PDM a součásti licence Prohlížeče na Webovém serveru služby IIS. Zadejte název počítače serveru úschovny, aby webový portál věděl, kde vyhledat službu serveru úschovny.

    Během instalace je PDMWeb aplikace přidána automaticky na výchozí webovou stránku služby IIS.

  3. Ujistěte se, že má brána firewall na interní síti porty 30000 a 40000 otevřené.
  4. Pokud má interní server fixní IP adresu na systému hraničního serveru, upravte soubor C:\Windows\system32\drivers\etc\hosts. Vytvořte název systému mapování IP adresy, aby mohl hraniční server komunikovat s interním serverem.
    1. Otevřete soubor hosts v textovém editoru, například v Poznámkovém bloku.
    2. Vložte nový řádek pro IP adresu a název serveru úschovny.
    3. Uložte hosts soubor.
Nadřazené téma
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Související pojmy
Konfigurace sítě pro Prohlížeč Workgoup PDM na hraniční síti


Přístup klientského počítače k Workgroup PDM

Klienti Workgroup PDM používají kontrolu přístupu Microsoft Windows, mají přístup na webové stránky pomocí Workgroup PDM Viewer a automaticky se aktualizují kdykoliv se úschovna Workgroup PDM aktualizuje.

Návod na přihlášení jako PDM Workgroup klient: | Uživatelská jména a hesla účtů klientů nejsou v PDMWorks Workgroup shodná s přihlášením do Microsoft Windows. Kontaktujte správce systému ohledně informací o přihlášení.
Návod na připojení k Workgroup PDM Viewer: | Kontaktujte správce systému ohledně URL pro připojení do Viewer.
Návod na aktualizaci PDM Workgroup klientů: | Klienti PDM Workgroup (doplňkový modul SOLIDWORKS Klient a Contributor) rozpoznají, když byla úschovna aktualizována. Pro aktualizaci klientů není nutné stahovat aktualizaci service pack.
Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Workgroup PDM VaultAdmin správy úschovny
Související úlohy
Instalace Workgroup PDM Server
Konfigurace PDM Workgroup pro klienty
Související odkazy
Prohlížeč Workgroup PDM


Workgroup PDM VaultAdmin správy úschovny

Po ukončení instalace PDM Workgroup by správci úschovny měli provést následující:

  • Přihlásit se do správy úschovny VaultAdmin.
  • Změnit heslo správce úschovny
  • Vytvořit uživatelské účty.
  • Oznámit uživatelům názvy a hesla jejich účtů.

Bližší informace viz SOLIDWORKS Workgroup PDM v hlavní nápovědě SOLIDWORKS.

Nadřazené téma
SOLIDWORKS Workgroup PDM
Související pojmy
Instalace Workgroup PDM Serveru a Prohlížeče na hraniční síti
Přístup klientského počítače k Workgroup PDM
Související úlohy
Instalace Workgroup PDM Server
Konfigurace PDM Workgroup pro klienty
Související odkazy
Prohlížeč Workgroup PDM

První přihlášení do Workgroup PDM VaultAdmin

Když se poprvé přihlašujete do Workgroup PDM VaultAdmin, určete jméno a heslo administrátora Workgroup PDM a název počítače, na kterém je úschovna Workgroup PDM.

  1. V systému Windows, klepněte na Start > Všechny programy > SOLIDWORKS verze > Workgroup PDM VaultAdmin.
  2. V dialogovém okně zadejte následující informace:

    Jméno | pdmwadmin
    Heslo | pdmwadmin
    Počítač úschovny | Název hostitele počítače, na kterém je nainstalovaná úschovna. Pokud spouštíte VaultAdmin správu úschovny na počítači, na kterém je úschovna nainstalovaná, zadejtelocalhost.

  3. Klepněte na Přihlášení.
Z bezpečnostních důvodů doporučujeme okamžitou změnu hesla správce. Ve správě úschovny VaultAdmin vyberte záložku Uživatelé a skupiny.

Provedení upgrade serveru úschovny Workgroup PDM

Můžete provést upgrade serveru úschovny Workgroup PDM pomocí funkce SOLIDWORKS Zjistit aktualizace, instalačního DVD SOLIDWORKS nebo ručního upgradu souboru Workgroup PDM, staženého do lokální složky.

Můžete nainstalovat pouze jednu verzi PDM Workgroup Server.
  1. Požádejte všechny uživatele, aby se odhlásili z úschovny Workgroup PDM a pak ji zamkněte.
  2. Vytvořte záložní kopii dat úschovny.
  3. Pomocí Ovládacích panelů Microsoft Windows Přidat/Odebrat programy odstraňte aktuální verzi programu PDM Workgroup Server.
  4. Nainstalujte novou verzi PDM Workgroup Server.
    • Použití funkce SOLIDWORKS Zjistit aktualizace:
      1. V systému Windows klepněte na Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace.
      2. V dialogovém okně Novější verze jsou k dispozici pro stažení vyberte Stáhnout a nainstalovat novou verzi, vyberte verzi, kterou chcete nainstalovat a pak klepněte na Další.

        Bude stažena a spuštěna nová verze Manažera instalací SOLIDWORKS.

    • Chcete-li pro instalaci SOLIDWORKS použít disk DVD, vložte jej do jednotky a postupujte podle pokynů Manažera instalací SOLIDWORKS.
    • Pro použití ručně stahovaného instalačního souboru Workgroup PDM (pdmwserver.exe) poklepejte na soubor a pak postupujte podle instrukcí pro upgrade Workgroup PDM Server.
  5. Použijte Plánovač úloh SOLIDWORKS k aktualizaci souborů PDM Workgroup v úschovně.
  6. Odemkněte úschovnu a informujte uživatele, že se mohou vrátit do úschovny.

Provedení upgrade u klientů Workgroup PDM

Klienti budou vyzváni k aktualizaci, když se poprvé přihlásí do aktualizované úschovny. K aktualizaci klientů není potřebná aktualizace service pack.

Stav klienta ve vztahu k úschovně | Operace
Stejná verze jako verze úschovny | Žádná
Stejná hlavní verze, novější než úschovna | Žádná
Novější hlavní verze, novější než úschovna | Přihlášení je blokované
Stejná hlavní verze, starší než úschovna | Volitelná aktualizace
Starší hlavní verze, starší než úschovna | Povinná aktualizace

Další informace ohledně aktualizace klientů Workgroup PDM najdete na odkaze Aktualizace klientů v Nápovědě PDM Workgroup.


SOLIDWORKS PDM

SOLIDWORKS PDM je produkt pro správu dokumentů založený na architektuře klient/server, dříve známý pod názvem SOLIDWORKS Enterprise PDM.

Software SOLIDWORKS PDM je k dispozici ve dvou typech:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

Software SOLIDWORKS PDM využívá pro správu úschoven souborů databázi Microsoft SQL Server.

Tato tabulka uvádí databázové systémy, serverové komponenty a možnosti klientských aplikací, které jsou k dispozici pro daný typ produktu.
 | PDM Standard | PDM Professional
Určeno pro: | Malé až středně velké podnikové sítě pro max. 5 uživatelů pracujících současně | Velké podnikové sítě s velkým počtem uživatelů pracujících současně
Omezení | 1 CPU, paměť 1 GB, velikost databáze 10 GB | Bez omezení
Systém pro správu databází | Microsoft SQL Server Express 2014 (součástí dodávky a nainstalováno s aplikací SOLIDWORKS) | Microsoft SQL Server 2014 (samostatně součástí dodávky aplikace SOLIDWORKS) nebo dříve nainstalované instance softwaru Microsoft SQL Server 2014, 2012 nebo 2008 R2
Vyžaduje Manažer licencí SolidNetWork? | Ano | Ano
Zahrnuje archivní a databázový server? | Ano | Ano
Zahrnuje webový server SOLIDWORKS PDM a server Web2? | No | Ano
Typ klienta | Nativní | Nativní, založený na prohlížeči
Klient a doplňkové moduly pro CAD Editory | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, Microsoft Office Integration, Autodesk Inventor, AutoCAD
Klient a doplňkové moduly pro přispěvatele | DraftSight | DraftSight, Microsoft Office Integration
Klient a doplňkové moduly pro prohlížeče |  | Integrace Microsoft Office

Obsah

  • Zobrazení seznamu serverových součástí PDM

  • Výběr klientů

    Potřebné klienty je nutno vybrat podle vašeho prostředí PDM.

  • Před instalací softwaru PDM Serveru

    Před instalací serverových součástí PDM mějte na paměti následující požadavky:


Zobrazení seznamu serverových součástí PDM

V této tabulce je uveden přehled serverových součástí softwaru SOLIDWORKS PDM Server.

Server | Funkce | Instalace
Microsoft SQL Server Express pro PDM Standard | Spravuje data v datových úschovnách softwaru SOLIDWORKS PDM. | Lze jej nainstalovat společně s verzí PDM Standard nebo použít předchozí licencovanou a instalovanou verzi.
Microsoft SQL Server pro PDM Professional | Spravuje data v datových úschovnách softwaru SOLIDWORKS PDM. | Dodává se samostatně s verzí PDM Professional. Je možno rovněž použít dříve licencovanou a instalovanou verzi.
Manažer licencí SolidNetWork | Spravuje licence SOLIDWORKS PDM. | Musí být nainstalováno před vytvářením nových úschoven. Pokud se používá SLDIM, lze nainstalovat se součástmi serveru SOLIDWORKS PDM.
Archivní server | Spravuje přenos souborů mezi klienty a archivem úschovny souborů a dále uživatele a jejich přihlašovací údaje. | Povinné. Instaluje se s verzí PDM Standard nebo Professional.
Databázový server | Vyhledává v databázích PDM aktualizace a spravuje pravidla importu a exportu dat. Spravuje systém zpráv a plánuje replikace a rezervní úložiště. | Povinné. Instaluje se s verzí PDM Standard nebo Professional.
Webový server a server Web2\ | Umožňuje přístup do úschoven souborů přes síť Internet z klientů založených na webových prohlížečích. | Volitelné. Instaluje se pouze s verzí PDM Professional.

Archivní servery běží jako služby pod systémovým účtem na počítačích, kde jsou nainstalovány. Na jednom archivním serveru může být více úschoven souborů, a to na stejném počítači.

V případě samostatné instalace může být archivní, databázový a licenční server i databáze SQL Express nebo SQL Server nainstalována na stejném počítači.

V případě distribuovaného prostředí mohou být serverové součásti umístěny na různých počítačích. Dále je možné umístit více archivních serverů na různé počítače, na kterých se pak nachází replikované kopie téhož archivu úschovny souborů. Viz Průvodce replikací SOLIDWORKS PDM Professional.

Nadřazené téma
SOLIDWORKS PDM
Související pojmy
Výběr klientů
Před instalací softwaru PDM Serveru


Výběr klientů

Potřebné klienty je nutno vybrat podle vašeho prostředí PDM.

V této tabulce je uveden přehled klientů pro software SOLIDWORKS PDM Standard:
Typ standardního klienta | Komentář
CAD Editor | Podporuje práci se softwarem SOLIDWORKS, DWG/DXF a Microsoft Office. Soubory všech formátů zpracovatelných ve formátu Office se chovají v softwaru SOLIDWORKS PDM Standard stejně.
Přispívající | Podporuje práci se softwarem SOLIDWORKS, DWG/DXF a Microsoft Office.
Viewer | Umožňuje přístup do úschoven jen pro čtení. Uživatel může provést přechod souborů prostřednictvím pracovního postupu, ale nemůže přidávat nebo upravovat (vyzvedávat, odevzdávat, aktualizovat hodnoty) soubory.
V této tabulce je uveden přehled klientů pro software SOLIDWORKS PDM Professional:
Typ profesionálního klienta | Komentář
CAD Editor & Web | Podporuje práci se všemi typy souborů, včetně pokročilé správy a náhledů formátů CAD, například aplikace SOLIDWORKS. Doplňkové moduly CAD umožňují uživatelům přistupovat k SOLIDWORKS PDM Professional z aplikací CAD. Vzdálení uživatelé mohou hledat v úschovnách a využívat základní funkce přes internet pomocí klientů Web a Web2.
Contributor & Web | Podporuje práci se všemi typy souborů, včetně CAD souborů. Doplňkové moduly CAD však nejsou na tomto typu klienta podporovány. Vzdálení uživatelé mohou hledat v úschovnách a využívat základní funkce přes Internet pomocí klientů Web a Web2.
Viewer | Umožňuje přístup do úschoven jen pro čtení. Uživatel může provést přechod souborů prostřednictvím pracovního postupu, ale nemůže přidávat nebo upravovat (vyzvedávat, odevzdávat, aktualizovat hodnoty) soubory ani používat doplňkové moduly CAD.
Nadřazené téma
SOLIDWORKS PDM
Související pojmy
Zobrazení seznamu serverových součástí PDM
Před instalací softwaru PDM Serveru


Před instalací softwaru PDM Serveru

Před instalací serverových součástí PDM mějte na paměti následující požadavky:

  • Obstarejte si úplná oprávnění správce pro počítače, na kterých budete instalovat servery a klienty.
  • Ověřte, že má databázový server přístup na archivační server přes TCP, port 3030 a SQL server přes TCP, port 1433.
  • Hodláte-li použít stávající databázi SQL Server Express nebo SQL Server, požádejte o název databáze SQL Serveru a přihlašovací ID a heslo správce nebo vlastníka databáze SQL s přístupem pro čtení/zápis do databáze. Uživatele tew nelze použít.
  • Pokud je již v systému nainstalován klient PDM, odinstalujte jej. Pokud chcete mít na jednom systému Server PDM i klienta PDM, je nutné je oba instalovat pomocí instalačního procesu pro server SOLIDWORKS PDM.

Obsah

  • Instalace serveru PDM s použitím SLDIM

    Když instalujete server PDM pro verzi PDM Standard, můžete nainstalovat archivní server, databázový server a klienta PDM CAD Editor na jednom počítači. Není nutné spouštět instalaci klienta samostatně.

  • Instalace klienta PDM s použitím SLDIM

Nadřazené téma
SOLIDWORKS PDM
Související pojmy
Zobrazení seznamu serverových součástí PDM
Výběr klientů


Instalace serveru PDM s použitím SLDIM

Když instalujete server PDM pro verzi PDM Standard, můžete nainstalovat archivní server, databázový server a klienta PDM CAD Editor na jednom počítači. Není nutné spouštět instalaci klienta samostatně.

Při instalaci serveru PDM pro verzi PDM Professional můžete zahrnout uvedené součásti a rovněž server Web a Web2.

Instalace serveru PDM a jeho součástí:

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na stránce Vítejte vyberte možnost Serverové produkty a zaškrtněte následující možnosti:
    • Instalovat součásti SOLIDWORKS PDM Server na tomto počítači.
    • Instalovat Manažer licencí SolidNetWork na tomto počítači.

      Pokud je nainstalovaný Manažer licencí SolidNetwork, tato možnost se nezobrazí.

  3. Pokud se zobrazí stránka Možnosti Manažera licencí SolidNetWork, zadejte sériové číslo, určete umístění adresáře a klepněte na tlačítko Další.
  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace v části SOLIDWORKS PDM Server klepněte na tlačítko Změnit.
  6. Na stránce Možnosti SOLIDWORKS PDM Serveru:
    1. Pod položkou Vyberte serverový produkt klepněte na možnost SOLIDWORKS PDM Standard nebo Professional.
    2. Pod položkou Umístění instalace klepněte na položku Procházet a zadejte cestu k souboru.
    3. V okně Vybrat prvky:

      1. Klepněte na položku Archivní server, Databázový server a Klient a nainstalujte tyto součásti na jeden počítač. Pokud jste v distribuovaném prostředí, lze nainstalovat archivní server a databázový server spuštěním Správce instalací na jiném počítači.
        Pokud je v počítači již nainstalován klient PDM, je nutné zrušit instalaci a klienta odinstalovat. Pak lze spustit nástroj SLDIM a nainstalovat server PDM společně s klientem.
      2. Pokud instalujete verzi PDM Professional, můžete rovněž klepnout na položky server Web a server Web2.

    4. V aplikaci server SQL lze nainstalovat novou instalaci databázových nástrojů a nástrojů pro správu, dodávaných se serverem PDM (SQL Server Express pro verzi PDM Standard), nebo lze zadat název databáze, uživatelské jméno a heslo stávající instalace.

      Pro verzi PDM Professional se plná verze serveru SQL dodává samostatně.

    5. Klepněte na Zpět na souhrnné informace.
  7. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.

    Když Manažer instalací SOLIDWORKS dokončí instalaci, spustí se Nástroj pro konfiguraci archivního serveru. Podle pokynů v průvodci nakonfigurujete archivní server.

Informace o nastavení, konfiguraci a odstraňování problémů s archivním serverem, databázovým serverem, servery Web a Web2 a databázemi serveru SQL naleznete v příslušných tématech v Průvodci instalací SOLIDWORKS PDM 2016.
Nadřazené téma
Před instalací softwaru PDM Serveru
Související úlohy
Instalace klienta PDM s použitím SLDIM


Instalace klienta PDM s použitím SLDIM

Při instalaci klienta PDM postupujte takto:

  1. Spusťte Manažer instalací SOLIDWORKS.
  2. Na stránce Vítejte vyberte možnost Samostatná.
  3. Na stránce Sériové číslo klikněte na tlačítko Další.

    Software SOLIDWORKS PDM nevyžaduje sériové číslo.

  4. Postupujte podle pokynů pro systémová varování a klikněte na tlačítko Další.
  5. Na stránce Souhrnné informace v části Produkty klikněte na tlačítko Změnit.
  6. Na stránce Výběr produktu klikněte na možnost Vybrat jiný balíček nebo produkty.
  7. V okně Vyberte balíček, který se má zobrazit vyberte verzi SOLIDWORKS. Potom klikněte na OK.
  8. Na stránce Výběr produktu vyberte položku SOLIDWORKS PDM Client. Pak vyberte eDrawings a povolte tak funkčnost náhledu PDM. Máte-li verzi SOLIDWORKS PDM Professional, můžete také vybrat možnost Průzkumník položek.
  9. Na stránce Souhrnné informace rozbalte položku Možnosti SOLIDWORKS PDM a klikněte na tlačítko Změnit.
  10. Na stránce Možnosti klienta SOLIDWORKS PDM vyberte následující možnosti a klikněte na tlačítko Zpět na souhrnné informace:
    • Typ produktu PDM
    • Typ klienta PDM
    • Doplňkové moduly
  11. Na stránce Souhrnné informace odsouhlaste podmínky licenční smlouvy SOLIDWORKS a klikněte na tlačítko Nainstalovat.
Nadřazené téma
Před instalací softwaru PDM Serveru
Související úlohy
Instalace serveru PDM s použitím SLDIM


SOLIDWORKS Electrical

Aplikace SOLIDWORKS Electrical zjednodušuje vytváření návrhů elektrických systémů pomocí inteligentních návrhářských nástrojů, široké databáze dílů a integrace schémat 2D s 3D modely v reálném čase.

Hlavní součásti aplikace SOLIDWORKS Electrical:
  • SOLIDWORKS Electrical Schematic – Nástroje pro vytváření 2D dynamických elektrických schémat.
  • SOLIDWORKS Electrical 3D – Nástroje pro integraci 2D schémat a 3D modelů, které umožňují modelování elektrických systémů ve 3D včetně kabelů a vodičů.
  • Data – Databáze dílů, symbolů, knihoven a katalogů, které je možné mezi jednotlivými uživateli sdílet.
  • Server pro spolupráci – Nástroj pro správu otevírání a aktualizací výkresů elektrických projektů.
  • Instance databáze Microsoft SQL Server.

Aplikace SOLIDWORKS Electrical vyžaduje databázi Microsoft SQL Server. Může použít stávající databázi nebo novou instanci jako součást instalace.

Všechny součásti aplikace SOLIDWORKS Electrical můžete nainstalovat do jednoho počítače. Taková instalace se považuje za samostatnou instalaci. Veškerá programová data, například projektové výkresy nebo zprávy, jsou uložena v jediném systému. Pro instalaci aplikace SOLIDWORKS Electrical jsou nutná úplná přístupová oprávnění správce k systému.

Součásti aplikace SOLIDWORKS Electrical můžete také nainstalovat ve verzi klient/server. Taková instalace je nutná, pokud je data potřeba ukládat na síťovém serveru nebo pokud existuje stávající databáze serveru SQL na síťovém serveru, kde jsou uloženy všechny databáze aplikace SOLIDWORKS Electrical. V takových případech jsou nutná úplná přístupová oprávnění správce k systému serveru i klienta. Klientské systémy také musí mít síťový přístup k serveru a oprávnění pro čtení i zápis, aby mohly vytvářet projekty, knihovny a symboly.

Obsah

  • Správa dat v aplikaci SOLIDWORKS Electrical

  • Požadavky na instalaci aplikace SOLIDWORKS Electrical


Správa dat v aplikaci SOLIDWORKS Electrical

Mnoho programů používá jednu databázi, která obsahuje všechna programová data. Aplikace SOLIDWORKS Electrical je v tomto jiná. Každý projekt v aplikaci SOLIDWORKS Electrical dostane přiřazeno jedinečné číslo ID a každý projekt má svou vlastní databázi, kterou lze identifikovat podle příslušného ID. Pokud například ve správci projektů aplikace SOLIDWORKS Electrical naleznete projekt s označením ID#112, pak je jeho vlastní databáze označena „tew_project_data_112“.

Důvodem pro vytváření samostatných databází pro jednotlivé projekty je významná úspora času při zpracování. Také v případě kritického selhání databáze dojde k poškození pouze jediného projektu a integrita většiny programových informací zůstane zachována.

Některé společnosti však mají omezení, která se vztahují na vytváření nových databází. Aby mohla aplikace SOLIDWORKS Electrical fungovat, nesmí pro vytváření nových databází uživateli platit žádná omezení. Ověřte si u správce systémů nebo databází, zda nejsou v platnosti omezení, která by uživatelům bránila ve vytváření nových databází.
Nadřazené téma
SOLIDWORKS Electrical
Související pojmy
Požadavky na instalaci aplikace SOLIDWORKS Electrical


Požadavky na instalaci aplikace SOLIDWORKS Electrical

Aktuální systémové požadavky naleznete na adrese http://solidworks.com/System_Requirements.

Obsah

  • Individuální instalace a instalace na server

    Aplikaci SOLIDWORKS Electrical můžete nainstalovat v individuálním režimu nebo v režimu serveru.

  • Nastavení umístění dat

  • Konfigurace serveru pro spolupráci

  • Konfigurace Microsoft SQL Serveru

Nadřazené téma
SOLIDWORKS Electrical
Související pojmy
Správa dat v aplikaci SOLIDWORKS Electrical


Individuální instalace a instalace na server

Aplikaci SOLIDWORKS Electrical můžete nainstalovat v individuálním režimu nebo v režimu serveru.

Upozorňujeme, že aplikace SOLIDWORKS Electrical se potřebuje připojit k instanci serveru SQL (stávající nebo nové).

V individuálním režimu můžete nainstalovat tyto součásti:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Server Collaborative Server
  • Data
  • Novou instanci databáze serveru SQL
V režimu serveru můžete nainstalovat tyto součásti:
  • Novou instanci databáze serveru SQL
  • Server Collaborative Server
  • Data

Můžete zkombinovat součásti z individuálního režimu a z režimu serveru a vytvořit prostředí klient/server. Můžete například nainstalovat SOLIDWORKS Electrical Schematic a SOLIDWORKS Electrical 3D na klientské systémy a veškeré serverové součásti na systém serveru.

Nadřazené téma
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Související pojmy
Nastavení umístění dat
Konfigurace serveru pro spolupráci
Konfigurace Microsoft SQL Serveru


Nastavení umístění dat

Vyberte adresář, kam se budou ukládat programová data, například díly, šablony nebo 2D či 3D symboly. Mělo by se jednat o vyhrazený adresář. Nesmí to být kořenový adresář ani stejný adresář, který se používá pro ukládání dat aplikace SOLIDWORKS.

Výchozí adresář je C:\ProgramData\SOLIDWORKS Electrical. Do tohoto adresáře je přidána složka Update, kam jsou ukládána všechna dostupná programová data.

Když aplikaci SOLIDWORKS Electrical spustíte poprvé, zobrazí se průvodce Aktualizace dat. V tomto průvodci si můžete nastavit, která data budou přidána do aplikace a do databáze serveru SQL.
Nadřazené téma
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Související pojmy
Individuální instalace a instalace na server
Konfigurace serveru pro spolupráci
Konfigurace Microsoft SQL Serveru


Konfigurace serveru pro spolupráci

Aby mohla aplikace SOLIDWORKS Electrical fungovat, je třeba nainstalovat server pro spolupráci na stejný systém, kde je hostována databáze Microsoft SQL Serveru.

Server pro spolupráci musí být stále aktivní a musí mít trvale k dispozici nepřerušovanou obousměrnou komunikaci s klienty skrz bránu firewall a antivirové systémy.

Při instalaci serveru pro spolupráci v individuálním režimu nebo v režimu serveru je třeba nastavit tyto parametry:
  • Název počítače, například LOCALHOST
  • Adresu IP počítače, například 127.0.0.1
  • Číslo portu, například 26666

Aby byla k dispozici nepřerušovaná obousměrná komunikace, je třeba zajistit, aby byl port číslo 26666 dostupný v systému, kde je server pro spolupráci nainstalován. Jestliže port 26666 není dostupný, najděte ve spolupráci se správcem systému jiný port, který by aplikace SOLIDWORKS Electrical mohla použít.

Nadřazené téma
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Související pojmy
Individuální instalace a instalace na server
Nastavení umístění dat
Konfigurace Microsoft SQL Serveru


Konfigurace Microsoft SQL Serveru

Je nutné zajistit, aby pro každý typ instalace aplikace SOLIDWORKS Electrical byla k dispozici instance databáze SQL Serveru. Můžete použít stávající databázi SQL Serveru, je-li již v systému nainstalována, nebo nainstalovat novou instanci v rámci instalace aplikace SOLIDWORKS Electrical.

Pokud se rozhodnete pro novou instanci SQL Serveru, instalace aplikace SOLIDWORKS nabízí bezplatnou verzi Microsoft SQL Serveru Express. Tato verze je omezena na 1 procesor, 1 GB paměti a 10 GB dat. Při takovém omezení paměti a procesoru může současně pracovat maximálně 5 uživatelů.

Pokud instalujete SQL Server Express Edition, dbejte na to, aby software i hardware serveru splňoval požadavky uvedené na webové adrese http://solidworks.com/System_Requirements.

Pokud však jeden server používá současně více než 6 uživatelů, je třeba zakoupit a nainstalovat plnou verzi SQL Serveru a postupovat podle pokynů pro instalaci aplikace SOLIDWORKS Electrical se stávající instancí SQL Serveru.

Bližší informace o produktu SQL Server Express Edition naleznete v dokumentaci pro Microsoft SQL Server.

Nadřazené téma
Požadavky na instalaci aplikace SOLIDWORKS Electrical
Související pojmy
Individuální instalace a instalace na server
Nastavení umístění dat
Konfigurace serveru pro spolupráci

Nové instance serveru SQL

Chcete-li nainstalovat novou instanci serveru SQL, musíte mít úplná přístupová práva správce k serveru i ke všem klientským systémům. Musíte také zajistit, aby klienti měli k databázi přístupová oprávnění pro čtení i zápis, aby mohli vytvářet a upravovat projekty, knihovny, symboly a další data projektů.

Když instalujete novou instanci serveru SQL, vyberte pro ni jiný název než výchozí.

Stávající instance serveru SQL

Chcete-li nainstalovat novou databázi aplikace SOLIDWORKS Electrical nebo se připojit k instalaci SOLIDWORKS Electrical na stávající instanci SQL Serveru, musíte mít uživatelský účet s úplným přístupovým oprávněním správce k danému SQL Serveru.

Aby aplikace SOLIDWORKS Electrical fungovala správně, je třeba nastavit SQL Server na smíšený režim ověření. Smíšený režim ověření umožňuje používání ověřovacích údajů Windows nebo serveru SQL.

Pro připojení ke stávající databázi serveru SQL můžete použít ověření Windows nebo serveru SQL. Zadejte uživatelské jméno a heslo účtu Windows nebo serveru SQL, který má úplná přístupová práva správce k serveru SQL.

Chcete-li se připojit k serveru SQL z důvodu instalace, nelze použít uživatele „tew“. Přihlašovací údaje s dostatečným oprávněním pro přístup k serveru SQL získáte u svého správce serveru SQL nebo u správce systému.

Po instalaci serveru SQL

Po instalaci aplikace SOLIDWORKS Electrical vytvoří instance SQL Serveru v aplikaci SOLIDWORKS Electrical následující databáze:
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


Administrace licencí

Po instalaci můžete aktivovat licence SOLIDWORKS buď aktivací individuálních počítačů (aktivace licence) nebo instalací a aktivací plovoucích síťových licencí na serveru (Licence SolidNetWork).

Zpravidla instalace na individuálních počítačích používají aktivaci licence, ale je také možné nainstalovat program samostatně a poté spravovat licence pomocí manažera licencí SolidNetWork. V opačném případě můžete zavést instalace z administrativní kopie a poté aktivovat sériová čísla na jednotlivých počítačích, i když na velkých pracovištích zpravidla používají plovoucí síťové licence.

Pokud používáte Windows 8, viz Tipy pro používání SOLIDWORKS s Microsoft Windows 8 pro úlohy, jako je přístup k Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti najdete v dokumentaci k systému Microsoft Windows.

Obsah

  • Správa jednotlivých součástí

    Správa individuálních licencí se obvykle skládá z aktivace a převodu licencí přímo ze SOLIDWORKS.

  • Správa licencí za použití manažera licencí SolidNetWork

    Manažer licencí SolidNetWork podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.


Správa jednotlivých součástí

Správa individuálních licencí se obvykle skládá z aktivace a převodu licencí přímo ze SOLIDWORKS.

Aktivace je licencování produktu a registrační proces pro licence samostatného softwaru SOLIDWORKS (ne pro síťové licence SolidNetWork). Pokud jste ještě neaktivovali licenci pro tento počítač, SOLIDWORKS se obvykle pokouší ji aktivovat, když spustíte SOLIDWORKS.

Můžete také převést individuální licence klepnutím na Nápověda > Převod licencí v SOLIDWORKS.

Nadřazené téma
Administrace licencí
Související pojmy
Správa licencí za použití manažera licencí SolidNetWork

Aktivace licence

Abyste mohli spustit produkty SOLIDWORKS na konkrétním počítači, musíte pro tento počítač aktivovat licenci.

K aktivaci je potřeba připojení k internetu nebo přístup k emailové službě. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje všechny programové licence pro celou řadu SOLIDWORKS produktů.
  • Vám umožní převést licenční práva z jednoho počítače na druhý.
  • Můžete provést ihned (doporučujeme) nebo nejpozději do 30 dnů po instalaci.
  • Vyloučí potřebu používat hardwarové klíče. Pokud však stále používáte starší verze produktů SOLIDWORKS, které nepoužívají aktivaci, musíte si ponechat hardwarový klíč.

Správci systému, kteří spravují několik sériových čísel, mohou najít užitečné informace na odkazu Editor možností administrativní kopie. Podrobné informace naleznete v Editoru možností administrativní kopie.

Návod na aktivaci licence:

  1. Spusťte program SOLIDWORKS.
  2. Spusťte Aktivaci produktu SOLIDWORKS za použití jedné z těchto metod:
    • Pokud jste ještě neaktivovali licenci pro tento počítač, objeví se při spuštění SOLIDWORKS automaticky okno Aktivace produktu SOLIDWORKS.
    • Pokud se okno Aktivace produktu SOLIDWORKS neobjeví automaticky, spusťte aktivaci klepnutím na Nápověda > Aktivovat licence.
  3. Klepněte na seznam Produkta určete produkt, jehož licenci chcete aktivovat.
  4. Určete automatickou aktivaci přes internet nebo ruční aktivaci za použití e-mailu.
  5. Zadejte kontaktní e-mailovou informaci.
  6. Klepněte na Další pro pokračování.
    • Internet: K aktivaci dojde automaticky.:
    • Email: Tlačítkem Uložit vytvořte soubor s požadavkem a odešlete jej na adresu activation@solidworks.com. Když obdržíte e-mail se souborem s odpovědí, soubor z e-mailu klepnutím na Otevřít načtěte.
      Pokud je to nutné, můžete tento krok ukončit a novu spustit aktivační postup pro otevření souboru s odpovědí.
  7. Klepněte na Dokončit.
Související odkazy
Editor možností administrativní kopie

Převedení licence

Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SOLIDWORKS Corporation a poté ho znovu aktivovat na jiném počítači.

Pokud se vám nepodaří převést licenci zpět na SOLIDWORKS (například v důsledku selhání disku), je ve většině případů reaktivace i tak úspěšná. Pokud ne, kontaktujte vašeho místního prodejce.

Návod na převod licence zpět na server:

  1. V SOLIDWORKS klepněte na Nápověda > Převedení licence a postupujte podle pokynů.
  2. Reaktivaci proveďte na novém nebo upgradovaném počítači a aktivujte licenci jako v počáteční aktivaci. Podrobnosti naleznete v části Aktivace licence.


Správa licencí za použití manažera licencí SolidNetWork

Manažer licencí SolidNetWork podporuje násobné licenční klienty pomocí distribuce licencí klientům na síti. To umožňuje počtu uživatelů rozšířit počet licencí použitím plovoucích licencí.

Tento obrázek znázorňuje typickou instalaci správy licencí SolidNetWork

Tento obrázek ilustruje:
  • Manažer licencí SolidNetWork je instalován a aktivován pouze na počítači manažera licencí.
  • Počítače licenční klientů nemají nainstalován žádný dodatečný program patřící SolidNetWork.

    Pokud určujete při instalaci sériové číslo licence SolidNetWork, Manažer instalací SOLIDWORKS identifikuje počítač jako klienta s licencí SolidNetWork. Manažer instalací SOLIDWORKS vás vyzve, abyste zadali název počítače a číslo portu manažera licencí SolidNetWork pro spojení klienta s manažerem licencí.

  • Manažer licencí a všichni klienti s licencí musí mít spojení TCP/IP (Transmission Control Protocol/Internet Protocol).

Obsah

  • Aktivace licence SolidNetWork

    Abyste mohli na jednotlivých počítačích spustit produkty SOLIDWORKS, musíte v počítači manažera licencí SolidNetWork aktivovat licenci SolidNetWork.

  • Převedení licence SolidNetWork

    Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SOLIDWORKS Corporation a poté ho znovu aktivovat na jiném počítači.

  • Instalace a konfigurace licencí SolidNetWork

    Konfigurace licencí SolidNetWork se skládá z instalace manažera licencí SolidNetWork na počítači manažera licencí a následné instalace SOLIDWORKS na klientských počítačích pomocí sériového čísla SolidNetWork.

  • Správa licencí SolidNetWork

    Mezi úkoly patří spuštění, upgrade a odinstalování manažera licencí a načítání, půjčování a vrácení licencí.

Nadřazené téma
Administrace licencí
Související pojmy
Správa jednotlivých součástí


Aktivace licence SolidNetWork

Abyste mohli na jednotlivých počítačích spustit produkty SOLIDWORKS, musíte v počítači manažera licencí SolidNetWork aktivovat licenci SolidNetWork.

K aktivaci je potřeba připojení k internetu nebo přístup k emailové službě. Po aktivaci již nemusíte být připojení k internetu při používání produktů. Pokud na počítači, na kterém instalujete tento produkt, nemáte přístup k emailové službě, můžete aktivační soubor uložit a odeslat ho z jiného počítače.

Tento proces:
  • Aktivuje Manažera licencí SolidNetWork pomocí licencí SolidNetWork pro jednotlivé produkty SOLIDWORKS.
  • Umožní vám převést licenční práva SolidNetWork z jednoho počítače manažera licencí SolidNetWork na druhý.
  • Umožní vám instalovat a aktivovat licenční práva SolidNetWork na počítači Manažera licencí SolidNetWork.
  • Musí být provedena než začnete používat licence SolidNetWork.
  • Vyloučí potřebu používat hardwarové klíče. Pokud aktivujete licenci SolidNetWork pro tuto verzi SOLIDWORKS, licence SolidNetWork pro dřívější verze SOLIDWORKS jsou aktivovány. (Už si nemusíte nechávat hardwarový klíč.)

Návod na aktivaci licence SolidNetWork:

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS verze > Manažer licencí SolidNetWork > Manažer licencí SolidWorks SolidNetWork).
  2. Pokud jste ještě neaktivovali licenci SolidNetWork, zobrazí se dotaz, zda ji chcete aktivovat nyní. Aktivujte klepnutím na Ano.
  3. Pod Jakým způsobem chcete provést převedení?, zvolte Automaticky přes Internet (doporučeno).
  4. Pod Kontaktní informace zadejte e-mailovou kontaktní adresu.
V dialogu Aktivace/Reaktivace byla úspěšná se zobrazí produkty, které byly aktivovány.
Nadřazené téma
Správa licencí za použití manažera licencí SolidNetWork
Související pojmy
Instalace a konfigurace licencí SolidNetWork
Správa licencí SolidNetWork
Související úlohy
Převedení licence SolidNetWork


Převedení licence SolidNetWork

Při převádění licence na jiný počítač musíte nejprve převést licenční klíč zpět na server společnosti SOLIDWORKS Corporation a poté ho znovu aktivovat na jiném počítači.

Pokud se vám nepodaří převést licenci zpět na SOLIDWORKS (například v důsledku selhání disku), je ve většině případů reaktivace i tak úspěšná. Pokud ne, kontaktujte vašeho místního prodejce.

Návod na převod licence SolidNetWork zpět na server:

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS SolidWorks > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).

  2. Pod položkou Informace o licenci klepněte na Upravit. Spustí se průvodce Aktivace produktu SOLIDWORKS.
  3. Pod možností Co chcete udělat? zvolte Převést licenci softwaru a pak klepněte na Další.
  4. Pod Jakým způsobem chcete provést převedení?, zvolte Automaticky přes Internet (doporučeno).
  5. Pod Kontaktní informace zadejte e-mailovou kontaktní adresu.
  6. Klepněte na Další. Převedení licence produktu se dokončuje.
Nadřazené téma
Správa licencí za použití manažera licencí SolidNetWork
Související pojmy
Instalace a konfigurace licencí SolidNetWork
Správa licencí SolidNetWork
Související úlohy
Aktivace licence SolidNetWork


Instalace a konfigurace licencí SolidNetWork

Konfigurace licencí SolidNetWork se skládá z instalace manažera licencí SolidNetWork na počítači manažera licencí a následné instalace SOLIDWORKS na klientských počítačích pomocí sériového čísla SolidNetWork.

Obsah

  • Instalace a aktivace licenčního klienta

    Manažer licencí SolidNetWork podporuje několik klientů licence. Tento server distribuuje licence klientům na síti.

  • Instalace licenčního klienta

    Pokud instalujete SOLIDWORKS do počítačů licenčních klientů SolidNetWork, sériové číslo identifikuje počítač jako klienta s licencí SolidNetWork.

  • Instalace manažerů licencí SolidNetWork před instalací licenčních klientů

    Manažera licencí SolidNetWork byste měli instalovat a konfigurovat nejpozději jeden počítači před instalací jakékoliv licence SolidNetWork na počítače s klientskou licencí.

  • Správa přístupu k různým verzím SOLIDWORKS

    Máte možnost zabránit uživatelům v přístupu k určitým verzím SOLIDWORKS v prostředí SolidNetWork. Tato funkce umožňuje spravovat verze SOLIDWORKS používané různými osobami, projekty a organizačními jednotkami.

  • Instalace Manažera licencí triády

    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.

  • Použití licencí SolidNetWork s firewall

    Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:

Nadřazené téma
Správa licencí za použití manažera licencí SolidNetWork
Související pojmy
Správa licencí SolidNetWork
Související úlohy
Aktivace licence SolidNetWork
Převedení licence SolidNetWork


Instalace a aktivace licenčního klienta

Manažer licencí SolidNetWork podporuje několik klientů licence. Tento server distribuuje licence klientům na síti.

Pokud upgradujete z předchozí verze Manažera licencí SolidNetWork, která používala hardwarové klíče pro aktivaci licence, odstraňte je před instalací nové verze Manažera licencí SolidNetWork.

  1. Spusťte aplikaci Manažer instalací SOLIDWORKS (jak je to popsáno v části Zahájení instalace SolidWorks ).
    1. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Instalovat Manažer licencí SolidNetWork (distribuované licencování) na tento počítač.

    2. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    3. Na stránce Souhrnné informace dokončete proces Manažera instalace SOLIDWORKS klepnutím na Nainstalovat.
  2. Návod na aktivaci licencování SolidNetWork:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
    2. Budete-li vyzváni k aktivaci, klepněte na Ano.
    3. Na obrazovce Informace o licenčním serveru SolidNetWork :

      • Pokud vaše společnost používá bránu firewall, vyberte Na tomto serveru se používá brána firewall..

        Další informace najdete v části Použití licencí SolidNetWork s firewall.

      • Použijte výchozí hodnoty pro Číslo portu (a Číslo portu dodavatele Demon, pokud máte bránu firewall), nebo zadejte čísla portu používané vaší společností.
        Číslo portu je číslo portu TCP/IP v rozmezí 1024-60000 a je používáno pouze tímto procesem. Výchozí hodnota (25734) je většinou vhodná a pravděpodobně odlišná od jiných procesů serveru FLEXnet na řídícím počítači licenčního serveru.

    4. Na obrazovce Aktivovat/převést váš produkt SOLIDWORKS:

      • Zvolte aktivaci na internetu, nebo emailem.
      • Zadejte kontaktní e-mailovou informaci.
      • Klepněte na Další pro pokračování.
        • Internet: K aktivaci dojde automaticky.
        • Email: Stiskněte Uložit pro vytvoření požadovaného souboru, pak pošlete soubor na adresu activation@solidworks.com. Jakmile obdržíte e-mail se souborem odpovědi, rozbalte soubor z e-mailu a klepnutím na Otevřít jej načtěte.
          Pokud je to nutné, můžete tento krok ukončit a novu spustit aktivační postup pro otevření souboru s odpovědí.

  3. Klepněte na Dokončit.
Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
Instalace Manažera licencí triády
Použití licencí SolidNetWork s firewall
Související úlohy
Instalace licenčního klienta
Správa přístupu k různým verzím SOLIDWORKS
Zahájení instalace SOLIDWORKS


Instalace licenčního klienta

Pokud instalujete SOLIDWORKS do počítačů licenčních klientů SolidNetWork, sériové číslo identifikuje počítač jako klienta s licencí SolidNetWork.

  1. Spusťte aplikaci Manažer instalací SOLIDWORKS (jak je to popsáno v části Zahájení instalace SolidWorks ).
  2. Na uvítací obrazovce klepněte na Individuální instalace (na tomto počítači.), pokud je to první instalace SOLIDWORKS na tomto počítači pro tuto významnou verzi.

    Pokud provádíte upgrade z existující verze a přecházíte z individuální licence na licenci SolidNetWork, klepněte na Změnit individuální instalaci (na tomto počítači).. Podrobnosti najdete v částiProvedení upgrade z individuální licence na licenci SolidNetWork.

  3. Po výzvě zadejte sériové číslo licence SolidNetWork.
  4. V dialogovém okně Přidat server zadejte adresu licenčního serveru v tomto tvaru:

    port@NázevPočítače

    Číslo portu se musí shodovat s číslem použitým pro počítač s Manažerem licencí. Výchozí nastavení je 25734 (jak je to popsáno v části Instalace a aktivace licenčního klienta).

    Manažer instalace SOLIDWORKS se pokusí ověřit, jestli je Manažer licencí SolidNetWork dostupný. Pokud jste ještě neinstalovali Manažera licencí, tato validace se nepodaří; ovšem můžete dále instalovat klienta s licencí.

  5. Dokončete instalaci SOLIDWORKS podle následujících pokynů Manažera instalace SOLIDWORKS.
Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
Instalace Manažera licencí triády
Použití licencí SolidNetWork s firewall
Provedení upgrade z individuální licence na licenci SolidNetWork
Související úlohy
Instalace a aktivace licenčního klienta
Správa přístupu k různým verzím SOLIDWORKS
Zahájení instalace SOLIDWORKS


Instalace manažerů licencí SolidNetWork před instalací licenčních klientů

Manažera licencí SolidNetWork byste měli instalovat a konfigurovat nejpozději jeden počítači před instalací jakékoliv licence SolidNetWork na počítače s klientskou licencí.

Pokud instalujete pomocí sériového čísla SolidNetWork, Manažer instalací SOLIDWORKS vás vyzve k zadání názvu počítače a čísla portu manažera licencí SolidNetWork a pak se pokusí ověřit tyto informace.

Pokud jste ještě neinstalovali Manažera licencí SolidWorks na určeném počítači, toto ověření nemůže být úspěšné. V tomto případě ale selhání ověření nesděluje, zda jste zadali správné informace manažera licencí. V tomto případě ale selhání ověření nesděluje, zda jste zadali správné informace manažera licencí.

Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace Manažera licencí triády
Použití licencí SolidNetWork s firewall
Související úlohy
Instalace a aktivace licenčního klienta
Instalace licenčního klienta
Správa přístupu k různým verzím SOLIDWORKS


Správa přístupu k různým verzím SOLIDWORKS

Máte možnost zabránit uživatelům v přístupu k určitým verzím SOLIDWORKS v prostředí SolidNetWork. Tato funkce umožňuje spravovat verze SOLIDWORKS používané různými osobami, projekty a organizačními jednotkami.

Správa přístupu k verzím SOLIDWORKS pomocí souboru možností FLEXnet se provádí takto:

  1. V manažeru licencí SolidNetwork vytvořte textový soubor:

    instalační_složka_SolidNetWork_License_Manageru\Licenses\sw_d.opt

  2. Chcete-li spravovat přístup k určité verzi softwaru SOLIDWORKS v licenčním souboru, přidejte za výraz SOLIDWORKS následující syntax:

    :SWVERSION=xx kde xx je verze produktu SOLIDWORKS, kterou chcete spravovat.

  3. Chcete-li spravovat více verzí softwaru SOLIDWORKS, přidejte řádek pro každou verzi.

    Nejsou podporovány všechny možnosti FLEXnet. Podporované možnosti filtrů verzí jsou následující:

    INCLUDE | Danou verzi může spouštět pouze tento uživatel nebo skupina. Ostatní uživatelé nebudou moci tuto verzi spustit.
    INCLUDE_BORROW | Danou verzi si může vypůjčit pouze tento uživatel nebo skupina. Ostatní uživatelé si nebudou moci tuto verzi vypůjčit.
    EXCLUDE | Zakáže uvedenému uživateli nebo skupině spustit danou verzi SOLIDWORKS. Výraz EXCLUDE má přednost před výrazem INCLUDE.
    EXCLUDE_BORROW | Zakáže uvedenému uživateli nebo skupině vypůjčit si danou verzi SOLIDWORKS. Výraz EXCLUDE má přednost před výrazem INCLUDE.
    Příklady:
    1 | SWVERSION=24.0 znamená SOLIDWORKS 2016
    SWVERSION=23.0 znamená SOLIDWORKS 2015
    2 | INCLUDE solidworks:SWVERSION=24.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=24.0 USER jane
    Tyto řádky v souboru možností povolují spuštění softwaru SOLIDWORKS 2016 pouze uživateli jane. Ostatní uživatelé nemohou software SOLIDWORKS spustit ani si jej vypůjčit; mohou ale spouštět a vypůjčovat si ostatní verze SOLIDWORKS. Uživatel jane dále může spouštět a vypůjčovat si i ostatní verze SOLIDWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=24.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=23.0 GROUP chicago
    EXCLUDE solidworks USER don
    Na těchto řádcích je definována skupina (GROUP) uživatelů s názvem chicago, kteří nemají přístup k verzím SOLIDWORKS 2015 a SOLIDWORKS 2016; mohou ale spustit libovolnou jinou verzi softwaru. Uživatel don nemůže spustit žádnou verzi softwaru SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=24.0 HOST machine1
    Tento řádek zakazuje přístup z počítače machine1 ke spuštění softwaru SOLIDWORKS Inspection 2016. Kterýkoli uživatel na počítači machine1 ale může spustit jinou verzi SOLIDWORKS Inspection 2015.

    Více informací o softwaru FLEXnet najdete v Průvodci správou licencí k softwaru FLEXnet Publisher v instalačním adresáři Manažera licencí SolidNetwork (\Docs\flexuser\licensingenduserguide.pdf).

Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
Instalace Manažera licencí triády
Použití licencí SolidNetWork s firewall
Související úlohy
Instalace a aktivace licenčního klienta
Instalace licenčního klienta


Instalace Manažera licencí triády

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Pokud není počítač, který spravuje licenční soubor, dostupný převezme jeho operace jeden ze dvou dalších počítačů.

Požadavky pro použití manažera licencí triády:
  • Jsou vyžadovány tři hardwarové klíče.
  • Nainstalujte triády na stabilní počítače, které nevyžadují časté restartování.
  • Všechny tři počítače manažera licencí by měly být na stejné dílčí síti. Nikdy nekonfigurujte triády prostřednictvím pomalého nebo telefonického připojení.
  • Správce systému by měl zjistit, když počítač manažera licencí selže a měl by jej okamžitě restartovat.
    Pokud jsou spuštěny dva počítače manažera licencí, situace je horší než pokud je spuštěn jeden server, protože může dojít k selhání na dvou místech.

Obsah

  • Instalace prvního manažera licencí triády

    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na prvním počítači triády.

  • Instalaci manažera licencí triád na následných počítačích

    Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na druhém a třetím počítači triády.

Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
Použití licencí SolidNetWork s firewall
Související úlohy
Instalace a aktivace licenčního klienta
Instalace licenčního klienta
Správa přístupu k různým verzím SOLIDWORKS


Instalace prvního manažera licencí triády

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na prvním počítači triády.

  1. Nainstalujte manažera licencí SolidNetWork na prvním počítači manažera licencí triády za použití manažera instalací SOLIDWORKS.
    1. Spusťte aplikaci Manažer instalací SOLIDWORKS (jak je to popsáno v části Zahájení instalace SolidWorks ).
    2. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Instalovat Manažer licencí SolidNetWork (distribuované licencování) na tento počítač.

    3. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    4. Na stránce Souhrnné informace dokončete proces Manažera instalace SOLIDWORKS klepnutím na Nainstalovat.
  2. Za použití Manažera licencí SolidNetWork nakonfigurujte první počítač manažera licencí triády:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
    2. Klepněte na Ne.

      Objeví se záložka Správa serveru programu SOLIDWORKS Manažera licencí SolidNetWork.

    3. V nabídce Upřesňující možnosti vyberte Možnosti.

      Zobrazí se dialogové okno Upřesňující možnosti.

    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

      Dialogové okno Upřesňující možnosti se zavře.

    5. Pod možností Informace o licenci klepněte na Upravit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    6. Pod položkou Typ serveru vyberte Triáda a klepněte na Další.
    7. Na stránce s informacemi o serveru zkontrolujte, jestli je Název počítače, ID hardwarového klíče a číslo portu pro tento počítač manažera licencí triády správný a klepněte na Další.

      Pokud server používá namísto hardwarového klíče adresu síťové karty, zkontrolujte, že adresa síťové karty odpovídá údajům v licenčním souboru přijatém ze SOLIDWORKS a že číslo portu počítače manažera licencí triády je správné. Adrese síťové karty se také říká adresa MAC (Media Access Control). Pote klepněte na Další.

      Adresu síťové karty zjistíte tak, že otevřete příkazový řádek a zadáte:

      ipconfig /all

      Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace najdete v části Použití licencí SolidNetWork s firewall.

    8. Na obrazovce Informace o serveru partnerské triády zadejte název počítače a ID hardwarového klíče pro druhé dva počítače manažera licencí triády. Pokud počítače používají adresy síťové karty, zadejte název počítače a hodnoty ID hostitele.

      Tímto je zajištěno, že pokud není jeden server k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.

    9. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.

      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork.

    10. Klepněte na Dokončit.
    11. Klepnutím na OK ukončíte průvodce Licenčním souborem SolidNetWork a pak klepnutím na Ukončitopustíte Manažer licencí SolidNetWork.
Nadřazené téma
Instalace Manažera licencí triády
Související pojmy
Použití licencí SolidNetWork s firewall
Související úlohy
Instalaci manažera licencí triád na následných počítačích
Zahájení instalace SOLIDWORKS


Instalaci manažera licencí triád na následných počítačích

Manažer licencí triády používá tři počítače pro zajištění dodatečné stability. Tento postup představuje, jak instalovat manažera licencí SolidNetWork na druhém a třetím počítači triády.

Předpokladem je, že jste již instalovali alespoň jednoho manažera licencí triády na jiném počítači.

  1. Nainstalujte manažera licencí SolidNetWork na počítači manažera licencí triády za použití manažera instalací SOLIDWORKS.
    1. Spusťte Manažera instalací SOLIDWORKS (jak je to popsáno v Zahájení instalace SOLIDWORKS).
    2. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Instalovat Manažer licencí SolidNetWork (distribuované licencování) na tento počítač.

    3. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    4. Na stránce Souhrnné informace dokončete proces Manažera instalace SOLIDWORKS klepnutím na Nainstalovat.
  2. Za použití Manažera licencí SolidNetWork nakonfigurujte počítač manažera licencí triády:
    1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).

      Protože je to poprvé, kdy spouštíte manažera licencí SolidNetWork na tomto počítači, zeptá se vás, jestli ho chcete nyní aktivovat.

    2. Klepněte na Ne.

      Objeví se záložka Správa serveru programu SOLIDWORKS Manažera licencí SolidNetWork.

    3. V nabídce Upřesňující možnosti vyberte Možnosti.

      Zobrazí se dialogové okno Upřesňující možnosti.

    4. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

      Dialogové okno Upřesňující možnosti se zavře.

    5. Pod možností Informace o licenci klepněte na Upravit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    6. Pod položkou Typ serveru vyberte Triáda a Synchronizujte serverové/licenční informacea pak klepněte na Další.
    7. Na stránce s informacemi o serveru zkontrolujte, jestli je Název počítače, ID hardwarového klíče a číslo portu pro tento počítač manažera licencí triády správný a klepněte na Další.

      Pokud server používá namísto hardwarového klíče adresu síťové karty, zkontrolujte, že adresa síťové karty odpovídá údajům v licenčním souboru přijatém ze SOLIDWORKS a že číslo portu počítače manažera licencí triády je správné. Adrese síťové karty se také říká adresa MAC (Media Access Control). Pote klepněte na Další.

      Adresu síťové karty zjistíte tak, že otevřete příkazový řádek a zadáte:

      ipconfig /all

      Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.

    8. Pokud počítače používají hardwarové klíče, na obrazovce Informace o serveru partnerské triády zadejte název počítače a ID hardwarového klíče pro druhé dva počítače manažera licencí triády. Pokud počítače používají adresy síťové karty, zadejte název počítače a hodnoty ID hostitele.

      Tímto je zajištěno, že pokud není jeden server k dispozici, klient může získat licenci z jednoho ze dvou dalších serverů.

    9. Na obrazovce Licence klepněte na Číst pro vyhledání a otevření licenčního souboru SolidNetWork.

      Licenční soubor je obvykle umístěn na \licenses\sw_d.lic na prvním počítači manažera licencí triády, který konfigurujete.

      Licence se zobrazí v průvodci Licenčním souborem SolidNetWork.

    10. Klepněte na Dokončit.

      Objeví se průvodce licenčním souborem SolidNetWork.

    11. Klepnutím na OK ukončíte průvodce Licenčním souborem SolidNetWork a pak klepnutím na Ukončitopustíte Manažer licencí SolidNetWork.

Pokud nakonfigurujete druhý počítač manažera licencí triády, opakujte tento postup i pro třetí počítač manažera licencí triády.

Nadřazené téma
Instalace Manažera licencí triády
Související úlohy
Instalace prvního manažera licencí triády


Použití licencí SolidNetWork s firewall

Pokud je na vašem počítači nainstalována bezpečnostní brána firewall, musíte konfigurovat porty správy licencí SolidNetWork následovně:

V software firewall musíte přidat dva porty licencí SolidNetWork (například SNL-in-port a SNL-out-port) do seznamu výjimek firewall. O bližší informace o konfiguraci těchto portů požádejte správce vaší sítě.

Pokud používáte bránu firewall podporovaného systému Windows, musíte změnit porty na počítači s Manažerem licencí SolidNetWork a upravit licenční soubor SolidNetWork pro distribuci licencí na klientské počítače licence.

Obsah

  • Úprava portů počítače Manažera licencí pro Windows Firewall

    Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na počítači manažera licencí SolidNetWork.

  • Úprava Manažera licencí SolidNetWork pro Windows Firewall

    Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na licenčním serveru a změnit licenční soubor SolidNetWork tak, aby distribuoval licence na počítače klientů.

Nadřazené téma
Instalace a konfigurace licencí SolidNetWork
Související pojmy
Instalace manažerů licencí SolidNetWork před instalací licenčních klientů
Instalace Manažera licencí triády
Související úlohy
Instalace a aktivace licenčního klienta
Instalace licenčního klienta
Správa přístupu k různým verzím SOLIDWORKS


Úprava portů počítače Manažera licencí pro Windows Firewall

Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na počítači manažera licencí SolidNetWork.

  1. Ve Windows otevřete Ovládací panely a poklepejte na Centrum zabezpečení.
  2. Klepněte na Brána firewall systému Windows.
  3. Na záložce Výjimky klepněte na Přidat port.
  4. Zadejte v dialogu Název (například, SNL-in-port) a Číslo portu (například, 25734) a pak klepněte na OK.
  5. Pro druhý port klepněte na Přidat port na záložce Výjimky zadejte název a číslo jiného portu (například, SNL-out-port a 25735), a pak klepněte na OK. Poznamenejte si číslo portu, protože je budete potřebovat později, když budete měnit licenční soubor SolidNetWork.

    Pokud používáte program PDM Workgroup, musíte změnit čísla portů PDMWorkgroup ve Windows Firewall. Tyto porty jsou většinou 20000 (Správa úschovny VaultAdmin), 30000 (Data), a 40000 (Request (Požadavek)).

  6. Uzavřete Centrum zabezpečení a Ovládací panely.
Nadřazené téma
Použití licencí SolidNetWork s firewall
Související úlohy
Úprava Manažera licencí SolidNetWork pro Windows Firewall


Úprava Manažera licencí SolidNetWork pro Windows Firewall

Pokud používáte bezpečnostní bránu Windows Firewall, musíte změnit porty na licenčním serveru a změnit licenční soubor SolidNetWork tak, aby distribuoval licence na počítače klientů.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit. (Klepněte na Ano, když jste vyzváni k potvrzení a na OK pro zastavení licenčního serveru.)
  3. Pod možností Informace o licenci klepněte na Upravit.
  4. Pod Typem serveru zvolte uspořádání serveru pro vaši síť (Samostatný nebo Triáda) a pak klepněte na Další.
  5. Pod Informace o serveru:
    1. Vyberte možnost Na tomto serveru se používá brána firewall
    2. Číslo portu a číslo portu dodavatele démona by měl obsahovat čísla portů určená pro bránu firewall systému Windows (podrobnosti viz Úprava portů počítače Manažera licencí pro Windows Firewall).
    3. Vyberte Soubor možností, klepněte na tlačítko Procházet a vyhledejte požadovaný soubor. Klepněte na Upravit a podle potřeby změňte jeho parametry.

      Soubor možností dovoluje správci licencí kontrolovat různé provozní parametry licencování softwaru FLEXnet.

      Doporučené umístění pro soubor možností je instalační adresář Manažera licencí SolidNetwork (instalační_adresář_SolidNetwork_License_Manager\Licenses \sw_d.opt). Tento soubor je třeba uložit do stejného adresáře jako soubor sw_d.lic.

      Více informací o souboru možností najdete v Průvodci správou licencí k softwaru FLEXnet Publisher v instalačním adresáři Manažera licencí SolidNetwork (\Docs\flexuser\licensingenduserguide.pdf).

    4. Klepněte na Další a potom klepněte na Dokončit.
  6. Na záložce Správa serveru v poli Licenční server klepněte na Spustit.
  7. Klepnutím na OK ukončíte Manažera licencí SolidNetWork .
Nadřazené téma
Použití licencí SolidNetWork s firewall
Související úlohy
Úprava portů počítače Manažera licencí pro Windows Firewall


Správa licencí SolidNetWork

Mezi úkoly patří spuštění, upgrade a odinstalování manažera licencí a načítání, půjčování a vrácení licencí.

Než spustíte nebo provedete upgrade manažera licencí, musíte vrátit veškeré zapůjčené licence.

Obsah

  • Spuštění Manažera licencí SolidNetWork

    Můžete spustit Manažera licencí SolidNetWork z nabídky Windows Start.

  • Upgrade Manažera licence SolidNetWork

    V případě významných verzí programu SOLIDWORKS se upgrade manažera licencí skládá z odinstalování starého manažera licencí a instalace nového a z nové aktivace licence SolidNetWork.

  • Odstranění licenčních souborů SolidNetWork

    Před provedením upgrade na nové soubory, odstraňte staré a neplatné licenční soubory SolidNetWork.

  • Zapůjčení a navrácení licencí SolidNetWork

    Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

  • Monitorování doby nečinnosti licence

    SOLIDWORKS může registrovat dobu nečinnosti licence SolidNetWork na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.

  • Instalace dočasných licencí

    Dočasnou licenci "ANY" je možno použití dočasně, když není k dispozici originální licence SolidNetWork.

  • Provedení upgrade z individuální licence na licenci SolidNetWork

    Můžete provést upgrade počítače z individuální licence SOLIDWORKS na licenci SolidNetWork zadáním sériového čísla licence SolidNetWork v Manažeru licencí SOLIDWORKS.

  • Použití licencí SolidNetWork a doplňkových modulů

    Aplikaci SolidNetWork License Manager můžete použít k distribuci licencí pro doplňkové moduly jádra SOLIDWORKS (například FeatureWorks, Workgroup PDM Server).

  • Použití stejného počítače pro manažera licencí a instalace administrativní kopie

    Jeden počítač v síti můžete nakonfigurovat tak, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork, a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SOLIDWORKS.

  • Správa licencí FLEXnet Publisher

    Správa licencí SolidNetWork je založena na správě licencí FLEXnet Publisher®.

Nadřazené téma
Správa licencí za použití manažera licencí SolidNetWork
Související pojmy
Instalace a konfigurace licencí SolidNetWork
Související úlohy
Aktivace licence SolidNetWork
Převedení licence SolidNetWork


Spuštění Manažera licencí SolidNetWork

Můžete spustit Manažera licencí SolidNetWork z nabídky Windows Start.

  • Ve Windows spusťte tento příkaz: Start > Programy > SOLIDWORKS verze > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork.
Nadřazené téma
Správa licencí SolidNetWork


Upgrade Manažera licence SolidNetWork

V případě významných verzí programu SOLIDWORKS se upgrade manažera licencí skládá z odinstalování starého manažera licencí a instalace nového a z nové aktivace licence SolidNetWork.

Manažer licence pro novější verzi může distribuovat licence pro klientské počítače, které také zůstávají u předchozí verze.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Na záložce Použití licencí ověřte, že žádný klientský počítač v síti nemá spuštěný SOLIDWORKS.
  3. Návod na odinstalování starší licence manažera. Podrobné informace naleznete v části Odinstalování Manažera licencí SolidNetWork.
  4. Nainstalujte nového manažera licencí a znovu aktivujte licenci SolidNetWork na počítači manažera licencí. Podrobnosti najdete v Instalace a aktivace licenčního klienta.

Pokud provádíte upgrade Manažera licencí v počítači, ve kterém běží také aplikace SOLIDWORKS, proveďte upgrade manažera licencí a klientů SolidNetWork ještě předtím, než budete do tohoto počítače instalovat jakoukoliv novou aplikaci servisního balíčku SOLIDWORKS.

Pokud provádíte upgrade manažera licencí na počítači, na němž jsou umístěny administrativní kopie, proveďte upgrade manažera licencí než provedete upgrade administrativních kopií. Podrobnosti viz Použití stejného počítače pro manažera licencí a instalace administrativní kopie.

Obsah

  • Odinstalování Manažera licencí SolidNetWork

    Pokud provádíte upgrade manažera licencí SolidNetWork , musíte odinstalovat starého manažera licencí před instalací nového.

Nadřazené téma
Správa licencí SolidNetWork


Odinstalování Manažera licencí SolidNetWork

Pokud provádíte upgrade manažera licencí SolidNetWork , musíte odinstalovat starého manažera licencí před instalací nového.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Ověřte, zda žádný z klientských počítačů na síti nemá spuštěnou aplikaci SOLIDWORKS.

    Záložka Použití licencí zobrazuje klienty se systémem SOLIDWORKS.

  3. Chcete-li převést licenci SolidNetWork na jiný počítač, nejprve ji převeďte a pak teprve odstraňte manažera licencí SolidNetWork z původního počítače.

    Informace o přenosu licencí SolidNetWork naleznete v části Převedení licence SolidNetWork.

  4. Na záložce Správa serveru v poli Licenční server klepněte na Zastavit.
  5. Klepnutím na OK ukončíte Manažera licencí.
  6. Ve Windows otevřete Ovládací panely > Přidat nebo odebrat programy.
  7. Vyberte Správce licencí SOLIDWORKS SolidNetWork, klepněte na Odstranit a potvrďte odstranění.
  8. V Průzkumníku Windows odstraňte složku Manažer licencí SOLIDWORKS SolidNetWork.

    (Tato složka je obvykle umístěna pod Programy v instalačním adresáři SOLIDWORKS).

Nyní můžete instalovat novou verzi manažera licencí. Podrobné informace naleznete v části Instalace a aktivace licenčního klienta.

Pokud má počítač s Manažerem licencí SolidNetWork připojený hardwarový klíč, odstraňte jej před instalací nové verze Manažera licencí SolidNetWork.
Nadřazené téma
Upgrade Manažera licence SolidNetWork
Související úlohy
Převedení licence SolidNetWork
Instalace a aktivace licenčního klienta


Odstranění licenčních souborů SolidNetWork

Před provedením upgrade na nové soubory, odstraňte staré a neplatné licenční soubory SolidNetWork.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Na záložce Správa serveru v poli Licenční soubor klepněte na Upravit a poté na Další, až přejdete na obrazovku Licence.
  3. Na obrazovce Licence vyberte starý nebo neplatný licenční soubor SolidNetWork a klepněte na Odstranit.
  4. Klepněte na Dokončit a pak na OK.
Nadřazené téma
Správa licencí SolidNetWork


Zapůjčení a navrácení licencí SolidNetWork

Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění. Protože je licence je odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

Vypůjčené licence jsou platné pouze pro systém a počítač, ve kterém byly vypůjčeny. Vypůjčené licence nelze převádět.

Daná licence je zapůjčena na vymezené časové období až do 30 dnů (nebo na jiný počet dnů definovaný správcem systému) a odebrána z fondu dostupných licencí.

Správci systému mohou upravit půjčování za účelem:
  • Definovat uživatele nebo skupiny uživatelů, kteří si mohou půjčovat licence.
  • Nastavit počet licencí, které nelze půjčovat.

Bližší údaje viz SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf.

Obsah

  • Zapůjčení licencí SolidNetWork

    Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění.

  • Vrácení půjčené licence SolidNetWork

    Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

Nadřazené téma
Správa licencí SolidNetWork


Zapůjčení licencí SolidNetWork

Můžete si půjčit licenci SolidNetWork, aby jste mohli používat tento program ze vzdáleného umístění.

Musíte být připojeni k Manažeru licencí SolidNetWork, abyste si mohli půjčit licenci, ale připojení není nutné k používání. licence.

Pokud používáte systém Windows 8 nebo novější, liší se tyto kroky v závislosti na konfiguraci vašeho systému. Další pokyny a možnosti najdete v dokumentaci k systému Microsoft Windows.
  1. Spusťte na klientském počítači Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Na záložce Půjčování licence:
    1. Zadejte datum v poli Vypůjčit do.
    2. Vyberte produkty, jejichž licence si chcete půjčit. Poté klepněte na Vypůjčit a klepnutím na Ano potvrďte půjčení.
    3. Klepněte na Obnovit. Sloupec Platnost končí označuje datum, do kterého se licence musí vrátit.
  3. Klepněte na tlačítko OK.
Nadřazené téma
Zapůjčení a navrácení licencí SolidNetWork
Související úlohy
Vrácení půjčené licence SolidNetWork


Vrácení půjčené licence SolidNetWork

Protože je licence SolidNetWork odstraněna ze souhrnu dostupných licencí, zapůjčenou licenci je nutno vrátit, aby byla opět k dispozici.

  1. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  2. Na záložce Půjčování licence:
    1. Vyberte produkty k navrácení, klepněte na Vrátit a pak klepněte na Ano pro potvrzení.
    2. Klepněte na Obnovit. Prázdný sloupec Platnost končí označuje, že byly licence vráceny.
  3. Klepněte na tlačítko OK.
Vypůjčené licence nemusí být po vypršení lhůty vráceny zpět. O půlnoci ve dne uplynutí půjčení licence SolidNetWork licenční soubor na vzdáleném počítači již neumožní spuštění programu SolidWorks a licence je automaticky vrácena do fondu volných licencí na licenčním serveru.
Nadřazené téma
Zapůjčení a navrácení licencí SolidNetWork
Související úlohy
Zapůjčení licencí SolidNetWork


Monitorování doby nečinnosti licence

SOLIDWORKS může registrovat dobu nečinnosti licence SolidNetWork na serveru, aby byly licence, které nejsou používány po určitou dobu, vráceny do fondu volných licencí.

  1. V manažeru licencí SolidNetwork vytvořte textový soubor:

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. Do souboru vložte následující řádek:

    TIMEOUTALL seconds

    kde seconds je číslo větší nebo rovno 900 (15 minut), což je minimální povolená doba.

Nadřazené téma
Správa licencí SolidNetWork


Instalace dočasných licencí

Dočasnou licenci "ANY" je možno použití dočasně, když není k dispozici originální licence SolidNetWork.

Instalováním licenčního souboru "ANY" souhlasíte s tím, že použijete tradiční licenci, jakmile ji obdržíte od společnosti Dassault Systemes SOLIDWORKS Corporation. Musíte stále dodržovat licenční podmínky.

Návod na instalaci licence "ANY":

  1. Pokud jste stávající uživatel SolidNetWork, klepněte na Odinstalovat Manažera licencí SolidNetWork a odstraňte instalační složku. Podrobnosti najdete v Odinstalování Manažera licencí SolidNetWork.
  2. Spusťte Manažera instalací SOLIDWORKS (jak je to popsáno v Zahájení instalace SOLIDWORKS).
    1. Jako typ instalace vyberte následující:

      • Produkty pro servery
      • Instalovat Manažer licencí SolidNetWork (distribuované licencování) na tento počítač.

    2. Na stránce Možnosti Manažera licencí SolidNetWork zadejte sériové číslo licence SolidNetWork a umístění pro instalaci Manažera licencí SolidNetWork.
    3. Na stránce Souhrnné informace dokončete proces Manažera instalace SOLIDWORKS klepnutím na Nainstalovat.
  3. Spusťte Manažera licencí SolidNetWork (Start > Programy > SOLIDWORKS s > Manažer licencí SolidNetWork > Manažer licencí SolidNetWork).
  4. Budete-li vyzváni k aktivaci, klepněte na Ne.

    Objeví se záložka Správa serveru programu SOLIDWORKS Manažera licencí SolidNetWork.

  5. V nabídce Upřesňující možnosti vyberte Možnosti.

    Zobrazí se dialogové okno Upřesňující možnosti.

  6. V režimu licencí serveru SolidNetWork klepněte na Použít licenční soubora klepněte na OK.

    Dialogové okno Upřesňující možnosti se zavře.

  7. Pod možností Informace o licenci klepněte na Upravit.

    Objeví se průvodce licenčním souborem SolidNetWork.

  8. Pod položkou Typ serveru vyberte Samostatný a klepněte na Další.
  9. Pokud se zobrazí tato zpráva:

    Nelze načíst ID hardwarového klíče ID, klepněte na Storno.

    Automaticky je zobrazeno ID "ANY".
    Pokud vás počítač používá bránu firewall, budete zřejmě muset provést dodatečné úpravy na této obrazovce. Další informace viz Použití licencí SolidNetWork s firewall.

  10. Pokračujte v instalaci.
Nadřazené téma
Správa licencí SolidNetWork


Provedení upgrade z individuální licence na licenci SolidNetWork

Můžete provést upgrade počítače z individuální licence SOLIDWORKS na licenci SolidNetWork zadáním sériového čísla licence SolidNetWork v Manažeru licencí SOLIDWORKS.

Pokud v počítači nebyl nainstalován program SOLIDWORKS, můžete určit licenci SolidNetWork zadáním sériového čísla licence SolidNetWork při instalaci pomocí Manažera instalace SOLIDWORKS.

Pokud je již v počítači nainstalován SOLIDWORKS a přecházíte z individuální licence na licenci SolidNetWork, můžete upravit instalaci pro klientský počítač a zadat sériové číslo licence SolidNetWork místo sériového čísla individuální licence, když spouštíte Manažera instalací SOLIDWORKS. Podrobnosti viz Změna instalace.
Jestliže byl software SOLIDWORKS nainstalován z administrativní kopie, není možnost změn k dispozici. V administrativní kopii musíte provést změny pomocí Editoru možností administrativní kopie, odinstalovat klientskou aplikaci a spustit instalaci znovu.
Nadřazené téma
Správa licencí SolidNetWork
Související úlohy
Změna instalace


Použití licencí SolidNetWork a doplňkových modulů

Aplikaci SolidNetWork License Manager můžete použít k distribuci licencí pro doplňkové moduly jádra SOLIDWORKS (například FeatureWorks, Workgroup PDM Server).

  • Není vyžadován stejný počet licencí programu SOLIDWORKS a licencí doplňkových modulů.
  • Chcete-li vyzvednout licenci pro doplňkový modul, musíte nejprve vyzvednout licenci pro program SOLIDWORKS.
  • Pokud si vypůjčíte licenci doplňkového modulu, musíte si vypůjčit obě licence: licenci softwaru SOLIDWORKS a licenci produktu SOLIDWORKS, ve které je tento doplňkový modul obsažen. Jako výchozí bude zapůjčena standardní licence SOLIDWORKS. Pro povolení doplňkových modulů je potřeba zapůjčit licenci produktu SOLIDWORKS Professional nebo SOLIDWORKS Premium.
  • Návod na uvolnění licence doplňkového modulu:
    • V SOLIDWORKS klepněte na Nástroje > Doplňkové moduly, a zrušte výběr doplňkového modulu.
    • Ukončete aplikaci SOLIDWORKS.
Nadřazené téma
Správa licencí SolidNetWork


Použití stejného počítače pro manažera licencí a instalace administrativní kopie

Jeden počítač v síti můžete nakonfigurovat tak, aby fungoval jako manažer licencí, který distribuuje licence SolidNetWork, a zároveň jako umístění kopie, z níž si uživatelé mohou instalovat aplikaci SOLIDWORKS.

Klientské počítače obdrží licence od manažera licencí a pak instalují SOLIDWORKS z téhož počítače.

Tato konfigurace vyžaduje, aby manažer licencí a administrativní kopie byly na stejném počítači. Nainstalujte nejprve manažera licencí a pak vytvořte a distribuujte administrativní kopii.
Podrobnosti najdete na odkazu:
  • Instalace a aktivace licenčního klienta
  • Zavádění více klientů
Nadřazené téma
Správa licencí SolidNetWork


Správa licencí FLEXnet Publisher

Správa licencí SolidNetWork je založena na správě licencí FLEXnet Publisher®.

Více informací ohledně správy licencí FLEXnet Publisher najdete Průvodce správou licencí FLEXnet Publisher v instalačním adresáři Manažera licencí SolidNetwork (\Docs\flexuser\licensingenduserguide.pdf).

Nejnovější informace o správě licencí FLEXnet Publisher získáte na kontaktu pro software Acresso®.

Nadřazené téma
Správa licencí SolidNetWork


Řešení potíží

Zkonzultujte tato témata, která vám pomohou při odstranění potíží při instalaci.

Obsah

  • Využití síťových licencí

  • Soubory protokolu Manažera instalací SOLIDWORKS

    Soubory protokolu Manažera instalací SOLIDWORKS jsou k dispozici jako pomoc při odstranění instalačních problémů.

  • Složka pro stažení Manažera instalací SOLIDWORKS

    Manažer instalací SOLIDWORKS stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.

  • Odstranění potíží s licencemi SolidNetWork

    Pokud se instalace Manažera licencí SolidNetWork nezdaří, zkontrolujte tato možná vysvětlení.

  • Řešení potíží s upgrady

    Pokud se setkáte s problémy během provádění upgrade nové verze SOLIDWORKS, zkontrolujte tato možná vysvětlení.

  • Ověření grafické karty při instalaci nebo upgradu

    Při dokončování instalace nebo upgradu softwaru SOLIDWORKS na vašem počítači je třeba spustit nástroj SOLIDWORKS Rx, abyste se ujistili, že je počítač vybaven podporovanou grafickou kartou s ovladačem.


Využití síťových licencí

Toto dialogové okno se otevře v případě, že server nemá další licence na určitý produkt.

Klepnutím na šipku v poli Produkt zobrazíte všechny produktové volby. K volbám patří produkty SOLIDWORKS a všechny doplňkové moduly, které lze zakoupit.

Celkový počet licencí udává celkový počet licencí, které jste zakoupili.

Položka Volné licence udává počet licencí, které nejsou v současné době používány.

Pole Licence použité do poskytuje informace o každé osobě, která právě používá licenci.

Nadřazené téma
Řešení potíží
Související pojmy
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Související úlohy
Ověření grafické karty při instalaci nebo upgradu


Soubory protokolu Manažera instalací SOLIDWORKS

Soubory protokolu Manažera instalací SOLIDWORKS jsou k dispozici jako pomoc při odstranění instalačních problémů.

Tyto soubory protokolu jsou umístěné společně se soubory protokolu jiných aplikací SOLIDWORKS.
  • V případě systému Windows 7 nebo novějšího:

    C:\Users\uživatelské jméno\AppData\Roaming\SOLIDWORKS\Installation Logs\nainstalovaná_verze

Pro zobrazení adresářů souborů protokolu budete možná muset nakonfigurovat možnosti složky Windows na Zobrazit skryté soubory a složky.

Pokud jsou data aplikací umístěna na jiné jednotce než C:, přizpůsobte podle toho cestu.

Tento adresář obsahuje soubor SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt, všeobecný protokol o průběhu procesů Manažera instalací SOLIDWORKS.

Podadresář Jiné protokoly obsahuje soubory protokolů s podrobnějšími informacemi.

Nadřazené téma
Řešení potíží
Související pojmy
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Související úlohy
Ověření grafické karty při instalaci nebo upgradu
Související odkazy
Využití síťových licencí


Složka pro stažení Manažera instalací SOLIDWORKS

Manažer instalací SOLIDWORKS stáhne potřebné instalační soubory do složky, kterou určíte. Toto téma obsahuje odpovědi na časté otázky o této složce pro stažení.

Používáte-li systém Windows 8 nebo novější, podívejte se na Tipy ohledně používání aplikace SolidWorks v systému Microsoft Windows 8, kde najdete pokyny pro přístup do nabídky Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti, týkající se především systémů novějších než Windows 8, najdete v dokumentaci k systému Microsoft Windows.
Otázka Odpověď
Jakým způsobem nainstalovat soubory v této složce?

Spuštěním souboru setup.exe. Pokud zvolíte instalaci položek, které ještě nebyly staženy, budete muset stáhnout některé soubory.

Neinstalujte pomocí msiexec (viz níže).
Je možné z této složky ručně nainstalovat soubory MSI pomocí msiexec nebo jiné aplikace?

Ne. Manažer instalací nestahuje určité soubory, které jsou vyžadovány při spuštění souboru msiexec.
Je možné zadat stejnou složku pro stažení pro každou nainstalovanou verzi?

Složky stažení jsou specifické podle verze. Počínaje SOLIDWORKS 2010, Manažer instalací SOLIDWORKS automaticky vytvoří uvnitř zadané složky podsložku specifickou pro tuto verzi.

Některé produkty byly ručně staženy z webové stránky Dassault Systemes SOLIDWORKS Corporation. Může je Manažer instalací také nainstalovat?
Počínaje SW2009 se soubory stažené ručně mohou používat k instalaci pomocí Manažera instalací SOLIDWORKS. Ovšem lepší je spustit Manažera instalací SOLIDWORKS a vybrat možnost pro stažení souborů. Manažer instalací SOLIDWORKS ukáže na základě toho, co instalujete, který soubor potřebujete, a poskytne odkazy pro stažení každého souboru. Zvolte tuto možnost, pokud vestavěná stránka pro stažení nefunguje (zřejmě z důvodu stahování i přes omezení uplatňovaná proxy serverem).
Pokud se Microsoft Internet Explorer zeptá, jestli chcete uložit nebo provést soubory během spuštění nebo instalace, vždy vyberte uložit.
Mohou být stažené soubory sdílené s jinými uživateli?

Ano. Pokud chcete soubory sdílet, stáhněte je na místo v síti. Každý klient může spustit Manažera instalací SOLIDWORKS z tohoto sdíleného umístění v síti.

Nebude již potřeba stáhnout další soubory, pokud uživatel nevybere k instalaci položky, které nebyly během počátečního stažení vybrány nebo pokud počítač, který to využívá k instalaci, má jinou sadu předpokladů než počítač, na který soubory stahujete.

Pokud provádíte pouze stažení za jiné, ale ne instalaci, vyberte při instalaci možnost Pouze stáhnout. Tato možnost vám umožní vybrat produkty nezávisle na tom, co je nainstalováno na vašem počítači. Tuto možnost však nelze použít pro instalaci oprav nebo pro vytvoření administrativních kopií.
Jak je možné zjistit, že jsou dostupné nové verze produktů SOLIDWORKS?
V těchto případech budete informování o nové verzi:
  • Pokud spustíte nástroj Zjistit aktualizace ( Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace)
  • Pokud jste povolili SOLIDWORKS Nástroj pro stahování na pozadí.
  • Jestliže vyberete nainstalovanou verzi programu SOLIDWORKS ve Windows v části Přidat/Odebrat programy a klepnete na Změnit.
  • Pokud ze složky pro stažení spustíte starší verzi Manažera instalací (sldIM.exe).
V těchto případech můžete stáhnout novější verzi. Manažer instalací SOLIDWORKS stáhne a spustí novou verzi manažera, ale ne žádné instalační soubory. Po spuštění nové verze Manažera instalací SOLIDWORKS můžete vybrat ze sady instalačních operací. Manažer instalací SOLIDWORKS určí požadované instalační soubory (a soubory, které ještě nebyly staženy) a nabídne je ke stažení.
Proč Manažer instalací SOLIDWORKS neumožňuje výběr jiné aktualizace service pack produktu k instalaci?

Každá verze Manažera instalací SOLIDWORKS je určena k instalaci pouze konkrétní verze produktů SOLIDWORKS. Pokud chcete instalovat jinou aktualizaci service pack, musíte spustit Manažera instalací SOLIDWORKS odpovídající verze. Potřebujete-li vyhledat poslední dostupnou verzi, přečtěte si předchozí odpověď.
Proč Manažer instalací SOLIDWORKS nemůže stáhnout soubory?

Pokud omezení proxy serveru zabraňují programům ve stahování souborů, Manažer instalací SOLIDWORKS nemůže automaticky stahovat soubory.

Soubory můžete stáhnout ručně a pak je instalovat pomocí Manažera instalací SOLIDWORKS. Zvolte v Manažeru instalací SOLIDWORKS možnost pro stažení individuálních souborů (například Provést ruční stažení na stránce Možnosti instalace). Podle vašeho výběru produktu a požadavků systému se objeví webová stránka ve zvláštním okně a obsahuje odkazy pro manuální stažení všech požadovaných souborů. Tyto odkazy jsou identické s těmi, které poskytuje Zákaznický portál SOLIDWORKS, ale soubory nemusíte hledat.
Ne všechny moje produkty SOLIDWORKS byly aktualizovány pomocí nejnovější aktualizace Service Pack. Proč příkaz Zjistit aktualizace uvádí, že mám poslední verzi?

Spuštěním příkazu Zjistit aktualizace se dozvíte, zda máte nainstalovanou anebo spuštěnou aktuální verzi Manažera instalací SOLIDWORKS.

Pokud chcete aktualizovat všechny produkty podle poslední verze, která byla instalována, v Přidat/Odstranit programy zvolte poslední instalovanou verzi SOLIDWORKS a klepněte na Změnit.

Je možné zkopírovat DVD do složky pro stažení?

Ano, ale instalace mohou selhat, pokud nezkopírujete celý obsah každého DVD vydaného pro odpovídající platformu. Manažer instalací SOLIDWORKS hledá soubory swdata*.id pro určení verze. Pokud tyto soubory nejsou k dispozici, nebude moci rozpoznat zkopírované instalační soubory a bude vyžadovat jejich stažení.
Nadřazené téma
Řešení potíží
Související pojmy
Soubory protokolu Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8
Související úlohy
Ověření grafické karty při instalaci nebo upgradu
Související odkazy
Využití síťových licencí


Odstranění potíží s licencemi SolidNetWork

Pokud se instalace Manažera licencí SolidNetWork nezdaří, zkontrolujte tato možná vysvětlení.

Nadřazené téma
Řešení potíží
Související pojmy
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Řešení potíží s upgrady
Související úlohy
Ověření grafické karty při instalaci nebo upgradu
Související odkazy
Využití síťových licencí

Přístup na soubory protokolu licencí SolidNetWork

Když dojde k chybě v licenci, většinou se odpověď zobrazí v souboru protokolu SNL_Manager_install_dir\lmgrd.log .

Nepodařilo se získat licenci pro SOLIDWORKS. Nepodařilo se připojit k licenčnímu serveru.

Tento problém je většinou způsoben nastaveními portu.

  • Nastavení portu mezi manažerem licencí SolidNetWork a licenčním klientem se zřejmě neshoduje.
  • Další nastavení portu pro násobné verze Manažera licence SolidNetWork nebyly pravděpodobně určeny.
  • Zkontrolujte, zda klientský počítač dokáže správně dešifrovat název serveru a přesměrovat se na něj na základě uvedeného názvu serveru. Dále zkontrolujte, zda server dokáže správně dešifrovat název klienta a přesměrovat se na něj na základě uvedeného názvu počítače.
Bližší informace o nastavení portu pro manažery licencí a klienty SolidNetWork vizPoužití licencí SolidNetWork s firewall.
Související pojmy
Použití licencí SolidNetWork s firewall


Řešení potíží s upgrady

Pokud se setkáte s problémy během provádění upgrade nové verze SOLIDWORKS, zkontrolujte tato možná vysvětlení.

Nadřazené téma
Řešení potíží
Související pojmy
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Související úlohy
Ověření grafické karty při instalaci nebo upgradu
Související odkazy
Využití síťových licencí

Upgrade z přemístěného zdroje

Při instalaci programu SOLIDWORKS si Manažer instalací SOLIDWORKS zapamatuje umístění zdrojů (disk, kopie disku na síti atd.). Manažer instalací očekává tyto zdroje ve stejném umístění během aktualizace.

Pokud dojde k přemístění nebo odstranění zdroje, nebo pokud se změní médium zdroje, zobrazí Manažer instalace SOLIDWORKS chybovou hlášku. Pokud vyhledáte jiné umístění obsahující stejné soubory a strukturu složky, můžete pokračovat v upgradu.


Ověření grafické karty při instalaci nebo upgradu

Při dokončování instalace nebo upgradu softwaru SOLIDWORKS na vašem počítači je třeba spustit nástroj SOLIDWORKS Rx, abyste se ujistili, že je počítač vybaven podporovanou grafickou kartou s ovladačem.

Ověření grafické karty a ovladače:

  1. Když Manažer instalací dokončí instalaci a zobrazí stránku Dokončit, v nabídce Zkontrolovat systém klepněte na položku Spustit diagnostiku systému.

    Nástroj SOLIDWORKS Rx spustí a provede diagnostiku.

  2. Nástroj SOLIDWORKS Rx potvrdí, zda jsou grafická karta a její ovladač podporovány. Pokud je podporována grafická karta, ale ovladač ne, stavová zpráva může nabídnout odkaz na podporovaný ovladač.

Při každém desátém spuštění softwaru SOLIDWORKS se zobrazí zpráva Zkontrolovat systém s doporučením spustit znovu diagnostiku systému. Pokud chcete tato oznámení potlačit, klepněte v oznamovací oblasti systému Windows pravým tlačítkem na SOLIDWORKS Resource Monitor a pak na Vypnout oznámení.

Grafickou kartu a její ovladač lze ověřit kdykoli klepnutím pravým tlačítkem na položku SOLIDWORKS Resource Monitor v oznamovací oblasti systému Windows. Místní nabídka rovněž umožňuje:
  • Zobrazit nápovědu pro SOLIDWORKS Resource Monitor
  • Spustit diagnostiku systému
  • Aktualizovat ovladače grafické karty
Nadřazené téma
Řešení potíží
Související pojmy
Soubory protokolu Manažera instalací SOLIDWORKS
Složka pro stažení Manažera instalací SOLIDWORKS
Odstranění potíží s licencemi SolidNetWork
Řešení potíží s upgrady
Související odkazy
Využití síťových licencí


Nápověda aplikace Manažer instalací SOLIDWORKS

Manažer instalací SOLIDWORKS je samostatný program, který nainstaluje a aktualizuje produkty SOLIDWORKS.

Manažera instalací SOLIDWORKS můžete spustit následujícími způsoby:
  • Z disku DVD SOLIDWORKS nebo ze sdílené zdrojové složky nebo složky pro stažení (když instalujete novou verzi).
  • Ze stránky Ovládací panel Přidat nebo Odebrat programy (když měníte nebo odstraňujete stávající verzi)
  • Prostřednictvím naplánovaného nebo ručního zjišťování aktualizací (najít, stáhnout a nainstalovat nové finální verze).

Každá verze SOLIDWORKS má verzi Manažera instalací SOLIDWORKS, která je specifická pro danou verzi SOLIDWORKS.

Pro verze předcházející verzi SOLIDWORKS 2008 použijte Manažera instalací SOLIDWORKS 2007 nebo stáhněte ručně verze produktu z webové stránky podpory SOLIDWORKS.
Používáte-li systém Windows 8, podívejte se na Tipy ohledně používání aplikace SolidWorks v systému Microsoft Windows 8, kde najdete pokyny pro přístup do nabídky Start nebo Ovládacích panelů. Tyto postupy se mohou měnit podle vaší konfigurace systému Windows 8. Další pokyny a možnosti, týkající se především systémů novějších než Windows 8, najdete v dokumentaci k systému Microsoft Windows.

Obsah

  • SOLIDWORKS Nástroj pro stahování na pozadí

    SOLIDWORKS Nástroj pro stahování na pozadí provádí automatizované stahování souborů (když je například nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se zobrazí dotaz, zda chcete instalovat nyní, odložit nebo odstranit stahování.

  • Výsledky zjištění aktualizací

    Funkce Zjistit aktualizace hledá novější verze SOLIDWORKS.

  • Umístění administrativní kopie

    Určete umístění instalace administrativní kopie.

  • Možnosti stažení

    Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.

  • Možnosti stažení pro soubory Manažera instalací SOLIDWORKS

    Zvolili jste stažení novější verze Manažera instalací SOLIDWORKS. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.

  • Stažení instalačních souborů produktu

    Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.

  • Průběh stahování

    Během tohoto procesu Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

  • Výsledky stahování

    Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.

  • Chyby během instalace / Instalace byla zrušena

    Při instalaci došlo k chybě nebo byla instalace zrušena.

  • Instalace je dokončena

    Manažer instalací SOLIDWORKS dokončil proces instalace.

  • Umístění instalace

    Určete umístění instalace SOLIDWORKS.

  • Možnosti upgradu

    V tomto počítači je nainstalována jedna nebo více starších významných verzí SOLIDWORKS. Vyberte, jestli provedete upgrade poslední existující verze na novou verzi nebo vytvoříte novou instalaci pro novou verzi.

  • Průběh instalace

    Tato obrazovka uvádí průběh instalace.

  • Typ instalace

    Určete operaci instalace, kterou chcete spustit, jako je vytvoření nové instalace, úprava nebo oprava existující instalace, vytvoření administrativní kopie, instalace administrativních produktů serveru nebo stažení souborů bez instalace.

  • Instalace a správa několika počítačů

    Manažer instalací SOLIDWORKS poskytuje následující nástroje na instalaci a správu několika počítačů SOLIDWORKS.

  • Ruční stahování

    Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SOLIDWORKS).

  • K dispozici je novější verze

    Manažer instalací zaznamenal novější verzi produktů SOLIDWORKS. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.

  • Nejsou k dispozici novější verze

    Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.

  • Zjištěné procesy

    Manažer instalací SOLIDWORKS zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.

  • Výběr produktu

    Určete součásti produktu, které chcete nainstalovat, upravit nebo odebrat.

  • Produkty ke stažení

    Vyberte produkty SOLIDWORKS, které se mají stáhnout do určitého umístění.

  • Produkty k opravě

    Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SOLIDWORKS spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SOLIDWORKS.

  • Sériová čísla

    Sériová čísla, která se nacházejí na balení, přiřazují zakoupené produkty SOLIDWORKS k vašemu počítači.

  • Instalace serveru

    Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.

  • Manažer licencí SolidNetWork

    Zadejte instalační volby pro produkt pro server Manažer licencí SolidNetWork.

  • Souhrnné informace

    Manažer instalací SOLIDWORKS má všechny potřebné informace pro dokončení instalace.

  • Upozornění kontroly systému

    Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SOLIDWORKS.

  • Možnosti Průvodce dírami/Toolbox

    Pokud je SOLIDWORKS Toolbox instalován, obsahuje software SOLIDWORKS knihovnu standardních typů děr stejně jako hardware.

  • Odinstalování produktů

    Zvolíte-li v Ovládacích panelech možnosti Odebrat nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SOLIDWORKS (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SOLIDWORKS. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.

  • Možnosti serveru Workgroup PDM

    Zadejte instalační volby pro server SOLIDWORKS Workgroup PDM.

Související pojmy
Tipy ohledně používání aplikace SOLIDWORKS v systému Microsoft Windows 8


SOLIDWORKS Nástroj pro stahování na pozadí

SOLIDWORKS Nástroj pro stahování na pozadí provádí automatizované stahování souborů (když je například nalezena nová verze aktualizace Service Pack) pomocí procesů na pozadí, přičemž umožňuje během stahování pokračovat v práci. Po dokončení stahování se zobrazí dotaz, zda chcete instalovat nyní, odložit nebo odstranit stahování.

Když instalujete SOLIDWORKS, je SOLIDWORKS Nástroj pro stahování na pozadí ve výchozím nastavení povolen.

Když běží Manažer instalací SOLIDWORKS, je SOLIDWORKS Nástroj pro stahování na pozadí pozastaven, bez ohledu na to, zda provádí instalaci nebo stahování. Dojde tak například k pozastavení všech probíhajících stahování, nepovolí se zahájení nových stahování a není možné změnit určení složky pro stahování.

SOLIDWORKS Nástroj pro stahování na pozadí můžete během instalace SOLIDWORKS vypnout, a sice tak, že změníte Možnosti stahování na stránce Shrnutí. (Zrušte výběr položky Chcete použít Nástroj pro stahování na pozadí?.)

Když je nástroj povolen, objeví se v systémové oblasti Windows v hlavním panelu tato ikona:

Klepnutím na tuto ikonu aktivujete následující operace:
  • Nápověda pro Nástroj pro stahování na pozadí
  • Pozastavit stahování
  • Obnovit stahování
  • Zrušit stahování
  • Možnosti instalace
  • Změnit umístění pro stahování
  • Zjistit aktualizace
  • Zjišťovat aktualizace automaticky
  • Automaticky stáhnout aktualizace
  • Zakázat nástroj pro stahování na pozadí

Nápověda pro Nástroj pro stahování na pozadí

Otevřete toto téma nápovědy pro Nástroj pro stahování na pozadí pomocí Průvodce instalací SOLIDWORKS.

Pozastavit/obnovit stahování

Pokud běží na pozadí stahování, klepnutím na Pozastavit stahování je pozastavíte a můžete je později kdykoli znovu obnovit klepnutím na Obnovit stahování.

Zrušit stahování

Pokud probíhá stahování, můžete je zastavit a odstranit veškeré soubory, které již Nástroj pro stahování na pozadí stáhl.
Zrušené stahování nemůžete obnovit.

Možnosti instalace

Když je stahování dokončeno, můžete si vybrat z následujících možností:
  • Nainstalovat: Nainstaluje stažené soubory.
  • Připomenout později: Nenainstaluje stažené soubory, ale sestaví zprávu, kterou vám připomene instalaci později.
  • Odstranit stažení: Nenainstaluje stažené soubory a odstraní je. (To je užitečné zejména v případě, že jste se rozhodli, že stažené soubory již nechcete instalovat.)

Změnit umístění pro stahování

Změní umístění, do něhož Nástroj pro stahování na pozadí stahuje soubory.

Tato volba není dostupná, pokud stahování buď běží nebo je pozastaveno.

Zjistit aktualizace

Spusťte funkci Zjistit aktualizace Manažera instalací SOLIDWORKS.

Zjišťovat aktualizace automaticky

Pravidelně spouští příkaz Zjistit aktualizace a upozorňuje, že jsou k dispozici aktualizace ke stažení.

Automaticky stáhnout aktualizace

Pravidelně spouští příkaz Zjistit aktualizace a stahuje dostupné aktualizace.

Vypnutí a opětovné zapnutí SOLIDWORKS Nástroje pro stahování na pozadí

Nástroj pro stahování na pozadí můžete vypnout klepnutím na jeho ikonu a výběrem možnosti Zakázat nástroj pro stahování na pozadí.

Chcete-li Nástroj pro stahování na pozadí znovu povolit, klepněte na Start > Programy > Manažer instalace SOLIDWORKS > SOLIDWORKS Nástroj pro stahování na pozadí.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Výsledky zjištění aktualizací

Funkce Zjistit aktualizace hledá novější verze SOLIDWORKS.

Můžete provést Zjistit aktualizace ručně:
  • V systému Windows klepněte na Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace
  • V SOLIDWORKS klepněte na položku Nápověda > Zjistit aktualizace.
Zjistit aktualizace není k dispozici u klientů instalovaných z administrativních kopií.

Dostupná novější verze

Manažer instalací SOLIDWORKS zaznamenal novější verzi produktů SOLIDWORKS. Vyberte Manažera instalací SOLIDWORKS pro tuto verzi, což vám umožní aktualizovat na novější verzi.

Tato novější verze může stáhnout instalační soubory založené na produktech, které jste určili v instalaci. Stažené soubory můžete sdílet s ostatními uživateli, kteří používají k instalaci Manažera instalací SOLIDWORKS.

Tato stažení lze použít pouze v Manažeru instalací SOLIDWORKS.
K dispozici jsou tyto možnosti:
  • Pokud je k dispozici několik verzí, vyberte požadovanou verzi ze seznamu.
  • Detaily o verzi najdete v odkazu Zkontrolujte, co tento upgrade obsahuje.
Klepnutím na Další bude stažena a spuštěna nová verze Manažera instalací SOLIDWORKS.

Žádná nová stažení/Nové verze není možné zjistit

Manažer instalací SOLIDWORKS nezjistil nové verze produktů SOLIDWORKS, protože jste instalovali nejnovější dostupnou verzi, nebo se nemohl připojit k serveru SOLIDWORKS, aby provedl kontrolu.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Umístění administrativní kopie

Určete umístění instalace administrativní kopie.

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie | Toto je umístění adresáře, ve kterém Manažer instalací SOLIDWORKS vytvoří novou kopii. | Toto umístění nemůže obsahovat existující administrativní kopii. Administrativní kopie musí být ve složce, kterou lze sdílet za účelem zavedení na klienty.
Odhadované místo na disku požadované pro vytvoření kopie | Toto je doplňkové místo požadované pro administrativní kopii. | Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z | Toto je umístění adresáře, ze kterého instalujete produkty SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti najdete v Možnosti stažení.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti stažení

Zadejte podrobnosti pro dokončení operace stažení, jako je umístění staženıch souborů, jakım způsobem soubory stáhnout a jestli chcete stažené soubory instalovat.

Manažer instalací SOLIDWORKS podporuje způsob distribuce softwaru označovaný jako electronic software distribution (ESD). Pokud neprovádíte instalaci z disku DVD SOLIDWORKS, budete vyzváni k zadání zdroje pro produkty SOLIDWORKS, které instalujete.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.

Co chcete udělat?

Vyberte jednu z následujících možností:

Stáhnout a instalovat/stáhnout a vytvořit kopii

Po dokončení stahování spustí Manažer instalací SOLIDWORKS instalaci za použití stažených souborů.

Pouze stáhnout. Můžete stáhnout soubor jednou a pak sdílet stažené soubory s více počítači.

Manažer instalací SOLIDWORKS nespustí instalaci po dokončení stažení.

Obvykle byste zadali tuto možnost, když byste stahovali soubory ke konfiguraci sady instalačních souborů, kterou použijete na více počítačích.

Pokud tuto možnost zvolíte, budete vyzváni, abyste si vybrali mezi dvěma sadami souborů, které chcete stáhnout:
  • Soubory pro TENTO počítač: Stažení bude obsahovat jen ty soubory, které chybí v sadě instalačních souborů aktuálně instalovaných na tomto počítači.
    Toto stažení by mělo být menší, protože obsahuje:
    • Pouze soubory pro produkty vybrané na stránce Výběr produktu
    • Pouze soubory předpokladů, které jsou požadovány pro váš počítač, ale ještě nejsou instalovány

    Pokud se ale pokusíte použít tuto stáhnutou sadu souborů na jiném počítači pro provedení instalace, některé soubory by mohly chybět (protože sada instalačních souborů na jiném počítači by mohla být rozdílná). Můžete použít tyto stažené soubory pro instalaci na jiném počítači, ale když instalace běží, budete možná muset stáhnout další soubory pro doplnění sady instalačních souborů na tomto počítači.

  • Soubory ke sdílení s JAKÝMKOLIV počítačem: Stažení bude obsahovat kompletní sadu instalačních souborů, kterou je možno použít k instalaci této verze na jakémkoliv počítači.

    Toto stažení je delší, protože obsahuje kompletní sadu souborů, kterou je možno použít k instalaci této verze jakéhokoliv produktu na jakémkoliv počítači.

    Pokud určíte omezenou sadu produktů, které se mají stáhnout, bude tato možnost toto určení ignorovat a stáhne všechny produkty obsažené v této verzi produktu.

    Stažení bude obsahovat všechny soubory nutné pro vytvoření administrativní kopie, nejenom ty soubory, které jsou nutné pro provedení individuální instalace.

Pouze instalovat/Vytvořit pouze kopii. Mám již všechny soubory, které jsou nutné k instalaci.

Manažer instalací SOLIDWORKS nestahuje žádné soubory, ale používá soubory ve vybraném adresáři.

Vyhledejte jiné umístění klepnutím na Vyhledat. Můžete například přejít k instalačnímu DVD nebo ke složce stažení, za předpokladu, že toto místo obsahuje všechny požadované soubory.

Pokud obdržíte chybovou hlášku, že složka není kompletní a předpokládali jste, že obsahuje všechny instalační soubory, vysvětlení mohou být následující:
  • Vybrali jste k instalaci produkt, který nebyl ještě stažen, nebo byl vybrán automaticky.
  • Soubory byly staženy na jiném počítači s jinou sadou systémových požadavků.
  • Nejprve jste provedli klientskou instalaci a nyní vytváříte administrativní kopii, která vyžaduje větší sadu souborů.

Můžete buď vyhledat složku obsahující všechny tyto soubory (například DVD) nebo vyberte jednu z možností stažení.

Kam se mají stáhnout požadované soubory?

Toto je složka pro umístění stažení.

V některých případech může být tato možnost viditelná, ale vypnutá. Pokud je například zadáno Pouze instalovat, Manažer instalací SOLIDWORKS nainstaluje jakékoliv stažené soubory z adresáře určeného pro tuto možnost a nepoužije samostatnou složku pro stažení.

Ať již stahujete tyto soubory nebo k nim máte přístup z vašeho vlastního umístění, všechny soubory musí být staženy do stejné složky.

Odhadovaná velikost stažení

Odhadovaný požadavek na místo na disku při stažení je založen na vybraném celkovém seznamu součástí, bez ohledu na to, zda se jedná o nové stažení nebo o obnovení předchozí relace.

Jestliže například obnovíte předchozí stažení, Manažer instalací SOLIDWORKS zpracuje pouze ty soubory, které ještě nebyly staženy. Doba stažení může být kratší než odhadovaná doba.

Pokud soubor dokončil stahování v předchozím stažení, jeho velikost není zahrnuta v tomto odhadu. Proto může být odhad vyšší než aktuální velikost stažení.

Jakým způsobem se má provést stažení?

Existují dvě možnosti:

Provést ruční stažení

V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SOLIDWORKS.

Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SOLIDWORKS a dokončit instalaci. Tato webová stránka je Manažerem instalací SOLIDWORKS přizpůsobena pro stahování pouze těch souborů, které jsou nutné pro dokončení instalace.

Zrychlete stahování využitím lepšího širokopásmového připojení.

Nástroj pro stahování používá algoritmus ke zrychlení stahování tak, že během stahování zvýší používání širokopásmového připojení.

V některých případech však může dojít k narušení výkonu sítě. Pokud budete mít během stahování potíže, může to znamenat, že tato možnost nemusí být podporována proxy serverem. Zrušte výběr této možnosti a proveďte stažení znovu. O detaily požádejte správce vaší sítě.

Tato možnost se vztahuje jen na automatické stahování.. Nemá žádný dopad na ruční stažení.

Používání SOLIDWORKS Nástroje pro stahování na pozadí

SOLIDWORKS Nástroj pro stahování na pozadí slouží k dokončení této operace stahování, nebo ke stažení budoucích aktualizací service pack pro program SOLIDWORKS, až budou k dispozici.

SolidWorks Nástroj pro stahování na pozadí automaticky zaznamená a stáhne nové aktualizace service pack na pozadí a upozorní vás, že je stahování dokončeno a soubory jsou připraveny k instalaci. Podrobnosti najdete v SOLIDWORKS Nástroj pro stahování na pozadí.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti stažení pro soubory Manažera instalací SOLIDWORKS

Zvolili jste stažení novější verze Manažera instalací SOLIDWORKS. Na této obrazovce zadejte, kde a jakým způsobem mají být soubory staženy.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.

Tato obrazovka se objeví pouze tehdy, když existuje problém s výchozí složkou pro stažení (například pokud není přístup ke čtení nebo síti k dispozici). Obvykle můžete sami určit alternativní adresář pro stažení pro pokračování.

Složka pro stažení

Vyhledejte cílovou složku pro soubory Manažera instalace SOLIDWORKS.

Zobrazí se požadované místo a aktuálně dostupné místo na disku. Toto číslo zahrnuje dodatečné místo pro dekomprimaci stažených souborů a je větší než velikost stažení.

Použít zrychlené stahování

Pokud je tato možnost vybrána, nástroj pro stahování používá algoritmus ke zrychlení stahování.

Zrychlené stahování zvyšuje požadavky na síť a může narušit její fungování. Poraďte se se správcem sítě, než povolíte zrychlené stahování.

Pokud není zrychlené stahování podporované proxy serverem, je tato možnost automaticky zakázána.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Stažení instalačních souborů produktu

Určete kam a jak se mají stáhnout chybějící soubory určitého produktu.

Během stahování Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

Zrušením této obrazovky zrušíte zbytek posloupnosti instalace.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací, najdete na odkaze Chyby při instalaci.

Složka pro stažení

Vyhledejte cílovou složku pro stažené soubory.

Je také zobrazena velikost stahování a požadované místo. Požadované místo zahrnuje jakékoliv místo navíc, které je zapotřebí pro dekomprimaci určitých stahování a je větší než aktuální stahovaná velikost.

Odpovědi na dotazy týkající se složky pro stažení najdete v části Složka pro stažení Manažera instalací SOLIDWORKS.

Možnosti stažení

Složka pro stažení Manažera instalací SOLIDWORKS

Zrychlete stahování využitím lepšího širokopásmového připojení.

Nástroj pro stahování používá algoritmus ke zrychlení stahování tak, že během stahování zvýší používání širokopásmového připojení.

V některých případech však může dojít k narušení výkonu sítě. Pokud budete mít během stahování potíže, může to znamenat, že tato možnost nemusí být podporována proxy serverem. Zrušte výběr této možnosti a proveďte stažení znovu. O detaily požádejte správce vaší sítě.
Zrychlené stahování zvyšuje požadavky na síť a může narušit její fungování. Poraďte se se správcem sítě, než povolíte zrychlené stahování.

Pokud není zrychlené stahování podporované proxy serverem, je tato možnost automaticky deaktivována.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související pojmy
Složka pro stažení Manažera instalací SOLIDWORKS
Související odkazy
Chyby během instalace / Instalace byla zrušena


Průběh stahování

Během tohoto procesu Manažer instalací SOLIDWORKS paralelně stáhne, ověří a extrahuje všechny soubory.

Chcete-li v průběhu zrušit stahování, klepněte na Storno.

Pokud stahování zrušíte nebo se stahování nepodaří, obrazovka Stahování zrušeno nebo Problém při stahování vám oznámí, které stažení nebylo dokončeno a umožní vám obnovit stahování, nebo ukončit program.

Odpovědi na otázky o složce pro stažení najdete v Složka pro stažení Manažera instalací SOLIDWORKS.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Výsledky stahování

Zobrazuje, jestli bylo stažení dokončeno úspěšně, jestli byla operace úspěšná nebo jestli byla zrušena.

Problém se stahováním/Stahování zrušeno

Pokud vidíte Problém se stahováním, Manažer instalací SOLIDWORKS narazil na problémy, které brání v dokončení stahování.

Pokud vidíte Stahování zrušeno, zrušili jste stahování před tím, než bylo dokončeno.

Pokračujte následovně:

Opakovat/Obnovit automatická stahování | Pro obnovení automatického stahování z místa, kde bylo zrušeno, zvolte tuto možnost a klepněte na Opakovat staženínebo Obnovit stažení.
Stáhnout soubory individuálně ve webovém prohlížeči | V některých případech může proxy server zabránit automatickým stažením z Manažera instalací SOLIDWORKS. | Když zvolíte tuto možnost, můžete stáhnout soubory ručně pomocí webové stránky a pak pokračovat v rámci Manažera instalace SOLIDWORKS a dokončit instalaci. Tato webová stránka je Manažerem instalací SOLIDWORKS přizpůsobena pro stahování pouze těch souborů, které jsou nutné pro dokončení instalace.

Stahování dokončeno

Obrazovka Stahování dokončeno se objeví, když je stahování dokončeno, pokud jste určili možnost Pouze stáhnout.

Klepnutím na Dokončit ukončíte Manažera instalací SOLIDWORKS.

Neinstalujte žádný z těchto produktů ručně. K instalaci stažených souborů vždy používejte Manažera instalací SOLIDWORKS.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Chyby během instalace / Instalace byla zrušena

Při instalaci došlo k chybě nebo byla instalace zrušena.

Pokud dojde k chybě, nebo ke zrušení:
  • Produkty, které byly nainstalovány než došlo k chybě nebo ke zrušení, zůstanou na počítači.
  • Instalace produktu, která probíhala v době zrušení, je vrácena zpět, je-li to možné, aby na počítači nebyly částečné instalace.
  • Zbylé produkty nejsou nainstalovány nebo odinstalovány. Seznam je k dispozici pod Nebyl proveden pokus.

    Chcete-li obnovit instalaci nebo tyto produkty odinstalovat, klepněte na odkazy, které jsou k dispozici.

Manažer instalací SOLIDWORKS nejprve nainstaluje nutné požadované součásti, které nejsou instalované na počítači, například .NET framework.

Obsah

  • Obnovení po nezdařené nebo zrušené instalaci

    Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětného spuštění instalace.

  • Oprava instalace

    Pokud zaznamenáte problém s nainstalovaným produktem SOLIDWORKS, můžete pomocí Manažera instalací SOLIDWORKS instalaci opravit.

  • Kontaktování prodejce SOLIDWORKS

    Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SOLIDWORKS a poskytněte mu informace z této obrazovky. Možná, že bude potřebovat také komprimovanou složku souborů protokolu Manažera instalací SOLIDWORKS.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Obnovení po nezdařené nebo zrušené instalaci

Pokud dojde k chybě nebo ke zrušení během instalace, můžete obnovit instalaci z tohoto bodu opětného spuštění instalace.

  1. Zaznamenejte chybovou hlášku a kód produktu pro každou nezdařenou instalaci tak, jak je zobrazeno na obrazovce Chyby během instalace nebo Instalace byla zrušena.

    Pokud jste vyzváni, abyste zadali zdroj souboru, a neměníte stávající instalaci SOLIDWORKS, instalace nebo váš počítač je možná poškozen. Obraťte se na prodejce SOLIDWORKS.

  2. Restartujte počítač.
  3. Abyste se ujistili, že nejsou spuštěny žádné produkty SOLIDWORKS, stiskněte ve Windows kombinaci kláves Ctrl+Alt+Del. Otevře se Správce úloh.
  4. Pokud se na záložce Procesy objeví pod položkou Název obrázku jakékoliv následující procesy, vyberte je a klepněte na Ukončit proces.

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. Pokud je program již nainstalován a snažíte se ho změnit, nebo odstranit, zkuste opravit instalaci. Podrobnosti viz Opravování instalace.
  6. V systému Windows 7 nebo novějším klikněte na Start > Ovládací panely > Programy a funkce. Ve starší verzi systému Windows klikněte na nabídku Start > Ovládací panely > Přidat nebo odebrat programy.
  7. Vyberte verzi programu SOLIDWORKS, která selhala.

    Pokud pro verzi SOLIDWORKS, kterou se snažíte nainstalovat, neexistuje žádná položka, zopakujte instalaci.

  8. Proveďte jeden z následujících úkonů:
    • Chcete-li instalaci zopakovat, klepněte na Změnit a vyberte všechny produkty, které během instalace selhaly, nebo byly přeskočeny.

    • Chcete-li přeskočit instalaci, která selhala, klepněte na Změnit a vyberte všechny produkty, které byly během instalace přeskočeny. Zrušte výběr produktů, které se nepodařilo nainstalovat.

    • Chcete-li instalaci přerušit, klepněte na Odstranit a vyberte produkty, které byly nainstalovány.

    Tímto se neobnoví předchozí verze produktů, u které jste chtěli provést upgrade.

Nadřazené téma
Chyby během instalace / Instalace byla zrušena
Související úlohy
Oprava instalace
Kontaktování prodejce SOLIDWORKS


Kontaktování prodejce SOLIDWORKS

Pokud změna nebo oprava instalace selže, obraťte se na místního prodejce SOLIDWORKS a poskytněte mu informace z této obrazovky. Možná, že bude potřebovat také komprimovanou složku souborů protokolu Manažera instalací SOLIDWORKS.

  1. Vyhledejte soubory protokolu:
    • V případě systému Windows 7 nebo novějšího:

      C:\Users\uživatelské jméno\AppData\Roaming\SOLIDWORKS\Installation Logs\nainstalovaná_verze\

    Pokud složku nemůžete najít, může být skryta. V Průzkumníku Windows klepněte na Nástroje > Možnosti složky. Na záložce Zobrazení, pod položkou Upřesnit nastavení, vyberte Zobrazovat skryté soubory a složky pro Skryté soubory a složky.

  2. Komprimujte veškerý obsah této složky včetně podsložek.
Nadřazené téma
Chyby během instalace / Instalace byla zrušena
Související úlohy
Obnovení po nezdařené nebo zrušené instalaci
Oprava instalace


Instalace je dokončena

Manažer instalací SOLIDWORKS dokončil proces instalace.

Jedna nebo více těchto možností se zobrazí.

Co je nového

V případě individuálních instalací se po dokončení instalace zobrazí dokument popisující nové funkce v programu SOLIDWORKS a v jeho doplňkových modulech.

V případě instalací administrativní kopie se tato příručka zobrazí na klientských počítačích po dokončení jejich instalací.

Průzkum

Zašlete nám váš názor na instalační proces prostřednictvím krátkého průzkumu.

Zúčastněte se programu na zlepšení zkušeností SOLIDWORKS zákazníka

Informace o výkonu jsou zasílány společnosti SOLIDWORKS Corporation, aby pomáhaly zlepšovat produkt. Tento proces je transparentní a důvěrný. Vyberte jednu z následujících možností:
  • Ano, chci se účastnit
  • Ne, děkuji
  • Připomenout později
Další informace viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Administrativní kopie byla dokončena

Po dokončení vytváření administrativní kopie, můžete klepnutím na Přizpůsobit kopii spustit Editor možností administrativní kopie a upravit ji.

Klepnutím na Zobrazit návod, jak instalovat kopii na klientském počítači. se zobrazí návod na používání Editoru možností.

Detaily o konfiguraci administrativní kopie za použití Editora možností viz Editor možností administrativní kopie.

Klepnutím na Přizpůsobit kopii spustíte Editor možností administrativní kopie, v němž můžete upravit nastavení možností pro danou administrativní kopii.
Editor možností můžete spustit později poklepáním na sldAdminOptionEditor.exe v instalačním adresáři administrativní kopie.

Obsah

  • Zjistit aktualizace SOLIDWORKS

    Pro manuální kontrolu aktualizací nebo pro konfiguraci automatické kontroly aktualizací můžete použít Manažera instalací SOLIDWORKS.

  • Program na zlepšení zkušeností zákazníků SOLIDWORKS

    Při instalaci SOLIDWORKS můžete zadat, že se mají společnosti SOLIDWORKS Corporation odesílat informace o výkonu za účelem vylepšení produktu.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související odkazy
Editor možností administrativní kopie


Zjistit aktualizace SOLIDWORKS

Pro manuální kontrolu aktualizací nebo pro konfiguraci automatické kontroly aktualizací můžete použít Manažera instalací SOLIDWORKS.

  1. Spusťte Manažera instalací SOLIDWORKS jedním z následujících způsobů:

    • V programu SOLIDWORKS klepněte na Nápověda > Zjistit aktualizace.

    • V systému Windows klepněte na Start > Programy > Manažer instalací SOLIDWORKS > Zjistit aktualizace.

    Manažer instalací SOLIDWORKS vám sdělí, jestli jsou aktuálně nějaké aktualizace k dispozici.

  2. Pokud existují nějaké aktualizace, zvolte zda je chcete stáhnout a nainstalovat.
  3. Pokud chcete umožnit automatické pravidelné kontroly aktualizací, zvolte poté, když Manažer instalací SOLIDWORKS dokončí proces, Kontrolovat aktualizace každých ___ dní a určete frekvenci kontrol.
Nadřazené téma
Instalace je dokončena
Související pojmy
Program na zlepšení zkušeností zákazníků SOLIDWORKS


Program na zlepšení zkušeností zákazníků SOLIDWORKS

Při instalaci SOLIDWORKS můžete zadat, že se mají společnosti SOLIDWORKS Corporation odesílat informace o výkonu za účelem vylepšení produktu.

Společnost SOLIDWORKS používá tyto informace k určení trendů týkajících se používání produktu a jeho kvality. Naším cílem je poskytovat produkt nejlepší kvality a soubory protokolu o výkonu jsou velmi užitečným nástrojem v tomto procesu.

Tento proces je transparentní. Všechny informace obsažené v těchto souborech protokolu jsou zpracovávány důvěrně. Tyto soubory neslouží k jiným účelům a nikdo vás nebude kontaktovat.

Více informací viz Webová stránka Programu na zlepšení zkušeností zákazníků.

Nadřazené téma
Instalace je dokončena
Související úlohy
Zjistit aktualizace SOLIDWORKS


Umístění instalace

Určete umístění instalace SOLIDWORKS.

Pro instalace kromě vytvoření administrativní kopie tyto možnosti zahrnují:
Nainstalovat vybrané produkty do | Toto je umístění adresáře, do kterého instalujete SOLIDWORKS. Když provádíte upgrade nebo měníte instalaci, všechny soubory musí být nainstalovány do existujícího místa pro tuto instalaci. V tomto případě nemůžete změnit místo stávající instalace SOLIDWORKS.
Odhadované místo na disku požadované pro instalaci | Toto je doplňkové místo na disku potřebné pro instalaci nebo změnu vybraných součástí. | Ověřte, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Instalovat z | Toto je umístění adresáře, ze kterého instalujete SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti naleznete v části Možnosti stahování.
Než změníte umístění instalace SOLIDWORKS, kontaktujte správce systému.

Umístění administrativní kopie

Když vytváříte administrativní kopii, jsou použity tyto možnosti:
Umístění nové kopie | Toto je umístění adresáře, ve kterém Manažer instalací SOLIDWORKS vytvoří novou kopii. | Toto umístění nemůže obsahovat existující administrativní kopii.
Odhadované místo na disku požadované pro vytvoření kopie | Toto je doplňkové místo požadované pro administrativní kopii. | Ověřte si, zda je na disku, na který chcete instalovat, dostatek volného místa pro podporu požadavků instalace.
Vytvořit kopii z | Toto je umístění adresáře, ze kterého instalujete produkty SOLIDWORKS. Tato volba se objeví jen tehdy, pokud je určena možnost Pouze instalovat. Podrobnosti naleznete v části Možnosti stahování.
Umístění stávající kopie | Když provádíte upgrade administrativní kopie, Manažer instalace SOLIDWORKS vytvoří novou kopii založenou na nastaveních pro tuto existující kopii. Tato existující kopie se nemění. Ukazuje umístění původní kopie, kterou jste určili na obrazovce Uvítání.

Zabránění použití cest adresáře specifických pro verzi

Pokud určíte číslo verze v umístění adresáře instalace (například C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2015\), a pak provedete upgrade této instalace na SOLIDWORKS 2016, bude instalační adresář SOLIDWORKS 2016 označen jako SOLIDWORKS 2015.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související odkazy
Možnosti stažení


Možnosti upgradu

V tomto počítači je nainstalována jedna nebo více starších významných verzí SOLIDWORKS. Vyberte, jestli provedete upgrade poslední existující verze na novou verzi nebo vytvoříte novou instalaci pro novou verzi.

Tato možnost se objeví pouze tehdy, když není žádná předchozí verze této významné verze instalována na tomto počítači. Pokud je instalována předchozí významná verze, Manažer instalací SOLIDWORKS vždy aktualizuje tuto instalaci.

(Počínaje verzí SOLIDWORKS 2010, nejsou už paralelní instalace více verzí aktualizací Service Pack stejné významné verze podporovány.)

Když provádíte upgrade:
  • U všech určených produktů byl proveden upgrade.
  • Všechny instalované produkty jsou standardně vybrány .
  • Pokud produkt odeberete, na tomto produktu se již neprovede upgrade.
    Pokud odeberete součást produktu, neurčujete, že tento Manažer instalace SOLIDWORKS tuto součást odstraní. Pro odebrání součásti produktu použijte funkci Přidat nebo odebrat programy. Podrobnosti viz Odstranění instalace.

Vyberte vhodnou možnost a klepněte na Další pro pokračování.

Vytvořit novou instalaci SOLIDWORKS verze.

Pokud si zvolíte tuto možnost, zůstane starší verze instalace zachována navíc k vytvořené nové instalaci této hlavní verze.

To může být užitečné především tehdy, pokud chcete mít přístup ke starší verzi SOLIDWORKS i poté, co byla nainstalována novější verze. Pokud například sdílíte soubory s jinými uživateli, kteří stále používají starší verzi, můžete tak zabránit problému s kompatibilitou se soubory, uloženými s použitím novější verze.

Upgrade SOLIDWORKS předchozí_hlavní_verze na SOLIDWORKS aktuální_hlavní_verze.

Pokud vyberete tuto možnost, provede se upgrade starší verze instalace na novou verzi.
Jakmile je instalace kompletní, starší verze SOLIDWORKS už nebude na tomto počítači k dispozici.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související úlohy
Odstranění instalace


Průběh instalace

Tato obrazovka uvádí průběh instalace.

Chcete-li v průběhu zrušit instalaci, klepněte na Storno.

Další informace o zrušených instalacích a pokyny k dokončení přerušených instalací najdete v tématu Chyby během instalace.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Typ instalace

Určete operaci instalace, kterou chcete spustit, jako je vytvoření nové instalace, úprava nebo oprava existující instalace, vytvoření administrativní kopie, instalace administrativních produktů serveru nebo stažení souborů bez instalace.

Individuální

Nainstalovat produkty SOLIDWORKS na tento počítač.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.

Změnit individuální instalaci

Změnit stávající instalaci SOLIDWORKS v tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.
Změny zahrnují:
  • Přidání nebo odebrání součástí produktu SOLIDWORKS
  • Změna na jiný balíček SOLIDWORKS (například SOLIDWORKS Professional, SOLIDWORKS Premium atd.)
  • Změna nastavení sériového čísla SOLIDWORKS
    Pokud jste již zadali sériové číslo SOLIDWORKS během předchozí instalace, Manažer instalací SOLIDWORKS vás k tomu znovu nevyzve. Pro změnu sériového čísla, které předpokládá Manažer instalací SOLIDWORKS, musíte vybrat tuto možnost.

Opravit individuální instalaci

Opravit stávající instalaci SOLIDWORKS v tomto počítači.

Tato volba se objeví jen tehdy, pokud tato verze není aktuálně instalována na tomto počítači.
Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.
Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte ji znovu nainstalovat za použití nové administrativní kopie.

Administrativní kopie

Na tomto počítači vytvořte nebo aktualizujte administrativní kopii.

Můžete použít administrativní kopii pro instalaci na více počítačích. Podrobnosti o instalaci SOLIDWORKS pro více klientů za pomoci administrativních kopií viz Používá administrativních kopií.

Když vytváříte nebo aktualizujete administrativní kopie:
  • Můžete použít nastavení instalace z existující kopie pro konfiguraci nové nebo aktualizované kopie nebo můžete použít výchozí nastavení instalace SOLIDWORKS.
  • Pokud aktualizujete existující kopii:
    • Manažer instalací SOLIDWORKS vytvoří novou kopii kopie, dokonce i pokud aktualizujete. Původní kopie se nemění.
    • Můžete vytvořit nebo aktualizovat kopii za použití souborů z existující kopie, kterou aktualizujete. Výsledkem je menší stažení.
    Pokud neurčíte kopii, pro kterou je k dispozici verze servisního balíčku pro aktualizaci předchozí kopie, nemůžete využít předností menšího stahování.

Produkty pro servery

Administrativní serverové produkty SOLIDWORKS zahrnují SOLIDWORKS Electrical, SOLIDWORKS Workgroup PDM Server (úschovna), SOLIDWORKS PDM a Manažer licencí SolidNetWork.

U aplikace SOLIDWORKS Electrical a SOLIDWORKS PDM je možné zvolit instalaci nástrojů klienta a serveru na stejný počítač nebo na různé počítače.

Podrobnosti o instalaci na tyto servery najdete v odpovídajících tématech nápovědy.

Pouze stáhnout

Stáhnout soubory instalací pro vybrané produkty SOLIDWORKS bez jejich instalace.

Tato možnost není k dispozici, když instalujete z disku DVD.

Obsah stažených souborů je stejný jako souborů, které jsou k dispozici na instalačních discích DVD SOLIDWORKS. Pokud vyberete tuto možnost, stáhne se plná sada instalačních souborů bez ohledu na to, které soubory již případně byly nainstalovány na vašem počítači.

Tento způsob je vhodný pro nastavení serveru, ze kterého mohou uživatelé provádět instalace. Tento způsob se liší od vytvoření administrativní kopie.

Instalování chybné architektury SOLIDWORKS v tomto počítači

Pokud se snažíte provést instalaci pomocí instalačního média nevhodného pro architekturu tohoto počítače (například, pokud instalujete 64bitový program SOLIDWORKS do 32bitového počítače), měl by instalační panel tento problém nahlásit.

Pokračování v instalaci:
  1. Zrušte tuto relaci Manažera instalací SOLIDWORKS.
  2. Zkontrolujte architekturu a systémové požadavky tohoto počítače.
  3. Znovu proveďte instalaci se správným instalačním médiem programu SOLIDWORKS pro architekturu tohoto počítače.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související pojmy
Použití administrativní kopie
SOLIDWORKS Workgroup PDM
Správa licencí za použití manažera licencí SolidNetWork
SOLIDWORKS Electrical


Instalace a správa několika počítačů

Manažer instalací SOLIDWORKS poskytuje následující nástroje na instalaci a správu několika počítačů SOLIDWORKS.

Administrativní kopie SOLIDWORKS

Pokud instalujete program SOLIDWORKS na více počítačích, můžete vytvořit administrativní kopii a poté ji nainstalovat na ostatní počítače.

Server Workgroup PDM

PDM Workgroup je program pro správu dat projektů. Běží buď v prostředí programu SOLIDWORKS, nebo jako samostatná aplikace v rámci Průzkumníka SOLIDWORKS. Při instalaci serveru PDM Workgroup je vytvořena úschovna PDM Workgroup, která je databází obsahující spravované projekty SOLIDWORKS.

Podpora SOLIDWORKS Workgroup PDM bude po verzi SOLIDWORKS 2017 ukončena. Zákazníci, kteří již software SOLIDWORKS Workgroup PDM používají, ho mohou nadále instalovat, ale měli by začít plánovat migraci úschoven na SOLIDWORKS PDM Server.

SOLIDWORKS PDM

SOLIDWORKS PDM je produkt pro správu dokumentů založený na stejné architektuře jako SOLIDWORKS Enterprise PDM. Je dostupný ve dvou verzích: Standard a Professional. SOLIDWORKS PDM používá pro správu úschoven databázi Microsoft SQL Server.

Manažer licencí SolidNetWork

Manažer licencí SolidNetWork umožňuje, aby počet uživatelů přesáhl počet licencí, pomocí plovoucích licencí. Pokud není klientská licence využívána, je k dispozici pro jiného uživatele SOLIDWORKS.

K rozdělení licencí pro doplňkové moduly jádra SOLIDWORKS (například FeatureWorks) můžete také použít Manažera licencí SolidNetWork.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Ruční stahování

Zvolili jste stáhnout soubory ručně (nebo jste možná vybrali ruční stažení, když jste naposledy spustili Manažera instalací SOLIDWORKS).

Klepněte na odkaz pro otevření automaticky generované webové stránky, která obsahuje kompletní seznam souborů, které potřebujete ke stažení.

Musíte je stáhnout do složky určené na stránce Souhrn. Instalace nemůže začít dokud nejsou všechny soubory stažené do této složky.

Jakmile jste dokončili ruční stahování, klepněte na Další pro pokračování.

Pokud chcete provést stahování automaticky, můžete změnit možnost návratem na stránku Souhrn a změnou možnosti stažení.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


K dispozici je novější verze

Manažer instalací zaznamenal novější verzi produktů SOLIDWORKS. Můžete buď nainstalovat verzi obsaženou na původním instalačním DVD nebo ve stažení, nebo můžete stáhnout a nainstalovat novou verzi.

Instalace z DVD

V části Chcete používat novější verzi?, vyberte následující:
  • Ne, pokračovat v instalaci version z tohoto DVD. Je možné aktualizovat s menším stažením.

    Vyberte tuto možnost, pokud chcete pokračovat v instalaci prostřednictvím stávajícího Manažera instalací.

    Po dokončení instalace můžete zkontrolovat a nainstalovat aktualizace pomocí Manažera instalací. Chcete-li zjistit aktualizace, spusťte z nabídkyStart > Manažer instalací SOLIDWORKS > Zjistit aktualizace.

    Výhodou této možnosti je, že stažení je menší. Nevýhodou je, že se jedná o dvou stupňový proces a stažené soubory jsou specifické pro určitou verzi (a nelze je sdílet s ostatními uživateli, kteří používají jiné verze).

  • Ano, provést instalaci pomocí tohoto DVD, pak stáhnout a aktualizovat na version.

    Tato možnost slouží ke stažení a spuštění starší verze Manažera instalací, aby bylo možné nainstalovat produkty SOLIDWORKS pro tuto verzi.

    Pokud je pro aktualizací verze DVD k dispozici malá verze servisního balíčku, Manažer instalací nejprve nainstaluje původní verzi z DVD a pak použije aktualizaci servisního balíčku. Výsledkem je menší stažení.

    Můžete dosáhnout stejného výsledku výběrem možnosti pokračovat v instalaci z DVD a pak později použít aktualizaci.

    Výhodou této možnosti je, že jde o jednorázový postup.

Ve většině případů je preferována instalace plné verzi z DVD a poté zjištění a instalace aktualizací pomocí Manažera instalací, protože tato možnost vyžaduje menší stažení.

Instalace ze stažení

Vyberte jednu z následujících možností:
  • Pokračovat v instalaci version.

    Vyberte tuto možnost a pokračujte v instalaci verze obsažené v počátečním stažení.

  • Stáhnout a nainstalovat novou verzi: version

    Vyberte tuto možnost, stáhněte novou verzi a nainstalujte ji. Pokud je k dispozici několik nových verzí, můžete vybrat verzi ke stažení a nainstalovat ji.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Nejsou k dispozici novější verze

Novější verze nejsou k dispozici pro stažení. Pokračovat v instalaci určené verze.

Pro pokračování v instalaci klepněte na Další.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Zjištěné procesy

Manažer instalací SOLIDWORKS zjistil procesy na tomto počítači, které by mohly zabránit úspěšné instalaci.

  • Pro pokračování v instalaci proveďte jednu z následujících možností:
    • Ukončete tyto procesy (například za použití Správce úloh Microsoft Windows) a pak stiskněte Opakovat.
    • Klepněte na Ignorovat a pokračujte bez uzavření procesů.
  • Pro zastavení instalace stiskněte Storno.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Výběr produktu

Určete součásti produktu, které chcete nainstalovat, upravit nebo odebrat.

V seznamu produktů:
  • Seznam produktů je kompletní seznam, který je k dispozici v balíčku určeném nad seznamem produktů.
  • Pokud chcete zobrazit promítnutou akci pro konkrétní součást, klepněte na název součásti (ale ne na zaškrtávací políčko). Plánovaná akce instalace se objeví v informačním poli pod seznamem produktů.
  • Chcete-li změnit akci instalace pro danou součást, můžete klepnout na zaškrtávací políčko vedle součásti produktu. (Pokud například instalujete nebo odebíráte součást, výběrem zaškrtávacího políčka určíte, že se má součást nainstalovat nebo odebrat a zrušením výběru tohoto políčka určíte, že se daná součást instalovat nebo odebírat nemá.)
  • Pokud provádíte instalaci Úpravy, nalevo od součástí se objeví (*), když provedete jakoukoliv změnu u vybraného produktu.
  • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona -. Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu -.

Pokud používáte servisní balíček, nelze vybrat funkce SOLIDWORKS, které se zobrazují pod položkou SOLIDWORKS (například FeatureWorks). Pokud vyberete tento typ upgradu, není možné přidat nebo odstranit jednotlivé funkce.

Akce provedené Manažerem instalací SOLIDWORKS jsou ovládané sadou pravidel koexistence produktu. Podrobnosti naleznete v části Pravidla koexistence produktu.

Manažer instalací SOLIDWORKS vybere standardně tyto součásti produktu:
  • Pokud provádíte upgrade nebo aktualizaci service pack, Manažer instalací SOLIDWORKS zvolí produkty, které jsou v současnosti nainstalovány.
  • Jinak Manažer instalací SOLIDWORKS vybere všechny produkty, ke kterým máte oprávnění.
Pro zkrácení doby stahování a zmenšení požadovaného místa na disku rozbalte součásti produktu a zrušte zaškrtnutí políčka u součástí, které nepotřebujete.

Pokud Manažer instalací SOLIDWORKS nebyl schopen ověřit produkty, které jste oprávněni používat, můžete klepnout na Vybrat jiný balíček nebo produkty a změnit tak balíček produktů (jako například SOLIDWORKS Professional nebo SOLIDWORKS Premium), které jsou uvedeny v seznamu k instalaci nebo změně. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS na vašem instalačním médiu, jenž jsou kompatibilní s vybraným balíčkem. Můžete vybrat jakékoli produkty, které jste zakoupili nebo jste oprávněni vyzkoušet.

Vyhledávání v SOLIDWORKS

Vyhledávání v SOLIDWORKS poskytuje výkonné fulltextové vyhledávání dokumentů SOLIDWORKS, dokumentů v úschovně PDM Workgroup a v 3D ContentCentral. Vyhledávání zobrazí náhled, umístění souborů a název.

Po dokončení instalace SOLIDWORKS vyhledávání indexuje dokumenty SOLIDWORKS pro rychlejší vyhledávání. Pouze soubory SOLIDWORKS jsou indexovány automaticky.

Instalace SOLIDWORKS vyhledávání automaticky nainstaluje Windows Desktop Search, pokud ještě není nainstalován ve vašem počítači.

Jazyková podpora

Rozbalením produktu SOLIDWORKS a součásti Jazyky se zobrazí jazyky, které lze nainstalovat.

Specifikace Jazyky vymezuje jazyky, které se instalují pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například programy eDrawings®, SolidWorks Workgroup PDM, Průzkumník SOLIDWORKS a SOLIDWORKS PDM instalují všechny jazyky.

Potřebné místo na disku

Manažer instalací SOLIDWORKS dole na stránce hlásí buď celkovou velikost instalace, nebo celkovou velikost stažení.

  • Pokud jste vybrali možnost Pouze stáhnout, objeví se velikost stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.
    V celkové velikosti stažení jsou zahrnuty všechny soubory potřebné k instalaci. Nebudou znovu staženy soubory, které jsou již obsaženy v aktuální složce pro stažení. To znamená, že velikost stažení může být menší než zobrazená celková velikost stažení, nebo nebudete muset stáhnout žádné soubory.
  • Jinak se zobrazí velikost instalace. Velikost instalace se rovná změně ve využití místa na disku, ke kterému dojde po dokončení instalace. V důsledku komprimace souboru se jedná pouze o odhady.

    Pokud upgradujete, nebo odstraňujete stávající instalaci, může se velikost instalace rovnat nule.

    Zobrazené číslo nezahrnuje místo potřebné ke stažení, nebo k extrahování souborů požadovaných k instalaci.

    Pokud je vyžadováno stažení a stahujete do stejné jednotky, mohou být požadavky na místo na disku daleko větší než je uvedená velikost instalace.

    Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související pojmy
Pravidla koexistence produktu


Produkty ke stažení

Vyberte produkty SOLIDWORKS, které se mají stáhnout do určitého umístění.

V závislosti na zadaném sériovém čísle se zobrazí odpovídající produkty ke stažení:

  • Operace, která má být provedena pro každou součást, se zobrazí na pravé straně.
  • Pokud je u součásti k dispozici volitelná instalace dílčích součástí, zobrazí se vedle součásti ikona +. Chcete-li zobrazit dostupné dílčí součásti pro danou součást, klepněte na ikonu +.
  • V případě rozbalení součásti a zobrazení volitelných dílčích součástí se vedle součásti zobrazí ikona -. Chcete-li sbalit výpis dílčích součástí, klepněte na ikonu -.
  • Klepnutím na ikonu umístěnou vlevo od součásti vyberte způsob, jakým ji Manažer instalací SOLIDWORKS má zpracovat.
Pokud neurčíte jinak, Manažer instalací SOLIDWORKS stáhne všechny součásti produktu, ke kterým máte oprávnění. Pro zkrácení doby stahování a zmenšení požadovaného místa na disku rozbalte součásti produktu a vyberte součásti, které nepotřebujete.

Pokud Manažer instalací SOLIDWORKS nebyl schopen ověřit produkty, které jste oprávněni používat, můžete ke stažení vybrat balík SOLIDWORKS. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS, jenž jsou kompatibilní s vybraným balíčkem.

Pokud Manažer instalací SOLIDWORKS nebyl schopen ověřit produkty, které jste oprávněni používat, můžete klepnout na Vybrat jiný balíček nebo produkty a změnit tak balíček produktů (jako například SOLIDWORKS Professional nebo SOLIDWORKS Premium), které jsou uvedeny v seznamu k instalaci nebo změně. Manažer instalací SOLIDWORKS zobrazí seznam všech produktů SOLIDWORKS na vašem instalačním médiu, jenž jsou kompatibilní s vybraným balíčkem. Můžete vybrat jakékoli produkty, které jste zakoupili nebo jste oprávněni vyzkoušet.

Jazyková podpora

Specifikace Jazyky omezuje jazyky, které jsou nainstalovány jen pro produkt SOLIDWORKS. Toto nastavení nemá vliv na instalace ostatních produktů. Například programy eDrawings®, SOLIDWORKS Workgroup PDM a Průzkumník SOLIDWORKS instalují všechny jazyky.

Potřebné místo na disku

V závislosti na vybraném produktu se zobrazí požadované místo ke stažení. Velikost stažení je celkové množství místa na disku vyžadovaného pro všechny stahované soubory (nezahrnuje místo požadované pro dekomprimaci souborů po dokončení stažení). Toto číslo je pouze odhad.

Pokud chcete u budoucích aktualizací a oprav snížit dobu na stažení a instalaci, neodstraňujte po instalaci stažené soubory. Následující aktualizace a opravy většinou vyžadují přístup k poslední sadě souborů úplné instalace.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Produkty k opravě

Když vyberete možnost Opravit tuto instalaci, zobrazí se obrazovka obsahující produkty SOLIDWORKS spolu s čísly verzí, které je možné opravit pomocí Manažera Instalací SOLIDWORKS.

Při opravě dojde k ověření, zda jsou přítomny všechny soubory a zda jsou správně zaregistrovány. Opravy nemají vliv na vytvořená data.
  • Chcete-li produkt opravit, ujistěte se, že je vybraný.
  • Zrušte výběr produktů, které nechcete opravit.

Klepnutím na Opravit zahájíte opravu vybraných produktů.

Je možné opravit individuální instalaci. Instalaci administrativní kopie nelze opravit; musíte znovu nainstalovat administrativní kopii.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Sériová čísla

Sériová čísla, která se nacházejí na balení, přiřazují zakoupené produkty SOLIDWORKS k vašemu počítači.

Pokud jsou ve vašem počítači již nainstalované produkty SOLIDWORKS, budou jejich sériová čísla automaticky zobrazena.
  • Zadejte sériové číslo pro SOLIDWORKS, pokud ještě není zobrazeno.
  • Pokud máte sériová čísla pro produkty, které ještě nebyly zahrnuty do vaší licence SOLIDWORKS, klepněte na produkt pod Máte jiná sériová čísla? a zadejte sériové číslo tohoto produktu.

Pokud máte připojení k internetu, budou sériová čísla během instalace použita k zobrazení produktů, ke kterým máte oprávnění, abyste mohli vybrat produkty k instalaci.

Některá sériová čísla mohou sloužit pro dva nebo více produktů, protože existuje několik způsobů zakoupení produktů SOLIDWORKS. Například sériové číslo SOLIDWORKS vám umožní nainstalovat SOLIDWORKS Simulation bez zadání sériového čísla SOLIDWORKS Simulation. Navíc některé produkty nevyžadují sériové číslo. Pokud máte jakékoliv dotazy ohledně sériových čísel, kontaktujte místního prodejce.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Instalace serveru

Produkty serveru, které instalujete, jsou uvedeny v seznamu s výsledkem instalace.

Stav instalace serveru

Instalace produktů serveru se provádějí pomocí externí instalační aplikace. Pokud se právě v této aplikace nenacházíte, musíte na ni přepnout, abyste instalaci dokončili.

Klepněte na Storno pro ukončení instalace produktů serveru.

Instalace serveru byla dokončena

Externí instalační aplikace byla úspěšně dokončena.

Klepněte na Dokončit nebo Další.
  • Pokud instalujete jiné administrativní produkty (například administrativní kopii SOLIDWORKS ), tato instalace pokračuje.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SOLIDWORKS se zavře.

Instalace serveru byla zrušena nebo se nepodařila

Pokud se instalace serveru nepodařila nebo byla zrušena, na seznamu budou uvedeny servery, které nebyly nainstalovány.

Klepněte na Zavřít nebo Další.
  • Pokud jste zadali jiné administrativní instalace produktů, Manažer instalací SOLIDWORKS se obnoví.
  • Pokud instalace produktů serveru byla jediná instalační operace, Manažer instalací SOLIDWORKS se zavře.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Manažer licencí SolidNetWork

Zadejte instalační volby pro produkt pro server Manažer licencí SolidNetWork.

Sériová čísla

Zadejte sériová čísla licence SolidNetWork. Můžete zadat více sériových čísel a oddělit je čárkami.
Sériová čísla SolidNetWork jsou odlišná od sériových čísel SOLIDWORKS.

Umístění instalace

Určete umístění instalace pro Manažera licencí SolidNetWork.

Pokud aktualizujete stávajícího Manažera licencí SolidNetWork, musíte jej nainstalovat do stávajícího umístění pro instalaci.

Pro více informací

Podrobné informace o instalaci, konfiguraci a používání Manažera licencí SolidNetWork viz Správa licencí za použití manažera licencí SolidNetWork.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související pojmy
Správa licencí za použití manažera licencí SolidNetWork


Souhrnné informace

Manažer instalací SOLIDWORKS má všechny potřebné informace pro dokončení instalace.

Chcete-li pokračovat: | Klepnutím na tlačítko akce Nyní zahájíte instalaci (například Instalovat nyní, Vytvořit nyní, Stáhnout nyní, Upravit nyní).
Postup při změně nastavení instalace: | Klepněte na ZMĚNA [image] pro část, kterou chcete změnit (například Produkty, Umístění instalace, Možnosti Toolbox).
Pro zrušení: | Klepněte na Storno pro ukončení Manažera instalací SOLIDWORKS bez změny součástí instalace.
Pokud se chcete vrátit na předchozí stránku: | Klepnutím na Zpět se v Manažeru instalací SOLIDWORKS vrátíte na předchozí stránku.
Další informace o určité sadě možností instalace (například Produkty, Umístění instalace, Možnosti Toolbox atd.):
  1. Klepněte na tlačítko ZMĚNA [image] vedle části, pro kterou potřebujete informace.
  2. Na podrobné stránce, která se objeví, klepněte na Nápověda pro získání informací o příslušném nastavení možností instalace.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Upozornění kontroly systému

Kontrola systému prověřuje oznámené problémy, které by mohly mít dopad na průběh instalace. Ve většině případů byste měli být schopni pokračovat dále s Manažerem instalací SOLIDWORKS.

Níže jsou uvedena varování, s nimiž se můžete v této fázi setkat, spolu s doporučením, jak pokračovat.

Problém s ověřením sériového čísla

Manažer instalací nezjistil nové verze, protože nemohl ověřit vaše sériové číslo. Pokud jste připojeni a zadali jste platné sériové číslo, může se jednat o dočasný problém na našem serveru. Zkuste to znovu později.

Ověření sériového čísla: Manažer instalací nemohl ověřit vaše sériové číslo, a tím určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. K instalaci budete muset poskytnout kompletní sadu zdrojových souborů nebo DVD.

Rozlišení:
  • Zkontrolujte připojení k internetu. Kontrola sériového čísla vyžaduje platné internetové připojení.
  • Zkontrolujte, zda vámi zadané sériové číslo je platné pro produkty, které chcete instalovat.
  • Některé instalace vyžadují, abyste měli v době vydání příslušné verze aktivní předplatitelskou službu., Podrobnosti vám sdělí váš prodejce SOLIDWORKS.
  • Ve většině případů můžete pokračovat v instalaci, za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.

Dostupná novější verze

Dostupná novější verze

Jsou k dispozici novější verze.

Novější verze tohoto produktu je k dispozici pro stažení.

Rozlišení: Když se provádí operace Zjistit aktualizace, instalační program může zobrazit výzvu k instalaci novější verze, která je dostupná ke stažení ze SOLIDWORKS. V této operaci můžete pokračovat s použitím verze, kterou jste na počátku specifikovali, nebo můžete stáhnout tuto novější verzi a pokračovat v operaci s použitím této verze.

Nejnovější dostupná verze

Toto je nejnovější dostupná verze. Pokračujte klepnutím na Další.

Žádná nová stažení

Řešení: Tato zpráva se může objevit, když kontrolujete aktualizace během instalace nebo změny. Informuje o tom, že právě instalujete (nebo jste nainstalovali) nejnovější dostupnou verzi.

Problémy s internetovým připojením

Internetové připojení: Manažer instalací se nemohl připojit k serveru SOLIDWORKS a určit, které produkty jste oprávněni nainstalovat. Budete si i nadále moci zvolit produkty, které chcete nainstalovat, ale nebudete moci stáhnout žádné instalační soubory. Bude potřeba poskytnout zdrojové soubory na DVD nebo z dříve stažené sady souborů.

Nepodařilo se zjistit nové verze

Manažer instalací nezjistil nové verze, protože se nemohl připojit k serveru.

Řešení:
  • Zkontrolujte připojení k internetu.
  • Můžete pokračovat v instalaci za předpokladu, že ji provádíte z DVD nebo z dříve stažené sady souborů.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti Průvodce dírami/Toolbox

Pokud je SOLIDWORKS Toolbox instalován, obsahuje software SOLIDWORKS knihovnu standardních typů děr stejně jako hardware.

Pokud se chcete dozvědět podrobnosti o konfiguraci, rozšíření a použití SOLIDWORKS Toolboxu, klepněte v SOLIDWORKS na Nápověda > Nápověda Toolboxu.
Pro zobrazení této nápovědy můžete nastartovat doplňkový modul Toolbox pomocí Nástroje > Doplňkové moduly.

Než začnete používat SOLIDWORKS Toolbox, ujistěte se, že je správně nakonfigurovaný podle zásad vaší společnosti nebo skupiny. V mnoha případech bude centrální Toolbox konfigurovat a spravovat skupina. Požádejte správce SOLIDWORKS o radu, jak při instalaci SOLIDWORKS zadat Toolbox.

Zvolený SOLIDWORKS Toolbox můžete po instalaci změnit. V SOLIDWORKS klepněte na Nástroje > Možnosti. Na záložce Možnosti systému klepněte na Průvodce dírami/Toolbox.

Následující sekce popisují všechny možnosti, se kterými se můžete setkat na této obrazovce, pro všechny konfigurace. Aktuální možnosti Toolboxu, které vidíte, závisejí na předchozích konfiguracích SOLIDWORKS a Toolboxu na tomto počítači a možnostech Manažera instalací SOLIDWORKS, které jste v tomto bodě určili.

Vytvořit nový Toolbox nová-verze

Vytvořte novou verzi SOLIDWORKS Toolboxu na tomto počítači.

Při vytváření nové verze rozbalte na obrazovce Výběr produktu SOLIDWORKS > SOLIDWORKS Toolbox a vyberte, které normy bude Toolbox podporovat. Všechny normy jsou standardně vybrány.

Jakékoliv již stávající Toolboxy na tomto počítači se nezmění.

Vytvořit odkaz nebo provést upgrade u stávajícího Toolbox

Použít stávající Toolbox Klepněte na Procházet pro určení místa Toolbox, který chcete použít s touto instalací.

  • Pokud je Toolbox konfigurován pro předchozí hlavní finální verzi SOLIDWORKS, provede se upgrade na tuto verzi. Jakékoliv přizpůsobení provedené na tomto Toolbox je v upgradovaném Toolbox zachováno.
    Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.
  • Pokud je Toolbox konfigurován pro tuto verzi SOLIDWORKS (což může být v případě, že jste určili sdílenou síť Toolboxu, u které byl již proveden upgrade), na tomto Toolboxu se upgrade neprovede.
  • Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky týkající se konfigurování SOLIDWORKS Toolboxu.

Tato možnost se objeví ve všech instalačních scénářích kromě vytvoření administrativní kopie.

Provést upgrade Toolbox předchozí-verze

Nakopírujte Toolbox konfigurovaný pro předchozí hlavní verzi do nového umístění a proveďte upgrade této kopie na tuto verzi.

Tato možnost se objeví, pokud je předchozí hlavní verze SOLIDWORKS instalována na tomto počítači, ale vy jste se rozhodli, že u této instalace na tuto verzi upgrade neprovedete.
Účelem této možnosti je provést upgrade Toolboxu pro předchozí hlavní verzi SOLIDWORKS, která je instalována, aniž by to mělo dopad na uživatele starší verze Toolboxu.

Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky týkající se konfigurování SOLIDWORKS Toolboxu.

Provést upgrade tohoto nainstalovaného Toolbox předchozí-verze

Proveďte upgrade tohoto Toolbox na novější verzi.
Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.

Tato možnost se objeví, pokud provádíte upgrade předchozí hlavní verze SOLIDWORKS na tuto verzi a na počítači je nalezen Toolbox konfigurovaný pro tuto verzi.

Pokud provádíte upgrade na Toolbox v prostředí SOLIDWORKS PDM, je nutno provést další postupy. Podrobnosti najdete v Poznámky týkající se konfigurování SOLIDWORKS Toolboxu.

Použít nainstalovaný Toolbox aktuální-verze

Manažer instalací SOLIDWORKS zjistil na tomto počítači Toolbox konfigurovaný pro tuto hlavní verzi SOLIDWORKS.

Pokud vyberete tuto možnost, SOLIDWORKS tento Toolbox použije. Nedojde k žádnému upgrade.

Tato možnost se objeví, pokud je předchozí hlavní verze SOLIDWORKS instalována na tomto počítači, ale Toolbox je konfigurován pro tuto verzi. K tomu může dojít, pokud je Toolbox vytvořen na počítači, na kterém stále běží starší verze SOLIDWORKS.

Zadat umístění Toolbox pro klientský počítač

Zadejte síť nebo adresář jako výchozí umístění Toolboxu, když klienti instalují z administrativní kopie.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Tato možnost se objeví, pokud vytváříte novou administrativní kopii.

Proveďte upgrade nebo použijte Toolbox, na nějž se odkazuje ve stávající kopii pro klientský počítač

Použijte umístění Toolbox určené ve stávající administrativní kopii, kterou jste aktualizovali.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Výběr jiného umístění Toolbox pro klientský počítač

Zadejte jiné umístění Toolboxu než to, které je zadáno ve stávající administrativní kopii, kterou aktualizujete.
Pokud umístění obsahuje Toolbox konfigurovaný pro předchozí hlavní verzi SOLIDWORKS v době, kdy dochází ke klientské instalaci, Manažer instalací SOLIDWORKS provede upgrade tohoto Toolboxu.

Obsah

  • Poznámky o konfiguraci SOLIDWORKS Toolboxu

    SOLIDWORKS Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolboxu za použití Manažera instalací SOLIDWORKS.

  • Formát UNC

    Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS
Související pojmy
Poznámky o konfiguraci SOLIDWORKS Toolboxu


Poznámky o konfiguraci SOLIDWORKS Toolboxu

SOLIDWORKS Toolbox obsahuje velice užitečné a komplexní funkce. Toto téma shrnuje určité koncepty, které je nutno zohlednit před konfigurací Toolboxu za použití Manažera instalací SOLIDWORKS.

Zdroje dodatečných informací o SOLIDWORKS Toolboxu

Chcete-li získat podrobné informace o konfigurování, rozšiřování a používání SOLIDWORKS Toolboxu, klepněte v SOLIDWORKS na možnost Nápověda > Nápověda Toolbox.
Pro zobrazení této nápovědy můžete spustit doplňkový modul Toolbox pomocí nabídky Nástroje > Doplňkové moduly.

Použití sdíleného Toolbox

Když instalujete Toolbox, můžete mít data Toolbox na lokálním počítači nebo na sdíleném místě na síti. Doporučujeme uložení dat Toolbox na síti. Když použijete společné místo, všichni uživatelé SOLIDWORKS používají společně konzistentní sadu informací o šroubech.

Pokud je to první instalace, přejděte k nově sdílenému umístění, kam chcete provést instalaci Toolbox.

Provedení upgrade existujícího Toolbox

Pokud provedete upgrade Toolboxu na novou hlavní finální verzi SOLIDWORKS, není už Toolbox kompatibilní s počítači, na kterých běží předchozí hlavní finální verze SOLIDWORKS.

Pokud na jiných počítačích zůstane tato předchozí finální verze a dále budou vyžadovat, aby byl Toolbox konfigurován na tuto verzi, zhotovte kopii tohoto Toolbox a u této kopie proveďte upgrade. Nová instalace SOLIDWORKS provede upgrade nových souborů a předchozí instalace SOLIDWORKS bude nadále používat starý Toolbox.

Konfigurace přístupu do Toolbox

Když po instalaci máte přístup k součástem Toolboxu, SOLIDWORKS kontroluje, jak jste nakonfigurovali Toolbox a navrhuje zlepšení přístupu a výkonu.

Pro přístup ke sdílené síti Toolbox (doporučeno) použijte cestu UNC k serveru, na kterém je instalován sdílený Toolbox. Pro podrobnosti viz Formát UNC.

Správce může vytvořit heslo pro Toolbox a nastavit oprávnění a předvolby pro pracovní skupinu. Omezení přístupu ke konfiguraci a nastavení všeobecných předvoleb zajišťuje konzistentní data Toolbox.

Upgrade modulu Toolbox v prostředí SOLIDWORKS PDM

Když upgradujete software SOLIDWORKS, bude upgradován i Toolbox, pokud přidáte nějaké díly. Pokud se kořenová složka Toolbox nachází v úschovně SOLIDWORKS PDM, musíte před zahájením upgradu SOLIDWORKS připravit složku Toolbox.

U prvního systému, na kterém provádíte upgrade, musíte zkontrolovat databázi Toolbox a příkazem Načíst aktuální verzi stáhnout soubory Toolbox do lokální vyrovnávací paměti. U dalších systémů, které se upgradují, je jediným požadavkem stažení souborů Toolfix.

Než provedete upgrade:
  • Zkontrolujte, zda máte úplnou aktuální zálohu databáze úschovny a archivu.
  • Zkontrolujte, zda nejsou díly Toolbox vyzvednuté nebo nejsou použity v žádných aktuálně vyzvednutých sestavách.

Postup upgradu Toolbox:

  1. V aplikaci Průzkumník Windows se přihlaste do úschovny jako uživatel s plným oprávněním (vyzvednutí, odevzdání, přidání, mazání).
  2. Klepněte pravým tlačítkem na složku Toolbox a příkazem Načíst aktuální verzi zkopírujte všechny soubory Toolbox a databázi dílů do lokální vyrovnávací paměti.
    Pokud pracujete se vzdáleným archivním serverem, můžete tato operace několik minut trvat.
  3. Vyzvedněte databázi Toolbox (SWBrowser.mdb) ze složky \název_složky_Toolbox\lang\czech.
  4. Spusťte Manažera instalací SOLIDWORKS a proveďte upgrade.
  5. V okně Souhrnné informace zkontrolujte, zda je umístění instalace v nastavení Možnosti Toolbox nastaveno na úschovnu.

    Pokud ne, klepněte na Změnit, vyberte možnost Vytvořit odkaz nebo provést upgrade u stávajícího nástroje Toolbox a vyhledejte umístění Toolbox v úschovně.

  6. Po dokončení upgradu odevzdejte v aplikaci Průzkumník Windows složku Toolbox; tím budou do úschovny přidány veškeré nové a aktualizované soubory, takže ostatní uživatelé budou moci pracovat s nástrojem Toolbox.
  7. V případě upgradu na verzi SOLIDWORKS 2012 nebo novější přejděte do složky Toolboxu v úschovně a zkontrolujte, zda obsahuje následující soubory:
    • \název_složky_Toolbox\Updates
    • \název_složky_Toolbox\ToolboxStandards.xml
    • \název_složky_Toolbox\Browser\ToolboxFiles.index

      Pokud je nenajdete, obraťte se na svého prodejce produktů SolidWorks.

  8. Proveďte upgrade ostatních počítačů, které využívají integraci softwaru SOLIDWORKS PDM s modulem Toolbox:
    1. V aplikaci Průzkumník Windows se přihlaste do úschovny jako uživatel alespoň s oprávněním ke čtení ze složky Toolbox.
    2. Klepněte pravým tlačítkem na složku Toolbox a příkazem Načíst aktuální verzi zkopírujte soubory Toolbox do lokální vyrovnávací paměti.
    3. Spusťte správce instalací SOLIDWORKS a proveďte upgrade.

      Instalační program zjistí, zda již nebyl Toolbox upgradován.

Podrobnosti o konfiguraci modulu Toolbox v SOLIDWORKS PDM najdete v části Konfigurace Toolbox nápovědy Nástroje pro správu SOLIDWORKS PDM.

Nadřazené téma
Možnosti Průvodce dírami/Toolbox
Související odkazy
Formát UNC


Formát UNC

Jednotný (nebo univerzální) formát pro konvence názvů určuje syntax názvů souborů pro popis sdíleného umístění souboru.

\\server\volume\path

Příklad:

\\Disk_Server\SOLIDWORKS\AdminImage

Nadřazené téma
Možnosti Průvodce dírami/Toolbox
Související pojmy
Poznámky o konfiguraci SOLIDWORKS Toolboxu


Odinstalování produktů

Zvolíte-li v Ovládacích panelech možnosti Odebrat nebo Odinstalovat program, zobrazí se tato obrazovka s produkty SOLIDWORKS (s čísly verze), které lze odinstalovat pomocí této verze Manažera instalací SOLIDWORKS. Můžete určit, zda se má provést standardní, vlastní nebo úplná odinstalace.

Při standardní odinstalaci budou odstraněny programové soubory a složky produktu SOLIDWORKS. Ve výchozím nastavení jsou k odinstalování určeny všechny produkty SOLIDWORKS pro vybranou verzi.

Při vlastní odinstalaci bude odstraněna jedna nebo více z následujících položek: programové soubory a složky, klíče registru a datové složky (např. SOLIDWORKS Toolbox) a soubory a složky z původního umístění stažených dat.

Při úplné odinstalaci budou odstraněny instalační adresáře, klíče registru a datové složky.

Chcete-li odinstalovat produkt, postupujte takto:
  1. Zkontrolujte na obrazovce Odinstalace, zda je produkt vybrán.

    Pokud odinstalujete všechny produkty, bude odinstalován i Manažer instalací.

  2. Zrušte výběr produktů, které nechcete odstranit.

    Pokud zachováte kterýkoli produkt, Manažer instalací SOLIDWORKS odinstalován nebude.

  3. Určete, zda se má provést vlastní nebo úplná odinstalace.
    1. Klepněte na možnost Změnit v části Upřesňující možnosti.

      Zobrazí se okno Upřesňující možnosti. Je zaškrtnuta možnost Programové soubory a složky.

    2. Vyberte jednu nebo více možností, chcete-li provést vlastní odinstalaci, nebo všechny položky, pokud chcete provést úplnou odinstalaci.
    3. Klepněte na Zpět na souhrnné informace.
    4. V okně Souhrnné informace rozbalte položku Upřesňující možnosti; zobrazí se metoda a údaje o odinstalaci.
  4. Klepněte na Odstranit položky.
Když klepnete na Odstranit položky, Manažer instalací SOLIDWORKS začne okamžitě odstraňovat produkty.
Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Možnosti serveru Workgroup PDM

Zadejte instalační volby pro server SOLIDWORKS Workgroup PDM.

Umístění instalace

Zadejte instalační umístění pro produkty pro server SolidWorks Workgroup PDM.

Produkty k instalaci

Určete, které produkty pro server Workgroup PDM se mají instalovat:
Úschovna Workgroup PDM | Určete umístění pro data úschovny Workgroup PDM. Licence prohlížeče Workgroup PDM musí být nainstalována společně s úschovnou, aby bylo možné aktivovat Prohlížeč.
Prohlížeč Workgroup PDM | Při instalaci Prohlížeče Workgroup PDM musíte zadat název nebo IP adresu počítače s úschovnou Workgroup PDM, do níž bude Prohlížeč přistupovat.

Workgroup PDM API

Licence na Workgroup PDM API je zahrnuta v licencích pro klienty SOLIDWORKS a klienty Průzkumníka. API pro odevzdávání vyžadují licence pro klienty.

Pro více informací

Detaily o instalaci Workgroup PDM viz SOLIDWORKS Workgroup PDM.

Detaily o používání Workgroup PDM viz Workgroup PDM v nápovědě SOLIDWORKS.

Nadřazené téma
Nápověda aplikace Manažer instalací SOLIDWORKS


Právní ustanovení

© 1995–2015, Dassault Systemes SolidWorks Corporation, součást skupiny Dassault Systèmes SE, 175 Wyman Street, Waltham, Massachusetts, USA 02451 USA. Všechna práva vyhrazena.

Informace obsažené v tomto dokumentu a předmětný software se mohou bez předchozího upozornění změnit a neměly by proto být považovány za závazky společnosti Dassault Systemes SolidWorks Corporation (DS SolidWorks).

Žádný z materiálů nesmí být kopírován ani šířen v jakékoli podobě či jakýmkoli způsobem, elektronicky či ručně, bez výslovného písemného svolení společnosti DS SolidWorks.

Software, jehož se tento dokument týká, je šířen na základě licence a lze jej používat nebo kopírovat pouze v souladu s podmínkami licence. Veškeré záruky vztahující se k softwaru a dokumentaci k němu poskytnuté společností DS SolidWorks jsou upraveny v licenční smlouvě a žádné informace uvedené v tomto dokumentu nebo z něj vyplývající nesmí být považovány za změnu či doplnění těchto podmínek, včetně záruk v licenční smlouvě.

Patentová oznámení

Strojní 3D CAD software SOLIDWORKS® je chráněn patenty USA 5 815 154; 6 219 049; 6 219 055; 6 611 725; 6 844 877; 6 898 560; 6 906 712; 7 079 990; 7 477 262; 7 558 705; 7 571 079; 7 590 497; 7 643 027; 7 672 822; 7 688 318; 7 694 238; 7 853 940; 8 305 376, 8 581 902, 8 817 028, 8 910 078 a zahraničními patenty (např. EP 1 116 190 B1 a JP 3 517 643).

Software eDrawings® je chráněn patenty USA 7 184 044; 7 502 027 a kanadským patentem 2 318 706.

V USA a jiných zemích probíhá vyřizování dalších patentů.

Ochranné známky a názvy produktů pro produkty a služby SOLIDWORKS

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings a logo eDrawings jsou registrované ochranné známky a FeatureManager je registrovaná ochranná známka ve společném vlastnictví společnosti DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360 a TolAnalyst jsou ochranné známky společnosti DS SolidWorks.

FeatureWorks je registrovanou ochrannou značkou společnosti Geometric Ltd.

SOLIDWORKS 2016, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Workgroup PDM, SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, eDrawings, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical, SOLIDWORKS Composer a SOLIDWORKS MBD jsou názvy produktů společnosti DS SolidWorks.

Ostatní značky či názvy výrobků jsou ochrannými známkami nebo registrovanými ochrannými známkami příslušných vlastníků.

KOMERČNÍ POČÍTAČOVÝ SOFTWARE – CHRÁNĚNO PATENTY

Tento software je „komerční zboží“ podle definice v zákoně 48 C.F.R. 2.101 (říjen 1995). Sestává z „komerčního počítačového softwaru“ a „komerční softwarové dokumentace“ tak, jak jsou tyto pojmy použity v zákoně 48 C.F.R. 12.212 (SEPT 1995), a je poskytován americké vládě za účelem (a) pořízení pro správní úřady, v souladu se zásadami zákona 48 C.F.R. 12.212; nebo (b) pořízení pro útvary Ministerstva obrany v souladu se zásadami zákona 48 C.F.R. 227.7202-1 (červen 1995) a 227.7202-4 (červen 1995)

V případě, že obdržíte objednávku jakéhokoli úřadu americké vlády na tento software s právy, které překračují práva stanovená ve výše uvedeném paragrafu, oznámíte společnosti DS SolidWorks rozsah této žádosti a DS SolidWorks během pěti (5) pracovních dnů dle vlastního výhradního uvážení rozhodne, zda žádosti vyhoví, nebo ji odmítne. Smluvní strana/výrobce: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451, USA.

Autorské doložky pro produkty SOLIDWORKS Standard, Premium, Professional a vzdělávací verzi

Součásti tohoto softwaru © 1986–2015 Siemens Product Lifecycle Management Software Inc. Všechna práva vyhrazena.

Tato práce obsahuje následující software, který je majetkem společnosti Siemens Industry Software Limited:

D-Cubed™ 2D DCM © 2015. Siemens Industry Software Limited. Všecha práva vyhrazena.

D-Cubed™ 3D DCM © 2015. Siemens Industry Software Limited. Všecha práva vyhrazena.

D-Cubed™ PGM © 2015. Siemens Industry Software Limited. Všecha práva vyhrazena.

D-Cubed™ CDM © 2015. Siemens Industry Software Limited. Všecha práva vyhrazena.

D-Cubed™ AEM © 2015. Siemens Industry Software Limited. Všecha práva vyhrazena.

Součásti tohoto softwaru © 1998-2015 Geometric Ltd.

Součásti tohoto softwaru zahrnují PhysX™ by NVIDIA, 2006-2010.

Součásti tohoto softwaru © 2001–2015 Luxology, LLC. Všechna práva vyhrazena, patenty čekají na vyřízení.

Součásti tohoto softwaru © 2007–2015 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. a držitelé její licence. Všechna práva vyhrazena. Chráněno patenty USA 5 929 866; 5 943 063; 6 289 364; 6 563 502; 6 639 593; 6 754 382; probíhá vyřizování dalších patentů.

Adobe, logo Adobe, Acrobat, logo Adobe PDF, Distiller a Reader jsou registrovanými ochrannými známkami nebo ochrannými známkami společnosti Adobe Systems Inc. v USA a dalších zemích.

Další informace o autorských právech na software DS SolidWorks najdete v části Nápověda > O aplikaci SolidWorks.

Autorská práva pro produkty SOLIDWORKS Simulation

Části tohoto softwaru © 2008 Solversoft Corporation.

PCGLSS © 1992–2014 Computational Applications and System Integration Inc. Všechna práva vyhrazena.

Autorská práva pro produkt SOLIDWORKS Standard

© 2011, Microsoft Corporation. Všechna práva vyhrazena.

Autorská práva pro produkt SOLIDWORKS PDM Professional

Outside In® Viewer Technology, © 1992–2012 Oracle

© 2011, Microsoft Corporation. Všechna práva vyhrazena.

Autorská práva pro produkty eDrawings

Součásti tohoto softwaru © 2000–2014 Tech Soft 3D.

Části tohoto softwaru © 1995-1998 Jean-Loup Gailly and Mark Adler.

Součásti tohoto softwaru © 1998-2001 3Dconnexion.

Součásti tohoto softwaru © 1998–2014 Open Design Alliance. Všechna práva vyhrazena.

Části tohoto softwaru © 1995-2012 Spatial Corporation.

Software eDrawings® for Windows® je částečně založen na práci Independent JPEG Group.

Součásti softwaru eDrawings® for iPad® © 1996–1999, Silicon Graphics Systems, Inc.

Součásti softwaru eDrawings® for iPad® © 2003–2005 Apple Computer Inc.


Editor možností administrativní kopie

Editor možností administrativní kopie SOLIDWORKS byl vylepšen.

  • Správci mohou pomocí nových možností odinstalace provádět úplnou nebo vlastní odinstalaci na klientských počítačích. Možnosti odinstalace se nacházejí v části Možnosti klientské instalace v Editoru možností. Chcete-li si tyto možnosti zobrazit, klepněte na Ano, provést vlastní odinstalování a vyberte položky, které chcete odstranit.
  • Správci také mohou provést předvýběr norem pro softwaru SOLIDWORKS Toolbox ze seznamu.