SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）

このガイドは SOLIDWORKS 製品の個人インストレーションと複数インストレーションの両方におけるインストレーション、ライセンス管理、アップグレード、管理について説明します。

個人インストレーション | 複数インストレーションの展開
インストール 1台または数台のコンピュータへのインストレーション。 | インストール 複数のクライアント コンピュータに展開するアドミニストレーティブ イメージの作成。
ライセンス契約（Licensing） ライセンス アクティベーションまたはネットワーク ライセンス。 | ライセンス契約（Licensing） ライセンス アクティベーションまたはネットワーク ライセンス。
アップグレード 各コンピュータを新しいリリース版に移行。 | アップグレード コンピュータへのインストールに使用したアドミニストレーティブ イメージのアップデートにより複数のコンピュータを新しいリリース版に移行。
管理 インストレーションの変更、修復、削除、および新しいリリースへのアップグレード。 | 管理 アドミニストレーティブ イメージとクライアントのアップグレード、ネットワーク ライセンス管理、Workgroup PDMのボルト管理。

SOLIDWORKS Installation Manager は、SOLIDWORKS、SOLIDWORKS Toolbox、PhotoView 360、SOLIDWORKS Electrical、Workgroup PDM、SOLIDWORKS PDM、および SOLIDWORKS SolidNetWork License Manager を含む SOLIDWORKS 製品コンポーネントの設定を構成できるようにします。

SOLIDWORKS Workgroup PDM のサポートは、SOLIDWORKS 2017 の後に終了いたします。SOLIDWORKS Workgroup PDM を既にご使用のお客様はインストールを続行できますが、ファイル ボルトを SOLIDWORKS PDM Server に移行する計画を開始する必要があります。

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。 フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

目次

  • 個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

    SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

  • SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）

    SOLIDWORKS インストレーションを開始するには、ローカル コンピュータで DVD を読み込むか、共有インストレーション ディレクトリにアクセスするか、または SOLIDWORKS からダウンロードします。

  • Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント

    Windows 8 （以降）のユーザー インタフェースは以前のバージョンの Windows とは大幅に異なっています。 ナビゲーションの方法が異なるだけでなく、主なコマンドにアクセスするための手段が複数追加されています。


個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）

SOLIDWORKS 製品を各コンピュータに個別にインストールしますか? あるいはアドミニストレーティブ イメージを作成して展開し、すべてのクライアントに 1 コマンドでインストールしますか?

一台のコンピュータのみにインストールする場合や数百台のコンピュータにインストールする場合、この選択は明らかです。それ以外の場合は、次の比較を参考にしてください。

個人インストレーション | アドミニストレーティブ イメージ
各ユーザーが個人的に SOLIDWORKS を管理できます。 | システム管理者はオプション エディタを使って、複数のインストレーションをカスタマイズすることができます。新規インストレーションを作成したり、あるいは既存のものを更新するインストレーション オプションを指定したり、アドミニストレーティブ ユーザーとして起動したり、インストレーションの前後に外部コマンドを実行したり、異なる製品のグループ分けを行います。
インストレーションを実行する個人が、コンピュータに物理的にアクセスできなければなりません。 | クライアント コンピュータが同じネットワーク上でアクセス可能な限り、物理的な距離は問題ありません。
異なるバージョン、ServicePack、製品を、別々のコンピュータ上に独自の設定でインストールできます。 | オプション エディタを使って、アドミニストレーティブ イメージはバージョン、Service Pack、製品、設定の一貫性を維持することができます。
コンピューターには、ネットワークまたは電子メールへのアクセスが必要です。 SOLIDWORKS をアクティブ化してファイルをダウンロードするには、ネットワークまたは電子メールの接続が必要です。 また、ネットワーク ライセンス サーバーからライセンスを収集するには、ネットワークへのアクセスが必要です。 | アプリケーションを展開するには、ローカル ネットワークが接続されている必要があります。クライアント コンピュータ上にメディア ドライブは必要ありません。 クライアントは自動的にアップデートされます。 同じアドミニストレーティブ イメージから展開されたすべてのクライアントが同じServicePackになります。 複数のバージョンを維持するには、複数のアドミニストレーティブ イメージを作成します。 ライセンスのアクティベーションを自動的に行うことができます。 アドミニストレーティブ イメージは、サーバー上の追加のディスク容量を必要とします。クライアントは、個別インストレーションと同じ容量を必要とします。
親トピック
SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）

SOLIDWORKS インストレーションを開始するには、ローカル コンピュータで DVD を読み込むか、共有インストレーション ディレクトリにアクセスするか、または SOLIDWORKS からダウンロードします。

SOLIDWORKS インストールを開始するは、次のいずれかを行います。

  • ローカル コンピュータにディスクからインストールするには、適切なディスクをディスク ドライブに挿入します。
  • ダウンロード ディレクトリからインストールするには、ディレクトリまで移動し、setup.exe をダブルクリックします。
  • SOLIDWORKS からダウンロードしてインストールするには、以下を行います。
    1. SOLIDWORKS Web サイトまで参照します。
    2. Subscription サービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SOLIDWORKS シリアル番号を入力します。
    3. セルフ サービス（Self Service）で、ソフトウェアとアップデートのダウンロード（Download Software and Updates）をクリックします。
    4. ソフトウェアのダウンロード （Windows、Mac、Linux）で、ダウンロードする SOLIDWORKS のバージョンとサービス パックを選択します。
親トピック
SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント

Windows 8 （以降）のユーザー インタフェースは以前のバージョンの Windows とは大幅に異なっています。 ナビゲーションの方法が異なるだけでなく、主なコマンドにアクセスするための手段が複数追加されています。

以下のトピックでは、Windows 8 の最も基本的な 3 つの機能にアクセスする方法について説明します。Windows 8 を使用して SOLIDWORKS をインストールするときは、以下のトピックを参照してください。
これらの手順は、Windows システムの構成方法によって異なる場合があります。 特に、Windows 8 よりも後のシステムの場合、追加の指示とオプションについて Microsoft Windows のドキュメントを確認してください。
親トピック
SOLIDWORKS インストレーションおよびアドミニストレーション（SOLIDWORKS Installation and Administration）
関連概念
個人インストレーションまたはアドミニストレーティブ イメージ（Individual Installation or Administrative Image）
個人コンピュータでのインストール（Installation on Individual Computers）
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）

SOLIDWORKS を起動中

Windows 8 のチャーム バーから SOLIDWORKS を起動できます。SOLIDWORKS をデスクトップにピン留めすることもできます。

チャーム バーから SOLIDWORKS にアクセスするには:

  1. スタート画面で、画面の右下隅をクリックします。

    画面の右側にチャーム バーが表示されます。

    Windows ロゴ + C を押してチャーム バーにアクセスすることもできます。

  2. 検索アイコンをタップまたはクリックします。
  3. 検索 に SOLIDWORKS と入力して、SOLIDWORKS タイルを下方向にスワイプするかタップします。
SOLIDWORKS をデスクトップにピン留めするには、SOLIDWORKS タイルを右クリックして、画面下部に表示されるツールバーの スタート画面にピン留めする をクリックします。

コントロール パネルへのアクセス

コントロール パネルにアクセスするには:

  1. スタート画面で、画面の右側から内側へスワイプするか、画面の右上隅にマウスをドラッグします。

    画面の右側にチャーム バーが表示されます。

  2. 検索アイコンをタップまたはクリックします。
  3. 検索ボックスにコントロール パネルと入力します。
  4. アプリ画面の左側に表示されたコントロール パネルタイルをクリックします。

コマンド プロンプトへのアクセス

コマンド プロンプトにアクセスするには:

  1. スタート画面で、右クリックして画面の下部にツールバーを表示します。
  2. ツールバーの右側にあるすべてのアプリをクリックします。
  3. アプリ画面の右側で、Windows システム ツールの下にあるコマンド プロンプトを押すか、またはクリックします。

便利なショートカット

次の一覧に、便利なキーボード ショートカットを示します。

Alt + Tab | デスクトップで実行されているアプリケーション間を切り替えます。
Windows ロゴ キー + Q | アプリの一覧と検索ウィンドウを開きます。
Windows ロゴ キー + R | ファイル名を指定して実行ダイアログ ボックスを開きます。
Windows ロゴ キー + I | 設定パネルを開きます。
キーボード ショートカットに関する追加の説明については、Microsoft Windows のドキュメントを参照してください。


個人インストレーション（Individual Installations）

目次

  • 個人コンピュータでのインストール（Installation on Individual Computers）

    SOLIDWORKS は、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。

  • 個人インストレーションの管理（Administration of Individual Installations）

    通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。


個人コンピュータでのインストール（Installation on Individual Computers）

SOLIDWORKS は、いくつかのインストレーション方法を使用して個人コンピュータにインストールできます。

SOLIDWORKS Installation Manager はインストレーションを購入した製品に合うように調整し、インストレーションを実行します。 インストレーションを開始する前に、以下を行います。

  • SOLIDWORKS シリアル番号をお手元に準備してください。
  • インターネット接続された環境であることを確認してください。 権利をチェックするには、接続が必要です。

SOLIDWORKS Installation Manager は、Microsoft Windows インストーラ、Office Web コンポーネント、Microsoft Visual Studio Tools for Applications、Visual Basic、および .NET Framework を含むさまざまな Microsoft コンポーネントを必要とします。 すべての Windows 前提条件コンポーネントの正しいバージョンがコンピュータにインストールされていない場合、SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストールする前に、これらのコンポーネントを自動的にインストールします。 Bonjour service for Windows も必要なコンポーネントです。

Windows 8 を実行している場合、スタートまたはコントロール パネルへのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 特に Windows 8 以降のシステムに関する追加の手順やオプションについては、Microsoft Windows のドキュメントを参照してください。
インストレーション方法 | プロセスの概要
SOLIDWORKS インストレーション メディアを使用 | DVD ディスクをコンピュータのディスク ドライブに挿入します。
サーバー上のダウンロード ディレクトリを使用 ダウンロード先のディレクトリで、setup.exe をダブルクリックします。

ダウンロード ディレクトリは、SOLIDWORKS 製品をインストールするコンピュータからアクセス可能であり、インストレーションの開始前にすべての SOLIDWORKS インストレーション ファイルが含められている必要があります。 SOLIDWORKS Installation Manager は、ダウンロード ディレクトリに対するインターネット アクセスと書き込みアクセスがある場合、見つからないファイルを探すのに役立ちます。

を使用して既存のSolidWorksインストレーションを更新 を使用して既存の SOLIDWORKS インストレーションを更新 次のいずれかを実行します:
  • SOLIDWORKS で、ヘルプ > アップデート チェック をクリックします。
  • Windows で、スタート > すべてのプログラム > SOLIDWORKS Installation Manager > アップデート チェック をクリックします。
インターネット接続されている必要があります。

Workgroup PDMクライアントはVaultの更新を自動的に検出します。 ServicePackをダウンロードしてクライアントをアップデートする必要はありません。 詳細については、Workgroup PDM オンライン ヘルプの クライアントのアップデートを参照してください。

SOLIDWORKS カスタマー Web サイトからのダウンロード
  1. SOLIDWORKS Web サイトまで参照します。
  2. Subscription サービス（有償サポート）契約対象のユーザーとしてログインし、電子メール アドレスとパスワードを入力するか、SOLIDWORKS シリアル番号を入力します。
  3. セルフ サービス (Self Service) で、ソフトウェアとアップデートのダウンロード (Download Software and Updates) をクリックします。
  4. ソフトウェアのダウンロード (Download Software) で、インストールする SOLIDWORKS バージョンを選択します。
インターネット接続されている必要があります。

Customer Portalサイトに対するログイン権限のあるSubscription契約ユーザーである必要があります。

インストレーションが完了したら、SOLIDWORKS アプリケーションおよびライセンス アクティベーションを開始します。

マシンにインストールされている製品のリストを表示するには、SOLIDWORKS のメイン メニューで ヘルプ（Help） > マイプロダクト（My Products）をクリックします。 マイプロダクト（My Products）には、現在利用可能なすべての SOLIDWORKS 製品が表示されます。 チェック マークは、アクティベーションおよびネットワーク ライセンスに基づいて、ユーザーまたはユーザーの組織が現在保持している製品を示します。
親トピック
個人インストレーション（Individual Installations）
関連概念
個人インストレーションの管理（Administration of Individual Installations）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


個人インストレーションの管理（Administration of Individual Installations）

通常、個人インストレーションの管理はインストレーションの変更、修復、削除、アップグレードで構成されます。

目次

  • インストレーションの変更（Modifying an Installation）

    インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  • 新しいリリースへのアップグレード（Upgrading to a New Release）

    個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

  • 製品の共存ルール（Product Coexistence Rules）

    製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

親トピック
個人インストレーション（Individual Installations）
関連概念
個人コンピュータでのインストール（Installation on Individual Computers）


インストレーションの変更（Modifying an Installation）

インストレーションを変更して、インストールされていない製品をインストールしたり、製品を削除したりできます。ただし、前回のインストールがインストレーション ファイルの完全なセットを使用して完了していることを条件とします。 このオプションは、前回のインストールをサービス パックでアップグレードしている場合は使用できません。

SOLIDWORKS をインストールした後でアドインを購入した場合は、新規のアドインが含まれるようにインストレーションを変更できます。 アドインは個別のコンピュータにインストールする必要があります。

元の SOLIDWORKS を変更して SOLIDWORKS Professional または SOLIDWORKS Premium のパッケージを含めるように指定すると、Workgroup PDM はインストールされません。
  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. Windows 7 以降では、スタート > コントロール パネル >プログラムと機能 をクリックします。
  3. 変更したい SOLIDWORKS インストレーションを選択してから、変更 をクリックします。
  4. SOLIDWORKS Installation Manager へようこそ (Welcome to the SOLIDWORKS Installation) 画面で、（Modify the individual installation （on this computer））をクリックします。 をクリックします。
  5. シリアル番号 画面で適切なシリアル番号が指定されていることを確認します。
  6. 製品選択 画面でインストールまたは削除する製品を選択します。

    インストレーションの変更は以下のようになります。

    • 新しいシリアル番号を指定した場合も、デフォルトでインストールまたは削除される製品はありません。 それぞれの製品や機能コンポーネントのインストール動作を変更する必要があります。
    • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。 製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
    • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。 （たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
    • 初期の指定からコンポーネントのインストール動作を変更すると、アスタリスク（*）がリスト内のそのコンポーネントの横に表示されます。
    • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
    • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

  7. サマリー 画面で、今すぐ変更 をクリックします。
  8. インストレーション完了 画面で、完了 をクリックします。
親トピック
個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）


インストールの修復（Repairing an Installation）

もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

ただし、インストールを修復するには、以前のインストールのすべてのソース ファイルと、適用されたすべてのサービス パックが、最初のインストール ロケーションになければなりません。

個人インストレーションは修復できます。 アドミニストレーティブ イメージは修復できません； アドミニストレーティブ イメージをアンインストールして、次に再インストールしなければなりません。
  1. Windows 7 以降で スタート > コントロール パネル > プログラム > プログラムと機能 をクリックします。
  2. 修復する SOLIDWORKS バージョンを選択し、変更 をクリックします。
  3. SOLIDWORKS Installation Manager へようこそ (Welcome to SOLIDWORKS Installation Manager) 画面で （Repair the individual installation (on this computer)）をクリックします。 をクリックします
  4. 修復する製品 画面で、修復する製品を選択します。
  5. スクリーン上で残りの製品を選択解除します。
  6. 修復 をクリックします。
親トピック
個人インストレーションの管理（Administration of Individual Installations）
親トピック
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）
失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）

個人インストレーションを現在のメジャー リリース ファミリー内の以前のServicePackリリースにロールバックするには、コンピュータに現在インストールされているServicePackバージョンをアンインストールしてから、以前のバージョンを再インストールします。
親トピック
個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
インストレーションの削除（Removing an Installation）


インストレーションの削除（Removing an Installation）

個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

  1. アクティブな SOLIDWORKS のセッションがないことを確認します。
  2. SOLIDWORKS ライセンスを別のコンピュータにトランスファーする場合は、コンピュータから SOLIDWORKS インストレーションを削除する前にライセンスを別のコンピュータにトランスファーしてください。

    詳細は、ライセンス トランスファー（Transferring a License）を参照してください。

  3. Windows 7 以降の場合は、コントロール パネル > プログラムと機能 を起動します。
  4. 削除する製品を選択します。

    場合によっては、特定のメジャー リリース バージョンに対して複数の SOLIDWORKS ServicePack コンポーネントが存在するかもしれません。 SOLIDWORKS メジャー リリースを削除するには、そのメジャー リリースに対するすべての SevicePack 要素を削除します。

  5. アンインストール 画面で:
    1. 削除する製品を選択します。 すべての製品コンポーネントがデフォルトで選択されています。
    2. 削除したくない製品を選択解除します。
    3. カスタム アンインストールか完全なアンインストールを選択します。 SOLIDWORKS Installation Manager では、デフォルトで一般的なアンインストールが実行され、プログラム ファイルとフォルダが削除されます。

      1. 変更 を 詳細設定オプション でクリックします。

        詳細設定オプション 画面が表示されます。プログラム ファイルとフォルダのオプションが選択されています。

      2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
      3. サマリーに戻る（Back to Summary）をクリックします。
      4. サマリー の画面で、詳細設定オプション を展開し、アンインストールの方法を表示します。

    4. アイテムを削除 をクリックします。
親トピック
個人インストレーションの管理（Administration of Individual Installations）
親トピック
複数インストレーションの管理（Administration of Multiple Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
製品の共存ルール（Product Coexistence Rules）
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
ライセンス トランスファー（Transferring a License）


新しいリリースへのアップグレード（Upgrading to a New Release）

個人インストレーションを新しい SOLIDWORKS リリースにアップグレードする方法は、いくつかあります。

次の場合に新しいリリースにアップグレードすることができます。
  • 新しいインストレーション メディアを受け取った
  • SOLIDWORKS の開始時にアップグレードが通知された
  • マニュアルでのアップデート チェックを行った
  • 新しいインスタンスの SOLIDWORKS Installation Manager を開始した

新しいメジャー リリースのインストール時には、前にインストールしたメジャー リリースをアップグレードするか、または新しいリリースを並行してインストールできます。インストール済みのメジャー リリースに対するServicePackリリースをインストールする場合、このリリースは自動的にアップデートされます。

親トピック
個人インストレーションの管理（Administration of Individual Installations）
関連概念
製品の共存ルール（Product Coexistence Rules）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）

マニュアルでのアップデート チェック（Checking for Updates Manually）

現在インストールされている SOLIDWORKS リリースのアップデート チェックは、以下のいずれかの方法を使用して行えます。

  • SOLIDWORKS で ヘルプ (Help) > アップデート チェック (Check for Updates) をクリックします。
  • Microsoft Windows で スタート (Start) > すべてのプログラム (All Programs) > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) をクリックします。

Workgroup PDMクライアントのアップグレード（Upgrading Workgroup PDM Clients）

ボルトのアップデート後にクライアントが初めてログインすると、アップデートを求めるプロンプトが表示されます。クライアントのアップデートに、ServicePackは必要ありません。

Vaultに対するクライアント ステータス | 動作
ボルトと同じバージョンの場合 | なし
同じメジャー リリース版でボルトより新しい場合 | なし
新しいメジャー リリース版でボルトより新しい場合 | ログインがブロックされる
同じメジャー リリース版でボルトより古い場合 | オプションでアップデート可
以前のメジャー リリース版でボルトより古い場合 | アップデートが必要

Workgroup PDMクライアントのアップデートの詳細については、Workgroup PDMヘルプ（Workgroup PDM Help）のクライアントのアップデート（Update Clients）を参照してください。

アップグレードの注意点（Upgrade Caveats）

メジャー バージョンが異なる複数のインストレーションが許可される製品の場合は、メジャー アップグレードがサポートされない、あるいは次のメジャー バージョンへのアップグレードが一度の作業で可能でない場合があります。

このような場合、SOLIDWORKS Installation Manager は先ず新規バージョンをインストールし、続いて古いバージョンを削除することにより、アップグレードを実行しようします。 現時点では、SOLIDWORKS のコア製品はメジャー バージョンのアップグレードをサポートしますが、その他の製品はサポートしません。

この結果、以下のようになります。
  • SOLIDWORKS のコア製品のメジャー バージョン アップグレードを行う場合:
    • 既存のインストレーション場所は変更しません。
    • アップグレード中にエラーが発生したり、キャンセルをした場合、アップグレードをロールバックできます。
  • その他の製品のメジャー バージョン アップグレードを行う場合:
    • 各製品は、先ず新規製品として新しい場所にインストールされ、続いて元のインストレーションが削除されます。
    • 一度アップグレードを開始すると、エラーが発生したり、キャンセルをした場合でも、アップグレードをロールバックすることはできません。


製品の共存ルール（Product Coexistence Rules）

製品の共存ルールは、新規製品のインストールと既存製品のアップグレード方法を決定します。

ルール | 例
以下に示す製品を除いて、複数のメジャー リリース バージョンのコア SOLIDWOKRS 製品が許可されます。 | SOLIDWORKS 2015 SP3.0 と SOLIDWORKS 2016 SP0.0 は 1 台のコンピュータに共存できます。
同じメジャー リリース バージョンの複数のサービス パックは許可されません。 | SOLIDWORKS 2016 SP0.0 と 2016 SP1.0 は 1 台のコンピュータに共存できません。 SOLIDWORKS 2016 SP0.0 が既にインストールされているコンピュータに SOLIDWORKS 2016 SP1.0 をインストールすると、SOLIDWORKS Installation Manager によって SP0.0 が SP1.0 に置き換えられます。
次の製品は、1台のコンピュータで1つのバージョンのみが許可されます。
  • Workgroup PDM Server
  • SolidNetWork License Manager
 SOLIDWORKS 2016 SP0.0 がインストールされている場合（それ以前の SOLIDWORKS メジャー リリースがコンピュータ上に残っている場合でも）、Workgroup PDM Server は 2016 SP0.0 にアップグレードされます。
次の製品は、1台のコンピュータで1つのバージョンのみが許可されます。
  • SOLIDWORKS PDM Client
  • SOLIDWORKS PDM Server

SOLIDWORKS 2016 SP0.0 または SP1.0 をインストールした場合、SOLIDWORKS 2016 PDM Server や PDM Client もアップグレードする必要があります。

SOLIDWORKS 2016 PDM Server をインストールした場合、PDM Server のインストール プロセスを使用して SOLIDWORKS PDM Client をインストールする必要があります。 SOLIDWORKS PDM Client をクライアントのインストール プロセスと別にインストールしないでください。

同じマシン上の SOLIDWORKS PDM Server と SOLIDWORKS PDM Client は同じリリース バージョンとサービス パックである必要があります。

詳細については、SLDIM による PDM サーバーのインストールに関するトピックを参照してください。

SOLIDWORKS に含まれる製品は、各メジャー リリース バージョンについて 1 つのバージョンのみインストールできます。 ただし、異なるメジャー リリース バージョンの SOLIDWORKS に含まれる製品は共存できます。 | SOLIDWORKS 2016 SP0.0 が 2016 SP1.0 にアップグレードされると、SOLIDWORKS Explorer 2016 SP0.0 は自動的に 2016 SP1.0 にアップグレードされます。ただし、SOLIDWORKS Explorer 2015 SP4.0 は SOLIDWORKS Explorer 2016 SP0.0 や SOLIDWORKS Explorer 2016 SP1.0 と共存できます。
複数のメジャー バージョンの SOLIDWORKS を同じマシンで実行するには、管理者権限が必要です。
親トピック
個人インストレーションの管理（Administration of Individual Installations）
関連概念
新しいリリースへのアップグレード（Upgrading to a New Release）
関連タスク
インストレーションの変更（Modifying an Installation）
インストールの修復（Repairing an Installation）
個別インストレーションを前回までのService Packにロールバックする方法（Rolling Back an Individual Installation to a Previous Service Pack）
インストレーションの削除（Removing an Installation）


複数インストレーション（Multiple Installations）

目次

  • 複数クライアントへの展開（Deploying to Multiple Clients）

    アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

  • アドミニストレーティブ イメージの使用（Using Administrative Images）

    アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

  • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

    共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

  • コマンドラインによる展開（Command-Line Deployment）

    コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

  • 複数インストレーションの管理（Administration of Multiple Installations）

    複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。


複数クライアントへの展開（Deploying to Multiple Clients）

アドミニストレーティブ イメージを作成してからクライアントにインストレーションを展開することにより、複数のクライアントに SOLIDWORKS 製品をインストールできます。

複数クライアントに展開する手順は、以下のようになります。
  1. アドミニストレーティブ イメージを作成します。
    • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）
  2. アドミニストレーティブ イメージをクライアントに展開します。
    • 電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
    • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
  3. ライセンス管理 を行います。
    • 個人ライセンスの管理（Administering Individual Licenses）
    • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
Windows 8 をお使いの場合、スタート や コントロール パネル にアクセスするタスクでは、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。
親トピック
複数インストレーション（Multiple Installations）
関連概念
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


アドミニストレーティブ イメージの使用（Using Administrative Images）

アドミニストレーティブ イメージは、単一のネットワーク位置からの SOLIDWORKS 製品の設定可能なインストレーションを可能にします。

ネットワーク上のクライアント コンピュータを含む任意のコンピュータから、アドミニストレーティブ イメージをインストールできます。
  • アドミニストレーティブ イメージは必ず共有フォルダに保存してください。
  • すべての製品を含むと、アドミニストレーティブ イメージには7GB かそれ以上のディスク容量が必要です。
  • アドミニストレーティブをアップグレードするときに、共有名を更新した場合、クライアントは、次の機会にアプリケーションを開始すると、アップグレードされます。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。
  • クライアントには、各自のコンピュータにおける管理権限が必要です。 クライアントの権限が不十分な場合、別の方法を使用してイメージをインストールします。

アドミニストレーティブ イメージを作成すれば、アドミニストレーティブ イメージ オプション エディタを用い、そのイメージからインストールするユーザーとグループに対するインストレーション オプション設定を管理することが可能です。 詳細については、SOLIDWORKS アドミニストレーティブ イメージ オプション エディタ (Administrative Image Option Editor)を参照してください。

目次

  • SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

    SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

親トピック
複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
アドミニストレーティブ イメージ オプション エディタ


SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

  1. SOLIDWORKS Installation Manager を起動します。 SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）を参照してください。
  2. ようこそ 画面で アドミニストレーティブ イメージ を選択します。

    アドミニストレーティブ イメージの作成オプションが表示されます。

    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. 画面上の指示に従います。

目次

  • アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

    アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

親トピック
アドミニストレーティブ イメージの使用（Using Administrative Images）
関連タスク
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

アドミニストレーティブ イメージ オプション エディタでは、個々のマシンと、マシンのグループのためのアドミニストレーティブ イメージのインストレーション パラメータ設定をカスタマイズできます。

アドミニストレーティブ イメージを作成した後で、SOLIDWORKS Installation Manager はオプション エディタを開始するように要求します。 オプション エディタは、アドミニストレーティブ イメージ フォルダにある sldAdminOptionEditor.exe をダブルクリックにより、後から起動することも可能です。

マシンのグループ、または個々のマシンに対して異なるインストール構成を指定するには、オプション エディタでマシン名、IP アドレス、または IP アドレスの範囲を使用してマシンを選択し、それらのマシンにインストール オプションを指定します。

ファイルまたはフォルダのパスを要求するすべてのダイアログ ボックスに、選択したフォルダを環境変数に割り当てることができるオプションがあります。 たとえば、C:\Program Files\SOLIDWORKS Corp を選択すると、ファイル パスは %ProgramFiles%\SOLIDWORKS Corp にマップされます。 最も共通する変数は %ProgramFiles% および %SystemDrive% です。

すべてのパスを環境変数に変換できるわけではありません。 たとえば、Z:\SOLIDWORKS Data は、適切な環境変数にマッピングできません。

目次

  • グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

    アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

  • オプション設定の表示と編集（Viewing and Editing Option Settings）

    SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

    手動またはプッシュによる方法を用いて、オプション エディタから直接インストレーションを展開することが可能です。

  • オプション エディタの終了（Exiting the Option Editor）

    オプション エディタを閉じるには、OKまたは閉じるをクリックします。

  • オプション エディタに対するデスクトップ ショートカットの作製

    特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

親トピック
SOLIDWORKS Installation Manager を使ったアドミニストレーティブ イメージの作成（Creating an Administrative Image from SOLIDWORKS Installation Manager）


グループとマシンの追加と削除（Adding and Deleting Groups and Machines）

アドミニストレーティブ イメージのオプション エディタは、マシンのグループと個々のマシンに異なるインストレーション設定を指定できるようにします。

例えば、いくつかのマシンではイメージに含まれる使用可能な製品コンポーネントの特定のサブセットを使用するように設定したいが、その一方で別のグループは異なる製品コンポーネントのサブセットを使用する場合もあります。オプション エディタのグループ設定は1つのアドミニストレーティブ イメージを使用しているにもかかわらず、異なるマシンのグループに異なる製品のサブセットをインストールできるようにします。

グループを追加するには:
  1. グローバル設定を右クリックし、グループ追加をクリックします。
  2. グループ名を入力します。

マシンを追加するには:
  1. 既存のグループまたはグローバル設定を右クリックし、マシン追加をクリックします。
    既存のグループを右クリックした場合、マシンはそのグループに追加されます。 他の場合、マシンはトップレベルに追加されます。
  2. 次のいずれかを行います:
    • マシン名（By Machine Name）を選択し、1 つ以上のマシン名を入力します。 複数のマシンが改行、スペース、タブ、カンマ、ピリオド、コロン、あるいはセミコロンによって分けられます。 外部ファイルからマシン名のリストをコピー/ペーストすることができます。 マシンはドメイン名を含むことができません。 例えば、pluto.solidworks.comは無効です。
    • IP アドレス（By IP Address）を選択し、マシンの IP アドレスを入力します。
    • IP アドレスの範囲（By IP Address Range）を選択し、指定する範囲の開始 IP アドレスと終了 IP アドレスを入力します。
    • 複数のマシン追加をクリックして、ネットワークからマシンを選択します。

既存のマシンをグループに移動するには:

グループにマシンをドラッグします。

既存のマシンをグループ外に移動するには:

グローバル設定にマシンをドラッグするか、他のグループにドラッグします。

グループ、マシンを削除するには:

グループまたはマシンを右クリックし、グループ削除またはマシン削除をクリックします。

グループを削除した場合、グループ内のすべてのマシンは削除されます。

すべてのグループとマシンを削除するには:

グローバル設定を右クリックし、すべて削除をクリックします。

親トピック
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


オプション設定の表示と編集（Viewing and Editing Option Settings）

SOLIDWORKS アドミニストレーティブ イメージ オプション エディタでは、イメージに対して設定されたグループおよびマシンに対するオプション設定の確認と編集が可能です。

  • オプション エディタを最初に起動すると、オプション設定が読み取り専用モードで表示されます。 編集アイコンは押された状態になっていません。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定のサマリが表示されます：

    スコープ（Scope） | 表示されるオプション設定
    グローバル設定 | アドミニストレーティブ イメージに対して指定されたすべてのオプション設定
    グループ | グローバル設定と比較してグループ設定で変更された内容
    工作機械 | グループ設定と比較してマシン設定で変更された内容
  • オプション設定を変更するには、編集アイコンをクリックします。 アイコン表示が押された状態になり、より詳細なオプション設定の一覧が表示されます。

    グローバル設定、グループ、またはマシンをクリックすると、該当アイテムに対するオプション設定が変更可能です。 変更により、グローバル設定やグループ設定から継承された設定とは異なったオプション設定は、ハイライト表示が行われます。

    編集アイコンを再度クリックすると、表示は読み取り専用モードに戻ります。

    変更を行った場合は、オプション エディタの終了時に、それらの保存または破棄が要求されます。

目次

  • グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

    すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  • アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

    オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

  • グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

    グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

  • 各マシンの設定のカスタマイズ

    マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

親トピック
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製


グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）

すべてのマシン（グローバル設定）、グループのマシン、個々のマシンのオプション設定を指定することができます。

  1. オプション エディタで、修正するオブジェクト（グローバル設定、グループ、またはマシン）をクリックします。
  2. 右側の編集アイコンをクリックします。

    編集アイコンが押された状態になり、より詳細なオプション設定の一覧が表示されます。

  3. 左側で選択されたアイテムに対する右側のオプション設定をクリックすることにより、それらを変更します。

    グローバル設定やグループ設定をオーバーライドするオプション設定の変更は、ハイライト表示されます。

  4. OKまたは閉じるをクリックして、変更内容を保存します。
    オプション | 説明
    OK | 変更内容が保存され、オプション エディタが終了します。
    閉じる（Close） | 変更内容を保存するか否かについてユーザーに質問を行い、その対応を受けた後、オプション エディタを終了します。
親トピック
オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）

オプション エディタで各クライアントやグループのオプション設定（シリアル番号、クライアント インストレーション オプション、インストールするソフトウェア コンポーネント、ツールボックスの場所などを含む）を指定できます。

シリアル番号（Serial Numbers）

クライアント マシンにインストールされる製品のシリアル番号を入力します。
SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。
ライセンス管理を SolidNetWork ライセンスを用いて行っている場合：
  • 最初のシリアル番号フィールドにSolidNetWorkのシリアル番号を入力します。
  • SNLサーバー ポート@サーバー フィールドに SolidNetWork License Manager のサーバー名とポートを nnnnn@サーバー名 の形式で入力します。 複数のエントリはセミコロンにより区切ってください。

SolidNetWork ライセンスの詳細は、SolidNetWork ライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）を参照してください。

クライアント インストレーション オプション（Client Installation Options）

メジャー バージョンのクライアント インストールどの方法で行いますか? クライアントのインストールでは、インストール済みの古いメジャー バージョンの取り扱い方法を指定できます：
  • 既存のメジャー バージョン（存在する場合）をアップグレードします。

    インストール済みの古いメジャー バージョンを新しいバージョンのインストールで置き換えるには、このオプションを指定します。

  • 新規メジャー バージョンを作成します。

    インストール済みの古いメジャー バージョンを保持したまま、新しいメジャー バージョンをインストールするには、このオプションを指定します。 新しいバージョンのインストール先を指定するには、参照（Browse）をクリックします。
新しいメジャー バージョンをインストールする前に、最も最新の前のバージョンをアンイストールしますか? インストール済みの古いメジャー バージョンをアンインストールするかどうかを指定できます:
  • いいえ、最初にアンインストールしません:

    古いメジャー バージョンを保持する場合に選択します。

  • はい、カスタム アンインストールを実行します:

    次のアイテムを削除する場合に選択します: プログラム ファイルとフォルダ、レジストリ エントリ、データ ファイルとフォルダ。

SOLIDWORKS 設定をどのように適用しますか? クライアントのインストールでは、SOLIDWORKS の設定をクライアント マシンの SOLIDWORKS 設定と設定のコピー ウィザードからエクスポートされた SOLIDWORKS 設定のどちらに基づいて行うかを指定できます。 設定のコピーウィザードは、システムの設定を保存、回復、またユーザーやコンピュータ、プロファイルへと伝播します。
設定のコピー ウィザード は、SOLIDWORKS ソフトウェアの ツール > 設定の保存/復元 から、または スタート > すべてのプログラム > SOLIDWORKS バージョン > SOLIDWORKS ツール (SOLIDWORKS Tools) > 設定のコピー ウィザード [image] をクリックして起動できます。
ツール（Tools） > 設定の保存/回復（Save/Restore Settings）を選択すると、設定のコピー ウィザード（Copy Settings Wizard）が特別なモードで実行し、SOLIDWORKS ソフトウェアが稼働したまま、現在のユーザー設定を保存または回復できます。
  • 現在の設定（存在する場合は）を使用するか、SOLIDWORKS デフォルト設定を使用します。

    クライアント マシンに定義済みの SOLIDWORKS 設定が存在する場合は、それらを維持します。 （クライアントで特に定義されていない設定に対しては、デフォルトの SOLIDWORKS 設定が使用されます。）

  • 設定のコピー ウィザードで出力した設定ファイルを使用します。

    本オプションを選択すると、設定のコピー ウィザードの既存ファイルを用いてオプションを設定できます。 （一般的に、ファイル名は solidworkssettings.sldreg です。）参照をクリックして既存の設定ファイルを見つけるか、新規作成をクリックして設定のコピー ウィザードを開始し、新しい設定ファイルを作成します。

    詳細は SOLIDWORKS ヘルプを参照してください。
クライアント インストレーションはどの方法でアクティブ化しますか? ライセンスのアクティブ化は、インストール後に自動で完了するか、あるいはユーザーが手動で行うかを選択することが可能です。
自動的な製品のアクティブ化を指定した場合、インストレーション後にクライアントが初めて SOLIDWORKS を実行する際、共有ネットワーク上にアドミニストレーティブ イメージが準備されている必要があります。 アドミニストレーティブ イメージからインストールしたクライアントがアドミニストレーティブ イメージにアクセスできない場合、クライアントは自動的に製品をアクティブ化することができません。 SOLIDWORKS 製品を手動でアクティブ化しない限り、SOLIDWORKS を実行することができません。
  • 各クライアント インストレーションが完了した時点で自動的にアクティベーションを行います。

    オプションを選択すると、アクティベーションは SOLIDWORKS 製品アクティベーション ファイルを使用して自動的に実行されます。 （一般的に、ファイル名は AutoActivation.xml です。） 参照 をクリックして既存のアクティベーション ファイルを見つけるか、新規作成 をクリックして SOLIDWORKS 製品アクティベーションを開始し、新しいアクティベーション ファイルを作成します。

  • 自動的にアクティブ化しません。

    オプションを選択すると、製品は自動的にアクティブ化されません。 クライアントは、インストレーション後に製品をアクティブ化します。

アドミニストレーティブ オプション（Administrative Options）

各インストレーションに対して診断ログ ファイルを作成します。 | クライアントのインストールでは、インストール時に発生した問題のトラブルシューティングに利用可能な診断ログを作成できます。 このログを作成すると、クライアントのインストール速度が遅くなります。
別ユーザーとしてインストレーションを実行。 | ユーザー アカウント制御（UAC）が無効になっている場合のみ、クライアントのインストールは異なるユーザーで実行できます。 本オプションは、個別のユーザーが使用中のマシンで SOLIDWORKS 製品のインストールに必要なローカル管理権限を持っていない場合に有効な場合があります。 クライアントが管理権限を持っていない場合、展開とインストールは別の方法で実行できます。 オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）を参照してください。
インストレーションの前後に実行するプログラム。 | クライアントのインストール前後におけるユーザー定義プログラムの実行を指定できます。
クライアントは SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムに参加しますか? | クライアント マシンの SOLIDWORKS ユーザー パフォーマンス フィードバック プログラムへの参加を指定できます。 パフォーマンス インフォメーションが、製品改善の手助けの為に SOLIDWORKS Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 詳細は、Customer Experience Improvement Program Web サイトを参照してください。

[インスレーションの前にプログラムを作動 (Run a Program Before Installation)] オプションおよび [インスレーションの後にプログラムを作動 (Run a Program After Installation)] オプション

これらのオプションを使用すると、SolidWorks を展開する前または後に他のインストール プログラムまたはスクリプト（例: Microsoft Office をインストールするスクリプト）をクライアント マシンで実行できます。

Windows 8 クライアント マシンに自動的に展開する場合は、これらのオプションの使用に関する制限があります。 いずれかのオプションを使用して、ユーザー インタフェースを表示するインストール プログラムまたはスクリプト（例: ダイアログ ボックスを表示するスクリプト）を展開した場合、失敗が生じます。 SOLIDWORKS の自動展開が実行されても、SOLIDWORKS がターゲット マシンにインストールされません。 この制限は、Windows 7 クライアント マシンでは発生しません。

インスレーションの前にプログラムを作動 (Run a program before installation) オプションと インスレーションの後にプログラムを作動 (Run a program after installation) オプションを使用するには、サイレント モードでインストール可能なプログラムのみを選択する必要があります。

インストールするソフトウェア

インストールする SOLIDWORKS 製品は指定することが可能です。
  • クライアントのインストール中にインストールされる製品コンポーネントを指定するには、コンポーネントの隣にあるチェックボックスを選択します。
  • チェックボックスの選択を解除すると、そのコンポーネントはインストールされません。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
言語 はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 たとえば、eDrawings®、SOLIDWORKS Workgroup PDM、SOLIDWORKS Explorer ではすべての言語版がインストールされます。

Toolbox オプション

クライアントのインストールに対しては、サポートする規格とデフォルトの Toolbox の場所を指定することが可能です。

Toolboxへのアクセスはネットワーク上のフォルダを、UNCパス、共有フォルダ、共通のネットワーク ドライブ指定等を用い、複数のユーザーで共有することが一般的です。

該当する場所に古いメジャー バージョンのToolboxが存在する場合は、クライアントのインストール時に新しいメジャー バージョンのToolboxにアップグレードされます。 このファイルは、古いメジャー バージョンの SOLIDWORKS との互換性を持ちません。
一部のユーザーが古いバージョンの SOLIDWORKS を継続使用する場合等、そのバージョン用の Toolbox を保持したい場合には、新しいバージョンにアップグレードするための Toolbox 用に異なるネットワーク ロケーションを指定する必要があります。

SOLIDWORKS Toolbox の管理に関する詳細は、SOLIDWORKS ヘルプの SolidWorksヘルプ 情報を参照してください。

SOLIDWORKS PDM Client ｵﾌﾟｼｮﾝ

SOLIDWORKS PDM のクライアントとアドインを配布する際に、次のオプションを選択できます:

  • PDM 製品のタイプ
  • PDM クライアントの種類
  • フィーチャー

これらのクライアントやアドインの詳細については、SOLIDWORKS PDM のセクションを参照してください。

Electrical オプション

SOLIDWORKS Electrical の管理コンポーネントに次のパラメータを指定できます。
  • データ パス
  • Collaborative Server マシン名とポート番号
  • SQL Server マシン名とパスワード

これらのコンポーネントの詳細については、SOLIDWORKS Electrical を参照してください。

親トピック
オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
各マシンの設定のカスタマイズ
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
SOLIDWORKS Electrical
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）


グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）

グローバル設定（Global Settings）やグループに対するオプション設定は、それらの下にあるアイテムで継承されます。

例：
  • グローバル設定（Global Settings）に定義された設定は、すべてのグループとマシンに継承されます。
  • グループのために定義された設定は、そのグループの中ですべてのマシンに継承されます。

マシン、またはグループのオプション設定で、デフォルトを上書きするか、設定を継承するかを変更することができます。オプション設定をデフォルト、またはその継承された値から変えるとき、そのオプションはハイライトされます。

オプション設定を元の継承された値に戻すには、グループまたはマシンを右クリックしてからグローバル設定に戻す（Revert to Global Settings）（グループ メンバーではないグループまたはマシンの場合）、あるいはグループ設定に戻す（Revert to Group Settings）（グループ メンバーであるマシンの場合）をクリックします。
親トピック
オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
各マシンの設定のカスタマイズ
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


各マシンの設定のカスタマイズ

マシン名を右クリックして、そのマシンに適用した設定を変更することもできます。

ショートカット メニューから、各マシンに対して以下の操作を実行できます。
  • エディターからのマシン削除
  • グローバル設定に戻す
  • 注記の追加または編集
  • 編集オプション

[編集オプション]（Edit options）では、クライアント インストール オプションやアドミニストレーティブ オプションなど、そのマシンのすべてのオプションを変更できます。

親トピック
オプション設定の表示と編集（Viewing and Editing Option Settings）
関連概念
グローバルおよびグループ オプション設定の継承（Inheritance of Global and Group Option Settings）
関連タスク
グループとマシンのオプション設定を指定（Specifying Option Settings for Groups and Machines）
関連資料
アドミニストレーティブ イメージのオプション設定（Administrative Image Option Settings）


オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）

手動またはプッシュによる方法を用いて、オプション エディタから直接インストレーションを展開することが可能です。

  • インストールの開始方法に関する電子メールの指示をユーザーに送信するには、オプション エディタの [手動配布（Deploy Manually）] ページを使用します。 この方法は、ユーザーがクライアント マシンの管理権限を持っている場合に使用します。
  • ターゲット マシンにインストレーションを自動的にプッシュするには、オプション エディタの [自動配布（Deploy Automatically）] ページを使用します。 カスタム アンインストールを実行することもできます。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

いずれの方法を使用する場合も、アドミニストレーティブ イメージのインストール ディレクトリを Windows の共有ディレクトリに変更し、ネットワークを通して利用可能にする必要があります（たとえば \\マシン\共有ディレクトリ、または C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0 のように各マシンのローカル ディレクトリにイメージ全体をコピーします）。

目次

  • アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）

    アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。

  • StartSWInstall.exe によるアドミニストレーティブ イメージの展開

  • 手動で展開する

    ユーザーに、システムへのインストールに必要な権限がある場合は、この方法を使用します。

  • 自動展開の前提条件

    自動展開では、インストール タスクはターゲット マシンにプッシュされ、各システムで Microsoft タスク スケジューラによって実行されます。ユーザーによる操作は必要ありません。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

  • 自動的に展開する

親トピック
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


アドミニストレーティブ イメージの展開に対する割り当て済みドライブの使用（Using a Mapped Drive to Deploy an Administrative Image）

アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーション指定には、UNCパス（\\マシン名\共有名）を用いることが推奨されます。しかしながら、インストールするユーザーが同じドライブ文字をアドミニストレーティブ イメージの共有ディレクトリにマッピングしていれば、アドミニストレーティブ イメージ内にあるStartSWInstall.htaファイルの場所として（U:\StartSWInstall.htaのように）割り当て済みドライブを使用することができます。

たとえば、アドミニストレーティブ イメージの共有ディレクトリにU:ドライブを割り当てた場合は、電子メールによりfile://U:\StartSWIOnstall.htaのクリックがユーザーに対して指示されます。電子メールを受け取ったユーザーは、U:ドライブがアドミニストレーティブ イメージに対するUNCロケーション（\\マシン名\共有名）に割り当てられていれば、問題なくインストールすることが可能です。

親トピック
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


StartSWInstall.exe によるアドミニストレーティブ イメージの展開

クライアント上でアドミニストレーティブ イメージをインストールまたはアンインストールするには、admin_image_install_dir\StartSWInstall.exe コマンドを実行します。 この方法により、アドミニストレーティブ イメージ オプション エディタで定義されたオプション、マシン、およびグループを使用して SOLIDWORKS がインストールされます。

StartSWInstall.exe コマンドには以下のオプションを追加できます。
/install | クライアント マシンにアドミニストレーティブ イメージをインストールします。
/uninstall クライアント マシンからソフトウェアをアンインストールします。次の 2 つのオプションを使用できます。

/removedata

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のデータ ファイルおよびフォルダを削除します。

/removeregistry

アンインストールの場合のみ有効です。 アンインストール時に SOLIDWORKS のレジストリ エントリを削除します。
/showui | SOLIDWORKS Installation Manager のプログレス ウィンドウを表示します。 指定しなかった場合、SOLIDWORKS Installation Manager はユーザーに対して非表示になります。
/now | インストールまたはアンインストールを直ちに開始します。 5 分間の警告ダイアログ ボックスは表示されません。

ユーザー操作なしでインストールを実行したいが、アドミニストレーティブ イメージ オプション エディターの自動展開を使用したくない場合は、StartSWInstall.hta ではなく StartSWInstall.exe を使用することを推奨します。

親トピック
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


手動で展開する

ユーザーに、システムへのインストールに必要な権限がある場合は、この方法を使用します。

電子メールを使用して手動でインストレーションを展開するには:

  1. オプション エディタで展開をクリックします。

    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。

  2. メール送信 をクリックします。
  3. アドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク パスを指定します。

    一般的にアドミニストレーティブ イメージのインストール ディレクトリに対するディレクトリ パスは、初期状態において、C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0 のような Windows のファイル パスで表示されます。 ダイアログ ボックスに このパスはネットワーク パスではありません が示されます。

    1. 参照 をクリックして、このアドミニストレーティブ イメージのインストール ディレクトリに対するネットワーク ロケーションを指定します。
    2. アドミニストレーティブ イメージがインストールされたコンピュータを探し、アドミニストレーティブ イメージに対するWindowsの共有ディレクトリを選択します。

      アドミニストレーティブ イメージの共有ディレクトリの内部（64bit のサブディレクトリなど）は選択しないでください。

    3. OK をクリックします。

      ダイアログ ボックスにはこのパスはネットワーク パスですと表示されます。

    電子メールが作成されます。このメールは、アドミニストレーティブ イメージ内の StartSWInstall.hta ファイルに対するネットワーク ロケーションを使用してアドミニストレーティブ イメージからインストールする方法をマシンの所有者に伝えるものです。

  4. SOLIDWORKS のインストール権限を持つユーザーに電子メールを送信してください。

ユーザーは電子メールに記述された StartSWInstall.hta に対するネットワーク ロケーションのリンクをダブルクリックすることで、アドミニストレーティブ イメージから SOLIDWORKS をインストールできます。

オプション エディターでは、インストレーション ステータス で次のように表示されます：
保留中 | ユーザーによる該当マシンへのインストールは未だ実施されていません。
成功 | ユーザーによる該当マシンへのインストールは無事完了しています。
失敗 | ユーザーによる該当マシンへのインストールが実施されましたが、失敗しました。

表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストールできませんでした」、「アンインストールできませんでした」。

親トピック
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動展開の前提条件

自動展開では、インストール タスクはターゲット マシンにプッシュされ、各システムで Microsoft タスク スケジューラによって実行されます。ユーザーによる操作は必要ありません。 この方法は、ユーザーがシステムにソフトウェアをインストールする管理権限を持っていない場合に使用します。

プッシュ インストールでは、タスク スケジューラは SOLIDWORKS Installation Manager を、管理者により指定された資格情報に従って動作するよう起動します。 タスク スケジューラはコンピュータの LocalSystem アカウントに従って動作します。 このアカウントはネットワーク上で、コンピュータ セキュリティ原則として表示されます。 コンピュータ セキュリティ原則には、アドミニストレーティブ イメージを置いてある共有フォルダへの読み取り権が必要です。

Active Directory では、共有フォルダのグループにコンピュータを追加する場合、オブジェクト タイプ（Object Types）を選択し、コンピュータ（Computers）が選択されていることを確認します。

また、アドミニストレーティブ イメージをホストするコンピュータとターゲット クライアント マシンが、同じ Active Directory ドメインのメンバーである必要があります。

親トピック
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


自動的に展開する

ユーザー システムにインストールをプッシュして自動的に展開するには:

  1. オプション エディタで自動配布タブをクリックします。

    それぞれのマシンに対するステータスと利用可能なインストールが表示されます。

  2. 展開 列では、展開（Deploy）列でターゲットのクライアント マシンとグループを選択します。

    展開プロセスを開始する前に、展開列で 1 つ以上のマシンまたはグループを選択する必要があります。

  3. インストール時間 で、今すぐ を選択してすぐに展開するか、後で実行 を選択して展開する特定の日時をスケジュールします。
  4. クライアント オプション で、次から選択します:
    • SOLIDWORKS 2015 インストールまたはアップグレード
    • SOLIDWORKS 2015 アンインストール
      アンインストールを選択する場合、プログラム ファイルおよびプログラム フォルダーと共にレジストリ エントリ、データ ファイル、データ フォルダーをアンインストールするかどうかを指定できます。
  5. 展開が完了したときにターゲット マシンを再起動するには、コンピュータを自動的に再起動します（Reboot computer automatically）を選択します。
  6. ターゲット マシンのクライアント 資格情報（Client Credentials）を入力します。
  7. 展開 をクリックして展開プロセスを開始します。
オプション エディタには次のようなインストレーション ステータスが表示されます:
保留中 | このマシンではまだインストールが実行されていません。
成功 | このマシンでのインストールは正常に完了しました。
失敗 | このマシンでのインストールは失敗しました。

表示される可能性がある他のステータスメッセージは、次のとおりです: 「正常にインストールされました」、「正常にアンインストールされました」、「スケジューリング」、「接続中」、「インストール中」、「アンインストール中」、「再起動が必要です」、「インストール スケジュール済」、「アンインストール スケジュール済」、「インストールできませんでした」、「アンインストールできませんでした」、「接続できませんでした」、「スケジュールできませんでした」。

親トピック
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）


オプション エディタの終了（Exiting the Option Editor）

オプション エディタを閉じるには、OKまたは閉じるをクリックします。

  • 変更内容を適用し、オプション エディタを閉じるにはOK、閉じる（Close）、あるいはWindowsアプリケーションの閉じるボタンをクリックします。
    • OKをクリックすると、オプション設定の変更内容が適用され、オプション エディタが終了します。
    • 閉じる（Close）をクリックすると、オプション エディタが終了します。

      適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。

    • Windowsアプリケーションの閉じるボタン（X）をクリックします。適用すべき変更内容が存在する場合には、それらを保存するか否かが質問されます。
親トピック
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタに対するデスクトップ ショートカットの作製
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


オプション エディタに対するデスクトップ ショートカットの作製

特定のアドミニストレーティブ イメージのためのオプション エディタに対するWindowsのデスクトップ ショートカットをアプリケーション内から作成することが可能です。

  1. オプション エディタを起動します。

    たとえばWindowsエクスプローラにおいて、アドミニストレーティブ イメージのインストール ディレクトリに移動し、sldAdminOptionEditor.exeをダブルクリックします。

  2. デスクトップにこのオプション エディタへのショートカットを作成（Create Desktop Shortcut to this Option Editor）をクリックします。

    該当するアドミニストレーティブ イメージに対するオプション エディタへのショートカットが、Windowsデスクトップに作成されます。

親トピック
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）
関連概念
グループとマシンの追加と削除（Adding and Deleting Groups and Machines）
オプション エディタからのインストレーションの展開（Deploying Installations from the Option Editor）
関連タスク
オプション エディタの終了（Exiting the Option Editor）
関連資料
オプション設定の表示と編集（Viewing and Editing Option Settings）


電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）

共有のアドミニストレーティブ イメージ ディレクトリを作成したら、電子メールでクライアントに通知できます。

アドミニストレーティブ イメージ ディレクトリは、他のコンピュータからアクセス可能なマシン（例えば、UNCパス経由）で共有されるように設定します。

すべてのクライアントに admin_image_install_dir\StartSWInstall.hta へのリンクを含む電子メールを送信できます。 その後、クライアントはこのリンクをクリックし、続いて SOLIDWORKS 製品のインストール開始（Install SOLIDWORKS products now） をクリックし、アドミニストレーティブ イメージからのインストレーションを開始します。

新しい SOLIDWORKS バージョンのアドミニストレーティブ イメージをアップグレードしている場合は、そのイメージを使用して前にインストールしたクライアントが自動的にアップグレードされるように、アドミニストレーティブ イメージの場所と共有プロパティを設定できます。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。
親トピック
複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
コマンドラインによる展開（Command-Line Deployment）
複数インストレーションの管理（Administration of Multiple Installations）
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）


コマンドラインによる展開（Command-Line Deployment）

コマンド プロンプト/バッチ ファイルによってアドミニストレーティブ イメージを自動的に展開（サイレント インストレーション）できます。

コマンドラインを使用して SOLIDWORKS PDM クライアントにアドミニストレーティブ イメージを配布するには、SOLIDWORKS PDM インストール ガイドを参照してください。

目次

  • アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

    アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

  • コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

    コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

  • コマンドライン プロパティ（Command-Line Properties）

    ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

  • Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

    Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

  • Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）

    次の手順に従い、Microsoft Windows Active Directory を使用してクライアント コンピュータに SOLIDWORKS をインストールする既存のアドミニストレーティブ イメージを用意します。

親トピック
複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
複数インストレーションの管理（Administration of Multiple Installations）


アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）

アドミニストレーティブ イメージを作成した後でクライアントに通知する前に、コマンドラインまたはMicrosoft Active Directoryを使用して作成したアドミニストレーティブ イメージではインストールできないMicrosoft Windowsコンポーネントをインストールする必要があります。

これらの Windows コンポーネントのマニュアル インストールは、コマンドラインの使用または Microsoft Active Directory によってアドミニストレーティブ イメージからインストールする場合のみに必要となります。 SOLIDWORKS Installation Manager でアドミニストレーティブ イメージを作成してインストールする場合、これらの Windows コンポーネントは自動的にインストールされます。
以下は、Windows コンポーネントに含まれる SOLIDWORKS で必要とするファイルをまとめたものです。
Office Webコンポーネント | DriveWorksに必要なCOMコントロールを含みます。
Visual C++ 2005、2008、2010、および 2012 再頒布可能パッケージ | Microsoft Visual C++の実行に必要なランタイム コンポーネントを含みます。 2005、2008、2010、および 2012 のバージョンがインストールされている必要があります。
Visual Basic for Applications 7.1 | Visual Basic のマクロをサポートします。
Visual Studio Tools for Applications | Visual Studio アプリケーションをサポートするツール セットを含みます。 SOLIDWORKS 2013 では、Microsoft Visual Studio Tools for Applications（VSTA）のインストールはオプションです。 VSTA は、コンピュータにインストールされている Microsoft .NET Framework 3.5 に依存します。 Windows 7 以降では、.NET Framework はオペレーティング システムの機能に含まれています。 .NET Framework 3.5 のインストールが必要な場合、これは Windows メディアに収録されています。あるいはインターネットから入手できます。 Windows メディアがない場合、インターネットに接続できない場合、あるいは Microsoft .NET Framework 3.5 をコンピュータにインストールする権限がない場合は、使用しているコンピュータの管理者に問い合わせてください。
Visual Studioリモート デバッガ | 64-ビット オペレーティング システムのデバッグ環境を提供します。
.NET Framework 4.5 | .NET Framework 4.5 アプリケーションの実行に必要な共通語のランタイムと .NET Framework コンポーネントが含まれています。
Bonjour service for Windows | ローカル エリア ネットワークでサービスを検出する機能です。
Visual C++ 再頒布可能パッケージと .NET Framework 4.5 は、コア SOLIDWORKS 製品だけではなく、すべての SOLIDWORKS 製品に必要です。

これらのコンポーネントはアドミニストレーティブ イメージのサブディレクトリに含める必要があります。

サポートされるオペレーティング システムで必要なファイルは次の通りです:
オペレーティング システム: Windows Server 2008 R2 64-bit SOLIDWORKS Media メディア: Windows 7 用の 64 ビット バージョン
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server、Workgroup PDM Server、および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Installer: | （適用不可）
Office Webコンポーネント: | owc11.exe
Visual C++ 2005 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: (オプション) | vsta_aide.msi
VSTA がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Bonjour service for Windows: | bonjour64.msi
OS: Windows Server 2012 および 2012 R2 64-bit SOLIDWORKS Media メディア: Windows 7 用の 64 ビット バージョン
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server、Workgroup PDM Server、および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Installer: | （適用不可）
Office Web コンポーネント: | owc11.exe
Visual C++ 2005 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2008 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: （オプション） | vsta_aide.msi
VSTA がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio リモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Bonjour service for Windows: | bonjour64.msi
OS: Windows Server 2012 および Windows Server 2012 R2 64-bit SOLIDWORKS Media メディア: Windows 8 および 8.1 用の 64 ビット バージョン
Windows Server 2008 R2 または Windows Server 2012 および 2012 R2 でのインストールは、SOLIDWORKS PDM Server、Workgroup PDM Server、および SOLIDWORKS SolidNetWork License Manager でサポートされています。
Windows Installer: | （適用不可）
Office Web コンポーネント: | owc11.exe
Visual C++ 2005 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2008 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 20102 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: （オプション） | vsta_aide.msi
VSTA がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 8 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio リモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .NET 4.5 は、この要件を満たすオペレーティング システムの一部です。
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows 7 64-bit SOLIDWORKS Media メディア: Windows 7 用の 64 ビット バージョン
Windows Installer: | （適用不可）
Office Webコンポーネント: | owc11.exe
Visual C++ 2005 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2008再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: (オプション) | vsta_aide.msi
VSTA がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studioリモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .netfx45_full_x86_x64.exe
Bonjour service for Windows: | bonjour64.msi
オペレーティング システム: Windows 8 および 8.1 64-bit SOLIDWORKS Media メディア: Windows 8 用の 64 ビット バージョン
Windows Installer: | （適用不可）
Office Web コンポーネント: | owc11.exe
Visual C++ 2005 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2008 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2010 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual C++ 2012 再頒布可能パッケージ: | vcredist_x86.exe vcredist_x64.exe 両方がインストールされている必要があります。
Visual Studio Tools for Applications: （オプション） | vsta_aide.msi
VSTA がインストールされている場合は、.NET 3.5 Framework（dotnetfx35.exe）が必要です。 Windows 7 の場合、.NET Framework 3.5 はオペレーティング システムの機能に含まれています。
Visual Studio リモート デバッガ: | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5: | .NET 4.5 は、この要件を満たすオペレーティング システムの一部です。
Bonjour service for Windows: | bonjour64.msi

目次

  • 64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

    次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールします。

親トピック
コマンドラインによる展開（Command-Line Deployment）
関連概念
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


64-bitオペレーティング システム上のコマンドラインからのWindows前提条件のインストール（Installing Windows Prerequisites from the Command Line on 64-bit Operating Systems）

次の手順に従い、64-bit バージョンの Windows でコマンドラインを使用したアドミニストレーティブ イメージ インストレーションのために Windows 前提条件をインストールします。

1回のインストール作業で複数のコンポーネントをインストールするには、次の手順にあるコマンドでバッチ ファイルを作成し、コンポーネントをクライアント コンピュータにインストールします。

  1. ターゲットのコンピュータに最低620 MBの空き容量と、有効なTEMPディレクトリがあることを確認します。
  2. 次のコマンドを実行し、Office Webコンポーネントをインストールします。

    administrative_image_directory\OfficeWeb_11\owc11.exe/quiet

  3. Visual C++ RELEASE 再頒布可能パッケージをインストールします。

    RELEASE = 2005、2008、2010、および 2012 用のパッケージをインストールします。

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    administrative_image_directory\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    このパッケージの 32-bit バージョンと 64-bit バージョンの両方をインストールする必要があります。

    たとえば、Visual C++ 2005 再頒布可能パッケージをインストールするには、以下を使用します。

    • administrative_image_directory\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q
    • administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  4. Microsoft .NET Framework 4.5 をインストールします。

    administrative_image_directory\.Net_Framework_4.5\dotnetfx45_full_x86_x64.exe

  5. Visual Studio Tools for Applicationsをインストールします：

    administrative_image_directory\Microsoft_VSTA\vsta_aide.msi

    VSTA をインストールする場合は、.NET Framework 3.5 が必要です。

    Windows 7 以降では、.NET Framework 3 はオペレーティング システムの機能として実装されています。

  6. Visual Studioリモート デバッガをインストールします。

    administrative_image_directory\VSRemoteDebugger\install.exe /Q

  7. Visual Basic 7.1 をインストールします。

    administrative_image_directory\Microsoft_VBA\vba71.msiおよびadministrative_image_directory\Microsoft_VBA\vba71_1033.msiはすべての言語で必要です。

    このパッケージでは 64-bit バージョンのみ、インストールが必須です。

    さらに、目的の言語用に次のパッケージをインストールします。

    vba71_1028.msi | 中国語
    vba71_1031.msi | ﾄﾞｲﾂ語
    vba71_1036.msi | ﾌﾗﾝｽ語
    vba71_1040.msi | イタリア語
    vba71_1041.msi | 日本語
    vba71_1042.msi | Korean
    vba71_1046.msi | ポルトガル語(ブラジル)
    vba71_2052.msi | 中国語（簡体字）
    vba71_3082.msi | スペイン語
    英語、チェコ語、ポーランド語、ロシア語、およびトルコ語では、言語パッケージを追加する必要がありません。
    SOLIDWORKS 2013 Service Pack 2.0 では、追加の前提条件をインストールする必要があります: Msiexec.exe /p vba71-kb27832-x64.msp

  8. Windows に Bonjour サービスをインストールします。

    administrative_image_directory\Bonjour\Bonjour64.msi

親トピック
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）


コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）

コマンドラインを使用したアドミニストレーティブ イメージからインストレーションを展開できます。

サイレント インストールを行うには:

  1. コマンド プロンプト ウィンドウを開きます（Windowsでスタート > ファイル名を指定して実行をクリックします）。
  2. msiexec.exeコマンドを/iと/qbオプションを使用して入力し、デフォルト値とは異なる値を指定する任意のオプションのプロパティを設定します。
インストール コンポーネントのコマンドライン プロパティには次が含まれます：
  • コマンドラインの機能プロパティ（Command-Line Feature Properties）
  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）
  • eDrawings コマンドライン プロパティ
  • SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

次の例をサイレント インストレーションのテンプレートとして使用してください。

SOLIDWORKS Client

  • SOLIDWORKS コア (英語)
  • Toolboxアドイン
  • フィードバック プログラムに参加
  • フランス語

SOLIDWORKS:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

SOLIDWORKS フランス語インストール コンポーネントは個別にインストールする必要があります:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

SOLIDWORKS 言語コンポーネントのインストール コマンドを指定する際には、コマンド ライン引数を指定しないでください。

eDrawings クライアント

  • ログ パフォーマンス
  • すべての機能

msiexec /i "admin_image_path\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Explorer と Workgroup PDM アドイン

  • SOLIDWORKS Explorer と Workgroup PDM アドイン

msiexec /i "admin_image_path\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Program Files\your_folder" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb

SOLIDWORKS Electrical

Microsoft SQL Server とともに SOLIDWORKS Electrical をインストールする場合の技術的な複雑さが原因で、SOLIDWORKS Electrical のコマンド ラインの例はドキュメントから除外されています。

親トピック
コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


コマンドライン プロパティ（Command-Line Properties）

ここで説明するコマンドライン プロパティには、機能プロパティ、グローバル プロパティ、製品特有のプロパティ、およびWindowsの位置表記が含まれます。

目次

  • コマンドラインの機能プロパティ（Command-Line Feature Properties）

    SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • コマンドラインのグローバル プロパティ（Command-Line Global Properties）

    各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

  • eDrawings コマンドライン プロパティ

    これらのコマンドライン プロパティは eDrawings® 特有のものです。

  • SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

    これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

  • SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）

    これらのコマンドライン プロパティは SOLIDWORKS Explorer と SOLIDWORKS Workgroup PDM 特有のものです。

  • SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

    これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

  • SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

    これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

  • アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

    コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

親トピック
コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


コマンドラインの機能プロパティ（Command-Line Feature Properties）

SOLIDWORKS のインストレーションでは、コマンドラインによる展開の ADDLOCAL プロパティをサポートしています。

  • CircuitWorks
  • CoreSOLIDWORKSTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
コマンドライン インストールのプロパティを指定する際の注意：
  • SOLIDWORKS は ADDSOURCE オプションを使用したインストレーションはサポートしません。
  • プロパティでは、大文字と小文字が識別されます。 またコマンドラインには、スペースやダッシュを含むことはできず、コンマで区切る必要があります。

    アプリケーションを正確にインストールするには、大文字と小文字が組み合わされた SOLIDWORKS を指定する必要があります。

親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


コマンドラインのグローバル プロパティ（Command-Line Global Properties）

各プロパティは、注記がある場合を除き、アドミニストレーティブ（管理者用）、または個人インストレーション用に定義されています。グローバル プロパティを使用してアドミニストレーティブ（管理者用）インストレーションと個人インストレーションの両方にシリアル番号を指定できます。

プロパティ | 説明
ENABLEPERFORMANCE SOLIDWORKS 社に自動的にパフォーマンス データを送信するかどうかを指定します。

1

パフォーマンス データを送信します。

0

パフォーマンス データを送信しません。
INSTALLDIR SOLIDWORKS インストレーション フォルダです。

個人インストレーションのみ。
MBDSERIALNUMBER | SOLIDWORKS モデル ベース定義のプロダクトのシリアル番号です。
MOTIONSERIALNUMBER | SOLIDWORKS Motion プロダクトのシリアル番号です。
OFFICEOPTION インストールする製品パッケージを指定します。
0 | SOLIDWORKS Client
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL 現在インストールされている機能すべてを更新するには、ALL を指定します。
このプロパティは、既存のメジャー リリース内のサービス パック リリースへの更新（たとえば、既存の SOLIDWORKS 2015 SP01 インストールから SOLIDWORKS 2015 SP02 への更新）にのみ指定してください。
REINSTALLMODE Microsoft Installer の再インストール オプションです。

たとえば、あるサービスパック リリースから別のサービス パックへ、同じメジャーリリース内でアップグレードする場合は REINSTALLMODE=vomus を指定します。

REINSTALLMODE の設定の詳細については、www.microsoft.com にある Windows Installer の関連ドキュメントを参照してください。

このプロパティは、既存のメジャー リリース内のサービス パック リリースへの更新（たとえば、既存の SOLIDWORKS 2015 SP01 インストールから SOLIDWORKS 2015 SP02 への更新）にのみ指定してください。 このプロパティは、SOLIDWORKS の新しいメジャー リリースを最初にインストールする際には指定しないでください。
SERVERLIST SolidNetWorkサーバー リストです。
SolidNetWork サーバー リストは、セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットを持つサーバー上のポート番号を表します。

xxxxx@server_name1;yyyyy@server_name2;&

ここで、x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。

個人インストレーションのみ。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation プロダクトのシリアル番号です。
SOLIDWORKSSERIALNUMBER | SOLIDWORKS プロダクトのシリアル番号です（すべてのアドインが含まれます）。
SWMIGRATE アップグレードする SOLIDWORKS のバージョンを指定します。このリストは SOLIDWORKS インストレーションの選択 ダイアログ ボックスに表示されます。 例:

SWMIGRATE="SOLIDWORKS 2015 x64 Edition SP01"

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。 このプロパティは、同じメジャー リリース内で 1 つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
TOOLBOXFOLDER SOLIDWORKS Toolbox ファイルのインストレーション フォルダです。

個人インストレーションのみ。

例: TOOLBOXFOLDER = "c:\SOLIDWORKS Data"
TRANSFORMS 次の形式で言語固有のアイテムを含めます。
TRANSFORMS number.mst
  • 中国語（台湾）（1028）
  • 中国語（中国）（2052）
  • チェコ語（1029）
  • 英語（1033）
  • フランス語（1036）
  • ドイツ語（1031）
  • イタリア語（1040）
  • 日本語（1041）
  • 韓国語（1042）
  • ポーランド語（1045）
  • ポルトガル語（ブラジル）（1046）
  • ロシア語（1049）
  • スペイン語（1034）
  • トルコ語（1055）
UPGRADESWINSTALL
既存の SOLIDWORKS のバージョンを現在のバージョンにアップグレードするかどうかを指定します。
0 | 新規インストレーション、アップデートなし。
1 | 更新

個人インストレーションのみ。

このプロパティは、前にインストールしたメジャー リリースが存在する場合に新しいメジャー リリースをインストールする場合にのみ指定してください。 このプロパティは、同じメジャー リリース内で 1 つのサービス パックから別のサービス パックにアップグレードする場合には指定しないでください。
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


eDrawings コマンドライン プロパティ

これらのコマンドライン プロパティは eDrawings® 特有のものです。

プロパティ（Properties） | 説明
ADDLOCAL インストールする eDrawings アプリケーション機能を指定します。
All が推奨オプションです。
コマンドライン構文 | フィーチャー
すべて | 全機能をインストールします。 eDrawings はインストール済みの SOLIDWORKS と AutoCAD の Publisher を検索し、インストールを有効にします。
CALS | eDrawings Viewer で CAL ファイルを表示
Inventor | Autodesk Inventor アプリケーションから eDrawings ファイルを作成します。
eDrawingsViewer | eDrawings やその他のファイルを表示します。
ProE | eDrawings Viewer を使用して ProE ファイルを表示
DXFDWGTranslator | eDrawings Viewer で DXF/DWG ファイルを表示します。
Shortcuts | デスクトップ ショートカットをインストールします。
XML3D | eDrawings Viewer で 3DXML ファイルを表示します。
INSTALLDIR | eDrawings のためのインストレーション フォルダーを指定します。
LOGPERFORMANCE SOLIDWORKS Corporation に自動的にパフォーマンス データを送信するかどうかを指定します。
1 | パフォーマンス データを送信する
0 | 送信しない
SNLSERVER SolidNetWork License Server の ポート@サーバー名 を入力します。 複数の ポート@サーバー名 の組み合わせはセミコロンで区切ります。

SNLSERVER のポート サーバー名は SOLIDWORKS SNL サーバーを設定する場合にのみ必要です。 ポート_の_リスト@サーバー_ストリング はセミコロンで区切られているストリングのリストであり、それぞれのストリングは、次のフォーマットをもつサーバー上のポート番号を表します:

xxxxx@サーバー_名1; yyyyy@サーバー_名2;

ここで、x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Composer/Composer Player コマンドライン プロパティ

これらのコマンドライン プロパティは、SOLIDWORKS Composer と SOLIDWORKS Composer Player に特有のものです。

SOLIDWORKS Composer の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Composer のシリアル番号。
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
ADDLOCAL 完全なアプリケーションをインストールする場合は、以下のアイテムを指定する必要はありません。
必須:
  • ライセンス契約（Licensing）
  • Documents_2D
  • Eula
  • InterOps
  • LicenseSupportFiles
  • PlugIns
  • SWComposerCommon
  • SWPlayer
これはオプションです。
  • Sync3Dvia
INSTALLDIR | SOLIDWORKS Composer ソフトウェアをインストールするフォルダを指定します。

SOLIDWORKS Composer Player の場合:

プロパティ(Properties) | 説明
ACTIVSERIALNUMBERPLAYERPRO | この操作はオプションです。 SOLIDWORKS Composer Player Pro のシリアル番号。
INSTALLDIR | SOLIDWORKS Composer Player ソフトウェアをインストールするフォルダを指定します。
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）

これらのコマンドライン プロパティは SOLIDWORKS Explorer と SOLIDWORKS Workgroup PDM 特有のものです。

SOLIDWORKS Explorer/Workgroup PDM クライアントの場合:
クライアント プロパティ | 説明
EXPLORERORPDM
0 | SOLIDWORKS Explorer のみ
1 | Workgroup PDM機能インストール可能
ADDLOCAL
  • Standalone
  • クライアント
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone は Contributor で、Client は SOLIDWORKS Explorer サイレント インストレーションの SOLIDWORKS アドインです。

AutoCAD を指定する場合、システムに AutoCAD をインストールしておく必要があります。 Workgroup PDM は、適切なAutoCADのバージョンを検知します。 複数の AutoCAD バージョンを指定できます:

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 と DocMgr64 は 64-bit の SOLIDWORKS Explorer インストレーションのみで使用できます。

INSTALLDIR | Workgroup PDMのインストレーション フォルダを指定します。
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS シリアル番号を指定します。
Workgroup PDMサーバーの場合:
サーバー プロパティ | 説明
ADDLOCAL
  • ボルト（Vault）
  • WebPortal
  • API

WebPortal（Viewer）を指定した場合は VAULTNAME も指定する必要があります。
INSTALLDIR | Workgroup PDMのインストレーション フォルダを指定します。
LICENSE_SERVER | ライセンス サーバーが保存されているコンピュータ名を指定します。
VAULTDATA | ボルトのフォルダ名とパス名を指定します。
VAULTNAME | ボルトが保存されているコンピュータ名を指定します。
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）

これらのコマンド ライン プロパティは SOLIDWORKS Flow Simulation 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） SOLIDWORKS Flow Simulation スタンドアロン シリアル番号です。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

CWUPGRADEINSTALL 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアの既存バージョンをアップグレードします。
1 | アップデート
2 | 新規インストレーション、新規ディレクトリにインストール

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

INSTALLDIR 特定の SOLIDWORKS Flow Simulation アプリケーション ソフトウェアのインストレーションを指定します。

（個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
SOLIDWORKSPATH SOLIDWORKS ソフトウェアのインストール フォルダを指定します。

（アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。

親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）

これらのコマンドライン プロパティは SOLIDWORKS 特有のものです。

プロパティ | 説明
ACTIVSERIALNUMBER ‏‎（日本語版未対応） | SOLIDWORKS Inspection のシリアル番号。 （アドミニストレーティブ イメージからの個人インストレーションとクライアント インストレーション）。
INSTALLDIR | SOLIDWORKS Inspection アプリケーション ソフトウェアのインストールを指定します。 （個人インストレーションのみ）。
SERVERLIST | セミコロンで区切られているストリングのリストであり、それぞれのストリングは次のフォーマットをもつサーバー上のポート番号を表します。 xxxxx@サーバー_名1; yyyyy@サーバー_名2;& ここで x と y は 1 桁の数字です。 リスト内の最後のサーバーの後にはセミコロンを追加しないでください。
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）


アドミニストレーティブ イメージのためのMSIファイルの場所（MSI File Locations for Administrative Images）

コマンド ラインからアドミニストレーティブ イメージを作成する際、製品コンポーネントの .msi ファイルは SOLIDWORKS メディアの次の場所に保存されています。

SOLIDWORKS （コア製品、英語版）

swwi\data\SOLIDWORKS.msi

SOLIDWORKS （英語以外の言語コンポーネント）

中国語（台湾） | swwi\lang\chinese\chinese.msi
中国語（中国） | swwi\lang\chinese-simplified\chinese-simplified.msi
チェコ語 | swwi\lang\czech\czech.msi
フランス語 | swwi\lang\french\french.msi
ドイツ語 | swwi\lang\german\german.msi
イタリア語 | swwi\lang\italian\italian.msi
日本語 | swwi\lang\japanese\japanese.msi
Korean | swwi\lang\korean\korean.msi
ポーランド語 | swwi\lang\polish\polish.msi
ポルトガル語（ブラジル） | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
Russian | swwi\lang\russian\russian.msi
スペイン語 | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings Shaders

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 Network Render

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS アクティベーション ウィザード

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Explorer

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional には API が用意されていますが、Client でのみ使用可能で、.msi では使用できません。 詳細については、SOLIDWORKS PDM Client の install\API ディレクトリにある API ガイドを参照してください。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS Viewer

swviewer\SOLIDWORKS Viewer.msi

Workgroup PDM Server

pdmwserver\SOLIDWORKS Workgroup PDM Server.msi
親トピック
コマンドライン プロパティ（Command-Line Properties）
関連資料
コマンドラインの機能プロパティ（Command-Line Feature Properties）
コマンドラインのグローバル プロパティ（Command-Line Global Properties）
eDrawings コマンドライン プロパティ
SOLIDWORKS Composer/Composer Player コマンドライン プロパティ
SOLIDWORKS Explorer/Workgroup PDM コマンドライン プロパティ（SOLIDWORKS Explorer/Workgroup PDM Command-Line Properties）
SOLIDWORKS Flow Simulation コマンド ライン プロパティ（SOLIDWORKS Flow Simulation Command Line Properties）
SOLIDWORKS Inspection コマンド ライン プロパティ（SOLIDWORKS Inspection Command Line Properties）


Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）

Microsoft Active Directory による展開では、SOLIDWORKS コア製品のクライアントへの展開もサポートされます。

Microsoft Active Directoryはネットワーク環境にあるクライアントとサーバーを管理するためのディレクトリ サービスです。 これにより、管理、移行、展開がシンプルになります。

  1. SOLIDWORKS Installation Manager を使用して管理イメージを作成します。
  2. コマンドラインを使用してアドミニストレーティブ イメージを作成した場合は、Microsoft Active Directoryを使用したアドミニストレーティブ イメージからのインストレーションのためにWindows前提条件をインストールします。 詳細は Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory） を参照してください。

    このステップはコマンドラインを使用してイメージをマニュアルで作成した場合のみ実行します。 SOLIDWORKS Installation Manager を使用してイメージを作成した場合は、すべての Windows 前提条件は自動的にインストールされます。

  3. トランスフォーム ファイルを作成して SOLIDWORKS ソフトウェアをユーザー定義します。
    1. コマンド プロンプト ウィンドウを開きます。
    2. アドミニストレーティブ イメージを含むフォルダーでSWCreateMST.exeをコマンド プロンプト ウィンドウ内にドラッグします。

      コマンドは、次のフォーマットにする必要があります。

      アドミニストレーティブ_イメージ_ディレクトリ\SWCreateMST.exe アドミニストレーティブ_イメージ_の_MSI_ファイル_へ_の_パスプロパティ_の_リスト

      プロパティは、機能プロパティまたはグローバルプロパティになります。 詳細は コマンドラインの機能プロパティ（Command-Line Feature Properties）、および コマンドラインのグローバル プロパティ（Command-Line Global Properties） を参照してください。

      次の例をテンプレートとして使用します。

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      トランスフォーム ファイル SOLIDWORKS.mst は、アドミニストレーティブ イメージを含むフォルダに作成されます。

  4. Active Directory でグループ、または複数グループの Published Apps ポリシーを編集して SOLIDWORKS ソフトウェアを展開します。
  5. グループ ポリシー ダイアログ ボックスでコンピュータの構成とソフトウェアの設定を展開します。
  6. ソフトウェア インストールを右クリックし、新規作成 > パッケージを選択します。
  7. アドミニストレーティブ イメージまで参照し、開く（Open）をクリックします。
  8. ソフトウェアの展開 ダイアログ ボックスで 公開または割り当て時の詳細設定 を選択してから、OK をクリックします。
  9. SOLIDWORKS プロパティ (SOLIDWORKS Properties) ダイアログ ボックスの [変更 (Modifications)] タブで次を行います。
    1. 追加 をクリックします。
    2. .mstファイルを参照します。
    3. 開く をクリックします。
  10. OK をクリックします。
親トピック
コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）


Microsoft Active Directoryを使用したWindows前提条件のインストール（Installing Windows Prerequisites Using Microsoft Active Directory）

次の手順に従い、Microsoft Windows Active Directory を使用してクライアント コンピュータに SOLIDWORKS をインストールする既存のアドミニストレーティブ イメージを用意します。

  1. Visual C++ 再頒布可能パッケージ インストーラ ファイルをすべて抽出してインストールします。
    1. Visual C++ 2005

      1. administrative_image_directory\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2005_Redistributable_(64)\vcredist_x64.exe /C /T: {Target Directory}
      3. Microsoft C++ 2005 再頒布可能モジュールをインストールするためのポリシーを作成します。

    2. Visual C++ 2008

      1. administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {Target Directory}
      2. administrative_image_directory\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x: {Target Directory}
      3. Microsoft C++ 2008 再頒布可能モジュールをインストールするためのポリシーを作成します。

    3. Visual C++ 2010

      1. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{Target Directory}
      2. administrative_image_directory\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{Target Directory}
      3. Microsoft C++ 2010 再頒布可能モジュールをインストールするためのポリシーを作成します。

    4. Visual C++ 2012

      1. テストマシンに admistrative_image_directory\Microsoft_C++_2012_Redistributable\vcredist_x86.exe をインストールします。
      2. ネットワーク ロケーションにこれらのフォルダをコピーします（Target Directory）:
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
      3. 次のファイルをインストールするためのポリシーを作成します:
        ファイル パスにはスペースを含められません。

        Target Directory\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Target Directory\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      4. テスト マシンに administrative_image_directory\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe をインストールします。
      5. ネットワーク ロケーションにこれらのフォルダをコピーします（Target Directory）:
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      6. 次のファイルをインストールするためのポリシーを作成します:
        ファイル パスにはスペースを含められません。

        Target Directory\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Target Directory\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Target Directory\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Microsoft .NET Framework 4.5 をインストールします。

    SOLIDWORKS では、.NET Framework 4.5 のインストールには Windows Updates Services (WSUS) または同様のサービスを使用することを推奨します。

  3. Office Webコンポーネント ファイルを抽出し、インストールします。
    1. 次のコマンドを実行します:

      アドミニストレーティブ_イメージ_ディレクトリ\OfficeWeb_11\owc11.exe /extract:{Office_Web_components_directory}

    2. Office Webコンポーネントをインストールするためのポリシーを作成します：

      {Office_Web_components_directory}\owc11.MSI

      このインストレーションでは、トランスフォーム ファイルは必要ありません。

  4. 次のポリシーを作成して、Visual Studio リモート デバッガをインストールします（.Net Framework 3.5 がコンピューターにインストールされている場合は 64 ビット バージョンのみ）。

    {Microsoft_remote_debugger_directory}\rdbgexp.MSI

    このインストレーションでは、トランスフォーム ファイルは必要ありません。

  5. 次のタスクを行います。
    1. vba71-kb2783832-x64 サービス パックを使用してアプリケーション用に Visual Basic 7.1 を更新します。
    2. 管理イメージの作成後に、次のコマンドを実行します。

      Msiexec /a {SOLIDWORKS アドミニストレーティブ イメージ}/Microsoft_vba/vba71.msi /p {SOLIDWORKS アドミニストレーティブ イメージ}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp

    3. 次のポリシーを作成して、Visual Basic 7.1 をインストールします。

      {VBA directory}\vba71.MSI

      このインストレーションでは、トランスフォーム ファイルは必要ありません。

  6. 次のポリシーを作成し、Visual basic 7.1言語パックをインストールします。

    {VBA directory}\vba71_nnnn.MSI

    このnnnnの部分で必要な言語を定義します。
    • 1028 = 中国語
    • 1031 = ドイツ語
    • 1033 = 英語
    • 1036 = フランス語
    • 1040 = イタリア語
    • 1041 = 日本語
    • 1042 = 韓国語
    • 1046 = ポルトガル語
    • 2052 = 中国語 - 中国
    • 3082 = スペイン語

  7. 次のポリシーを作成して、Bonjour Serviceをインストールします。

    {Bonjour directory}\Bonjour.MSI

    このインストレーションでは、トランスフォーム ファイルは必要ありません。

親トピック
コマンドラインによる展開（Command-Line Deployment）
関連概念
アドミニストレーティブ イメージからのコマンドライン インストレーションに向けたクライアントの準備（Preparing Clients for Command-Line Installation from an Administrative Image）
コマンドラインを使用したアドミニストレーティブ イメージからのインストール（Installing from the Administrative Image Using the Command Line）
コマンドライン プロパティ（Command-Line Properties）
関連タスク
Microsoft Active Directoryを使用したアドミニストレーティブ イメージの展開（Deploying an Administrative Image Using Microsoft Active Directory）


複数インストレーションの管理（Administration of Multiple Installations）

複数インストレーションの場合、管理タスクには新しいリリースへのアドミニストレーティブのアップグレード、ServicePack製品アップデートの適用、インストレーションの削除が含まれます。

目次

  • 新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

    アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

  • ServicePack製品アップデートの管理（Service Pack Product Update Administration）

    ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

  • インストレーションの削除（Removing an Installation）

    個人コンピュータ上、およびクライアント/サーバー環境で、インストレーションを削除することができます。

親トピック
複数インストレーション（Multiple Installations）
関連概念
複数クライアントへの展開（Deploying to Multiple Clients）
アドミニストレーティブ イメージの使用（Using Administrative Images）
電子メールによるクライアントへのアドミニストレーティブ イメージの展開（Deploying an Administrative Image to Clients Through Email）
コマンドラインによる展開（Command-Line Deployment）


新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）

アドミニストレーティブ イメージからインストールしたクライアントをアップデートするには、まずアドミニストレーティブ イメージをアップデートしてから新しいイメージのコピーを参照するようにクライアントを設定します。

SOLIDWORKS Installation Manager をインターネットから実行し、正しいファイルが参照されるようにします。 SOLIDWORKS Installation Manager は自動的にリダイレクトされますが、SOLIDWORKS Downloads Web サイト（http://www.solidworks.com/sw/support/downloads.htm）からアップデートを直接実行することもできます。

アドミニストレーティブ イメージをアップデートすると（新しいイメージのコピーが作成されます）、新しいアドミニストレーティブ イメージのコピーを参照することによってクライアントを更新できます。

クライアントが、前のバージョンのネットワークドライブに割り当てられている、または共有ディレクトリにあるアドミニストレーティブ イメージを参照していた場合、ネットワークドライブに割り当てられている、または共有ディレクトリのアドミニストレーティブ イメージの位置を更新することによって再定義することができます。

目次

  • アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  • アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

    アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

  • アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

    SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

親トピック
複数インストレーションの管理（Administration of Multiple Installations）
関連概念
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージのアップグレード時に、いつアップデートされたインストレーション ファイルが必要となるかを検知します。

  1. DVD をメディアに挿入し、SOLIDWORKS Installation Manager を開始します。
  2. ようこそ(Welcome) スクリーンで、アドミニストレーティブ イメージ(Administrative image)をクリックします。
  3. シリアル番号 画面で、SOLIDWORKS のシリアル番号を入力します。

    SOLIDWORKS Installation Manager は、ライセンスのある製品と使用可能なサービス パックが SOLIDWORKS Web サイトにあるかどうかをチェックします。

  4. 利用可能なより新しいバージョン（Newer Version Available）画面が表示されたら、 はい、新しいバージョンをダウンロードﾞしてインストールします：バージョン（Yes, download and install a newer version: version）を選択します。

    SOLIDWORKS Installation Manager が新しいバージョンをインストールするためのセッションを新たに開始します。

  5. ダウンロード フォルダーに問題がある場合は、ダウンロード オプション（Download Options）が表示されるかもしれません。この場合は、新しいインストレーション ファイルのデフォルトのディレクトリを確定するか、または新しいディレクトリ名を入力します。

    ディレクトリが存在しない旨を伝えるメッセージが表示された場合は、はい（Yes）をクリックしてディレクトリを作成します。

  6. ダウンロード完了（Download Complete）画面で閉じる（Close）をクリックして現在のインストーラを閉じ、新規バージョンのインストーラを開始します。
親トピック
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連概念
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
関連タスク
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）


アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

アドミニストレーティブ イメージをアップグレードするため、SOLIDWORKS Installation Manager は新しいイメージ ディレクトリを作成します。 その後、その製品バージョンにアップグレードするため新しいアドミニストレーティブ イメージ ディレクトリを使用するよう、クライアントに指示します。

このプロセスは、アドミニストレーティブ イメージのすべてのアップデートされたインストレーション ファイルのダウンロードが行われていることを前提とします。 詳細は、アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロードを参照してください。

  1. SOLIDWORKS Installation Manager を起動します。 詳細は、SOLIDWORKS インストレーションの開始を参照してください。
  2. ようこそ 画面で アドミニストレーティブ イメージ を選択します。

    アドミニストレーティブ イメージの作成オプションが表示されます。

    オプション | 説明
    新規イメージをデフォルト設定を使用して作成します。（Create a new image using default settings） | デフォルト設定を使用してイメージを作成します（現在のサイトの既存のアドミニストレーティブ イメージに対して設定されている設定ではなく）。
    新規イメージを既存のイメージの設定とファイルを使用して作成します。（Create a new image using settings and files from an existing image.） | 現在のサイトの既存のアドミニストレーティブ イメージに指定されている設定を使用してイメージを作成します。 参照 をクリックして既存のアドミニストレーティブ イメージのインストール ディレクトリを指定します。
  3. シリアル番号 画面でシリアル番号を確認します。
  4. サマリー（イメージ作成の準備完了）画面で、アドミニストレーティブ イメージのオプションが正しいかどうか確認します。

    個々のアドミニストレーティブ イメージとインストレーション オプションの詳細については、変更（CHANGE）をクリックしてオプション ページに移動してから、ヘルプ（Help）をクリックします。

  5. アドミニストレーティブ イメージの新しいバージョンを作成するには、今すぐ作成（Create Now）をクリックします。

これで、この新しいバージョンのアドミニストレーティブ イメージへのクライアントのアップグレードを行えるようになります。 詳細については、アドミニストレーティブ イメージからのクライアント アップグレード (Upgrading Clients from Administrative Images)を参照してください。

親トピック
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連概念
アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）
関連タスク
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


アドミニストレーティブ イメージからのクライアント アップグレード（Upgrading Clients from Administrative Images）

SOLIDWORKS Installation Manager はアドミニストレーティブ イメージからインストールしたクライアント コンピュータを自動的に更新できます。

通常、アドミニストレーティブ イメージはサーバー上のフォルダーにまとめられています。クライアントの自動アップグレードをサポートするためには、アドミニストレーティブ イメージが共有フォルダーにある必要があります。

アドミニストレーティブ イメージのアップグレードを行うと、元のインストレーションが1つのフォルダーに保存され、更新されたインストレーションが別のフォルダーに保存されます。アップグレードされたインストレーションを使用するには、元のアドミニストレーティブ イメージ フォルダーの共有オプションを解除します。続いてアップグレードされたアドミニストレーティブ イメージ フォルダーに共有オプションを追加します。

元のアドミニストレーティブ イメージからインストールした SOLIDWORKS をクライアント マシンで起動すると、新しいバージョンが識別されてクライアントがアップグレードされます。

親トピック
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連タスク
アドミニストレーティブ イメージのアップデートされたインストレーション ファイルのダウンロード（Downloading Updated Installation Files for Administrative Images）
アドミニストレーティブ イメージのアップグレード（Upgrading an Administrative Image）

元のアドミニストレーティブ イメージ フォルダからの共有オプションの解除（Removing the Sharing Option from the Original Administrative Image Folder）

共有フォルダからアクセスされるアドミニストレーティブ イメージをアップグレードする際は、元のフォルダから共有オプションを解除する必要があります。

  1. 元のアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブでこのフォルダを共有しない（Do not share this folder）を選択し、OKをクリックします。

次に、アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）の手順に従い、アップグレードされたアドミニストレーティブ フォルダに共有オプションを追加します。

アップグレードされたアドミニストレーティブ イメージ フォルダに対する共有オプションの追加（Adding the Sharing Option to an Upgraded Administrative Image Folder）

アドミニストレーティブ イメージ フォルダーを作成してアップデートし、元のアドミニストレーティブ イメージ フォルダーの共有を無効にしたら、新しいフォルダーに共有オプションを追加してアドミニストレーティブ イメージを再び有効にする必要があります。

  1. アップグレードされたアドミニストレーティブ イメージ ファイルがあるフォルダまで検索します。
  2. フォルダーを右クリックし、プロパティ（Properties）を選択します。
  3. 共有（Sharing）タブで、適切な共有プロパティを業務グループ用に指定し、共有名を元のアドミニストレーティブ イメージ フォルダ名に変更します。
元のアドミニストレーティブ イメージの共有場所からインストールしたコンピュータは、SOLIDWORKS の起動時に新しいバージョンに自動的にアップグレードされます。


ServicePack製品アップデートの管理（Service Pack Product Update Administration）

ServicePack製品アップデートには、システムの信頼性、互換性、セキュリティなどのためのアップデートが含まれています。

次の2つの方法で製品アップデートを入手できます。
  • SOLIDWORKS Installation Manager を使用して、ダウンロードとインストールの更新をチェックできます。

    SOLIDWORKS Installation Manager を手動で開始するか、アップデート チェックが定期的に行われるようにスケジュールします。

  • サービス パックを SOLIDWORKS サポート Web サイトから手動でダウンロードします。

    サービス パックはソフトウェアの既存バージョンにパッチとして適用されます。 たとえば、SOLIDWORKS 2015 SP1.0 は SOLIDWORKS 2015 SP0.0 のサービス パックです。これらのサービス パックは SOLIDWORKS 2015 Installation Manager を使用してインストールします。SOLIDWORKS 2016 の SOLIDWORKS Installation Manager を使用してインストールすることはできません。

    サービス パックのダウンロードとインストールの詳細手順については、アップデートしている SOLIDWORKS バージョンのインストレーション ドキュメントを参照してください。

目次

  • アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

    アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

  • Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）

    Microsoft Active Directory を使用して SOLIDWORKS ソフトウェアをインストールした場合、サービス パックも同様にクライアントに適用することができます。

親トピック
複数インストレーションの管理（Administration of Multiple Installations）
関連概念
新しいリリースへのアドミニストレーティブ イメージのアップグレード（Upgrading Administrative Images to a New Release）
関連タスク
インストレーションの削除（Removing an Installation）


アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）

アドミニストレーティブ イメージを以前のアドミニストレーティブ イメージにロールバックして戻すことができます。 ディスクから SOLIDWORKS をインストールした場合、特定のサービス パックまでロールバックするには、元のディスクが必要です。 以前のアドミニストレーティブ イメージの保存コピーが必要です。

一度アップグレードしたアドミニストレーティブ イメージを前回バージョンのService Packへとロールバックすることはできません。 SOLIDWORKS Installation Manager 以外の方法で作成したアドミニストレーティブ イメージを以前のバージョンにロールバックすることはできません。 これらのアドミニストレーティブ イメージからインストールしたクライアントは、アンインストールしてから前のバージョンで作成したアドミニストレーティブ イメージを使用して再インストールする必要があります。
  1. 現在のアドミニストレーティブ イメージを含むフォルダーを削除します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。

    rmdir /s/q 現在の_アドミニストレーティブ_イメージ_への_パス

  2. アドミニストレーティブ イメージのバックアップ コピーを現在のアドミニストレーティブ イメージを削除した場所へ移動します。これを行うには、コマンド プロンプト ウィンドウを開いて次のように入力します。

    move バックアップした_アドミニストレーティブ_イメージ_への_パス現在の_アドミニストレーティブ_イメージ_への_パス

    アドミニストレーティブ イメージをロールバックすると、次回 SOLIDWORKS を実行した時にクライアント コンピュータは自動的にロールバックされます。

親トピック
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）


Microsoft Active Directoryを使用して展開されたクライアントに対するServicePackの適用（Applying Service Packs to Clients Deployed with Microsoft Active Directory）

Microsoft Active Directory を使用して SOLIDWORKS ソフトウェアをインストールした場合、サービス パックも同様にクライアントに適用することができます。

  1. 次のコマンドラインでアドミニストレーティブ イメージを新規フォルダーにコピーします。

    xcopy 現在の_アドミニストレーティブ_イメージ_への_パスバックアップした_アドミニストレーティブ_イメージ_への_パス /s/i/v

  2. SOLIDWORKS Installation Manager を使用してアドミニストレーティブ イメージをアップグレードします。
  3. SOLIDWORKS ソフトウェアのアップグレード インストレーションを指定するために、新規トランスフォーム ファイルを作成するには以下を行います。
    1. コマンド プロンプト ウィンドウを開きます。
    2. アドミニストレーティブ イメージを含むフォルダでSWCreateMST.exeをコマンド プロンプト ウィンドウ内にドラッグします。

      コマンド フォーマットは次のようになります。

      アドミニストレーティブ_イメージ_への_パスSWCreateMST.exe アドミニストレーティブ_イメージ_の_MSI_ファイル_へ_の_パスプロパティ_の_リスト

      コマンドラインには、元の MST ファイルを作成した際に使用したすべてのパラメータが含まれていなくてはなりません。また、グローバル プロパティの UPGRADESWINSTALL と SWMIGRATE も必要です。

      たとえば、元のコマンドが次の場合:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\選択_フォルダ" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー

      アップデート コマンドは次のようにする必要があります。

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\選択_フォルダ" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@選択_サーバー UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS versionservice_pack"

      トランスフォーム ファイル SOLIDWORKS.mst は、アドミニストレーティブ イメージを含むフォルダに作成されます。

  4. Active Directory でグループ、または複数グループの Published Apps ポリシーを編集して SOLIDWORKS ソフトウェアを展開します。
  5. グループ ポリシー ダイアログ ボックスで コンピュータの構成とソフトウェアの設定 を展開します。
  6. ソフトウェア インストール を右クリックし、新規作成（New） > パッケージ（Package） を選択します。
  7. アドミニストレーティブ イメージまで参照し、開く（Open）をクリックします。
  8. ソフトウェアの展開 ダイアログ ボックスで 公開または割り当て時の詳細設定 を選択してから、OK をクリックします。
  9. SOLIDWORKS プロパティ (SOLIDWORKS Properties) ダイアログ ボックスの 変更 タブで次を行います。
    1. 追加 をクリックします。
    2. .mstファイルを参照します。
    3. 開く をクリックします。
  10. OK をクリックします。
親トピック
ServicePack製品アップデートの管理（Service Pack Product Update Administration）
関連タスク
アドミニストレーティブ イメージにおけるServicePackのロールバック（Rolling Back Service Packs in an Administrative Image）


SOLIDWORKS Workgroup PDM

Workgroup PDM アプリケーションは、SOLIDWORKS 環境内で、あるいはスタンドアロン アプリケーションとして SOLIDWORKS Explorer 内で動作する、製品データ管理ソフトウェアです。 Workgroup PDMは、プロジェクトのチェックアウト/チェックイン/リビジョン管理の手順、またその他の管理作業をコントロールします。

下記は Workgroup PDM を図解したものです:

  • １つのコンピュータで使用できるボルトは１つだけです。
  • Vault（ボルト）ディレクトリに非表示や読み取り専用のディレクトリは使用できません。
  • クライアント/サーバー アプリケーションとして、Workgroup PDM のパフォーマンスは、強力なネットワーク環境に依存します。
  • 多数のドキュメントを維持する必要がある場合は、少数のプロジェクト（各プロジェクトに属するドキュメント数が多い）で維持するのではなく、プロジェクトやサブプロジェクトの数を増やす（各プロジェクトに属するドキュメント数が少ない）とパフォーマンスが改善されます。

サポート終了のお知らせ

SOLIDWORKS Workgroup PDM のサポートは、SOLIDWORKS 2017 の後に終了いたします。SOLIDWORKS Workgroup PDM を既にご使用のお客様はインストールを続行できますが、ファイル ボルトを SOLIDWORKS PDM Server に移行する計画を開始する必要があります。

インストレーション(Installation)

  • Clients と VaultAdmin、API と Viewer は、Vault（ボルト）が存在するコンピュータにインストールすることも、また別のコンピュータにインストールすることもできます。
  • クライアント API をインストールする際、Workgroup PDM Server をインストールする必要はありません。 Workgroup PDM Client をインストールする際、クライアント API もインストールされるようになりました。
  • ボルト フォルダをリモート位置に設定するには、サーバー先を指定する時に、UNC(一般的な命名規則)に従ったパス名全体を入力します。 （詳細は UNCフォーマット（UNC Format） を参照してください。）
  • ボルトのインストールや更新には、コンピュータを再起動させる必要があります。
  • 再起動後、Workgroup PDM Serverサービスが自動的に実行されない場合は、マニュアルで開始させる必要があります。 Windows Explorer で、インストール_ディレクトリ\SOLIDWORKS Workgroup PDM\Vault フォルダの pdmwvault.exe を実行します。
  • Workgroup PDM クライアントをインストールする場合、各コンピュータに solidworksexplorer.exe をインストールする必要があります。 この実行ファイルは、共有ドライブから実行できます。 Workgroup PDMのVault（ボルト）、Viewer（ビューア）、API Client（APIクライアント）、VaultAdmin（ボルト アドミン）は、各クライアント コンピュータにはインストールされません。
Windows 8 を実行している場合、スタート や コントロール パネル へのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。

ライセンス（Licenses）

  • Workgroup PDM API のライセンスは SOLIDWORKS クライアントと Explorer クライアントのライセンスに含まれています。 Check-in APIs（チェックインAPI）にはクライアント ライセンスが必要です。
  • Viewer を有効にするには、Workgroup PDM Viewer のライセンスをボルトと共にインストールする必要があります。

権限(Permissions)

  • ボルト アドミン管理者には、インストレーションとボルト フォルダーへの書き込み許可を与えてください。
  • ボルト アドミン管理者は、ボルト フォルダを VaultAdmin から（Windows エクスプローラからではありません）管理してください。
  • ユーザーには、Windows エクスプローラでボルト フォルダーへの書き込み許可を与えないでください。

セキュリティ、ポート、デュプレックス設定（Security, Ports, and Duplex Settings）

  • 他のアプリケーションによってサービスをブロックまたはフィルターされないように、Workgroup PDMは必ずWindowsサービスとしてインストールしてください。 たとえば、Microsoft AntiSpyware などのスパイウェア対策ツールによって、インストレーション過程でユーザーの承諾を求める警告メッセージがプロンプト表示されたら、許可する （Allow）をクリックし、Workgroup PDM Server を Windows のサービスとしてインストールしてください。
  • Workgroup PDM をファイアウォールがアクティブに設定されたコンピュータにインストールした場合、ファイアウォールの Workgroup PDM ポートが例外として実行されるように設定する必要があります。

    通常、ポートは次のようになります。

    • 20000（VaultAdmin）
    • 30000（Data）
    • 40000（Request）
    • 80（Viewer）
    ポート設定を変更する方法の詳細については、SolidWorks ExplorerのWorkgroup PDM、SOLIDWORKS Explorer ヘルプおよび Microsoft Windows ヘルプのセキュリティ センター SOLIDWORKS を参照してください。 Workgroup PDM Vault と Viewer を同時にインストールするには、カスタム ダイアログ ボックスの カスタム オプションを使用します。
  • サーバーと対応するポートにおけるデュプレックス設定（二重の設定）は、一致する必要があります（たとえば、両方が 100MB全二重通信 （100MB Full）、または 自動検出 （Auto）であるなど）。

SOLIDWORKS Toolbox ドキュメント

SOLIDWORKS Toolbox ドキュメントは、ほとんどの場合、リビジョン コントロールを必要とせず、Workgroup PDM Vault にチェックインされない共有構成部品です。 SOLIDWORKS Toolbox やその他の標準ライブラリのコンフィギュレーションに関する詳細は Workgroup PDM オンライン ヘルプを参照してください。

目次

  • Workgroup PDM Viewer

    Workgroup PDMソフトウェアはMicrosoftインターネット インフォメーション サービス（IIS）を使用してインストール中に自動的にバーチャル ディレクトリを設定します。

  • Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）

    Workgroup PDM Server をインストールすると、Workgroup PDM ボルトが作成されます。これは管理する SOLIDWORKS プロジェクトを保存するためのデータベースです。

  • クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）

    Workgroup PDMサーバー ボルトをインストールした後で、クライアント用のボルトを設定できます。

  • Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）

    SOLIDWORKS Workgroup PDM Web サーバーと Workgroup PDM Viewer を境界ネットワーク（DMZ）にインストールすると、ファイアウォールに影響を及ぼします。

  • Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）

    Workgroup PDMクライアントはMicrosoft Windowsのログイン アクセス コントロールを使用してWorkgroup PDM Viewer経由でWebにアクセスし、Workgroup PDM Vaultがアップデートされると自動的にアップデートされます。

  • Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）

    Workgroup PDMがインストールされた後で、ボルト管理者は以下を行うべきです。

関連概念
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


Workgroup PDM Viewer

Workgroup PDMソフトウェアはMicrosoftインターネット インフォメーション サービス（IIS）を使用してインストール中に自動的にバーチャル ディレクトリを設定します。

Viewerをインストールする前に、必ずMicrosoftインターネット インフォメーション サービス（IIS）をインストールしてください。
次のコンポーネントが必要です：
  • Web Management Tools
    • IIS Management Console
  • World Wide Web Services:Application Development Features
    • .NET Extensibility
    • ASP.NET
    • CGI
    • ISAPI Extensions
    • ISAPI Filters
IISのインストレーション手順については、Microsoftのドキュメントを参照してください。
Workgroup PDM Viewerのインストレーションには、以下の制約があります。
  • Web Site Content Directory は、Viewerのインストレーション フォルダです。
  • Viewerをホストするマシンの名前にアンダースコアなどの文字は使用できません。
  • Viewerは、常に1つのVault（ボルト）のみに接続できます。

Internet Explorerのアドレス フィールドに次のURLを入力するとWorkgroup PDM Viewerにアクセスできます。

http://ViewerComputerName/pdmweb/

親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
関連タスク
Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）


Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）

Workgroup PDM Server をインストールすると、Workgroup PDM ボルトが作成されます。これは管理する SOLIDWORKS プロジェクトを保存するためのデータベースです。

  1. SOLIDWORKS Installation Manager を起動します。 SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）を参照してください。
  2. ようこそ（Welcome）画面で以下を選択します。

    • サーバー製品
    • SOLIDWORKS Workgroup PDM Server （ボルト）をこのコンピュータにインストールします。

  3. サマリー（Summary）の画面で変更（Change）をクリックし、検証コードを取得してください。 次の方法でコードを取得できます:
    • インターネット接続:
      1. SOLIDWORKS シリアル番号と電子メール アドレスをフィールドに入力します。
      2. 自動的に検証（Validate automatically）を選択し、コード取得（Get Code）をクリックします。
    • 電子メール
      1. インターネットに接続できない場合は、電子メールを使用して検証（Validate manually by email）をクリックします。 Installation Manager によって検証リクエスト ファイルが作成されます。
      2. 保存（Save）をクリックし、ファイルをローカル システム上に保存します。
      3. 画面に表示される手順に従い、検証コードを入力します。
  4. サマリーに戻る（Back to Summary）をクリックします。
  5. サマリー画面で今すぐインストール（Install Now）をクリックします。
親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
関連タスク
クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）
関連資料
Workgroup PDM Viewer


クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）

Workgroup PDMサーバー ボルトをインストールした後で、クライアント用のボルトを設定できます。

  1. VaultAdmin （SOLIDWORKS Explorer と共にインストールされます）にデフォルトのユーザー名とパスワードでログインします。
  2. VaultAdminでユーザーとグループのアカウント、プロジェクト フォルダー、許可権限などを設定します。

    手順については、Workgroup PDMヘルプ（Workgroup PDM Help）を参照してください。

  3. クライアントのユーザー名、パスワード（通常、Microsoft Windowsのユーザー名やパスワードとは異なります）の情報を、サーバー コンピュータ名でクライアントに電子メールで送信します。
親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
関連タスク
Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
関連資料
Workgroup PDM Viewer

Workgroup PDM Viewerを別のボルトの場所に接続するための設定（Configuring the Workgroup PDM Viewer to Connect to a Different Vault Location）

Windowsレジストリを使用してWorkgroup PDM Viewerを別のボルトの場所に接続するように設定できます。

  1. Vault Computer の値を変更し、レジストリ パスを更新します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\Vault Computer

  2. Workgroup PDM Viewerを再インストールします。ボルト コンピュータ名（Vault Computer Name）ダイアログ ボックスで新しいコンピュータ名を入力します。

ドキュメント ダウンロードのMIMEタイプの設定（Configuring Mime Types for Document Downloading）

Windowsレジストリの設定を使用し、ドキュメント ダウンロードのMIMEタイプを設定できます。

デフォルトで、Viewerは一般的なMIMEタイプのapplication/octet-streamと共にドキュメントを開く（Open Document）リクエストを送信します。続いてMicrosoft Internet Explorerにより、リクエストされた、提供されたファイル拡張子のあるドキュメントが開かれます。追加のMIMEタイプをマッピングする、またはMIMEタイプのマッピングを中止するには、WindowsレジストリでMIMEタイプ レジストリのサブキーを変更します。

  • 追加のMIMEタイプをマッピングするには、このレジストリ サブキーの下に追加のストリング値を作成します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Mime Types

    次のフォームを使用します。

    "ext" = "mime type"

    例えば:

    "dxf" = "image/vnd.dxf"

    値を追加する前にこのレジストリのサブキーをマニュアル操作で作成する必要があります。

    MIMEタイプのマッピングを中止するには、Use Custom MIME Types レジストリの値を0（ゼロ）に変更します。

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    この設定を有効にするために、Web サーバーを再起動する必要はありません。


Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）

SOLIDWORKS Workgroup PDM Web サーバーと Workgroup PDM Viewer を境界ネットワーク（DMZ）にインストールすると、ファイアウォールに影響を及ぼします。

Workgroup PDM Viewer クライアントは、Web サーバーと HTTP あるいは HTTPS ポートを使用して通信するため、Web サーバーがインストールされている IIS (Internet Information Server) でこれらのポートがオープンでなくてはなりません。

  • HTTP プロトコールの場合、デフォルト ポートは 80 です。
  • HTTPS プロトコール（SSL）の場合、デフォルト ポートは 443 です。

Web Viewer クライアント自身は、ファイアウォールの例外を構成する必要はありません。

Web サーバー システムが次のデフォルト ポートを使用して Vault サーバーと通信できることを確認する必要があります:

  • 30000（Data）
  • 40000（Request）

目次

  • 境界ネットワークにおける Workgroup PDM Viewer のネットワーク コンフィギュレーション（Network Configuration for Workgroup PDM Viewer in a Perimeter Network）

    ネットワーク構成は、環境ネットワーク サーバー設定（環境サブネット上）と、その内部ネットワークと外部ネットワークへの通信を表しています。

  • Workgroup PDM Web Server と Viewer のインストレーションとコンフィギュレーション（Installing and Configuring the Workgroup PDM Web Server and Viewer）

    Workgroup PDM Web サーバーを環境ネットワークで設定する場合は、コンポーネントをインストールする場所が重要になります。

親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
関連タスク
Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）
関連資料
Workgroup PDM Viewer


境界ネットワークにおける Workgroup PDM Viewer のネットワーク コンフィギュレーション（Network Configuration for Workgroup PDM Viewer in a Perimeter Network）

ネットワーク構成は、環境ネットワーク サーバー設定（環境サブネット上）と、その内部ネットワークと外部ネットワークへの通信を表しています。

環境ネットワーク サーバーは、内部ファイアウォールを介して LAN と通信します。 外部ネットワークには、外部ファイアウォール、ルーター、ロード バランサーのクラスターを介して通信します。

Internet Explorer クライアントは、Workgroup PDM Viewer/IIS サーバーに、ポート 80 （SSL を使用する場合は 443） を介してつながります。 続いて、Workgroup PDM Viewer は、 Vault サーバーに、 ポート 30000 またはポート 40000 を使用してつながります。 Vault サーバーがリクエストされた情報を Workgroup PDM Viewer まで送信し、そこから Internet Explorer クライアントまで情報がフィードされます。

環境ネットワーク Web サーバーには2つの IP アドレスがあります:

  • 内部 IP アドレス （LAN）
  • パブリック IP アドレス （ISP）

Web サーバー（環境ネットワーク内）は、ロード バランサーのクラスターの後にあります。 直接 Web サーバーにアクセスできますが（管理タスクを行う場合など）、すべての Web サービス トラフィックは環境ネットワークのサーバーに集められ、ロード バランサーによって処理されます。

ロード バランサーは、公開されているネットワーク部分で、サーバー ハードウェアの IP アドレスを仮想 IP（VIP）に変換します。 ネットワークにつながっている間に、VIP あるいは Web サーバー URL を参照すると、サイトを見ることができます。

外部ファイアウォールは、ロード バランサー VIP を公開された、ルーティング可能なアドレスに変換します。

親トピック
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
関連タスク
Workgroup PDM Web Server と Viewer のインストレーションとコンフィギュレーション（Installing and Configuring the Workgroup PDM Web Server and Viewer）


Workgroup PDM Web Server と Viewer のインストレーションとコンフィギュレーション（Installing and Configuring the Workgroup PDM Web Server and Viewer）

Workgroup PDM Web サーバーを環境ネットワークで設定する場合は、コンポーネントをインストールする場所が重要になります。

  • IIS が有効な Web サーバーを環境サブネットにインストールします。
  • IIS が有効な Workgroup PDM Viewer を環境サブネットにインストールします。
  • Workgroup PDM Vault をプライマリ ドメインか内部ネットワーク（ローカル イントラネット上）にインストールします。

Workgroup PDM Viewer を環境ネットワーク上にインストールし、設定するための前提条件は:

  • Microsoft IIS 6.0 以降
  • ユーザーの ISP プロバイダーによって指定された、Web サーバーへのパブリック IP アドレス（環境サブネット上）

Workgroup PDM コンポーネントをインストールし、設定するには:

  1. Microsoft IIS を環境サブネット サーバー システムにインストールします。
  2. SOLIDWORKS Workgroup PDM Server のインストールを 2 回行います。
    1. 最初に、Vault コンポーネントを Vault サーバー上にインストールします。
    2. 2度目のインストーラーを実行し、Workgroup PDM Viewer と Viewer ライセンス コンポーネントを IIS Web サーバー上にインストールします。 ボルト サーバーのコンピュータ名を入力し、Web ポータルが Vault サーバー サービスを見つけることができるようにします。

    インストレーションを実行すると、PDMWeb アプリケーションがデフォルト IIS Web サイトに自動的に追加されます。

  3. 内部ネットワークのファイアウォールが、ポート 30000 とポート 40000 をオープンにしていることを確認してください。
  4. 内部サーバーに固定 IP アドレスがある場合は、環境サーバー システム上で C:\Windows\system32\drivers\etc\hosts ファイルを編集します。 IP アドレスのシステム名を作成し、環境サーバーが内部サーバーと通信できるようにマッピングします:
    1. hosts ファイルをメモ帳などのテキスト エディタで開きます。
    2. Vault サーバー IP アドレスと名前の新しい列に追加します。
    3. hosts ファイルを保存します。
親トピック
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
関連概念
境界ネットワークにおける Workgroup PDM Viewer のネットワーク コンフィギュレーション（Network Configuration for Workgroup PDM Viewer in a Perimeter Network）


Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）

Workgroup PDMクライアントはMicrosoft Windowsのログイン アクセス コントロールを使用してWorkgroup PDM Viewer経由でWebにアクセスし、Workgroup PDM Vaultがアップデートされると自動的にアップデートされます。

Workgroup PDMクライアントとしてログインするには: | Workgroup PDMのクライアントのユーザー名とパスワードは、Microsoft Windowsのログインのものとは異なります。ログインするための情報に関しては、お客様のシステム管理者にお問い合わせください。
Workgroup PDM Viewerに接続するには: | Viewerに接続するためのURLに関しては、お客様のシステム管理者にお問い合わせください。
Workgroup PDMクライアントをアップデートするには: | ボルトがアップデートされている場合、Workgroup PDM クライアント（SOLIDWORKS アドインとコントリビュータ）はそれを検知します。 ServicePack をダウンロードしてクライアントをアップデートする必要はありません。
親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）
関連タスク
Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）
関連資料
Workgroup PDM Viewer


Workgroup PDM VaultAdmin管理（Workgroup PDM VaultAdmin Administration）

Workgroup PDMがインストールされた後で、ボルト管理者は以下を行うべきです。

  • VaultAdminへログインする。
  • ボルト管理者用のパスワードを変更する。
  • ユーザー アカウントを作成する。
  • 各ユーザーにアカウント名とパスワードを通知する。

詳細については、SOLIDWORKS 本体のヘルプにある SOLIDWORKS Workgroup PDM を参照してください。

親トピック
SOLIDWORKS Workgroup PDM
関連概念
Workgroup PDM Server と Viewer を境界ネットワーク にインストール（Installing Workgroup PDM Server and Viewer in a Perimeter Network）
Workgroup PDMクライアント アクセス（Workgroup PDM Client Access）
関連タスク
Workgroup PDM Serverのインストール（Installing a Workgroup PDM Server）
クライアント用のWorkgroup PDMの設定（Configuring Workgroup PDM for Clients）
関連資料
Workgroup PDM Viewer

Workgroup PDM VaultAdminへの初回ログイン（Initial Login to Workgroup PDM VaultAdmin）

Workgroup PDM VaultAdminへの初回ログイン時には、Workgroup PDM管理者名とパスワード、およびWorkgroup PDM Vaultをホストするコンピュータ名を指定します。

  1. Windows で、スタート > すべてのプログラム > SOLIDWORKS version > Workgroup PDM VaultAdminをクリックします。
  2. ダイアログ ボックスで、次の情報を入力します。

    名前 | pdmwadmin
    パスワード | pdmwadmin
    ボルト コンピュータ | ボルトがインストールされているコンピュータのホスト名です。 ボルトがインストールされているコンピュータで VaultAdmin を実行する場合、localhost を入力します。

  3. ログイン（Login）をクリックします。
セキュリティ上の理由から、できるだけ早い時期に管理者のパスワードを変更することを推奨します。VaultAdminでユーザーとグループ（Users and Groups）タブを選択します。

Workgroup PDM Vault Serverのアップグレード（Upgrading the Workgroup PDM Vault Server）

Workgroup PDM Vault Server をアップグレードするには SOLIDWORKS のアップデート チェック、SOLIDWORKS インストレーション DVD、またはローカル フォルダにマニュアルでダウンロードした Workgroup PDM アップグレード ファイルを使用します。

Workgroup PDM Vault Serverは1つのバージョンのみをインストールできます。
  1. すべてのユーザーをWorkgroup PDMボルトからログアウトさせ、ロックします。
  2. ボルト データをバックアップします。
  3. Microsoft Windowsコントロール パネルのプログラムの追加と削除（Add/Remove Programs）を使用し、現在のバージョンのWorkgroup PDM Serverを削除します。
  4. 新しいバージョンのWorkgroup PDM Serverをインストールします。
    • SOLIDWORKS のアップデート チェックを使用するには、以下を行います。
      1. Windows で スタート > すべてのプログラム > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) をクリックします。
      2. 利用可能なより新しいバージョン ダイアログ ボックスで、新しいバージョンのダウンロードとインストール (Download and install a new version) を選択し、インストールするバージョンを選択してから、次へ (Next) をクリックします。

        新しいバージョンの SOLIDWORKS Installation Manager がダウンロードされ、実行されます。

    • SOLIDWORKS インストレーション DVD を使用するには、ドライブに DVD を挿入し、SOLIDWORKS Installation Manager の指示に従います。
    • マニュアルでダウンロードしたWorkgroup PDMインストレーション ファイル（pdmwserver.exe）を使用するには、ファイルをダブルクリックし、手順に従ってWorkgroup PDM Serverをアップグレードします。
  5. SOLIDWORKS タスク スケジューラを使用して、ボルトにある Workgroup PDM ファイルをアップデートします。
  6. ボルトをロック解除してから、ユーザーに使用できる状態に戻ったことを連絡します。

Workgroup PDMクライアントのアップグレード（Upgrading Workgroup PDM Clients）

ボルトのアップデート後にクライアントが初めてログインすると、アップデートを求めるプロンプトが表示されます。クライアントのアップデートに、ServicePackは必要ありません。

Vaultに対するクライアント ステータス | 動作
ボルトと同じバージョンの場合 | なし
同じメジャー リリース版でボルトより新しい場合 | なし
新しいメジャー リリース版でボルトより新しい場合 | ログインがブロックされる
同じメジャー リリース版でボルトより古い場合 | オプションでアップデート可
以前のメジャー リリース版でボルトより古い場合 | アップデートが必要

Workgroup PDMクライアントのアップデートの詳細については、Workgroup PDMヘルプ（Workgroup PDM Help）のクライアントのアップデート（Update Clients）を参照してください。


SOLIDWORKS PDM

SOLIDWORKS PDM は、以前 SOLIDWORKS Enterprise PDM と呼ばれていたクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。

SOLIDWORKS PDM には次の 2 種類があります。
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

この表には、各製品で使用できるデータベース システム、サーバー コンポーネント、およびクライアント オプションがリストされています。
 | PDM Standard | PDM Professional
設計対象 | 小規模から中規模のオフィス ネットワーク（最大 5 人の同時ユーザー） | 大規模オフィス ネットワーク（多数の同時ユーザー）
制限 | 1 個の CPU、1 GB のメモリ、10 GB のデータベース サイズ | 制限なし
データベース管理システム | Microsoft SQL Server Express 2014（SOLIDWORKS に含まれており、一緒にインストールされます） | Microsoft SQL Server 2014（SOLIDWORKS とは別途）、または前もってインストールされた Microsoft SQL Server 2014、2012、または 2008 R2
SolidNetWork License Manager が必要ですか? | はい | はい
アーカイブ サーバーとデータベース サーバーが含まれていますか? | はい | はい
SOLIDWORKS PDM Web サーバーと Web2 サーバーが含まれていますか? | いいえ | はい
クライアント タイプ | ネイティブ | ネイティブ、ブラウザ ベース
CAD Editors 向けクライアント アドイン | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office Integration、Autodesk Inventor、AutoCAD
Contributors 向けクライアント アドイン | DraftSight | DraftSight、Microsoft Office Integration
Viewers 向けクライアント アドイン |  | Microsoft Office との統合（Microsoft Office Integration）

目次

  • PDM Server コンポーネントのリスト

  • クライアントの選択

    PDM 環境に応じてどのクライアントが必要か決定する必要があります。

  • PDM Server をインストールする前に

    PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。


PDM Server コンポーネントのリスト

このテーブルにはSOLIDWORKS PDM Server のサーバー コンポーネントがまとめられています。

Server | 関数 | インストレーション（Installation）
PDM Standard 向け Microsoft SQL Server Express | SOLIDWORKS PDM データ ボルトのデータを管理します。 | PDM Standard と一緒にインストール可能です。または、前にライセンスが付与されインストールされているバージョンを使用できます。
PDM Professional 向け Microsoft SQL Server | SOLIDWORKS PDM データ ボルトのデータを管理します。 | 個別に PDM Professional で提供 以前に使用許諾され、インストールされたバージョンも使用できます。
SolidNetWork License Manager | SOLIDWORKS PDM ライセンスを管理します。 | 新しいボルトを作成する前にインストールされている必要があります。 SLDIM を使用するときに、SOLIDWORKS PDM サーバー構成部品でインストールできます。
アーカイブ サーバー | クライアントとファイル ボルト アーカイブ間のファイル転送を管理し、ユーザーとその資格情報を管理します。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
データベース サーバー | 更新に関して PDM データベースをポーリングし、データのインポートおよびエクスポート ルールを管理し、メッセージ システムを管理し、また複製およびコールド ストレージをスケジュールします。 | 必ず実行: PDM Standard または Professional と一緒にインストールします。
Web Server と Web2 Server | ブラウザ ベースのクライアントからインターネット経由でファイル ボルトへのアクセスを提供します。 | この操作はオプションです。 PDM Professional のみと一緒にインストールします。

アーカイブ サーバーはインストール先のコンピュータのシステム アカウントでのサービスとして実行されます。 1 つのアーカイブ サーバーは同じコンピュータにある複数のファイル ボルトをホスティングできます。

スタンドアロン インストレーションでは、アーカイブ サーバー、データベース サーバー、ライセンス サーバー、SQL Express または SQL Server データベースが、すべて同じマシンにインストールできます。

分散環境では、サーバー コンポーネントは別のマシンに配置できます。 また、同じファイル ボルト アーカイブの複製コピーをホスティングするために、複数のアーカイブ サーバーを別のコンピュータにセットアップすることも可能です。 詳細はSOLIDWORKS PDM Professional 複製ガイドを参照してください。

親トピック
SOLIDWORKS PDM
関連概念
クライアントの選択
PDM Server をインストールする前に


クライアントの選択

PDM 環境に応じてどのクライアントが必要か決定する必要があります。

このテーブルには SOLIDWORKS PDM Standard 向けクライアントの要約が記載されています。
Standard クライアントの種類 | 説明
CAD Editor | SOLIDWORKS、DWG/DXF、および Microsoft Office ファイルがサポートされています。 Office プラグインで処理されるすべてのファイル フォーマットは、SOLIDWORKS PDM Standard で同じように動作します。
Contributor | SOLIDWORKS、DWG/DXF、および Microsoft Office ファイルがサポートされています。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。 ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）することはできません。
このテーブルには SOLIDWORKS PDM Professional 向けクライアントの要約が記載されています。
Professional クライアントの種類 | 説明
CAD Editor & Web | 全てのファイル タイプをサポートし、SOLIDWORKS を含む CAD フォーマットの管理とプレビュー機能が強化されています。 CAD アドインの使用により、CAD アプリケーションから SOLIDWORKS PDM Professional にアクセスすることも可能です。 リモート ユーザーは、ボルトを検索し、インターネットを介して Web クライアントおよび Web2 クライアントを使用して基本的な機能を実行できます。
Contributor & Web | CAD ファイルを含む全てのファイルタイプをサポートしています。 しかし、このクライアントタイプに対しては CAD アドインはサポートされていません。 リモート ユーザーは、ボルトを検索し、インターネットを介して Web クライアントおよび Web2 クライアントを使用して基本的な機能を実行できます。
Viewer | ファイル ボルトに読み取り専用のアクセスを許可します。 ユーザーは、ワークフローを通してファイルを遷移させることができますが、ファイルを追加または修正（チェックアウト、チェックイン、値の更新）すること、または CAD アドインを使用することはできません。
親トピック
SOLIDWORKS PDM
関連概念
PDM Server コンポーネントのリスト
PDM Server をインストールする前に


PDM Server をインストールする前に

PDM Server コンポーネントをインストールする前に、次の要件を満たしておく必要があります。

  • サーバーとクライアントをインストールする予定のマシンに完全な管理権限を取得してください。
  • データベース サーバーがTCP</Z1>ポート3030</Z2>を使ってアーカイブ サーバーへ、そしてTCP</Z3>ポート1433</Z4>を使ってSQL</Z5>サーバーにアクセス可能であることを確認してください。
  • 既存の SQL Server Express または SQL Server データベースを使用する予定の場合、SQL Server データベースの名前と、データベースへの読み取り/書き込みアクセス権を持つ SQL Server 管理者またはデータベース所有者のアカウント ID とパスワードを取得してください。 tew ユーザーは使用できません。
  • PDM クライアントが既にシステムにインストールされている場合、それをアンインストールします。 PDM Server と PDM Client を同じシステム上に置く場合、SOLIDWORKS PDM Server インストレーション プロセスを使用して両方をインストールする必要があります。

目次

  • SLDIM を使用した PDM Server のインストール

    PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

  • SLDIM を使用した PDM Client のインストール

親トピック
SOLIDWORKS PDM
関連概念
PDM Server コンポーネントのリスト
クライアントの選択


SLDIM を使用した PDM Server のインストール

PDM Standard 用に PDM Server をインストールする場合、同じマシン上にアーカイブ サーバー、データベース サーバー、および PDM CAD Editor クライアントをインストールできます。 クライアントのインストレーションを別途実行する必要はありません。

PDM Professional 用に PDM Server をインストールする場合、これらのコンポーネント、および Web サーバーと Web2 サーバーも含めることができます。

PDM Server とそのコンポーネントをインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページでサーバー製品（Server Products）を選択して以下を選択します。
    • SOLIDWORKS PDM Server コンポーネントをこのコンピュータにインストールする（Install SOLIDWORKS PDM Server components on this computer）。
    • SolidNetWork License Manager をこのコンピュータにインストールする（Install SolidNetWork License Manager on this computer）。

      SolidNetwork License Manager がインストールされている場合、このオプションは表示されません。

  3. SolidNetwork License Manager オプション（SolidNetwork License Manager Options）ページが表示される場合、シリアル番号を入力し、ディレクトリの場所を指定して次へ（Next）をクリックします。
  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. SOLIDWORKS PDM Server のサマリー（Summary）ページで変更（Change）をクリックします。
  6. SOLIDWORKS PDM Server オプション（SOLIDWORKS PDM Server Options）ページで:
    1. Server 製品の選択（Select Server Product）で、SOLIDWORKS PDM Standard または Professional をクリックします。
    2. インストレーション先（Installation Location）で、参照（Browse）をクリックしてファイル パスを指定します。
    3. 機能の選択（Select Features）で:

      1. アーカイブ サーバー（Archive Server）、データベース サーバー（Database Server）、およびクライアント（client）をクリックして、これらのコンポーネントを同じマシン上にインストールします。 分散環境にいる場合、別のマシン上で Installation Manager を実行して、アーカイブ サーバーとデータベース サーバーをインストールできます。
        マシン上に PDM クライアントが既にインストールされている場合、インストレーションをキャンセルして、クライアントをアンインストールする必要があります。 次に、SLDIM を実行して、クライアントと共に PDM サーバーをインストールします。
      2. PDM Professional をインストールしている場合、Web サーバー（Web server）と Web2 Server もクリックできます。

    4. SQL Server で、PDM Server と共に提供されるデータベースおよび管理ツールの新規インスタンスをインストールできます（SQL Server Express for PDM Standard）。または、既存インスタンスのデータベース名、ユーザー名、およびパスワードを指定できます。

      完全版の SQL Server は、別途 PDM Professional と共に提供されます。

    5. サマリーに戻る（Back to Summary）をクリックします。
  7. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。

    SOLIDWORKS Installation Manager がインストールを完了すると、アーカイブサーバー コンフィギュレーション ツール（Archive Server Configuration Tool）が起動します。 ウィザード内のプロンプトに従って、アーカイブ サーバーを構成します。

アーカイブ サーバー、データベース サーバー、Web サーバーと Web2 サーバー、および SQL Server データベースのセットアップ、構成、およびトラブルシューティングを行うには、SOLIDWORKS PDM 2016 インストール ガイドで関連するトピックを参照してください。
親トピック
PDM Server をインストールする前に
関連タスク
SLDIM を使用した PDM Client のインストール


SLDIM を使用した PDM Client のインストール

PDM Client をインストールするには:

  1. SOLIDWORKS Installation Manager を起動します。
  2. ようこそ（Welcome）ページで個人（Individual）を選択します。
  3. シリアル番号（Serial Number）ページで次へ（Next）をクリックします。

    SOLIDWORKS PDM にはシリアル番号は不要です。

  4. システムの警告の指示に従い次へ（Next）をクリックします。
  5. サマリー（Summary）ページの製品（Products）の下で変更（Change）をクリックします。
  6. 製品選択（Product Selection）ページで別のパッケージ/製品の選択（Select different packages or products）をクリックします。
  7. 表示するパッケージを選択してください（Select the package you want to show）ダイアログ ボックスで SOLIDWORKS のエディションを選択します。 OKをクリックします。
  8. 製品選択（Product Selection）ページで SOLIDWORKS PDM Client を選択します。 次に、eDrawings を選択して、PDM プレビュー機能を有効にします。 SOLIDWORKS PDM Professional を使用している場合は Item Explorer も選択できます。
  9. サマリー（Summary）ページで SOLIDWORKS PDM オプションを展開して変更（Change）をクリックします。
  10. SOLIDWORKS PDM Client オプション（SOLIDWORKS PDM Client Options）ページで次を選択してサマリーに戻る（Back to Summary）をクリックします。
    • PDM 製品の種類
    • PDM クライアントの種類
    • アドイン
  11. サマリー（Summary）ページで SOLIDWORKS 使用許諾書の条件を受け入れて今すぐインストール（Install Now）をクリックします。
親トピック
PDM Server をインストールする前に
関連タスク
SLDIM を使用した PDM Server のインストール


SOLIDWORKS Electrical

SOLIDWORKS Electrical は、インテリジェントな設計ツール、包括的な部品データベース、および 2D スキマティックと 3D モデル間のリアルタイム統合によって、電子システム設計を簡略化します。

SOLIDWORKS Electrical の主なコンポーネントは以下のとおりです。
  • SOLIDWORKS Electrical Schematic - 動的な 2D 電気配線を作成するツールです。
  • SOLIDWORKS Electrical 3D - 電気システムを 3D でモデリングできるように、ケーブルやワイヤを含む 2D スキマティックを 3D モデルに統合するツールです。
  • Data - ユーザー間で共有できる部品、記号、ライブラリ、カタログのデータベースです。
  • Collaborative Server - 電気図面のオープンと更新を管理するユーティリティです。
  • Microsoft SQL Server データベースのインスタンス。

SOLIDWORKS Electrical には、Microsoft SQL Server データベースが必要です。 既存のデータベースを使用することも、インストール時に作成した新しいインスタンスを使用することもできます。

SOLIDWORKS Electrical のすべてのコンポーネントを同じマシンにインストールできます。 このインストールは、通常、スタンドアロン インストールとみなされます。 1 つのシステムにすべてのプログラム データ（プロジェクトの図面やレポートなど）が保存されます。 SOLIDWORKS Electrical をインストールするには、あらかじめシステムに対する完全な管理者権限が必要です。

SOLIDWORKS Electrical のコンポーネントをクライアント/サーバー アプリケーションとしてインストールすることもできます。 このインストールは、データをネットワーク サーバー上に保存する必要がある場合や、すべての SOLIDWORKS Electrical データベースが格納される既存の SQL Server データベースがネットワーク サーバー上にある場合に必要です。 このような場合は、サーバー システムとクライアント システムの両方に完全な管理者権限が必要です。 また、クライアント システムに、サーバーへのネットワーク アクセス権と、プロジェクト、ライブラリ、および記号を作成するための読み取り/書き込み権限が必要です。

目次

  • SOLIDWORKS Electrical でのデータの管理

  • SOLIDWORKS Electrical をインストールするための要件


SOLIDWORKS Electrical でのデータの管理

多くのプログラムは、1 つのデータベースを使用してすべてのプログラム データを格納します。 SOLIDWORKS Electrical はこれに該当しません。SOLIDWORKS Electrical の各プロジェクトには一意の ID 番号が割り当てられ、その一意の ID 番号に基づいて識別できるデータベースが各プロジェクトに関連付けられています。 たとえば、SOLIDWORKS Electrical Project Manager で、ID 番号 112 のプロジェクトが存在する場合、関連付けられたデータベースの名前は「tew_project_data_112」になります。

各プロジェクトに一意のデータベースが存在する理由は、それによって処理時間が大幅に短縮されるためです。 また、重大なデータベース障害が発生した場合も、影響を受けるプロジェクトは 1 つだけであり、プログラム情報の大部分の整合性が保持されます。

ただし、新しいデータベースの作成を制限するポリシーを持つ企業もあります。 SOLIDWORKS Electrical を実行するには、ユーザーによる新しいデータベースの作成を制限しないようにする必要があります。 システムまたはデータベースの管理者に問い合わせて、ユーザーによる新しいデータベースの作成を禁止するコンフィギュレーション設定が存在しないことを確認してください。
親トピック
SOLIDWORKS Electrical
関連概念
SOLIDWORKS Electrical をインストールするための要件


SOLIDWORKS Electrical をインストールするための要件

最新のシステム要件にアクセスするには、http://solidworks.com/System_Requirements を参照してください。

目次

  • 個別オプションとサーバー オプション

    SOLIDWORKS Electrical は、個別モードかサーバー モードのどちらかでインストールできます。

  • データの場所の指定

  • Collaborative Server の設定

  • Microsoft SQL Server の設定

親トピック
SOLIDWORKS Electrical
関連概念
SOLIDWORKS Electrical でのデータの管理


個別オプションとサーバー オプション

SOLIDWORKS Electrical は、個別モードかサーバー モードのどちらかでインストールできます。

SOLIDWORKS Electrical は SQL Server のインスタンス（既存か新規かに関係なく）に接続する必要があることに注意してください。

個別モードでは、以下のコンポーネントをインストールできます。
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • ﾃﾞｰﾀ
  • SQL Server データベースの新規インスタンス
サーバー モードでは、以下のコンポーネントをインストールできます。
  • SQL Server データベースの新規インスタンス
  • Collaborative Server
  • ﾃﾞｰﾀ

個別モードとサーバー モードのコンポーネントを組み合わせて、クライアント/サーバー環境を作成できます。 たとえば、クライアント システムに SOLIDWORKS Electrical Schematic と SOLIDWORKS Electrical 3D をインストールし、サーバー システムにすべてのサーバー コンポーネントをインストールすることができます。

親トピック
SOLIDWORKS Electrical をインストールするための要件
関連概念
データの場所の指定
Collaborative Server の設定
Microsoft SQL Server の設定


データの場所の指定

データの場所として、部品、テンプレート、2D と 3D の記号などのプログラム データを保存するディレクトリを選択します。 この場所については、専用のディレクトリを指定してください。 ルート ディレクトリや SOLIDWORKS データの保存に使用するディレクトリは指定できません。

デフォルト ディレクトリは C:\ProgramData\SOLIDWORKS Electrical です。同じディレクトリに Update と言う名前のフォルダが追加され、このフォルダに使用可能なすべてのプログラム データが保存されます。

SOLIDWORKS Electrical を初めて起動すると、データ更新 ウィザードが表示されます。 このウィザードで、アプリケーションや SQL Server データベースに追加するデータを選択できます。
親トピック
SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
Collaborative Server の設定
Microsoft SQL Server の設定


Collaborative Server の設定

SOLIDWORKS Electrical を実行するには、Microsoft SQL Server データベースをホストしている同じシステムに Collaborative Server をインストールする必要があります。

Collaborative Server は、常に実行されている必要があり、ファイアウォールとウイルス スキャナーを介してクライアントと常に中断なしで双方向通信を行う必要があります。

Collaborative Server を個別モードまたはサーバー モードでインストールするには、以下のパラメータを指定する必要があります。
  • マシン名（LOCALHOST など）
  • マシンの IP アドレス（127.0.0.1 など）
  • ポート番号（26666 など）

中断なしで双方向通信を行うには、Collaborative Server がインストールされるシステム上でポート番号 26666 が使用可能であることを確認してください。 ポート 26666 にアクセスできない場合は、システム管理者と協力して、SOLIDWORKS Electrical がアクセスできる別のポートを見つけてください。

親トピック
SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
データの場所の指定
Microsoft SQL Server の設定


Microsoft SQL Server の設定

SOLIDWORKS Electrical のどのタイプのインストールでも、必ず SQL Server データベースのインスタンスを使用可能にする必要があります。 既存の SQL Server データベースがシステムにインストールされている場合は、それを使用できます。SOLIDWORKS Electrical のインストール時に新しいインスタンスをインストールすることもできます。

SOLIDWORKS のインストールで SQL Server の新しいインスタンスをインストールすると、Microsoft SQL Server Express の無償ライセンス版がインストールされます。 このバージョンは、1 つの CPU、1 GB のメモリ、および 10 GB のデータに制限されています。 このメモリと CPU の制限内で、5 人の同時ユーザーを十分にサポートできます。

SQL Server Express Edition をインストールする場合は、サーバーのソフトウェアとハードウェアが http://solidworks.com/System_Requirements に記載されている要件を満たすことを確認してください。

ただし、同じサーバー上に 6 人以上の同時ユーザーが存在する場合は、SQL Server のフル バージョンを購入してインストールし、既存の SQL Server インスタンスを使用して SOLIDWORKS Electrical をインストールする場合のワークフローを使用してください。

SQL Server Express Edition については、Microsoft SQL Server のドキュメントを参照してください。

親トピック
SOLIDWORKS Electrical をインストールするための要件
関連概念
個別オプションとサーバー オプション
データの場所の指定
Collaborative Server の設定

SQL Server の新しいインスタンス

SQL Server の新しいインスタンスをインストールする場合は、サーバーおよびクライアント システムに対する完全な管理者権限が必要です。 また、クライアントにデータベースの読み取り/書き込み権限があり、クライアントでプロジェクト、ライブラリ、記号、およびその他のプロジェクト データを作成できることを確認する必要があります。

SQL Server の新しいインスタンスをインストールする場合は、デフォルト以外の名前を選択してください。

SQL Server の既存のインスタンス

新しい SOLIDWORKS Electrical データベースをインストールする場合、または SQL Server の既存のインスタンスにインストールされた SOLIDWORKS Electrical に接続する場合は、SQL Server データベースに対する完全な管理者権限を持つユーザー アカウントが必要です。

SOLIDWORKS Electrical が正しく機能するには、SQL Server の混合モード認証を有効にする必要があります。 混合モード認証では、Windows と SQL Server のどちらかの認証情報を使用できます。

既存の SQL Server データベースに接続するには、Windows 認証または SQL Server 認証を使用します。 SQL Server に対する完全な管理者権限を持つユーザーが Windows または SQL Server にログインするためのユーザー名とパスワードを入力します。

インストール時に「tew」ユーザーを使用して SQL Server に接続することはできません。 SQL Server に対する適切な認証情報を含むログインの取得方法については、SQL Server 管理者またはシステム管理者に問い合わせてください。

SQL Server のインストール後処理

SOLIDWORKS Electrical をインストールした後は、SQL Server インスタンスによって SOLIDWORKS Electrical の以下のデータベースが作成されます。
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


ライセンス管理（License Administration）

インストール後に SOLIDWORKS ライセンスをアクティブ化するには、個人コンピュータでのアクティブ化（ライセンス アクティベーション）、またはサーバーでのフローティングネットワーク ライセンスのインストールとアクティブ化（SolidNetWork ライセンス）のいずれかを行います。

一般的に、個人コンピュータで行うインストレーションではライセンス アクティベーションを使用します。しかし、ソフトウェアを個別にインストールしてからライセンスをSolidNetWork License Managerでコントロールすることもできます。逆に、大規模な環境では一般的にフローティング ネットワーク ライセンスが使用されますが、アドミニストレーティブ イメージからインストレーションを展開し、シリアル番号を各コンピュータからアクティブ化することもできます。

Windows 8 を稼働している場合は、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント（Tips for Using SOLIDWORKS with Microsoft Windows 8）を参照し、スタート または コントロール パネル へのアクセスなどのタスクを確認してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。

目次

  • 個人ライセンスの管理（Administering Individual Licenses）

    通常、個人ライセンスの管理は直接 SOLIDWORKS からのライセンスのアクティベーションとトランスファーで構成されます。

  • SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

    SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。


個人ライセンスの管理（Administering Individual Licenses）

通常、個人ライセンスの管理は直接 SOLIDWORKS からのライセンスのアクティベーションとトランスファーで構成されます。

SOLIDWORKS スタンドアロン ライセンス (SolidNetWork ライセンスではありません) において、製品のライセンスを取得して登録するプロセスを「アクティベーション」と呼びます。 一般に製品のライセンスがアクティブ化されていない場合、SOLIDWORKS は製品の開始時にライセンスをアクティブ化しようとします。

また、個人ライセンスをトランスファーするには、SOLIDWORKS で ヘルプ (Help) > ライセンス トランスファー (Transfer Licenses) をクリックします。

親トピック
ライセンス管理（License Administration）
関連概念
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

ライセンス アクティベーション（Activating a License）

SOLIDWORKS 製品を個人コンピュータで実行する前に、そのコンピュータに対するライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体のソフトウェア ライセンスをアクティブ化します。
  • ライセンス権を別のコンピュータへトランスファー（移動）します。
  • その場で実行する（推奨）ことも、インストレーション後 30日以内に実行することもできます。
  • ドングル（ハードウェア ロック）が不必要になります。 しかし、アクティベーションを利用しない、以前のバージョンの SOLIDWORKS 製品をご使用の場合は、ドングルが必要です。

複数のシリアル番号を管理するシステム管理者の場合、アドミニストレーティブ イメージ オプション エディタを参照してください。 詳細については、SOLIDWORKS アドミニストレーティブ イメージ オプション エディタ (Administrative Image Option Editor)を参照してください。

ライセンスをアクティブ化するには:

  1. SOLIDWORKS アプリケーションを開始します。
  2. 以下のいずれかの方法を使用し、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) を開始します。
    • このコンピュータのライセンスがアクティブ化されていない場合、SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) ウィンドウは SOLIDWORKS の開始時に自動的に表示されます。
    • SOLIDWORKS 製品のアクティベーション (SOLIDWORKS Product Activation) ウィンドウが自動的に表示されない場合、ヘルプ > ライセンス アクティブ化 をクリックしてアクティベーションを開始します。
  3. 製品 リストをクリックし、ライセンスをアクティブ化する製品を指定します。
  4. インターネット経由の自動アクティベーションまたは電子メール使用のマニュアル アクティベーションを指定します。
  5. 電子メールの連絡先を入力します。
  6. 続行するには 次へ をクリックしてください。
    • インターネットの場合:アクティベーションは自動的に行われます。
    • Email : 保存 をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com まで電子メールで送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く をクリックしてファイルを読み込みます。
      必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。
  7. 完了 をクリックします。
関連資料
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）

ライセンス トランスファー（Transferring a License）

ライセンスを新しいまたはアップグレードしたコンピュータにトランスファー (移動) するには、まずライセンスを Dassault Systèmes SOLIDWORKS Corporation のライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。

ライセンスを Dassault Systèmes SOLIDWORKS Corporation のライセンス キー サーバーにトランスファーできない場合（たとえば、ハードドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。 そうでない場合は、お客様の代理店にお問い合わせください。

ライセンスをトランスファーしてサーバーに戻すには、以下を行います。

  1. SOLIDWORKS でヘルプ (Help) > ライセンス トランスファー (Transfer Licenses)をクリックし、指示に従います。
  2. 再アクティブ化するには、新しいまたはアップグレードしたコンピュータで初期のアクティベーションと同じようにライセンス アクティベーションを行います。 詳細については、ライセンス アクティベーションを参照してください。


SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）

SolidNetWork License Managerは、ネットワーク上のクライアントにライセンスを配布することで複数のライセンス クライアントをサポートします。フローティング ライセンスを使用することにより、ユーザー数はライセンス数を上回ることが可能になります。

次のイメージは、SolidNetWorkライセンスのインストレーションを表しています。

このイメージは、以下を明らかにします。
  • SolidNetWork License Managerソフトウェアは、ライセンス マネージャー コンピュータ上のみにインストールされ、アクティブ化されます。
  • ライセンス クラインアント コンピュータには、SolidNetWork特有のソフトウェアはインストールされていません。

    インストール時に SolidNetWork ライセンスのシリアル番号を指定すると、SOLIDWORKS Installation Manager はそのコンピュータを SolidNetWork ライセンス クライアントとして認識します。 SOLIDWORKS Installation Manager はクライアントをライセンス マネージャーと接続させるために、SolidNetWork License Manager コンピュータ名とポート番号を求めるプロンプトを表示します。

  • ライセンス マネージャーとすべてのライセンス クライアントは、TCP/IP（Transmission Control Protocol/Internet Protocol）接続を必要とします。

目次

  • SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）

    ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

  • SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）

    SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスを Dassault Systèmes SOLIDWORKS Corporation のライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。

  • SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）

    SolidNetWork ライセンスの設定は、ライセンス マネージャー コンピュータに SolidNetWork License Manager をインストールしてから SolidNetWork ライセンスのシリアル番号を使用してクライアント コンピュータに SOLIDWORKS をインストールすることで構成されます。

  • SolidNetWorkライセンス管理（SolidNetWork License Administration）

    タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの借入と返却が含まれます。

親トピック
ライセンス管理（License Administration）
関連概念
個人ライセンスの管理（Administering Individual Licenses）


SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）

ユーザーが SOLIDWORKS 製品を各自の個人コンピュータで実行する前に、SolidNetWork License Manager コンピュータで SolidNetWork ライセンスをアクティブ化する必要があります。

アクティベーションにはインターネットと電子メールへのアクセスが必要です。アクティベーションが終了した後、製品を使用するには、オンライン上でつながっている必要はありません。製品を使用するコンピュータに電子メールの設定がない場合は、アクティベーション ファイルを保存し、それを別のコンピュータから送信できます。

このプロセスでは次を行います:
  • SOLIDWORKS 製品全体の SolidNetWork ライセンスと共に SOLIDWORKS SolidNetWork License Manager をアクティブ化します。
  • 1台のSolidNetWork License Managerコンピュータから別のコンピュータへSolidNetWorkライセンス権限をトランスファーできるようにします。
  • 1台のSolidNetWork License ManagerコンピュータにSolidNetWorkライセンス権限をインストールしてアクティブ化できるようにします。
  • SolidNetWorkライセンスを使用する前に、実行する必要があります。
  • ドングル（ハードウェア ロック）が不必要になります。 このバージョンの SOLIDWORKS の SolidNetWork ライセンスをアクティブ化すると、前のバージョンの SOLIDWORKS の SolidNetWork ライセンスもアクティブ化されます （ドングルを保持する必要はなくなります）。

SolidNetWorkライセンスをアクティブ化するには、以下を行います。

  1. SolidNetWork License Manager を開始します（スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. まだ SolidNetWork ライセンスをアクティブ化していない場合は、今すぐライセンスをアクティブ化するかどうかを確認するプロンプトが表示されます。 はい をクリックしてアクティブ化します。
  3. どのようにアクティブ化しますか? （How would you like to activate?）で インターネットを自動的に使用（推奨） （Automatically over the internet (recommended)）を選択します。
  4. 連絡情報 （Contact Information）で連絡先の電子メール アドレスを指定します。
アクティベーション/再アクティベーションに成功しました（Activation/Reactivation Succeeded）ダイアログ ボックスにアクティブ化された製品の名前が表示されます。
親トピック
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）


SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）

SolidNetWork ライセンスを新しいまたはアップグレードしたコンピュータにトランスファー（移動）するには、まずライセンスを Dassault Systèmes SOLIDWORKS Corporation のライセンス キー サーバーにトランスファーし、続いて別のコンピュータ上で再度アクティブ化します。

ライセンスを Dassault Systèmes SOLIDWORKS Corporation のライセンス キー サーバーにトランスファーできない場合（たとえば、ハードドライブの故障など）でも、再アクティベーションはほとんどの場合に成功します。 そうでない場合は、お客様の代理店にお問い合わせください。

SolidNetWorkライセンスをトランスファーしてサーバーに戻すには、以下を行います。

  1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。

  2. ライセンス情報 で、変更 をクリックします。 SOLIDWORKS 製品のアクティベーション （SOLIDWORKS Product Activation）ウィザードが開始されます。
  3. 何を行いますか? （What would you like to do?）で ソフトウェア ライセンスのトランスファー （Transfer a software license）を選択してから、次へ （Next）をクリックします。
  4. どのようにトランスファーしますか? （How would you like to transfer?）で インターネットを自動的に使用（推奨） （Automatically over the internet (recommended)）を選択します。
  5. 連絡情報 （Contact Information）で連絡先の電子メール アドレスを指定します。
  6. 次へ（Next）をクリックします。 これで、製品ライセンスのトランスファーが完了します。
親トピック
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）


SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）

SolidNetWork ライセンスの設定は、ライセンス マネージャー コンピュータに SolidNetWork License Manager をインストールしてから SolidNetWork ライセンスのシリアル番号を使用してクライアント コンピュータに SOLIDWORKS をインストールすることで構成されます。

目次

  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）

    SolidNetWork License Managerは、複数のラインセンス クライアント コンピューターをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

  • ライセンス クライアントのインストール（Installing a License Client）

    SOLIDWORKS を SolidNetWork ライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によって SolidNetWork ライセンス クライアントとして識別されます。

  • ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）

    SolidNetWorkライセンス クライアント コンピュータをインストールする前に、少なくとも1台のコンピュータにSolidNetWork License Managerをインストールして設定する必要があります。

  • SOLIDWORKS バージョンに対するアクセスの管理

    SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

  • トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

  • SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

    コンピュータでファイアウォールを使用している場合は、SolidNetWorkライセンスをサポートするようにポートを構成する必要があります。

親トピック
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）
SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）


License Managerのインストールとアクティベーション（Installing and Activating a License Manager）

SolidNetWork License Managerは、複数のラインセンス クライアント コンピューターをサポートします。 また、ネットワーク上のクライアント コンピュータにライセンスを配布します。

ライセンスのアクティベーション にハードウェア ドングルを使用した以前のバージョンの SolidNetWork License Manager をアップグレードする場合は、新しいバージョンの SolidNetWork License Manager をインストールする前にハードウェア ドングルを取り外してください。

  1. SOLIDWORKS Installation Manager を起動します (SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います)。
    1. インストレーションのタイプには、以下を選択します。

      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。

    2. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    3. サマリー ページで、今すぐインストール をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWorkライセンスをアクティブ化するには、以下を行います。
    1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
    2. アクティブ化を求めるプロンプトが表示されたら、はい をクリックします。
    3. SolidNetWorkライセンス サーバー情報（SolidNetWork License Server Information）画面で以下を行います。

      • ファイアウォールを使用している場合、このサーバーのファイアウォールは使用中です を選択します。

        詳細は、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。

      • ポート番号 （Port Number）（およびファイアウォールを使用している場合は ベンダー デーモン ポート番号 （Vendor Daemon Port Number））にはデフォルト値を使用するか、または会社で使用しているポート番号を指定します。
        ポート番号は、1024 - 60000の範囲内のTCP/IPポート番号で、これは他のプロセスでは使用できません。 通常、デフォルト（25734）が好ましく、現在ライセンス マネージャー コンピュータ上にある他の FLEXnet サーバーのプロセスと一致する可能性が少ないといえます。

    4. SOLIDWORKS 製品のアクティブ化（Activate Your SOLIDWORKS Product）画面で以下を行います。

      • インターネットか電子メールのプロセスを選択します。
      • 電子メールの連絡先を入力します。
      • 次へ をクリックし、続行します。
        • インターネットの場合: アクティベーションは自動的に行われます。
        • Email : 保存 をクリックしてリクエスト ファイルを作成し、ファイルを activation@solidworks.com に送信します。レスポンス ファイルを含む電子メールを受信したら、電子メールからファイルを抽出し、開く をクリックしてファイルを読み込みます。
          必要に応じて、アクティベーション手順を終了してから再び実行してレスポンス ファイルを開きます。

  3. 完了（Finish）をクリックします。
親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS バージョンに対するアクセスの管理
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


ライセンス クライアントのインストール（Installing a License Client）

SOLIDWORKS を SolidNetWork ライセンス クライアント コンピュータにインストールするときに、コンピュータはシリアル番号によって SolidNetWork ライセンス クライアントとして識別されます。

  1. SOLIDWORKS Installation Manager を起動します (SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います)。
  2. このメジャー リリースの SOLIDWORKS を今回初めてインストールする場合、ようこそ画面で 個人（このコンピュータ上） をクリックします。

    既存のリリースからアップグレードして個人ライセンスから SolidNetWork ライセンスに変更する場合は、個人インストレーションの変更（このコンピュータ上で実行します） をクリックします。詳細については、個人ライセンスから SolidNetWork ライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）を参照してください。

  3. シリアル番号を求めるプロンプトが表示されたら、SolidNetWorkライセンスのシリアル番号を入力します。
  4. サーバーの追加（Add Server）ダイアログ ボックスで、SolidNetWork License Managerのアドレスを次の形式で入力します。

    port@ComputerName

    ポート番号は、ライセンス マネージャー コンピュータで使用している番号と同じでなければなりません。 デフォルトは 25734 です（License Manager のインストールとアクティベーション（Installing and Activating a License Manager）を参照）。

    SOLIDWORKS Installation Manager は、この SolidNetWork License Manager がアクセス可能であることを検証しようとします。 まだライセンス マネージャーをインストールしていない場合、この検証には失敗します。しかし、それでもライセンス クライアントのインストレーションは続行できます。

  5. SOLIDWORKS Installation Manager の指示に従い、SOLIDWORKS のインストレーションを完了します。
親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
SOLIDWORKS バージョンに対するアクセスの管理
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）

SolidNetWorkライセンス クライアント コンピュータをインストールする前に、少なくとも1台のコンピュータにSolidNetWork License Managerをインストールして設定する必要があります。

SolidNetWork ライセンスのシリアル番号でインストールするときに、SOLIDWORKS Installation Manager は SolidNetWork License Manager コンピュータ名とポート番号の入力を求めるプロンプトを表示した後で、この情報を検証しようとします。

SolidNetWork License Managerが指定したコンピュータにインストールされていない場合は、検証に失敗します。しかし、この場合、検証の失敗は正しいライセンス マネージャー情報が提供されているかどうかを示すものではありません。ライセンス マネージャーがインストールされている場合、検証の失敗は指定したライセンス マネージャー情報が間違っていることを示します。

親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS バージョンに対するアクセスの管理


SOLIDWORKS バージョンに対するアクセスの管理

SolidNetWork 環境で特定のバージョンの SOLIDWORKS を使用しないように制限できます。 この機能を使用して、さまざまなユーザー、プロジェクト、部門で使用される SOLIDWORKS のバージョンを管理できます。

FLEXnet オプション ファイルを使用して SOLIDWORKS のバージョンに対するアクセスを管理するには:

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. ライセンス ファイルで特定の SOLIDWORKS バージョンに対するアクセスを管理するには、次の構文を SOLIDWORKS に追加します:

    :SWVERSION=xx xx は、管理する SOLIDWORKS 製品のバージョンを示します

  3. 複数のバージョンの SOLIDWORKS を管理するには、管理するバージョンごとに行を追加します。

    すべての FLEXnet オプションがサポートされているわけではありません。 サポートされるバージョン フィルタのオプションは次のとおりです:

    INCLUDE | ユーザーまたはグループのみが、特定のバージョンを開始できます。 その他のすべてのユーザーは、このバージョンを開始できません。
    INCLUDE_BORROW | ユーザーまたはグループのみが、特定のバージョンを借用できます。 その他のすべてのユーザーは、このバージョンを借用できません。
    EXCLUDE | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を開始することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    EXCLUDE_BORROW | リストにあるユーザーまたはグループが特定のバージョンの SOLIDWORKS を借用することを禁止します。 EXCLUDE は INCLUDE よりも優先されます。
    例：
    1 | SWVERSION=24.0 は SOLIDWORKS 2016 を表します
    SWVERSION=23.0 は SOLIDWORKS 2015 を表します
    2 | INCLUDE solidworks:SWVERSION=24.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=24.0 USER jane
    オプション ファイル内のこれらの行で、jane のみが SOLIDWORKS 2016 の実行または借用が可能です。その他のすべてのユーザーは SOLIDWORKS 2016 の実行も借用もできませんが、他のバージョンの SOLIDWORKS の実行と借用ができます。jane も他のバージョンの SOLIDWORKS の実行と借用ができます。
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=24.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=23.0 GROUP chicago
    EXCLUDE solidworks USER don
    これらの行は、chicago というユーザーの GROUP を定義します。このグループは SOLIDWORKS 2015 と SOLIDWORKS 2016 の両方へのアクセスは拒否されますが、他のすべてのバージョンの SOLIDWORKS は実行できます。 ユーザー don はどのバージョンの SOLIDWORKS も実行できません。
    4 | EXCLUDE swinspection_std:SWVERSION=24.0 HOST machine1
    この行によって、machine1 上のすべてのユーザーが SOLIDWORKS Inspection 2016 を起動することを禁止します。machine1 を使用するすべてのユーザーは別のバージョンである SOLIDWORKS Inspection 2015 を実行できます。

    FLEXnet の詳細については、SolidNetwork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）


トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ライセンス ファイルを管理しているコンピュータが使用できなくなった場合も、残りの2台のコンピュータの内の1台で処理できます。

トライアド ライセンス マネージャーの使用条件は、以下のとおりです。
  • 3個のハードウェア ドングルが必要です。
  • トライアド ライセンス マネージャーは、頻繁に再起動、またはシャットダウンがスケジュールされたコンピュータではなく、安定したコンピュータのみにインストールしてください。
  • トライアド ライセンス マネージャー コンピュータは同一のサブネット上になければなりません。トライアド ライセンス マネージャーは、通信状態の悪い状態、またはダイアルアップ リンクで構成しないでください。
  • ライセンス マネージャー コンピュータがダウンした場合、システム管理者が早急に検知でき、再起動できる状態になければなりません。
    2台のライセンス マネージャー コンピュータのみが実行されている場合、2台のコンピュータ共に問題があることになるため、ライセンス マネージャー コンピュータが1台のみの場合よりも好ましくない状況にあるといえます。

目次

  • 最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの最初のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

  • 残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

    トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの2台目と3台目のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS バージョンに対するアクセスの管理


最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの最初のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

  1. 最初のトライアド ライセンス マネージャー コンピュータで、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. SOLIDWORKS Installation Manager を起動します (SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います)。
    2. インストレーションのタイプには、以下を選択します。

      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。

    3. SolidNetWork License Manager オプション ページで、SolidNetWork ライセンスのシリアル番号と SolidNetWork License Manager のインストール先を指定します。
    4. サマリー ページで、今すぐインストール をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、最初のトライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
    2. いいえ をクリックします。

      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。

    3. 詳細設定オプション で、オプション をクリックします。

      詳細設定オプション ダイアログ ボックスが表示されます。

    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。

      詳細設定オプション ダイアログ ボックスが閉じます。

    5. ライセンス情報 で、変更 をクリックします。

      SolidNetWorkライセンス ファイル ウィザードが表示されます。

    6. サーバー タイプ で、3サーバー を選択して 次へ をクリックします。
    7. サーバー情報パネルで最初のトライアド ライセンス マネージャー コンピュータのコンピュータ名、ドングルID、ポート番号が正しいことを確認し、次へ （Next）をクリックします。

      サーバーでドングルではなくネットワーク インタフェース カード (NIC) アドレスを使用する場合は、NIC アドレスが SOLIDWORKS から受け取ったライセンス ファイルの情報と一致することと、トライアド ライセンス マネージャー コンピュータのポート番号が正しいことを確認します。 NIC アドレスは、MAC (Media Access Control Address) アドレスとも呼ばれます。 続いて 次へ をクリックします。

      NIC アドレスを調べるには、コマンド プロンプト ウィンドウを開いて次のように入力します:

      ipconfig /all

      また、コンピュータでファイアウォールを使用している場合は、いくつかの追加の指定をこの画面で行う必要があります。 詳細は、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。

    8. Triad Partner Server Information 画面で、他の 2 台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とドングル ID の値を入力します。 コンピュータで NIC アドレスを使用している場合は、コンピュータ名と Host ID の値を入力します。

      この方法では、1台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの2台のサーバーからライセンスを取得できます。

    9. ライセンス 画面で 読み取り をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。

      SolidNetWorkライセンス ファイル ウィザード ウィザードにライセンス情報が表示されます。

    10. 完了 をクリックします。
    11. OK をクリックし SolidNetWorkライセンス ファイル ウィザード ウィザードを終了してから、終了 をクリックして SolidNetWork License Manager を終了します。
親トピック
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連概念
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）
SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）


残りのコンピュータのトライアド ライセンス マネージャーのインストール（Installing the Triad License Manager on Subsequent Computers）

トライアド ライセンス マネージャーは安定性のために3台のコンピュータを使用します。ここでは、トライアドの2台目と3台目のコンピュータにSolidNetWork License Managerをインストールする方法について説明します。

既に別のコンピュータに少なくとも1つのトライアド ライセンス マネージャーがインストールされていることを前提とします。

  1. トライアド ライセンス マネージャー コンピュータで、SOLIDWORKS Installation Manager を使用して SolidNetWork License Manager をインストールします。
    1. SOLIDWORKS Installation Manager を開始します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    2. インストレーションのタイプには、以下を選択します。

      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。

    3. SolidNetWork License Manager オプション ページで、SolidNetWork ライセンスのシリアル番号と SolidNetWork License Manager のインストール先を指定します。
    4. サマリー ページで、今すぐインストール をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  2. SolidNetWork License Managerを使用し、トライアド ライセンス マネージャー コンピュータを設定します。
    1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。

      このコンピュータでSolidNetWork License Managerを実行するのは今回が初めてであるため、今すぐアクティブ化するかどうかを確認するプロンプトが表示されます。

    2. いいえ をクリックします。

      SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。

    3. 詳細設定オプション で、オプション をクリックします。

      詳細設定オプション ダイアログ ボックスが表示されます。

    4. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。

      詳細設定オプション ダイアログ ボックスが閉じます。

    5. ライセンス情報 で、変更 をクリックします。

      SolidNetWorkライセンス ファイル ウィザードが表示されます。

    6. サーバー タイプ で、3サーバー および 同期サーバー/ライセンス情報 を選択した後、次へ をクリックします。
    7. サーバー情報パネルで、このトライアド ライセンス マネージャー コンピュータのコンピュータ名、ドングルID、ポート番号が正しいことを確認し、次へ （Next）をクリックします。

      サーバーでドングルではなくネットワーク インタフェース カード (NIC) アドレスを使用する場合は、NIC アドレスが SOLIDWORKS から受け取ったライセンス ファイルの情報と一致することと、トライアド ライセンス マネージャー コンピュータのポート番号が正しいことを確認します。 NIC アドレスは、MAC (Media Access Control Address) アドレスとも呼ばれます。 続いて 次へ をクリックします。

      NIC アドレスを調べるには、コマンド プロンプト ウィンドウを開いて次のように入力します:

      ipconfig /all

      また、コンピュータでファイアウォールを使用している場合は、いくつかの追加の指定をこの画面で行う必要があります。 詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

    8. コンピュータでドングルを使用している場合は、Triad Partner Server Information 画面で、他の 2 台のトライアド ライセンス マネージャー コンピュータのコンピュータ名とドングル ID の値を入力します。 コンピュータで NIC アドレスを使用している場合は、コンピュータ名と Host ID の値を入力します。

      この方法では、1台のライセンス マネージャーが使用できなくなった場合でも、クライアント コンピュータは残りの2台のサーバーからライセンスを取得できます。

    9. ライセンス 画面で 読み取り をクリックし、SolidNetWork ライセンス ファイルまで参照し、これを開きます。

      通常、ライセンス ファイルは設定した最初のトライアド ライセンス マネージャー コンピュータの \licenses\sw_d.lic にあります。

      SolidNetWorkライセンス ファイル ウィザード ウィザードにライセンス情報が表示されます。

    10. 完了 をクリックします。

      SolidNetWorkライセンス ファイル ウィザードの警告が表示されます。

    11. OK をクリックし SolidNetWorkライセンス ファイル ウィザード ウィザードを終了してから、終了 をクリックして SolidNetWork License Manager を終了します。

2台目のトライアド ライセンス マネージャー コンピュータを設定したら、このプロセスを3台目のトライアド ライセンス マネージャー コンピュータに対しても繰り返してください。

親トピック
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連タスク
最初のトライアド ライセンス マネージャーのインストール（Installing the Initial Triad License Manager）


SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）

コンピュータでファイアウォールを使用している場合は、SolidNetWorkライセンスをサポートするようにポートを構成する必要があります。

ファイアウォールのソフトウェアで、2つのSolidNetWorkライセンス ポート（例えば、SNL-in-portとSNL-out-port）をファイアウォールの例外リストに追加する必要があります。これらのポートを構成する方法の詳細については、システム管理者に相談してください。

サポートされる Windows オペレーティング システムで Windows ファイアウォールを使用している場合は、SolidNetWork ライセンス マネージャー コンピューターでポートを変更し、SolidNetWork ライセンス ファイルを変更してライセンスをライセンス クライアント コンピューターに配布する必要があります。

目次

  • Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

    Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。

  • WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

    Windowsファイアウォールを使用している場合は、ファイアウォールのポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWorkライセンス ファイルを変更する必要があります。

親トピック
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連概念
ライセンス クライアントのインストール前のSolidNetWork License Managerのインストール（Install SolidNetWork License Managers Before Installing License Clients）
トライアド ライセンス マネージャーのインストレーション（Triad License Manager Installation）
関連タスク
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
ライセンス クライアントのインストール（Installing a License Client）
SOLIDWORKS バージョンに対するアクセスの管理


Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）

Windowsファイアウォールを使用している場合は、SolidNetWorkライセンス マネージャー コンピュータでファイアウォールのポート設定を変更する必要があります。

  1. Windowsでコントロール パネルを開き、セキュリティ センター（Security Center）をダブル クリックします。
  2. Windows ファイアウォール（Windows Firewall）をクリックします。
  3. 例外（Exceptions）タブでポートの追加（Add Port）をクリックします。
  4. 名前（Name）（例えば、SNL-in-port）とポート番号（Port Number）（例えば、25734）を入力してから、OKをクリックします。
  5. 2つ目のポートのために、例外（Exceptions）タブのポートの追加（Add Port）を再びクリックし、残りのポートの名前と番号（例えば、SNL-out-portと25735）を指定してから、OKをクリックします。後からSolidNetWorkライセンス ファイルを変更する際等に参照ができるように、ポート番号をメモしてください。

    Workgroup PDMを使用する場合は、Workgroup PDMのポート番号をWindowsファイアウォールで変更する必要があります。通常、これらのポートは20000（VaultAdmin）、30000（Data）、40000（Request）、および80（Viewer）となります。

  6. Windowsセキュリティ センターとコントロール パネルを閉じます。
親トピック
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）


WindowsファイアウォールのためのSolidNetWork License Manager設定の変更（Modifying SolidNetWork License Manager Settings for Windows Firewall）

Windowsファイアウォールを使用している場合は、ファイアウォールのポートを使用してライセンス クライアント コンピュータにライセンスを配布するために、SolidNetWorkライセンス ファイルを変更する必要があります。

  1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  2. ライセンス タブの ライセンス サーバー（License Server） で サーバー をクリックします。 （確認を求めるプロンプトが表示されたら、はい と OK をクリックし、ライセンス サーバーの停止を完了します。）
  3. ライセンス情報 で、変更 をクリックします。
  4. サーバー タイプ でネットワークのサーバー配置（単一 または 3サーバー）を選択してから、次へ をクリックします。
  5. サーバー情報 で:
    1. このサーバーのファイアウォールは使用中です を選択します。
    2. ポート番号とベンダー デーモン ポート番号には、Windows ファイアウォールに指定したポート番号が含まれていなければなりません（詳細については、Windows ファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）を参照）。
    3. オプション ファイル を選択し、参照 をクリックしてファイルを見つけます。 編集 をクリックして、いずれかのパラメータを変更します。

      オプション ファイルを使用することで、ライセンス管理者は FLEXnet ライセンスのさまざまな操作パラメータを制御できます。

      オプション ファイルの推奨される場所は、SolidNetwork License Manager のインストレーション ディレクトリ（SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt）です。 このファイルは、sw_d.lic ファイルと同じディレクトリにある必要があります。

      オプション ファイルの詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

    4. 次へ をクリックし、次に 終了 をクリックします。
  6. サーバー アドミニストレーション タブの ライセンス サーバー で 開始 をクリックします。
  7. OK をクリックして SolidNetWork License Manager を閉じます。
親トピック
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）
関連タスク
Windowsファイアウォールのためのライセンス マネージャー コンピュータの変更（Modifying License Manager Computer Ports for Windows Firewall）


SolidNetWorkライセンス管理（SolidNetWork License Administration）

タスクには、ライセンス マネージャーの開始、アップグレード、アンインストール、およびライセンスの借入と返却が含まれます。

ライセンス マネージャーを開始またはアップグレードする前に、借りたライセンスを返却する必要があります。

目次

  • SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

    SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

  • SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

    SOLIDWORKS メジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化で構成されます。

  • SolidNetWorkライセンス ファイルの削除（Deleting SolidNetWork License Files）

    新しいSolidNetWorkライセンス ファイルにアップグレードする前に、古いまたは有効期限の切れたファイルを削除してください。

  • SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  • ライセンスのアイドル状態の監視（Monitoring License Idle Time）

    SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  • 一時的なライセンスのインストール（Installing Temporary Licenses）

    一時的な"ANY"ライセンスは、オリジナルのSolidNetWorkライセンスが使用できない場合に一時的に使用できます。

  • 個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

    SOLIDWORKS 個人ライセンスから SolidNetWork ライセンスにコンピュータをアップグレードするには、SOLIDWORKS Installation Manager で SolidNetWork ライセンスのシリアル番号を指定します。

  • SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

    SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品（たとえば、FeatureWorks、Workgroup PDM Server など）のライセンスを配布できます。

  • ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

    ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

  • FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）

    SolidNetWorkライセンスは、FLEXnet Publisher®ライセンス管理に基づいています。

親トピック
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
関連概念
SolidNetWorkライセンスのインストールと設定（Installing and Configuring SolidNetWork Licensing）
関連タスク
SolidNetWorkライセンス アクティベーション（Activating a SolidNetWork License）
SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）


SolidNetWork License Managerの開始（Starting the SolidNetWork License Manager）

SolidNetWork License Manager は Windowsの スタート メニューから開始できます。

  • Windows で次のコマンドを実行します： スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager。
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）

SOLIDWORKS メジャー リリースの場合、ライセンス マネージャーのアップグレードは古いライセンス マネージャーのアンインストール、新しいライセンス マネージャーのインストール、SolidNetWork ライセンスの再アクティブ化で構成されます。

新しいリリース用のライセンス マネージャーは、以前のリリースを保持しているクライアント コンピュータのライセンスも配布できます。

  1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  2. ライセンスの使用状況 タブで、SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。
  3. 古いライセンス マネージャーをアンインストールします。 詳細は、SolidNetWork License Manager のアンインストール（Uninstalling the SolidNetWork License Manager）を参照してください。
  4. 新しいライセンス マネージャーをインストールし、ライセンス マネージャー コンピュータでSolidNetWorkライセンスを再アクティブ化します。 詳細は、License Managerのインストールとアクティベーション（Installing and Activating a License Manager）を参照してください。

SOLIDWORKS アプリケーションを同時に実行しているコンピュータで SolidNetWork License Manager をアップグレードする場合は、そのコンピュータに SOLIDWORKS アプリケーションの新しいサービス パックをインストールする前に SolidNetWork ライセンス マネージャーとクライアントをアップグレードします。

アドミニストレーティブ イメージをホストするコンピュータでライセンス マネージャーをアップグレードする場合は、アドミニストレーティブ イメージをアップグレードする前にライセンス マネージャーをアップグレードします。 詳細については、Using the Same Computer for the License Manager and Administrative Image Installations を参照してください。

目次

  • SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager）

    SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager）

SolidNetWork License Managerのアップグレードを行うには、新しいライセンス マネージャーをインストールする前に古いライセンス マネージャーをアンインストールする必要があります。

  1. SolidNetwork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  2. SOLIDWORKS を実行しているクライアント コンピュータがネットワーク上にないことを確認します。

    ライセンスの使用状況 タブには SOLIDWORKS を実行しているクライアントが表示されます。

  3. SolidNetWorkライセンスを別のコンピュータにトランスファーする場合は、コンピュータからSolidNetWork License Managerを削除する前にライセンスを別のコンピュータにトランスファーしてください。

    SolidNetWork ライセンスのトランスファーについては、SolidNetWork ライセンス トランスファー（Transferring a SolidNetWork License）を参照してください。

  4. ライセンス タブの ライセンス サーバー で、サーバー をクリックします。
  5. OK をクリックし、ライセンス マネージャーを閉じます。
  6. Windows で コントロール パネル > プログラムの追加と削除 を開きます。
  7. SOLIDWORKS SolidNetWork License Manager を選択し、削除 をクリックして、削除を確認します。
  8. Windows エクスプローラで SOLIDWORKS SolidNetWork License Manager のフォルダを削除します

    （通常、このフォルダは SOLIDWORKS インストレーション ディレクトリの Program Files にあります）。

これで、新しいバージョンのライセンス マネージャーのインストールを行う準備が整いました。 詳細については、License Manager のインストールとアクティベーション（Installing and Activating a License Manager）を参照してください。

SolidNetWork License Manager コンピュータにハードウェア ドングルが取り付けられている場合は、新しいバージョンの SolidNetWork License Manager をインストールする前に、ハードウェア ドングルを取り外します。
親トピック
SolidNetWork License Managerのアップグレード（Upgrading the SolidNetWork License Manager）
関連タスク
SolidNetWorkライセンス トランスファー（Transferring a SolidNetWork License）
License Managerのインストールとアクティベーション（Installing and Activating a License Manager）


SolidNetWorkライセンス ファイルの削除（Deleting SolidNetWork License Files）

新しいSolidNetWorkライセンス ファイルにアップグレードする前に、古いまたは有効期限の切れたファイルを削除してください。

  1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  2. サーバー アドミニストレーション （Server Administration）タブの ライセンス ファイル （License File）で 変更 （Modify）をクリックします。続いて ライセンス （Licenses）スクリーンが表示されるまで 次へ （Next）をクリックします。
  3. ライセンス （Licenses）画面で古いまたは期限の切れた SolidNetWork ライセンス ファイルを選択してから、削除 （Remove）をクリックします。
  4. 終了 （Finish）をクリックし、次に OK をクリックします。
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。ライセンスは使用可能なライセンスのプールから取り除かれるため、借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

借入ライセンスは、現在のユーザーおよび借りたコンピュータでのみ有効で、トランスファーすることはできません。

ライセンスは指定期間中（30日間まで）、（またはシステム管理者によって定義された日数）貸し出すことができ、ライセンスは使用可能なライセンスのプールから取り除かれます。

システム管理者はライセンスの借入を次のようにカスタマイズできます。
  • ライセンスを借りることのできるユーザーやグループを定義する
  • 借りることのできないライセンスの数を設定する

詳細については、SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdfを参照してください。

目次

  • SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

    SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。

  • 借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

    借りたSolidNetWorkライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）

SolidNetWorkライセンスを借り、リモート位置からソフトウェアを使用することができます。

ライセンスを借りるには（使用は必須ではありません）、SolidNetWorkライセンス マネージャーに接続している必要があります。

Windows 8 以降を実行している場合、以下の手順はシステムのコンフィギュレーションによって異なります。 追加の手順およびオプションについては、Microsoft Windows のドキュメントを参照してください。
  1. クライアント マシンで SolidNetWork License Manager を開始します（スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager）。
  2. ライセンスを借りるタブで以下を行います。
    1. 借りる期限 で日付を選択します。
    2. 借りる製品ライセンスを選び、借りる （Borrow）をクリックし、続いて はい もクリックして確認します。
    3. 更新 をクリックします。 期限切れ期日 列は、ライセンスの期限を示します。
  3. OK をクリックします。
親トピック
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
関連タスク
借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）


借りたSolidNetWorkライセンスを戻す（Returning a Borrowed SolidNetWork License）

借りたSolidNetWorkライセンスは使用可能なライセンスのプールから取り除かれるため、その借りたライセンスを再び使用可能にするにはこれを戻す必要があります。

  1. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  2. ライセンスを借りるタブで以下を行います。
    1. 返す製品ライセンスを選び、返却 （Return）をクリックし、確認のために はい をクリックします。
    2. 更新 （Refresh）をクリックします。 期限切れ期日 （Expire Date）は空欄になり、ライセンスが返却されたことを示します。
  3. OK をクリックします。
有効期限が過ぎたライセンスを戻す必要はありません。有効期限最終日の真夜中になると、ライセンスは自動的にSolidNetWorkライセンス マネージャーのライセンス プールに戻され、リモート システム上にあるアプリケーションは実行できなくなります。
親トピック
SolidNetWorkライセンスの借入と返却（Borrowing and Returning SolidNetWork Licenses）
関連タスク
SolidNetWorkライセンスの借入（Borrowing SolidNetWork Licenses）


ライセンスのアイドル状態の監視（Monitoring License Idle Time）

SOLIDWORKS は SolidNetWork License Manager のアイドル状態を記録し、一定時間使用されていないライセンスをフリーのライセンス プールに戻すことができます。

  1. SolidNetWork License Managerインストレーション ディレクトリで次のテキスト ファイルを作成します。

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. ファイルに次のラインを追加します。

    TIMEOUTALL seconds

    ここで、secondsは900（15分）（許容最少時間）、またはそれ以上の数値となります。

親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


一時的なライセンスのインストール（Installing Temporary Licenses）

一時的な"ANY"ライセンスは、オリジナルのSolidNetWorkライセンスが使用できない場合に一時的に使用できます。

"ANY" ライセンス ファイルのインストールにより、お客様は Dassault Systèmes SOLIDWORKS Corporation から SolidNetWork ライセンスを受け取った際、従来のライセンスの履行に同意することになります。 この場合も、ライセンス制限への応諾が必要となります。

"ANY"ライセンスをインストールするには、以下を行います。

  1. 既存のSolidNetWorkユーザーである場合、SolidNetWork License Managerのアンインストールを行い、インストレーション フォルダを削除します。 詳細は、SolidNetWork License Managerのアンインストール（Uninstalling the SolidNetWork License Manager）を参照してください。
  2. SOLIDWORKS Installation Manager を開始します（SOLIDWORKS インストレーションの開始（Initiating SOLIDWORKS Installation）の手順に従います）。
    1. インストレーションのタイプには、以下を選択します。

      • サーバー製品
      • SolidNetWork License Manager （配布ライセンス）をこのコンピュータにインストールします（Install SolidNetWork License Manager (distributed licensing) on this computer）。

    2. SolidNetWork License Manager オプション （SolidNetWork License Manager Options）ページで、SolidNetWork License シリアル番号と SolidNetWork License Manager インストール オプションを指定します。
    3. サマリー ページで、今すぐインストール をクリックして SOLIDWORKS Installation Manager のプロセスを完了します。
  3. SolidNetWork License Manager (スタート > プログラム > SOLIDWORKS version > SolidNetWork License Manager > SolidNetWork License Manager) を開始します。
  4. アクティブ化を求めるプロンプトが表示される場合は、いいえ をクリックします。

    SOLIDWORKS SolidNetWork License Manager のサーバー アドミニストレーション タブが表示されます。

  5. 詳細設定オプション で オプション をクリックします。

    詳細設定オプション（Advanced Options）ダイアログ ボックスが表示されます。

  6. SolidNetWork Server ライセンス モードで ライセンス ファイル使用 （Use a License File）をクリックし、OK をクリックします。

    詳細設定オプション（Advanced Options）ダイアログ ボックスが閉じます。

  7. ライセンス情報 （License Information）で 変更 （Modify）をクリックします。

    SolidNetWorkライセンス ファイル ウィザードが表示されます。

  8. サーバー タイプ （Server Type）で 単一 （Single）を選択し、次へ （Next）をクリックします。
  9. 次のメッセージが表示される場合は、以下を行います。

    ドングルのID番号が読み取れませんでした。キャンセルをクリックしてください。

    IDとして"ANY"が自動的に表示されます。
    コンピュータでファイアウォールを使用している場合は、この画面で追加の指定を行う必要があります。 詳細は、SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls） を参照してください。

  10. インストレーションを続行します。
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


個人ライセンスからSolidNetWorkライセンスへのアップグレード（Upgrading from Individual Licensing to SolidNetWork Licensing）

SOLIDWORKS 個人ライセンスから SolidNetWork ライセンスにコンピュータをアップグレードするには、SOLIDWORKS Installation Manager で SolidNetWork ライセンスのシリアル番号を指定します。

コンピュータに SOLIDWORKS がインストールされていない場合は、SOLIDWORKS Installation Manager でインストールするときに SolidNetWork シリアル番号を入力することで SolidNetWork ライセンスを指定できます。

SOLIDWORKS が既にインストールされたコンピュータで個人ライセンスから SolidNetWork ライセンスに切り替える場合は、クライアント コンピュータのインストレーションの変更を行い、SOLIDWORKS Installation Manager の実行時に個人ライセンスのシリアル番号の代わりに SolidNetWork ライセンスのシリアル番号を指定します。 詳細は、インストレーションの変更（Modifying an Installation）を参照してください。
管理イメージから SOLIDWORKS をインストールした場合、変更オプションは使用できません。 管理オプション エディタを使用して管理イメージを変更して、クライアントをアンインストールして、インストールを再実行する必要があります。
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）
関連タスク
インストレーションの変更（Modifying an Installation）


SolidNetWorkライセンスとアドイン製品の使用（Using SolidNetWork Licenses with Add-in Products）

SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品（たとえば、FeatureWorks、Workgroup PDM Server など）のライセンスを配布できます。

  • SOLIDWORKS ソフトウェアのライセンス数と SOLIDWORKS アドインのライセンス数が同じである必要はありません。
  • アドイン製品のライセンスをチェックアウトするには、最初に SOLIDWORKS のライセンスをチェックアウトする必要があります。
  • アドイン製品ライセンスを借りるには、SOLIDWORKS ソフトウェア ライセンスと、アドイン製品を含む SOLIDWORKS 製品ライセンスの両方を借りる必要があります。 デフォルトでは、SOLIDWORKS Standard ライセンスを借りますが、アドインを有効にするには、SOLIDWORKS Professional または SOLIDWORKS Premium 製品のライセンスを借りる必要があります。
  • アドイン製品ライセンスをリリースするには、以下を行います。
    • SOLIDWORKS で ツール (Tools) > アドイン (Add-ins) をクリックし、アドインを選択解除します。
    • SOLIDWORKS を終了します。
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


ライセンス マネージャーとアドミニストレーティブ イメージ インストレーションに向けた同じコンピュータの使用（Using the Same Computer for the License Manager and Administrative Image Installations）

ネットワーク上の 1 台のコンピュータが SolidNetWork ライセンスを配布するライセンス マネージャー、およびユーザーがそこから SOLIDWORKS ソフトウェアをインストールできるアドミニストレーティブ イメージの位置として両方の機能を果たすように設定することも可能です。

クライアント コンピュータはライセンス マネージャーからライセンスを入手し、次に同じコンピュータから SOLIDWORKS をインストールできます。

このコンフィギュレーションでは、同じコンピュータにライセンス マネージャーとアドミニストレーティブ イメージ の両方をインストールする必要があります。 最初にライセンス マネージャーのインストールを行い、次にアドミニストレーティブ イメージの作成と展開を行います。
詳細は次を参照してください：
  • License Managerのインストールとアクティベーション（Installing and Activating a License Manager）
  • 複数クライアントへの展開（Deploying to Multiple Clients）
親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


FLEXnet Publisherライセンス管理（FLEXnet Publisher License Management）

SolidNetWorkライセンスは、FLEXnet Publisher®ライセンス管理に基づいています。

FLEXnet Publisher ライセンス管理の詳細については、SolidNetWork License Manager インストレーション ディレクトリにある FLEXnet Publisher License Administration Guide（\Docs\flexuser\licensingenduserguide.pdf）を参照してください。

FLEXnet Publisher ライセンス管理の最新情報については、Acresso® Software までお問い合わせください。

親トピック
SolidNetWorkライセンス管理（SolidNetWork License Administration）


トラブルシューティング（Troubleshooting）

インストレーションの問題のトラブルシューティングに役立てるため、これらのトピックを参考にしてください。

目次

  • ネットワーク ライセンスの使用状況（Network License Usage）

  • SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

    SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

  • SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

    SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

  • SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

    SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

  • アップグレードのトラブル シューティング（Troubleshooting Upgrades）

    新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

  • インストール時またはアップグレード時にグラフィック カードを検証

    マシン上への SOLIDWORKS のインストールまたはアップグレードを完了すると、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認する必要があります。


ネットワーク ライセンスの使用状況（Network License Usage）

このダイアログ ボックスは、サーバーで製品のライセンスが不足している場合に開きます。

製品 ボックスの矢印をクリックし、選択可能なすべての製品を表示します。 製品の選択アイテムには、SOLIDWORKS、および購入可能なすべてのアドインが含まれています。

ライセンスの合計数は購入したライセンスの合計数です。

利用可能なライセンスは現在使用されていないライセンスです。

ライセンス使用者ボックスには、現在ライセンスを使用している各ユーザーに関する情報が表示されます。

親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証


SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）

SOLIDWORKS Installation Manager ログ ファイルを使用し、インストレーションの問題のトラブルシューティングに役立てられます。

これらのログ ファイルは、その他の SOLIDWORKS アプリケーションのログ ファイルと同じ場所にあります。
  • Windows 7 以降の場合:

    C:\Users\ユーザー名\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version

ログ ファイルのディレクトリを表示するには、Windowsのフォルダ オプションをすべてのファイルとフォルダを表示する（Show hidden files and folders）に設定する必要があるかもしれません。

アプリケーション データがC:以外のドライブにある場合は、これに応じて適切にディレクトリ パスを調整してください。

このディレクトリには、SOLIDWORKS Installation Manager プログレスの全般的なログである SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt ファイルがあります。

Other Logsサブディレクトリには、より詳細なインストレーション ログ情報が含まれています。

親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

SOLIDWORKS Installation Manager では、必要なインストレーション ファイルを指定フォルダにダウンロードできます。 このトピックには、ダウンロード フォルダに関するよくある質問（FAQ）とそれに対する回答が掲載されています。

Windows 8 以降を実行している場合、スタートまたはコントロール パネルへのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 詳細な説明およびオプション、特に Windows 8 以降のシステムに関する説明については、Microsoft Windows のドキュメントを参照してください。
質問 答え
このフォルダにあるファイルをインストールするには？

setup.exeを実行します。 以前ダウンロードされたことの無いアイテムをインストールするように選択した場合は、追加ファイルのダウンロードが必要な場合があります。

msiexecを使用してインストールしないでください（下記参照）。
msiexec や他のアプリケーションを使用して MSI ファイルをこのフォルダからマニュアルでインストールできますか?

いいえ。 Installation Manager では msiexec の実行に必要なファイルの一部がダウンロードされません。
各々のバージョンのインストールに同じダウンロード フォルダを選択して良いですか？

ダウンロード フォルダはバージョン固有のものです。 SOLIDWORKS 2010 を開始すると、SOLIDWORKS Installation Manager は指定されたフォルダ内にバージョン固有のサブフォルダを自動的に作成します。

一部の製品は Dassault Systèmes SOLIDWORKS Corporation Web サイトからダウンロードしてあります。 これらもInstallation Managerでインストールできますか?
SW2009 から、マニュアルでダウンロードしたファイルを SOLIDWORKS Installation Manager で使うことができます。 しかし、ファイルをダウンロードするオプションを選択して、SOLIDWORKS Installation Manager を実行するほうが適切です。 SOLIDWORKS Installation Manager は各ファイルをダウンロードするためにリンクを提供し、インストールしているものに基づいてどのファイルを必要とするかを表示します。 組み込みのダウンロードページが機能しないとき、このオプションを使用してください（プロキシ サーバーによって実施されたダウンロード制限などがあるときです）。
Microsoft Internet Explorer によってダウンロードまたはインストレーション中にファイルを保存するか、または実行するかを確認された場合は、必ず保存を指定してください。
ダウンロードしたファイルは他のユーザーと共有できますか?

Yes そのためには、共有ネットワーク上にダウンロードします。 続いて、各クライアントが共有ネットワークから SOLIDWORKS Installation Manager を実行し、インストールすることができます。

初期のダウンロードに含まれていないアイテムがユーザーによって選択されていない、またはダウンロードをインストールに使用するコンピュータがファイルをダウンロードするコンピュータとは異なる前提条件のセットを持っていない限り、追加のダウンロードは必要ありません。

インストールは行わず、他のユーザーのためにダウンロードを行う場合は、インストール時にダウンロードのみ（Download Only）オプションを選択します。 このオプションを選択すると、システム上にインストールされていない製品も選択することができます。 ただし、パッチをダウンロードする場合、アドミニストレーティブ イメージを作成する場合は、このオプションを使用することはできません。
いつ新しいバージョンの SOLIDWORKS を使用できるか知りたいのですが?
次の場合において、新しいバージョンが使用できるようになった際に通知を受けることができます。
  • [アップデート チェック (Check for Updates)] ( スタート > すべてのプログラム > SOLIDWORKS Installation Manager > アップデート チェック) を実行する場合
  • SOLIDWORKS バックグラウンド ダウンローダーを有効にした場合
  • Windows プログラムの追加と削除 でインストール済みバージョンの SOLIDWORKS を選択して、変更 をクリックした場合
  • ダウンロード フォルダで古いバージョンの Installation Manager（sldIM.exe）を実行した場合
これらの場合、新しいバージョンのダウンロードを選択することができます。 SOLIDWORKS Installation Manager は新しいバージョンの Installation Manager （インストレーション ファイルでは無く）をダウンロードし、実行します。 新しいバージョンの SOLIDWORKS Installation Manager が実行された後、インストレーションの詳細を指定することができます。 続いて、SOLIDWORKS Installation Manager によって必要なインストレーション ファイル（これまでにダウンロードされていないファイル）が確定され、これらのファイルをダウンロードするかどうかを尋ねられます。
SOLIDWORKS Installation Manager で別の製品の ServicePack のインストールを選択できないのはなぜですか。

それぞれのバージョンの SOLIDWORKS Installation Manager は、特定バージョンの SOLIDWORKS 製品のみをインストールするように設計されています。 別のバージョンの ServicePack をインストールするには、そのバージョンの SOLIDWORKS Installation Manager を実行する必要があります。 使用可能な最新バージョンを確認するには、前の項目を参照してください。
SOLIDWORKS Installation Manager によるファイルのダウンロードが妨げられるのはなぜですか。

プロキシ サーバーによってアプリケーションによるファイルのダウンロードが制限さていれる場合、SOLIDWORKS Installation Manager は自動的にファイルをダウンロードすることができません。

マニュアルでファイルをダウンロードして、次に SOLIDWORKS Installation Manager を使ってそれらをインストールすることができます。 個々のファイルをダウンロードするには SOLIDWORKS Installation Manager のオプションを選択します (たとえば、マニュアル ダウンロード実行 ページの ダウンロード オプション)。 製品選択とシステム必要条件に基づいて、マニュアルでダウンロードするすべての必要なファイルのリンクを含むWebページが、別のウィンドウに表示されます。 これらのリンクは SOLIDWORKS Customer Portal によって提供されたものとまったく同じです。しかしファイルを探す必要はありません。
一部の SOLIDWORKS 製品が最新の ServicePack バージョンまでアップデートされません。 アップデート チェックに最新バージョンであると示されるのはなぜですか。

アップデート チェックは最新バージョンの SOLIDWORKS Installation Manager がインストールされているか（あるいは実行されているか）のみを伝えてきます。

すべての製品を最新バージョンまでアップデートしたい場合は、プログラムの追加と削除 で、インストールされている SOLIDWORKS の最新バージョンを選択し、変更 をクリックしてください。

DVD をダウンロード フォルダにコピーして良いですか?

はい、しかし該当するプラットフォームにリリースされた各 DVD の全内容をコピーしない限り、インストレーションが失敗する場合があります。 SOLIDWORKS Installation Manager はバージョンを決定するためにファイル swdata*.id を探します。 これらのファイルが無い場合は、コピーした、ダウンロードが必要なインストレーション ファイルが認識されません。
親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）

SolidNetWork License Managerのインストレーションに失敗した場合は、これらの考えられる説明を確認してください。

親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）

SolidNetWorkライセンス ログ ファイルへのアクセス（Accessing the SolidNetWork License log files）

ライセンス エラーの原因は、ほとんどの場合、SNL_Manager_インストール_ディレクトリ\lmgrd.logファイルに表示されています。

SOLIDWORKS のライセンスを取得できない場合。 ライセンス サーバーに接続できない場合。(Cannot connect to license server.)

一般に、この問題はポートの設定によって生じます。

  • SolidNetWorkライセンス マネージャーとライセンス クライアントとで一致していないポート設定を使用している場合が考えられます。
  • 複数バージョンのSolidNetWorkライセンス マネージャーで必要な追加のポート設定が指定されていない場合が考えられます。
  • サーバー名が指定されている場合に、クライアント マシンがサーバーを正確に解決してサーバーにルートできることを確認します。 また、クライアント マシン名が指定されている場合に、サーバーがクライアントを正確に解決してクライアントにルートできることを確認します。
SolidNetWork ライセンス マネージャーとクライアントのポート設定に関する詳細については、SolidNetWork ライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）を参照してください。
関連概念
SolidNetWorkライセンスとファイアウォールの使用（Using SolidNetWork Licenses with Firewalls）


アップグレードのトラブル シューティング（Troubleshooting Upgrades）

新しい SOLIDWORKS リリースへのアップグレード中に問題が発生した場合は、これらの考えられる説明を確認してください。

親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
関連タスク
インストール時またはアップグレード時にグラフィック カードを検証
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）

移動されたソースからアップグレードする場合（Upgrading from a Source That Has Moved）

SOLIDWORKS がインストールされると、SOLIDWORKS Installation Manager はインストレーション ソース（ディスク メディア、ネットワーク上のディスク イメージなど）を記憶します。 更新する際、このソースがアクセス可能であることを前提とします。

ソースが移動/削除されている、あるいはソース メディアが変更されている場合、SOLIDWORKS Installation Manager はエラー メッセージを表示します。 しかし、必要なすべてのソース ファイルが同じフォルダ階層で移動されている場合は、そこまで参照し、アップグレードを続行できます。


インストール時またはアップグレード時にグラフィック カードを検証

マシン上への SOLIDWORKS のインストールまたはアップグレードを完了すると、SOLIDWORKS Rx を実行して、マシン上でサポート対象のグラフィック カードとグラフィック カード ドライバが実行されていることを確認する必要があります。

グラフィック カードとドライバを検証するには:

  1. Installation Manager がインストールを完了し、完了（Finish）ページが表示されたら、システムを確認（Check Your System）の下で、システム診断ツールの実行（Run System Diagnostics）をクリックします。

    SOLIDWORKS Rx が起動し、診断を実行します。

  2. SOLIDWORKS Rx は、グラフィック カードとグラフィック カード ドライバがサポートされているか確認します。 グラフィック カードがサポートされているが、ドライバがサポートされていない場合は、ステータス メッセージによってサポートされているドライバへのリンクが提供されます。

SOLIDWORKS を 10 回起動するごとに、システムを確認（Check Your System）メッセージが表示され、もう一度システム診断を実行するように推奨されます。 これらの通知を抑制するには、Windows 通知領域で SOLIDWORKS Resource Monitor を右クリックして、通知をオフに設定（Turn Off Notifications）をクリックします。

Windows 通知領域で SOLIDWORKS Resource Monitor を右クリックすることにより、任意の時点でグラフィック カードとドライバを検証できます。 ショートカット メニューを使用すると、次の作業を行うこともできます。
  • SOLIDWORKS Resource Monitor のヘルプを表示（Display Help）
  • システム診断ツールの実行
  • ｸﾞﾗﾌｨｯｸ ﾄﾞﾗｲﾊﾞｰの更新
親トピック
トラブルシューティング（Troubleshooting）
関連概念
SOLIDWORKS Installation Manager ログ ファイル（SOLIDWORKS Installation Manager Log Files）
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
SolidNetWorkライセンスのトラブルシューティング（Troubleshooting SolidNetWork Licenses）
アップグレードのトラブル シューティング（Troubleshooting Upgrades）
関連資料
ネットワーク ライセンスの使用状況（Network License Usage）


SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品をインストール/更新する、スタンドアロン アプリケーションです。

SOLIDWORKS Installation Manager は、次のように実行することができます:
  • SOLIDWORKS DVD、共有ソース、またはダウンロード フォルダ（新規バージョンのインストール時）
  • コントロール パネルのプログラムの追加と削除ページ（既存のバージョンの変更または削除時）から
  • スケジュールまたはマニュアルによるアップデート チェック（新規リリース バージョンの検出、ダウンロード、インストール時）を介して

各バージョンの SOLIDWORKS には、そのバージョン特有の SOLIDWORKS Installation Manager があります。

SOLIDWORKS 2008 より前のバージョンでは、SOLIDWORKS 2007 の Installation Manager を使用してください。または、SOLIDWORKS サポート ウェブ サイトからマニュアルで製品バージョンをダウンロードしてください。
Windows 8 を実行している場合、スタート または コントロール パネル へのアクセスなどのタスクについては、Microsoft Windows 8 で SOLIDWORKS を使用する際のヒントを参照してください。 これらのステップは、システムでの Windows 8 の構成方法によって異なります。 詳細な説明およびオプション、特に Windows 8 以降のシステムに関する説明については、Microsoft Windows のドキュメントを参照してください。

目次

  • SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

    SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。

  • アップデート チェックの結果（Check for Updates Results）

    アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

  • アドミニストレーティブ イメージ位置（Administrative Image Location）

    アドミニストレーティブ イメージのインストール場所を指定します。

  • ダウンロード オプション（Download Options）

    ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

  • SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

    より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

  • 製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

    指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

  • ダウンロードの進捗状況（Download Progress）

    このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

  • ダウンロード結果（Download Results）

    ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

  • インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

    インストレーションでエラーが発生し、キャンセルされました。

  • インストレーション完了（Installation Is Complete）

    SOLIDWORKS Installation Manager は、その処理を完了しました。

  • インストール先（Installation Location）

    SOLIDWORKS のインストール先を指定します。

  • 更新オプション（Upgrade Options）

    現在、このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 最も新しい既存のバージョンを新しいバージョンにアップグレードするか、または新しいバージョンのために新しいインストレーションを作成するかを選択します。

  • インストールの進行状況（Installation Progress）

    この画面にはインストレーションの進捗状況が表示されます。

  • インストレーション タイプ（Installation Type）

    新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。

  • 複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

    SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

  • マニュアル ダウンロード（Manual Download）

    ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

  • 利用可能なより新しいバージョン（Newer Version Available）

    Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

  • 利用可能な新しいバージョンはありません（No New Versions Available）

    ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

  • 検出されたプロセス（Processes Detected）

    SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • 製品選択（Product Selection）

    インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。

  • ダウンロードする製品（Products to Download）

    指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

  • 修復する製品（Products to Repair）

    このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

  • シリアル番号（Serial Numbers）

    シリアル番号 (パッケージ上にあります) は、購入した SOLIDWORKS 製品をご使用のコンピュータに関連付けます。

  • サーバー インストール（Server Installation）

    インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

  • SolidNetWork License Manager

    SolidNetWork License Managerサーバー製品のインストール オプションを指定します。

  • サマリー（Summary）

    SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

  • システム チェックの警告（System Check Warnings）

    システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

  • 穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

    SOLIDWORKS Toolbox がインストールされている場合、SOLIDWORKS は穴タイプと汎用部品の標準ライブラリを含みます。

  • 製品のアンインストール（Uninstall Products）

    削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

  • Workgroup PDM Serverオプション（Workgroup PDM Server Options）

    SOLIDWORKS Workgroup PDM サーバー製品のインストール オプションを指定します。

関連概念
Microsoft Windows 8 で SOLIDWORKS を使用する際のヒント


SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）

SOLIDWORKS バックグラウンド ダウンローダーは、新しいサービス パックが見つかった場合等に、バックグラウンド プロセスを用いてファイルのダウンロードを自動的に行います。これにより、ダウンロード中にも他の作業を継続することが可能となります。 ダウンロードが完了すると、直ちにインストールするか、ダウンロードを延期するか、あるいはダウンロードを削除するかが質問されます。

バックグラウンド ダウンローダーは、SOLIDWORKS のインストール時にデフォルトで有効になります。

インストールやダウンロードのために Installation Manager を実行している間は、バックグラウンド ダウンローダーは一時停止します。 たとえば、実行中のダウンロードを一時停止し、新たなダウンロードの開始やダウンロード フォルダ指定の変更等を禁止します。

サマリー ページで [ダウンロード オプション (Download Options)] を変更することにより、インストール中にバックグラウンド ダウンローダーを無効にできます。 (バックグラウンド ダウンローダーを使用しますか? (Do you want to use the Background Downloader?) オプションを選択解除します。)

有効な場合には、Windowsのシステム トレイに次のアイコンが表示されます：

このアイコンをクリックすると、次のオプションが有効になります：
  • バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）
  • ダウンロード一時停止（Pause Download）
  • ダウンロード再開（Resume Download）
  • ダウンロード キャンセル（Cancel Download）
  • インストレーション オプション（Installation Options）
  • ダウンロード先の変更（Change Download Location）
  • アップデート チェック（Check for Updates）
  • アップデートを自動的にチェック（Automatically Check for Updates）
  • アップデート自動ダウンロード（Automatically Download Updates）
  • バックグラウンド ダウンローダー無効化（Disable Background Downloader）

バックグラウンド ダウンローダー ヘルプ（Help with Background Downloader）

SOLIDWORKS インストレーション ガイド（SOLIDWORKS Installation Guide）内のバックグラウンド ダウンローダーに対する本ヘルプ トピックを開きます。

ダウンロード一時停止/再開（Pause/Resume Download）

バックグラウンドでダウンロードを実行している場合は、ダウンロード一時停止（Pause Download）のクリックによりダウンロードの一時停止が行えます。このダウンロードはダウンロード再開（Resume Download）のクリックにより再開できます。

ダウンロード キャンセル（Cancel Download）

実行中のダウンロードを停止し、バックグラウンド ダウンローダーがダウンロードしたすべてのファイルを削除します。
キャンセルしたダウンロードは再開できません。

インストレーション オプション（Installation Options）

ダウンロードが完了したら、次のオプションが選択できます：
  • 今すぐインストール（Install now）：ダウンロードしたファイルをインストールします。
  • 後で通知（Remind me later）：ダウンロードしたファイルをインストールせず、後から実行を促すための通知メッセージを設定します。
  • このダウンロードﾞを削除（Delete this download）：ダウンロードしたファイルをインストールせずに削除します。（本機能は、ダウンロードしたファイルのインストールが無用となった場合に有効です。）

ダウンロード先の変更（Change Download Location）

バックグラウンド ダウンローダーによるファイルのダウンロード先を変更します。

ダウンロードの実行中や一時停止中には、本オプションは利用できません。

アップデート チェック（Check for Updates）

SOLIDWORKS Installation Manager の アップデート チェック (Check for Updates) 機能を実行します。

アップデートを自動的にチェック（Automatically Check for Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には通知します。

アップデート自動ダウンロード（Automatically Download Updates）

アップデート チェック（Check for Updates）を定期的に実行し、アップデートがダウンロード可能な場合には、それらをダウンロードします。

SOLIDWORKS バックグラウンド ダウンローダーの無効化と再有効化（Disabling and Re-Enabling SOLIDWORKS Background Downloader）

アイコンをクリックし、バックグラウンド ダウンローダー無効化（Disable Background Downloading）を選択することにより、バックグラウンド ダウンローダーを無効にすることが可能です。

バックグラウンド ダウンローダーを再度有効にするには、スタート (Start) > すべてのプログラム (All Programs) > SOLIDWORKS Installation Manager > SOLIDWORKS バックグラウンド ダウンローダー (SOLIDWORKS Background Downloader) をクリックします。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アップデート チェックの結果（Check for Updates Results）

アップデート チェックは、SOLIDWORKS の最新バージョンを探します。

アップデート チェックは、マニュアルで実行できます。
  • Windows で スタート > プログラム > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) をクリックします。
  • SOLIDWORKS で ヘルプ (Help) > アップデート チェック (Check for Updates) をクリックします。
アップデート チェックは、アドミニストレーティブ イメージからインストールしたクライアントでは利用できません。

利用可能なより新しいバージョン（Newer Version Available）

SOLIDWORKS Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 より新しいバージョンの SOLIDWORKS Installation Manager を選択することで、新しいバージョンに更新できます。

より新しいバージョンでは、インストレーションで指定した製品に基づいてインストレーション ファイルをダウンロードできます。 ダウンロードしたファイルは SOLIDWORKS Installation Manager を使用してインストールを行う他のユーザーと共有することができます。

これらのダウンロードは、SOLIDWORKS Installation Manager のみで利用できます。
次のオプションを利用できます。
  • 複数のバージョンが利用可能な場合、リストから選択できます。
  • このバージョンの詳細については、アップグレードに含まれるアイテムのチェック（Check to see what this upgrade includes）をクリックします。
次へ (Next) をクリックすると、選択したバージョンの SOLIDWORKS Installation Manager を入手して実行します。

利用可能な新しいダウンロードはありません/新しいバージョンをチェックすることができません（No New Downloads Available/Unable to Check for New Versions）

SOLIDWORKS Installation Manager は SOLIDWORKS 製品の新しいバージョンを見つけられません。これは、利用可能な最新のバージョンがインストール済みであるか、または SOLIDWORKS のサイトに接続してチェックできなかったかのどちらかです。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


アドミニストレーティブ イメージ位置（Administrative Image Location）

アドミニストレーティブ イメージのインストール場所を指定します。

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。 アドミニストレーティブ イメージは、クライアント向けに共有可能なフォルダにある必要があります。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプション（Download Options）を参照してください。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード オプション（Download Options）

ダウンロード ファイルの場所、ファイルをダウンロードする方法、ダウンロード ファイルをインストールするかどうかなど、ダウンロード処理を完了するための詳細を指定します。

SOLIDWORKS Installation Manager は 電子ソフトウェア配布 (ESD) をサポートします。 SOLIDWORKS DVD からインストールしない場合は、インストールする SOLIDWORKS 製品のソースを指定する必要があります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

何を行いますか?（What do you want to do?）

次のいずれかを選択します。

ダウンロードとインストール/ダウンロードとイメージ作成

ダウンロードの完了後、SOLIDWORKS Installation Manager はダウンロード ファイルを使用してインストレーションを実行します。

ダウンロードのみ。 ダウンロードを 1 度行い、ダウンロード ファイルを複数コンピュータで共有できます。

SOLIDWORKS Installation Manager はダウンロードの完了後にインストレーションを実行しません。

通常、このオプションは複数のコンピュータ間で共有するインストレーション ファイル セットを構成するためにファイルをダウンロードする場合のみに指定します。

このオプションを指定すると、ダウンロードする 2 つのファイル セットからの選択を求められます。
  • 当コンピュータ用のファイル: ダウンロードには、現在コンピュータ上にあるインストレーション ファイル セットにないファイルのみが含められます。
    このダウンロードには以下が含まれるため、そのサイズは小さくなるはずです。
    • 製品選択ページで選択した製品のファイルのみ
    • コンピュータに必要な未インストールの前提条件ファイルのみ

    しかし、このダウンロード ファイル セットを別のコンピュータで使用してインストレーションを実行しようとすると、いくつかのファイルが見つからないかもしれません（なぜなら、別のコンピュータ上のインストレーション ファイル セットがこのコンピュータのものと異なる可能性があるからです）。 このダウンロード ファイルを使用して別のコンピュータへインストールすることは可能ですが、インストレーションの実行時に追加のファイルをダウンロードし、そのコンピュータのインストレーション ファイル セットを完全にする必要があるかもしれません。

  • 任意のコンピュータで共有できるファイル: ダウンロードには、このバージョンを任意のコンピュータにインストールするために使用できる完全なインストレーション ファイル セットが含まれます。

    このダウンロードには、このバージョンの任意の製品を任意のコンピュータにインストールするために使用できる完全なファイル セットが含まれているため、そのサイズは大きくなります。

    限られた製品セットをダウンロードするように指定している場合、このオプションはその指定を無視して製品リリースに含まれるすべての製品をダウンロードします。

    ダウンロードには、個人インストレーションを実行するために必要となるファイルだけでなく、アドミニストレーティブ イメージを作成するために必要となるすべてのファイルが含まれます。

インストールのみ/イメージ作成のみ。 必要なインストレーション ファイルは既にすべて持っています。

SOLIDWORKS Installation Manager はファイルをいっさいダウンロードしないで、選択したディレクトリにあるファイルを使用します。

参照をクリックし、別の場所に移動します。 例えば、その場所に必要なファイルがすべて含まれている場合は、インストレーション DVD またはダウンロード フォルダまで参照します。

すべてのインストレーション ファイルがその場所にあると思われたのに、フォルダーが不完全であるとするメッセージが表示される場合は、以下が考えられます。
  • 前にダウンロードされなかったインストーレーションのコンポーネントを選択したか、またはそのコンポーネントがデフォルトで選択された。
  • ファイルはシステム必要条件の異なる設定で別のコンピュータにダウンロードされた。
  • 以前はクライアント インストレーションを実行しており、今回は多くのファイル セットが必要となるアドミニストレーティブ イメージを作成している。

すべてのファイルを含むフォルダ（例えば、DVD）まで参照するか、またはダウンロード オプションのいずれかを選択できます。

必要なファイルをどこにダウンロードしますか?（Where do you want to download the required files?）

これは、ダウンロード フォルダーの場所です。

場合によっては、このオプションが無効になった状態で表示されることもあります。 たとえば、インストールのみ (Install only) を指定した場合、SOLIDWORKS Installation Manager は個別のダウンロード フォルダを使用するのではなく、そのオプションに対して指定されたディレクトリのダウンロード ファイルをインストールします。

これらのファイルをダウンロードする場合、あるいは独自の位置からアクセスしている場合でも、すべてのファイルを同じダウンロード フォルダーにダウンロードする必要があります。

推定ダウンロード サイズ（Estimated download size）

推定ダウンロードの必要なディスク スペースは、これが新規のダウンロードであるか、または前のセッションからのダウンロードを再開しているかどうかにかかわらず、選択された完全なコンポーネント リストに基づいています。

たとえば、もし前回のダウンロードを再開している場合、SOLIDWORKS Installation Manager はダウンロードされなかったファイルだけを処理します。 ダウンロード時間は推定より短くなる可能性があります。

前回のダウンロードでファイルのダウンロードが完了している場合も、そのサイズは推定に含められません。したがって、推定は実際のダウンロード サイズよりも大きい可能性があります。

どのようにダウンロードしますか?（How do you want to download?）

2つのオプションがあります。
マニュアル ダウンロード実行 | 場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。 | このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。 この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。
ネットワークの高帯域幅を使用してダウンロード速度を向上 | ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。 場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。 このオプションは自動ダウンロードのみに適用されます。マニュアル ダウンロードには影響しません。

SOLIDWORKS バックグラウンド ダウンローダーの使用

ダウンロード処理の完全実行や、SOLIDWORKS のサービスパックがリリースされた際のダウンロードには、SOLIDWORKS バックグラウンド ダウンローダーを使用できます。

SolidWorksバックグラウンド ダウンローダーでは、新しいサービスパックの検出とダウンロードをバンクグラウンドで実行することが可能です。ダウンロードが完了し、ファイルのインストール準備が整うと、その内容が通知されます。 詳細は、SOLIDWORKS バックグラウンド ダウンローダー（SOLIDWORKS Background Downloader）を参照してください。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SOLIDWORKS Installation Manager ファイルのダウンロード オプション (Download Options for SOLIDWORKS Installation Manager Files)

より新しいバージョンの SOLIDWORKS Installation Manager をダウンロードします。 この画面で、ファイルをどこからどのようにダウンロードするかを指定します。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。

この画面はデフォルトのダウンロード フォルダーに問題がある場合のみに表示されます（例えば、書き込みアクセスまたはネットワーク アクセスを利用できない場合など）。通常、続行するには代替のダウンロード ディレクトリをただ指定するだけです。

ダウンロード ディレクトリ（Download Directory）

SOLIDWORKS Installation Manager ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード アクセラレータを使用（Use Download Acceleration）

このオプションを選択した場合、ダウンロード速度を速くするためのアルゴリズムが使用されます。

ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になります。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品のインストレーション ファイルをダウンロード（Download Product Installation Files）

指定された製品の欠けているファイルをどこで、どのように、ダウンロードするべきか指定してください。

SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

このスクリーンをキャンセルすると、残りのインストレーション シーケンスもキャンセルされます。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラー（Installation Errors）を参照してください。

ダウンロード ディレクトリ（Download Directory）

ダウンロード ファイルの保存先まで参照します。

ダウンロード サイズと必要とされるスペースが表示されます。必要とされるスペースはある特定のダウンロードを圧縮解除するために必要とされる余分のスペースを含み、実際のダウンロードの大きさより大きくなります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダを参照してください。

ダウンロード オプション（Download Options）

SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）

ネットワークの高帯域幅を使用してダウンロード速度を向上

ダウンローダーは、ダウンロード中に使用するネットワークの帯域幅を増やしてダウンロード速度を増加させるアルゴリズムを使用しています。

場合によって、これはネットワーク パフォーマンスを低下させる可能性があります。ダウンロード中にトラブルが発生する場合、このオプションがプロキシ サーバーでサポートされていない可能性もあります。オプションを解除して、再びダウンロードを行ってください。詳細については、ネットワーク管理者に確認してください。
ダウンロード アクセラレータは、帯域幅を増やし、ネットワーク パフォーマンスを妨げる場合があります。ダウンロード アクセラレータを有効にする前に、ネットワーク管理者に確認してください。

ダウンロード アクセラレータがプロキシ サーバーでサポートされていない場合、このオプションは自動的に無効になる場合もあります。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）
関連資料
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）


ダウンロードの進捗状況（Download Progress）

このプロセスで、SOLIDWORKS Installation Manager はすべてのファイルのダウンロード、検証、抽出を同時に行います。

ダウンロードを実行中にキャンセルするにはキャンセルをクリックします。

ダウンロードをキャンセルするかまたはダウンロードに失敗すると、ダウンロード中止（Download Canceled）またはダウンロードの問題（Download Problem）画面にどのダウンロードが完了されていないかが表示され、ダウンロードを再開するかまたはアプリケーションを終了できるようになります。

ダウンロード フォルダに関する質問の答えについては、SOLIDWORKS Installation Manager ダウンロード フォルダ（SOLIDWORKS Installation Manager Download Folder）を参照してください。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


ダウンロード結果（Download Results）

ダウンロードが正常に終了したか、処理中に失敗したか、または中止されたかを示します。

ダウンロードの問題/ダウンロード中止（Download Problem/Download Cancelled）

ダウンロードの問題 は、SOLIDWORKS Installation Manager がダウンロードの完了を妨げる問題と遭遇した場合に表示されます。

ダウンロード中止（Download Cancelled）は、ユーザーがダウンロードが完了する前に中止した場合に表示されます。

続行するには、以下を行います。

自動ダウンロードの再試行/再開 | 中止した時点から自動ダウンロードを再開するには、このオプションを選択してダウンロードを再試行（Retry Download）またはダウンロードを再開（Resume Download）をクリックします。
Webブラウザで個々のファイルをダウンロード | 場合によっては、プロキシ サーバーによって SOLIDWORKS Installation Manager からの自動ダウンロードが禁止されていることもあります。 | このオプションを選択することで、Web ページからファイルをマニュアルでダウンロードしてから SOLIDWORKS Installation Manager を続行し、インストレーション動作を完了できます。 この Web ページは、インストレーションの完了に必要なファイルのみがダウンロードされるように SOLIDWORKS Installation Manager によってユーザー定義されます。

ダウンロード完了（Download Complete）

ダウンロード完了画面は、ダウンロードのみ（Download Only）オプションを指定した場合にダウンロードが完了すると表示されます。

終了 (Finish) をクリックし、SOLIDWORKS Installation Manager を終了します。

これらの製品のマニュアル インストールは試みないでください。 必ず SOLIDWORKS Installation Manager を使用してダウンロードしたファイルをインストールしてください。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）

インストレーションでエラーが発生し、キャンセルされました。

エラーまたはキャンセルが発生した場合は:
  • エラーまたはキャンセルが発生する前にインストールされた製品はコンピュータに残ります。
  • エラーまたはキャンセルが発生した際にインストールされていた製品は、可能な場合はロールバックされ、部分的なインストレーションが残らないようにします。
  • 残りの製品はインストールされないか、またはアンインストールされます。まだ実行されていません（Not Yet Attempted）の下にリストが表示されます。

    これらの製品をインストールを再開するか、またはアンインストールするには、表示されたリンクをクリックします。

SOLIDWORKS Installation Manager はまずコンピュータにインストールされていない前提条件 (たとえば .NET Framework など) をインストールします。

目次

  • 失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）

    インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。

  • インストールの修復（Repairing an Installation）

    もしインストールされた SOLIDWORKS 製品の問題があるならば、SOLIDWORKS インストール マネージャーをインストールを修復するために使うことができます。

  • 代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

    インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager のログ ファイルを Zip 圧縮して提供する必要がある場合もあります。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）

インストレーション中にエラーまたはキャンセルが発生した場合は、インストレーションを再び実行することでその時点から回復できます。

  1. インストレーションが失敗した場合は、インストレーション エラー（Installation Errors）およびインストレーションのキャンセル（Installation Cancelled）画面に表示されるエラー メッセージと製品コード番号を記録してください。

    既存の SOLIDWORKS インストレーションを変更していないときにソース ファイルに対するプロンプトが表示される場合は、インストレーションまたはコンピュータが破損している可能性があります。 お客様の代理店までご連絡ください。

  2. コンピューターを再起動します。
  3. SOLIDWORKS 製品が実行されていないことを確認するために、Windows で Ctr+Alt+Del キーを押してタスク マネージャーを開きます。
  4. プロセス タブで、次のいずれかのプロセスが イメージ名 に表示される場合、選択して プロセスの終了 をクリックします。

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. アプリケーションが既にインストールされており、変更/削除する場合は、インストレーションの修復を試みます。 詳細は インストールの修復(Repairing an Installation)を参照してください。
  6. Windows 7 以降では、スタート > コントロール パネル >プログラムと機能 をクリックします。 前のバージョンの Windows では、スタート > コントロール パネル > アプリケーションの追加と削除 をクリックします。
  7. 失敗したバージョンの SOLIDWORKS を選択します。

    インストールする SOLIDWORKS のバージョンが表示されない場合は、インストレーション プロセスを繰り返してください。

  8. 次のいずれかを行います：
    • 再試行するには、変更 （Change）をクリックし、インストールに失敗した、あるいはインストレーション中にスキップされたすべての製品を選択します。

    • 失敗したインストレーションをスキップするには、変更 （Change）をクリックし、インストレーション中にスキップされたすべての製品を選択します。 インストールに失敗した製品を選択解除します。

    • インストレーションを中止するには、削除 （Remove）をクリックし、インストールされたすべての製品を選択します。

    このプロセスでは、アップグレードしていた製品の前バージョンまでは回復されません。

親トピック
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連タスク
インストールの修復（Repairing an Installation）
代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）


代理店までご連絡する場合（Contacting the SOLIDWORKS Reseller）

インストレーションの変更/修復に失敗した場合は、この画面に表示される情報をお客様の SOLIDWORKS 代理店までご連絡ください。 SOLIDWORKS Installation Manager のログ ファイルを Zip 圧縮して提供する必要がある場合もあります。

  1. ログ ファイルを探します：
    • Windows 7 以降の場合:

      C:\Users\ユーザー名\AppData\Roaming\SOLIDWORKS\Installation Logs\installed_version\

    フォルダーが見つからない場合は、隠しフォルダーになっている場合があります。Windowsエクスプローラでツール > フォルダ オプションをクリックします。表示（View）タブの詳細設定（Advanced Settings）で、ファイルとフォルダの表示（Hidden files and folders）ですべてのファイルとフォルダを表示する（Show hidden files and folders）を選択します。

  2. サブフォルダーを含め、このフォルダーのすべてのコンテンツをZip圧縮します。
親トピック
インストレーション エラー/インストールのキャンセル（Installation Errors / Installation Cancelled）
関連タスク
失敗またはキャンセルされたインストレーションから回復（Recovering from a Failed or Cancelled Installation）
インストールの修復（Repairing an Installation）


インストレーション完了（Installation Is Complete）

SOLIDWORKS Installation Manager は、その処理を完了しました。

以下の1つまたは複数のオプションが表示されるかもしれません。

新規機能（What's New）

個人インストレーションの場合は、インストレーション手順を完了した際に、SOLIDWORKS とアドイン製品の新規機能を説明するドキュメントが表示されます。

アドミニストレーティブ イメージ インストレーションの場合は、クライアントがインストレーションを完了した際に、クライアントのコンピュータ上にドキュメントが表示されます。

アンケート（Survey）

インストレーション プロセスに関する短いアンケートにご協力ください。

SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム (Join the SOLIDWORKS Customer Experience Improvement Program)

製品改善を支援するため、パフォーマンス インフォメーションが SOLIDWORKS Corporation に送られます。 このプロセスでは透明性と機密情報が確保されます。 次のいずれかを選択します:
  • はい、参加します
  • いいえ、参加しません
  • 後で通知
詳細は、Customer Experience Improvement Program Web サイト を参照してください。

アドミニストレーティブ イメージの作成が完了しました（Administrative Image Creation Is Complete）

アドミニストレーティブ イメージの作成が完了したら、イメージのカスタマイズ（Customize Image）をクリックすることによりアドミニストレーティブ イメージ オプション エディタを起動し、イメージをカスタマイズすることが可能です。

オプション エディタの使用方法を表示するには、クライアントにイメージをインストールする方法を表示します。（Show me how to install this image on a client.）をクリックしてください。

オプション エディタを使用してアドミニストレーティブ イメージを設定する方法の詳細については、アドミニストレーティブ イメージ オプション エディタを参照してください。

アドミニストレーティブ イメージ オプション エディタを起動し、アドミニストレーティブ イメージに対するオプション設定をカスタマイズするには、イメージのカスタマイズ（Customize Image）をクリックします。
オプション エディタは、アドミニストレーティブ イメージのインストール ディレクトリにあるsldAdminOptionEditor.exeをダブルクリックにより、後から起動することも可能です。

目次

  • SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

    SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  • SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

    SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連資料
アドミニストレーティブ イメージ オプション エディタ（Administrative Image Option Editor）


SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）

SOLIDWORKS Installation Manager を使用し、マニュアルでアップデートをチェックするか、またはアップデートの定期的な自動チェックを設定できます。

  1. 次のいずれかを実行して SOLIDWORKS Installation Manager を開始します:

    • SOLIDWORKS アプリケーションで、ヘルプ (Help) > アップデート チェック (Check for Updates) をクリックします。

    • Windows でスタート (Start) > プログラム (Programs) > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) をクリックします。

    SOLIDWORKS Installation Manager は利用できるアップデートがあるかどうかを通知します。

  2. 利用できるアップデートがある場合は、ダウンロードしてインストールするかどうかを選びます。
  3. 定期的な自動アップデート チェックを有効にするには、SOLIDWORKS Installation Manager がそのプロセスを完了したときに ___日毎に更新をチェックします (Check for Updates every __ days) を選択し、チェックの頻度を指定します。
親トピック
インストレーション完了（Installation Is Complete）
関連概念
SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）


SOLIDWORKS ユーザー パフォーマンス フィードバック プログラム（SOLIDWORKS Customer Experience Improvement Program）

SOLIDWORKS のインストール時には、SOLIDWORKS Corporation にパフォーマンス情報を送信し製品改良に役立てることが選べます。

SOLIDWORKS はこの情報を製品の使用と品質の評価の傾向を確定するために使用します。 パフォーマンス ログは、最も高品質な製品を提供するために役立ちます。

このプロセスでは透明性が確保されています。ログ ファイルに含まれるすべての情報は機密情報として扱われます。その他の目的で使用されることは無く、お客様に連絡が入ることもありません。

詳細については、Customer Experience Improvement Program Web サイトを参照してください。

親トピック
インストレーション完了（Installation Is Complete）
関連タスク
SOLIDWORKS に対するアップデート チェック（Checking for Updates to SOLIDWORKS）


インストール先（Installation Location）

SOLIDWORKS のインストール先を指定します。

アドミニストレーティブ イメージの作成を除いて、インストレーションには以下のオプションが適用されます。
選択製品を次へインストールします | これは、SOLIDWORKS をインストールするディレクトリの場所です。 インストレーションのアップグレードまたは変更時には、すべてのファイルをそのインストレーションの既存の場所にインストールする必要があります。 この場合、既存の SOLIDWORKS インストレーションの場所は変更できません。
インストレーションに必要なスペースの推定サイズ | これは、インストレーションまたは変更のために選択された製品に対して必要となる追加スペースです。 | インストール先のディスクにインストレーションの要件をサポートするのに十分な空きスペースがあることを確認してください。
インストール元 | これは、SOLIDWORKS のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプションを参照してください。
どちらの SOLIDWORKS インストール位置についても変更する前に、システム管理者に相談してください。

アドミニストレーティブ イメージの位置（Administrative Image Locations）

アドミニストレーティブ イメージの作成時は、以下のオプションが適用されます。
新規イメージ位置 | これは、SOLIDWORKS Installation Manager が新規イメージを作成するディレクトリ位置です。 | この位置には、既存のアドミニストレーティブ イメージを含められません。
イメージ作成に必要なスペースの推定サイズ | これは、アドミニストレーティブ イメージに必要となる追加スペースです。 | インストール先のディスクにイメージの要件をサポートするのに十分な空きスペースがあることを確認してください。
イメージ作成元 | これは、SOLIDWORKS 製品のインストール元となるディレクトリ位置です。 このオプションは、インストールのみ（Install Only）オプションを指定した場合のみに表示されます。 詳細は、ダウンロード オプションを参照してください。
既存イメージ位置 | 既存のアドミニストレーティブ イメージをアップグレードするとき、SOLIDWORKS Installation Manager は既存のイメージの設定に基づいて新規イメージを作成します。 この既存のイメージは変更されません。 これは、ようこそ 画面で指定した元のイメージの場所を示します。

特定のバージョンのディレクトリ パスの使用回避（Avoid Using Version-Specific Directory Paths)

インストレーション ディレクトリの位置にバージョン番号を指定してから（たとえば、C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2015\）このインストレーションを SOLIDWORKS 2016 にアップグレードすると、SOLIDWORKS 2016 のインストレーション ディレクトリに SOLIDWORKS 2015 というラベルが付きます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連資料
ダウンロード オプション（Download Options）


更新オプション（Upgrade Options）

現在、このコンピュータには 1 つまたは複数の古い SOLIDWORKS メジャー バージョンがインストールされています。 最も新しい既存のバージョンを新しいバージョンにアップグレードするか、または新しいバージョンのために新しいインストレーションを作成するかを選択します。

この選択は、このメジャー リリースの以前のバージョンがコンピュータにインストールされていない場合のみ表示されます。 このメジャー リリースの以前のバージョンがインストールされている場合、SOLIDWORKS Installation Manager は必ずそのインストレーションをアップデートします。

(SOLIDWORKS 2010 以降、同じメジャー リリースの複数の ServicePack のパラレル インストレーションはサポートされなくなりました)。

アップグレード時には、以下が行われます。
  • 指定したすべての製品がアップグレードされます。
  • インストール済みのすべての製品がデフォルトで選択されます。
  • 製品を選択解除すると、その製品はアップグレードされません。
    製品コンポーネントを選択解除しても、そのコンポーネントを削除するように SOLIDWORKS Installation Manager に指定したわけではありません。 製品コンポーネントを削除するには、プログラムの追加と削除 (Add/Remove Programs) を使用します。 詳細は、インストレーションの削除を参照してください。

適切なオプションを選択し、次へ（Next）をクリックして続行します。

SOLIDWORKS version の新しいインストレーションを作成します。

このオプションを選択すると、このメジャー バージョンの新しいインストレーションが作成されるほか、古いメジャー バージョン インストレーションが保持されます。

これは、新しいバージョンのインストール後も インストレーションの削除 の古いバージョンにアクセスしたい場合に役立ちます。 たとえば、古いバージョンを実行し続けている他のユーザーとファイルを共有する場合、新しいバージョンを使用して保存したファイルのバージョンの互換性の問題を回避できます。

SOLIDWORKS previous_major_version から SOLIDWORKS current_major_version へアップグレードします。

このオプションを選択すると、古いバージョンのインストレーションが新しいバージョンにアップグレードされます。
インストレーションの完了後、古い SOLIDWORKS バージョンはこのコンピュータで利用できなくなります。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連タスク
インストレーションの削除（Removing an Installation）


インストールの進行状況（Installation Progress）

この画面にはインストレーションの進捗状況が表示されます。

インストレーションの開始後にキャンセルするには、キャンセル（Cancel）をクリックします。

キャンセルの影響や、中断されたインストレーションを完了するための手順は、インストレーション エラーを参照してください。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


インストレーション タイプ（Installation Type）

新規インストレーションの作成、既存インストレーションの変更または修復、アドミニストレーティブ イメージの作成、アドミニストレーティブ サーバー製品のインストール、インストールを伴わないファイルのダウンロードなど、実行するインストール動作を指定します。

個人（Individual）

SOLIDWORKS 製品をこのコンピュータへインストールします。

このオプションは、このバージョンがコンピュータにインストールされていない場合のみに表示されます。

個人インストレーションの変更（Modify the individual installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で変更します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
変更には以下が含まれます。
  • SOLIDWORKS 製品コンポーネントの追加または削除
  • 異なる SOLIDWORKS パッケージへの変更 (たとえば、SOLIDWORKS Professional、SOLIDWORKS Premium など)
  • SOLIDWORKS シリアル番号設定の変更
    前回のインストレーションで SOLIDWORKS シリアル番号を既に指定している場合、SOLIDWORKS Installation Manager ではシリアル番号の指定を求められないことがあります。 SOLIDWORKS Installation Manager によって仮定されたシリアル番号を変更するには、このオプションを選択する必要があります。

個人インストレーションの修復（Repair the individual installation）

既存の SOLIDWORKS インストレーションをこのコンピュータ上で修復します。

このオプションは、このバージョンがコンピュータにインストールされている場合のみに表示されます。
修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。
個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを使用して再インストールする必要があります。

アドミニストレーティブ イメージ（Administrative image）

このコンピュータでアドミニストレーティブ イメージの作成または更新を行います。

アドミニストレーティブ イメージを使用し、複数のコンピュータにインストールできます。 アドミニストレーティブ イメージを使用して複数のクライアントに SOLIDWORKS をインストールする方法については、アドミニストレーティブ イメージの使用を参照してください。

アドミニストレーティブ イメージを作成またはアップデートするときは、以下を行えます。
  • 既存イメージのインストレーション設定を使用し、新規またはアップデートされたイメージを設定するか、デフォルトの SOLIDWORKS インストレーション設定を使用できます。
  • 既存のイメージをアップデートする場合:
    • アップデートする場合も、SOLIDWORKS Installation Manager はイメージの新規コピーを作成します。 元のイメージは変更されません。
    • アップデートする既存のイメージのファイルを使用し、アップデートされたイメージを作成できます。この結果、ダウンロード サイズが小さくなります。
    以前のイメージをアップデートするためにServicePackリリースを利用できるイメージを指定しなかった場合、サイズの小さいダウンロードを利用することはできません。

サーバー製品（Server products）

SOLIDWORKS アドミニストレーティブ サーバー製品には、SOLIDWORKS Electrical、SOLIDWORKS Workgroup PDM Server （Vault）、SOLIDWORKS PDM、および SolidNetWork License Manager が含まれます。

SOLIDWORKS Electrical と SOLIDWORKS PDM については、クライアント ツールとサーバー ツールを同じコンピュータにインストールするか、別々のコンピュータにインストールするかを選べます。

これらのサーバーのインストールについての詳細は、ヘルプで対応するトピックを参照してください。

ダウンロードのみ（Download only）

製品をインストールしないで、選択した SOLIDWORKS 製品のインストレーション ファイルをダウンロードします。

このオプションは DVD からインストレーションを行っているときは表示されません。

ダウンロード ファイルの内容は、SOLIDWORKS インストレーション DVD で利用できるファイルと同じものです。 このオプションを選択すると、どのファイルが既にコンピュータにインストールされているかにかかわらず、インストール ファイルの完全なセットがダウンロードされます。

この方法を使用してサーバーをセット アップし、このサーバーからユーザーはインストレーションを実行できます。これはアドミニストレーティブ イメージを作成することとは異なります。

コンピュータに適合しない SOLIDWORKS アーキテクチャのインストール

使用しているコンピュータのアーキテクチャと適合しない SOLIDWORKS インストレーション メディアを用いてインストールを試みた (たとえば、32 ビットのコンピュータに 64 ビットの SOLIDWORKS をインストール使用した) 場合、インストレーション パネルに問題が報告されます。

インストレーションを継続するには：
  1. この SOLIDWORKS Installation Manager セッションを終了します。
  2. 使用中のコンピュータのアーキテクチャとシステム要件を確認します。
  3. このコンピュータのアーキテクチャに適合する SOLIDWORKS インストレーション メディアを使用して、再度インストールを行います。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
アドミニストレーティブ イメージの使用（Using Administrative Images）
SOLIDWORKS Workgroup PDM
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）
SOLIDWORKS Electrical


複数コンピュータのインストールと管理（Installing and Managing Multiple Computers）

SOLIDWORKS Installation Manager は、複数の SOLIDWORKS コンピュータのインストールと管理のために次のツールを提供します。

SOLIDWORKS アドミニストレーティブ イメージ（SOLIDWORKS Administrative Images）

SOLIDWORKS を複数コンピュータにインストールする場合は、アドミニストレーティブ イメージを作成し、アプリケーションを他のコンピュータで展開できます。

Workgroup PDM Server

Workgroup PDM アプリケーションは、SOLIDWORKS 環境内で、あるいはスタンドアロン アプリケーションとして SOLIDWORKS Explorer 内で動作する、プロジェクト データ管理ソフトウェアです。 Workgroup PDM Server をインストールすると、Workgroup PDM ボルトが作成されます。これは管理する SOLIDWORKS プロジェクトを保存するためのデータベースです。

SOLIDWORKS Workgroup PDM のサポートは、SOLIDWORKS 2017 の後に終了いたします。SOLIDWORKS Workgroup PDM を既にご使用のお客様はインストールを続行できますが、ファイル ボルトを SOLIDWORKS PDM Server に移行する計画を開始する必要があります。

SOLIDWORKS PDM

SOLIDWORKS PDM は、SOLIDWORKS Enterprise PDM と同じクライアント/サーバー アーキテクチャに基づくドキュメント管理製品です。 次の 2 つのバージョンで使用できます。 Standard および Professional。 SOLIDWORKS PDM は Microsoft SQL Server データベースを使用してファイル ボルトを管理します。

SolidNetWork License Manager

SolidNetWork License Managerでは、ライセンスの使用をフロートすることにより、実際のライセンス数よりも多数のユーザーを許可します。 使用されていないクライアント ライセンスは、他の SOLIDWORKS ユーザーが使用できます。

また、SolidNetWork License Manager を使用し、SOLIDWORKS コア アドイン製品（たとえば、FeatureWorks）のライセンスを配布できます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


マニュアル ダウンロード（Manual Download）

ファイルを手動操作でダウンロードすることを選択しました（または最後に SOLIDWORKS Installation Manager を実行したときに手動操作でダウンロードすることを選択しました）。

リンクをクリックし、ダウンロードを完了するために必要なファイルの完全なリストを含む自動生成されたWebページを開きます。

サマリー ページで指定したフォルダーにダウンロードする必要があります。インストレーションは、すべてのファイルがフォルダーにダウンロードされるまで開始できません。

マニュアル ダウンロードを終えたら、次へ（Next）をクリックして続行します。

自動的にダウンロードしたい場合は、サマリー ページに戻ってダウンロード オプションを変更することでオプションを変更できます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能なより新しいバージョン（Newer Version Available）

Installation Manager は、より新しいバージョンの SOLIDWORKS 製品を検知します。 オリジナルのインストレーションDVDまたはダウンロードに含まれるバージョンのインストールを選択できます。または、新しいバージョンをダウンロードしてインストールすることを選ぶことも可能です。

DVDからインストールする場合（If You Are Installing from a DVD）

より新しいバージョンを使用しますか? (Would you like to use the newer version?) で以下のいずれかを選択します。
  • いいえ、この DVD からの version のインストールを継続します。 その後で少量のダウンロードを行って更新することができます。（No, continue installing version from this DVD. You can update afterwards with a smaller download.）

    このオプションは、現在のInstallation Managerを使用してインストレーションを続行する場合に選択します。

    インストレーションが完了した後は、Installation Managerを使用してアップデートをチェックしてインストールすることができます。 アップデートをチェックするには、スタート (Start) > SOLIDWORKS Installation Manager > アップデート チェック (Check for Updates) を実行します。

    この場合の利点は、ダウンロードが最小限になることです。不利な点は、これが2ステップの過程になり、ダウンロードしたファイルが特定のバージョン用になる点です（他のバージョンを使用しているユーザーと共有はできません）。

  • はい、この DVD を使用してインストールを行います。続いて、ダウンロードして次までのアップデートを行います: (Yes, perform installation using this DVD, then download and update to )version。

    SOLIDWORKS　製品の最新のバージョンをインストールするために、このオプションを選択し、最新のバージョンの Installation Manager をダウンロードして起動します。

    小さなServicePackリリースを利用してDVDバージョンをアップデートできる場合、Installation Managerは最初にDVDから元のバージョンをインストールし、次にServicePackアップデートを適用します。この結果、ダウンロード サイズが小さくなります。

    DVDからインストールを続行するオプションを選択してから、後日アップデートを適用しても同じ結果を得られます。

    このオプションの利点は、これが1ステップの過程であることです。

通常、完全なバージョンをDVDからインストールし、Installation Managerを使用して更新をチェックし、インストールすることが最小限のファイルをダウンロードする点で推奨されます。

ダウンロードからインストールする場合（If You Are Installing from a Download）

次のいずれかを選択します。
  • versionのインストールを続行します。（Continue installing version.）

    このオプションを選択し、初期のダウンロードに含まれるバージョンのインストールを続行します。

  • 新しいバージョンのダウンロードとインストール: version（Download and install a new version: version）

    このオプションを選択し、新しいバージョンをダウンロードし、インストールします。もし複数の新しいバージョンがあるなら、ダウンロードしてインストールするバージョンを選択できます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


利用可能な新しいバージョンはありません（No New Versions Available）

ダウンロードできる利用可能なより新しいバージョンはありません。指定されたバージョンのインストールを開始してください。

インストレーションを続けるには次へ（Next）をクリックします。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


検出されたプロセス（Processes Detected）

SOLIDWORKS Installation Manager は正常なインストレーションを妨げる可能性のあるプロセスを検出しました。

  • インストレーションを続行するには、以下のいずれかを行います。
    • 例えば、Microsoft Windowsタスク マネージャを使用してプロセスを終了してから、再試行（Retry）をクリックします。
    • 無視（Ignore）をクリックし、プロセスを終了しないまま続行します。
  • インストレーションを中止するには、キャンセル（Cancel）をクリックします。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


製品選択（Product Selection）

インストール、変更、ダウンロード、または削除する製品コンポーネントを指定します。

製品リストは以下のようになります。
  • 製品リストは、製品リスト上で指定されたパッケージで利用できる製品の完全なリストです。
  • 特定のコンポーネントに対して計画された動作を確認するには、コンポーネント名（チェックボックスではなく）をクリックします。 製品リストの下部にある情報フィールドに意図されたインストール動作が表示されます。
  • 製品コンポーネントに対するインストール動作を変更するには、コンポーネントの隣にあるチェックボックスをクリックします。 （たとえば、コンポーネントのインストールや削除を行っている場合は、チェックボックスを選択すると対応するコンポーネントがインストールまたは削除の対象となり、チェックボックスの選択を解除すると対応するコンポーネントがインストールまたは削除の対象から外れます。）
  • インストレーションの変更を行っている場合、製品選択で変更を行うとアスタリスク（*）がコンポーネントの左に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。

ServicePack を適用している場合、SOLIDWORKS の下に表示される FeatureWorks などの SOLIDWORKS 機能は選択できません。 これは、このタイプの更新を行う時に、機能の追加/削除ができないためです。

SOLIDWORKS Installation Manage は製品の共存ルール（product coexistence rules）に従って機能します。 詳細は、製品の共存ルール（Product Coexistence Rules）を参照してください。

SOLIDWORKS Installation Manager は以下の製品をデフォルトで選択します。
  • アップグレードまたは SevicePack アップデートを実行している場合、SOLIDWORKS Installation Manager は現在インストールされている製品を選択します。
  • そうでない場合、SOLIDWORKS Installation Manager は権限のあるすべての製品を選択します。
インストレーションまたはダウンロードの時間と必要なディスク スペースを減らすために、製品コンポーネントを展開して不要なコンポーネントのチェック ボックスを選択解除します。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、別のパッケージ/製品の選択 をクリックしてインストールまたは変更する製品のパッケージ（たとえば、SOLIDWORKS Professional または SOLIDWORKS Premium など）のリストを変更できます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

SOLIDWORKS 検索

SOLIDWORKS 検索機能は、SOLIDWORKS ドキュメント、Workgroup PDM ボルトと 3D ContentCentral の強力で完全なテキスト検索を提供します。 検索機能は、プレビューとファイルの場所と名前を示します。

インストレーションの後で、SOLIDWORKS 検索は、より速い検索のために SOLIDWORKS ドキュメントにインデックスを付けます。 デフォルトでは、SOLIDWORKS ファイルのインデックス ファイルのみが作成されます。

SOLIDWORKS 検索は Windows Desktop Search が既にコンピュータの上にインストールされていない場合、自動的にそれをインストールします。

言語サポート（Language Support）

SOLIDWORKS 製品と 言語 コンポーネントを展開し、インストール可能な言語版を表示します。

言語 はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 たとえば、eDrawings®、SOLIDWORKS Workgroup PDM、SOLIDWORKS Explorer、および SOLIDWORKS PDM はすべての言語をインストールします。

必要なスペース（Space Needed）

SOLIDWORKS Installation Manager はページの一番下に合計のインストレーション サイズ、あるいは、合計のダウンロード サイズを表示します。

  • ダウンロードのみ オプションを選択した場合は、ダウンロード サイズ が表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。
    インストレーションに必要なすべてのファイルは合計のダウンロード サイズに含まれます。 もしいくつかのファイルが既に現在のダウンロードフォルダにダウンロードされている場合、それらは再びダウンロードされません。 結果として、実際のダウンロードサイズは表示された合計サイズより小さくなることがあります。または、まったくファイルのダウンロードが必要ないときもあります。
  • そうでない場合、インストレーション サイズ(installation size)が表示されます。 インストレーション サイズは、このインストレーションを完了したときに生じるディスク スペース使用量で変わります。 ファイル圧縮のため、これらの数字は推定です。

    既存のインストレーションをアップグレード、または削除する場合、インストレーション サイズは0（ゼロ）になります。

    表示される数字は、インストレーションに必要である場合もファイルをダウンロードする、または解凍するために必要なスペースを含みません。

    ダウンロードが必要で、同じドライブにダウンロードしている場合、実際に必要とされるディスク スペースは表示されるインストレーション サイズよりも著しく大きくなります。

    将来の更新作業でのダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
製品の共存ルール（Product Coexistence Rules）


ダウンロードする製品（Products to Download）

指定された場所にダウンロードするように SOLIDWORKS 製品を選択します。

ダウンロードで利用可能な製品は与えられたシリアルナンバーによって決まります：

  • 各コンポーネントに対して行われるアクションは、各項目の右側に表示されます。
  • コンポーネント内にサブコンポーネントがある場合には、コンポーネントの隣に + アイコンが表示されます。 利用可能なサブコンポーネントを確認するには、+ アイコンをクリックしてください。
  • コンポーネントが展開されサブコンポーネントが表示されている場合は、コンポーネントの隣に - アイコンが表示されます。 サブコンポーネントへの展開を解除するには、- アイコンをクリックしてください。
  • 各コンポーネントの左にあるチェックボックスをクリックし、SOLIDWORKS Installation Manager が行う処理を指定します。
指定しない場合、SOLIDWORKS Installation Manager は使用権があるすべての製品のコンポーネントをダウンロードします。 ダウンロード時間と必要なディスク スペースを減らすために、製品コンポーネントを展開し、ダウンロードする必要のないコンポーネントを指定します。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、SOLIDWORKS パッケージをダウンロードするように選ぶことができます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての SOLIDWORKS 製品をリストします。

SOLIDWORKS Installation Manager が権限のある製品を確認できない場合、別のパッケージ/製品の選択 をクリックしてインストールまたは変更する製品のパッケージ（たとえば、SOLIDWORKS Professional または SOLIDWORKS Premium など）のリストを変更できます。 SOLIDWORKS Installation Manager は、選択するパッケージと互換性があるすべての インストレーションメディア上の SOLIDWORKS 製品をリストします。 購入した、または評価する権限のある任意の製品を選択できます。

言語サポート（Language Support）

[言語 (Languages)] はインストールされる言語を SOLIDWORKS 製品でのみ限定します。 その他の製品のインストレーションは影響されません。 たとえば、eDrawings®、SOLIDWORKS Workgroup PDM、SOLIDWORKS Explorer ではすべての言語版がインストールされます。

必要なスペース（Space Needed）

選択する製品に基づいて、ダウンロードを行なうために必要なスペースが表示されます。 ダウンロード サイズはすべてのダウンロードされたファイルの必要とするディスク スペースの合計です（ダウンロード完了後の解凍に必要な追加のスペースは含まれていません）。 この数字は推定です。

将来の更新やパッチを当てる作業でダウンロード時間、またはインストレーション時間を減らすために、インストレーションのあとのダウンロード ファイルを削除しないでください。 一般に、次の更新作業とパッチを当てる作業は前回の完全なインストレーション ファイル セットにアクセスすることが必要です。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


修復する製品（Products to Repair）

このインストレーションを修復 (Repair this installation) を指定すると、画面にはこのバージョンの SOLIDWORKS Installation Manager で修復可能な SOLIDWORKS 製品とバージョン番号が表示されます。

修復は、すべてのファイルが存在し、正しく登録されていることを確認し、見つかった問題を修正します。ユーザーが作成したデータは影響されません。
  • 特定の製品を修復する場合、その製品が選択されていることを確認してください。
  • 修復しない製品は選択解除してください。

修復（Repair）をクリックし、選択した製品の修復を開始します。

個人インストレーションは修復できます。アドミニストレーティブ イメージ インストレーションは修復できません。アドミニストレーティブ イメージを再インストールする必要があります。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


シリアル番号（Serial Numbers）

シリアル番号 (パッケージ上にあります) は、購入した SOLIDWORKS 製品をご使用のコンピュータに関連付けます。

既にインストールされている SOLIDWORKS 製品のシリアル番号は、デフォルトで表示されます。
  • シリアル番号が表示されていない場合は、SOLIDWORKS シリアル番号を入力します。
  • SOLIDWORKS ライセンスに含まれていない製品のシリアル番号を持っている場合は、その他のシリアル番号をお持ちですか? の下にある製品項目をクリックし、その製品のシリアル番号を入力します。

インターネットに接続している場合、入力したシリアル番号はインストレーション プロセスを続ける際に権限のある製品を決定します。

SOLIDWORKS 製品を購入するには複数の方法があるため、一部のシリアル番号は複数の製品に対応している場合があります。 たとえば、 SOLIDWORKS シリアル番号は、個々の SOLIDWORKS Simulation シリアル番号を入力しないで SOLIDWORKS Simulation のインストールを可能にします。 また、一部の製品はシリアル番号を必要としません。 シリアル番号に関する質問は、お客様の代理店までご連絡ください。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


サーバー インストール（Server Installation）

インストールを試みているサーバー製品が、インストレーションの結果と共に表示されます。

サーバー インストレーション ステータス（Server Installation Status）

サーバー製品のインストレーションは、外部インストレーション アプリケーションによって実行されます。このアプリケーションを開いていない場合はインストレーションを完了するため、このアプリケーションに切り替える必要があります。

サーバー製品のインストレーションを中止するには、キャンセル（Cancel）をクリックします。

サーバー インストレーション完了（Server Installation Complete）

外部インストレーション アプリケーションは正常に終了しました。

終了 あるいは 次へをクリックします。
  • その他のアドミニストレーティブ製品をインストールする場合（たとえば、SOLIDWORKS アドミニストレーティブ イメージ）、そのインストレーションが続きます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。

サーバー インストレーションのキャンセルまたは失敗（Server Installation Cancelled or Failed）

サーバー製品のインストレーションに失敗したか、または開始後にキャンセルされた場合、インストールが完了しなかったサーバーがリストに表示されます。

閉じる あるいは 次へをクリックします。
  • 別のアドミニストレーティブ製品のインストレーションが指定されている場合、SOLIDWORKS Installation Manager は再開されます。
  • インストレーション作業がサーバー製品のインストレーションのみの場合、SOLIDWORKS Installation Manager は閉じられます。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


SolidNetWork License Manager

SolidNetWork License Managerサーバー製品のインストール オプションを指定します。

シリアル番号（Serial numbers）

SolidNetWork Licenseのシリアル番号を指定します。 複数のシリアル番号をカンマで区切って入力できます。
SolidNetWork シリアル番号は SOLIDWORKS シリアル番号とは異なります。

インストレーション場所（Installation location）

SolidNetWork License Managerをインストールする場所を指定します。

既存のSolidNetWork License Managerを更新する場合、既存のインストレーション場所にインストールする必要があります。

詳細情報

SolidNetWork License Manager のインストール、設定、使用の詳細については、SolidNetWork License Manager を使用したライセンスの管理 (Administering Licenses Using a SolidNetWork License Manager)を参照してください。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SolidNetWork License Managerを使用したライセンスの管理（Administering Licenses Using a SolidNetWork License Manager）


サマリー（Summary）

SOLIDWORKS Installation Manager には、インストレーション作業を完了するために必要な情報がすべてあります。

続行するには: | アクション今すぐ ボタンをクリックしてインストレーション作業を開始します（たとえば、今すぐインストール、今すぐ作成、今すぐダウンロード、今すぐ変更）。
インストレーション設定を変更するには: | 変更したいセクションに対して変更 [image] をクリックします（たとえば、製品、インストール先、Toolbox オプション）。
キャンセルするには: | インストレーション コンポーネントを変更せずに SOLIDWORKS Installation Manager を終了するには、キャンセルをクリックします。
前のページに戻るには: | SOLIDWORKS Installation Manager の前のページに戻るには、戻るをクリックします。
特定のインストレーション オプション セット（たとえば、製品、インストール先、Toolbox オプション など）の情報については、以下を行います。
  1. 情報を希望するセクションの横にある変更 [image] をクリックします。
  2. 表示される詳細ページでヘルプをクリックし、これらのインストレーション オプションの設定に関する情報を入手します。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


システム チェックの警告（System Check Warnings）

システム チェックは、インストレーションの継続に影響する可能性のある問題を報告します。 ほとんどの場合は、SOLIDWORKS Installation Manager を続行できるはずです。

下記にこの段階で遭遇する可能性のある警告を解決方法と共に一覧します。

シリアル番号検証に関する問題

シリアル番号の検証ができなかったので、InstallationManagerは新しいバージョンをチェックすることができませんでした。 接続しており、正しいシリアル番号を入力している場合は、ご使用のサーバーの一時的な問題である可能性があります。 後でまた試してみてください。

シリアル番号認証: InstallationManager は使用権をお持ちの製品を自動的に確定するために必要なシリアル番号の認証ができませんでした。インストールする製品を選ぶことはできますが、インストレーション ファイルをダウンロードすることはできません。インストールするためにはダウンロード ソース ファイルの全セットか DVD が必要です。

解決策:
  • インターネットの接続を確認してください。シリアル番号のチェックには、有効なインターネット接続が必要です。
  • 入力したシリアル番号が、インストールを試みている製品に対して正しいことを確認してください。
  • 一部のインストールでは、バージョンのリリース時に適切な契約を交わす必要があります。 詳細は、SOLIDWORKS 代理店までお問い合わせください。
  • 大部分のケースでは、DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

より新しいバージョンの存在

利用可能なより新しいバージョン

利用可能な新しいバージョン

製品のより新しいバージョンをダウンロードして利用できます。

解決策: アップデート チェックの実行時には、SOLIDWORKS からのダウンロードにより利用可能な新しいバージョンのインストールを促される場合があります。 この処理は最初に指定したバージョンを用い継続することも、あるいは利用可能なより新しいバージョンをダウンロードし、そのバージョンを用いて継続することも可能です。

最新バージョンの存在

これはご利用可能な最新のバージョンです。「次へ」をｸﾘｯｸして続行してください。

利用可能な新しいﾀﾞｳﾝﾛｰﾄﾞはありません

解決策:このメッセージには、インストールや変更の間、アップデートをチェックしている際に遭遇する可能性があります。このメッセージは、利用可能な最新バージョンをインストール中であること、あるいは最新バージョンが既にインストール済みであることを示すものです。

インターネット接続に関する問題

インターネット接続: InstallationManager は使用権をお持ちの製品を確定するために必要な SOLIDWORKS サーバーへ接続できませんでした。 インストールを行う製品を選択することは可能ですが、しかしインストレーションファイルをダウンロードすることはできません。 ソース ファイルの DVD あるいは以前にダウンロードしたファイル セットが必要です。

新しいバージョンをチェックすることができません

サーバーに接続することができなかったので、InstallationManager は新しいバージョンをチェックすることができませんでした。

解決策:
  • インターネットの接続を確認してください。
  • DVDまたは以前にダウンロードしたファイル セットからインストールすることで、インストールを続行できます。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）

SOLIDWORKS Toolbox がインストールされている場合、SOLIDWORKS は穴タイプと汎用部品の標準ライブラリを含みます。

SOLIDWORKS Toolbox の設定、拡張、使用の詳細は、SOLIDWORKS で ヘルプ (Help) > Toolbox ヘルプ (Toolbox Help) をクリックします。
このヘルプを表示するには、ツール > アドインを使用してToolboxアドインを開始する必要があります。

SOLIDWORKS Toolbox を使用する前に、企業やグループのポリシーに従って適切に設定されていることを確認します。 ほとんどの場合は、グループが中央 Toolbox を設定および管理します。 SOLIDWORKS のインストレーション中に Toolbox を指定する方法のガイダンスについては、SOLIDWORKS 管理者に確認してください。

選択した SOLIDWORKS Toolbox は、インストレーション後に変更できます。 SOLIDWORKS で ツール (Tools) > オプション (Options) をクリックします。 システム オプション タブの 穴ウィザード/Toolbox (Hole Wizard/Toolbox) をクリックします。

次のセクションでは、あらゆる設定に対して画面に表示されるすべてのオプションについて説明します。 実際に表示される Toolbox オプションは、コンピュータにある既存の SOLIDWORKS と Toolbox の設定、および、これまでに指定した SOLIDWORKS Installation Manager の選択内容によって異なります。

新しいnew-version Toolboxの作成（Create a new new-version Toolbox）

このコンピュータで SOLIDWORKS Toolbox の新しいバージョンを作成します。

[製品選択 (Product Selection)] 画面で新しいバージョンを作成する場合、SOLIDWORKS > SOLIDWORKS Toolbox の順に展開し、Toolbox に対してどの規格をサポートするか選択します。 デフォルトでは、すべての規格が選択されます。

このコンピュータにある既存のToolboxは、いっさい変更されません。

既存のToolboxの参照またはアップグレード（Reference or upgrade an existing Toolbox）

既存のToolboxを使用します。参照（Browse）をクリックし、このインストレーションで使用するToolboxの位置を指定します。

  • Toolbox が以前の SOLIDWORKS メジャー リリース バージョン用に設定されている場合は、現在のバージョンにアップグレードされます。 前のToolboxに対して行われたユーザー定義はすべて、アップグレードされたToolboxでも保持されます。
    Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。
  • Toolbox が現在の SOLIDWORKS バージョン用に設定されている場合（既にアップグレードされた共有ネットワーク Toolbox を指定した場合）、その Toolbox に対するアップグレードは行われません。
  • SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

このオプションは、アドミニストレーティブ イメージの作成を除く、すべてのインストレーション シナリオで表示されます。

previous-version Toolboxのアップグレード（Upgrade a previous-version Toolbox）

以前のメジャー リリース バージョン用に設定されたToolboxを新しい位置にコピーし、このコピーを現在のバージョンにアップグレードします。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、そのインストレーションを現在のリリースにアップグレードしないことを選択した場合に表示されます。
このオプションの目的は、古いバージョンの Toolbox を使用しているユーザーに影響を与えずに、以前の SOLIDWORKS メジャー リリース バージョン用の Toolbox をアップグレードすることです。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている previous-version Toolboxのアップグレード（Upgrade this installed previous-version Toolbox）

より新しいバージョンにToolboxをアップグレードします。
Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンを現在のバージョンにアップグレードする際に、以前のリリース用に設定された Toolbox がコンピュータ上で見つかった場合に表示されます。

SOLIDWORKS PDM 環境で Toolbox をアップグレードする場合には、さらに手順を実行する必要があります。 詳細は、SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）を参照してください。

インストールされている current-version Toolboxの使用（Use the installed current-version Toolbox）

SOLIDWORKS Installation Manager は、このコンピュータ上に現在の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox があることを検出しました。

このオプションを選択すると、SOLIDWORKS はこの Toolbox を使用します。 アップグレードは行われません。

このオプションは、以前の SOLIDWORKS メジャー リリース バージョンがコンピュータにインストールされているが、Toolbox は現在のバージョン用に設定されている場合に表示されます。 このような状況は、古い SOLIDWORKS バージョンを実行し続けているコンピュータに共有 Toolbox が作成された場合に生じる可能性があります。

クライアント コンピュータのToolbox位置を指定（Specify the Toolbox location for the client computer）

アドミニストレーティブ イメージからのクライアント インストール時に、デフォルトの Toolbox 位置としてネットワークまたはディレクトリ位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

このオプションは、新しいアドミニストレーティブ イメージを作成するときに表示されます。

クライアント コンピュータ用に、アップグレードするか、既存のイメージで参照されているToolboxを使用します（Upgrade or use the Toolbox referenced in the existing image for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたToolbox位置を使用します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

クライアント コンピュータ用に別のToolbox位置を選択します（Select a different Toolbox location for the client computer）

アップデート中の既存のアドミニストレーティブ イメージで指定されたものとは異なる Toolbox 位置を指定します。
クライアント インストレーションの実行時に、この位置に以前の SOLIDWORKS メジャー リリース バージョン用に設定された Toolbox が存在する場合、SOLIDWORKS Installation Manager はその Toolbox をアップグレードします。

目次

  • SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

    SOLIDWORKS Toolbox は、強力かつ複雑な機能です。 ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。

  • UNCフォーマット（UNC Format）

    UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）
関連概念
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox は、強力かつ複雑な機能です。 ここでは、SOLIDWORKS Installation Manager を使用して Toolbox を設定する前に、考慮する必要のあるいくつかの概念をまとめたものです。

SOLIDWORKS Toolbox の詳細情報（Finding More Information About SOLIDWORKS Toolbox）

SOLIDWORKS Toolbox の設定、拡張、使用の詳細は、SOLIDWORKS の ヘルプ > Toolbox ヘルプ をクリックしてください。
このヘルプを表示するには、ツール > アドインを使用して Toolbox アドインを開始する必要があります。

共有Toolboxの使用（Using a Shared Toolbox）

Toolbox をインストールするとき、ローカルコンピュータ上、あるいは共有されたネットワーク上でToolbox データを持つことができます。 Toolbox データをネットワーク上に保管することが推奨されます。 共通の場所を使うことによって、すべての SOLIDWORKS ユーザーは一貫したファスナー情報を共有します。

今回が最初のインストールである場合、Toolbox をインストールする新しい共有された場所を参照してください。

既存のToolboxのアップグレード（Upgrading an Existing Toolbox）

Toolbox を新しい SOLIDWORKS メジャー リリース バージョンにアップグレードすると、この Toolbox は以前の SOLIDWORKS メジャー リリース バージョンを実行しているコンピュータとの互換性がなくなります。

他のコンピュータが以前のメジャー リリースのままであり、以前のリリース用に設定されたToolboxを必要とする場合は、このToolboxのコピーを作成し、そのコピーをアップグレードするべきです。 新規の SOLIDWORKS インストレーションは Toolbox のコピーをアップグレードし、以前の SOLIDWORKS インストレーションは古い Toolbox を使用し続けます。

Toolboxアクセスの設定（Configuring Toolbox Access）

インストレーション後に、Toolbox コンポーネントにアクセスするとき、SOLIDWORKS はどのように Toolbox を配置したかをチェックし、アクセスとパフォーマンスを改善するために提案をします。

共有ネットワークToolbox（推奨）にアクセスする場合、共有Toolboxのインストールされたサーバーに対するUNCパスを使用します。 詳細は、UNC フォーマット（UNC Format）を参照してください。

アドミニストレータ（管理者）はToolboxのパスワードを作成し、ワークグループの権限と優先権を設定できます。コンフィギュレーションへのアクセスを限定することと、共通の優先権を設定することは安定した Toolbox データを保証します。

SOLIDWORKS PDM 環境での Toolbox のアップグレード

SOLIDWORKS ソフトウェアをアップグレードする際、Toolbox に部品が追加されていれば Toolbox もアップグレードされます。 Toolbox ルート フォルダが SOLIDWORKS PDM ボルト内にある場合、SOLIDWORKS のアップグレードを開始する前に、Toolbox フォルダの準備をする必要があります。

アップグレードを行う最初のシステムで、最新バージョンの取得 を使用して Toolbox ファイルをローカル キャッシュにダウンロードし、Toolbox データベースをチェックアウトする必要があります。 アップグレードする他のシステムでは、Toolboxファイルをダウンロードするだけです。

アップグレードをはじめる前に:
  • ボルト データベースの最新のフルバックアップおよびアーカイブが存在することを確認します。
  • Toolbox 部品がチェックアウトされておらず、現在チェックアウトされているいずれのアセンブリでも使用されていないことを確認します。

Toolbox をアップグレードするには:

  1. Windows エクスプローラで、全権限（チェックアウト、チェックイン、追加、削除）を持つユーザーとしてボルトにログインします。
  2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして、すべての Toolbox ファイルおよび Toolbox データベースをローカル キャッシュにコピーします。
    アーカイブ サーバーがリモートの場合、この操作には数分かかることがあります。
  3. Toolbox データベース ファイル（SWBrowser.mdb）を \Toolbox_folder_name\lang\your_lang からチェックアウトします。
  4. SOLIDWORKS Installation Manager を実行してアップグレードを行います。
  5. サマリー画面で、Toolbox オプションのインストレーションの位置がボルトにあることを確認します。

    無い場合は、変更をクリックし、既存の Toolbox の参照またはアップグレードを選択し、ボルトの Toolbox 位置を参照します。

  6. アップグレードが完了した後、Windows エクスプローラで、新しい、または更新されたファイルをボルトへ追加するために Toolbox フォルダをチェックインし、他のユーザーが Toolbox を操作できるようにします。
  7. SOLIDWORKS 2012 またはそれ以降へのアップグレードでは、ボルトの Toolbox フォルダに移動して、次のフォルダおよびファイルがあることを確認します。
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      無い場合は、お客様の代理店までご連絡ください。

  8. Toolbox と SOLIDWORKS PDM 統合を使用する残りのコンピュータをアップグレードします。
    1. Windows エクスプローラで、少なくとも Toolbox フォルダに対する読み取り権限を持つユーザーとしてボルトにログインします。
    2. Toolbox フォルダを右クリックし、最新バージョンを取得をクリックして Toolbox ファイルをローカル キャッシュにコピーします。
    3. SOLIDWORKS Installation Manager を実行してアップグレードを行います。

      Toolbox が既にアップグレードされていることが、インストーラによって検出されます。

SOLIDWORKS PDM における Toolbox コンフィギュレーションに関する詳細は、SOLIDWORKS PDM アドミニストレーション ツール ヘルプの Toolbox の設定 を参照してください。

親トピック
穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
関連資料
UNCフォーマット（UNC Format）


UNCフォーマット（UNC Format）

UNC（UniformまたはUniversal Naming Convention、命名規則）フォーマットは、共有ファイルの場所を記述するためにファイル名の構文フォーマットを指定します。

\\サーバー\ボリューム\パス

例えば:

\\Disk_Server\SOLIDWORKS\AdminImage

親トピック
穴ウィザード/Toolbox オプション（Hole Wizard/Toolbox Options）
関連概念
SOLIDWORKS Toolbox の設定に関する注記（Notes About Configuring SOLIDWORKS Toolbox）


製品のアンインストール（Uninstall Products）

削除 (Remove) または アンインストール (Uninstall) を コントロール パネル から選択すると、画面にはこのバージョンの SOLIDWORKS Installation Manager でアンインストールできる SOLIDWORKS 製品がバージョン番号と共に表示されます。 一般的なアンインストール、カスタム アンインストール、完全なアンインストールを選択します。

一般的なアンインストールでは、SOLIDWORKS 製品のプログラム ファイルとフォルダが削除されます。 デフォルトで、選択したリリースのすべての SOLIDWORKS 製品のアンインストールが指定されます。

カスタム インストールでは、次のアイテムのいくつかを削除できます: プログラム ファイルとフォルダ、レジストリ キー、SOLIDWORKS Toolbox などのデータ フォルダ、元のダウンロード位置からのファイルとフォルダ。

完全なアンインストールではインストール ディレクトリ、レジストリ キー、データ フォルダが削除されます。

製品をアンインストールするには:
  1. アンインストール（Uninstall）の画面で、製品が選択されていることを確認してください。

    すべての製品をアンインストールすると、Solidworks Installation Manager もアンインストールされます。

  2. 削除したくない製品を選択解除します。

    1 つでも製品を保持すると、SOLIDWORKS Installation Manager も削除されません。

  3. カスタム アンインストールか完全なアンインストールを選択します。
    1. 変更（Change）を詳細設定オプション（Advanced Options）でクリックします。

      詳細設定オプション(Advanced Options)画面が表示されます。 プログラム ファイルとフォルダのオプションが選択されています。

    2. 希望のオプションを選択してカスタム アンインストールを行うか、すべてのオプションを選択して完全なアンインストールを行います。
    3. サマリーに戻る（Back to Summary）をクリックします。
    4. サマリー（Summary）の画面で、詳細設定オプション（Advanced Options）を展開し、アンインストールの方法を表示します。
  4. アイテムを削除 をクリックします。
アイテムを削除 (Remove Items) をクリックすると、SOLIDWORKS Installation Manager は直ちに製品の削除を開始します。
親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


Workgroup PDM Serverオプション（Workgroup PDM Server Options）

SOLIDWORKS Workgroup PDM サーバー製品のインストール オプションを指定します。

インストール先（Installation Location）

Workgroup PDM Server 製品のインストール先を指定します。

インストールする製品（Products to install）

インストールするWorkgroup PDM Server製品を指定します：
Workgroup PDM ボルト（Workgroup PDM Vault） | Workgroup PDMボルトデータの場所を指定します。Viewerを有効にするには、Workgroup PDM Viewerのライセンスをボルトと共にインストールする必要があります。
Workgroup PDM Viewer | Workgroup PDM Viewerをインストールする際、ViewerがアクセスするWorkgroup PDM Vaultコンピュータの名前またはIPアドレスを指定する必要があります。

Workgroup PDM API.

Workgroup PDM API のライセンスは SOLIDWORKS クライアントと Explorer クライアントのライセンスに含まれています。 Check-in APIs（チェックインAPI）にはクライアント ライセンスが必要です。

詳細情報

Workgroup PDM をインストールする詳細については SOLIDWORKS Workgroup PDM を参照してください。

Workgroup PDM の使い方の詳細については、SOLIDWORKS ヘルプのSolidWorks ヘルプを参照してください。

親トピック
SOLIDWORKS Installation Manager アプリケーション ヘルプ（SOLIDWORKS Installation Manager Application Help）


著作権に関する注意書き

© 1995-2015, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

本ドキュメントに記載されている情報とソフトウェアは予告なく変更されることがあり、Dassault Systèmes SolidWorks Corporation (DS SolidWorks) の保証事項ではありません。

この製品を DS SolidWorks の書面上の許可なしにその目的、方法に関わりなく複製、頒布はできません。

本ドキュメントに記載されているソフトウェアは使用許諾に基づくものであり、当該使用許諾の条件の下でのみ使用あるいは複製が許可されています。 DS SolidWorks がソフトウェアとドキュメントに関して付与するすべての保証は、ライセンス契約書に規定されており、本ドキュメントまたはその内容に記載、あるいは黙示されているいかなる事項もそれらの保証、その変更あるいは補完を意味するものではありません。

特許

SOLIDWORKS® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028, 8,910,078, and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

SOLIDWORKS 製品とサービスの商標と製品名

SOLIDWORKS、3D ContentCentral、3D PartStream.NET、eDrawings、eDrawings のロゴは DS SOLIDWORKS の登録商標です。FeatureManager DS SOLIDWORKS が共同所有する登録商標です。

CircuitWorks、FloXpress、PhotoView 360、TolAnalyst は DS SolidWorks の商標です。

FeatureWorks は、Geometric Ltd. の登録商標です。

SOLIDWORKS 2016、SOLIDWORKS Standard、SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS PDM Professional、SOLIDWORKS PDM Standard、SOLIDWORKS Workgroup PDM、SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、eDrawings、eDrawings Professional、SOLIDWORKS Sustainability、SOLIDWORKS Plastics、SOLIDWORKS Electrical、SOLIDWORKS Composer、SOLIDWORKS MBD は DS SolidWorks の製品名です。

その他、記載されているブランド名、製品名は各社の商標及び登録商標です。

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

本ソフトウェアは、48 C.F.R. 2.101 (OCT 1995) に定義されている「商用品」であり、48 C.F.R. 12.212 (SEPT 1995) で使用されている「商用コンピュータ ソフトウェア」および「商用コンピュータ ソフトウェア ドキュメンテーション」で構成されます。本ソフトウェアは、(a) 48 C.F.R. 12.212 に規定された政策に従って、民間機関による、またはそれに代わる取得のため、あるいは (b) 48 C.F.R. 227.7202-1 (JUN 1995) および 227.7202-4 (JUN 1995) に既定された政策に従って、国防総省の一部門による、またはそれに代わる取得のために、米国政府に対して提供されます。

米国政府機関から、上記の規定を超える権利と共にソフトウェアを提供するように要求された場合は、DS SolidWorks にその要求の範囲を通知するものとします。DS SolidWorks は、5 営業日以内に、独自の判断により、そのような要求を受け入れるか拒絶するかを決定します。 Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

SOLIDWORKS Standard、Premium、Professional、Education 製品における著作権

Portions of this software (c) 1986-2015 Siemens Product Lifecycle Management Software Inc. All rights reserved.

この製品には、Siemens Industry Software Limited が所有する、次のソフトウェアが含まれています。

D-Cubed™ 2D DCM © 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ 3D DCM © 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ PGM © 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ CDM © 2015. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed™ AEM © 2015. Siemens Industry Software Limited. All Rights Reserved.

Portions of this software © 1998-2015 Geometric Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2015 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2015 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe、Adobeのロゴ、Acrobat、Adobe PDFのロゴ、Distiller、Reader は米国およびその他の国において Adobe Systems Inc. の登録商標または商標です。

DS SolidWorks の詳細な著作権情報については、ヘルプ > SOLIDWORKS についてを参照してください。

SOLIDWORKS Simulation 製品における著作権

Portions of this software © 2008, Solversoft Corporation.

PCGLSS © 1992-2014 Computational Applications and System Integration, Inc. All rights reserved.

SOLIDWORKS Standard 製品における著作権

(c) 2011, Microsoft Corporation. All rights reserved.

SOLIDWORKS PDM Professional 製品における著作権

Outside In® Viewer Technology, © 1992-2012 Oracle

© 2011, Microsoft Corporation. All rights reserved.

eDrawings 製品における著作権

Portions of this software © 2000-2014 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.

Portions of this software © 1995-2012 Spatial Corporation.

eDrawings® for Windows® ソフトウェアは部分的に Independent JPEG Group の研究に依存しています。

Portions of eDrawings® for iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.

Portions of eDrawings® for iPad® copyright © 2003 – 2005 Apple Computer Inc.


アドミニストレーティブ イメージ オプション エディタ

SOLIDWORKS アドミニストレーティブ イメージ オプション エディタが改善されました。

  • 管理者は完全アンインストールまたはカスタム アンインストールをクライアント コンピュータ上で実行する新しいアンインストール オプションを使用できます。アンインストール オプションは、オプション エディタのクライアント インストール オプション (Client Installation Options) セクションにあります。オプションを表示するには、はい、カスタム インストールを実行します (Yes, perform a custom uninstall) をクリックし、削除対象の項目を選択します。
  • 管理者はまた、SOLIDWORKS Toolbox の標準をリストから事前に選択できます。