SOLIDWORKS 安装与管理

本指南介绍 SOLIDWORKS 产品单机安装和多个安装的安装、许可、升级和管理。

单机安装 | 调用多个安装
安装 在一台或几台计算机上安装。 | 安装 生成可调用到一系列客户端计算机的管理映像。
颁发许可 激活许可或通过网络颁发许可。 | 颁发许可 激活许可或通过网络颁发许可。
升级 将单台计算机升级到新发行版本。 | 升级 通过更新用于在多台计算机上进行安装的管理映像，将这些计算机升级到新发行版。
管理 修改、修复、删除安装、升级到新版本。 | 管理 升级管理映像和客户端、网络许可颁发管理、Workgroup PDM 库管理。

SOLIDWORKS 安装管理程序允许您配置下列 SOLIDWORKS 产品组件的设置，包括：SOLIDWORKS、SOLIDWORKS Toolbox、PhotoView 360、SOLIDWORKS Electrical、Workgroup PDM、SOLIDWORKS PDM 和 SOLIDWORKS SolidNetWork License Manager。

SOLIDWORKS 2017 推出后，SOLIDWORKS Workgroup PDM 将不再受支持。已经在使用 SOLIDWORKS Workgroup PDM 的客户仍可继续安装，但他们应开始计划将文件库迁移到 SOLIDWORKS PDM Server。

SolidNetWork 许可管理器可通过向网络中的客户端分发许可支持多个许可客户端。 这样就能够利用浮动许可，允许用户数量超过许可数量。

内容

  • 单机安装或管理映像

    您是否应在每台计算机上单独安装 SOLIDWORKSs 产品，或者应创建管理映像然后以一个命令将安装调用到所有客户端？

  • 启动 SOLIDWORKS 安装

    您可以通过下列几种方式启动 SOLIDWORKS 安装：将 DVD 装入本地计算机、访问共享安装目录或从 SOLIDWORKS 下载。

  • 在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示

    Windows 8（及更高版本）的用户界面明显不同于 Windows 的早期版本。 不仅导航技术有所不同，还添加了数个访问关键命令的方法。


单机安装或管理映像

您是否应在每台计算机上单独安装 SOLIDWORKSs 产品，或者应创建管理映像然后以一个命令将安装调用到所有客户端？

如果您只在一台计算机上进行安装，或者如果您管理几十台或几百台计算机，则很容易做出选择。对于介于两者之间的情况，可考虑以下比较因素。

单机安装 | 管理映像
用户可进行自己的 SOLIDWORKS 管理。 | 系统管理员可使用选项编辑器自定义多个安装，可指定安装选项（如创建新的安装或更新现有安装）、以管理用户身份运行安装、在安装前或安装后运行外部命令、进行不同的产品分组等等。
进行安装的人员必须能够亲手操作计算机。 | 客户端计算机只要可从同一网络进行访问，则可位于远程位置。
您可以通过独立的设置，在不同计算机上安装不同版本、service pack 或产品。 | 通过使用选项编辑器，管理映像可在各个版本、service pack、产品及多个安装的设定之间保持一致。
计算机必须有网络或电子邮件可使用。 需要有网络或电子邮件连接才能激活 SOLIDWORKS 并下载文件。 从网络许可服务器获取许可时也需要网络访问。 | 要求有本地网络连接才可调用应用程序；客户端计算机上不要求有媒体驱动器。 客户端可自动进行更新。 所有从同一管理映像调用的客户端使用同样的 service pack。 若想保留多个版本，您可生成多个管理映像。 许可激活可自动化。 管理映像要求服务器上具有额外磁盘空间；客户端要求有与单机安装相同的空间。
父主题
SOLIDWORKS 安装与管理
相关概念
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示
相关任务
启动 SOLIDWORKS 安装


启动 SOLIDWORKS 安装

您可以通过下列几种方式启动 SOLIDWORKS 安装：将 DVD 装入本地计算机、访问共享安装目录或从 SOLIDWORKS 下载。

若要启动 SOLIDWORKS 安装，请进行以下操作之一：

  • 若要从光盘在本地计算机上进行安装，将适当的光盘插入到您的计算机光驱中。
  • 若要从下载目录安装，导航至该目录，然后双击 setup.exe。
  • 要通过从 SOLIDWORKS 下载进行安装：
    1. 浏览到 SOLIDWORKS 网站。
    2. 使用您的电子邮件地址和密码或您的 SOLIDWORKS 序列号作为订购服务客户登录。
    3. 在自助服务下单击下载软件与更新。
    4. 在 下载软件（Windows、Mac、Linux）下选择要下载的 SOLIDWORKS 版本和 service pack。
父主题
SOLIDWORKS 安装与管理
相关概念
单机安装或管理映像
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示


在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示

Windows 8（及更高版本）的用户界面明显不同于 Windows 的早期版本。 不仅导航技术有所不同，还添加了数个访问关键命令的方法。

以下主题提供关于如何访问 Windows 8 中三个最基本功能的说明。使用 Windows 8 安装 SOLIDWORKS 时请参阅这些主题。
这些步骤会根据您的 Windows 系统的配置方式而有所变化。 请参阅 Microsoft Windows 文档了解其他说明和选项，尤其是对于 Windows 8 之后的系统。
父主题
SOLIDWORKS 安装与管理
相关概念
单机安装或管理映像
在单台计算机上安装
相关任务
启动 SOLIDWORKS 安装

启动 SOLIDWORKS

您可以从 Windows 8 Charm Bar 启动 SOLIDWORKS 并将 SOLIDWORKS 固定到您的桌面。

要从 Charm Bar 访问 SOLIDWORKS：

  1. 从开始屏幕上，单击屏幕右下角。

    Charm Bar 显示在屏幕右侧。

    您还可以通过按下 Windows logo+C 访问 Charm Bar。

  2. 轻点或单击搜索图标。
  3. 在 搜索 框中键入 SOLIDWORKS 并向下滑动或轻点 SOLIDWORKS 平铺。
您可以通过右键单击 SOLIDWORKS 平铺，然后单击出现在屏幕底部的工具栏中的 固定到开始屏幕，将 SOLIDWORKS 固定到您的桌面上。

访问控制面板

要访问控制面板：

  1. 从开始屏幕，在屏幕右侧滑动或将您的鼠标拖动至屏幕右上边角。

    Charm Bar 显示在屏幕右侧。

  2. 轻点或单击搜索图标。
  3. 在搜索框中键入控制面板。
  4. 单击出现在程序屏幕左侧的控制面板平铺。

访问命令提示符

要访问命令提示符：

  1. 在开始屏幕上，右键单击以在屏幕底部显示工具栏。
  2. 在工具栏右侧，单击所有程序。
  3. 在程序屏幕的右侧的 Windows 系统下，按下或单击命令提示符。

有用的快捷键

以下列表提供有用的键盘快捷键：

Alt+Tab | 切换桌面上运行的不同程序。
Windows logo 键 +Q | 打开程序列表和搜索窗口。
Windows logo 键 +R | 单开运行对话框。
Windows logo 键 +I | 打开设置窗格。
请参阅 Microsoft Windows 文档以获取键盘快捷键的其他说明。


单机安装

内容

  • 在单台计算机上安装

    可通过多种安装方法在单台计算机上安装 SOLIDWORKS。

  • 单机安装的管理

    通常，单机安装的管理包括修改、修复、删除和升级安装。


在单台计算机上安装

可通过多种安装方法在单台计算机上安装 SOLIDWORKS。

SOLIDWORKS 安装管理程序会进行安装，并根据您所购买的产品定制安装过程。 在开始安装前：

  • 将您的 SOLIDWORKS 序列号准备待用。
  • 核实您的因特网连接无故障。 要求有连接才能检查授权。

SOLIDWORKS 安装管理程序需要许多 Microsoft 组件，其中包括 Microsoft Windows Installer、Office Web 组件、应用程序的 Microsoft Visual Studio 工具、Visual Basic 和 .NET Framework。 如果计算机上未安装 Windows 必备组件的正确版本，SOLIDWORKS 安装管理程序会在安装 SOLIDWORKS 产品之前自动安装它们。 Windows 的 Bonjour 服务也是一个必备组件。

如果您运行 Windows 8，请参阅 在 Microsoft Windows 8 中使用 SOLIDWORKS 提示 了解任务，如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 请参阅 Microsoft Windows 文档了解其他说明和选项，尤其是对于 Windows 8 及之后的系统。
安装方法 | 流程摘要
使用 SOLIDWORKS 安装介质 | 将 DVD 光盘放入计算机的光盘驱动器中。
使用服务器上的下载目录 在下载目录中双击 setup.exe。

必须能从安装 SOLIDWORKS 产品的计算机上访问下载目录，且下载目录必须包含所有的 SOLIDWORKS 安装文件，才能开始安装。 如果您可接入因特网且拥有对下载目录的写入访问权，SOLIDWORKS 安装管理程序可帮助您查找缺少的文件。

使用 检查更新 更新现有的 SOLIDWORKS 安装 执行以下其中一项操作：
  • 在 SOLIDWORKS 中，单击 帮助 > 检查更新。
  • 在 Windows 中，单击 开始 > 所有程序 > SOLIDWORKS 安装管理程序 > 检查更新。
确保您的因特网连接无故障。

Workgroup PDM 客户端会自动检测库更新。 您不必下载 service pack 便能更新客户端。 有关详细信息，请参阅 Workgroup PDM 联机帮助中的Workgroup PDM 联机帮助。

从 SOLIDWORKS 客户网站上下载
  1. 浏览到 SOLIDWORKS 网站。
  2. 使用您的电子邮件地址和密码或您的 SOLIDWORKS 序列号作为订购服务客户登录。
  3. 在自助服务下单击下载软件与更新。
  4. 在 下载软件 下，单击您要安装的 SOLIDWORKS 版本。
确保您的因特网连接无故障。

您必须是订购服务客户且必须具有客户门户网站的登录权限。

当安装完成后，启动 SOLIDWORKS 应用程序并 激活许可。

要查看安装在您机器上的产品列表，单击 SOLIDWORKS 主菜单上的帮助 > 我的产品。 我的产品显示您当前可用的所有 SOLIDWORKS 产品。 复选标记指明基于您的激活和网络许可，您或您机构当前拥有的产品。
父主题
单机安装
相关概念
单机安装的管理
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示


单机安装的管理

通常，单机安装的管理包括修改、修复、删除和升级安装。

内容

  • 修改安装

    假设已使用一组安装文件完成先前安装，您可以修改安装以安装未安装的产品或移除产品。 如果您通过 service pack 升级先前安装，则此选项不可用。

  • 修复安装

    如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

  • 将单机安装退回到先前的 Service Pack

  • 删除安装

    您可以在单台计算机或在服务器/客户端环境中删除安装。

  • 升级到新的发行版

    可使用多种方法将单机安装升级到新的 SOLIDWORKS 发行版。

  • 产品共存规则

    以下产品共存规则决定新产品如何安装及现有产品如何升级。

父主题
单机安装
相关概念
在单台计算机上安装


修改安装

假设已使用一组安装文件完成先前安装，您可以修改安装以安装未安装的产品或移除产品。 如果您通过 service pack 升级先前安装，则此选项不可用。

如果您安装了 SOLIDWORKS 并且以后购买了一插件，您可修改安装将新插件包括在内。 您必须在每台单独机器上安装插件。

如果您修改原有的 SOLIDWORKS 套件以增加 SOLIDWORKS Professional 或 SOLIDWORKS Premium，此时不会安装 Workgroup PDM。
  1. 确认无激活的 SOLIDWORKS 进程。
  2. 在 Windows 7 或更高版本上，单击 开始 > 控制面板 >程序和功能。
  3. 选择您要修改的 SOLIDWORKS 安装程序，然后单击 更改。
  4. 在欢迎使用 SOLIDWORKS 安装管理程序屏幕上单击 修改单个安装程序（此计算机上）
  5. 在序列号屏幕中，验证是否指定了适当的序列号。
  6. 在产品选择屏幕中，选择要安装或删除的产品。

    当修改安装时：

    • 默认情况下不会安装或删除任何产品，即使您指定了新的序列号。 您必须更改每个产品或功能组件的安装操作。
    • 要查看对特定组件的预计操作，请单击该组件名称（而不是复选框）。 预期的安装操作会出现在产品列表下方的信息字段中。
    • 您可以单击产品组件旁的复选框更改该组件的安装操作。 （例如，如果您要安装或删除组件，可选中相应复选框指定要安装或删除的组件，或清除相应复选框指定不想安装或删除的组件。）
    • 当您从初始规格更改了组件安装操作时，列表中该组件旁会出现一个星号 (*)。
    • 如果一个组件内含有可选安装子组件，则该组件旁会出现一个 + 图标。 要查看一个组件的可用子组件，请单击 + 图标。
    • 如果扩展一个组件以显示可选子组件，则该组件旁会显示一个 - 图标。 要折叠子组件列表，请单击 - 图标。

  7. 在摘要屏幕中，单击现在修改。
  8. 在安装完成荧屏上单击完成。
父主题
单机安装的管理
相关概念
升级到新的发行版
产品共存规则
相关任务
修复安装
将单机安装退回到先前的 Service Pack
删除安装


修复安装

如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

但是，要修复安装，您的机器必须在其原始安装位置应用来自先前安装的所有源文件和所有 service pack。

您可修复单机安装。您无法修复管理映像，您必须卸装然后重新安装管理映像。
  1. 在 Windows 7 或更高版本中，单击开始 > 控制面板 >程序 >程序和功能。
  2. 选择您要修复的 SOLIDWORKS 版本，然后单击 更改。
  3. 在欢迎使用 SOLIDWORKS 安装管理程序屏幕上单击 修复单机安装（此计算机上）。
  4. 在要修复的产品 屏幕中，选择要修复的产品。
  5. 清除屏幕上的其它产品。
  6. 单击修复。
父主题
单机安装的管理
父主题
安装错误/安装已取消
相关概念
升级到新的发行版
产品共存规则
相关任务
修改安装
将单机安装退回到先前的 Service Pack
删除安装
恢复失败或取消的安装
请与 SOLIDWORKS 转售商联系


将单机安装退回到先前的 Service Pack

若要将单机安装退回到当前主要版本系列中先前的 Service Pack，请卸载计算机上当前安装的 service pack 版本，然后重新安装先前的版本。
父主题
单机安装的管理
相关概念
升级到新的发行版
产品共存规则
相关任务
修改安装
修复安装
删除安装


删除安装

您可以在单台计算机或在服务器/客户端环境中删除安装。

  1. 确认无激活的 SOLIDWORKS 进程。
  2. 如果您想将 SOLIDWORKS 许可转移到另一台计算机，请在此计算机上删除 SOLIDWORKS 安装之前将许可转移到该计算机。

    有关更多信息，请参阅转移许可。

  3. 在 Windows 7 或以后版本中，启动控制面板 > 程序和功能。
  4. 选定要移除的产品部件。

    在某些情况下，您可能会发现给定的主要版本的多个 SOLIDWORKS Service Pack 组件。 要移除 SOLIDWORKS 主要发行版本，移除该主要版本的所有 Service Pack 单元。

  5. 在卸装荧屏上：
    1. 选定要移除的产品。默认会选中所有产品组件。
    2. 消除您不想移除的产品。
    3. 选择是否进行自定义或完整卸装。 默认情况下，SOLIDWORKS 安装管理程序进行标准卸载并移除程序文件和文件夹。

      1. 在高级选项中单击更改。

        高级选项 屏幕出现，并且已选定“程序文件和文件夹”选项。

      2. 选取一个或多个选项进行自定义卸载，或者选取所有选项进行完整卸载。
      3. 单击返回到摘要。
      4. 在摘要荧屏上扩展高级选项显示卸装方法和条目。

    4. 单击移除项目。
父主题
单机安装的管理
父主题
多个安装的管理
相关概念
升级到新的发行版
产品共存规则
将管理映像升级到新的发行版
Service Pack 产品更新管理
相关任务
修改安装
修复安装
将单机安装退回到先前的 Service Pack
转移许可


升级到新的发行版

可使用多种方法将单机安装升级到新的 SOLIDWORKS 发行版。

您可在下列情况下升级到新版本：
  • 收到新的安装介质
  • 启动 SOLIDWORKS 时收到升级通知
  • 手动检查更新
  • 启动 SOLIDWORKS 安装管理程序的新实例

当安装新的主要版本时，可选择升级之前安装的主要版本或者同时安装新发行版。如果是为之前安装的主要版本安装 Service Pack 发行版，则会自动更新该发行版。

父主题
单机安装的管理
相关概念
产品共存规则
相关任务
修改安装
修复安装
将单机安装退回到先前的 Service Pack
删除安装

手动检查更新

可用下列方法之一为当前安装的 SOLIDWORKS 发行版检查更新。

  • 在 SOLIDWORKS 中单击帮助 > 检查更新。
  • 在 Microsoft Windows 中，单击开始 > 所有程序 > SOLIDWORKS 安装管理程序 > 检查更新。

升级 Workgroup PDM 客户端

Workgroup PDM 客户端可检测到库何时被更新。您不必下载 service pack 便能更新客户端。

有关说明，请参阅Workgroup PDM 联机帮助中的更新客户端。

升级注意事项

可具有多个不同主要版本安装的产品并不始终支持主要升级，也不支持通过一次操作在主要版本之间进行升级的功能。

在此情况下，SOLIDWORKS 安装管理程序通过首先安装新版本，然后移除旧版本来模拟升级。 此时，核心 SOLIDWORKS 产品支持主要升级，而其他产品则不能。

此举的后果为：
  • 当在主要版本之间升级核心 SOLIDWORKS 产品时：
    • 您的现有安装位置不改变。
    • 如果在升级过程中发生错误或者您取消操作，则升级可退回。
  • 当在主要版本之间升级其它产品时：
    • 每个产品先作为新产品安装到新的位置，然后再删除原有安装。
    • 一旦开始，如果在升级过程中发生错误或者您取消操作，则升级不可退回。


产品共存规则

以下产品共存规则决定新产品如何安装及现有产品如何升级。

规则 | 示例
允许一个核心 SOLIDWORKS 产品的多个主要发行版本共存，但下述产品除外。 | SOLIDWORKS 2015 SP3.0 和 SOLIDWORKS 2016 SP0.0 可以在同一台计算机上共存。
不允许同一主要发行版本的多个 service pack 共存。 | SOLIDWORKS 2016 SP0.0 和 2016 SP1.0 不能在同一台计算机上共存。 如果您在已安装有 SOLIDWORKS 2016 SP0.0 的计算机上安装 SOLIDWORKS 2016 SP1.0，SOLIDWORKS 安装管理程序会将 SP0.0 替换为 SP1.0。
以下产品在计算机上只允许有一个版本：
  • Workgroup PDM Server
  • SolidNetWork 许可管理器
 如果安装了 SOLIDWORKS 2016 SP0.0，则 Workgroup PDM Server 将升级到 2016 SP0.0，即使计算机上仍留有 SOLIDWORKS 的早期主要发行版本。
以下产品在计算机上只允许有一个版本：
  • SOLIDWORKS PDM 客户端
  • SOLIDWORKS PDM 服务器

如果您安装 SOLIDWORKS 2016 SP0.0 或 SP1.0，您也应升级到 SOLIDWORKS 2016 PDM 服务器和 PDM 客户端。

如果您安装 SOLIDWORKS 2016 PDM 服务器，您应使用 PDM 服务器安装流程来安装 SOLIDWORKS PDM 客户端。 不要使用客户端安装流程单独安装 SOLIDWORKS PDM 客户端。

SOLIDWORKS PDM 客户端必须与同一计算机上的 SOLIDWORKS PDM 服务器具有相同的发行版本和 service pack。

有关详细信息，请参阅使用 SLDIM 安装 PDM 服务器主题。

SOLIDWORKS 的任何主要发行版本只可安装所包括产品的一个版本。 但是，来自不同 SOLIDWORKS 主要发行版本的所包括产品的各个版本可以共存。 | 如果将 SOLIDWORKS 2016 SP0.0 升级到 2016 SP1.0，则 SOLIDWORKS Explorer 2016 SP0.0 也会自动升级到 2016 SP1.0。但是，SOLIDWORKS Explorer 2015 SP4.0 可与 SOLIDWORKS Explorer 2016 SP0.0 或 SOLIDWORKS Explorer 2016 SP1.0 共存。
您必须具有管理权限才能在同一计算机上运行多个主要版本的 SOLIDWORKS。
父主题
单机安装的管理
相关概念
升级到新的发行版
相关任务
修改安装
修复安装
将单机安装退回到先前的 Service Pack
删除安装


多个安装

内容

  • 调用到多个客户端

    您可通过创建管理映像并将安装部署到客户端以在多个客户端上安装 SOLIDWORKS 产品。

  • 使用管理映像

    管理映像可用于从单一网络位置进行 SOLIDWORKS 产品的可配置安装。

  • 通过电子邮件将管理映像调用到客户端

    一旦创建好共享管理映像目录后，即可通过电子邮件通知客户端。

  • 命令行调用

    您可使用命令提示符/批处理文件自动调用管理映像（无声安装）。

  • 多个安装的管理

    多个安装的管理任务包括将管理映像升级到新发行版、应用 service pack 更新以及删除安装。


调用到多个客户端

您可通过创建管理映像并将安装部署到客户端以在多个客户端上安装 SOLIDWORKS 产品。

调用到多个客户端的过程为：
  1. 创建管理映像。
    • 从 SOLIDWORKS 安装管理程序创建管理映像
  2. 将管理映像调用到客户端。
    • 通过电子邮件将管理映像调用到客户端
    • 通过命令行从管理映像安装
  3. 实施许可。
    • 管理个人许可
    • 使用 SolidNetWork 许可管理器管理许可
如果您正在运行 Windows 8，则请参阅在 Microsoft Windows 8 中使用 SOLIDWORKS 提示以进行以下任务，如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 参阅 Microsoft Windows 文档了解其他说明和选项。
父主题
多个安装
相关概念
使用管理映像
通过电子邮件将管理映像调用到客户端
命令行调用
多个安装的管理
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示


使用管理映像

管理映像可用于从单一网络位置进行 SOLIDWORKS 产品的可配置安装。

您可从网络上的任何计算机安装管理映像，包括客户端计算机。
  • 管理映像必须位于共享文件夹中。
  • 如果您包括所有产品，则管理映像磁盘空间可占用 7GB 或更多。
  • 如果在升级管理映像时更新共享名称，则在应用程序下次启动时客户端会自动升级。 详细信息请参阅从管理映像升级客户端。
  • 要求客户端在其计算机上具有管理员特权。 如果客户不具备充足的权限，可使用其它方法安装映像。

生成管理映像后，管理映像选项编辑器可以为从该映像进行安装的用户和组管理安装选项设置。 有关详细信息，请参阅管理映像选项编辑器。

内容

  • 从 SOLIDWORKS 安装管理程序创建管理映像

    如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

父主题
多个安装
相关概念
调用到多个客户端
通过电子邮件将管理映像调用到客户端
命令行调用
多个安装的管理
从管理映像升级客户端
管理映像选项编辑器


从 SOLIDWORKS 安装管理程序创建管理映像

如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

  1. 启动 SOLIDWORKS 安装管理器。 请参阅初始化 SOLIDWORKS 安装。
  2. 在 欢迎 屏幕上，选择 管理映像。

    将显示管理映像生成选项。

    选项 | 描述
    使用默认设定生成新映像。 | 使用默认配置设定生成映像（也就是说，不依据当前为您站点的现有管理映像建立的设定来生成映像）。
    使用现有映像的设定和文件生成新映像。 | 使用为您站点的现有管理映像指定的配置设定生成映像。 单击 浏览，为现有管理映像指定安装目录。
  3. 按照屏幕上的说明操作。

内容

  • 管理映像选项编辑器

    使用管理映像选项编辑器可以在管理映像中为机器组和单机自定义安装参数设定。

父主题
使用管理映像
相关任务
启动 SOLIDWORKS 安装


管理映像选项编辑器

使用管理映像选项编辑器可以在管理映像中为机器组和单机自定义安装参数设定。

创建管理映像后，SOLIDWORKS 安装管理程序会要求您启动选项编辑器。 您也可通过在管理映像文件夹中双击 sldAdminOptionEditor.exe 开启选项编辑器。

要为机器组或单机指定不同的安装配置，在选项编辑器中按机器名称、IP 地址或 IP 地址范围选择机器，然后指定这些机器的安装选项。

所有提示文件或文件夹路径的对话框都包括一个选项，您可以在其中将选定文件夹分配到环境变量。 例如，如果您选择 C:\Program Files\SOLIDWORKS Corp，则文件路径会被映射到 %ProgramFiles%\SOLIDWORKS Corp。 最常见的变量为 %ProgramFiles% 和 %SystemDrive%。

您无法将所有路径都转换为环境变量。 例如，Z:\SOLIDWORKS Data 无法映射到相应的环境变量。

内容

  • 添加和删除组和机器

    使用管理映像选项编辑器可以为机器组和单机指定不同的安装配置。

  • 查看和编辑选项设置

    SOLIDWORKS 管理映像选项编辑器可以查看和更改为映像指定的组和机器的选项设置。

  • 从选项编辑器调用安装

    您可以使用电子邮件指示直接从“选项编辑器”部署安装以开始安装。

  • 退出选项编辑器

    您可单击“确定”或“关闭”退出选项编辑器。

  • 为选项编辑器生成桌面快捷方式

    您可以为选项编辑器创建 Windows 桌面快捷方式，用于来自应用程序内的特定管理映像。

父主题
从 SOLIDWORKS 安装管理程序创建管理映像


添加和删除组和机器

使用管理映像选项编辑器可以为机器组和单机指定不同的安装配置。

例如，您可能希望将某几台机器配置为使用映像中可用产品组件的一个特定子集，而将另一个组配置为使用产品组件的另一个子集。尽管使用的是同一个管理映像，选项编辑器组设定使您可为不同的机器组安装不同的产品子集。

要添加组：
  1. 右键单击全局设置，然后单击添加组。
  2. 输入组名称。

要添加机器：
  1. 右键单击一个现有组或全局设置，然后单击添加机器。
    如果右键单击现有的组，则会将机器添加到该组中。 否则会将机器添加到顶层。
  2. 执行以下其中一项操作：
    • 选择按机器名称，然后输入一个或多个机器名称。 如果有多台机器，可以使用换行符、空格、制表符、逗号、冒号或分号来分隔。 您可以从外部文件中复制并粘贴一份机器名称列表。 机器名称不能包含域限定词。 例如 pluto.solidworks.com 是无效的。
    • 选择按 IP 地址，然后输入机器的 IP 地址。
    • 选择按 IP 地址范围，然后输入范围的起始 IP 地址和结束 IP 地址。
    • 单击添加多台机器从网络中选择机器。

要将现有机器移动到组中：

将机器拖动到组上。

要将机器从组中移出：

将机器拖动到全局设定上或其它组上。

要删除组或机器：

右键单击组或机器，然后单击删除组或删除机器。

如果删除组，则组中的所有机器将一并删除。

要删除所有组和机器：

右键单击全局设置，然后单击删除所有。

父主题
管理映像选项编辑器
相关概念
从选项编辑器调用安装
相关任务
退出选项编辑器
为选项编辑器生成桌面快捷方式
相关参考
查看和编辑选项设置


查看和编辑选项设置

SOLIDWORKS 管理映像选项编辑器可以查看和更改为映像指定的组和机器的选项设置。

  • 初次启动选项编辑器时，选项设置以只读模式显示。 编辑图标未上色。

    单击全局设置，组或机器将显示该项目的选项设置摘要：

    范围 | 显示的选项设置
    整体设定 | 为管理映像指定的所有选项设置
    组 | 与整体设定有关的组设置中的更改
    机床 | 与组有关的机器设置中的更改
  • 要对选项设置进行更改，请单击编辑图标。 该图标将上色并且显示更详细的选项设置列表。

    单击全局设置，组或机器让您可以更改该项目的选项设置。 当您对选项设置的更改不同于继承的全局设置或组设置时，该选项设置将高亮显示。

    如果您再次单击编辑图标，则显示将恢复为只读模式。

    如果进行了更改，则选项编辑器会在退出时提示您保存或放弃更改。

内容

  • 指定组和机器的选项设置

    您可以为所有机器（整体设定）、机器组及单机指定选项设定。

  • 管理映像选项设置

    选项编辑器可让您为单独客户端或组指定选项设定，包括序列号、客户端安装选项、要安装哪些软件部件、及 Toolbox 位置。

  • 继承整体和组选项设置

    整体设定或组的选项设置由其下的项目继承。

  • 每个机器的自定义设置

    您还可以通过右键单击机器名称来修改已应用到特定机器的设置。

父主题
管理映像选项编辑器
相关概念
添加和删除组和机器
从选项编辑器调用安装
相关任务
退出选项编辑器
为选项编辑器生成桌面快捷方式


指定组和机器的选项设置

您可以为所有机器（整体设定）、机器组及单机指定选项设定。

  1. 在选项编辑器中，单击要修改的对象（全局设置、一个组或一台机器）。
  2. 在右方，单击“编辑”图标。

    “编辑”图标将上色并且显示更详细的选项设置列表。

  3. 在列表左侧选择条目，然后单击右侧的选项设定做出相应更改。

    选项设定中覆盖全局设置或组设置的更改将高亮显示。

  4. 单击确定或关闭以保存您的更改。
    选项 | 描述
    确定 | 选项编辑器保存您的更改并退出。
    关闭 | 选项编辑器将会询问您是否要保存所作的更改并退出。
父主题
查看和编辑选项设置
相关概念
继承整体和组选项设置
每个机器的自定义设置
相关参考
管理映像选项设置


管理映像选项设置

选项编辑器可让您为单独客户端或组指定选项设定，包括序列号、客户端安装选项、要安装哪些软件部件、及 Toolbox 位置。

序列号

输入要在客户端计算机上安装的产品的序列号。
由于有多种办法购买 SOLIDWORKS 产品，有些序列号可覆盖两个或多个产品。 例如，SOLIDWORKS 序列号可让您在安装 SOLIDWORKS Simulation 时不必输入单独的 SOLIDWORKS Simulation 序列号。 此外，有些产品不需要序列号。 如果您对序列号有疑问，请与您的经销商联系。
如果您使用 SolidNetWork 许可管理许可：
  • 在第一个序列号字段中，输入 SolidNetWork 序列号。
  • 在 SNL Server port@server 字段中，输入 SolidNetWork 许可管理器服务器名和端口，格式为 nnnnn@servername。 使用分号分隔多个条目。

有关 SolidNetWork 许可的详细信息，请参阅安装和配置 SolidNetWork 许可。

客户端安装选项

您想如何进行主要版本的客户端安装? 您可以指定客户端安装如何处理之前已有的主要版本：
  • 升级现有主要版本(如果有)。

    指定此选项可使用新版本安装替换之前的主要版本安装

  • 创建新的主要版本。

    指定此选项以保留之前的主要版本，并为新主要版本重新创建安装。 要指定新版本安装位置，请单击浏览。
您想在安装新主要版本之前卸装最新先前版本吗? 您可指定是否在安装主要版本之前卸装现有版本：
  • 不，不要先卸装。

    指定此选项以保留先前主要版本的安装。

  • 是，执行自定义卸装。

    选取此选项以移除这些项目： 程序文件和文件夹、注册表项、数据文件和文件夹。

您想如何应用 SOLIDWORKS 设定？ 您可以指定客户端安装基于客户端计算机上配置的 SOLIDWORKS 设置或从复制设定向导输出的 SOLIDWORKS 设置来配置 SOLIDWORKS 设置。 复制设定向导保存、恢复并延伸系统设定到用户、计算机或轮廓。
您可以从 SOLIDWORKS 软件中的 启动 > 复制设置向导 启动 工具，或单击 开始 > 所有程序 > SOLIDWORKS 版本 > SOLIDWORKS 工具 > 复制设置向导 [image] 。
依次选择工具 > 保存/恢复设定可在特定模式下运行复制设置向导，这使 SOLIDWORKS 软件能够保持工作和运行，同时您也能够保存或恢复当前的用户设置。
  • 使用当前设置（如果存在）或者使用 SOLIDWORKS 默认设置

    如果客户端计算机已定义 SOLIDWORKS 设置，请保留这些设置。 （对于未在客户端上特别定义的任何设置，客户端安装将使用默认的 SOLIDWORKS 设置。）

  • 使用从复制设定向导所输出的设置文件。

    选择此选项设定可让您从现有复制设定向导导出文件指定选项设定。 （通常情况下，该文件名为 solidworkssettings.sldreg。）单击浏览以找到现有的设定文件，或者单击新建以启动复制设定向导，从而创建一个新的设定文件。

    有关详细信息，请参阅 SOLIDWORKS 帮助。
您想如何激活客户端安装? 您可以指定是在运行安装后自动完成产品激活，还是要求用户在安装后手工进行产品激活。
如果您指定产品自动激活，则管理映像必须在客户端于安装后第一次运行 SOLIDWORKS 时可通过共享网路位置而可供使用。 如果管理映像不可为从该映像进行安装的客户端使用，则这些客户端将无法完成产品自动激活。 它们将无法运行 SOLIDWORKS，除非手动运行 SOLIDWORKS 产品激活。
  • 在每个客户端安装完成时自动激活。

    选择该选项设定指定产品激活使用 SOLIDWORKS 产品激活文件自动运行。 （通常，此文件命名为 AutoActivation.xml。） 单击 浏览 以查找现有激活文件，或 新建 启动 SOLIDWORKS 产品激活以创建新的激活文件。

  • 不自动激活。

    选择该选项设定指定无自动产品激活发生。 客户端用户在安装后进行产品激活。

管理选项

在每次安装过程中生成诊断日志。 | 客户端安装可创建可用于安装问题故障排除的诊断日志。 创建此日志可能会使客户端安装的运行变慢。
以不同用户运行安装。 | 如果禁用了用户帐户控制 (UAC)，则客户端安装可以其他用户的身份运行。 当单个用户在其计算机上没有本地管理权限（安装 SOLIDWORKS 产品所需的权限）时，此选项可能非常有用。 当客户端不具有管理权限时，则可使用另一部署和安装方法。 请参阅从选项编辑器调用安装。
安装之前或之后运行程序。 | 您可以指定自定义程序在客户端安装之前或之后运行。
您想要客户端参与 SOLIDWORKS 客户经历计划吗？ | 您可以指定客户端计算机参与 SOLIDWORKS 客户体验计划。 性能信息将发送到 SOLIDWORKS Corporation 以帮助改进产品。 此过程是透明并且保密的。 有关详细信息，请参阅 客户经历改进计划网站：

在安装之前和之后运行程序的限制

这些选项使您可以在部署 SOLIDWORKS 之前和之后在客户端机器上运行其他安装程序或脚本，例如安装 Microsoft Office 的脚本。

如果您自动部署到 Windows 8 客户端机器，则限制对这些选项的使用限制。 如果您使用任一选项部署显示用户界面的安装程序或脚本时出现故障，例如显示对话框的脚本。 SOLIDWORKS 的自动部署运行时，无法在目标机器上安装 SOLIDWORKS。 对于 Windows 7 客户端机器，无此限制。

要使用在安装之前运行程序和在安装之后运行程序选项，您应该仅选择以无声模式安装的程序。

要安装的软件

您可以指定要安装的 SOLIDWORKS 产品组件。
  • 选中产品组件旁的复选框可指定在客户端安装过程中安装该组件。
  • 清除复选框指定不安装该组件。
  • 如果一个组件内含有可选安装子组件，则该组件旁会出现一个 + 图标。 要查看一个组件的可用子组件，请单击 + 图标。
  • 如果扩展一个组件以显示可选子组件，则该组件旁会显示一个 - 图标。 要折叠子组件列表，请单击 - 图标。
语言 规格只限制为 SOLIDWORKS 产品所安装的语种。 其它产品安装不受该规范影响。 例如，eDrawings®、SOLIDWORKS Workgroup PDM 和 SOLIDWORKS Explorer 将安装所有语种。

Toolbox 选项

您可以为客户端安装指定支持哪些标准及默认 Toolbox 位置。

多个用户访问 Toolbox 的情况很常见，这些访问通常是通过网络位置（例如，UNC 路径、共享文件夹或通用网络驱动器规范）进行的。

如果该位置包含较旧主要版本的 Toolbox，则客户端安装会将该 Toolbox 升级到新的主要版本。 这些文件将不再与之前主要版本的 SOLIDWORKS 兼容。
如果您想要保留用于较旧 SOLIDWORKS 版本的 Toolbox（例如，如果某些客户端可能继续使用较旧的版本），则必须为升级到较新版本的客户端指定不同的 Toolbox 网络位置。

有关 SOLIDWORKS Toolbox 管理的详细信息，请参阅 SOLIDWORKS 帮助中的 SolidWorks 帮助 信息。

SOLIDWORKS PDM 客户端选项

您可选择以下选项来部署 SOLIDWORKS PDM 客户端和插件：

  • PDM 产品类型
  • PDM 客户端类型
  • 特征

请参阅 SOLIDWORKS PDM 部分了解有关这些客户端和插件的更多信息。

Electrical 选项

您可以为 SOLIDWORKS Electrical 的管理组件指定以下参数：
  • 数据路径
  • 协作服务器机器名称和端口号
  • SQL 服务器机器名称和密码

请参阅 SOLIDWORKS Electrical 部分了解有关这些组件的更多信息。

父主题
查看和编辑选项设置
相关概念
继承整体和组选项设置
每个机器的自定义设置
安装和配置 SolidNetWork 许可
从选项编辑器调用安装
SOLIDWORKS Electrical
相关任务
指定组和机器的选项设置


继承整体和组选项设置

整体设定或组的选项设置由其下的项目继承。

例如：
  • 为整体设定定义的设置会被所有组和机器继承。
  • 为组定义的设置会被该组中的所有机器继承。

您可以更改机器或组的选项设置以覆盖默认的或继承的设置。当更改选项设置的默认值或继承值后，该选项将高亮显示。

要将选项设置恢复为原始继承值，请右键单击组或机器，然后单击恢复到整体设定（用于不属于组成员的组或机器）或恢复到组设置（用于属于组成员的机器）。
父主题
查看和编辑选项设置
相关概念
每个机器的自定义设置
相关任务
指定组和机器的选项设置
相关参考
管理映像选项设置


每个机器的自定义设置

您还可以通过右键单击机器名称来修改已应用到特定机器的设置。

从快捷键菜单中，您可以为每个机器执行以下任务：
  • 从编辑器选择删除机器
  • 恢复到整体设定
  • 添加或编辑注释
  • 编辑选项

编辑选项允许您修改机器的所有选项，如客户端安装选项和管理选项。

父主题
查看和编辑选项设置
相关概念
继承整体和组选项设置
相关任务
指定组和机器的选项设置
相关参考
管理映像选项设置


从选项编辑器调用安装

您可以使用电子邮件指示直接从“选项编辑器”部署安装以开始安装。

  • 使用“选项编辑器”的“手动部署”页面，向用户发送有关如何开始安装的指示电子邮件。 当用户拥有其客户端机器的管理权限时，请使用此种方法。
  • 使用“选项编辑器”的“自动部署”页面自动推送安装至目标机器。 您还可以执行自定义卸载。 如果用户不具有在自己系统上安装软件的管理权限，则可使用此方法。

要使用任一方法，您必须将管理映像安装目录更改为 Windows 共享目录，以便可通过网络位置（例如， \\machine\shared_directory 或将整个图像复制到每台机器的本地目录上，例如 C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0）。

内容

  • 使用映射的驱动器调用管理映像

    UNC 路径 (\\machine_name\share_name) 是指定管理映像安装目录网络位置的建议方法。不过，您可以使用映射的驱动器作为管理映像中 StartSWInstall.hta 文件的位置（例如，U:\StartSWInstall.hta），只要安装用户都将同一驱动器盘符映射到管理映像共享目录即可。

  • 使用 StartSWInstall.exe 调用管理映像

  • 手动部署

    如果用户具有在自己系统中安装的权限，则可使用此方法。

  • 自动部署的先决条件

    使用自动部署，安装任务将被推送到目标计算机，并由各系统上的 Microsoft 任务计划程序执行，无需用户进行任何操作。 如果用户不具有在自己系统上安装软件的管理权限，则可使用此方法。

  • 自动部署

父主题
管理映像选项编辑器
相关概念
添加和删除组和机器
相关任务
退出选项编辑器
为选项编辑器生成桌面快捷方式
相关参考
查看和编辑选项设置


使用映射的驱动器调用管理映像

UNC 路径 (\\machine_name\share_name) 是指定管理映像安装目录网络位置的建议方法。不过，您可以使用映射的驱动器作为管理映像中 StartSWInstall.hta 文件的位置（例如，U:\StartSWInstall.hta），只要安装用户都将同一驱动器盘符映射到管理映像共享目录即可。

例如，如果您将 U: 驱动器映射到管理映像共享目录，则通知电子邮件将指导用户单击指向 file://U:\StartSWIOnstall.hta 的链接。只要 U: 驱动器映射到管理映像的 UNC 位置 (\\machine_name\share_name)，收到电子邮件的用户就能够成功安装。

父主题
从选项编辑器调用安装


使用 StartSWInstall.exe 调用管理映像

您可以通过运行命令 admin_image_install_dir\StartSWInstall.exe，安装或卸装客户端上的管理映像。 此方法使用管理映像选项编辑器中定义的选项、机器和组安装 SOLIDWORKS。

您可以将以下开关附加至 StartSWInstall.exe 命令：
/安装 | 在客户端机器上安装管理映像。
/卸装 通过两个可选开关从客户端机器上卸装软件：

/removedata

只适用于卸装。 卸装期间删除 SOLIDWORKS 数据文件和文件夹。

/removeregistry

只适用于卸装。 卸装期间删除 SOLIDWORKS 注册表条目。
/showui | 显示 SOLIDWORKS 安装管理程序的进展窗口。 否则 SOLIDWORKS 安装管理窗口将对用户隐藏。
/现在 | 立即启动安装或卸装。 5 分钟警告对话框未出现。

如果您希望在安装过程中没有任何用户交互，但不想使用管理映像选项编辑器中的自动部署时，推荐使用 StartSWInstall.exe，而非 StartSWInstall.hta。

父主题
从选项编辑器调用安装


手动部署

如果用户具有在自己系统中安装的权限，则可使用此方法。

要使用电子邮件手动部署安装：

  1. 在“选项编辑器”中，单击部署。

    此时将显示每个计算机的安装可用性和状态。

  2. 单击发送电子邮件。
  3. 指定管理映像安装目录的网络路径。

    通常，管理映像安装目录的目录路径最初显示为 Windows 文件路径（如 C:\SOLIDWORKS Admin\SOLIDWORKS 2015 SP0）。 此对话框表示 该路径不是网络路径。

    1. 单击浏览指定此管理映像安装目录的网络位置。
    2. 导航至安装管理映像的计算机，然后选择指定用于管理映像安装目录的 Windows 共享目录。

      请不要在管理映像共享目录内部导航（例如，进入 64bit 子目录）。

    3. 单击确定。

      对话框将指示该路径是网络路径。

    此时将创建一封电子邮件，指导计算机所有者如何使用管理映像中 StartSWInstall.hta 文件的网络位置从管理映像进行安装。

  4. 该电子邮件将发送给负责安装 SOLIDWORKS 的用户。

用户可双击电子邮件中 StartSWInstall.hta 网络位置的链接，从管理映像安装 SOLIDWORKS。

在选项编辑器中，安装状态 显示：
待定 | 用户尚未在此计算机上运行安装。
成功 | 用户已在此计算机上成功完成安装。
已失败 | 用户在此计算机上运行了安装，但安装失败。

可能显示的其他状态信息为： 安装成功、卸载成功、安装、卸载、需要重新启动、安装失败、卸载失败。

父主题
从选项编辑器调用安装


自动部署的先决条件

使用自动部署，安装任务将被推送到目标计算机，并由各系统上的 Microsoft 任务计划程序执行，无需用户进行任何操作。 如果用户不具有在自己系统上安装软件的管理权限，则可使用此方法。

推送安装时，Task Scheduler 启动 SOLIDWORKS 安装管理程序以在您（即管理员）指定的凭证下运行。 Task Scheduler 将在计算机的本地系统帐户下运行。 此帐户将在网络上显示为计算机安全基本账户。 计算机安全基本账户必须具有管理映像所在的 共享文件夹 的读取访问权限。

在 Active Directory 中，当您将计算机添加到共享文件夹组时，选择对象类型并确保选定计算机。

此外，服务管理映像和目标客户端计算机的计算机必须是同一个 Active Directory 域的成员。

父主题
从选项编辑器调用安装


自动部署

要通过推送安装至用户系统的方法自动部署：

  1. 在“选项编辑器”中，单击自动部署选项卡。

    此时将显示每个计算机的安装可用性和状态。

  2. 在 部署 列下的部署列中选择目标客户端计算机和组。

    初始化部署过程前，您必须在部署列下选择一个或多个计算机或组。

  3. 在安装时间下选择现在来立即部署，或选择稍后以排定部署的特定日期和时间。
  4. 在客户端选项下，选择以下：
    • 安装或升级 SOLIDWORKS 2015
    • 卸载 SOLIDWORKS 2015
      如果选择卸载，您可指定卸载程序文件和文件夹时是否卸载注册表条目和数据文件以及文件夹。
  5. 如果希望目标机器在部署完成时重新启动，可选择自动重启计算机。
  6. 输入目标机器的客户端凭据。
  7. 单击部署以初始化部署流程。
在“选项编辑器”中，安装状态显示为：
待定 | 尚未在此计算机上运行安装。
成功 | 已在此计算机上成功完成安装。
已失败 | 此计算机上安装失败。

可能显示的其他状态信息为： 安装成功、卸载成功、正在计划、正在连接、正在安装、正在卸载、需要重新启动、按计划安装、按计划卸载、安装失败、卸载失败、连接失败、计划失败。

父主题
从选项编辑器调用安装


退出选项编辑器

您可单击“确定”或“关闭”退出选项编辑器。

  • 单击确定、关闭或使用 Windows 应用程序的关闭按钮应用更改并退出选项编辑器。
    • 单击确定应用任何选项设置更改并退出选项编辑器。
    • 单击关闭退出选项编辑器。

      如果有要应用的更改，系统将询问您是否要保存这些更改。

    • 单击 Windows 应用程序的关闭按钮 (X)。如果有要应用的更改，系统将询问您是否要保存这些更改。
父主题
管理映像选项编辑器
相关概念
添加和删除组和机器
从选项编辑器调用安装
相关任务
为选项编辑器生成桌面快捷方式
相关参考
查看和编辑选项设置


为选项编辑器生成桌面快捷方式

您可以为选项编辑器创建 Windows 桌面快捷方式，用于来自应用程序内的特定管理映像。

  1. 启动选项编辑器。

    例如，在 Windows 资源管理器中，导航至管理映像安装目录并双击 sldAdminOptionEditor.exe。

  2. 单击为该选项编辑器生成桌面快捷方式。

    Windows 桌面上将出现管理映像选项编辑器的快捷方式。

父主题
管理映像选项编辑器
相关概念
添加和删除组和机器
从选项编辑器调用安装
相关任务
退出选项编辑器
相关参考
查看和编辑选项设置


通过电子邮件将管理映像调用到客户端

一旦创建好共享管理映像目录后，即可通过电子邮件通知客户端。

在一台可供其它计算机访问（例如通过 UNC 路径）的机器上将管理映像目录配置为共享。

可向所有客户端发送包含指向 管理映像安装目录\StartSWInstall.hta 的链接的电子邮件。 客户端然后可单击该链接并接着单击现在安装 SOLIDWORKS 产品来开始从管理映像进行安装。

如果您正将管理映像升级到新的 SOLIDWORKS 版本，则可以配置您的管理映像位置和共享属性，这样所有使用该映像的先前安装的客户端将自动升级。 详细信息请参阅从管理映像升级客户端。
父主题
多个安装
相关概念
调用到多个客户端
使用管理映像
命令行调用
多个安装的管理
从管理映像升级客户端


命令行调用

您可使用命令提示符/批处理文件自动调用管理映像（无声安装）。

要使用命令行为 SOLIDWORKS PDM 客户端部署管理映像，请参阅 SOLIDWORKS PDM 安装指南。

内容

  • 准备客户端以便通过命令行从管理映像进行安装

    创建管理映像后，在通知客户端之前，您必须安装无法通过使用命令行或 Microsoft Active Directory 创建的管理映像来安装的 Microsoft Windows 组件。

  • 通过命令行从管理映像安装

    您可以通过命令行从管理映像调用安装。

  • 命令行属性

    此处所述的命令行属性包括特征属性、全局属性、产品特定的属性和 Windows 位置约定。

  • 使用 Microsoft Active Directory 调用管理映像

    Microsoft Active Directory Deployment 在为客户端调用核心 SOLIDWORKS 产品时受支持。

  • 使用 Microsoft Active Directory 安装 Windows 必备组件

    按照下列流程准备一个用于通过 Microsoft Windows Active Directory 将 SOLIDWORKS 安装到客户端计算机上的现有管理映像。

父主题
多个安装
相关概念
调用到多个客户端
使用管理映像
通过电子邮件将管理映像调用到客户端
多个安装的管理


准备客户端以便通过命令行从管理映像进行安装

创建管理映像后，在通知客户端之前，您必须安装无法通过使用命令行或 Microsoft Active Directory 创建的管理映像来安装的 Microsoft Windows 组件。

只有在从使用命令行或 Microsoft Active Directory 的管理映像安装时，才需要手动安装这些 Windows 组件。 如果您使用 SOLIDWORKS 安装管理程序创建和安装管理映像，则会自动安装这些 Windows 组件。
下面总结了 Windows 组件中 SOLIDWORKS 所需的文件：
Office Web 组件 | 包含 DriveWorks 所需的 COM 控件。
Visual C++ 2005、2008、2010 和 2012 可重新分发软件包 | 包含 Microsoft Visual C++ 运行时组件。 必须安装 2005、2008、2010 和 2012 版本。
Visual Basic for Applications 7.1 | 提供对 Visual Basic 宏的支持。
应用程序的 Visual Studio 工具 | 包含支持 Visual Studio 应用程序的工具集。 SOLIDWORKS 2013 之前的版本可选择安装 Microsoft Visual Studio Tools for Applications (VSTA)。 VSTA 是否安装，具体取决于您计算机上安装的 Microsoft .NET Framework 3.5。 对于 Windows 7 及更新的版本而言，.NET Framework 是操作系统的一项功能。 如果您需要安装 .NET Framework 3.5，则可在 Windows Media 和英特网上找到。 如果您找不到 Windows 媒体、不能联网，或者不具有在您计算机上安装 Microsoft .NET Framework 3.5 的权限，请联系计算机管理员以寻求帮助。
Visual Studio 远程调试器 | 为 64 位操作系统提供调试环境。
.NET Framework 4.5 | 包含有普通语言运行时间和运行 .NET Framework 4.5 应用程序所需的 .NET Framework 组件。
Windows 的 Bonjour 服务 | 能够识别局域网上进行的服务。
所有 SOLIDWORKS 产品（并非只是核心 SOLIDWORKS 产品），均要求有 Visual C++ 可重新分发软件包和 .NET Framework 4.5。

这些组件必须包括在管理映像目录的子目录中。

下表标示了每种受支持操作系统所需的特定文件。
操作系统： Windows Server 2008 R2 64 位 SOLIDWORKS 媒体： 用于 Windows 7 的 64 位版本
SOLIDWORKS PDM 服务器、Workgroup PDM Server 和 SOLIDWORKS SolidNetWork License Manager 支持在 Windows Server 2008 R2 或 Windows Server 2012 及 2012 R2 上的安装。
Windows Installer： | （不适用）
Office Web 组件： | owc11.exe
Visual C++ 2005 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2008 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2010 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2012 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
应用程序的 Visual Studio 工具： (可选) | vsta_aide.msi
如果安装了 VSTA，则需安装 .NET 3.5 Framework (dotnetfx35.exe)。 对于 Windows 7 而言，.NET Framework 3.5 是操作系统的一项功能。
Visual Studio 远程调试器： | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5： | .netfx45_full_x86_x64.exe
Windows 的 Bonjour 服务： | bonjour64.msi
操作系统: Windows Server 2012 和 2012 R2 64 位 SOLIDWORKS 媒体： 用于 Windows 7 的 64 位版本
SOLIDWORKS PDM 服务器、Workgroup PDM Server 和 SOLIDWORKS SolidNetWork License Manager 支持在 Windows Server 2008 R2 或 Windows Server 2012 及 2012 R2 上的安装。
Windows Installer： | （不适用）
Office Web 组件： | owc11.exe
Visual C++ 2005 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2008 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2010 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2012 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
应用程序的 Visual Studio 工具： (可选) | vsta_aide.msi
如果安装了 VSTA，则需安装 .NET 3.5 Framework (dotnetfx35.exe)。 对于 Windows 7 而言，.NET Framework 3.5 是操作系统的一项功能。
Visual Studio 远程调试器： | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5： | .netfx45_full_x86_x64.exe
Windows 的 Bonjour 服务： | bonjour64.msi
操作系统: Windows Server 2012 和 Windows Server 2012 R2 64 位 SOLIDWORKS 媒体： 用于 Windows 8 和 8.1 的 64 位版本
SOLIDWORKS PDM 服务器、Workgroup PDM Server 和 SOLIDWORKS SolidNetWork License Manager 支持在 Windows Server 2008 R2 或 Windows Server 2012 及 2012 R2 上的安装。
Windows Installer： | （不适用）
Office Web 组件： | owc11.exe
Visual C++ 2005 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2008 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2010 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 20102 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
应用程序的 Visual Studio 工具： (可选) | vsta_aide.msi
如果安装了 VSTA，则需安装 .NET 3.5 Framework (dotnetfx35.exe)。 对于 Windows 8 而言，.NET Framework 3.5 是操作系统的一项功能。
Visual Studio 远程调试器： | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5： | .Net 4.5 是操作系统的一部分，可满足此要求。
Windows 的 Bonjour 服务： | bonjour64.msi
操作系统： Windows 7 64 位 SOLIDWORKS 媒体： 用于 Windows 7 的 64 位版本
Windows Installer： | （不适用）
Office Web 组件： | owc11.exe
Visual C++ 2005 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2008 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2010 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2012 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
应用程序的 Visual Studio 工具： (可选) | vsta_aide.msi
如果安装了 VSTA，则需安装 .NET 3.5 Framework (dotnetfx35.exe)。 对于 Windows 7 而言，.NET Framework 3.5 是操作系统的一项功能。
Visual Studio 远程调试器： | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5： | .netfx45_full_x86_x64.exe
Windows 的 Bonjour 服务： | bonjour64.msi
操作系统： Windows 8 和 8.1 64 位 SOLIDWORKS 媒体： 用于 Windows 8 的 64 位版本
Windows Installer： | （不适用）
Office Web 组件： | owc11.exe
Visual C++ 2005 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2008 可重新分发套件： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2010 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
Visual C++ 2012 可重新分发软件包： | vcredist_x86.exe vcredist_x64.exe 必须安装两者。
应用程序的 Visual Studio 工具： (可选) | vsta_aide.msi
如果安装了 VSTA，则需安装 .NET 3.5 Framework (dotnetfx35.exe)。 对于 Windows 7 而言，.NET Framework 3.5 是操作系统的一项功能。
Visual Studio 远程调试器： | rdbgexp.msi
Visual Basic 7.1: | vba71.msi
.NET Framework 4.5： | .Net 4.5 是操作系统的一部分，可满足此要求。
Windows 的 Bonjour 服务： | bonjour64.msi

内容

  • 在 64 位操作系统上从命令行安装 Windows 必备组件

    按照下列流程在 64 位 Windows 版本上使用命令行安装管理映像安装所需的 Windows 必备组件。

父主题
命令行调用
相关概念
通过命令行从管理映像安装
命令行属性
相关任务
使用 Microsoft Active Directory 调用管理映像
使用 Microsoft Active Directory 安装 Windows 必备组件


在 64 位操作系统上从命令行安装 Windows 必备组件

按照下列流程在 64 位 Windows 版本上使用命令行安装管理映像安装所需的 Windows 必备组件。

若要一次安装多个组件，按照下面步骤中所提供的命令生成一个批处理文件，然后用它将组件推送到客户端计算机。

  1. 确定目标计算机至少具有 620 MB 可用磁盘空间及有效的 TEMP 目录。
  2. 通过运行该命令安装 Office Web 组件：

    管理映像的目录\OfficeWeb_11\owc11.exe/quiet

  3. 安装 Visual C++ RELEASE 可重新分发软件包。

    为 RELEASE = 2005、2008、2010 和 2012 安装软件包。

    管理映像的目录\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    管理映像的目录\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    您必须安装有该软件包的 32 位和 64 位版本。

    例如，要安装 Visual C++ 2005 可重新分发软件包，请使用：

    • 管理映像的目录\Microsoft_C++_2005_Redistributable_(x64)\vcredist_x64.exe /Q
    • 管理映像的目录\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /Q

  4. 安装 Microsoft .NET Framework 4.5：

    administrative_image_directory\.Net_Framework_4.5\dotnetfx45_full_x86_x64.exe

  5. 安装应用程序的 Visual Basic 工具：

    管理映像的目录\Microsoft_VSTA\vsta_aide.msi

    如果安装 VSTA，则必须安装 .NET Framework 3.5。

    对于 Windows 7 或以后版本而言，.NET Framework 3 是操作系统的一项功能。

  6. 安装 Visual Studio 远程调试器：

    管理映像的目录\VSRemoteDebugger\install.exe /Q

  7. 安装 Visual Basic 7.1：

    所有语种都要求 administrative_image_directory\Microsoft_VBA\vba71.msi 和 administrative_image_directory\Microsoft_VBA\vba71_1033.msi。

    只能安装此软件包的 64 位版本。

    此外，请为所需语言安装以下软件包：

    vba71_1028.msi | 中文
    vba71_1031.msi | 德文
    vba71_1036.msi | 法文
    vba71_1040.msi | 意大利文
    vba71_1041.msi | 日文
    vba71_1042.msi | 韩文
    vba71_1046.msi | 巴西葡萄牙文
    vba71_2052.msi | 简体中文
    vba71_3082.msi | 西班牙文
    英文、捷克文、波兰文、俄文和土耳其文无需其他语言软件包。
    自 SOLIDWORKS 2013 Service Pack 2.0 起，您必须安装一个附加的先决条件： Msiexec.exe /p vba71-kb27832-x64.msp

  8. 安装 Windows 的 Bonjour 服务：

    administrative_image_directory\Bonjour\Bonjour64.msi

父主题
准备客户端以便通过命令行从管理映像进行安装


通过命令行从管理映像安装

您可以通过命令行从管理映像调用安装。

要进行无声安装：

  1. 打开命令提示符窗口（在 Windows 中，单击开始 > 运行）。
  2. 键入 msiexec.exe 命令，附上 /i 和 /qb 开关，并为任何未处于默认值的选项设定属性，默认值如下文所示。
单机安装组件命令行属性包括:
  • 命令行特征属性
  • 命令行全局属性
  • eDrawings 命令行属性
  • SOLIDWORKS Explorer/Workgroup PDM 命令行属性
  • SOLIDWORKS Flow Simulation 命令行属性

使用以下范例作为无声安装的模板。

SOLIDWORKS 客户端

  • SOLIDWORKS 核心产品（英文）
  • Toolbox 插件
  • 参与反馈项目
  • 法语

SOLIDWORKS：

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

SOLIDWORKS 法语安装组件必须单独安装：

msiexec /i "64-bit_admin_image_path\SOLIDWORKS French\french.msi" /qb

指定 SOLIDWORKS 语言组件安装命令时，请勿指定命令行参数。

eDrawings 客户端

  • 日志性能
  • 所有特征

msiexec /i "admin_image_path\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\your_folder" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Explorer 和 Workgroup PDM 插件

  • SOLIDWORKS Explorer 带 Workgroup PDM 插件

msiexec /i "admin_image_path\SOLIDWORKS Explorer\SOLIDWORKS Explorer.msi" INSTALLDIR="C:\Program Files\your_folder" EXPLORERORPDM=1 ADDLOCAL=VaultAdmin,Client,Standalone,DocMgr,LicenseEXE ACTIVSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" /qb

SOLIDWORKS Electrical

由于在 Microsoft SQL Server 中安装 SOLIDWORKS Electrical 的技术复杂性，SOLIDWORKS Electrical 的命令行示例将从文档中排除。

父主题
命令行调用
相关概念
准备客户端以便通过命令行从管理映像进行安装
命令行属性
相关任务
使用 Microsoft Active Directory 调用管理映像
使用 Microsoft Active Directory 安装 Windows 必备组件


命令行属性

此处所述的命令行属性包括特征属性、全局属性、产品特定的属性和 Windows 位置约定。

内容

  • 命令行特征属性

    SOLIDWORKS 安装支持适用于命令行部署的以下 ADDLOCAL 属性。

  • 命令行全局属性

    每个属性都为管理或单机安装定义，除非另有说明。可使用全局属性将序列号传递给管理安装及单机安装。

  • eDrawings 命令行属性

    这些命令行属性特定于 eDrawings®。

  • SOLIDWORKS Composer/Composer Player 命令行属性

    这些命令行属性特定于 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player。

  • SOLIDWORKS Explorer/Workgroup PDM 命令行属性

    这些命令行属性是特定于 SOLIDWORKS Explorer 和 SOLIDWORKS Workgroup PDM 的。

  • SOLIDWORKS Flow Simulation 命令行属性

    这些命令行属性是特定于 SOLIDWORKS Flow Simulation 的。

  • SOLIDWORKS Inspection 命令行特性

    这些命令行特性是特定于 SOLIDWORKS Inspection 的。

  • 管理映像的 MSI 文件位置

    要从命令行生成管理映像，产品组件 .msi 文件储存在 SOLIDWORKS 媒体的以下位置中。

父主题
命令行调用
相关概念
准备客户端以便通过命令行从管理映像进行安装
通过命令行从管理映像安装
相关任务
使用 Microsoft Active Directory 调用管理映像
使用 Microsoft Active Directory 安装 Windows 必备组件


命令行特征属性

SOLIDWORKS 安装支持适用于命令行部署的以下 ADDLOCAL 属性。

  • CircuitWorks
  • CoreSOLIDWORKSTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
指定命令行安装的属性时：
  • SOLIDWORKS 不支持使用 ADDSOURCE 选项进行产品安装。
  • 属性区分大小写，不能包含空格或破折号，并且必须由逗号隔开。

    必须在 ADDLOCAL 属性中为应用程序指定大小写混合形式 SolidWorks 才能正确安装。

父主题
命令行属性
相关参考
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


命令行全局属性

每个属性都为管理或单机安装定义，除非另有说明。可使用全局属性将序列号传递给管理安装及单机安装。

属性 | 说明
ENABLEPERFORMANCE 应用程序是否自动将性能数据发送到 SOLIDWORKS Corporation。

1

发送性能数据。

0

不发送性能数据。
INSTALLDIR SOLIDWORKS 的安装文件夹。

仅单机安装。
MBDSERIALNUMBER | 基于 SOLIDWORKS 模型的定义产品的序列号。
MOTIONSERIALNUMBER | SOLIDWORKS Motion 产品的序列号。
OFFICEOPTION 指定要安装的产品套件：
0 | SOLIDWORKS 客户端
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL 指定 所有 以更新当前安装的所有功能。
只有在更新现有主要版本的 Service Pack 发行版时，才需要指定此属性（例如，将现有 SOLIDWORKS 2015 SP01 安装升级为 SOLIDWORKS 2015 SP02 时）。
REINSTALLMODE Microsoft 安装程序重新安装选项。

例如，将安装程序从先前的 Service Pack 发行版升级到相同主要版本内的另一 Service Pack 发行版时，您需要指定 REINSTALLMODE=vomus。

有关 REINSTALLMODE 设置的详细信息，请参阅 www.microsoft.com 上的 Windows Installer 文档。

只有在更新现有主要版本的 Service Pack 发行版时，才需要指定此属性（例如，将现有 SOLIDWORKS 2015 SP01 安装升级为 SOLIDWORKS 2015 SP02 时）。 首次安装 SOLIDWORKS 新的主要版本时请勿指定此属性。
SERVERLIST SolidNetWork 服务器清单。
SolidNetWork 服务器列表为由分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为：

xxxxx@server_name1;yyyyy@server_name2;&

此处 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。

仅单机安装。
SIMULATIONSERIALNUMBER | SOLIDWORKS Simulation 产品的序列号。
SOLIDWORKSSERIALNUMBER | SOLIDWORKS 产品的序列号，包括所有插件。
SWMIGRATE 按在 SOLIDWORKS 安装选择对话框列表中所显示内容指定要升级的 SOLIDWORKS 版本。 例如：

SWMIGRATE="SOLIDWORKS 2015 x64 Edition SP01"

只有在当前已安装先前主要版本的情况下安装新的主要版本时，才需要指定此属性。 将同一个主要版本中的 Service Pack 发行版升级为另一个版本时，请勿指定此属性。
TOOLBOXFOLDER SOLIDWORKS Toolbox 文件的安装文件夹。

仅单机安装。

例如： TOOLBOXFOLDER = "c:\SOLIDWORKS Data"
TRANSFORMS 包含语言特定的表单项：
TRANSFORMS 数字.mst
  • 中文 (1028)
  • 简体中文 (2052)
  • 捷克文 (1029)
  • 英文 (1033)
  • 法文 (1036)
  • 德文 (1031)
  • 意大利文 (1040)
  • 日文 (1041)
  • 韩文 (1042)
  • 波兰文 (1045)
  • 巴西葡萄牙文 (1046)
  • 俄文 (1049)
  • 西班牙文 (1034)
  • 土耳其文 (1055)
UPGRADESWINSTALL
指定是否将 SOLIDWORKS 现有版本升级到当前版本。
0 | 新安装，不更新。
1 | 更新

仅单机安装。

只有在当前已安装先前主要版本的情况下安装新的主要版本时，才需要指定此属性。 将同一个主要版本中的 Service Pack 发行版升级为另一个版本时，请勿指定此属性。
父主题
命令行属性
相关参考
命令行特征属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


eDrawings 命令行属性

这些命令行属性特定于 eDrawings®。

属性 | 说明
ADDLOCAL 指定安装 eDrawings 应用程序的哪个部分。
All 为推荐选项。
命令行语法 | 特征
全部 | 安装所有功能。 eDrawings 应用程序搜索已安装的 SOLIDWORKS 和 AutoCAD 出版程序应用程序以核准安装。
CALS | 在 eDrawings 浏览器中查看 CAL 文件
Inventor | 从 Autodesk Inventor 应用程序创建 eDrawings 文件。
eDrawingsViewer | 查看 eDrawings 及其它文件。
ProE | 使用 eDrawings 浏览器查看 ProE 文件
DXFDWGTranslator | 在 eDrawings Viewer 中观阅 DXF/DWG 文件。
快捷键 | 安装桌面快捷方式。
XML3D | 在 eDrawings 浏览器中查看 3DXML 文件。
INSTALLDIR | 为 eDrawings 指定安装文件夹
LOGPERFORMANCE 指定应用程序是否自动将性能数据以电子邮件发送到 SOLIDWORKS Corporation。
1 | 发送性能数据
0 | 否则
SNLSERVER 请输入 SolidNetWork 许可服务器的 端口@。 使用分号分开多个 端口@服务器 组合。

只要求为 SOLIDWORKS SNL 服务器配置提供 SNLSERVER 的端口服务器名称。 list_of_port@server_strings 为由分号分隔的字串列表，每个字串指明服务器上一端口号，格式为：

xxxxx@server_name1；yyyyy@server_name2；

此处 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


SOLIDWORKS Composer/Composer Player 命令行属性

这些命令行属性特定于 SOLIDWORKS Composer 和 SOLIDWORKS Composer Player。

有关 SOLIDWORKS Composer：

属性 | 说明
ACTIVSERIALNUMBER | SOLIDWORKS Composer 序列号。
ACTIVSERIALNUMBERPLAYERPRO | 可选。 SOLIDWORKS Composer Player Pro 序列号。
ADDLOCAL 如果您安装完整的应用程序，则不需要指定以下条目。
要求：
  • 颁发许可
  • Documents_2D
  • Eula
  • InterOps
  • LicenseSupportFiles
  • 插件
  • SWComposerCommon
  • SWPlayer
可选：
  • Sync3Dvia
INSTALLDIR | 为 SOLIDWORKS Composer 软件指定安装文件夹。

有关 SOLIDWORKS Composer Player：

属性 | 说明
ACTIVSERIALNUMBERPLAYERPRO | 可选。 SOLIDWORKS Composer Player Pro 序列号。
INSTALLDIR | 为 SOLIDWORKS Composer Player 软件指定安装文件夹。
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


SOLIDWORKS Explorer/Workgroup PDM 命令行属性

这些命令行属性是特定于 SOLIDWORKS Explorer 和 SOLIDWORKS Workgroup PDM 的。

对于 SOLIDWORKS Explorer/Workgroup PDM 客户端：
客户端属性 | 说明
EXPLORERORPDM
0 | 仅 SOLIDWORKS Explorer
1 | 可安装 Workgroup PDM 功能
ADDLOCAL
  • Standalone
  • 客户端
  • Client64
  • VaultAdmin
  • AutoCADRxxxx
  • DocMgr
  • DocMgr64
  • LicenseEXE

Standalone 是 Contributor，而 Client 则是 SOLIDWORKS Explorer 无声安装的 SOLIDWORKS 插件。

如果您指定 AutoCAD，您的系统上必须装有 AutoCAD。 Workgroup PDM 可找出 AutoCAD 的适当版本。 您可指定一个以上 AutoCAD 版本：

  • AutoCADR14Addin
  • AutoCADR2000Addin
  • AutoCADR2004Addin
  • AutoCADR2005Addin
  • AutoCADR2006Addin

Client64 和 DocMgr64 仅适用于 64 位 SOLIDWORKS Explorer 安装。

INSTALLDIR | 为 Workgroup PDM 指定安装文件夹。
ACTIVSERIALNUMBER | 指定 SOLIDWORKS 序列号。
对于 Workgroup PDM Server：
服务器属性 | 说明
ADDLOCAL
  • 库
  • WebPortal
  • API

如果您指定 WebPortal（浏览器），您还必须指定 VAULTNAME。
INSTALLDIR | 为 Workgroup PDM 指定安装文件夹。
LICENSE_SERVER | 指定许可服务器所处的计算机的名称。
VAULTDATA | 指定库的路径和文件夹。
VAULTNAME | 指定库所处的计算机名称。
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


SOLIDWORKS Flow Simulation 命令行属性

这些命令行属性是特定于 SOLIDWORKS Flow Simulation 的。

属性 | 说明
ACTIVSERIALNUMBER SOLIDWORKS Flow Simulation 独立序列号。

（单机安装和从管理映像执行的客户端安装）
CWUPGRADEINSTALL 升级特定 SOLIDWORKS Flow Simulation 应用程序软件的现有版本。
1 | 更新
2 | 新的安装；在新目录中安装

（单机安装和从管理映像执行的客户端安装）
INSTALLDIR 为特定 SOLIDWORKS Flow Simulation 应用程序软件指定安装。

（仅适用于个人安装）
SERVERLIST | 以分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为： xxxxx@server_name1; yyyyy@server_name2;&，其中 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
SOLIDWORKSPATH 指定安装有 SOLIDWORKS 软件的文件夹。

（单机安装和从管理映像执行的客户端安装）
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Inspection 命令行特性
管理映像的 MSI 文件位置


SOLIDWORKS Inspection 命令行特性

这些命令行特性是特定于 SOLIDWORKS Inspection 的。

属性 | 说明
ACTIVSERIALNUMBER | SOLIDWORKS Inspection 序列号。 （单机安装和从管理映像执行的客户端安装）
INSTALLDIR | 为 SOLIDWORKS Inspection 应用程序软件指定安装位置。 （仅适用于个人安装）
SERVERLIST | 以分号分隔的字符串列表，每个字符串指明服务器上的一个端口号，格式为： xxxxx@server_name1; yyyyy@server_name2;&，其中 x 和 y 为单个数字。 在列表中的最后一个服务器后不要放置分号。
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
管理映像的 MSI 文件位置


管理映像的 MSI 文件位置

要从命令行生成管理映像，产品组件 .msi 文件储存在 SOLIDWORKS 媒体的以下位置中。

SOLIDWORKS（核心产品，英文）

swwi\data\SOLIDWORKS.msi

SOLIDWORKS（非英文组件）

繁体中文 | swwi\lang\chinese\chinese.msi
简体中文 | swwi\lang\chinese-simplified\chinese-simplified.msi
捷克文 | swwi\lang\czech\czech.msi
法文 | swwi\lang\french\french.msi
德文 | swwi\lang\german\german.msi
意大利文 | swwi\lang\italian\italian.msi
日文 | swwi\lang\japanese\japanese.msi
韩文 | swwi\lang\korean\korean.msi
波兰文 | swwi\lang\polish\polish.msi
巴西葡萄牙文 | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
俄文 | swwi\lang\russian\russian.msi
西班牙文 | swwi\lang\spanish\spanish.msi
土耳其文 | swwi\lang\turkish\turkish.msi

DocManager API

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

eDrawings 上色器

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

PhotoView 360 网络渲染

pvnetworkrender\pvnetrender.msi

SolidNetWork License Manager

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

SOLIDWORKS 激活向导

swactwizard\Activation Wizard.msi

SOLIDWORKS API SDK

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Explorer

swexplorer\SOLIDWORKS Explorer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional 提供了 API，但其仅可用于客户端且不可用于 .msi 文件中。 有关详细信息，请参阅 SOLIDWORKS PDM 客户端 install\API 目录中的 API 指南。

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi

SOLIDWORKS 浏览器

swviewer\SOLIDWORKS Viewer.msi

Workgroup PDM Server

pdmwserver\SOLIDWORKS Workgroup PDM Server.msi
父主题
命令行属性
相关参考
命令行特征属性
命令行全局属性
eDrawings 命令行属性
SOLIDWORKS Composer/Composer Player 命令行属性
SOLIDWORKS Explorer/Workgroup PDM 命令行属性
SOLIDWORKS Flow Simulation 命令行属性
SOLIDWORKS Inspection 命令行特性


使用 Microsoft Active Directory 调用管理映像

Microsoft Active Directory Deployment 在为客户端调用核心 SOLIDWORKS 产品时受支持。

Microsoft Active Directory 是在网络环境中管理客户端和服务器的目录服务。它可简化管理、迁移及调用。

  1. 使用 SOLIDWORKS 安装管理程序创建管理映像。
  2. 如果已使用命令行创建管理映像，请安装使用 Microsoft Active Directory 从管理映像进行安装所需的 Windows 必备组件。有关详细信息，请参阅使用 Microsoft Active Directory 安装 Windows 必备组件。

    仅在使用命令行手动创建映像的情况下才进行此步骤。 如果您使用 SOLIDWORKS 安装管理程序创建并安装映像，则会自动安装所有 Windows 必备组件。

  3. 生成一个转换文件来自定义 SOLIDWORKS 软件：
    1. 打开命令提示符窗口。
    2. 在包含管理映像的文件夹中，将 SWCreateMST.exe 拖动到命令提示符窗口中。

      命令格式应为：

      管理映像目录\SWCreateMST.exe 管理映像 MSI 文件的路径属性列表

      属性可以是特征属性或全局属性。 有关详细信息，请参见 命令行特征属性 和 命令行全局属性。

      使用以下示例作为模板：

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST="25734@your_server"

      将在管理映像所在的文件夹中创建转换文件 SOLIDWORKS.mst。

  4. 在 Active Directory 中，为要部署 SOLIDWORKS 软件的组编辑发行的应用程序策略。
  5. 在“组策略”对话框中扩展“计算机配置”和“软件设置”。
  6. 右键单击“软件安装”并选择新建 > 套包。
  7. 浏览至管理映像，然后单击打开。
  8. 在部署软件对话框中选择高级发行或指派，然后单击确定。
  9. 在 SOLIDWORKS 属性对话框中的“修改”选项卡上：
    1. 单击添加。
    2. 浏览至 .mst 文件。
    3. 单击打开。
  10. 单击确定。
父主题
命令行调用
相关概念
准备客户端以便通过命令行从管理映像进行安装
通过命令行从管理映像安装
命令行属性
相关任务
使用 Microsoft Active Directory 安装 Windows 必备组件


使用 Microsoft Active Directory 安装 Windows 必备组件

按照下列流程准备一个用于通过 Microsoft Windows Active Directory 将 SOLIDWORKS 安装到客户端计算机上的现有管理映像。

  1. 提取所有 Visual C++ 可重新分发软件包安装程序文件并对其进行安装。
    1. Visual C++ 2005

      1. 管理映像目录\Microsoft_C++_2005_Redistributable\vcredist_x86.exe /C /T： {目标目录}
      2. 管理映像目录\Microsoft_C++_2005_Redistributable_(64)\vcredist_x64.exe /C /T： {目标目录}
      3. 生成安装 Microsoft C++ 2005 可重新分发的模块的政策。

    2. Visual C++ 2008

      1. 管理映像目录\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x： {目标目录}
      2. 管理映像目录\Microsoft_C++_2008_Redistributable_(64)\vcredist_x64.exe /x： {目标目录}
      3. 生成安装 Microsoft C++ 2008 可重新分发的模块的政策。

    3. Visual C++ 2010

      1. 管理映像目录\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{目标目录}
      2. 管理映像目录\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{目标目录}
      3. 生成安装 Microsoft C++ 2010 可重新分发的模块的政策。

    4. Visual C++ 2012

      1. 在测试机器上安装管理映像目录\Microsoft_C++_2012_Redistributable\vcredist_x86.exe。
      2. 将这些文件夹复制的到网络位置（目标目录）：
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
      3. 生成安装以下文件的政策：
        文件路径不能包含空格。

        目标目录\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        目标目录\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      4. 在测试机器上安装管理映像目录\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe。
      5. 将这些文件夹复制的到网络位置（目标目录）：
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      6. 生成安装以下文件的政策：
        文件路径不能包含空格。

        目标目录\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        目标目录\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        目标目录\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. 安装 Microsoft .NET Framework 4.5。

    SOLIDWORKS 建议您使用 Windows 更新服务 (WSUS) 或类似服务安装 .NET Framework 4.5。

  3. 提取 Office Web 组件文件并安装。
    1. 运行此命令：

      管理映像目录\OfficeWeb_11\owc11.exe /extract:{Office Web 组件目录}

    2. 生成安装 Office Web 组件的政策：

      {Office Web 组件目录}\owc11.MSI

      此安装不需要转换文件。

  4. 通过创建此策略安装 Visual Studio 远程调试器（仅在计算机上安装 .Net Framework 3.5 时使用 64 位版本）：

    {Microsoft 远程调试器目录}\rdbgexp.MSI

    此安装不需要转换文件。

  5. 执行以下任务：
    1. 使用 vba71-kb2783832-x64 service pack 更新应用程序的 Visual Basic 7.1
    2. 创建管理映像后，运行此命令：

      Msiexec /a {SOLIDWORKS Administrative image}/Microsoft_vba/vba71.msi /p {SOLIDWORKS Administrative image}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp

    3. 通过创建以下策略安装 Visual Basic 7.1：

      {VBA 目录}\vba71.MSI

      此安装不需要转换文件。

  6. 通过创建此政策安装 Visual basic 7.1 语言包：

    {VBA 目录}\vba71_nnnn.MSI

    其中 nnnn 定义所需的语言：
    • 1028 = 中文
    • 1031 = 德语
    • 1033 = 英语
    • 1036 = 法语
    • 1040 = 意大利语
    • 1041 = 日语
    • 1042 = 韩语
    • 1046 = 葡萄牙语
    • 2052 = 中文 - 中国
    • 3082 = 西班牙语

  7. 通过创建以下策略安装 Bonjour 服务：

    {Bonjour 目录}\Bonjour.MSI

    此安装不需要转换文件。

父主题
命令行调用
相关概念
准备客户端以便通过命令行从管理映像进行安装
通过命令行从管理映像安装
命令行属性
相关任务
使用 Microsoft Active Directory 调用管理映像


多个安装的管理

多个安装的管理任务包括将管理映像升级到新发行版、应用 service pack 更新以及删除安装。

内容

  • 将管理映像升级到新的发行版

    若要更新从管理映像安装的客户端，请首先更新管理映像，然后将客户端配置为参考引用新版本的映像。

  • Service Pack 产品更新管理

    Service Pack 产品更新可包含系统可靠性、程序兼容性、安全性等的更新。

  • 删除安装

    您可以在单台计算机或在服务器/客户端环境中删除安装。

父主题
多个安装
相关概念
调用到多个客户端
使用管理映像
通过电子邮件将管理映像调用到客户端
命令行调用


将管理映像升级到新的发行版

若要更新从管理映像安装的客户端，请首先更新管理映像，然后将客户端配置为参考引用新版本的映像。

从因特网运行 SOLIDWORKS 安装管理程序，这样可引用正确的文件。 SOLIDWORKS 安装管理程序将引导自己进行该操作，或者您可直接从 SOLIDWORKS 下载网站 (http://www.solidworks.com/sw/support/downloads.htm) 运行更新。

您一旦更新了管理映像（此将创建一份新的映像），则可通过使客户端参考引用新的管理映像来更新客户端。

如果客户端使用映射的驱动器或共享目录参考引用了以前的管理映像版本，您可使用管理映像更新版本的位置来重新定义映射驱动器或共享目录。

内容

  • 为管理映像下载更新后的安装文件

    SOLIDWORKS 安装管理程序可在升级管理映像的过程中检测是否需要更新后的安装文件。

  • 升级管理映像

    若要升级管理映像，SOLIDWORKS 安装管理程序会创建一个新的映像目录。 随后，您可以指引客户端使用该新的管理映像目录以升级到该产品版本。

  • 从管理映像升级客户端

    SOLIDWORKS 安装管理程序可以自动从管理映像更新客户端计算机上安装的客户端。

父主题
多个安装的管理
相关概念
Service Pack 产品更新管理
相关任务
删除安装


为管理映像下载更新后的安装文件

SOLIDWORKS 安装管理程序可在升级管理映像的过程中检测是否需要更新后的安装文件。

  1. 插入 DVD 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎屏幕上，选择管理映像。
  3. 在 序列号 屏幕中，输入 SOLIDWORKS 序列号。

    SOLIDWORKS 安装管理程序检查 SOLIDWORKS 网站有关颁有许可的产品以及可用的 service pack。

  4. 如果有新版本可用屏幕出现，单击是，下载并安装更新版本:版本。

    SOLIDWORKS 安装管理程序启动新会话以安装新版本。

  5. 如果下载文件夹有问题，则可能出现下载选项，在这种情况下，请接受新安装文件的默认目录或输入新的目录名称。

    如果您看到目录不存在的信息，单击是以便创建。

  6. 在下载已完成屏幕上单击关闭，可关闭当前的安装程序并为新版本开启安装程序。
父主题
将管理映像升级到新的发行版
相关概念
从管理映像升级客户端
相关任务
升级管理映像


升级管理映像

若要升级管理映像，SOLIDWORKS 安装管理程序会创建一个新的映像目录。 随后，您可以指引客户端使用该新的管理映像目录以升级到该产品版本。

此过程假定您已经下载了管理映像所需的所有已更新的安装文件。 有关详细信息，请参阅为管理映像下载更新安装文件。

  1. 启动 SOLIDWORKS 安装管理器。 有关详细信息，请参阅初始化 SOLIDWORKS 安装程序。
  2. 在欢迎屏幕上，选择管理映像。

    将显示管理映像生成选项。

    选项 | 描述
    使用默认设定生成新映像。 | 使用默认配置设定生成映像（也就是说，不依据当前为您站点的现有管理映像建立的设定来生成映像）。
    使用现有映像的设定和文件生成新映像。 | 使用为您站点的现有管理映像指定的配置设定生成映像。 单击 浏览，为现有管理映像指定安装目录。
  3. 在序列号屏幕中，检查序列号。
  4. 在摘要（已准备好创建映像）屏幕中，检查确保管理映像选项正确。

    关于各个管理映像选项和安装选项的详细信息，请单击更改以转到选项页面，然后单击帮助。

  5. 若要创建新版本的管理映像，请单击立即创建。

现在可以将客户端升级到此新版本的管理映像了。 详细信息请参阅从管理映像升级客户端。

父主题
将管理映像升级到新的发行版
相关概念
从管理映像升级客户端
相关任务
为管理映像下载更新后的安装文件
启动 SOLIDWORKS 安装


从管理映像升级客户端

SOLIDWORKS 安装管理程序可以自动从管理映像更新客户端计算机上安装的客户端。

一般而言，管理映像在服务器上的文件夹中进行组织。要想支持客户端自动升级，管理映像必须位于共享文件夹中。

在升级管理映像之后，原始安装将位于一个文件夹，而升级后的安装将位于另一个文件夹。要想使用升级后的安装，请首先从原始管理映像文件夹中移除共享选项，然后将共享选项添加到升级的管理映像文件夹中。

在从原始管理映像安装的客户端机器上启动 SOLIDWORKS 时，SOLIDWORKS 将查找新的版本并升级客户端。

父主题
将管理映像升级到新的发行版
相关任务
为管理映像下载更新后的安装文件
升级管理映像

删除原始管理映像文件夹的共享选项

当升级在共享文件夹中供访问的管理映像时，必须删除原始文件夹的共享选项。

  1. 浏览到原始管理映像文件所处于的文件夹。
  2. 用右键单击文件夹并选择属性。
  3. 在共享选项卡上，选择不共享此文件夹，然后单击确定。

现在按照为升级的管理映像文件夹添加共享选项中的说明为升级的管理映像文件夹添加共享选项。

为升级后的管理映像文件夹添加共享选项

一旦您创建了更新后的管理映像文件夹并禁用了原始管理映像文件夹的共享之后，必须为新文件夹添加共享选项以重新启用管理映像。

  1. 浏览到已升级的管理映像文件所在的文件夹。
  2. 用右键单击文件夹并选择属性。
  3. 在共享选项卡上指定对您机构或组适合的共享属性，并将共享名称更改到用于原有管理映像文件夹的名称。
从原始管理映像共享位置安装的计算机会在启动 SOLIDWORKS 时自动升级到新版本。


Service Pack 产品更新管理

Service Pack 产品更新可包含系统可靠性、程序兼容性、安全性等的更新。

您可使用两种方法获取产品更新：
  • 可使用 SOLIDWORKS 安装管理程序来检查、下载及安装更新。

    您可手动启动 SOLIDWORKS 安装管理程序，或者安排定期检查更新。

  • 可从 SOLIDWORKS 支持网站上手动下载 service pack。

    Service pack 作为对现有软件版本的修补而应用。 例如，SOLIDWORKS 2015 SP1.0 为 SOLIDWORKS 2015 SP0.0 的 service pack。您可以使用 SOLIDWORKS 2015 安装管理程序来安装这些 service pack；您不能使用 SOLIDWORKS 2016 中的 SOLIDWORKS 安装管理程序进行安装。

    有关下载和安装 service pack 的说明，请参阅您正在进行更新的 SOLIDWORKS 版本的安装文档。

内容

  • 在管理映像中退回 Service Pack

    您可将管理映像退回到早期安装的 service pack。 如果您以光盘安装了 SOLIDWORKS 软件，您需要原有光盘才可恢复某个 service pack。 您必须保存有早期管理映像的副本。

  • 将 Service Pack 应用到通过 Microsoft Active Directory 部署的客户端。

    如果您使用 Microsoft Active Directory 安装了 SOLIDWORKS 软件，您可将 service pack 应用到通过其部署的客户端。

父主题
多个安装的管理
相关概念
将管理映像升级到新的发行版
相关任务
删除安装


在管理映像中退回 Service Pack

您可将管理映像退回到早期安装的 service pack。 如果您以光盘安装了 SOLIDWORKS 软件，您需要原有光盘才可恢复某个 service pack。 您必须保存有早期管理映像的副本。

已升级过的管理映像不能退回到先前的 service pack。 以 SOLIDWORKS 安装管理程序以外的其他方法所创建的管理映像无法退回到早期版本。 必须卸载从这些管理映像安装的客户端，然后使用由先前版本生成的管理映像重新安装。
  1. 删除包含当前管理映像的文件夹。若要进行此操作，打开命令提示符窗口并输入：

    rmdir /s/q 当前管理映像的路径

  2. 将管理映像的备份副本移到您删除了当前管理映像的位置。若要进行此操作，打开命令提示符窗口并输入：

    move 备份管理映像的路径当前管理映像的路径

    在您退回管理映像后，客户端计算机在下次运行 SOLIDWORKS 软件时自动退回。

父主题
Service Pack 产品更新管理
相关任务
将 Service Pack 应用到通过 Microsoft Active Directory 部署的客户端。


将 Service Pack 应用到通过 Microsoft Active Directory 部署的客户端。

如果您使用 Microsoft Active Directory 安装了 SOLIDWORKS 软件，您可将 service pack 应用到通过其部署的客户端。

  1. 使用以下命令行将管理映像复制到新文件夹：

    xcopy 当前管理映像的路径备份管理映像的路径 /s/i/v

  2. 使用 SOLIDWORKS 安装管理程序更新管理映像。
  3. 生成新的转换文件为 SOLIDWORKS 软件指定升级安装：
    1. 打开命令提示符窗口。
    2. 在包含管理映像的文件夹中，将 SWCreateMST.exe 拖动到“命令提示符”窗口中。

      命令格式为：

      管理映像的路径\SWCreateMST.exe 管理映像 MSI 文件的路径属性列表

      命令行必须包括用来创建原有转换文件的所有参数，外加全局属性 UPGRADESWINSTALL 和 SWMIGRATE。

      例如，如果原有命令为：

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\您的文件夹" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@您的服务器

      更新命令必须是：

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\您的文件夹" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@您的服务器 UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS 版本服务包"

      将在管理映像所在的文件夹中创建转换文件 SOLIDWORKS.mst。

  4. 在 Active Directory 中，为一个或多个组编辑 发行的应用程序 策略以部署 SOLIDWORKS 软件。
  5. 在组策略对话框中扩展计算机配置和软件设置。
  6. 右键单击软件安装并选择新建 > 软件包。
  7. 浏览至管理映像，然后单击打开。
  8. 在部署软件对话框中选择高级发行或指派，然后单击确定。
  9. 在 SOLIDWORKS 属性对话框中的 修改 选项卡上：
    1. 单击添加。
    2. 浏览至 .mst 文件。
    3. 单击打开。
  10. 单击确定。
父主题
Service Pack 产品更新管理
相关任务
在管理映像中退回 Service Pack


SOLIDWORKS Workgroup PDM

Workgroup PDM 应用程序为产品数据管理软件，在 SOLIDWORKS 环境内部运行或作为独立应用程序在 SOLIDWORKS Explorer 中运行。 Workgroup PDM 以检出、检入、版本控制及其它管理任务的步骤来控制项目。

Workgroup PDM 系统如下图所示：

  • 一台计算机只能包含一个库。
  • 库目录不能为隐藏或只读目录。
  • 作为客户端/服务器应用程序，Workgroup PDM 性能依赖于强大的网络。
  • 如果您的用户维持有大量文档，则当您生成较多的项目或子项目，从而使每个项目具有较少的文档时可提高性能。而非在少量项目中保留文档，使每个项目具有较多的文档。

使用寿命结束通告

SOLIDWORKS 2017 推出后，SOLIDWORKS Workgroup PDM 将不再受支持。已经在使用 SOLIDWORKS Workgroup PDM 的客户仍可继续安装，但他们应开始计划将文件库迁移到 SOLIDWORKS PDM Server。

安装

  • 客户端以及 VaultAdmin、API 和 Viewer 可安装在作为库的同一计算机上，或安装在不同的计算机上。
  • 客户端 API 可以直接安装，而不必先安装 Workgroup PDM Server。但是，Workgroup PDM 客户端的安装过程中会安装客户端 API。
  • 若要在远程位置配置库文件夹，在提示服务器目标时键入完整的通用命名代码 (UNC) 路径。（详情请参阅UNC（通用命名代码）格式。
  • 安装或更新库要求重新启动计算机。
  • 在重新启动后，如果 Workgroup PDM Server 服务不自动启动，您必须手动启动它。 在 Windows 资源管理器，在 install_dir\SOLIDWORKS Workgroup PDM\Vault 文件夹下运行 pdmwvault.exe。
  • 当您安装 Workgroup PDM 客户端时，您必须在每台计算机上安装 solidworksexplorer.exe。 此执行文件可位于共享驱动器上。 Workgroup PDM 库、Viewer、API 客户端及 VaultAdmin 并不安装在每台客户端计算机上。
如果您运行的是 Windows 8，请参阅在 Microsoft Windows 中使用 SOLIDWORKS 提示以进行以下任务，如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 参阅 Microsoft Windows 文档了解其他说明和选项。

许可

  • SOLIDWORKS 客户端和 Explorer 客户端许可附带有 Workgroup PDM API 许可。 检入 API 要求有客户端许可。
  • Workgroup PDM 浏览器许可必须随库一起安装才能启用浏览器。

权限

  • 库管理员应对安装和库文件夹具有写入权限。
  • 库管理员应从 VaultAdmin，而不是 Windows 资源管理器来管理库文件夹。
  • 用户不应在 Windows 资源管理器中对库文件夹具有写入权限。

安全、端口及双相设定

  • Workgroup PDM 必须能够作为 Windows 服务安装，这样其它应用程序不被允许阻挡或过滤该服务。 例如，如果诸如 Microsoft AntiSpyware 之类的防间谍软件工具显示安装过程中需要审批的警告，则请单击允许，以便 Workgroup PDM Server 将作为 Windows 服务安装。
  • 如果您在带有激活的防火墙的计算机上安装 Windows PDM，您必须在防火墙设置中启用 Workgroup PDM 端口作为例外。

    通常，端口为：

    • 20000 (VaultAdmin)
    • 30000（数据）
    • 40000（请求）
    • 80 (Viewer)
    有关更改端口设置的信息，请参阅 Workgroup PDM 中的 库管理员疑难解答 和 SOLIDWORKS Explorer 帮户，及 安全中心 Microsoft Windows 帮助。 要同时安装 Workgroup PDM 库和查看器，请使用 自定义 对话框中的 自定义 选项。
  • 服务器及其相应端口的双相设置应相同；例如，两者可以都是 100MB 全工，或者都是自动。

SOLIDWORKS Toolbox 文档

SOLIDWORKS Toolbox 文档为共同硬件部件，通常不需要版本控制而且不会检入到 Workgroup PDM 库中。 参阅 Workgroup PDM 在线帮助了解有关配置 SOLIDWORKS Toolbox 和其他标准库的细节。

内容

  • Workgroup PDM 浏览器

    Workgroup PDM 软件在安装过程中使用 Microsoft Internet Information Services (IIS) 自动设置虚拟目录。

  • 安装 Workgroup PDM 服务器

    安装 Workgroup PDM Server 将创建一个 Workgroup PDM 库，此为储存被管理的 SOLIDWORKS 项目的数据库。

  • 为客户端配置 Workgroup PDM

    安装好 Workgroup PDM 服务器库后，即可为客户端配置库。

  • 在周边网路中安装 Workgroup PDM 服务器和浏览器

    在周边网路 (DMZ) 中安装 SOLIDWORKS Workgroup PDM Web 服务器和 Workgroup PDM 浏览器存在有防火墙方面的牵连因素。

  • Workgroup PDM 客户端访问

    Workgroup PDM 客户端使用 Microsoft Windows 登录访问控制，您可以通过 Workgroup PDM Viewer 进行 Web 访问，且会在每次 Workgroup PDM 库更新时自动更新。

  • Workgroup PDM VaultAdmin 管理

    在安装 Workgroup PDM 后，库管理员应执行下列任务。

相关概念
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示


Workgroup PDM 浏览器

Workgroup PDM 软件在安装过程中使用 Microsoft Internet Information Services (IIS) 自动设置虚拟目录。

您在安装浏览器之前必须安装 Microsoft Internet Information Services (IIS)。
所需的组件包括：
  • Web 管理工具
    • IIS 管理控制台
  • World Wide Web Services：应用程序开发功能
    • .NET 扩展
    • ASP.NET
    • CGI
    • ISAPI 扩展
    • ISAPI 过滤器
参阅 Microsoft 文献了解 IIS 安装说明。
Workgroup PDM 浏览器安装受如下条件限制：
  • 网站内容目录是查看器安装文件夹。
  • 您不能在托管浏览器的主机名称中使用下划线字符。
  • 浏览器在任何时候只能指向一个库。

用户可通过将以下 URL 键入到 Internet Explorer 的地址栏来访问 Workgroup PDM 浏览器：

http://查看器计算机名/pdmweb/

父主题
SOLIDWORKS Workgroup PDM
相关概念
在周边网路中安装 Workgroup PDM 服务器和浏览器
Workgroup PDM 客户端访问
Workgroup PDM VaultAdmin 管理
相关任务
安装 Workgroup PDM 服务器
为客户端配置 Workgroup PDM


安装 Workgroup PDM 服务器

安装 Workgroup PDM Server 将创建一个 Workgroup PDM 库，此为储存被管理的 SOLIDWORKS 项目的数据库。

  1. 启动 SOLIDWORKS 安装管理器。 请参阅初始化 SOLIDWORKS 安装。
  2. 在欢迎屏幕上，选择下列项：

    • 服务器产品
    • 在此计算机上安装 SOLIDWORKS Workgroup PDM 服务器（库）。

  3. 在摘要荧屏上单击更改获取验证码。您可使用以下方法之一获取验证码：
    • 因特网连接
      1. 在所提供的栏区输入 SOLIDWORKS 序列号和电子邮件地址。
      2. 选取自动验证然后单击获取编码。
    • 电子邮件
      1. 如果您的计算机无因特网连接，单击通过电子邮件手工验证。安装管理程序会生成验证请求文件。
      2. 单击保存将文件就地存储在系统上。
      3. 按照荧屏上的指示操作并输入验证码。
  4. 单击返回到摘要。
  5. 在摘要屏幕上单击现在安装。
父主题
SOLIDWORKS Workgroup PDM
相关概念
在周边网路中安装 Workgroup PDM 服务器和浏览器
Workgroup PDM 客户端访问
Workgroup PDM VaultAdmin 管理
相关任务
为客户端配置 Workgroup PDM
启动 SOLIDWORKS 安装
相关参考
Workgroup PDM 浏览器


为客户端配置 Workgroup PDM

安装好 Workgroup PDM 服务器库后，即可为客户端配置库。

  1. 使用默认用户名称和密码登录到 VaultAdmin（随 SOLIDWORKS Explorer 安装）。
  2. 在 VaultAdmin 中，设定用户和组帐户、项目文件夹和权限等等。

    有关说明请参阅 Workgroup PDM 帮助。

  3. 给客户端用户发送电子邮件告知服务器计算机名称和其用户名称及密码，这些通常与其 Microsoft Windows 用户名称和密码不一样。
父主题
SOLIDWORKS Workgroup PDM
相关概念
在周边网路中安装 Workgroup PDM 服务器和浏览器
Workgroup PDM 客户端访问
Workgroup PDM VaultAdmin 管理
相关任务
安装 Workgroup PDM 服务器
相关参考
Workgroup PDM 浏览器

配置 Workgroup PDM Viewer 以连接到其它库位置

您可以通过 Windows 注册表来配置 Workgroup PDM Viewer 以连接到其它库位置。

  1. 通过更改库计算机值来更新注册表路径：

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\Vault Computer

  2. 重新安装 Workgroup PDM Viewer。在库计算机名称对话框中键入新计算机名。

为文档下载配置 Mime 类型

您可以通过 Windows 注册表设定来为文档下载配置 Mime 类型。

在默认情况下，Viewer 以通用 mime 类型 “application/octet-stream” 发送'打开文档'请求。Microsoft Internet Explorer 然后以所提供的文件扩展名打开请求的文件。可通过修改 Windows 注册表中的 Mime 类型注册表子项来映射其它 mime 类型或关闭 mime 类型映射。

  • 若要映射其它 mime 类型，请在此注册表子项下创建其它字符串值：

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Mime Types

    形式为：

    "ext" = "mime type"

    例如：

    "dxf" = "image/vnd.dxf"

    您在添加数值前必须手动创建此注册表子项。

    要关闭 mime 类型映射，请将 Use Custom MIME Types 注册表值更改为 0（零）。

    HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\SOLIDWORKS 2015\PDMWorks Workgroup\WebPortal\Use Custom MIME Types

    不需要重新启动 Web 服务器即可激活该设置。


在周边网路中安装 Workgroup PDM 服务器和浏览器

在周边网路 (DMZ) 中安装 SOLIDWORKS Workgroup PDM Web 服务器和 Workgroup PDM 浏览器存在有防火墙方面的牵连因素。

由于 Workgroup PDM 浏览器客户端通过 Web 服务器在 HTTP 或 HTTPS 端口上进行交流，这些端口必须在安装有 Web 服务器的 Internet Information Server (IIS) 系统上开放。

  • 对于 HTTP 协议，默认端口为 80。
  • 对于 HTTPS 协议 (SSL)，默认端口为 443。

Web Viewer 客户端自身不需要防火墙例外。

您必须确定 Web 服务器系统可通过这些默认端口上到达库服务器。

  • 30000（数据）
  • 40000（请求）

内容

  • 周边网路中 Workgroup PDM Viewer 的网路配置

    网路配置显示子网络上周边网路服务器设置以及其与内部和外部网路的交流。

  • 安装并配置 Workgroup PDM Web 服务器和浏览器

    当您在周边网路中设置 Workgroup PDM Web 服务器时，部件的安装位置很重要。

父主题
SOLIDWORKS Workgroup PDM
相关概念
Workgroup PDM 客户端访问
Workgroup PDM VaultAdmin 管理
相关任务
安装 Workgroup PDM 服务器
为客户端配置 Workgroup PDM
相关参考
Workgroup PDM 浏览器


周边网路中 Workgroup PDM Viewer 的网路配置

网路配置显示子网络上周边网路服务器设置以及其与内部和外部网路的交流。

周边网路服务器通过内部防火墙与 LAN 进行交流。它通过外部防火墙、路由器、或负载平衡器串与外部网路进行交流。

Internet Explorer 客户端通过 80 端口（如果配置到使用 SSL 则为 443 端口）连接到 Workgroup PDM Viewer/IIS 服务器。Workgroup PDM Viewer 然后可使用 30000 或 40000 端口连接到库服务器。库服务器将所需信息发回到 Workgroup PDM Viewer，此然后将信息回馈到 Internet Explorer 客户端。

周边网路 Web 服务器有两个 IP 地址：

  • LAN 上的内部 IP 地址
  • 由 ISP （英特网服务提供商）所提供的公共 IP 地址

周边网路中的 Web 服务器位于负载平衡器串之后。尽管您可直接进入 Web 服务器执行管理任务，周边网路中服务器的所有 Web 服务交通通过载荷平衡器处理。

载荷平衡器将服务器硬件 IP 地址在向公众敞开的网路段上转换到虚拟 IP（VIP）。如果您在附加到网路时浏览到 VIP 或 Web 服务器 URL，您可看到站点。

外部防火墙将载荷平衡器 VIP 转换到公共可路由的地址。

父主题
在周边网路中安装 Workgroup PDM 服务器和浏览器
相关任务
安装并配置 Workgroup PDM Web 服务器和浏览器


安装并配置 Workgroup PDM Web 服务器和浏览器

当您在周边网路中设置 Workgroup PDM Web 服务器时，部件的安装位置很重要。

  • 在周边子网路上安装 IIS-激活的 Web 服务器。
  • 在周边子网路上安装 IIS-激活的 Workgroup PDM 浏览器。
  • 在主域或本地内联网的内部网路上安装 Workgroup PDM 库。

在周边子网路上安装和配置 Workgroup PDM 浏览器的前提是：

  • Microsoft IIS 6.0 或以上
  • 周边子网络上由您的 ISP（英特网服务提供商）所指派的 Web 服务器公共 IP 地址。

要安装并配置 Workgroup PDM 部件：

  1. 在周边子网络服务器系统上安装 Microsoft IIS。
  2. 进行两种 SOLIDWORKS Workgroup PDM 服务器安装：
    1. 首先在库服务器上安装库组件。
    2. 再次运行安装程序并在 IIS Web 服务器上安装 Workgroup PDM 浏览器和浏览器许可组件。输入库服务器计算机名称，这样 Web 门户知道在何处查找库服务器服务。

    当您执行安装时，PDM Web 应用程序自动添加到默认的 IIS 网站。

  3. 确定内部网路的防火墙的端口 30000 和 40000 已打开。
  4. 如果内部服务器有固定的 IP 地址，在周边服务器系统上编辑 C:\Windows\system32\drivers\etc\hosts 文件。给 IP 地址映射生成一个系统名称，这样周边服务器可与内部服务器交流。
    1. 在文本编辑程序中（如记事本）打开 hosts 文件。
    2. 给库服务器 IP 地址和名称添加新行。
    3. 保存 hosts 文件。
父主题
在周边网路中安装 Workgroup PDM 服务器和浏览器
相关概念
周边网路中 Workgroup PDM Viewer 的网路配置


Workgroup PDM 客户端访问

Workgroup PDM 客户端使用 Microsoft Windows 登录访问控制，您可以通过 Workgroup PDM Viewer 进行 Web 访问，且会在每次 Workgroup PDM 库更新时自动更新。

要以 Workgroup PDM 客户端身份登录： | Workgroup PDM 中的用户名称和密码与 Microsoft Windows 登录不相同。有关登录信息，请联系您的系统管理员。
要连接到 Workgroup PDM Viewer： | 有关连接到 Viewer 的 URL，请联系您的系统管理员。
要更新 Workgroup PDM 客户端： | Workgroup PDM 客户端（SOLIDWORKS 插件和 Contributor）可检测库什么时候被更新过。 您不必下载 service pack 便能更新客户端。
父主题
SOLIDWORKS Workgroup PDM
相关概念
在周边网路中安装 Workgroup PDM 服务器和浏览器
Workgroup PDM VaultAdmin 管理
相关任务
安装 Workgroup PDM 服务器
为客户端配置 Workgroup PDM
相关参考
Workgroup PDM 浏览器


Workgroup PDM VaultAdmin 管理

在安装 Workgroup PDM 后，库管理员应执行下列任务。

  • 登录到 VaultAdmin。
  • 更改库管理员密码。
  • 创建用户帐户。
  • 通知用户其帐户名称和密码。

有关详细信息，请参阅 SOLIDWORKS 主帮助中的 SOLIDWORKS Workgroup PDM。

父主题
SOLIDWORKS Workgroup PDM
相关概念
在周边网路中安装 Workgroup PDM 服务器和浏览器
Workgroup PDM 客户端访问
相关任务
安装 Workgroup PDM 服务器
为客户端配置 Workgroup PDM
相关参考
Workgroup PDM 浏览器

初次登录到 Workgroup PDM VaultAdmin

初次登录到 Workgroup PDM VaultAdmin 时，请指定 Workgroup PDM 管理员名称和密码以及 Workgroup PDM Vault 所在计算机的名称。

  1. 在 Windows 中，单击 开始 > 所有程序 > SOLIDWORKS 版本 > Workgroup PDM VaultAdmin。
  2. 在对话框中，输入以下信息：

    名称 | pdmwadmin
    密码 | pdmwadmin
    库计算机 | 安装库的计算机的主机名。 如果您在安装库的计算机上运行 VaultAdmin，键入 localhost。

  3. 单击登录。
出于安全原因，我们推荐您为管理员尽早更改密码。在 VaultAdmin 中选择用户和组标签。

升级 Workgroup PDM Vault Server

您可以通过下列方法升级 Workgroup PDM Vault Server：使用 SOLIDWORKS 检查更新、SOLIDWORKS 安装 DVD 或者将 Workgroup PDM 升级文件手动下载到本地文件夹中。

只能安装一个版本的 Workgroup PDM Vault Server
  1. 要求所有用户从 Workgroup PDM 库中注销，然后将其锁定。
  2. 备份库数据。
  3. 使用 Microsoft Windows 控制面板中的添加/删除程序移除 Workgroup PDM Server 的当前版本。
  4. 安装 Workgroup PDM Server 的新版本。
    • 若要使用 SOLIDWORKS 检查更新：
      1. 在 Windows 中，单击开始 > 所有程序 > SOLIDWORKS 安装管理程序 > 检查更新。
      2. 在 有新版本可用 对话框中，选择下载并安装新版本，选择要安装的版本，然后单击下一步。

        SOLIDWORKS 安装管理程序的新版本将下载并运行。

    • 若要使用 SOLIDWORKS 安装 DVD，请将 DVD 放入驱动器中，然后按照 SOLIDWORKS 安装管理程序的说明操作。
    • 若要使用手动下载的 Workgroup PDM 安装文件 (pdmwserver.exe)，请双击该文件，然后按照说明操作以升级 Workgroup PDM Server。
  5. 使用 SOLIDWORKS Task Scheduler 更新库中的 Workgroup PDM 文件。
  6. 解除锁定库并通知用户可返回使用。

升级 Workgroup PDM 客户端

Workgroup PDM 客户端可检测到库何时被更新。您不必下载 service pack 便能更新客户端。

有关说明，请参阅Workgroup PDM 联机帮助中的更新客户端。


SOLIDWORKS PDM

SOLIDWORKS PDM 是与之前称为 SOLIDWORKS Enterprise PDM 的产品具有相同的客户端/服务器体系结构的文档管理产品。

SOLIDWORKS PDM 有两种类型：
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

SOLIDWORKS PDM 使用 Microsoft SQL Server 数据库来管理文件库。

此表列示各产品类型可用的数据库系统、服务器组件和客户端选项。
 | PDM Standard | PDM Professional
设计用途 | 小到中型办公网络，至多 5 个并发用户 | 大型办公网络，大量并发用户
界限 | 1 个 CPU，1 GB 内存，10 GB 数据库大小 | 无限制
数据库管理系统 | Microsoft SQL Server Express 2014（随 SOLIDWORKS 提供和安装） | Microsoft SQL Server 2014（随 SOLIDWORKS 单独提供），或之前安装的 Microsoft SQL Server 2014、2012 或 2008 R2 实例
是否需要 SolidNetWork License Manager？ | 是 | 是
是否包括存档服务器和数据库服务器？ | 是 | 是
是否包括 SOLIDWORKS PDM Web 服务器和 Web2 服务器？ | No | 是
客户端类型 | 本地 | 本地，基于浏览器
CAD Editor 的客户端插件 | SOLIDWORKS、DraftSight | SOLIDWORKS、DraftSight、Microsoft Office 集成、Autodesk Inventor、AutoCAD
Contributor 的客户端插件 | DraftSight | DraftSight、Microsoft Office 集成
Viewer 的客户端插件 |  | Microsoft Office 集成

内容

  • PDM 服务器组件列表

  • 选择您的客户端

    您必须根据您的 PDM 环境确定所需的客户端。

  • 安装 PDM 服务器之前

    安装 PDM 服务器组件之前请牢记这些要求：


PDM 服务器组件列表

此表概述了 SOLIDWORKS PDM 服务器的各服务器组件。

服务器 | Function | 安装
用于 PDM Standard 的 Microsoft SQL Server Express | 管理 SOLIDWORKS PDM 数据库中的数据。 | 可随 PDM Standard 安装，或者使用之前授权许可和安装的版本。
用于 PDM Professional 的 Microsoft SQL Server | 管理 SOLIDWORKS PDM 数据库中的数据。 | 单独随 PDM Professional 交付。 您还可使用之前授权许可和安装的版本。
SolidNetWork 许可管理程序 | 管理 SOLIDWORKS PDM 许可。 | 必须先进行安装才能创建新库。 使用 SLDIM 时，可随 SOLIDWORKS PDM 服务器组件一同安装。
存档服务器 | 管理客户端之间的文件传输、文件库存档以及用户及其凭据。 | 要求有。 随 PDM Standard 或 Professional 安装。
数据库服务器 | 轮询 PDM 数据库以获取更新并管理数据导入和导出规则、管理邮件信息系统以及计划复制和冷存储。 | 要求有。 随 PDM Standard 或 Professional 安装。
Web 服务器和 Web2 服务器 | 允许通过 Internet 从基于浏览器的客户端访问文件库。 | 可选。 仅可随 PDM Professional 安装。

存档服务器在安装它们的计算机的系统帐户上作为服务运行。 一个存档服务器在同一计算机上可承载多个文件库。

在独立安装中，存档服务器、数据库服务器、许可证服务器以及 SQL Express 或 SQL Server 数据库均可安装在同一台机器上。

在分布式环境中，服务器组件可位于不同机器上。 此外，可在不同计算机上设置多个存档服务器来托管同一文件库存档的复制型副本。 请参阅 SOLIDWORKS PDM Professional 复制指南。

父主题
SOLIDWORKS PDM
相关概念
选择您的客户端
安装 PDM 服务器之前


选择您的客户端

您必须根据您的 PDM 环境确定所需的客户端。

此表概述了 SOLIDWORKS PDM Standard 的各客户端：
Standard 客户端类型 | 说明
CAD Editor | 支持处理 SOLIDWORKS、DWG/DXF 和 Microsoft Office 文件。 Office 插件处理所有文件格式的方式与 SOLIDWORKS PDM Standard 相同。
贡献者 | 支持处理 SOLIDWORKS、DWG/DXF 和 Microsoft Office 文件。
查看者 | 允许以只读方式访问文件库。 用户可以通过工作流程变换文件，但用户不能添加或修改（检出、检入、更新值）文件。
此表概述了 SOLIDWORKS PDM Professional 的各客户端：
Professional 客户端类型 | 说明
CAD Editor & Web | 支持处理所有文件类型（包括增强的管理）和预览 CAD 格式（例如 SOLIDWORKS）。 CAD 插件允许用户从 CAD 应用程序内访问 SOLIDWORKS PDM Professional。 远程用户可使用 Web 和 Web2 客户端通过 Internet 搜索库并执行基本功能。
Contributor & Web | 支持处理所有的文件类型，包括 CAD 文件。 但是，此客户端类型不支持 CAD 插件。 远程用户可使用 Web 和 Web2 客户端通过 Internet 搜索库并执行基本功能。
查看者 | 允许以只读方式访问文件库。 用户可以通过工作流程变换文件，但用户不能添加或修改（检出、检入、更新值）文件或使用 CAD 插件。
父主题
SOLIDWORKS PDM
相关概念
PDM 服务器组件列表
安装 PDM 服务器之前


安装 PDM 服务器之前

安装 PDM 服务器组件之前请牢记这些要求：

  • 在要安装服务器和客户端的机器上获取完全管理权限。
  • 确保数据库服务器有权通过 TCP 端口 3030 访问存档服务器，以及通过 TCP 端口 1433 访问 SQL Server。
  • 如果您要使用现有的 SQL Server Express 或 SQL Server 数据库，请获取 SQL Server 数据库的名称以及具有数据库读写权限的 SQL Server 管理员或数据库所有者的帐户 ID 和密码。 您不能使用 tew 用户。
  • 如果系统上已安装 PDM 客户端，请将其卸载。 如果您想要 PDM 服务器和 PDM 客户端在同一系统上，则您必须使用 SOLIDWORKS PDM 服务器安装流程对这两者进行安装。

内容

  • 使用 SLDIM 安装 PDM 服务器

    当您为 PDM Standard 安装 PDM 服务器时，您可在同一台计算机上安装存档服务器、数据库服务器和 PDM CAD Editor 客户端。 您不需要单独运行客户端安装。

  • 使用 SLDIM 安装 PDM 客户端

父主题
SOLIDWORKS PDM
相关概念
PDM 服务器组件列表
选择您的客户端


使用 SLDIM 安装 PDM 服务器

当您为 PDM Standard 安装 PDM 服务器时，您可在同一台计算机上安装存档服务器、数据库服务器和 PDM CAD Editor 客户端。 您不需要单独运行客户端安装。

当您为 PDM Professional 安装 PDM 服务器时，您可包含上述组件以及 Web 服务器和 Web2 Server。

要安装 PDM 服务器及其组件：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页，选择服务器产品，然后选中以下选项：
    • 在此计算机上安装 SOLIDWORKS PDM 服务器组件。
    • 在此计算机上安装 SolidNetWork License Manager。

      如已安装 SolidNetwork License Manager，则不会显示此选项。

  3. 如果显示 SolidNetwork License Manager 选项页面，键入序列号并指定目录位置，然后单击下一步。
  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，对于 SOLIDWORKS PDM 服务器，单击更改。
  6. 在 SOLIDWORKS PDM 服务器选项页面上：
    1. 对于选择服务器产品，单击 SOLIDWORKS PDM Standard 或 Professional。
    2. 对于安装位置，单击浏览以指定文件路径。
    3. 在选择功能中：

      1. 单击存档服务器、数据库服务器和客户端以在同一台计算机上安装这些组件。 如果您在分布式环境中，则您也可通过在另一台计算机上运行安装管理程序来安装存档服务器和数据库服务器。
        如果已在计算机上安装 PDM 客户端，则您必须取消安装并卸载客户端。 然后您可运行 SLDIM 来一起安装 PDM 服务器和客户端。
      2. 如果您安装的是 PDM Professional，则您也可单击 Web 服务器和 Web2 Server。

    4. 在 SQL Server 中，您可安装 PDM 服务器随附的数据库和管理工具的新实例（对于 PDM Standard，即为 SQL Server Express），或者您也可指定现有实例的数据库名称、用户名和密码。

      PDM Professional 单独提供了完整版本的 SQL Server。

    5. 单击返回到摘要。
  7. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。

    当 SOLIDWORKS 安装管理程序完成安装后，将启动存档服务器配置工具。 按照向导中的提示配置存档服务器。

要设置和配置存档服务器、数据库服务器、Web 和 Web2 Server 以及 SQL Server 数据库并对其进行故障排除，请参阅 SOLIDWORKS PDM 2016 安装指南 中的相关主题。
父主题
安装 PDM 服务器之前
相关任务
使用 SLDIM 安装 PDM 客户端


使用 SLDIM 安装 PDM 客户端

要安装 PDM 客户端：

  1. 启动 SOLIDWORKS 安装管理程序。
  2. 在欢迎页，选择单机。
  3. 在序列号页面上，单击下一步。

    SOLIDWORKS PDM 不需要序列号。

  4. 请遵循系统警告的说明进行操作，然后单击下一步。
  5. 在摘要页面上，在产品下，单击更改。
  6. 在产品选择页面上，单击选择不同软件包或产品。
  7. 在选择您想显示的软件包对话框中，选择 SOLIDWORKS 版本。 然后单击确定。
  8. 在产品选择页面上，选择 SOLIDWORKS PDM 客户端。 然后选择 eDrawings 以启用 PDM 预览功能。 如果您使用的是 SOLIDWORKS PDM Professional，则您还可选择条目探索器。
  9. 在摘要页面上，展开 SOLIDWORKS PDM 选项，然后单击更改。
  10. 在 SOLIDWORKS PDM 客户端选项页面上，选择以下选项，然后单击返回到摘要：
    • PDM 产品类型
    • PDM 客户端类型
    • 插件
  11. 在摘要页面上，接受 SOLIDWORKS 许可协议条款，然后单击立即安装。
父主题
安装 PDM 服务器之前
相关任务
使用 SLDIM 安装 PDM 服务器


SOLIDWORKS Electrical

SOLIDWORKS Electrical 通过智能设计工具、综合零件数据库和 2D 图解与 3D 模型之间的实时迁移，简化了电气系统设计。

SOLIDWORKS Electrical 的主要组件为：
  • SOLIDWORKS Electrical Schematic 是用于 2D 动态电气图解创建的工具。
  • SOLIDWORKS Electrical 3D 是用于将 2D 图解与 3D 模型集成的工具，使您可以 3D 形式建模电气系统（包括电缆和电线）。
  • 数据 - 用户可以共享零件、符号、库和目录的数据库。
  • 协作服务器 - 管理电力工程图打开和更新的实用程序。
  • Microsoft SQL Server 数据库的实例。

SOLIDWORKS Electrical 需要一个 Microsoft SQL Server 数据库。 可以将现有数据库或新的实例用作安装的一部分。

您可以在同一台机器上安装所有 SOLIDWORKS Electrical 组件。 该安装通常被视为单机版安装。 所有程序数据（例如项目工程图和报告）均存储在单一系统中。 安装 SOLIDWORKS Electrical 之前，需要系统的完全管理权限。

您也可以安装 SOLIDWORKS Electrical 组件作为客户端/服务器应用程序。 数据必须存储在网络服务器时或网络服务器上的现有 SQL Server 数据库存储所有 SOLIDWORKS Electrical 数据库时，要求进行此安装。 在这些情况中，服务器和客户端系统均要求完全管理权限。 而且，客户端系统必须具有对服务器的网络访问权限和创建项目、库和符号的读取/写入权限。

内容

  • 管理 SOLIDWORKS Electrical 中的数据

  • 安装 SOLIDWORKS Electrical 的要求


管理 SOLIDWORKS Electrical 中的数据

很多程序使用包含所有程序数据的的单一数据库。 这与 SOLIDWORKS Electrical 的情况不同。SOLIDWORKS Electrical 的每个项目分配有唯一 ID 号码，且每个项目都有可以基于唯一 ID 号码识别的相关数据库。 例如，在 SOLIDWORKS Electrical Project Manager 中，如果您找到的项目为 ID#112，则关联的数据库名称为 “tew_project_data_112”。

为每个项目分配唯一数据库的原因是，这样可以显著缩短处理时间。 而且，在关键数据库故障时，仅有一个项目会受到影响，大部分程序信息的完整性会得以保留。

但是，一些公司有限制创建新数据库的策略。 要运行 SOLIDWORKS Electrical，不应限制用户创建新数据库。 请向系统管理员或数据库管理员核实，以确保不会有配置阻止用户创建新数据库。
父主题
SOLIDWORKS Electrical
相关概念
安装 SOLIDWORKS Electrical 的要求


安装 SOLIDWORKS Electrical 的要求

欲访问当前的系统要求，请参阅 http://solidworks.com/System_Requirements。

内容

  • 单机型和服务器安装选项

    您可以在单机型和服务器模式中安装 SOLIDWORKS Electrical。

  • 指定数据位置

  • 配置协作服务器

  • 配置 Microsoft SQL Server

父主题
SOLIDWORKS Electrical
相关概念
管理 SOLIDWORKS Electrical 中的数据


单机型和服务器安装选项

您可以在单机型和服务器模式中安装 SOLIDWORKS Electrical。

必须注意 SOLIDWORKS Electrical 需要连接到一个 SQL Server 的实例（无论是现有实例还是新实例）。

在单机模式中，您可以安装以下组件：
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • 协作服务器
  • 数据
  • SQL Server 数据库的新实例
在服务器模式中，您可以安装以下组件：
  • SQL Server 数据库的新实例
  • 协作服务器
  • 数据

您可以组合单机和服务器模式中的组件，以创建客户端/服务器环境。 例如，您可以在客户端系统上安装 SOLIDWORKS Electrical Schematic 和 SOLIDWORKS Electrical 3D，并在服务器系统上安装所有服务器组件。

父主题
安装 SOLIDWORKS Electrical 的要求
相关概念
指定数据位置
配置协作服务器
配置 Microsoft SQL Server


指定数据位置

关于数据位置，选择一个目录来存储程序数据，例如零件、模板和 2D 及 3D 符号。 该位置应该为专用目录。 它不能是根目录或用于存储 SOLIDWORKS 数据的同一目录。

默认目录为 C:\ProgramData\SOLIDWORKS Electrical。名为 更新 的文件夹添加到了同一目录以存储所有可用程序数据。

当您第一次启动 SOLIDWORKS Electrical 时，会显示 更新数据 向导。 在此向导中，您可以选择要添加到应用程序和 SQL Server 数据库的数据。
父主题
安装 SOLIDWORKS Electrical 的要求
相关概念
单机型和服务器安装选项
配置协作服务器
配置 Microsoft SQL Server


配置协作服务器

欲运行 SOLIDWORKS Electrical，您必须在承载 Microsoft SQL Server 数据库的同一系统上安装协作服务器。

协作服务器必须始终运行，且通过防火墙和病毒扫描工具与客户端进行固定、不间断的双向通信。

无论在单机或服务器模式中安装协作服务器，您必须指定以下参数：
  • 机器名称，例如 LOCALHOST
  • 机器的 IP 地址，例如 127.0.0.1
  • 端口号，例如 26666

要提供不间断的双向通信，请确保端口号 26666 可用于安装有协作服务器的系统上。 如果端口 26666 无法访问，则与系统管理员合作查找 SOLIDWORKS Electrical 可以访问的其他端口。

父主题
安装 SOLIDWORKS Electrical 的要求
相关概念
单机型和服务器安装选项
指定数据位置
配置 Microsoft SQL Server


配置 Microsoft SQL Server

您必须确保 SQL Server 数据库的一个实例可用于任何类型的 SOLIDWORKS Electrical 安装。 如果现有的 SQL Server 数据库已安装到系统，或安装新的实例作为 SOLIDWORKS Electrical 安装的一部分，则您可以使用现有的 SQL Server 数据库。

当您安装新的 SQL Server 实例时，SOLIDWORKS 安装将提供 Microsoft SQL Server Express 的免费版本。 该版本限于 1 个 CPU，1 GB 内存和 10 GB 数据。 内存和 CPU 限制足够同时支持 5 个用户。

如果您安装 SQL Server Express 版本，请确保服务器软件和硬件满足 http://solidworks.com/System_Requirements 中列出的要求。

但是，如果同一服务器上同时出现 6 个或更多用户时，您需要购买并安装 SQL Server 的完整版本，并使用用于安装带有现有 SQL Server 实例的 SOLIDWORKS Electrical 所描述的工作流程。

关于 SQL Server Express 版本的信息，请参阅 Microsoft SQL Server 文档资料。

父主题
安装 SOLIDWORKS Electrical 的要求
相关概念
单机型和服务器安装选项
指定数据位置
配置协作服务器

SQL Server 的新实例

如果您安装 SQL Server 的新实例，则需要服务器和任意客户端系统的完全管理权限。 您还必须确保客户端具有数据库的读/写权限，以便客户端可以创建并修改项目、库、符号和其他项目数据。

安装 SQL Server 的新实例时，请选择一个名称，而非选择默认。

SQL Server 的现有实例

您需要有一个对 SQL Server 数据库有完全管理权限的用户账户，以在现有 SQL Server 实例上安装新的 SOLIDWORKS Electrical 数据库或连接到 SOLIDWORKS Electrical 安装。

要使 SOLIDWORKS Electrical 妥当运行，您必须启用 SQL Server 的混合模式身份验证。 混合模式身份验证允许使用 Windows 或 SQL Server 证书。

要连接现有 SQL Server 数据库，您可以使用 Windows 或 SQL Server 身份验证。 输入具有完全管理权限的 Windows 或 SQL Server 登录的用户名和密码。

您不能使用 ‘tew’ 用户连接 SQL Server 进行安装。 请联系您的 SQL Server 管理员或系统管理员获得帮助，以获取 SQL Server 适当证书的登录名。

SQL Server 的后安装

安装 SOLIDWORKS Electrical 后，SQL Server 实例在 SOLIDWORKS Electrical 中创建以下数据库：
  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION
  • TEW_SQLEXPRESS


许可管理

安装后，您可以通过两种方式激活 SOLIDWORKS 许可：激活个人计算机（许可激活），或在服务器上安装并激活浮动网络许可（SolidNetWork 许可颁发）。

一般而言，在个人计算机上进行的安装需要使用许可激活；但是，您也可以单独安装软件，然后通过 SolidNetWork 许可管理器控制许可。与之相反的是，尽管大型场所通常使用浮动网络许可，但是您可以从管理映像调用安装，然后从个人计算机激活序列号。

如果您正在运行 Windows 8，则请参阅通过 Microsoft Windows 8 使用 SOLIDWORKS 的提示，对于任务，例如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 参阅 Microsoft Windows 文档了解其他说明和选项。

内容

  • 管理个人许可

    通常，管理个人许可包括直接从 SOLIDWORKS 激活和转移许可。

  • 使用 SolidNetWork 许可管理器管理许可

    SolidNetWork 许可管理器可通过向网络中的客户端分发许可，支持多个许可客户端。这样就能够利用浮动许可，允许用户数量超过许可数量。


管理个人许可

通常，管理个人许可包括直接从 SOLIDWORKS 激活和转移许可。

激活是 SOLIDWORKS 单机（非 SolidNetWork 许可）许可的产品许可颁发和注册过程。 通常，如果产品许可尚未激活，在您启动产品时 SOLIDWORKS 会尝试激活该许可。

您也可以在 SOLIDWORKS 中单击帮助 > 转移许可，以转移个人许可。

父主题
许可管理
相关概念
使用 SolidNetWork 许可管理器管理许可

激活许可

您必须首先激活单台计算机的许可，才能在该计算机上运行 SOLIDWORKS 产品。

激活要求您有因特网或电子邮件的访问权限。激活后，您不必上网即可使用该产品。如果您使用该产品的计算机上无法访问电子邮件，您可以保存激活文件并从另一计算机上发送。

该过程将：
  • 激活 SOLIDWORKS 产品系列的所有软件许可。
  • 允许您将许可权从一台计算机转移到另一台计算机。
  • 可立即执行（推荐）或在安装 30 天内执行。
  • 消除硬件锁 (dongle) 的必要。 但是，如果您运行不使用激活的先前 SOLIDWORKS 产品版本，则必须保留硬件锁。

对于需要管理多个序列号的系统管理员，可以使用管理映像选项编辑器。 有关详细信息，请参阅管理映像选项编辑器。

要激活许可：

  1. 启动 SOLIDWORKS 应用程序。
  2. 使用以下方法之一启动 SOLIDWORKS 产品激活：
    • 如果您尚未激活该计算机的许可，SOLIDWORKS 产品激活窗口将在您启动 SOLIDWORKS 时自动出现。
    • 如果 SOLIDWORKS 产品激活窗口未自动出现，可单击 帮助 > 激活许可 启动激活。
  3. 单击产品列表，指定您想要为其激活许可的产品。
  4. 指定通过因特网自动激活或使用电子邮件手动激活。
  5. 提供电子邮件联系信息。
  6. 单击下一步继续。
    • 因特网：自动激活。
    • 电子邮件: 按下保存生成请求文件，然后将该文件发送到 activation@solidworks.com。在收到包含响应文件的电子邮件后，从电子邮件中提取文件，然后单击打开以加载该文件。
      如有必要，可以退出并返回激活程序以打开响应文件。
  7. 单击完成。
相关参考
管理映像选项编辑器

转移许可

若要将许可转移到新计算机或升级的计算机上，请首先将其转移到 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器上，然后再在其他计算机上重新激活该密钥。

如果您无法将许可转移到 Dassault Systèmes SOLIDWORKS Corporation（例如由于硬件故障），在大部分情况下仍然能够成功地重新激活。 如果没成功，请与您的经销商联系。

要将许可传回服务器：

  1. 在 SOLIDWORKS 中，单击帮助 > 转移许可，然后按照指示操作。
  2. 若要重新激活，请转到新计算机或升级的计算机，并按照初始激活程序激活许可。 有关详细信息，请参阅激活许可。


使用 SolidNetWork 许可管理器管理许可

SolidNetWork 许可管理器可通过向网络中的客户端分发许可，支持多个许可客户端。这样就能够利用浮动许可，允许用户数量超过许可数量。

下图显示了典型的 SolidNetWork 许可安装：

此图说明：
  • SolidNetWork 许可管理器软件仅可在许可管理器计算机上安装和激活。
  • 许可客户端计算机没有安装额外的特定 SolidNetWork 软件。

    如果您在安装时指定了 SolidNetWork 许可序列号，SOLIDWORKS 安装管理程序将把该计算机识别为 SolidNetWork 许可客户端。 SOLIDWORKS 安装管理程序将向您提示客户端连接到许可管理程序时使用的 SolidNetWork 许可管理器计算机名和端口号。

  • 许可管理器和所有许可客户端都必须使用 TCP/IP（传输控制协议/因特网协议）连接。

内容

  • 激活 SolidNetWork 许可

    您必须首先在 SolidNetWork 许可管理器计算机上激活 SolidNetWork 许可，才能在单台计算机上运行 SOLIDWORKS 产品。

  • 转移 SolidNetWork 许可

    若要将 SolidNetWork 许可转移到新计算机或升级的计算机上，首先将其转移到 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器，然后再在其他计算机上重新激活该密钥。

  • 安装和配置 SolidNetWork 许可

    配置 SolidNetWork 许可包括在许可管理器计算机上安装 SolidNetWork 许可管理器，然后在客户端计算机上使用 SolidNetWork 许可序列号安装 SOLIDWORKS。

  • SolidNetWork 许可管理

    任务包括启动、升级和卸载许可管理器，以及借用和归还许可。

父主题
许可管理
相关概念
管理个人许可


激活 SolidNetWork 许可

您必须首先在 SolidNetWork 许可管理器计算机上激活 SolidNetWork 许可，才能在单台计算机上运行 SOLIDWORKS 产品。

激活要求您有因特网或电子邮件的访问权限。激活后，您不必上网即可使用该产品。如果您使用该产品的计算机上无法访问电子邮件，您可以保存激活文件并从另一计算机上发送。

该过程将：
  • 激活所有 SOLIDWORKS 产品拥有 SolidNetWork 许可的 SOLIDWORKS SolidNetWork 许可管理器。
  • 允许您将 SolidNetWork 许可权限从一台 SolidNetWork 许可管理器计算机转移到另一计算机。
  • 使您能够在一台 SolidNetWork 许可管理器计算机上安装并激活 SolidNetWork 许可权限。
  • 必须执行，您才能使用 SolidNetWork 许可。
  • 消除硬件锁 (dongle) 的必要。 如果您为此版本的 SOLIDWORKS 激活 SolidNetWork 许可，旧版 SOLIDWORKS 的 SolidNetWork 许可也激活。 （您无需再保留硬件锁。）

要激活 SolidNetWork 许可：

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 如果您尚未激活 SolidNetWork 许可，则将询问您是否现在激活。 单击是以激活。
  3. 在您想如何激活？下，选择通过因特网自动激活（推荐）。
  4. 在联系信息下，指定电子邮件联系地址。
激活/重新激活成功对话框显示所有已激活的产品。
父主题
使用 SolidNetWork 许可管理器管理许可
相关概念
安装和配置 SolidNetWork 许可
SolidNetWork 许可管理
相关任务
转移 SolidNetWork 许可


转移 SolidNetWork 许可

若要将 SolidNetWork 许可转移到新计算机或升级的计算机上，首先将其转移到 Dassault Systèmes SOLIDWORKS Corporation 的许可密钥服务器，然后再在其他计算机上重新激活该密钥。

如果您无法将许可转移到 Dassault Systèmes SOLIDWORKS Corporation（例如由于硬件故障），在大部分情况下仍然能够成功地重新激活。 如果没成功，请与您的经销商联系。

若要将 SolidNetWork 许可转移回服务器：

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。

  2. 在 许可信息 下，单击 修改。 SOLIDWORKS 产品激活向导启动。
  3. 在您想怎么办？下，选择转移软件许可，然后单击下一步。
  4. 在您想如何转移？下，选择通过因特网自动转移（推荐）。
  5. 在联系信息下，指定电子邮件联系地址。
  6. 单击下一步。 产品许可转移完成。
父主题
使用 SolidNetWork 许可管理器管理许可
相关概念
安装和配置 SolidNetWork 许可
SolidNetWork 许可管理
相关任务
激活 SolidNetWork 许可


安装和配置 SolidNetWork 许可

配置 SolidNetWork 许可包括在许可管理器计算机上安装 SolidNetWork 许可管理器，然后在客户端计算机上使用 SolidNetWork 许可序列号安装 SOLIDWORKS。

内容

  • 安装并激活许可管理器

    SolidNetWork 许可管理器支持多个许可客户端。它在网络上为客户端分发许可。

  • 安装许可客户端

    在 SolidNetWork 许可客户端计算机上安装 SOLIDWORKS 时，序列号将该计算机识别为 SolidNetWork 许可客户端。

  • 在安装许可客户端之前安装 SolidNetWork 许可管理器

    在安装任何 SolidNetWork 许可客户端计算机之前，至少应在一台计算机上安装并配置 SolidNetWork 许可管理器。

  • 管理 SOLIDWORKS 版本的访问权限

    您可在 SolidNetWork 环境中限制用户使用特定版本的 SOLIDWORKS。 此功能让您能够管理不同个人、项目和业务单位所使用的 SOLIDWORKS 版本。

  • 三合一许可管理器安装

    三合一许可管理器使用三台计算机以确保万无一失。如果管理许可文件的计算机不可使用，另外两台计算机之一将接管。

  • 在防火墙中使用 SolidNetWork 许可

    如果您的计算机使用防火墙，您必须配置相应的端口来支持 SolidNetWork 许可。

父主题
使用 SolidNetWork 许可管理器管理许可
相关概念
SolidNetWork 许可管理
相关任务
激活 SolidNetWork 许可
转移 SolidNetWork 许可


安装并激活许可管理器

SolidNetWork 许可管理器支持多个许可客户端。它在网络上为客户端分发许可。

如果您在从为许可激活使用硬件锁的 SolidNetWork 许可管理器先前版本进行升级，在安装 SolidNetWork 许可管理器的新版本之前移除硬件锁。

  1. 启动 SOLIDWORKS 安装管理程序（如初始化 SOLIDWORKS 安装中所述）。
    1. 请从下列安装类型中选择一种：

      • 服务器产品
      • 在这台计算机上安装 SolidNetWork 许可管理器（分布式许可）。

    2. 在 SolidNetWork 许可管理器选项页面上，指定 SolidNetWork 许可序列号和 SolidNetWork 许可管理器安装位置。
    3. 在 摘要 页面上，单击 立即安装 以完成 SOLIDWORKS 安装管理程序过程。
  2. 要激活 SolidNetWork 许可使用：
    1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
    2. 在提示您激活时，单击是。
    3. 在 SolidNetWork 许可服务器信息屏幕上：

      • 如果您的公司使用防火墙，请选择 此服务器上使用了防火墙。

        有关更多信息，请参阅使用具有防火墙的 SolidNetWork 许可。

      • 使用端口号（如果您使用防火墙，还包括供应商端口监控程序端口号）的默认值，或指定您的公司所使用的端口号。
        端口号是 1024-60000 范围内的 TCP/IP 端口号，由此进程独自使用。 正常情况下，默认值 (25734) 即适合，也不会与许可管理器计算机上当前其他 FLEXnet 服务器进程相同。

    4. 在激活您的 SOLIDWORKS 产品屏幕上：

      • 选取因特网或电子邮件步骤。
      • 提供电子邮件联系信息。
      • 单击下一步继续。
        • 因特网： 自动激活。
        • 电子邮件: 按下保存生成请求文件，然后将该文件发送到 activation@solidworks.com。在收到包含响应文件的电子邮件后，从电子邮件中提取文件，然后单击打开以加载该文件。
          如有必要，可以退出并返回激活程序以打开响应文件。

  3. 单击完成。
父主题
安装和配置 SolidNetWork 许可
相关概念
在安装许可客户端之前安装 SolidNetWork 许可管理器
三合一许可管理器安装
在防火墙中使用 SolidNetWork 许可
相关任务
安装许可客户端
管理 SOLIDWORKS 版本的访问权限
启动 SOLIDWORKS 安装


安装许可客户端

在 SolidNetWork 许可客户端计算机上安装 SOLIDWORKS 时，序列号将该计算机识别为 SolidNetWork 许可客户端。

  1. 启动 SOLIDWORKS 安装管理程序（如初始化 SOLIDWORKS 安装中所述）。
  2. 如果是首次在这台计算机上安装此主要版本，请在欢迎屏幕上单击 单机安装（此计算机上）。

    如果从现有版本升级且将个人许可更改为 SolidNetWork 许可，请单击 修改单机安装（此计算机上）。。有关详细信息，请参阅从个人许可升级到 SolidNetWork 许可。

  3. 在提示您输入序列号时，输入 SolidNetWork 许可序列号。
  4. 在添加服务器对话框中，键入 SolidNetWork 许可管理器的地址，格式为：

    端口@计算机名

    端口号必须与许可管理器计算机使用的相同。 默认为 25734（如安装和激活许可管理器中所述）。

    SOLIDWORKS 安装管理器将尝试验证此 SolidNetWork 许可管理器是否可访问。 如果您尚未安装许可管理器，此验证将失败；但是，您仍然可以继续进行许可客户端安装。

  5. 按照 SOLIDWORKS 安装管理器的说明完成 SOLIDWORKS 安装程序。
父主题
安装和配置 SolidNetWork 许可
相关概念
在安装许可客户端之前安装 SolidNetWork 许可管理器
三合一许可管理器安装
在防火墙中使用 SolidNetWork 许可
从个人许可升级为 SolidNetWork 许可
相关任务
安装并激活许可管理器
管理 SOLIDWORKS 版本的访问权限
启动 SOLIDWORKS 安装


在安装许可客户端之前安装 SolidNetWork 许可管理器

在安装任何 SolidNetWork 许可客户端计算机之前，至少应在一台计算机上安装并配置 SolidNetWork 许可管理器。

在使用 SolidNetWork 许可序列号安装时，SOLIDWORKS 安装管理程序将提示您输入 SolidNetWork 许可管理器的计算机名和端口号，然后提示您验证该信息。

如果您尚未在自己指定的计算机上安装 SolidNetWork 许可管理器，此验证将不会成功。但是，在这种情况下，验证失败不表示您是否提供了正确的许可管理器信息。如果已安装了许可管理器，验证失败就表示您指定的许可管理器信息不正确。

父主题
安装和配置 SolidNetWork 许可
相关概念
三合一许可管理器安装
在防火墙中使用 SolidNetWork 许可
相关任务
安装并激活许可管理器
安装许可客户端
管理 SOLIDWORKS 版本的访问权限


管理 SOLIDWORKS 版本的访问权限

您可在 SolidNetWork 环境中限制用户使用特定版本的 SOLIDWORKS。 此功能让您能够管理不同个人、项目和业务单位所使用的 SOLIDWORKS 版本。

要使用 FLEXnet 选项文件管理 SOLIDWORKS 版本的访问权限：

  1. 在 SolidNetwork 许可管理器安装目录中，创建一个文本文件：

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. 要在许可文件中管理特定 SOLIDWORKS 版本的访问权限，将以下语法添加到 SOLIDWORKS 旁边：

    :SWVERSION=xx 其中 xx 是您要管理的 SOLIDWORKS 产品的版本

  3. 要管理多个版本的 SOLIDWORKS，为您要管理的每个版本均添加一行。

    并非所有 FLEXnet 选项均受到支持。 受支持的版本过滤器选项包括：

    INCLUDE | 仅允许用户或组启动特定版本。 所有其他用户不允许启动该版本。
    INCLUDE_BORROW | 仅允许用户或组借用特定版本。 所有其他用户不允许借用该版本。
    EXCLUDE | 禁止列示的用户或组启动特定版本的 SOLIDWORKS。 EXCLUDE 可取代 INCLUDE。
    EXCLUDE_BORROW | 禁止列示的用户或组借用特定版本的 SOLIDWORKS。 EXCLUDE 可取代 INCLUDE。
    范例：
    1 | SWVERSION=24.0 指 SOLIDWORKS 2016
    SWVERSION=23.0 指 SOLIDWORKS 2015
    2 | INCLUDE solidworks:SWVERSION=24.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=24.0 USER jane
    选项文件中的这些行将仅允许 jane 运行或借用 SOLIDWORKS 2016。所有其他用户均不能运行或借用 SOLIDWORKS 2016，但他们可运行或借用其他版本的 SOLIDWORKS。jane 也可运行和借用其他版本的 SOLIWORKS。
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=24.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=23.0 GROUP chicago
    EXCLUDE solidworks USER don
    这些行定义了名为 chicago 的用户组并且拒绝他们访问 SOLIDWORKS 2015 和 SOLIDWORKS 2016，但他们可运行任何其他版本的 SOLIDWORKS。 用户 don 不能运行任何版本的 SOLIDWORKS。
    4 | EXCLUDE swinspection_std:SWVERSION=24.0 HOST machine1
    此行禁止 machine1 上的任何用户启动 SOLIDWORKS Inspection 2016。但是 machine1 上的用户可运行另一版本，即 SOLIDWORKS Inspection 2015。

    有关 FLEXnet 的详细信息，请参阅 SolidNetwork License Manager 安装目录下的 FLEXnet Publisher 许可管理指南 (\Docs\flexuser\licensingenduserguide.pdf)。

父主题
安装和配置 SolidNetWork 许可
相关概念
在安装许可客户端之前安装 SolidNetWork 许可管理器
三合一许可管理器安装
在防火墙中使用 SolidNetWork 许可
相关任务
安装并激活许可管理器
安装许可客户端


三合一许可管理器安装

三合一许可管理器使用三台计算机以确保万无一失。如果管理许可文件的计算机不可使用，另外两台计算机之一将接管。

使用三合一许可管理器的要求：
  • 要求有三个硬件锁 (dongle)。
  • 三合一许可管理器只能安装在不常关机的计算机上。
  • 三台许可管理器应在同一子网络上。不要使用通信速度较低的链接或拨号链接配置三合一许可管理器。
  • 系统管理员应及时探测到许可管理器何时死机并且尽快重新开机。
    如果只有两台许可管理器计算机在运行，这种状况比单一许可管理器更糟，因为有两个故障点。

内容

  • 安装初始三合一许可管理器

    三合一许可管理器使用三台计算机以确保万无一失。此过程显示如何在三合一组合的第一台计算机上安装 SolidNetWork 许可管理器。

  • 在随后的计算机上安装三合一许可管理器

    三合一许可管理器使用三台计算机以确保万无一失。此过程显示如何在三合一组合的第二台和第三台计算机上安装 SolidNetWork 许可管理器。

父主题
安装和配置 SolidNetWork 许可
相关概念
在安装许可客户端之前安装 SolidNetWork 许可管理器
在防火墙中使用 SolidNetWork 许可
相关任务
安装并激活许可管理器
安装许可客户端
管理 SOLIDWORKS 版本的访问权限


安装初始三合一许可管理器

三合一许可管理器使用三台计算机以确保万无一失。此过程显示如何在三合一组合的第一台计算机上安装 SolidNetWork 许可管理器。

  1. 在三合一许可管理器的第一台计算机上，使用 SOLIDWORKS 安装管理程序安装 SolidNetWork 许可管理器：
    1. 启动 SOLIDWORKS 安装管理程序（如初始化 SOLIDWORKS 安装中所述）。
    2. 请从下列安装类型中选择一种：

      • 服务器产品
      • 在这台计算机上安装 SolidNetWork 许可管理器（分布式许可）。

    3. 在 SolidNetWork 许可管理器选项页面上，指定 SolidNetWork 许可序列号和 SolidNetWork 许可管理器安装位置。
    4. 在 摘要 页面上，单击 立即安装 以完成 SOLIDWORKS 安装管理程序过程。
  2. 使用 SolidNetWork 许可管理器配置三合一许可管理器的初始计算机：
    1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
    2. 单击否。

      此时将出现 SOLIDWORKS SolidNetwork 许可管理器的“服务器管理”选项卡。

    3. 在高级选项下，单击选项。

      高级选项对话框出现。

    4. 在 SolidNetWork 服务器许可模式下，单击使用许可文件，然后单击确定。

      高级选项 对话框关闭。

    5. 在许可信息下，单击修改。

      SolidNetWork 许可文件向导出现。

    6. 在服务器类型下，选择三合一，然后单击下一步。
    7. 在“服务器信息”窗格中，验证三合一许可管理器的初始计算机的计算机名、硬件锁 ID 和端口号正确无误，然后单击下一步。

      如果服务器使用网络接口卡 (NIC) 地址，而非硬件锁，则检查 NIC 地址是否与从 SOLIDWORKS 接收到的许可文件中的信息相匹配，以及三合一许可管理器计算机的端口号是否正确。 NIC 地址也被称为 MAC（媒体访问控制地址）地址。 然后单击 下一步。

      要查找 NIC 地址，打开命令提示符窗口，然后键入：

      ipconfig /all

      并且，如果您的计算机使用防火墙，您可能需要在此屏幕上指定其他信息。 有关更多信息，请参阅使用具有防火墙的 SolidNetWork 许可。

    8. 在 三合一伙伴服务器信息 屏幕上，输入三合一许可证管理器的其他两台计算机的计算机名和硬件锁 ID 值。 如果计算机使用 NIC 地址，输入计算机名和主机 ID 值。

      这样可确保如果一个许可管理器不可用，客户端计算机可从其他两台服务器获得许可。

    9. 在许可屏幕上，单击读取浏览并打开 SolidNetWork 许可文件。

      许可出现在 SolidNetWork 许可文件向导中。

    10. 单击完成。
    11. 单击确定退出 SolidNetWork 许可文件向导，然后单击完成退出 SolidNetWork 许可管理器。
父主题
三合一许可管理器安装
相关概念
在防火墙中使用 SolidNetWork 许可
相关任务
在随后的计算机上安装三合一许可管理器
启动 SOLIDWORKS 安装


在随后的计算机上安装三合一许可管理器

三合一许可管理器使用三台计算机以确保万无一失。此过程显示如何在三合一组合的第二台和第三台计算机上安装 SolidNetWork 许可管理器。

假定您已在另一台计算机上安装了至少一个三合一许可管理器。

  1. 在三合一许可管理器的计算机上，使用 SOLIDWORKS 安装管理程序安装 SolidNetWork 许可管理器：
    1. 启动 SOLIDWORKS 安装管理程序（如 启动 SOLIDWORKS 安装 中所述）。
    2. 请从下列安装类型中选择一种：

      • 服务器产品
      • 在这台计算机上安装 SolidNetWork 许可管理器（分布式许可）。

    3. 在 在 SolidNetWork 许可管理器选项 页面上指定 SolidNetWork License 序列号和 SolidNetWork License Manager 安装位置。
    4. 在 摘要 页面上，单击 立即安装 以完成 SOLIDWORKS 安装管理程序过程。
  2. 使用 SolidNetWork 许可管理器配置三合一许可管理器计算机：
    1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。

      由于这是在这台计算机上首次运行 SolidNetWork 许可管理器，系统将会询问您是否要现在激活。

    2. 单击否。

      此时将出现 SOLIDWORKS SolidNetwork 许可管理器的“服务器管理”选项卡。

    3. 在高级选项下，单击选项。

      高级选项对话框出现。

    4. 在 SolidNetWork 服务器许可模式下，单击使用许可文件，然后单击确定。

      高级选项 对话框关闭。

    5. 在许可信息下，单击修改。

      SolidNetWork 许可文件向导出现。

    6. 在服务器类型下，选择三合一和同步服务器/许可信息，然后单击下一步。
    7. 在“服务器信息”窗格中，验证三合一许可管理器计算机的计算机名、硬件锁 ID 和端口号正确无误，然后单击下一步。

      如果服务器使用网络接口卡 (NIC) 地址，而非硬件锁，则检查 NIC 地址是否与从 SOLIDWORKS 接收到的许可文件中的信息相匹配，以及三合一许可管理器计算机的端口号是否正确。 NIC 地址也被称为 MAC（媒体访问控制地址）地址。 然后单击 下一步。

      要查找 NIC 地址，打开命令提示符窗口，然后键入：

      ipconfig /all

      并且，如果您的计算机使用防火墙，您可能需要在此屏幕上指定其他信息。 有关详细信息，请参阅在防火墙中使用 SolidNetWork 许可。

    8. 如果计算机使用硬件锁，在 三合一伙伴服务器信息 屏幕上，输入三合一许可证管理器的其他两台计算机的计算机名和硬件锁 ID 值。 如果计算机使用 NIC 地址，输入计算机名和主机 ID 值。

      这样可确保如果一个许可管理器不可用，客户端计算机可从其他两台服务器获得许可。

    9. 在许可屏幕上，单击读取浏览并打开 SolidNetWork 许可文件。

      通常，许可文件位于您配置的三合一许可管理器第一台计算机上的 \licenses\sw_d.lic。

      许可出现在 SolidNetWork 许可文件向导中。

    10. 单击完成。

      SolidNetWork 许可文件向导警告出现。

    11. 单击确定退出 SolidNetWork 许可文件向导，然后单击完成退出 SolidNetWork 许可管理器。

如果您正在配置三合一许可管理器的第二台计算机，请为三合一许可管理器的第三台计算机重复此过程。

父主题
三合一许可管理器安装
相关任务
安装初始三合一许可管理器


在防火墙中使用 SolidNetWork 许可

如果您的计算机使用防火墙，您必须配置相应的端口来支持 SolidNetWork 许可。

在防火墙软件中，您必须在防火墙例外清单中添加两个 SolidNetWork 许可端口（例如，SNL-in-port 和 SNL-out-port）。有关配置这些端口的详细信息，请咨询您的系统管理员。

如果您使用 Windows 操作系统上的 Windows 防火墙，则您必须在 SolidNetWork 许可管理器计算机上修改端口，并修改 SolidNetWork 许可文件，以向许可客户端计算机分发许可。

内容

  • 修改用于 Windows 防火墙的许可管理器计算机端口

    如果您使用 Windows 防火墙，您必须在 SolidNetWork 许可管理器计算机上修改防火墙端口设置。

  • 修改用于 Windows 防火墙的 SolidNetWork 许可管理器设置

    如果您使用 Windows 防火墙，则必须修改 SolidNetWork 许可文件才能使用防火墙端口向许可客户端计算机分发许可。

父主题
安装和配置 SolidNetWork 许可
相关概念
在安装许可客户端之前安装 SolidNetWork 许可管理器
三合一许可管理器安装
相关任务
安装并激活许可管理器
安装许可客户端
管理 SOLIDWORKS 版本的访问权限


修改用于 Windows 防火墙的许可管理器计算机端口

如果您使用 Windows 防火墙，您必须在 SolidNetWork 许可管理器计算机上修改防火墙端口设置。

  1. 在 Windows 中，打开控制面板，然后双击安全中心。
  2. 单击 Windows 防火墙。
  3. 在例外选项卡上单击添加端口。
  4. 键入名称（例如 SNL-in-port）和端口号（例如 25734），然后单击确定。
  5. 对于第二个端口，再次在例外选项卡上单击添加端口，指定其他端口名称和端口号（例如 SNL-out-port 和 25735），然后单击确定。记下端口号，以便在日后修改 SolidNetWork 许可文件时使用。

    如果您使用 Workgroup PDM，您必须在 Windows 防火墙中修改 Workgroup PDM 端口号。通常，这些端口为 20000 (VaultAdmin)、30000（数据）、40000（请求）和 80（查看器）。

  6. 关闭 Windows 安全中心和控制面板。
父主题
在防火墙中使用 SolidNetWork 许可
相关任务
修改用于 Windows 防火墙的 SolidNetWork 许可管理器设置


修改用于 Windows 防火墙的 SolidNetWork 许可管理器设置

如果您使用 Windows 防火墙，则必须修改 SolidNetWork 许可文件才能使用防火墙端口向许可客户端计算机分发许可。

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 在许可服务器下的服务器管理标签上，单击停止。 （在提示确认时单击是，然后单击确定完成许可服务器的停止程序。）
  3. 在许可信息下，单击修改。
  4. 在服务器类型下，选择您的网络的服务器配置（单一或三合一），然后单击下一步。
  5. 在服务器信息下：
    1. 选择 此服务器上使用了防火墙
    2. 端口号和供应商守护程序端口号应包含为 Windows 防火墙指定的端口号（有关详细信息，请参阅为 Windows 防火墙修改许可管理器计算机端口）。
    3. 选择选项文件并单击浏览以查找文件。 单击编辑以更改它的任何参数。

      选项文件允许许可管理员控制 FLEXnet 许可的各种操作参数。

      建议的选项文件位置在 SolidNetwork 许可管理器安装目录 (SolidNetwork_License_Manager_install_dir\Licenses \sw_d.opt) 中。 该文件必须与 sw_d.lic 文件位于相同的目录中。

      有关选项文件的详细信息，请参见 SolidNetwork 许可管理器安装目录下的 FLEXnet Publisher 许可管理指南 (\Docs\flexuser\licensingenduserguide.pdf)。

    4. 单击下一步，然后单击完成。
  6. 在服务器管理选项卡上，在许可服务器下单击开始。
  7. 单击确定关闭 SolidNetWork 许可管理器。
父主题
在防火墙中使用 SolidNetWork 许可
相关任务
修改用于 Windows 防火墙的许可管理器计算机端口


SolidNetWork 许可管理

任务包括启动、升级和卸载许可管理器，以及借用和归还许可。

启动或更新许可管理器前，您必须归还所有借用的许可。

内容

  • 启动 SolidNetWork 许可管理器

    您可以从 Windows 开始菜单启动 SolidNetWork 许可管理器。

  • 升级 SolidNetWork 许可管理器

    对于 SOLIDWORKS 主要发行版本，升级许可管理器包括卸载旧版许可管理器、安装新版本，以及重新激活 SolidNetWork 许可。

  • 删除 SolidNetWork 许可文件

    在升级到新许可之前，删除旧的或过期的 SolidNetWork 许可文件。

  • 借用和归还 SolidNetWork 许可

    您可以借用 SolidNetWork 许可以从远程位置使用软件。由于许可已从可用许可库中移除，因此借用的许可必须要在归还后才能继续可用。

  • 监控许可闲置时间

    SOLIDWORKS 可在 SolidNetWork 许可管理器上登记闲置时间，以便将在一段时间内未使用的许可归还到可用许可库中。

  • 安装临时许可

    当原始 SolidNetWork 许可不可用时，可临时使用临时的“ANY”许可。

  • 从个人许可升级为 SolidNetWork 许可

    您可以在 SOLIDWORKS 安装管理程序中指定 SolidNetWork 许可序列号，将计算机从个人 SOLIDWORKS 许可升级为 SolidNetWork 许可。

  • 在插件产品中使用 SolidNetWork 许可

    您可以使用 SolidNetWork 许可管理器为 SOLIDWORKS 核心插件产品（如 FeatureWorks 和 Workgroup PDM Server）分发许可。

  • 在同一台计算机上安装许可管理器和管理映像

    您可以配置网络上的一台计算机，作为发布 SolidNetWork 许可的许可管理器，同时作为可供用户安装 SOLIDWORKS 软件的管理映像位置。

  • FLEXnet Publisher 许可管理

    SolidNetWork 的许可管理方式建立在 FLEXnet Publisher® 许可管理的基础之上。

父主题
使用 SolidNetWork 许可管理器管理许可
相关概念
安装和配置 SolidNetWork 许可
相关任务
激活 SolidNetWork 许可
转移 SolidNetWork 许可


启动 SolidNetWork 许可管理器

您可以从 Windows 开始菜单启动 SolidNetWork 许可管理器。

  • 在 Windows 中，运行以下命令： 开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器。
父主题
SolidNetWork 许可管理


升级 SolidNetWork 许可管理器

对于 SOLIDWORKS 主要发行版本，升级许可管理器包括卸载旧版许可管理器、安装新版本，以及重新激活 SolidNetWork 许可。

新版本的许可管理器也可为仍然使用先前版本的客户端计算机分发许可。

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 在 许可使用 选项卡上，验证网络上没有客户端计算机在运行 SOLIDWORKS。
  3. 卸载旧版许可管理器。 有关详细信息，请参阅卸载 SolidNetWork 许可管理器。
  4. 在许可管理器计算机上安装新许可管理器并重新激活 SolidNetWork 许可。 有关详细信息，请参阅 安装并激活许可管理器：

如果您正在还将运行 SOLIDWORKS 应用程序的计算机上升级 SolidNetWork 许可管理器，先升级 SolidNetWork 许可管理器和客户端，然后再在该计算机上安装任何新 SOLIDWORKS 应用程序 Service Pack。

如果您正在作为管理映像主机的计算机上升级许可管理器，先升级许可管理器再升级管理映像。 有关详细信息，请参阅在同一台计算机上安装许可管理器和管理映像。

内容

  • 卸载 SolidNetWork 许可管理器

    在升级 SolidNetWork 许可管理器时，您必须先卸载旧许可管理器才能安装新版本。

父主题
SolidNetWork 许可管理


卸载 SolidNetWork 许可管理器

在升级 SolidNetWork 许可管理器时，您必须先卸载旧许可管理器才能安装新版本。

  1. 启动 SolidNetwork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 验证网络上没有客户端计算机在运行 SOLIDWORKS。

    许可使用 选项卡显示运行 SOLIDWORKS 的客户端。

  3. 如果您想将 SolidNetWork 许可转移到其他计算机上，则先将许可转移到该计算机，然后再从本计算机上移除 SolidNetWork 许可管理器。

    有关转移 SolidNetWork 许可的信息，请参阅转移 SolidNetWork 许可。

  4. 在许可服务器下的服务器管理标签上，单击停止。
  5. 单击确定退出许可管理器。
  6. 在 Windows 中，打开控制面板 > 添加或删除程序。
  7. 选择 SOLIDWORKS SolidNetWork 许可管理器，单击 移除，然后确认删除。
  8. 在 Windows 资源管理器中，删除 SOLIDWORKS SolidNetWork 许可管理器文件夹。

    （通常，此文件夹位于 SOLIDWORKS 安装目录的 Program Files 下。）

现在，您已经准备好安装新版本的许可管理器了。 有关详细信息，请参阅安装和激活许可管理器。

如果 SolidNetWork 许可管理器计算机附加有硬件锁，在安装 SolidNetWork 许可管理器的新版本之前移除硬件锁。
父主题
升级 SolidNetWork 许可管理器
相关任务
转移 SolidNetWork 许可
安装并激活许可管理器


删除 SolidNetWork 许可文件

在升级到新许可之前，删除旧的或过期的 SolidNetWork 许可文件。

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 在服务器管理选项卡中，在许可文件下单击修改，然后单击下一步，直到许可屏幕出现。
  3. 在许可屏幕上，选择旧的或过期的 SolidNetWork 许可文件，然后单击移除。
  4. 单击完成，然后单击确定。
父主题
SolidNetWork 许可管理


借用和归还 SolidNetWork 许可

您可以借用 SolidNetWork 许可以从远程位置使用软件。由于许可已从可用许可库中移除，因此借用的许可必须要在归还后才能继续可用。

借用的许可只对当前用户和所借用的机器有效；它们不能转移。

许可可以在指定的借用期限内使用，最多 30 天（或由您的系统管理员定义），过期后许可将从许可资源库中移除。

系统管理员可自定义借用以便：
  • 定义允许借用许可的用户或组
  • 设定不能借用的许可数

有关详情，请参阅 SolidNetWork_License_Manager_install_dir\Docs\flexuser\licensingenduserguide.pdf。

内容

  • 借用 SolidNetWork 许可

    您可以借用 SolidNetWork 许可，以从远程位置使用软件。

  • 归还借用的 SolidNetWork 许可

    由于借用的 SolidNetWork 许可已从许可库中移除，因此借用的许可必须要在归还后才能继续保持可用。

父主题
SolidNetWork 许可管理


借用 SolidNetWork 许可

您可以借用 SolidNetWork 许可，以从远程位置使用软件。

您必须连接到 SolidNetWork 许可管理器才能借用许可，但不必一定使用。

如果您在运行 Windows 8 或以后版本，这些步骤取决于您的系统配置。 参阅 Microsoft Windows 文档了解其他说明和选项。
  1. 在客户端机器上启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 在“许可借用”选项卡上：
    1. 在借用到中选取一日期。
    2. 选取要借用的产品，然后单击借用，接着单击是以确认。
    3. 单击刷新。 失效日期列表示许可什么时候该归还。
  3. 单击确定。
父主题
借用和归还 SolidNetWork 许可
相关任务
归还借用的 SolidNetWork 许可


归还借用的 SolidNetWork 许可

由于借用的 SolidNetWork 许可已从许可库中移除，因此借用的许可必须要在归还后才能继续保持可用。

  1. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  2. 在“许可借用”选项卡上：
    1. 选择要归还的产品，单击归还，然后单击是以确认。
    2. 单击刷新。 失效日期列变为空白，表示许可已归还。
  3. 单击确定。
在到达失效日期后没有必要再归还许可。在失效日期午夜，许可将归还到 SolidNetWork 许可管理器上的许可库中，远程系统上的应用程序不再运行。
父主题
借用和归还 SolidNetWork 许可
相关任务
借用 SolidNetWork 许可


监控许可闲置时间

SOLIDWORKS 可在 SolidNetWork 许可管理器上登记闲置时间，以便将在一段时间内未使用的许可归还到可用许可库中。

  1. 在 SolidNetwork 许可管理器安装目录中，创建一个文本文件：

    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt

  2. 将下行添加到文件：

    TIMEOUTALL seconds

    其中 seconds 是大于或等于 900（15 分钟）的数字，是允许的最小时间。

父主题
SolidNetWork 许可管理


安装临时许可

当原始 SolidNetWork 许可不可用时，可临时使用临时的“ANY”许可。

安装“ANY”许可文件，即表示您同意在从 Dassault Systèmes SOLIDWORKS Corporation 收到 SolidNetWork 许可时实施传统的许可。 仍要求遵循许可限制。

若要安装“ANY”许可：

  1. 如果您目前已是 SolidNetWork 用户，卸载 SolidNetWork 许可管理器并删除安装文件夹。 有关详细信息，请参阅 卸载 SolidNetWork 许可管理器：
  2. 启动 SOLIDWORKS 安装管理程序（如 启动 SOLIDWORKS 安装 中所述）。
    1. 请从下列安装类型中选择一种：

      • 服务器产品
      • 在这台计算机上安装 SolidNetWork 许可管理器（分布式许可）。

    2. 在 SolidNetWork 许可管理器选项页面上，指定 SolidNetWork 许可序列号和 SolidNetWork 许可管理器安装位置。
    3. 在 摘要 页面上，单击 立即安装 以完成 SOLIDWORKS 安装管理程序过程。
  3. 启动 SolidNetWork 许可管理器 (开始 > 程序 > SOLIDWORKS 版本 > SolidNetWork 许可管理器 > SolidNetWork 许可管理器)。
  4. 如果提示您激活，单击否。

    此时将出现 SOLIDWORKS SolidNetwork 许可管理器的“服务器管理”选项卡。

  5. 在高级选项下，单击选项。

    高级选项对话框出现。

  6. 在 SolidNetWork 服务器许可模式下，单击使用许可文件，然后单击确定。

    高级选项对话框关闭。

  7. 在许可信息下，单击修改。

    SolidNetWork 许可文件向导出现。

  8. 在服务器类型下，选择单一，然后单击下一步。
  9. 如果您看到此信息：

    无法读取硬件锁 ID 号码。单击取消。

    ID“ANY”自动出现。
    如果您的计算机使用防火墙，您可能需要在此屏幕上指定其他信息。 有关详细信息，请参阅在防火墙中使用 SolidNetWork 许可。

  10. 继续进行安装。
父主题
SolidNetWork 许可管理


从个人许可升级为 SolidNetWork 许可

您可以在 SOLIDWORKS 安装管理程序中指定 SolidNetWork 许可序列号，将计算机从个人 SOLIDWORKS 许可升级为 SolidNetWork 许可。

如果计算机上未安装 SOLIDWORKS，您可以在使用 SOLIDWORKS 安装管理程序进行安装时输入 SolidNetWork 序列号，以指定 SolidNetWork 许可。

如果计算机已经安装 SOLIDWORKS，并且您已将个人许可转换为 SolidNetWork 许可，您可以为该计算机修改安装，并在运行 SOLIDWORKS 安装管理程序时指定 SolidNetWork 许可序列号代替个人许可序列号。 有关详细信息，请参阅修改安装。
如果您从管理映像安装了 SOLIDWORKS，则修改选项不可用。 您必须使用管理映像编辑器修改管理映像、卸装客户端并重新运行安装程序。
父主题
SolidNetWork 许可管理
相关任务
修改安装


在插件产品中使用 SolidNetWork 许可

您可以使用 SolidNetWork 许可管理器为 SOLIDWORKS 核心插件产品（如 FeatureWorks 和 Workgroup PDM Server）分发许可。

  • SOLIDWORKS 软件许可和 SOLIDWORKS 插件许可的数量不一定要相等。
  • 若要为某一插件产品检出许可，您必须首先检出 SOLIDWORKS 的许可。
  • 要借用插件产品许可，您必须同时借用 SOLIDWORKS 软件许可和包括插件的 SOLIDWORKS 产品许可。 默认情况下会借用 SOLIDWORKS Standard 许可，但是要启用插件，必须借用 SOLIDWORKS Professional 或 SOLIDWORKS Premium 产品许可。
  • 要释放插件产品许可：
    • 在 SOLIDWORKS 中，单击工具 > 插件，然后清除插件。
    • 退出 SOLIDWORKS。
父主题
SolidNetWork 许可管理


在同一台计算机上安装许可管理器和管理映像

您可以配置网络上的一台计算机，作为发布 SolidNetWork 许可的许可管理器，同时作为可供用户安装 SOLIDWORKS 软件的管理映像位置。

客户端计算机可以从许可管理器获得许可，然后从同一台计算机安装 SOLIDWORKS。

此配置要求许可管理器和管理映像安装在同一台计算机上。 首先安装许可管理器，然后再创建和调用管理映像。
详情请参阅：
  • 安装并激活许可管理器
  • 调用到多个客户端
父主题
SolidNetWork 许可管理


FLEXnet Publisher 许可管理

SolidNetWork 的许可管理方式建立在 FLEXnet Publisher® 许可管理的基础之上。

有关 FLEXnet Publisher 许可管理的详细信息，请参见 SolidNetwork 许可管理器安装目录下的 FLEXnet Publisher 许可管理指南许可管理指南 (\Docs\flexuser\licensingenduserguide.pdf)。

如需 FLEXnet Publisher 许可管理的最新信息，请联系 Acresso® 软件。

父主题
SolidNetWork 许可管理


疑难解答

遇到安装问题时请参阅这些主题以排除故障。

内容

  • 网络许可证使用

  • SOLIDWORKS 安装管理程序日志文件

    SOLIDWORKS 安装管理程序日志文件可帮助您在遇到安装问题时排除故障。

  • SOLIDWORKS 安装管理程序下载文件夹

    SOLIDWORKS 安装管理程序可将所需的安装文件下载到您指定的文件夹中。 该主题提供对下载文件夹常见问题的回答。

  • SolidNetWork 许可故障排除

    如果 SolidNetWork 许可管理器安装失败，请查看这些可能的解释。

  • 升级故障排除

    如果在升级到新的 SOLIDWORKS 发行版时遇到问题，请查看这些可能的解释。

  • 安装或升级时验证您的图形卡

    当您在计算机上完成 SOLIDWORKS 安装或升级后，您应运行 SOLIDWORKS Rx 来确保您的计算机运行的是受支持的图形卡和图形卡驱动程序。


网络许可证使用

此对话框在服务器缺少某种产品许可证时出现。

单击 产品 框中的箭头来显示所有产品选择。 选择包括 SOLIDWORKS 及其所有可购买的插件。

许可证总数为您所购买的许可总数量。

闲置许可证为当前没使用的许可总数量。

许可证用户方框给您提供目前使用许可每个人的信息。

父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除
相关任务
安装或升级时验证您的图形卡


SOLIDWORKS 安装管理程序日志文件

SOLIDWORKS 安装管理程序日志文件可帮助您在遇到安装问题时排除故障。

这些日志文件与其他 SOLIDWORKS 应用程序的日志文件放在相同的位置。
  • 对于 Windows 7 或更高版本：

    C:\Users\用户名\AppData\Roaming\SOLIDWORKS\Installation Logs\安装的版本

若要查看日志文件目录，必须将 Windows 文件夹选项配置为显示隐藏的文件和文件夹。

如果该应用程序不在 C: 盘上，请相应调整目录路径。

此目录包含 SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt 文件，该文件是 SOLIDWORKS 安装管理程序进度的常规日志。

Other Logs 子目录包含更详细的安装日志信息。

父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除
相关任务
安装或升级时验证您的图形卡
相关参考
网络许可证使用


SOLIDWORKS 安装管理程序下载文件夹

SOLIDWORKS 安装管理程序可将所需的安装文件下载到您指定的文件夹中。 该主题提供对下载文件夹常见问题的回答。

如果您运行 Windows 8 及更高版本，请参阅 在 Microsoft Windows 8 中使用 SOLIDWORKS 提示 了解任务，如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 请参阅 Microsoft Windows 文档了解其他说明和选项，尤其是对于 Windows 8 之后的系统。
问题 答案
我如何安装此文件夹中的文件？

运行 setup.exe。如果您选择安装以前没有下载的项目，您可能仍需要下载某些文件。

不要使用 msiexec 进行安装（参阅下文）。
我可以使用 msiexec 或一些其它应用程序手工从此文件夹安装 MSI 文件吗？

否。 安装管理程序不下载在运行 msiexec 时所需的某些文件。
我可为每个安装的版本选取同一下载文件夹吗？

下载文件夹是版本特定的。 从 SOLIDWORKS 2010 开始，SOLIDWORKS 安装管理程序会自动在指定的文件夹内创建版本特定的子文件夹。

我从 Dassault Systèmes SOLIDWORKS Corporation 网站手动下载了一些产品。 安装管理程序可安装这些内容吗？
从 SW2009 开始，SOLIDWORKS 安装管理程序可以使用手动下载的文件。 但最好是运行 SOLIDWORKS 安装管理程序，然后选择文件下载选项。 SOLIDWORKS 安装管理程序会根据您的安装内容来显示所需的文件，并提供下载每个文件的链接。 当内置的下载页面不能正常运行时（很有可能是代理服务器施加了下载限制），可以使用此选项。
如果在下载或安装过程中 Microsoft Internet Explorer 问您是保存还是运行文件，始终选择保存。
我下载的文件可被其他用户共享吗？

是。 若要共享，下载到网络共享中。 然后，每个客户端即可从共享处运行 SOLIDWORKS 安装管理程序进行安装。

无需另外下载，除非用户选择下载在初始下载时未选择的某些项，或者使用此下载内容进行安装的计算机上的必备组件集与初始下载的计算机上的必备组件集不同。

如果您在代表他人进行下载但不进行安装，请在安装时选择只下载选项。 无论您的系统上安装什么项目，该选项将让您选取产品。 然而，此选项不能用来下载修补程序，也不能用来生成管理映像。
我如何知道有新版本 SOLIDWORKS 产品可用？
在以下情况下，当有新版本可用时将会通知您：
  • 如果您运行检查更新 ( 开始 > 所有程序 > SOLIDWORKS Installation Manager > 检查更新)
  • 如果您已启用 SOLIDWORKS 后台下载程序。
  • 如果您选择已在 Windows 添加/删除程序 中安装的 SOLIDWORKS 版本，然后单击 更改
  • 如果您从下载文件夹运行安装管理程序 (sldIM.exe) 的旧版本
在这些情况下，您可选择下载新版本。 SOLIDWORKS 安装管理程序将下载并运行自身的新版本，而不是任何安装文件。 在 SOLIDWORKS 安装管理程序的新版本运行后，您可选取一组安装操作。 然后，SOLIDWORKS 安装管理程序将决定需要哪些安装文件（以前没有下载过）并主动下载这些文件。
SOLIDWORKS 安装管理程序为什么不让我选择安装产品的另一个 service pack？

每个 SOLIDWORKS 安装管理程序仅用于安装 SOLIDWORKS 产品的特定版本。 如果您想安装另一 service pack，您需要运行该版本的 SOLIDWORKS 安装管理程序。 要找到最新的可用版本，请参见之前的条目。
SOLIDWORKS 安装管理程序为什么被禁止下载文件？

如果代理服务器的限制阻止应用程序下载文件，则 SOLIDWORKS 安装管理程序无法自动下载文件。

您可以手动下载文件，然后使用 SOLIDWORKS 安装管理程序安装这些文件。 在 SOLIDWORKS 安装管理程序中选择选项，以下载单独文件（例如，进行手动下载 页面上的 进行手动下载）。 根据您的产品选择和系统要求，将在单独的窗口中显示网页，其中包含所有手动下载文件的链接。 这些链接与 SOLIDWORKS 客户门户提供的链接相同，但您无需搜索文件。
并不是我的所有 SOLIDWORKS 产品都会更新到最新的 service pack。 为什么“检查更新”告诉我所使用的已是最新版本？

“检查更新”只告诉您是否您已安装有（或在运行）SOLIDWORKS 安装管理程序的最新版本。

如果您想将所有产品都更新到安装的最新版本，请在 添加/删除程序 中选取 SOLIDWORKS 的最新安装版本，然后单击 更改。

我可将 DVD 复制到下载文件夹中吗？

是，但安装可能失败，除非您为该平台复制每张 DVD 提供的全部内容。 SOLIDWORKS 安装管理程序通过查找文件 swdata*.id 来确定版本。 如果这些文件不存在，它将无法识别您所复制的任何安装文件，并要求将之下载。
父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序日志文件
SolidNetWork 许可故障排除
升级故障排除
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示
相关任务
安装或升级时验证您的图形卡
相关参考
网络许可证使用


SolidNetWork 许可故障排除

如果 SolidNetWork 许可管理器安装失败，请查看这些可能的解释。

父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
升级故障排除
相关任务
安装或升级时验证您的图形卡
相关参考
网络许可证使用

访问 SolidNetWork 许可日志文件

出现许可错误时，答案常常出现在 SNL_管理器安装目录\lmgrd.log 文件中。

无法获得 SOLIDWORKS 许可。 不能连接到许可服务器。

通常，此问题是由端口设定导致的。

  • SolidNetWork 许可管理器和许可客户端之间的端口设定不匹配。
  • 可能未指定 SolidNetWork 许可管理器多个版本的其它端口设定。
  • 根据提供的服务器名称检查客户端机器是否可以准确还原并步路到该服务器。 此外，根据客户端机器名称检查服务器是否可准确还原并步路到客户端。
有关 SolidNetWork 许可管理器和客户端端口设置的详细信息，请参阅使用具有防火墙的 SolidNetWork 许可。
相关概念
在防火墙中使用 SolidNetWork 许可


升级故障排除

如果在升级到新的 SOLIDWORKS 发行版时遇到问题，请查看这些可能的解释。

父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
相关任务
安装或升级时验证您的图形卡
相关参考
网络许可证使用

从已移动的源处升级

安装 SOLIDWORKS 时，SOLIDWORKS 安装管理程序会记住安装源的位置（光盘媒介、网络上的光盘映像等）。 更新时，它需要这些位置的安装源仍然可用。

如果安装源已移动或删除，或者如果源媒介已更改，则 SOLIDWORKS 安装管理程序会产生一错误信息。 但是，您可以浏览到另一位置继续进行升级，只要该位置包含完全相同的文件和文件夹结构。


安装或升级时验证您的图形卡

当您在计算机上完成 SOLIDWORKS 安装或升级后，您应运行 SOLIDWORKS Rx 来确保您的计算机运行的是受支持的图形卡和图形卡驱动程序。

要验证图形卡和驱动程序：

  1. 当安装管理程序完成安装并显示完成页面时，在请检查您的系统下，单击运行系统诊断。

    SOLIDWORKS Rx 将启动并运行诊断。

  2. SOLIDWORKS Rx 将确认图形卡和图形卡驱动程序是否受支持。 如果图形卡受支持但驱动程序不受支持，将出现一则状态消息提供受支持的驱动程序的链接。

您每启动 SOLIDWORKS 十次会出现一次请检查您的系统消息，并建议您再次运行系统诊断。 要抑制这些通知，右键单击 Windows 通知区域中的 SOLIDWORKS Resource Monitor 并单击禁用通知。

您可通过右键单击 Windows 通知区域中的 SOLIDWORKS Resource Monitor 随时验证图形卡和驱动程序。 该快捷菜单还让您能够：
  • 为 SOLIDWORKS Resource Monitor 显示帮助
  • 运行系统诊断程序
  • 更新图形驱动程序
父主题
疑难解答
相关概念
SOLIDWORKS 安装管理程序日志文件
SOLIDWORKS 安装管理程序下载文件夹
SolidNetWork 许可故障排除
升级故障排除
相关参考
网络许可证使用


SOLIDWORKS 安装管理程序应用程序帮助

SOLIDWORKS 安装管理程序是用于安装并升级您的 SOLIDWORKS 产品的单独应用程序。

您可以下列方式运行 SOLIDWORKS 安装管理程序：
  • 从 SOLIDWORKS DVD 或共享源或下载文件夹（安装新版本时）
  • 从控制面板添加或删除程序页面（当修改或删除现有版本时）
  • 通过计划或手动的更新检查（当检测、下载并安装新发行版时）

每个 SOLIDWORKS 版本都有特定于该版本的 SOLIDWORKS 安装管理程序。

对于 SOLIDWORKS 2008 之前的版本，请使用 SOLIDWORKS 2007 安装管理程序，或从 SOLIDWORKS 支持网站上手动下载产品版本。
如果您运行 Windows 8，请参见 在 Microsoft Windows 8 中使用 SOLIDWORKS 提示 了解任务，如访问 开始 或 控制面板。 这些步骤会根据 Windows 8 在您的系统上如何配置而变化。 请参阅 Microsoft Windows 文档了解其他说明和选项，尤其是对于 Windows 8 之后的系统。

内容

  • SOLIDWORKS 后台下载程序

    SOLIDWORKS 后台下载程序使用后台程序进行文件自动下载（例如，发现新的 Service Pack 发行版时），使您可在下载时继续进行其他工作。 当下载完成时，系统会询问您是否想马上安装、推迟下载或者移除下载。

  • 检查更新结果

    “检查更新”会查找更高版本的 SOLIDWORKS。

  • 管理映像位置

    指定管理映像的安装位置。

  • 下载选项

    指定完成下载操作的详细信息，例如下载的文件的位置、文件下载方式以及是否安装下载的文件。

  • SOLIDWORKS 安装管理程序文件的下载选项

    您选择了下载 SOLIDWORKS 安装管理程序的新版本。 使用此荧屏指定在何处以及如何下载。

  • 下载产品安装文件

    指定在何处及如何为所指定的产品下载遗失的文件。

  • 下载进度

    SOLIDWORKS 安装管理程序在此过程中同时下载、验证并提取所有文件。

  • 下载结果

    表示下载是成功完成、操作过程失败还是被取消。

  • 安装错误/安装已取消

    安装遇到问题或被取消。

  • 安装完成

    SOLIDWORKS 安装管理程序已完成安装过程。

  • 安装位置

    指定 SOLIDWORKS 安装位置。

  • 升级选项

    当前计算机上安装有一个或多个旧的 SOLIDWORKS 主要版本。 选择是将现有的最新版本升级为该新版本还是为该新版本创建一个新安装。

  • 安装进度

    该荧屏显示安装的进度。

  • 安装类型

    指定您要运行的安装操作，例如创建新安装、修改或修复现有安装、创建管理映像、安装管理服务器产品或下载文件而不安装。

  • 安装并管理多台计算机

    SOLIDWORKS 安装管理程序提供以下工具用于安装并管理多台 SOLIDWORKS 计算机。

  • 手动下载

    您已选择手动下载文件（或者可能在上次运行 SOLIDWORKS 安装管理程序时选择了手动下载）。

  • 有新版本可用

    安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择安装包含在原有安装 DVD 或下载中的版本，或者您可选择下载并安装更新的版本。

  • 没有新版本可用

    没有可下载的更新版本。开始安装指定的版本。

  • 检测到进程

    SOLIDWORKS 安装管理程序在此计算机上检测到可能影响安装成功完成的进程。

  • 产品选择

    指定要安装、修改、下载或删除的产品组件。

  • 要下载的产品

    选取要下载到指定位置的 SOLIDWORKS 产品。

  • 要修复的产品

    当您指定修复此安装时，该屏幕显示出可由此版本 SOLIDWORKS 安装管理程序修复的 SOLIDWORKS 产品（带有版本号）。

  • 序列号

    印在包装盒上的序列号将您的计算机与您已购买的 SOLIDWORKS 产品关联起来。

  • 服务器安装

    会列出您正在尝试安装的服务器产品，并显示安装结果。

  • SolidNetWork 许可管理器

    指定 SolidNetWork 许可管理器服务器产品的安装选项。

  • 摘要

    SOLIDWORKS 安装管理程序已获得了完成安装操作所需的所有信息。

  • 系统检查警告

    系统检查报告了可能影响您继续安装的问题。 大多数情况下，您应该能够继续运行 SOLIDWORKS 安装管理程序。

  • 异型孔向导/Toolbox 选项

    如果安装有 SOLIDWORKS Toolbox，SOLIDWORKS 将包含一个标准的孔类型与器件库。

  • 卸载产品

    当您从 控制面板 中选取删除或卸装程序时，该屏幕显示可由此版本 SOLIDWORKS 安装管理程序卸载的 SOLIDWORKS 产品（带有版本号）。 您可选择进行标准、自定义或完整卸装。

  • Workgroup PDM 服务器选项

    指定 SOLIDWORKS Workgroup PDM 服务器产品的安装选项。

相关概念
在 Microsoft Windows 8 上使用 SOLIDWORKS 的提示


SOLIDWORKS 后台下载程序

SOLIDWORKS 后台下载程序使用后台程序进行文件自动下载（例如，发现新的 Service Pack 发行版时），使您可在下载时继续进行其他工作。 当下载完成时，系统会询问您是否想马上安装、推迟下载或者移除下载。

安装 SOLIDWORKS 时，会默认启用后台下载程序。

运行安装管理程序时，无论是在进行安装还是下载操作，后台下载程序都将暂停运行。 例如，暂停所有运行中的下载、不允许开始新的下载并且不允许更改下载文件夹规格等。

您可以通过在安装过程中更改摘要页上的下载选项，禁用后台下载程序。 （清除您想使用后台下载程序吗？选项。）

启用后，以下图标将显示在工具栏的 Windows 系统托盘中：

单击此图标，启用下列操作:
  • 帮助后台下载程序
  • 暂停下载
  • 恢复下载
  • 取消下载
  • 安装选项
  • 更改下载位置
  • 检查更新
  • 自动检查更新
  • 自动下载更新
  • 禁用后台下载程序

帮助后台下载程序

打开 SOLIDWORKS 安装指南中的后台下载程序帮助主题。

暂停/恢复下载

如果后台正在运行下载，单击暂停下载可暂停下载，稍后也可通过单击恢复下载来恢复下载。

取消下载

如果正在运行下载，此操作将会停止下载，并删除后台下载程序已经下载的所有文件。
下载一旦取消，将无法恢复。

安装选项

下载完成后，您可以从以下选项选择：
  • 现在安装：安装下载的文件。
  • 以后再提醒我：暂不安装下载的文件，以后再发送消息提醒我。
  • 删除该下载：不安装并删除下载的文件。（如果您确定不再需要安装下载的文件，可以选择此项。）

更改下载位置

更改后台下载程序所下载文件的保存位置。

下载正在运行或暂停时，此选项不可用。

检查更新

运行 SOLIDWORKS 安装管理器的检查更新功能。

自动检查更新

定期运行检查更新，它会在有更新可供下载时通知您。

自动下载更新

定时运行检查更新，它会在有更新可供下载时自动下载更新。

禁用和再次启用 SOLIDWORKS 后台下载程序

要禁用后台下载程序，请单击程序图标，然后选择禁用后台下载程序。

要再次启用后台下载程序，请单击开始 > 所有程序 > SOLIDWORKS 安装管理程序 > SOLIDWORKS 后台下载程序。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


检查更新结果

“检查更新”会查找更高版本的 SOLIDWORKS。

可手动运行“检查更新”：
  • 在 Windows 中，单击开始 > 程序 > SOLIDWORKS 安装管理程序 > 检查更新
  • 在 SOLIDWORKS 中单击帮助 > 检查更新。
在通过管理映像安装的客户端上，“检查更新”不可用。

有新版本可用

SOLIDWORKS 安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择该版本的 SOLIDWORKS 安装管理程序来更新到新版本。

此新版本可以根据您在安装中指定的产品来下载安装文件。 您可与其他使用 SOLIDWORKS 安装管理程序进行安装的用户共享下载的文件。

这些下载只可为 SOLIDWORKS 安装管理程序所用。
有这些选项可供使用：
  • 如果有多个版本可供使用，您可从列表中选取一个版本。
  • 有关该版本的细节，单击检查以查看此升级包括什么内容。
单击下一步会获得并运行所选版本的 SOLIDWORKS 安装管理程序。

无新下载可用/不能检查新版本

SOLIDWORKS 安装管理程序未发现更高版本的 SOLIDWORKS 产品，原因要么是您安装的就是最新版本，要么是它无法连接到 SOLIDWORKS 网站以进行检查。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


管理映像位置

指定管理映像的安装位置。

当创建管理映像时，这些选项可适用：
新映像位置 | 这是 SOLIDWORKS 安装管理程序将创建新映像的目标目录位置。 | 此位置不能包含现有的管理映像。 管理映像必须位于共享文件夹中以供客户端调用。
创建映像所需的估计空间 | 这是管理映像所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持映像要求。
从此处创建映像 | 这是您安装 SOLIDWORKS 产品的源目录位置。 仅当指定了仅安装选项时，此选项才出现。 有关详细信息，请参阅 下载选项：
父主题
SOLIDWORKS 安装管理程序应用程序帮助


下载选项

指定完成下载操作的详细信息，例如下载的文件的位置、文件下载方式以及是否安装下载的文件。

SOLIDWORKS 安装管理程序支持电子软件发布 (ESD)。 如果您不是从 SOLIDWORKS DVD 进行安装，系统将提示您为正在安装的 SOLIDWORKS 产品指定来源。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。

您想做什么?

选择以下选项之一：

下载并安装/下载并创建映像

下载完成之后，SOLIDWORKS 安装管理程序会使用下载的文件运行安装。

只下载。 您可下载一次，然后在多台计算机之间共享下载的文件。

SOLIDWORKS 安装管理程序不会在下载完成后运行安装。

通常，如果您要下载文件以配置安装文件集并在多台计算机之间共享，则请指定此选项。

若您指定此选项，则程序会要求您在要下载的两个文件集中作出选择：
  • 此计算机的文件： 下载将只包含此计算机上当前的安装文件集中缺少的那些文件。
    这样下载的内容应该较少，因为它只包含：
    • 适用于在“产品选择”页面上选择的产品的文件
    • 您的计算机上尚未安装的必要文件

    然而，如果您尝试使用此下载文件集在其它计算机上进行安装，则可能会缺少某些文件（因为其它计算机上的安装文件集可能有所差异）。 您可使用这些下载文件在其它计算机上进行安装，但在安装过程中，可能必须下载其它文件才能备齐该计算机上的安装文件集。

  • 与任何计算机共享的文件： 下载将包含可用于在任何计算机上安装此版本的完整安装文件集。

    这样下载的内容应该较多，因为它将包含可用于在任何计算机上安装此版本的任何产品的完整安装文件集。

    如果您指定了要下载有限产品集，此选项会忽略该指定并下载该产品发行版中的所有产品。

    下载将包含创建管理映像所需的所有文件，而不仅仅是进行单机安装所需的那些文件。

仅安装/仅创建映像。 我已拥有所需的所有安装文件。

SOLIDWORKS 安装管理程序不会下载任何文件，而是使用所选文件夹中的文件。

单击浏览以导航到其它位置。 例如，您可浏览到包含所需文件的安装 DVD 或下载文件夹。

如果您收到错误信息说文件夹不完整，而您认为所有安装文件都应出现在该位置，可能的解释包括：
  • 您选取了先前未下载的组件进行安装或者是默认选取。
  • 文件下载到另一台具有不同系统要求的计算机上。
  • 您先前进行了客户端安装，而现在正在生成管理映像，这将要求更大的文件集。

您既可浏览到包含所有文件的文件夹（例如 DVD），也可选择下载选项之一。

您想在什么地方下载所需文件?

这是下载文件夹位置。

在某些情况下，此选项虽然可见，但被禁用。 例如，如果指定了仅安装，则 SOLIDWORKS 安装管理程序会从为该选项指定的目录中安装下载的任何文件，而非使用单独的下载文件夹。

无论您是否在下载这些文件或从您自己的位置访问这些文件，所有文件都必须下载到同一个下载文件夹。

估计的下载大小

所估计的下载磁盘空间要求基于选定的完整组件清单，无论此为新下载或从先前进程恢复的下载。

例如，如果您在恢复先前下载，SOLIDWORKS 安装管理程序将只处理那些还未下载的文件。 下载时间可能比估计的要少。

如果某文件已经在之前下载时完成了下载，则其大小不会包含在估计值中。因此，估计的下载大小可能大于实际大小。

您想如何下载?

有两个选项：
进行手动下载 | 某些情况下，代理服务器可能禁止 SOLIDWORKS 安装管理程序自动下载。 | 通过选择此选项，您可从网页手动下载文件，然后在 SOLIDWORKS 安装管理程序中继续进行安装操作。 此网页由 SOLIDWORKS 安装管理程序自定义，仅用于下载完成安装所需的文件。
使用更多网络带宽加速下载 | 下载程序使用一种规则系统通过增加下载过程中所使用的网络带宽来增加下载速度。 在某些情况下，这会扰乱网络性能。如果您出现下载困难，则该选项可能不受代理服务器支持。尝试消除此选项并再次进行下载。有关细节，请向您的网络管理员核实。 此选项仅适用于自动下载。它不影响手动下载。

使用 SOLIDWORKS 后台下载程序

您可使用 SOLIDWORKS 后台下载程序完成该下载操作或者在以后发布 SOLIDWORKS Service Pack 新版本时进行下载。

SOLIDWORKS 后台下载程序可在后台自动检测并下载新的 Service Pack 更新，并在下载完成及文件可用于安装时通知您。 有关详细信息，请参阅 SOLIDWORKS 后台下载程序：

父主题
SOLIDWORKS 安装管理程序应用程序帮助


SOLIDWORKS 安装管理程序文件的下载选项

您选择了下载 SOLIDWORKS 安装管理程序的新版本。 使用此荧屏指定在何处以及如何下载。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。

仅当默认下载文件夹有问题（例如写入访问权限或网络访问权限不可用）时，本屏幕才会出现。通常，您只需指定一个替代下载目录即可继续。

下载目录

浏览到 SOLIDWORKS 安装管理程序文件的目标位置。

下载大小和所需的空间量会显示出来。所需空间量包括解压某些下载内容所需的额外空间，大于实际下载大小。

使用下载加速

如果您选取该选项，下载将使用一种算法来增加下载的速度。

下载加速可增加带宽使用并扰乱网络性能。在启用下载加速之前与您的网络管理员联系。

如果代理服务器不支持下载加速，那么该选项将自动禁用。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


下载产品安装文件

指定在何处及如何为所指定的产品下载遗失的文件。

SOLIDWORKS 安装管理程序在下载过程中同时下载、验证并提取所有文件。

取消此荧屏也将取消其余安装序列。

有关取消的后果及完成中断的安装的说明，请参阅安装错误。

下载目录

浏览到下载文件的目的地。

下载大小和所需的空间会显示出来。所需空间量包括解压某些下载内容所需的额外空间，大于实际下载大小。

若有关于下载文件夹的疑问，请参阅 SOLIDWORKS 安装管理程序下载文件夹。

下载选项

SOLIDWORKS 安装管理程序下载文件夹

使用更多网络带宽加速下载

下载程序使用一种规则系统通过增加下载过程中所使用的网络带宽来增加下载速度。

在某些情况下，这会扰乱网络性能。如果您出现下载困难，则该选项可能不受代理服务器支持。尝试消除此选项并再次进行下载。有关细节，请向您的网络管理员核实。
下载加速可增加带宽使用并扰乱网络性能。在启用下载加速之前与您的网络管理员联系。

如果代理服务器不支持下载加速，那么该选项可能被自动禁用。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关概念
SOLIDWORKS 安装管理程序下载文件夹
相关参考
安装错误/安装已取消


下载进度

SOLIDWORKS 安装管理程序在此过程中同时下载、验证并提取所有文件。

若要在开始后取消下载，单击取消。

如果您取消下载或下载失败，已取消下载或下载问题屏幕会指出哪些下载未完成，并允许您恢复下载或者关闭该应用程序。

若有关于下载文件夹的疑问，请参阅SOLIDWORKS 安装管理程序下载文件夹。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


下载结果

表示下载是成功完成、操作过程失败还是被取消。

下载问题/下载被取消

如果您看到 下载问题，则说明 SOLIDWORKS 安装管理程序遇到了问题，使下载无法完成。

如果您看到下载被取消，则说明您在下载完成前将其取消。

若要继续：

重试/恢复自动下载 | 若要从您取消的位置恢复自动下载，请选择此选项并单击重试下载或恢复下载。
在 Web 浏览器中单独下载文件 | 某些情况下，代理服务器可能禁止 SOLIDWORKS 安装管理程序自动下载。 | 通过选择此选项，您可从网页手动下载文件，然后在 SOLIDWORKS 安装管理程序中继续进行安装操作。 此网页由 SOLIDWORKS 安装管理程序自定义，仅用于下载完成安装所需的文件。

下载已完成

如果您指定了仅下载选项，则当下载完成时，会出现“下载完成”屏幕。

单击完成以退出 SOLIDWORKS 安装管理程序。

切勿尝试手动安装这些产品中的任一项。 始终使用 SOLIDWORKS 安装管理程序来安装下载的文件。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


安装错误/安装已取消

安装遇到问题或被取消。

如果发生错误或取消安装：
  • 在发生错误或取消之前安装的产品在计算机上保留。
  • 如有可能，在取消时刻安装的产品将被退回，这样不会存在部分安装。
  • 剩余的产品将不会安装或卸载。将在还未尝试下提供一个列表。

    若要恢复安装或卸载这些产品，请单击提供的链接。

SOLIDWORKS 安装管理程序将首先安装计算机上还未安装的必备组件，如 .NET framework。

内容

  • 恢复失败或取消的安装

    如果在安装过程中出错或取消，可通过重新运行安装来从该位置恢复安装。

  • 修复安装

    如果您遇到所安装的 SOLIDWORKS 产品的问题，您可使用 SOLIDWORKS 安装管理程序来修复安装。

  • 请与 SOLIDWORKS 转售商联系

    如果修改或修复安装失败，请与您的本地 SOLIDWORKS 转售商联系并提供从该屏幕所收集的信息。 可能还会要求您提供 SOLIDWORKS 安装管理程序日志文件的 zip 文件。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


恢复失败或取消的安装

如果在安装过程中出错或取消，可通过重新运行安装来从该位置恢复安装。

  1. 记录已失败的安装的错误信息和产品码，如安装错误或安装已取消屏幕上所示。

    如果提示您指定源文件但您未修改现有的 SOLIDWORKS 安装，则该安装或计算机可能已损坏。 请与您的 SOLIDWORKS 转售商联系。

  2. 重新启动计算机。
  3. 为确保当前未运行 SOLIDWORKS 产品，在 Windows 中，按 Ctr+Alt+Del 打开任务管理器。
  4. 在进程选项卡上，如果下列任何进程出现在映像名称下，请选择该进程并单击结束进程。

    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • solidworksexplorer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe

  5. 如果应用程序已安装，而您试图修改或删除该应用程序，请尝试修复安装。 有关详细信息，请参阅修复安装。
  6. 在 Windows 7 或更高版本上，单击 开始 > 控制面板 >程序和功能。 有关 Windows 的早期版本，请单击 开始 > 控制面板 > 添加或删除程序。
  7. 选取已失败的 SOLIDWORKS 版本。

    如果没有您在尝试进行安装的 SOLIDWORKS 版本条目，请重复安装过程。

  8. 执行以下操作之一：
    • 若要重试，单击更改然后选取安装失败或在安装过程中跳过的所有产品。

    • 要跳过已失败的安装，单击更改然后选取所有在安装过程中跳过的产品。 清除安装失败的产品。

    • 若要放弃安装，单击删除然后选取任何已安装的产品。

    这不会恢复您所升级的任何产品的先前版本。

父主题
安装错误/安装已取消
相关任务
修复安装
请与 SOLIDWORKS 转售商联系


请与 SOLIDWORKS 转售商联系

如果修改或修复安装失败，请与您的本地 SOLIDWORKS 转售商联系并提供从该屏幕所收集的信息。 可能还会要求您提供 SOLIDWORKS 安装管理程序日志文件的 zip 文件。

  1. 找出日志文件：
    • 对于 Windows 7 或更高版本：

      C:\Users\用户名\AppData\Roaming\SOLIDWORKS\Installation Logs\安装的版本\

    如果您找不到文件夹，可能文件夹已隐藏。在资源管理器中，依次单击工具 > 文件夹选项。在查看选项卡上的高级设置下，为隐藏文件和文件夹选择显示隐藏的文件和文件夹。

  2. 压缩整个文件夹的内容（包括子文件夹）。
父主题
安装错误/安装已取消
相关任务
恢复失败或取消的安装
修复安装


安装完成

SOLIDWORKS 安装管理程序已完成安装过程。

可能显示下列选项中的一项或多项。

新增功能

对于单机安装，在您完成安装过程时，将出现一个描述 SOLIDWORKS 及其插件产品中新增功能的文档。

对于管理映像安装，该文档会在客户端计算机完成其安装时出现在这些计算机上。

普查

通过回答一项简短普查为我们提供您对安装过程的意见。

参加 SOLIDWORKS 客户经历改进计划

性能信息将发送到 SOLIDWORKS Corporation 以帮助改进产品。 此过程是透明并且保密的。 选择以下项之一：
  • 是，我想参加
  • 不，谢谢
  • 以后再提醒我
有关更多信息，请参阅 客户经历改进计划网站。

管理映像创建已完成

当您完成生成管理映像时，您可单击自定义映像运行管理映像选项编辑器来自定义映像。

单击为我示范如何在客户端上安装此映像显示使用选项编辑器的指南。

有关使用选项编辑器配置管理映像的详细信息，请参阅管理映像选项编辑器。

单击自定义映像开启管理映像选项编辑器，以自定义您的管理映像选项设置。
以后，您也可以通过在管理映像安装目录中双击 sldAdminOptionEditor.exe 来开启选项编辑器。

内容

  • 检查 SOLIDWORKS 的更新

    可使用 SOLIDWORKS 安装管理程序来手动检查更新或配置自动定期检查更新。

  • SOLIDWORKS 客户经历改进计划

    安装 SOLIDWORKS 时，您可以指定将性能信息发送到 SOLIDWORKS Corporation 以帮助改进产品。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关参考
管理映像选项编辑器


检查 SOLIDWORKS 的更新

可使用 SOLIDWORKS 安装管理程序来手动检查更新或配置自动定期检查更新。

  1. 通过以下操作之一开启 SOLIDWORKS 安装管理程序：

    • 在 SOLIDWORKS 应用程序中依次单击帮助 > 检查更新。

    • 在 Windows 中，单击开始 > 程序 > SOLIDWORKS 安装管理程序 > 检查更新。

    SOLIDWORKS 安装管理程序会告诉您当前是否有任何更新可用。

  2. 如果有更新可用，选择是否下载更新并安装。
  3. 若要启用自动定期检查更新，当 SOLIDWORKS 安装管理程序完成处理后，选择每 __ 天一次检查更新并指定检查频率。
父主题
安装完成
相关概念
SOLIDWORKS 客户经历改进计划


SOLIDWORKS 客户经历改进计划

安装 SOLIDWORKS 时，您可以指定将性能信息发送到 SOLIDWORKS Corporation 以帮助改进产品。

SOLIDWORKS 使用该信息来决定有关产品使用和质量的趋向。 我们的目标是提供最佳质量的产品，性能日志是该过程中的有用工具。

此过程是透明的。日志文件中包含的所有信息都视为机密。该信息不用于任何其它目的，没人会接洽您。

有关详细信息，请参阅客户经历改进计划网站。

父主题
安装完成
相关任务
检查 SOLIDWORKS 的更新


安装位置

指定 SOLIDWORKS 安装位置。

对于除管理映像创建之外的安装，这些选项可适用：
将选定产品安装到 | 这是您要将 SOLIDWORKS 安装到的目录位置。 当升级或修改安装时，所有文件必须安装到该安装的现有位置。 在此情况下，您无法更改现有 SOLIDWORKS 安装的位置。
估计的安装所需空间 | 这是选定要安装或修改的产品所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持安装要求。
从此处安装 | 这是您安装 SOLIDWORKS 的源目录位置。 仅当指定了仅安装选项时，此选项才出现。 有关详细信息，请参阅下载选项。
在更改任何 SOLIDWORKS 安装位置之前请咨询系统管理员。

管理映像位置

当创建管理映像时，这些选项可适用：
新映像位置 | 这是 SOLIDWORKS 安装管理程序将创建新映像的目标目录位置。 | 此位置不能包含现有的管理映像。
创建映像所需的估计空间 | 这是管理映像所需的额外空间。 | 验证您的安装磁盘有足够的可用空间支持映像要求。
从此处创建映像 | 这是您安装 SOLIDWORKS 产品的源目录位置。 仅当指定了仅安装选项时，此选项才出现。 有关详细信息，请参阅下载选项。
现有映像位置 | 当升级现有的管理映像时，SOLIDWORKS 安装管理程序会基于该现有映像的设置创建新的映像。 不会修改现有映像。 这显示了您在 欢迎 屏幕中指定的原始映像的位置。

避免使用版本特定的目录路径

如果您在安装目录位置中指定了版本号（例如 C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2015\），然后将该安装升级到 SOLIDWORKS 2016，那么您的 SOLIDWORKS 2016 安装目录会标为 SOLIDWORKS 2015。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关参考
下载选项


升级选项

当前计算机上安装有一个或多个旧的 SOLIDWORKS 主要版本。 选择是将现有的最新版本升级为该新版本还是为该新版本创建一个新安装。

仅当此计算机上未安装此主要版本的先前版本时，此选项才会出现。 如果装有此主要版本的先前版本，SOLIDWORKS 安装管理程序一定会更新该安装。

（从 SOLIDWORKS 2010 开始，不再支持同时安装同一个主要版本的多个 Service Pack 版本。）

当升级时：
  • 会升级指定的所有产品。
  • 默认会选择已安装的所有产品。
  • 如果您取消选择某个产品，则不会升级该产品。
    如果您取消选择某个产品组件，并不表示您指定让 SOLIDWORKS 安装管理程序删除该组件。 要移除该产品组件，请使用添加/删除程序。 有关详细信息，请参阅移除安装。

选择合适的选项，然后单击下一步以继续。

生成 SOLIDWORKS 版本 的新安装。

选择此选项会保留旧的主要版本安装，并创建其新安装。

这在您安装了新的 SOLIDWORKS 版本后仍希望访问旧版本的情况下很有用。 例如，如果您要与仍使用旧版本的用户共享文件，则可避免采用新版本保存的文件出现版本不兼容的情况。

将 SOLIDWORKS 先前主要版本 升级到 SOLIDWORKS 当前主要版本。

选择此选项会将旧版本安装升级为新版本。
一旦安装完成，旧的 SOLIDWORKS 版本将不会存在于此计算机上。
父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关任务
删除安装


安装进度

该荧屏显示安装的进度。

若要在开始后取消安装，请单击取消。

有关取消的后果及完成中断的安装的说明，请参阅 安装错误。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


安装类型

指定您要运行的安装操作，例如创建新安装、修改或修复现有安装、创建管理映像、安装管理服务器产品或下载文件而不安装。

单机型

在该计算机上安装 SOLIDWORKS 产品。

仅当此计算机上当前未安装此版本时才出现此选项。

修改单机安装

修改此计算机上现有的 SOLIDWORKS 安装。

仅当此计算机上当前安装了此版本时才出现此选项。
修改包括：
  • 添加或删除 SOLIDWORKS 产品组件
  • 更改为其他 SOLIDWORKS 软件包（例如 SOLIDWORKS Professional、SOLIDWORKS Premium 等等）
  • 更改 SOLIDWORKS 序列号设定
    如果您已经在以前的安装中指定了 SOLIDWORKS 序列号，则 SOLIDWORKS 安装管理程序可能不会再显示该提示。 若要更改由 SOLIDWORKS 安装管理程序假定的序列号，则必须选择此选项。

修复单机安装

修复此计算机上现有的 SOLIDWORKS 安装。

仅当此计算机上当前安装了此版本时才出现此选项。
修复操作将核实是否所有文件都存在并已妥当注册，并且修复发现的任何问题。您所生成的数据不受影响。
  • 若要修复产品，请将其选定。
  • 清除您不想修复的产品的复选框。
您可修复单机安装。您无法修复管理映像安装；您必须使用管理映像重新安装。

管理映像

在该计算机上创建或更新管理映像。

您可使用管理映像在多台计算机上安装。 有关使用管理映像在多台客户端上安装 SOLIDWORKS 的详细信息，请参阅使用管理映像。

当创建或更新管理映像时：
  • 您可使用现有映像的安装设定来配置新的或更新后的映像，也可使用默认的 SOLIDWORKS 安装设定。
  • 如果是从现有映像更新：
    • 虽然是在更新，SOLIDWORKS 安装管理程序也会将该映像复制一份。 原始映像并未修改。
    • 您可使用正在更新的映像中的文件创建更新后的映像。这样可使下载内容较少。
    如果您不指定可供 Service Pack 发行版更新的先前版本的映像，则无法利用下载内容较少的便利。

服务器产品

SOLIDWORKS 管理服务器产品包括 SOLIDWORKS Electrical、SOLIDWORKS Workgroup PDM Server（库）、SOLIDWORKS PDM 和 SolidNetWork License Manager。

对于 SOLIDWORKS Electrical 和 SOLIDWORKS PDM，您可以选择在同一台计算机或不同计算机上安装客户端和服务器工具。

有关安装这些服务器的详细信息，请参阅帮助中的相应主题。

只下载

为选定的 SOLIDWORKS 产品下载安装文件而不安装产品。

如果从 DVD 安装，则不会出现该选项。

下载的文件的内容与 SOLIDWORKS 安装 DVD 上的文件内容相同。 选择此选项会下载整套安装文件，无论您的计算机上已安装有什么文件。

您可使用此方法设置服务器，您的用户可从该服务器进行安装。这与创建管理映像不同。

为该计算机安装错误的 SOLIDWORKS 体系结构

如果您在尝试为该计算机体系结构使用错误的 SOLIDWORKS 安装媒体进行安装（例如，如果您在尝试在 32 位计算机上装 64 位 SOLIDWORKS），此安装面板应表明该问题。

要继续进行安装：
  1. 取消此 SOLIDWORKS 安装管理程序进程。
  2. 为该计算机检查计算机体系结构和系统要求。
  3. 使用正确的 SOLIDWORKS 安装媒体为该计算机体系结构重新安装。
父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关概念
使用管理映像
SOLIDWORKS Workgroup PDM
使用 SolidNetWork 许可管理器管理许可
SOLIDWORKS Electrical


安装并管理多台计算机

SOLIDWORKS 安装管理程序提供以下工具用于安装并管理多台 SOLIDWORKS 计算机。

SOLIDWORKS 管理映像

如果要在多台计算机上安装 SOLIDWORKS，您可以创建管理映像，然后将应用程序调用到其他计算机上。

Workgroup PDM Server

Workgroup PDM 应用程序为项目数据管理软件，在 SOLIDWORKS 环境内部运行或作为独立应用程序在 SOLIDWORKS Explorer 中运行。 安装 Workgroup PDM Server 将创建一个 Workgroup PDM 库，此为储存被管理的 SOLIDWORKS 项目的数据库。

SOLIDWORKS 2017 推出后，SOLIDWORKS Workgroup PDM 将不再受支持。已经在使用 SOLIDWORKS Workgroup PDM 的客户仍可继续安装，但他们应开始计划将文件库迁移到 SOLIDWORKS PDM Server。

SOLIDWORKS PDM

SOLIDWORKS PDM 是基于与 SOLIDWORKS Enterprise PDM 相同的客户端/服务器体系结构的文档管理产品。 它有两个版本： Standard 和 Professional。 SOLIDWORKS PDM 使用 Microsoft SQL Server 数据库来管理文件库。

SolidNetWork 许可管理器

SolidNetWork 许可管理程序 (SNL) 可通过浮动许可使用而允许用户数量超过许可数量。 客户端许可在没有使用时可供另一 SOLIDWORKS 用户使用。

还可使用 SolidNetWork 许可管理程序来为 SOLIDWORKS 核心插件产品（例如 FeatureWorks）分发许可。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


手动下载

您已选择手动下载文件（或者可能在上次运行 SOLIDWORKS 安装管理程序时选择了手动下载）。

单机该链接以打开一个包含完成下载所需的文件的完整列表的自动生成的网页。

您必须下载到“摘要”页面中指定的文件夹。将所有文件下载到该文件夹后安装才能开始。

完成手动下载后，请单击下一步继续。

如果您要自动下载，可返回到“摘要”页面并更改下载选项。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


有新版本可用

安装管理程序检测到 SOLIDWORKS 产品的新版本。 您可选择安装包含在原有安装 DVD 或下载中的版本，或者您可选择下载并安装更新的版本。

如果您是从 DVD 进行安装

在您想使用更新版本吗？下，选项下列选项之一：
  • 不，继续从该 DVD 安装 版本。 您可在以后以较小下载进行更新。

    选取该选项可继续使用当前的安装管理程序进行安装。

    在安装完成后，您可使用安装管理程序检查并安装更新。 若要检查更新，请运行开始 > SOLIDWORKS 安装管理程序 > 检查更新。

    好处在于下载更小。缺点在于此为两步骤过程，而且您下载的文件为版本特定（不能被使用其它版本的其他用户所共享）。

  • 是，使用该 DVD 进行安装，然后下载并更新到 版本。

    选取该选项以下载并运行安装管理程序的以后版本，从而为该版本安装 SOLIDWORKS 产品。

    如果提供了可用于更新 DVD 版本的 Service Pack 发行版，则安装管理程序会首先从 DVD 安装原始版本，然后应用 Service Pack 更新。结果是下载内容较少。

    若选择继续从 DVD 安装的选项，日后再应用更新，也可获得相同的结果。

    此选项的好处在于一步到位。

在某些情况下，从 DVD 安装完整版本然后使用安装管理程序检查并安装更新为优先方法，因为这样所需下载更小。

如果您是从下载的文件进行安装

选择以下选项之一：
  • 继续安装版本。

    选取该选项继续安装包含在原有下载中的版本。

  • 下载并安装新版本：版本

    选取该选项以下载新版本并进行安装。如果有多个新版本可供使用，您可选取要下载并安装的版本。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


没有新版本可用

没有可下载的更新版本。开始安装指定的版本。

要开始安装，请单击下一步。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


检测到进程

SOLIDWORKS 安装管理程序在此计算机上检测到可能影响安装成功完成的进程。

  • 若要继续安装，请进行以下操作之一：
    • 关闭这些进程（例如使用 Microsoft Windows 任务管理器），然后按重试。
    • 单击忽略继续安装而不关闭该进程。
  • 若要停止安装，请按取消。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


产品选择

指定要安装、修改、下载或删除的产品组件。

在产品列表中：
  • 产品列表是在其上方指定的套包中的所有可用产品的完整列表。
  • 要查看对特定组件的预计操作，请单击该组件名称（而不是复选框）。 预期的安装操作会出现在产品列表下方的信息字段中。
  • 您可以单击产品组件旁的复选框更改该组件的安装操作。 （例如，如果您要安装或删除组件，可选中相应复选框指定要安装或删除的组件，或清除相应复选框指定不想安装或删除的组件。）
  • 如果要进行修改安装，则当您在产品选择中进行任何更改时，相应的组件左边会出现一个星号 (*)。
  • 如果一个组件内含有可选安装子组件，则该组件旁会出现一个 + 图标。 要查看一个组件的可用子组件，请单击 + 图标。
  • 如果扩展一个组件以显示可选子组件，则该组件旁会显示一个 - 图标。 要折叠子组件列表，请单击 - 图标。

如果您正在应用 Service Pack，则无法选择 SOLIDWORKS 下出现的功能（如 FeatureWorks）。 这是因为在进行此类升级时您不能添加或移除功能。

SOLIDWORKS 安装管理程序所进行的操作受一系列产品共存规则控制。 有关详细信息，请参阅产品共存规则。

SOLIDWORKS 安装管理程序默认选择这些产品组件：
  • 如果您正在执行升级或 Service Pack 更新，则 SOLIDWORKS 安装管理程序会选择当前已安装的产品。
  • 否则，SOLIDWORKS 安装管理程序会选择您有资格安装的所有产品。
要减少您的安装或下载时间和磁盘空间要求，展开产品组件，然后清除您不需要的那些组件的复选框。

如果 SOLIDWORKS 安装管理程序无法验证您有权使用的产品，则您可单击 选择不同软件包或产品 以更改要安装或修改的产品软件包（例如 SOLIDWORKS Professional 或 SOLIDWORKS Premium）清单。 SOLIDWORKS 安装管理程序将列出安装媒体上与您所选软件包兼容的所有 SOLIDWORKS 产品。 您可选择任何自己购买或有权评估的产品。

SOLIDWORKS 搜索

SOLIDWORKS 搜索提供对 SOLIDWORKS 文档、Workgroup PDM 库及 3D ContentCentral 的强大完整文本搜索功能。 搜索显示预览及文件位置和名称。

在安装完成后，SOLIDWORKS 搜索对 SOLIDWORKS 文档编制索引以便进行更快速搜索。 只有 SOLIDWORKS 文件才默认进行索引编制。

如果还未在您计算机上进行安装，安装 SOLIDWORKS 搜索会自动安装 Windows 桌面搜索。

语言支持

展开 SOLIDWORKS 产品以及 语言 组件可看到能够安装的语种。

语言 规格只限制为 SOLIDWORKS 产品所安装的语种。 其它产品安装不受该规范影响。 例如，eDrawings®、SOLIDWORKS Workgroup PDM、SOLIDWORKS Explorer 和 SOLIDWORKS PDM 将安装所有语种。

需要的空间

SOLIDWORKS 安装管理程序在页底报告出总安装大小或总下载大小。

  • 如果选择了仅下载选项，则下载大小会出现。 下载大小为所有下载文件所需的磁盘空间总量（不包括下载完成后解压文件所需的额外空间）。 该数字为估计值。
    安装所需的所有文件都包括在总下载大小中。 如果有些文件已下载到当前下载文件夹中，它们将不会再下载。 因此，您的实际下载大小可能比所示总下载大小要小，或者您可能不必下载任何文件。
  • 否则，安装大小会出现。 安装大小为在您完成此安装时会发生的磁盘空间使用变化。 由于压缩关系，这些数字为估计值。

    如果您在升级或移除现有安装，安装大小可能为零。

    所示数字不包括下载或提取安装所需要文件而要用的任何空间。

    如果要求下载且您在下载到同一个驱动器，实际磁盘空间要求可能比所出现的安装大小要大得多。

    要为将来修改减少下载或安装时间，不要在安装后删除下载的文件。 以后更新和修补通常要求访问上次完整安装文件集。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关概念
产品共存规则


要下载的产品

选取要下载到指定位置的 SOLIDWORKS 产品。

可下载的产品由您所提供的序列号决定：

  • 为每个组件所进行的操作出现在每项的右侧。
  • 如果一个组件内含有可选安装子组件，则该组件旁会出现一个 + 图标。 要查看一个组件的可用子组件，请单击 + 图标。
  • 如果扩展一个组件以显示可选子组件，则该组件旁会显示一个 - 图标。 要折叠子组件列表，请单击 - 图标。
  • 单击每个组件左边的复选框以选择它们如何被 SOLIDWORKS 安装管理程序处理。
SOLIDWORKS 安装管理程序将下载您有权使用的所有产品组件，除非您另有指定。 要减少您的下载时间和磁盘空间要求，请展开产品组件，并选择您不需要的那些组件。

如果 SOLIDWORKS 安装管理程序无法验证您有权使用的产品，则您可选择一个 SOLIDWORKS 软件包进行下载。 SOLIDWORKS 安装管理程序将列举与您所选软件包兼容的所有 SOLIDWORKS 产品。

如果 SOLIDWORKS 安装管理程序无法验证您有权使用的产品，则您可单击 选择不同软件包或产品 以更改要安装或修改的产品软件包（例如 SOLIDWORKS Professional 或 SOLIDWORKS Premium）清单。 SOLIDWORKS 安装管理程序将列出安装媒体上与您所选软件包兼容的所有 SOLIDWORKS 产品。 您可选择任何自己购买或有权评估的产品。

语言支持

语言规格只限制为 SOLIDWORKS 产品所安装的语种。 其它产品安装不受该规范影响。 例如，eDrawings®、SOLIDWORKS Workgroup PDM 和 SOLIDWORKS Explorer 将安装所有语种。

需要的空间

根据您所选取的产品，将显示出下载所需的空间。下载大小为所有下载文件所需的磁盘空间总量（不包括下载完成后解压文件所需的额外空间）。该数字为估计值。

要为将来更新和修补减少下载或安装时间，不要在安装后删除下载的文件。以后更新和修补通常要求访问上次完整安装文件集。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


要修复的产品

当您指定修复此安装时，该屏幕显示出可由此版本 SOLIDWORKS 安装管理程序修复的 SOLIDWORKS 产品（带有版本号）。

修复操作将核实是否所有文件都存在并已妥当注册，并且修复发现的任何问题。您所生成的数据不受影响。
  • 若要修复产品，请将其选定。
  • 清除您不想修复的产品的复选框。

单击修复以开始修复所选的产品。

您可修复单机安装。您无法修复管理映像安装；您必须使用管理映像重新安装。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


序列号

印在包装盒上的序列号将您的计算机与您已购买的 SOLIDWORKS 产品关联起来。

如果您的计算机上已安装有 SOLIDWORKS 产品，其序列号将默认显示。
  • 若未显示 SOLIDWORKS 序列号，则请输入。
  • 如果您拥有未包含在 SOLIDWORKS 许可中的产品序列号，请单击 您拥有其他序列号吗？ 下方的产品条目，然后输入该产品的序列号。

如果您拥有英特网连接，则继续安装过程时，您提供的序列号将确定您有权使用的产品。

由于有多种办法购买 SOLIDWORKS 产品，有些序列号可覆盖两个或多个产品。 例如，SOLIDWORKS 序列号可让您在安装 SOLIDWORKS Simulation 时不必输入单独的 SOLIDWORKS Simulation 序列号。 此外，有些产品不需要序列号。 如果您对序列号有疑问，请与您的经销商联系。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


服务器安装

会列出您正在尝试安装的服务器产品，并显示安装结果。

服务器安装状态

服务器产品安装由外部安装应用程序进行。如果您当前不在该应用程序中，请切换到该应用程序以完成安装。

单击取消以停止服务器产品安装。

服务器安装已完成

外部安装应用程序已成功完成。

单击 完成 或 下一步。
  • 如果您安装的是其他管理产品（例如 SOLIDWORKS 管理映像），该安装会继续。
  • 如果该服务器产品安装是唯一的安装操作，则 SOLIDWORKS 安装管理程序会关闭。

服务器安装被取消或失败

如果服务器产品安装在开始后失败或被取消，则会列出未安装的服务器。

单击 关闭 或 下一步。
  • 如果您指定了其他管理产品安装，则 SOLIDWORKS 安装管理程序会恢复。
  • 如果该服务器产品安装是唯一的安装操作，则 SOLIDWORKS 安装管理程序会关闭。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


SolidNetWork 许可管理器

指定 SolidNetWork 许可管理器服务器产品的安装选项。

序列号

指定 SolidNetWork 许可序列号。 您可通过以逗号分隔序列号，从而指定多个序列号。
SolidNetWork 序列号不同于 SOLIDWORKS 序列号。

安装位置

指定 SolidNetWork 许可管理器的安装位置。

如果您要更新现有的 SolidNetWork 许可管理器，则必须安装到现有的安装位置。

详情

有关安装、配置和使用 SolidNetWork 许可管理器的详细信息，请参阅使用 SolidNetWork 许可管理器管理许可。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关概念
使用 SolidNetWork 许可管理器管理许可


摘要

SOLIDWORKS 安装管理程序已获得了完成安装操作所需的所有信息。

若要继续： | 单击 操作立即按钮以启动安装操作，如立即安装、立即创建、立即下载或立即修改。
要更改安装设置： | 单击更改 [image] 以更改您要更改的部分（例如产品、安装位置和 Toolbox 选项）。
若要取消： | 单击 取消 以退出 SOLIDWORKS 安装管理程序而不更改安装组件。
若要返回先前的页面： | 单击 返回 以返回到 SOLIDWORKS 安装管理程序中的前一页。
关于特定安装选项集（例如 产品、安装位置、Toolbox 选项 等）的信息：
  1. 单击您要获取信息的部分旁边的更改 [image] 。
  2. 在出现的详细信息页面中，单击 帮助 以获取关于这些安装选项设置的信息。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


系统检查警告

系统检查报告了可能影响您继续安装的问题。 大多数情况下，您应该能够继续运行 SOLIDWORKS 安装管理程序。

下面列举了系统检查阶段您可能遇到的警告，并提供了如何继续操作的建议。

序列号验证性问题

安装管理程序因为无法验证您的序列号而不能检查新版本。 如果您已连网并且输入了有效序列号，此警告可能表示我们的服务器出现临时性问题。 请稍后再试。

序列号验证：安装管理程序无法验证您的序列号以决定您有权安装哪些产品。您仍将可以选择要安装的产品，但无法下载任何安装文件。您需要提供可从之进行安装的整套下载源文件或 DVD。

分辨率(R):
  • 检查英特网连接。序列号检查需要连接有效的英特网连接。
  • 检查您输入的序列号是否是要安装产品的有效序列号。
  • 有些安装要求您在版本发行时就进行了有效的订阅。 有关详细信息，请咨询您的 SOLIDWORKS 转售商。
  • 大多数情况下，只要您是从 DVD 或先前下载的组文件进行安装，就可以继续操作。

有新版本可用

有新版本可用

有新版本可用

该产品有新版本可供下载。

分辨率(R): 执行检查更新操作时，安装程序可能会提示您从 SOLIDWORKS 下载较新版本进行安装。 您可以使用最初指定的版本继续操作，或者下载此较新版本并使用该版本继续操作。

可用的最新版本

此为可供使用的最新版本。单击“下一步”以继续。

无新下载可用

解决方案：在安装或修改过程中检查更新时，可能会出现此信息。它表示您当前安装的（或已安装的）是最新的可用版本。

英特网连接问题

Internet 连接： 安装管理程序无法连接到 SOLIDWORKS 服务器以决定您有权安装哪些产品。 您仍将可以选择要安装的产品，但无法下载任何安装文件。 您需要提供 DVD 上的源文件或先前下载的组文件。

不能检查新版本

安装管理程序因为无法连接到服务器而不能够检查新版本。

解决方案:
  • 检查英特网连接。
  • 只要您是从 DVD 或先前下载的组文件进行安装，就可以继续操作。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


异型孔向导/Toolbox 选项

如果安装有 SOLIDWORKS Toolbox，SOLIDWORKS 将包含一个标准的孔类型与器件库。

关于配置、扩展和使用 SOLIDWORKS Toolbox 的详细信息，请在 SOLIDWORKS 中单击帮助 > Toolbox 帮助。
若要查看此帮助，可能必须通过工具 > 插件来启动 Toolbox 插件。

在使用 SOLIDWORKS Toolbox 之前，确保 Toolbox 已根据贵公司或组的政策而妥当配置。 在许多情况下，组会配置并维护一个中央 Toolbox。 请咨询 SOLIDWORKS 管理员，获取关于如何在 SOLIDWORKS 安装过程中指定 Toolbox 的指导。

您可在安装之后更改选定的 SOLIDWORKS Toolbox。 在 SOLIDWORKS 中，单击工具 > 选项。 在 系统选项 选项卡上单击孔向导/Toolbox。

下面的部分介绍了您在所有配置中可能在此屏幕上遇到的所有选项。 您实际看到的 Toolbox 选项取决于此计算机上已存在的 SOLIDWORKS 和 Toolbox 配置以及到此为止您已指定的 SOLIDWORKS 安装管理程序选项。

创建新的新版 Toolbox

在此计算机上创建新版 SOLIDWORKS Toolbox。

创建新版本后，在“产品选择”屏幕中，展开 SOLIDWORKS > SOLIDWORKS Toolbox，然后选择支持 Toolbox 的标准。 默认会选取所有标准。

不会修改此计算机上现有的任何 Toolbox。

参考引用或升级现有 Toolbox

使用现有 Toolbox。单击浏览以指定您要在此安装中使用的 Toolbox 的位置。

  • 如果已经为先前的 SOLIDWORKS 主要版本配置了该 Toolbox，则会将其升级为此版本。 对该 Toolbox 进行的任何自定义均会保留在升级后的 Toolbox 中。
    将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。
  • 如果该 Toolbox 被配置为用于此 SOLIDWORKS 版本（例如如果您指定了一个已升级的共享网络 Toolbox），则不会对该 Toolbox 进行升级。
  • 如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。 有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明：

此选项出现在除创建管理映像外的所有安装场景中。

升级先前版本的 Toolbox

将配置为用于先前主要版本的 Toolbox 复制到新位置，并将该拷贝升级为此版本。

如果此计算机上安装有先前的 SOLIDWORKS 主要版本且您选择不将该安装升级为此发行版，则会出现此选项。
此选项的用途在于在升级先前的 SOLIDWORKS 主要版本的 Toolbox 的同时，不影响使用该旧版 Toolbox 的用户。

如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。 有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明：

升级此安装的先前版本 Toolbox

将此 Toolbox 升级到新版本。
将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。

如果您正在将先前的 SOLIDWORKS 主要版本升级到此版本且在此计算机上发现了为该发行版配置的 Toolbox，则会出现此选项。

如果您在 SOLIDWORKS PDM 环境中升级 Toolbox，则需要执行其它程序。 有关详细信息，请参阅 关于配置 SOLIDWORKS Toolbox 的说明：

使用此安装的当前版本 Toolbox

SOLIDWORKS 安装管理程序在此计算机上检测到了为此 SOLIDWORKS 主要版本配置的 Toolbox。

如果您选择此选项，SOLIDWORKS 将使用此 Toolbox。 不会进行升级。

如果此计算机上安装了先前的 SOLIDWORKS 主要版本，但为此版本配置了 Toolbox，则会出现此选项。 如果在仍然运行较旧 SOLIDWORKS 版本的计算机上创建共享 Toolbox，则可能出现这种情况。

为客户端计算机指定 Toolbox 位置

将一个网络或目录位置指定为当客户端从管理映像安装时的默认 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

当您创建新的管理映像时，此选项会出现。

为客户端计算机升级或使用在现有映像中参考引用的 Toolbox

使用您正在更新的现有管理映像中指定的 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

为客户端计算机选取另一个 Toolbox 位置

指定一个不同于您正在更新的现有管理映像中所指定的 Toolbox 位置的其他 Toolbox 位置。
如果在开始客户端安装时，该位置包含为先前的 SOLIDWORKS 主要版本配置的 Toolbox，则 SOLIDWORKS 安装管理程序会升级该 Toolbox。

内容

  • 关于配置 SOLIDWORKS Toolbox 的说明

    SOLIDWORKS Toolbox 是一项强大而复杂的功能。 本主题总结了在使用 SOLIDWORKS 安装管理程序配置 Toolbox 之前需要考虑的概念。

  • UNC（通用命名代码）格式

    通用命名代码格式指定了描述共享文件位置的文件名称语法格式。

父主题
SOLIDWORKS 安装管理程序应用程序帮助
相关概念
关于配置 SOLIDWORKS Toolbox 的说明


关于配置 SOLIDWORKS Toolbox 的说明

SOLIDWORKS Toolbox 是一项强大而复杂的功能。 本主题总结了在使用 SOLIDWORKS 安装管理程序配置 Toolbox 之前需要考虑的概念。

查找关于 SOLIDWORKS Toolbox 的更多信息

有关配置、扩展和使用 SOLIDWORKS Toolbox 的详细信息，请在 SOLIDWORKS 中单击 帮助 > Toolbox 帮助。
要查看此帮助，可能必须通过工具 > 插件来启动 Toolbox 插件。

使用共享的 Toolbox

在安装 Toolbox 时，可在本地计算机或共享的网络位置存放 Toolbox 数据。 建议将 Toolbox 数据存储在网络位置。 通过使用公用位置，所有的 SOLIDWORKS 用户可以共享一致的扣件信息。

如果是首次安装 Toolbox，请浏览到要安装 Toolbox 的新共享位置。

升级现有 Toolbox

将 Toolbox 升级到新的 SOLIDWORKS 主要版本会使该 Toolbox 与运行 SOLIDWORKS 先前主要版本的计算机不兼容。

如果其它计算机保持在该主要版本且仍然需要为该发行版配置的 Toolbox，则您应将该 Toolbox 复制一份后再进行升级。 新的 SOLIDWORKS 安装将升级复制的那份 Toolbox，而先前的 SOLIDWORKS 安装则会继续使用旧的 Toolbox。

配置 Toolbox 访问设置

安装完毕后，访问 Toolbox 零部件时，SOLIDWORKS 将检查您是如何配置 Toolbox 的，并提供一些建议来提高访问速度和性能。

若要访问共享网络 Toolbox（建议），请使用指向该共享 Toolbox 所在的服务器的 UNC 路径。 有关详细信息，请参阅 UNC 格式。

管理员可以为 Toolbox 生成密码并为工作组设置权限和设定。限制对配置的访问和设置公用设定可以确保 Toolbox 数据的一致性。

在 SOLIDWORKS PDM 环境中升级 Toolbox

在您升级 SOLIDWORKS 软件时，如果已添加了零件，则会升级 Toolbox。 如果 Toolbox 根文件夹位于 SOLIDWORKS PDM 库中，则在开始升级 SOLIDWORKS 前，必须准备 Toolbox 文件夹。

在执行升级的第一个系统上，您必须使用获取最新版本下载 Toolbox 文件到本地缓存，然后检出 Toolbox 数据库文件。 在要升级的其它系统上，只需下载 Toolbox 文件即可。

在您升级之前：
  • 确保拥有数据库和存档的最新完整备份。
  • 确保 Toolbox 零件未检出或正用于任何已检出装配体中。

升级工具箱：

  1. 在 Windows 资源管理器中，使用拥有所有权限（检出、检入、添加和删除）的用户登录库。
  2. 右键单击 Toolbox 文件夹，然后单击获取最新版本将 Toolbox 文件和数据库复制到本地缓存中。
    如果您的存档服务器在远处，这需要几分钟的时间。
  3. 从\Toolbox_文件夹名\lang\您的语言检出 Toolbox 数据库文件 (SWBrowser.mdb)。
  4. 运行 SOLIDWORKS 安装管理程序以进行升级。
  5. 在摘要荧屏上确保 Toolbox 选项安装位置是库中的位置。

    如果不是，单击更改，选择参考引用或升级现有 Toolbox，然后浏览到库中的 Toolbox 位置。

  6. 当升级完成，在 Windows 资源管理器中，检入 Toolbox 文件夹以将任何新的或已更新的文件添加到库中，这样其它用户可操纵 Toolbox。
  7. 升级到 SOLIDWORKS 2012 或之后版本，导览至库 Toolbox 文件夹，确保包括下列文件：
    • \Toolbox_文件夹名\Updates
    • \Toolbox_文件夹名\ToolboxStandards.xml
    • \Toolbox_文件夹名\Browser\ToolboxFiles.index

      否则，联系您的增值经销商。

  8. 升级其余使用 SOLIDWORKS PDM 与 Toolbox 集成的计算机。
    1. 在 Windows 资源管理器中，使用至少拥有 Toolbox 文件夹读权限的用户登录到库。
    2. 右键单击 Toolbox 文件夹，然后单击获取最新版本将 Toolbox 零件复制到本地缓存中。
    3. 运行 SOLIDWORKS 安装管理程序以进行升级。

      安装程序检测到 Toolbox 已经完成升级。

有关在 SOLIDWORKS PDM 中的 Toolbox 配置的详细信息，请参阅 SOLIDWORKS PDM 管理工具帮助中的 SolidWorks Enterprise PDM 管理工具。

父主题
异型孔向导/Toolbox 选项
相关参考
UNC（通用命名代码）格式


UNC（通用命名代码）格式

通用命名代码格式指定了描述共享文件位置的文件名称语法格式。

\\服务器\卷\路径

例如：

\\Disk_Server\SOLIDWORKS\AdminImage

父主题
异型孔向导/Toolbox 选项
相关概念
关于配置 SOLIDWORKS Toolbox 的说明


卸载产品

当您从 控制面板 中选取删除或卸装程序时，该屏幕显示可由此版本 SOLIDWORKS 安装管理程序卸载的 SOLIDWORKS 产品（带有版本号）。 您可选择进行标准、自定义或完整卸装。

标准卸装移除 SOLIDWORKS 产品的程序文件和文件夹。 在默认情况下，所选发行版本的所有 SOLIDWORKS 产品都将被指定为标准卸载。

自定义卸载可移除一个或多个以下项： 程序文件和文件夹、注册表项和数据文件夹，如 SOLIDWORKS Toolbox 和原始下载位置的文件和文件夹。

完整卸装移除安装目录、注册表项和数据文件夹。

要卸装产品：
  1. 在卸装荧屏上确定产品已选定。

    如果您卸载所有产品，Solidworks 安装管理程序也会被卸载。

  2. 消除您不想移除的产品。

    如果您保留任何产品，SOLIDWORKS 安装管理程序不会移除。

  3. 选择是否进行自定义或完整卸装。
    1. 在高级选项中单击更改。

      高级选项屏幕出现。程序文件和文件夹选项被复选。

    2. 选取一个或多个选项进行自定义卸载，或者选取所有选项进行完整卸载。
    3. 单击返回到摘要。
    4. 在摘要荧屏上扩展高级选项显示卸装方法和条目。
  4. 单击移除项目。
当您单击移除项目后，SOLIDWORKS 安装管理程序会立即开始移除产品。
父主题
SOLIDWORKS 安装管理程序应用程序帮助


Workgroup PDM 服务器选项

指定 SOLIDWORKS Workgroup PDM 服务器产品的安装选项。

安装位置

指定 Workgroup PDM 服务器产品的安装位置。

要安装的产品

指定要安装的 Workgroup PDM 服务器产品：
Workgroup PDM 库 | 指定 Workgroup PDM 库数据的位置。Workgroup PDM 浏览器许可必须随库一起安装才能启用浏览器。
Workgroup PDM 浏览器 | 当安装 Workgroup PDM 浏览器时，必须指定浏览器要访问的 Workgroup PDM 库计算机的名称或 IP 地址。

Workgroup PDM API

SOLIDWORKS 客户端和 Explorer 客户端许可附带有 Workgroup PDM API 许可。 检入 API 要求有客户端许可。

详情

关于安装 Workgroup PDM 的详细信息，请参阅SOLIDWORKS Workgroup PDM。

有关使用 Workgroup PDM 的详细信息，请参阅 SOLIDWORKS 帮助中的 SolidWorks 帮助。

父主题
SOLIDWORKS 安装管理程序应用程序帮助


法律通告

© 1995-2015, Dassault Systemes SolidWorks Corporation 属于 Dassault Systèmes SE 公司，该公司位于 175 Wyman Street, Waltham, Mass. 02451 USA。 保留所有权利。

本文档中提及的信息和软件如有更改，恕不另行通知，Dassault Systèmes SolidWorks Corporation (DS SolidWorks) 对此概不负责。

未经 DS SolidWorks 明确书面许可，不得以任何形式或通过任何手段（电子或手工方式）以及出于任何目的翻印或传播任何相关资料。

本文档中提及的软件受许可证协议限制，只能根据本许可证协议的条款使用或拷贝。DS SolidWorks 对该软件和文档提供的所有保证均在许可协议中阐明，此文档及其内容中提及或暗示的任何内容，均不会视为许可协议中任何条款（包括保证）的修改和补充。

专利通告

SOLIDWORKS® 3D 机械 CAD 软件受美国专利 5,815,154、6,219,049、6,219,055、6,611,725、6,844,877、6,898,560、6,906,712、7,079,990、7,477,262、7,558,705、7,571,079、7,590,497、7,643,027、7,672,822、7,688,318、7,694,238、7,853,940、8,305,376、8,581,902、8,817,028、8,910,078 以及外国专利（例如 EP 1,116,190 B1 和 JP 3,517,643）保护。

eDrawings® 软件受美国专利 7,184,044、美国专利 7,502,027、以及加拿大专利 2,318,706 保护。

还有正在申请中的美国和外国专利。

SOLIDWORKS 产品和服务的商标和产品名称

SOLIDWORKS、3D ContentCentral、3D PartStream.NET、eDrawings 和 eDrawings 徽标是注册商标，FeatureManager 是 DS SolidWorks 的合营注册商标。

CircuitWorks、FloXpress、PhotoView 360 及 TolAnalyst 是 DS SolidWorks 的商标。

FeatureWorks 是 Geometric Ltd 的注册商标。

SOLIDWORKS 2016、SOLIDWORKS Standard、SOLIDWORKS Professional、SOLIDWORKS Premium、SOLIDWORKS PDM Professional、SOLIDWORKS PDM Standard、SOLIDWORKS Workgroup PDM、SOLIDWORKS Simulation、SOLIDWORKS Flow Simulation、eDrawings、eDrawings Professional、SOLIDWORKS Sustainability、SOLIDWORKS Plastics、SOLIDWORKS Electrical、SOLIDWORKS Composer 和 SOLIDWORKS MBD 是 DS SolidWorks 的产品名称。

其它商标或产品名称分别是其所有者的商标或注册商标。

商用计算机软件 - 所有权

本软件是一种“商业项目”，该名词定义见 48 C.F.R. 2.101（1995 年 10 月），包含“商业电脑软件”和“商业软件文档”，这些术语用于 48 C.F.R. 12.212（1995 年 9 月），提供给美国政府，用于由民用机构购买或代表民用机构购买，与 48 C.F.R. 12.212 中规定的政策一致；或 (b) 由国防部机构购买或代表国防部机构购买，与 48 C.F.R. 227.7202-1（1995 年 6 月）和 227.7202-4（1995 年 6 月）中规定的政策一致。

如果您收到美国政府任何机构的请求，要求提供超出以上所述权利的软件，您可通知 DS SolidWorks 有关请求的范围，DS SolidWorks 将在五 (5) 个工作日内酌情考虑接受或不接受此请求。 合同方/制作商： Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

SOLIDWORKS Standard、Premium、Professional 和 Education 产品的版权通告

本软件一部分归 © 1986-2015 Siemens Product Lifecycle Management Software Inc. 所有。保留所有权利。

本指南中涉及 Siemens Industry Software Limited 拥有的以下软件：

D-Cubed™ 2D DCM © 2015。Siemens Industry Software Limited。 保留所有权利。

D-Cubed™ 3D DCM © 2015。Siemens Industry Software Limited。 保留所有权利。

D-Cubed™PGM © 2015。Siemens Industry Software Limited。 保留所有权利。

D-Cubed™CDM © 2015。Siemens Industry Software Limited。 保留所有权利。

D-Cubed™AEM © 2015。Siemens Industry Software Limited。 保留所有权利。

本软件一部分归 © 1998-2015 Geometric Ltd. 所有。

该软件一部分并入了 NVIDIA 的 PhysX™, 2006-2010。

本软件一部分归 © 2001-2015 Luxology, LLC 所有。 保留所有权利，专利待定。

本软件一部分归 © 2007-2015 DriveWorks Ltd. 所有。

版权所有 1984-2010 Adobe Systems Inc. 及其许可方。 保留所有权利。 受美国专利 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382 和申请中的专利保护。

Adobe、Adobe 徽标、Acrobat、Adobe PDF 徽标、Distiller 及 Reader 是 Adobe Systems Inc. 在美国或其它国家中的注册商标或商标。

有关 DS SolidWorks 详细的版权信息，请参阅帮助 > 关于 SOLIDWORKS。

SOLIDWORKS Simulation 产品的版权通告

本软件一部份归 © 2008 Solversoft Corporation。

PCGLSS © 1992-2014 Computational Applications and System Integration, Inc。保留所有权利。

SOLIDWORKS Standard 产品的版权通告

© 2011, Microsoft Corporation。 保留所有权利。

SOLIDWORKS PDM Professional 产品的版权通告

Outside In® Viewer Technology，© 1992-2012 Oracle

© 2011, Microsoft Corporation。 保留所有权利。

eDrawings 产品的版权通告

本软件一部分归 © 2000-2014 Tech Soft 3D 所有。

本软件一部分归 © 1995-1998 Jean-Loup Gailly and Mark Adler 所有。

本软件一部分属 © 1998-2001 3Dconnexion。

本软件一部分归 © 1998-2014 Open Design Alliance 所有。 保留所有权利。

本软件一部分属 © 1995-2012 Spatial Corporation。

eDrawings® for Windows® 软件部分基于 Independent JPEG Group 的创作。

eDrawings® for iPad® 一部分版权 © 1996-1999 Silicon Graphics Systems, Inc.

eDrawings® for iPad® 一部分版权 © 2003 – 2005 Apple Computer Inc.


管理映像选项编辑器

SOLIDWORKS 管理映像选项编辑器有所增强。

  • 管理员可使用新的卸装选项在客户端计算机上执行完整或自定义卸装。选项编辑器的客户端安装选项部分中提供有卸载选项。要查看选项，单击是，执行自定义卸装，然后选取要移除的项目。
  • 管理员也可从列表中预选 SOLIDWORKS Toolbox 标准。